File 36f57ad-advertise-migv3.patch of Package libvirt

commit 36f57ad7d792f9a1342d48c9977ca9f5af647d1d
Author: Jim Fehlig <jfehlig@suse.com>
Date:   Mon Aug 29 10:08:01 2016 -0600

    libxl: advertise support for migration V3
    
    The libxl driver has long supported migration V3 but has never
    indicated so in the connectSupportsFeature API. As a result, apps
    such as virt-manager that use the more generic virDomainMigrate API
    fail with
    
    libvirtError: this function is not supported by the connection driver:
    virDomainMigrate
    
    Add VIR_DRV_FEATURE_MIGRATION_V3 to the list of features marked as
    supported in the connectSupportsFeature API.

Index: libvirt-2.0.0/src/libxl/libxl_driver.c
===================================================================
--- libvirt-2.0.0.orig/src/libxl/libxl_driver.c
+++ libvirt-2.0.0/src/libxl/libxl_driver.c
@@ -5247,6 +5247,7 @@ libxlConnectSupportsFeature(virConnectPt
         return -1;
 
     switch (feature) {
+    case VIR_DRV_FEATURE_MIGRATION_V3:
     case VIR_DRV_FEATURE_TYPED_PARAM_STRING:
     case VIR_DRV_FEATURE_MIGRATION_PARAMS:
     case VIR_DRV_FEATURE_MIGRATION_P2P: