File libqt5-qtwebengine.changes of Package libqt5-qtwebengine

-------------------------------------------------------------------
Mon Oct  2 19:27:04 UTC 2017 - t.zell@gmx.de

- Fixes to make fonts readable again with FreeType 2.8.1:
  * clip-ft-glyph.diff
  * harmony-fix.diff

-------------------------------------------------------------------
Tue Sep 26 15:03:00 UTC 2017 - fabian@ritter-vogt.de

- Unbundle ffmpeg if possible, only support proprietary codecs
  if the system ffmpeg does

-------------------------------------------------------------------
Mon Jul 10 09:56:30 UTC 2017 - mlin@suse.com

- Raise memory size to 9G and drop overwrite part of s390z build,
  we didn't have build s390x at all. (bsc#1047896)
- Make it -j4 for all archtectures: do not run too many parallel that
  would costs more memory.

-------------------------------------------------------------------
Sat Jul  1 08:03:22 UTC 2017 - lbeltrame@kde.org

- Update to 5.9.1
  * For more details please see:
    http://blog.qt.io/blog/2017/06/30/qt-5-9-1-released/
- Drop upstreamed patches:
  * arm64-linux.patch
  * arm64-toolchain.patch

-------------------------------------------------------------------
Tue Jun 13 11:26:59 UTC 2017 - fvogt@suse.com

- Backport patches to fix build on AArch64 and add workaround
  (QTBUG-61128):
  * arm64-linux.patch
  * arm64-toolchain.patch
- Use proprietary codecs if supported by system ffmpeg (boo#1043375)

-------------------------------------------------------------------
Thu Jun  1 07:58:09 UTC 2017 - fabian@ritter-vogt.de

- Remove patch that is apparently not enough for aarch64:
  * gn-add-aarch64.patch

-------------------------------------------------------------------
Thu Jun  1 07:49:42 UTC 2017 - jengelh@inai.de

- Update descriptions.
- Use find -exec's "+" strategy.

-------------------------------------------------------------------
Wed May 31 07:05:31 UTC 2017 - fabian@ritter-vogt.de

- Update to 5.9.0 final

-------------------------------------------------------------------
Tue May 30 14:32:33 UTC 2017 - fabian@ritter-vogt.de

- Disable usage of system ICU on TW as ICU 59 is not supported
  and patches do not apply

-------------------------------------------------------------------
Wed May 24 19:16:41 UTC 2017 - fabian@ritter-vogt.de

- Update to 5.9.0 RC:
  * For more details please see: 
    http://lists.qt-project.org/pipermail/announce/2017-May/000115.html
    and https://wiki.qt.io/New_Features_in_Qt_5.9
- Remove patches, now upstream:
  * fix-chromium-gcc7.patch
  * use-fno-delete-null-pointer-checks-with-gcc-6.diff
  * webrtc-build-with-neon.patch
- Refresh patches:
  * armv6-ffmpeg-no-thumb.patch
  * disable-gpu-when-using-nouveau-boo-1005323.diff
- Support new build system, which does not support manual unbundling
  anymore
- Add patch to allow building on aarch64:
  * gn-add-aarch64.patch
- Reorder rpm sections

-------------------------------------------------------------------
Mon May 15 14:07:24 UTC 2017 - fabian@ritter-vogt.de

- Add patch to fix build with gcc 7:
  * fix-chromium-gcc7.patch

-------------------------------------------------------------------
Wed Dec 14 16:06:02 UTC 2016 - hrvoje.senjan@gmail.com

- Update to 5.7.1
  * For more details please see:
    https://blog.qt.io/blog/2016/12/14/qt-5-7-1-released/
    and https://www.qt.io/qt5-7/
- Drop upstreamed patches:
  Do-not-depend-on-Linux-4.5.patch and
  detect-gcc6-use-fno-delete-null-pointer-checks.diff

-------------------------------------------------------------------
Thu Nov  3 10:47:39 UTC 2016 - wbauer@tmo.at

- Add -fno-delete-null-pointer-checks to CXXFLAGS instead to
  really fix the gcc6 issues (boo#1003985)

-------------------------------------------------------------------
Tue Oct 25 13:40:49 UTC 2016 - alarrosa@suse.com

- Add disable-gpu-when-using-nouveau-boo-1005323.diff. Disables the
  use of the gpu by webengine when the nouveau opengl driver is
  detected since nouveau doesn't support rendering from different
  threads. Also, allows to use two environment variables
  QT_WEBENGINE_DISABLE_GPU to force the disabling of the gpu and
  QT_WEBENGINE_DISABLE_NOUVEAU_WORKAROUND to disable the detection
  of nouveau, just in case someone wants to try with newer nouveau
  releases (boo#1005323, boo#997171).

-------------------------------------------------------------------
Thu Oct  6 09:26:52 UTC 2016 - hrvoje.senjan@gmail.com

- Pass the -fno-delete-null-pointer-checks flag to avoid further
  gcc6 issues

-------------------------------------------------------------------
Wed Oct  5 09:54:47 UTC 2016 - hrvoje.senjan@gmail.com

- Added Do-not-depend-on-Linux-4.5.patch (boo#1002873)

-------------------------------------------------------------------
Wed Sep 28 07:32:47 UTC 2016 - schwab@suse.de

- Ensure to build for armv6 on armv6
- armv6-ffmpeg-no-thumb.patch: Fix ffmpeg configuration for armv6
- webrtc-build-with-neon.patch: Properly configure webrtc for neon support

-------------------------------------------------------------------
Sat Sep 24 18:39:10 UTC 2016 - hrvoje.senjan@gmail.com

- Update to 5.7.0
  * For more details please see:
    https://www.qt.io/qt5-7/
- Add detect-gcc6-use-fno-delete-null-pointer-checks.diff

-------------------------------------------------------------------
Thu Jun 23 08:10:46 UTC 2016 - lbeltrame@kde.org

- Add use-fno-delete-null-pointer-checks-with-gcc-6.diff: fix
  crashes with GCC 6 (https://codereview.qt-project.org/#/c/161965/)

-------------------------------------------------------------------
Wed Jun  8 14:15:23 UTC 2016 - hrvoje.senjan@gmail.com

- Update to 5.6.1
  * For more details please see:
    http://blog.qt.io/blog/2016/06/08/qt-5-6-1-released/
- Drop obsolete gcc50-fixes.diff

-------------------------------------------------------------------
Fri Mar 18 19:03:33 UTC 2016 - hrvoje.senjan@gmail.com

- Update to 5.6.0
  * For more details please see:
    http://blog.qt.io/blog/2016/03/16/qt-5-6-released/
    and https://wiki.qt.io/New_Features_in_Qt_5.6
- Drop upstreamed and/or obsolete patches:
  gyp-arm64.patch, gyp_conf.patch, sandbox-linux-arm64.patch and
  strip.diff

-------------------------------------------------------------------
Thu Dec  3 07:24:43 UTC 2015 - mlin@suse.com

- Do not build on s390 and s390x, chromium have not ported to them 

-------------------------------------------------------------------
Fri Oct 16 20:22:42 UTC 2015 - hrvoje.senjan@gmail.com

- Update to 5.5.1
  * For more details please see:
    http://blog.qt.io/blog/2015/10/15/qt-5-5-1-released/

-------------------------------------------------------------------
Wed Sep 30 08:10:19 UTC 2015 - schwab@suse.de

- gyp-arm64.patch: Update ffmpeg config
- sandbox-linux-arm64.patch: fix chromium build for aarch64

-------------------------------------------------------------------
Sun Aug 16 08:32:10 UTC 2015 - hrvoje.senjan@gmail.com

- Update to 5.5.0
  * For more details please see:
    http://blog.qt.io/blog/2015/07/01/qt-5-5-released/
    and https://wiki.qt.io/New_Features_in_Qt_5.5
- Enable jsoncpp support on Leap

-------------------------------------------------------------------
Fri Aug 14 13:33:36 UTC 2015 - normand@linux.vnet.ibm.com

- ExcludeArch:    ppc ppc64 ppc64le
  http://www.chromium.org/blink not ported to PowerPC

-------------------------------------------------------------------
Mon Jun 29 15:23:43 UTC 2015 - schwab@suse.de

- gyp-arm64.patch: fix support for aarch64
- gcc50-fixes.diff: also handle gcc < 5

-------------------------------------------------------------------
Mon Jun 22 11:56:10 UTC 2015 - tittiatcoke@gmail.com

- Add patch gcc50-fixes.diff to fix the detection of the GCC 5.x 
  compiler. Patch is equal to the one used for Chromium

-------------------------------------------------------------------
Wed Jun  3 22:56:36 UTC 2015 - hrvoje.senjan@gmail.com

- Update to 5.4.2
  * Bugfix release, for more details please see:
    http://blog.qt.io/blog/2015/06/02/qt-5-4-2-released/
- Use correct names in baselibs.conf

-------------------------------------------------------------------
Wed May 27 10:24:39 UTC 2015 - aj@ajaissle.de

- Fix summary, this is not an Qt 5 Nfc Addon

-------------------------------------------------------------------
Tue Feb 24 16:10:33 UTC 2015 - hrvoje.senjan@gmail.com

- Update to 5.4.1
  * For more details please see:
    http://blog.qt.io/blog/2015/02/24/qt-5-4-1-released/
- Add minimal requires on other Qt5 libraries

-------------------------------------------------------------------
Wed Dec 10 11:00:14 UTC 2014 - hrvoje.senjan@gmail.com

- Update to 5.4 Final
  * For more details please see:
    http://blog.qt.digia.com/blog/2014/12/10/qt-5-4-released/
    and http://qt-project.org/wiki/New-Features-in-Qt-5.4

-------------------------------------------------------------------
Thu Nov 27 15:58:50 UTC 2014 - hrvoje.senjan@gmail.com

- Update to 5.4 RC
  * For more details please see:
    http://blog.qt.digia.com/blog/2014/11/27/qt-5-4-release-candidate-available/
    and http://qt-project.org/wiki/New-Features-in-Qt-5.4

-------------------------------------------------------------------
Sat Aug  2 15:31:16 UTC 2014 - hrvoje.senjan@gmail.com

- Activate libqt5-qtwebengine package