A new user interface for you! Read more...

File python-pbr.changes of Package python-pbr

-------------------------------------------------------------------
Thu Jan 17 15:56:29 UTC 2019 - Dominique Leuenberger <dimstar@opensuse.org>

- BuildIgnore python[23]-pyparsing: python-packaging requires it
  for some actions it could perform, but we don't make use of these
  here. Ignoring this dependency allows us to break open a
  BuildCycle.

-------------------------------------------------------------------
Tue Dec 11 17:00:20 UTC 2018 - Matěj Cepl <mcepl@suse.com>

- Actually, although the package is noarch, its test suite is not, so we
  need python-devel at least for tests.

-------------------------------------------------------------------
Tue Dec  4 12:51:21 UTC 2018 - Matej Cepl <mcepl@suse.com>

- Remove superfluous devel dependency for noarch package

-------------------------------------------------------------------
Wed Nov  7 11:22:59 UTC 2018 - mmnelemane@suse.com

- Fix for error "invalid option --#" in SLE_12_SP4 build. 

-------------------------------------------------------------------
Mon Oct 15 13:23:36 UTC 2018 - Matej Cepl <mcepl@suse.com>

- Update to 4.3.0:
    * Remove my\_ip from generated wsgi script
    * Fix typo in contribution instructions
    * Add release note for fix to bug 1786306
    * Move pbr-installation jobs in-tree
    * Support subdirectory in the url
    * remove pypy jobs
    * add lib-forward-testing-python3 test job
    * add python 3.6 unit test job
    * switch documentation job to new PTI
    * import zuul job settings from project-config
    * Ignore Zuul when generating AUTHORS
    * tox: Re-add cover target
- Add new_wheel.patch to make compatible with wheel = 0.32.1

-------------------------------------------------------------------
Sun Oct  7 08:43:14 CEST 2018 - mcepl@suse.com

- Revert previous commit.

-------------------------------------------------------------------
Sun Oct  7 06:34:26 UTC 2018 - Matěj Cepl <mcepl@suse.com>

- Partially switch off tests requiring testscenarios and stestr.

-------------------------------------------------------------------
Fri Sep 14 21:18:14 UTC 2018 - dmueller@suse.com

- add 0001-Skip-test-for-testr-hook-being-installed-when-testr-.patch 

-------------------------------------------------------------------
Tue Sep  4 08:47:32 UTC 2018 - dmueller@suse.com

- update to 4.2.0:
  * Deprecate 'test' integration
  * Deprecate 'build\_sphinx' integration
  * Add Sphinx extension
  * doc: Add documentation for missing '[pbr]' options
  * doc: Fix formatting of packagers guide
  * Switch to stestr

-------------------------------------------------------------------
Mon Aug 27 15:24:52 UTC 2018 - tchvatal@suse.com

- Move the Name declaration above BR with LUA expansion as it won't
  get expanded in time for older codestreams otherwise and result
  in issue like "Package does not exist: %files -n python-%name"

-------------------------------------------------------------------
Wed Aug 15 12:38:40 UTC 2018 - mcepl@suse.com

- Fix conditions when to enanle tests and when not.

-------------------------------------------------------------------
Mon Aug  6 10:03:48 UTC 2018 - tchvatal@suse.com

- Switch to multibuild to run tests
- Drop doc subpkg, they have compiled docu on web, much better
  * Drops patch for_sphinx.patch

-------------------------------------------------------------------
Mon Aug  6 09:37:30 UTC 2018 - tchvatal@suse.com

- Version update to 4.1.1:
  * Fixes on python 3.x

-------------------------------------------------------------------
Fri May 25 09:48:46 UTC 2018 - mimi.vx@gmail.com

- for_sphinx.patch - allow warnings for sphinx_build
  unfortuanetly python3 and python2 Sphinx have diff in docstring parsing

-------------------------------------------------------------------
Wed May 23 02:48:49 UTC 2018 - arun@gmx.de

- update to version 4.0.3:
  * Don't poke in pip for requests
  * Fix builddoc with sphinx <= 1.6

-------------------------------------------------------------------
Mon Apr 23 15:14:47 UTC 2018 - arun@gmx.de

- update to version 4.0.2:
  * Better Sem-Ver header handling

- changes from version 4.0.1:
  * add lower-constraints job
  * Explicitly read setup.cfg as utf-8 on Python 3

-------------------------------------------------------------------
Wed Mar 28 04:42:26 UTC 2018 - tbechtold@suse.com

- update to 4.0.0:
  * builddoc: Treat '[pbr] autodoc\_tree\_excludes' as a multi-line opt
  * update parse test to use reliable comparison
  * Make docs on env vars a little clearer
  * Updated from global requirements
  * future-proof invocation of apidoc
  * emit warning correctly
  * deprecations: Deprecate support for '-py{N}' requirements
  * doc: Minor rework of usage doc
  * doc: Rework features doc
  * Support v<semver> version
  * Deprecate testr and nose integration
  * tests: Increase coverage of requirements parsing
  * trivial: Move packaging tests to test\_packaging
  * Put test-requirements into an extra named 'test'
  * Support Description-Content-Type metadata
  * Avoid tox\_install.sh for constraints support
  * Test on Python 3.6
  * Support PEP 345 Project-URL metadata
  * Remove setting of version/release from releasenotes
  * Use 'build\_reno' setuptools extension if available
  * Remove unnecessary 'if True'
  * Discover Distribution through the class hierarchy
  * Add reno for release notes management
  * Remove support for command hooks
  * Remove dead code
  * Deprecate support for Sphinx < 1.6
  * builddoc: Use '[sphinx\_build] builders' with Sphinx < 1.6
  * Remove win32/nt checks for wrapper script gen
  * Remove py26 support
  * Update URLs in documents according to document migration
  * gitignore: Ignore .venv
  * switch from oslosphinx to openstackdocstheme
  * Trivial: Fix docstring
  * turn on warning-as-error flag for doc build
  * rearrange existing documentation using the new standard layout

-------------------------------------------------------------------
Mon Oct 30 16:09:24 UTC 2017 - jmatejek@suse.com

- use %python_clone instead of manual copying
- drop shebang and executable from the included test setup.py
  instead of complicated post-install fixing

-------------------------------------------------------------------
Tue Aug  8 06:04:36 UTC 2017 - tbechtold@suse.com

- remove unused BuildRequires on python-pip
- add python-setuptools as BuildRequires

-------------------------------------------------------------------
Mon Jul 10 18:42:12 UTC 2017 - toddrme2178@gmail.com

- Fix wrong-script-interpreter rpmlint error.

-------------------------------------------------------------------
Thu Jun 29 16:16:36 UTC 2017 - tbechtold@suse.com

- update to 3.1.1:
  * Restore previous IP binding
  * allow user to override the output location of api docs
  * fix tests based on API change in Sphinx
  * Updated from global requirements
  * Add binding option for WSGI server
  * Ignore index URL lines in requirements.txt files

-------------------------------------------------------------------
Thu May 18 11:36:19 UTC 2017 - dmueller@suse.com

- Update to pbr-3.0.1:
  * builddoc: uses the new Sphinx 1.6 code for multiple builder
  * Updated from global requirements
  * Fix missing comment from previous change
  * trivial: Add note about multiple builders support
  * Remove 'build\_sphinx\_latex'
  * Stop building man pages by default
  * docs: Use definition lists
  * add image.nonlocal\_uri to the list of warnings ignored
  * doc: Document Sphinx integration
  * add changelog to published documentation
  * Lazy import pkg\_resources
  * Add Changelog build handling for invalid chars
  * Initialize sphinx config using application instead of config
  * Make oslosphinx optional
  * Updated from global requirements
  * Also generate XML coverage report
  * Update to a newer hacking library
- drop 0001-Initialize-sphinx-config-using-application-instead-o.patch
  Upstream

-------------------------------------------------------------------
Mon Apr  3 05:05:43 UTC 2017 - tbechtold@suse.com

- Add 0001-Initialize-sphinx-config-using-application-instead-o.patch

-------------------------------------------------------------------
Wed Mar 29 13:53:04 UTC 2017 - jmatejek@suse.com

- uninstall alternatives in %postun

-------------------------------------------------------------------
Wed Mar 29 11:59:27 UTC 2017 - tbechtold@suse.com

- Fix Source url

-------------------------------------------------------------------
Wed Mar  8 10:30:49 UTC 2017 - aplanas@suse.com

- Update to pbr-2.0.0
  * tox: Don't set skipsdist=True
  * Stop using 'warnerrors'
  * doc: Clarify sections in 'setup.cfg'
  * Updated from global requirements
  * Remove discover from test-requirements
  * Add Constraints support
  * Don't raise exception on missing man pages
  * Updated from global requirements
  * Clean imports in code
  * Updated from global requirements
  * Docstrings should not start with a space
  * Changed the home-page link
  * Update .coveragerc after the removal of openstack directory
  * coverage package name option, doc improvement
  * Updated from global requirements
  * Deprecated warning for SafeConfigParser
  * Add more words to a confusing error message
  * Don't ignore data-files
  * Change assertTrue(isinstance()) by optimal assert
  * Fix handling of old git log output
  * Fix typo in the index.rst
  * Expose deb version to match exposing rpm version
  * Replace OpenStack LLC with OpenStack Foundation
  * Updated from global requirements
  * Fix pypy soabi tests
  * Add Python 3.5 classifier and venv
  * Fix argument order for assertEqual to (expected, observed)
  * Move to oslosphinx
  * Updated from global requirements
  * Restore warnerrors behavior and support Sphinx 1.4
  * Updated from global requirements
  * Updated from global requirements
  * Updated from global requirements
  * Fix pypy wsgi tests
  * Remember the insertion order for pbr.json
- Remove 0001-Don-t-ignore-data-files.patch (included)
- Remove 0001-Don-t-raise-exception-on-missing-man-pages.patch (included)

-------------------------------------------------------------------
Mon Feb 27 13:11:37 UTC 2017 - jmatejek@suse.com

- use hardlinks instead of symlinks for %fdupes, because
  symlinks would point across subpackages

-------------------------------------------------------------------
Tue Feb 21 14:11:09 UTC 2017 - jmatejek@suse.com

- update for singlespec

-------------------------------------------------------------------
Mon Feb 20 22:03:16 UTC 2017 - dmueller@suse.com

- add 0001-Don-t-raise-exception-on-missing-man-pages.patch,
  0001-Don-t-ignore-data-files.patch

-------------------------------------------------------------------
Tue Sep 27 18:32:25 UTC 2016 - tbechtold@suse.com

- Add missing python-setuptools Requires.

-------------------------------------------------------------------
Tue Sep 27 09:46:15 UTC 2016 - tbechtold@suse.com

- Remove unneeded Requires for python-pip. It's only used
  for testing.

-------------------------------------------------------------------
Tue May 24 05:15:09 UTC 2016 - tbechtold@suse.com

- Fix pypi source

-------------------------------------------------------------------
Tue May 24 04:46:16 UTC 2016 - tbechtold@suse.com

- update to 1.10.0:
  * File is wrongly marked as executable
  * Fix wsgiref script use with oslo.config
  * Update Preversioning explanation to avoid double that
  * Handle IndexError during version string parsing
  * Correct server test
  * Updated from global requirements
  * Fix soabi tests with pypy
  * package: fix wrong catch in email parsing
  * Do not convert git tags when searching history
  * Include wsgi_scripts in generated wheels
  * Correct the indentation in the classifiers example
  * Do not silently drop markers that fail to evaluate
  * Clarifications around tags and version numbers
  * Correct typo - s/enabeld/enabled/
  * Use apt-cache generated packages to provide build deps
  * fix some variable names
  * Don't attempt to test with 0.6c11 with Py3
  * Support entry point patching on setuptools < 12
  * Updated from global requirements
  * Split changelog on nulls instead of (
  * Add libjpeg and liberasurecode for tests
  * Handle markers to support sdist on pip < 6
  * Deprecated tox -downloadcache option removed
  * passenv integration environment variables re-enabling integration tests
  * Enable pep8 H405 tests
  * Add patch to properly get all commands from dist
  * doc: Remove 'MANIFEST.in'
  * doc: Trivial cleanup of 'index.rst'
  * doc: Add deprecation note for 'requirements-pyN'
  * doc: Restructure 'Requirements' section
  * doc: Restructure 'Usage' section
  * doc: Add details of manifest generation
  * Support git://, git+ssh://, git+https:// without -e flag
  * More support Sphinx >=1.3b1 and <1.3.1
  * Fix docs for markers
  * Do not error when running pep8 with py3
  * Ensure changelog log output is written if it already exists
  * Cleanup jeepyb and pypi-mirror special casing
- Adjust BuildRequires

-------------------------------------------------------------------
Fri Apr  1 15:20:52 UTC 2016 - tbechtold@suse.com

- update to 1.8.1:
  * Handle the case where cmd.distribution has no pbr attribute
  * test_integration cleanups
  * Remove redundant testscenarios glue
  * Add standard code coverage configuration file
  * Add shields.io version/downloads links/badges into README.rst

-------------------------------------------------------------------
Sun Sep 20 09:03:29 UTC 2015 - tbechtold@suse.com

- update to 1.8.0:
  * Strip comments present in setup.cfg
  * Protect WSGI application with a critical section
- Remove 0001-Remove-sphinx_config.init_values-manual-call.patch
  Fixed upstream

-------------------------------------------------------------------
Wed Sep  9 06:42:06 UTC 2015 - tbechtold@suse.com

- update to 1.7.0:
  * Have pbr egg_info.writer check PBR is enabled

-------------------------------------------------------------------
Wed Aug 26 06:20:59 UTC 2015 - tbechtold@suse.com

- update to 1.6.0:
  * Strip comments in requirements files
  * Handle git being entirely absent
  * We require the use of setuptools
  * Fix retrieval of commit data and most recent tag
- Remove 0001-Handle-git-being-entirely-absent.patch .
  Applied upstream

-------------------------------------------------------------------
Wed Aug 12 09:32:35 UTC 2015 - dmueller@suse.com

- add 0001-Handle-git-being-entirely-absent.patch
- revert dependency on git (see comment in the specfile)

-------------------------------------------------------------------
Tue Aug 11 07:34:34 UTC 2015 - seife+obs@b1-systems.com

- update to version 1.4.0
  * Fix docs for environment markers in extras
  * Export ChangeLog and AUTHORS in install
  * Show how long the git querying takes
  * Add wsgi_scripts support to PBR
  * Updated from global requirements
- requires python-mock >= 1.2

-------------------------------------------------------------------
Mon Aug  3 10:04:09 UTC 2015 - toddrme2178@gmail.com

- Actually remove documentation requirements

-------------------------------------------------------------------
Mon Aug  3 09:46:34 UTC 2015 - toddrme2178@gmail.com

- Split documentation into own package to avoid dependency loop

-------------------------------------------------------------------
Mon Jul 27 15:37:32 UTC 2015 - toddrme2178@gmail.com

- Fix update-alternatives usage.

-------------------------------------------------------------------
Fri Jul 17 11:54:48 UTC 2015 - tbechtold@suse.com

- update to 1.3.0:
  * Wrap env markers in parens
  * Updated from global requirements
  * Add more documentation around building docs
  * Updated from global requirements
  * Use string for 'OS_TEST_TIMEOUT' default
  * Updated from global requirements
  * This documents the use of comments that work between 2.6, 2.7 and 3.4
- Add 0001-Remove-sphinx_config.init_values-manual-call.patch . Needed
  for newer Sphinx versions.

-------------------------------------------------------------------
Wed Jun 24 08:24:05 UTC 2015 - dmueller@suse.com

- update to 1.2.0:
  * Strip markers from test requirements
  * Revert "Remove sphinx_config.init_values(

-------------------------------------------------------------------
Tue Jun  9 07:17:47 UTC 2015 - tbechtold@suse.com

- update to 1.1.0:
  * Fix test case to be runnable with gnupg 2.1
  * More explicit data_files install location docs
  * Move CapturedSubprocess fixture to base
  * Remove sphinx_config.init_values() manual call
  * Updated from global requirements
  * builddoc: allow to use fnmatch-style exclusion for autodoc
  * doc: add some basic doc about pbr doc options
  * Add home-page into sample setup.cfg
  * Make setup.py --help-commands work without testrepository
- Removed 0001-Remove-sphinx_config.init_values-manual-call.patch
  Applied upstream.

-------------------------------------------------------------------
Tue Jun  2 16:19:13 UTC 2015 - tbechtold@suse.com

- update to 1.0.1:
  * Remove self.pre_run calls in packaging.py
  * Update hacking to 0.10.x series
  * Teach pbr to read extras and env markers
  * Bump integration test timeouts
  * Finish removing invocations of pip
  * Advertise support for Python3.4
  * Issue #1451976: handle commits with non-utf8 text
  * Parallelise integration tests
- Removed pbr-0.10.8-fix-sphinx-init_values.patch . Replaced upstream
  with 0001-Remove-sphinx_config.init_values-manual-call.patch
- Added 0001-Remove-sphinx_config.init_values-manual-call.patch

-------------------------------------------------------------------
Tue May  5 10:57:35 UTC 2015 - benoit.monin@gmx.fr

- update to version 0.11.0:
  * Issue #1450210: Preversioning rc tag handling
  * Stop testing setup.py easy_install behaviour
  * Test pip install -e of projects
  * Build all the wheels in one pass rather than many
  * Improve integration.sh
  * Honour new test variable PIPVERSION
  * Be safe, don't let friends use RawConfigParser
  * Revert "Support platform-specific requirements files"
  * Reinstate pure-git-hashes-are-illegal test
  * Ignore non-release related tags
  * Test that MANIFEST.in excludes work
  * Fixup semver
  * Better diagnostics on test failure
  * Don't avoid egg-info quite so often
  * Add truncated lincense text
  * "packages" might list multiple directories
  * Support script text override for newer develop
  * Fixes Windows generated scripts headers
  * Update README format to match release notes tool
  * Be more aggressive about building wheels
  * Use a wheelhouse in the integration test
  * Build a wheel when integration testing PBR changes
  * Use unsafe OpenPGP keys for testing
- increase required version of python-hacking for the tests

-------------------------------------------------------------------
Thu Apr 16 08:53:20 UTC 2015 - hpj@urpla.net

- Update to version 0.10.8
  * Support script text override for newer develop
- Changes from version 0.10.7
  * _get_revno only returns a commit count
- Changes from 0.10.6
  * Integration test PBR commits
- Changes from 0.10.5
  * Move write_pbr_json to avoid issues with nose
- Changes from 0.10.4
  * Properly check for git before getting git dir
  * Use post version signifiers
  * Only import sphinx during hook processing
- Changes from 0.10.3
  * Stop including git sha in version strings
  * Write and read more complex git sha info
- Changes from 0.10.2
  * Remove all 2.7 filtering
  * Stop filtering out argparse
  * Remove mirror testing from the integration script
- Changes from 0.10.1
  * Prefix git suffixes with + instead of 
- fix Sphinx config.init_values fallout
- add update-alternatives
- remove outdated patches
  * 0001-use-get_boolean_option-for-warnerrors.patch
  * 0001-Allow-overwriting-sphinx-builder-list-from-command-l.patch
- Add pbr-0.10.8-fix-sphinx-init_values.patch
- put docs in its own package

-------------------------------------------------------------------
Fri Oct 24 09:38:37 UTC 2014 - toddrme2178@gmail.com

- Add python-pip from requires to buildrequires

-------------------------------------------------------------------
Thu Aug 28 10:48:07 UTC 2014 - dmueller@suse.com

- add 0001-Allow-overwriting-sphinx-builder-list-from-command-l.patch
  0001-use-get_boolean_option-for-warnerrors.patch

-------------------------------------------------------------------
Thu Jul 31 16:25:10 UTC 2014 - dimstar@opensuse.org

- Rename rpmlintrc to %{name}-rpmlintrc.
  Follow the packaging guidelines.

-------------------------------------------------------------------
Sat Jul 26 15:17:14 UTC 2014 - tbechtold@suse.com

- Update BuildRequires according to test-requirements.txt
- Update to version 0.10.0
  * Remove all 2.7 filtering
  * Stop filtering out argparse
  * Remove mirror testing from the integration script
  0.9.0
  * Allow examining parsing exceptions
  * Update integration script for Apache 2.4
  * Restore Monkeypatched Distribution Instance
  * Register testr as a distutil entry point
  * Check for git before querying it for a version
  * Allow _run_cmd to run commands in any directory
  * Make setUp fail if sdist fails
  * Permit pre-release versions with git metadata
  * Un-nest some sections of code
  0.8.2
  * Remove --use-mailmap as it's not needed
  * Fix typos in docs
  0.8.1
  * pbr/testr_command.py: Add logging
  * Documentation updates
  * Fixed a typo in the documentation
  * Make source configurable when using --coverage
  * README.rst: tweaks
  * Format autoindex.rst file properly
  * make pbr use hacking directly

-------------------------------------------------------------------
Fri Mar 28 08:25:25 UTC 2014 - speilicke@suse.com

- Update to version 0.8.0:
  * Use unicode_literals import instead of u'unicode' notation
  * Remove pip version specifier
  * Make tools/integration.sh take a branch
  * Fixes blocking issue on Windows

-------------------------------------------------------------------
Mon Mar 24 16:20:30 UTC 2014 - dmueller@suse.com

- update to 0.7.0:
  * No changes, just use the released tarball which has
  the right version (that others are checking for)

-------------------------------------------------------------------
Tue Mar 18 14:18:44 UTC 2014 -  speilicke@suse.com

- Update to version pbr-0.6.14.g6ffff7c:
  * Factor run_cmd out of the base class
  * Return the real class in VersionInfo __repr__
  * Fix up some docstrings
  * Init sphinx config values before accessing them
  * Remove copyright from empty files
  * Declare support for Python versions in setup.cfg
  * Updated from global requirements
  * Remove unused _parse_mailmap()
  * Add support for python 3-<3.3
  * Remove tox locale overrides
  * Do not force log verbosity level to info
  0.6
  * package: read a specific Python version requirement file
- Fix dependencies

-------------------------------------------------------------------
Fri Feb 14 09:39:45 UTC 2014 - speilicke@suse.com

- Run testr directly

-------------------------------------------------------------------
Tue Feb  4 09:42:28 UTC 2014 - dmueller@suse.com

- update to 0.6:
  * package: read a specific Python version requirement file
  * Fix typos in documents
  * Pin sphinx to <1.2
  * Build mirror using proper requirements
  * Use wheels for installation
  * show diff between pip installed packages and requirements
  * Enable wheel processing in the tests
  * Clean up integration script
  * Let git do mailmap mapping for us
  * Make ChangeLog more condensed
  * Make sphinx builders configurable in LocalBuildDoc
  * Serve local mirror using apache
  * Bump the development status classifier
  * Support building wheels (PEP-427)
  * Ignore jenkins@openstack.org in authors building
  * Communicate to user when we skip a requirement
  * Base python 2.7 skip list on parsed names
  * Link to the documentation in the readme
  * Avoid using 'which' executable for finding git
  * Add wheel mirror structure awareness
  * Remove pip as an argument from mkvenv
  * Use pypi-mirror instead of jeepyb

-------------------------------------------------------------------
Thu Jan  9 09:20:10 UTC 2014 - speilicke@suse.com

- Update to version 0.5.23.36.g00fbbd1:
- Install from tarballs.openstack.org (rather than PyPI) and use _service file

-------------------------------------------------------------------
Mon Nov 25 13:58:28 UTC 2013 - speilicke@suse.com

- Update dependencies
- Rename build-conditional to "test", avoid clash with Cloud:OpenStack:Master's
  "tests" build-conditional. We've got other issues here
- Add rpmlintrc, we have some C files as part of the testsuite

-------------------------------------------------------------------
Thu Oct 31 23:47:07 UTC 2013 - dmueller@suse.com

- update to 0.5.23:
  * Use dev based release versioning

-------------------------------------------------------------------
Thu Aug  8 06:49:22 UTC 2013 - speilicke@suse.com

- Update to version 0.5.21:
  + Replace setuptools_git with a smarter approach

-------------------------------------------------------------------
Mon Aug  5 09:09:57 UTC 2013 - speilicke@suse.com

- Add python-pip requirement

-------------------------------------------------------------------
Sun Aug  4 15:03:42 UTC 2013 - dmueller@suse.com

- update to 0.5.20:
  * Add support for globbing in data files
  * Stop trying to install old pip and setuptools

-------------------------------------------------------------------
Thu Jul 11 14:30:02 UTC 2013 - dmueller@suse.com

- update to 0.5.18:
  * support python setup.py test
  * various python 3.x compat fixes

-------------------------------------------------------------------
Thu Jul  4 07:29:43 UTC 2013 - speilicke@suse.com

- Introduce a build conditional for running tests to break build cycle
  with python-oslo.config

-------------------------------------------------------------------
Tue Jul  2 16:06:42 UTC 2013 - dmueller@suse.com

- update description 

-------------------------------------------------------------------
Wed Jun 26 15:29:49 UTC 2013 - cdenicolo@suse.com

- license update: Apache-2.0
  license SUSE-Xano license not found in package. See LICENSE file.

-------------------------------------------------------------------
Wed Jun 26 09:47:22 UTC 2013 - dmueller@suse.com

- remove python-discover dependency for newer distros 

-------------------------------------------------------------------
Fri Jun 21 07:28:12 UTC 2013 - dmueller@suse.com

- update to 0.5.17:
  * Remove dependency on distribute
  * Fix pip invocation for old versions of pip.
- remove 0001-Use-pip-instead-of-easy_install-for-installation.patch
- remove 0001-Skip-git-checkout-related-tests-when-.git-is-missing.patch

-------------------------------------------------------------------
Mon Jun 10 13:35:54 UTC 2013 - dmueller@suse.com

- add 0001-Use-pip-instead-of-easy_install-for-installation.patch 

-------------------------------------------------------------------
Mon Jun 10 12:01:19 UTC 2013 - dmueller@suse.com

- update to 0.5.14:
  * Remove jinja pin.
  * Explicitly install install_requires.
  * More python3 compatibility.
  * Fix tox.ini to not reference deleted testenv
  * Fix doc autoindexing.
  * Add missing files to the tarball.
- add 0001-Skip-git-checkout-related-tests-when-.git-is-missing.patch

-------------------------------------------------------------------
Mon May 27 09:43:54 UTC 2013 - dmueller@suse.com

- update to 0.5.10:
  + Default to single-version-externally-managed
  + Add config for skipping authors and changelog.
  + Update to d2to1 0.2.10.

-------------------------------------------------------------------
Tue May  7 08:16:26 UTC 2013 - speilicke@suse.com

- Buildrequire python-python-mimeparse and use testr instead of nosetests.
  The pbr testsuite needs some proper setup to pass successfully.

-------------------------------------------------------------------
Thu May  2 12:22:15 UTC 2013 - speilicke@suse.com

- Initial version