File kwallet.changes of Package kwallet

-------------------------------------------------------------------
Sun May 13 21:03:07 UTC 2018 - lbeltrame@kde.org

- Update to 5.46.0
  * New feature release
  * For more details please see:
  * https://www.kde.org/announcements/kde-frameworks-5.46.0.php
- Changes since 5.45.0:
  * Use override
  * Warning--

-------------------------------------------------------------------
Sat Apr 14 13:19:06 CEST 2018 - lbeltrame@kde.org

- Update to 5.45.0
  * New feature release
  * For more details please see:
  * https://www.kde.org/announcements/kde-frameworks-5.45.0.php
- Changes since 5.44.0:
  * Remove not necessary QtCore and co

-------------------------------------------------------------------
Mon Mar 12 23:29:42 CET 2018 - lbeltrame@kde.org

- Update to 5.44.0
  * New feature release
  * For more details please see:
  * https://www.kde.org/announcements/kde-frameworks-5.44.0.php
- Changes since 5.43.0:
  * None

-------------------------------------------------------------------
Mon Feb 12 23:42:10 CET 2018 - lbeltrame@kde.org

- Update to 5.43.0
  * New feature release
  * For more details please see:
  * https://www.kde.org/announcements/kde-frameworks-5.43.0.php
- Changes since 5.42.0:
  * None

-------------------------------------------------------------------
Tue Jan 16 22:50:21 CET 2018 - lbeltrame@kde.org

- Update to 5.42.0
  * New feature release
  * For more details please see:
  * https://www.kde.org/announcements/kde-frameworks-5.42.0.php
- Changes since 5.41.0:
  * Remove obsolete reviewboardrc file
  * Use cmake variable kwallet_xml for specifing org.kde.KWallet.xml
  * Use correct service executable path for installing kwalletd dbus service on Win32

-------------------------------------------------------------------
Sun Dec 17 09:43:49 CET 2017 - lbeltrame@kde.org

- Update to 5.41.0
  * New feature release
  * For more details please see:
  * https://www.kde.org/announcements/kde-frameworks-5.41.0.php
- Changes since 5.40.0:
  * Fix some clazy warning
  * Port to qCDebug
  * Remove some remove_definition
  * Port to qCDebug

-------------------------------------------------------------------
Mon Nov 13 07:01:15 CET 2017 - lbeltrame@kde.org

- Update to 5.40.0
  * New feature release
  * For more details please see:
  * https://www.kde.org/announcements/kde-frameworks-5.40.0.php
- Changes since 5.39.0:
  * Add explicit keyword

-------------------------------------------------------------------
Mon Oct 23 06:41:44 CEST 2017 - lbeltrame@kde.org

- Update to 5.39.0
  * New feature release
  * For more details please see:
  * https://www.kde.org/announcements/kde-frameworks-5.39.0.php
- Changes since 5.38.0:
  * tests/kwalletd/CMakeLists.txt - requires KF5ConfigWidgets now

-------------------------------------------------------------------
Tue Sep 12 07:11:18 CEST 2017 - lbeltrame@kde.org

- Update to 5.38.0
  * New feature release
  * For more details please see:
  * https://www.kde.org/announcements/kde-frameworks-5.38.0.php
- Changes since 5.37.0:
  * Do not leak symbols of pimpl classes, protect with Q_DECL_HIDDEN
  * Don't use find_file for finding files in our own source dir

-------------------------------------------------------------------
Sat Aug 12 09:23:39 UTC 2017 - christophe@krop.fr

- Update to 5.37.0
  * New feature release
  * For more details please see:
  * https://www.kde.org/announcements/kde-frameworks-5.37.0.php
- Changes since 5.36.0 :
  * More nullptr
  * API dox: use official name "D-Bus" consistently

-------------------------------------------------------------------
Wed Jul 12 07:14:02 CEST 2017 - lbeltrame@kde.org

- Update to 5.36.0
  * New feature release
  * For more details please see:
  * https://www.kde.org/announcements/kde-frameworks-5.36.0.php
- Changes since 5.35.0:
  * [FEATURE] Option to build & install QCH file with the public API dox

-------------------------------------------------------------------
Sun Jun 11 09:27:43 CEST 2017 - lbeltrame@kde.org

- Update to 5.35.0
  * New feature release
  * For more details please see:
  * https://www.kde.org/announcements/kde-frameworks-5.35.0.php
- Changes since 5.34.0:
  * Replace kwalletd4 after migration has finished
  * Signal completion of migration agent
  * Whitespace fixup
  * Only start timer for migration agent if necessary
  * Check for unique applicaton instance as early as possible

-------------------------------------------------------------------
Mon May 15 13:53:14 CEST 2017 - fabian@ritter-vogt.de

- Update to 5.34.0
  * New feature release
  * For more details please see:
  * https://www.kde.org/announcements/kde-frameworks-5.34.0.php
- Changes since 5.33.0:
  * None

-------------------------------------------------------------------
Sat Apr 15 10:11:56 CEST 2017 - lbeltrame@kde.org

- Update to 5.33.0
  * New feature release
  * For more details please see:
  * https://www.kde.org/announcements/kde-frameworks-5.33.0.php
- Changes since 5.32.0:
  * Upgrade ECM and KF5 version requirements for 5.33.0 release.
  * Upgrade KF5 version to 5.33.0.

-------------------------------------------------------------------
Sun Mar 19 14:51:08 CET 2017 - lbeltrame@kde.org

- Update to 5.32.0
  * New feature release
  * For more details please see:
  * https://www.kde.org/announcements/kde-frameworks-5.32.0.php
- Changes since 5.31.0:
  * Commit translations from l10n-kf5
  * Upgrade ECM and KF5 version requirements for 5.32.0 release.
  * Fix -Wdocumentation warning
  * Upgrade KF5 version to 5.32.0.

-------------------------------------------------------------------
Thu Mar  9 23:19:25 UTC 2017 - wbauer@tmo.at

- Build against libqgpgme-devel on openSUSE and SLE13 to enable GPG
  encryption, gpgmepp5 is not supported any more

-------------------------------------------------------------------
Thu Feb  9 09:34:13 UTC 2017 - hrvoje.senjan@gmail.com

- Update to 5.31.0
  * For more details please see:
    https://www.kde.org/announcements/kde-frameworks-5.31.0.php

-------------------------------------------------------------------
Wed Feb  1 11:56:37 UTC 2017 - adam.majer@suse.de

- use individual libboost-*-devel packages instead of boost-devel

-------------------------------------------------------------------
Sun Jan  8 23:44:02 UTC 2017 - hrvoje.senjan@gmail.com

- Update to 5.30.0
  * For more details please see:
    https://www.kde.org/announcements/kde-frameworks-5.30.0.php

-------------------------------------------------------------------
Sun Dec  4 02:04:59 UTC 2016 - hrvoje.senjan@gmail.com

- Update to 5.29.0
  * For more details please see:
    https://www.kde.org/announcements/kde-frameworks-5.29.0.php

-------------------------------------------------------------------
Sat Nov  5 22:11:57 UTC 2016 - hrvoje.senjan@gmail.com

- Update to 5.28.0
  * If Gpgmepp is not found, try to use KF5Gpgmepp
  * Use Gpgmepp from GpgME-1.7.0
  * For more details please see:
    https://www.kde.org/announcements/kde-frameworks-5.28.0.php

-------------------------------------------------------------------
Sun Oct  9 13:00:27 UTC 2016 - hrvoje.senjan@gmail.com

- Update to 5.27.0
  * Check whether kwallet is enabled in Wallet::isOpen(name)
    (kde#358260)
  * Add missing boost header
  * Remove duplicate search for KF5DocTools
  * For more details please see:
    https://www.kde.org/announcements/kde-frameworks-5.27.0.php
- Drop upstreamed fix-isOpen-crash-when-wallet-disabled.patch

-------------------------------------------------------------------
Thu Oct  6 14:48:04 UTC 2016 - wbauer@tmo.at

- Add fix-isOpen-crash-when-wallet-disabled.patch to fix a crash in
  drkonqi (and maybe other applications) if kwallet is disabled
  (kde#358260)

-------------------------------------------------------------------
Tue Sep  6 20:54:04 UTC 2016 - hrvoje.senjan@gmail.com

- Update to 5.26.0
  * Move kwallet-query docbook to correct subdir
  * Fix wording an -> one
  * For more details please see:
    https://www.kde.org/announcements/kde-frameworks-5.26.0.php

-------------------------------------------------------------------
Sun Aug  7 21:57:22 UTC 2016 - hrvoje.senjan@gmail.com

- Update to 5.25.0
  * Qt >= 5.5 is now required
  * For more details please see:
    https://www.kde.org/announcements/kde-frameworks-5.25.0.php

-------------------------------------------------------------------
Wed Jul  6 15:06:35 UTC 2016 - hrvoje.senjan@gmail.com

- Update to 5.24.0
  * For more details please see:
    https://www.kde.org/announcements/kde-frameworks-5.24.0.php

-------------------------------------------------------------------
Mon Jun  6 21:28:03 UTC 2016 - hrvoje.senjan@gmail.com

- Update to 5.23.0
  * KWalletd migration: fix error handling, stops the migration
    from happening on every single boot.
  * For more details please see:
    https://www.kde.org/announcements/kde-frameworks-5.23.0.php

-------------------------------------------------------------------
Sat May  7 18:34:14 UTC 2016 - hrvoje.senjan@gmail.com

- Update to 5.22.0 (boo#980066)
  * Disable seession restore for kwalletd5
  * For more details please see:
    https://www.kde.org/announcements/kde-frameworks-5.22.0.php

-------------------------------------------------------------------
Mon Apr  4 14:22:37 UTC 2016 - hrvoje.senjan@gmail.com

- Update to 5.21.0 (boo#974793)
  * Upgrade Qt version requirement to 5.4.0
  * For more details please see:
    https://www.kde.org/announcements/kde-frameworks-5.21.0.php

-------------------------------------------------------------------
Sun Mar  6 10:02:35 UTC 2016 - hrvoje.senjan@gmail.com

- Update to 5.20.0 (boo#970856)
  * Make sure KDocTools is looked-up
  * Don't pass a negative number to dbus, it asserts in libdbus
  * Clean cmake files
  * KWallet::openWallet(Synchronous): don't time out after 25 seconds
  * For more details please see:
    https://www.kde.org/announcements/kde-frameworks-5.20.0.php

-------------------------------------------------------------------
Sat Feb  6 18:07:37 UTC 2016 - hrvoje.senjan@gmail.com

- Update to 5.19.0 (boo#967668)
  * Duplicate the file descriptor while opening the file to read the env
  * For more details please see:
    https://www.kde.org/announcements/kde-frameworks-5.19.0.php

-------------------------------------------------------------------
Mon Feb  1 18:01:58 UTC 2016 - hrvoje.senjan@gmail.com

- Enable gpgmepp5 integration on Leap also

-------------------------------------------------------------------
Sat Jan  2 17:45:33 UTC 2016 - hrvoje.senjan@gmail.com

- Update to 5.18.0
  * kwalletd: Fix FILE* leak
  * For more details please see:
    https://www.kde.org/announcements/kde-frameworks-5.18.0.php

-------------------------------------------------------------------
Thu Dec 10 23:10:16 UTC 2015 - hrvoje.senjan@gmail.com

- Update to 5.17.0
  * Correctly handle the case where the user deactivated us
  * For more details please see:
    https://www.kde.org/announcements/kde-frameworks-5.17.0.php

-------------------------------------------------------------------
Sun Nov  8 17:04:43 UTC 2015 - hrvoje.senjan@gmail.com

- Update to 5.16.0 (boo#955067)
  * Use KDE_INSTALL_DBUSINTERFACEDIR to install dbus interfaces
  * Fixed KWallet configuration file warnings on login (kde#351805)
  * Prefix the kwallet-pam output properly
  * For more details please see:
    https://www.kde.org/announcements/kde-frameworks-5.16.0.php

-------------------------------------------------------------------
Mon Oct  5 17:37:37 UTC 2015 - hrvoje.senjan@gmail.com

- Update to 5.15.0
  * No longer automatically close on last use
  * For more details please see:
    https://www.kde.org/announcements/kde-frameworks-5.15.0.php
- Enable gpgmepp integration with openSUSE > 13.2

-------------------------------------------------------------------
Tue Sep  8 17:13:34 UTC 2015 - hrvoje.senjan@gmail.com

- Update to 5.14.0
  * For more details please see:
    https://www.kde.org/announcements/kde-frameworks-5.14.0.php

-------------------------------------------------------------------
Tue Aug  4 19:20:46 UTC 2015 - hrvoje.senjan@gmail.com

- Update to 5.13.0
  * The Qt version requirement has been bumped from 5.2 to 5.3
  * Debug output has been ported to categorized output, for less
    noise by default
  * Docbook documentation has been reviewed and updated
  * Fix Windows build
  * Print a warning with error code when opening the wallet by
    PAM fails
  * Return the backend error code rather than -1 when opening a
    wallet failed
  * Make the backend's "unknown cipher" a negative return code
  * Watch for PAM_KWALLET5_LOGIN for KWallet5
  * Fix crash when MigrationAgent::isEmptyOldWallet() check fails
  * KWallet can now be unlocked by PAM using kwallet-pam module
  * For more details please see:
    https://www.kde.org/announcements/kde-frameworks-5.13.0.php

-------------------------------------------------------------------
Sun Jul  5 18:45:26 UTC 2015 - hrvoje.senjan@gmail.com

- Update to 5.12.0
  * Imported and improved the kwallet-query command-line tool.
  * Support to overwrite maps entries.
  * For more details please see:
    https://www.kde.org/announcements/kde-frameworks-5.12.0.php

-------------------------------------------------------------------
Sun Jun  7 19:07:57 UTC 2015 - hrvoje.senjan@gmail.com

- Update to 5.11.0
  * For more details please see:
    https://www.kde.org/announcements/kde-frameworks-5.11.0.php

-------------------------------------------------------------------
Sun May  3 19:47:23 UTC 2015 - hrvoje.senjan@gmail.com

- Update to 5.10.0
  * Migration agent now also check old wallet is empty
    before starting (kde#346498)
  * For more details please see:
    https://www.kde.org/announcements/kde-frameworks-5.10.0.php

-------------------------------------------------------------------
Sat Apr  4 14:40:49 UTC 2015 - hrvoje.senjan@gmail.com

- Update to 5.9.0
  * For more details please see:
    https://www.kde.org/announcements/kde-frameworks-5.9.0.php
- Drop no longer needed Requires of the devel subpackage:
  kconfig-devel and kwindowsystem-devel

-------------------------------------------------------------------
Sat Mar  7 16:58:49 UTC 2015 - hrvoje.senjan@gmail.com

- Update to 5.8.0
  * For more details please see:
    https://www.kde.org/announcements/kde-frameworks-5.8.0.php
- Drop 0001-Retrofitting-the-fix-for-a-bug-found-in-Applications.patch,
  merged upstream

-------------------------------------------------------------------
Wed Feb 18 01:48:33 UTC 2015 - hrvoje.senjan@gmail.com

- Added 0001-Retrofitting-the-fix-for-a-bug-found-in-Applications.patch
  (kde#343718)

-------------------------------------------------------------------
Sun Feb  8 18:15:22 UTC 2015 - hrvoje.senjan@gmail.com

- Update to 5.7.0
  * Automatically detect and convert old ECB wallets to CBC
  * Fixed the CBC encryption algorithm
  * Ensured wallet list gets updated when a wallet file gets
    removed from disk
  * Remove stray </p> in user-visible text
  * For more details please see:
    https://www.kde.org/announcements/kde-frameworks-5.7.0.php

-------------------------------------------------------------------
Sat Jan  3 18:03:23 UTC 2015 - hrvoje.senjan@gmail.com

- Update to 5.6.0
  * For more details please see:
    https://www.kde.org/announcements/kde-frameworks-5.6.0.php

-------------------------------------------------------------------
Sat Dec  6 12:53:44 UTC 2014 - hrvoje.senjan@gmail.com

- Update to 5.5.0
  * For more details please see:
    https://www.kde.org/announcements/kde-frameworks-5.5.0.php

-------------------------------------------------------------------
Sun Nov  2 17:47:19 UTC 2014 - hrvoje.senjan@gmail.com

- Update to 5.4.0
  * Emit 'walletListDirty' signal when the 'kwalletd'
    directory is deleted
  * For more details please see:
    https://www.kde.org/announcements/kde-frameworks-5.4.0.php

-------------------------------------------------------------------
Sat Oct  4 17:59:44 UTC 2014 - hrvoje.senjan@gmail.com

- Update to 5.3.0
  * For more details please see:
    https://www.kde.org/announcements/kde-frameworks-5.3.0.php
- Let new kwalletd5-lang subpackage be recommended by kwalletd5 subpackage

-------------------------------------------------------------------
Tue Sep  9 09:49:30 UTC 2014 - hrvoje.senjan@gmail.com

- Update to 5.2.0
  * For more details please see:
    http://kde.org/announcements/kde-frameworks-5.2.php

-------------------------------------------------------------------
Sat Aug  2 10:20:13 UTC 2014 - hrvoje.senjan@gmail.com

- Update to 5.1.0
  * For more details please see:
    http://www.kde.org/announcements/kde-frameworks-5.1.php

-------------------------------------------------------------------
Fri Jul 11 09:48:52 UTC 2014 - hrvoje.senjan@gmail.com

- Define kf5_version within package

-------------------------------------------------------------------
Tue Jul  1 21:35:56 UTC 2014 - hrvoje.senjan@gmail.com

- Update to 5.0.0
  * Final release of KDE Frameworks 5
  * API improvements and cleanups
  * Buildsystem fixes
  * For more details please see:
    http://www.kde.org/announcements/kde-frameworks-5.0.php

-------------------------------------------------------------------
Sun Jun  1 18:02:28 UTC 2014 - hrvoje.senjan@gmail.com

- Update to 4.100.0
  * API improvements and cleanups
  * Buildsystem fixes
  * For more details please see:
    http://www.kde.org/announcements/announce-frameworks5-beta3.php
- Add baselibs.conf
-------------------------------------------------------------------
Sun May  4 01:41:25 UTC 2014 - hrvoje.senjan@gmail.com

- Update to 4.99.0
  * API improvements and cleanups
  * Buildsystem fixes
  * For more details please see:
    http://www.kde.org/announcements/announce-frameworks5-beta2.php

-------------------------------------------------------------------
Sat Mar 29 19:47:53 UTC 2014 - hrvoje.senjan@gmail.com

- Update to 4.98.0
  * API improvements and cleanups
  * Buildsystem fixes
  * For more details please see:
    http://www.kde.org/announcements/announce-frameworks5-beta1.php
- Added libgcrypt-devel >= 1.5.0 BuildRequires

-------------------------------------------------------------------
Tue Mar  4 16:39:29 UTC 2014 - hrvoje.senjan@gmail.com

- Update to 4.97.0:
  * Buildsystem fixes
  * For more details please see:
    http://www.kde.org/announcements/announce-frameworks5-alpha2.php

-------------------------------------------------------------------
Sat Feb  8 02:19:57 UTC 2014 - hrvoje.senjan@gmail.com

- Init kwallet package