File python-papyrus.changes of Package python-papyrus

-------------------------------------------------------------------
Wed Dec 26 13:40:23 UTC 2018 - Bruno Friedmann <bruno@ioda-net.ch>

- Update to version 2.4.0 
  + Add element_callback parameters to XSD and XSDGenerator 
  + Ease development through Makefile and virtualenv
  + Use psycopg2-binary package instead of psycopg2 in tests
  + Fix spelling errors
- Refresh .spec with spec-cleaner

-------------------------------------------------------------------
Mon Jun  4 13:32:25 UTC 2018 - bruno@ioda-net.ch

- Update to version 2.3.0
  + Add time support in geojson renderer
  + Change content type to ‘application/geo+json’
  + Fix membership test in create_geom_filter
  + Change ‘update’ HTTP response from 201 to 200
- Packaging 
  + spec-cleaner minimal (URL,date,%license)
  + remove merge upstream patches upstream-post-2.2.patch
  + Fix %check part

-------------------------------------------------------------------
Fri Jul 28 15:11:29 UTC 2017 - bruno@ioda-net.ch

- Packaging : move to singlespec 
  + Fix copyright year
  + Spec-cleaner

-------------------------------------------------------------------
Tue Jun 06 13:10:20 UTC 2017 - gutaper@gmail.com

- Fixed "%check" section which caused build fail

-------------------------------------------------------------------
Thu Feb 23 10:36:20 UTC 2017 - bruno@ioda-net.ch

- Add post 2.2 release patch to fix tests upstream-post-2.2.patch
- Add pyramid_handlers and modify tests call 

-------------------------------------------------------------------
Mon Jul  4 16:07:35 UTC 2016 - arun@gmx.de

- specfile:
  * remove dependency for simplejson

- update to version 2.2:
  * Remove dependency to simplejson for Decimal handling @gberaudo

-------------------------------------------------------------------
Mon Jun 13 19:07:12 UTC 2016 - toddrme2178@gmail.com

- Remove unneeded test dependencies.

-------------------------------------------------------------------
Sun May  8 07:13:51 UTC 2016 - arun@gmx.de

- specfile:
  * changed to https for source url
  * updated source url to files.pythonhosted.org

-------------------------------------------------------------------
Sun Apr 10 17:19:49 UTC 2016 - arun@gmx.de

- specfile:
  * removed source file Changelog.rst (CHANGES back in tar-ball)
  * removed sed fix (fixed upstream? no match for regexp anymore)

- update to version 2.1:
  * Support recent versions of geojson package. @sbrunner
    https://github.com/elemoine/papyrus/pull/53

-------------------------------------------------------------------
Fri Mar  4 16:08:53 UTC 2016 - toddrme2178@gmail.com

- Remove unmaintained, optional python3-pyramid_handlers dependency

-------------------------------------------------------------------
Tue Nov 24 16:34:43 UTC 2015 - bruno@ioda-net.ch

- Update upstream release 2.0.post1
  * (tag: 2.0.post1) Set version to 2.0.post1
  * (tag: 2.0) Attempt to fix Read the Docs build
  * Merge pull request #49 from elemoine/release-20
  * Run bdist_wheel before uploading to pypi
  * Set version to 2.0
  * Merge pull request #48 from elemoine/classifiers
  * Pass Python 3 classifiers to setup
  * Add bdist_wheel section to setup.cfg
  * Merge pull request #47 from elemoine/tox
  * Comparing and_ filter with compare() does not work
  * Add print statements
  * Try to use Travis containers
  * Add Travis badge to README file
  * Simplify create_attr_filter code
  * Make Travis run flake8
  * Make views.py flake8 compliant
  * Make test_init.py flake8 compliant
  * Make renderers.py flake8 compliant
  * Make __init__.py flake8 compliant
  * Make test_renderers.py flake8 compliant
  * assertIsNotNone not available on Python < 2.7
  * Remove unused PY variable
  * Use unittest.mock on Python 3
  * Use tox
  * Merge pull request #46 from elemoine/python3
  * Add install section to Travis config
  * Add -e . to dev_requirements.txt
  * Add Travis CI configuration file
  * Add flake8 to dev_requirements.txt
  * Make flake8 happier
  * Use __future__ and six
  * Merge pull request #42 from elemoine/license
  * Add LICENSE.txt to MANIFEST.in
  * Merge pull request #41 from elemoine/license
  * Add a LICENSE.txt file (BSD 2-Clause)
  * Merge pull request #39 from Jenselme/simplejson
  * Update installing section from documentation to counsel simplejson
  * Merge pull request #38 from elemoine/doclinks
  * Clarify links to documentation
  * Merge pull request #37 from elemoine/geo-interface
  * Fix PythonGeoInterface links
  * Merge pull request #35 from ametaireau/patch-1
  * Fix the documentation link

- Packaging :
  * Remove LICENCE.rst (added upstream)
  * Added Changelog.rst (upstream forget CHANGES.rst)

-------------------------------------------------------------------
Fri Aug 21 13:53:53 UTC 2015 - bruno@ioda-net.ch

- Inital Packaging on obs for python3
- Version 2.0
	Use GeoAlchemy 2 instead of GeoAlchemy. @elemoine