A new user interface for you! Read more...

File gwenhywfar.changes of Package gwenhywfar

-------------------------------------------------------------------
Mon Dec 11 13:02:15 UTC 2017 - wbauer@tmo.at

- Re-enable Qt4 front-end, kmymoney still needs it for its kbanking
  plugin
- BuildIgnore libopenssl-1_0_0-devel to avoid openssl conflict on
  Tumbleweed

-------------------------------------------------------------------
Mon Dec  4 22:59:04 UTC 2017 - nico.kruber@gmail.com

- Update to 4.18.0
  + show SSL certificate hashes as MD5, SHA1, and SHA512

-------------------------------------------------------------------
Mon Nov 27 10:00:09 UTC 2017 - dimstar@opensuse.org

- Conditionalize usage of qt4 libs

-------------------------------------------------------------------
Sat Jun 10 11:17:28 UTC 2017 - wbauer@tmo.at

- Enable Qt5 front-end

-------------------------------------------------------------------
Tue May 30 21:33:32 UTC 2017 - nico.kruber@gmail.com

- Update to 4.17.0
  + minor bugfixes

-------------------------------------------------------------------
Fri Oct 14 19:02:52 UTC 2016 - jcnengel@gmail.com

- Update to 4.16.0
  + Fix issues handling certificates

-------------------------------------------------------------------
Wed Sep  7 21:47:37 UTC 2016 - nico.kruber@gmail.com

- quick fix for $CPP being unset and configure failing to handle
  include dirs properly

-------------------------------------------------------------------
Sun Aug 21 21:47:50 UTC 2016 - jcnengel@gmail.com

- Update to 4.15.5beta
  + Fix connections to buggy SSL servers

-------------------------------------------------------------------
Sat Apr 30 11:23:03 UTC 2016 - nico.kruber@gmail.com

- Update to 4.15.3
  + improve and simplify the TLS code
  + fix an error in the message parser (MsgEngine) that caused
    problems with some special HBCI messages
  + new (experimental) QT5 front-end (not enabled yet here)

-------------------------------------------------------------------
Wed Jan 13 14:55:50 UTC 2016 - jcnengel@gmail.com

- Update to 4.15.2beta
  + Use new code for SSL connections to enable build with current
    GnuTLS versions. This obsoletes patch gwenhywfar-gnutls30.patch

-------------------------------------------------------------------
Thu Nov  5 23:39:26 UTC 2015 - nico.kruber@gmail.com

- Update to 4.14.0:
  + Fix segfault on windows when using HBCI with keyfile.
  + Major speedup of GWEN_Directory_GetMatchingFilesRecursively().
  + Re-work Compiler Symbol Visibility Check.
  + Drop unused autoconf variable gwen_enable_export.
  + Fix symbol visibilty check for GCC 5.x.
  + Revert "Turn compiler warning for implicit function declaration
    into error."
  + Revert "Disable timestamps in HTML pages generated by Doxygen".
  + Disable timestamps in HTML pages generated by Doxygen.
  + typemaker2: Added support for _free-hooks, fixed many compiler
    warnings.
  + API ADDITION: Added 2 more virtual functions to
    GWEN_MULTICACHE.
  + Added functions
    GWEN_Param_List_Get/SetCurrentValueAsInt/Double.

-------------------------------------------------------------------
Thu Apr 23 18:33:42 UTC 2015 - zaitor@opensuse.org

- Add gwenhywfar-gnutls30.patch: Fix build with gnutls30, patch
  taken from Arch linux.

-------------------------------------------------------------------
Fri Jan 30 13:28:41 UTC 2015 - zaitor@opensuse.org

- Update to version 4.13.1:
  + Add function declaration that was missing in header, as
    discovered by the additional compiler option.
  + Turn compiler warning for implicit function declaration into
    error.
  + Fix function name for systems without <langinfo.h> but with
    <localcharset.h>.

-------------------------------------------------------------------
Sat Jan  3 11:41:27 UTC 2015 - jcnengel@gmail.com

- Update to version 4.13.0
  + Some bugfixes, stable version

-------------------------------------------------------------------
Fri Apr 18 22:05:36 UTC 2014 - jcnengel@gmail.com

- Update to version 4.12.0beta
  + Fixes a bug in calculating quarter's beginning and end

-------------------------------------------------------------------
Mon Mar  3 09:53:52 UTC 2014 - jcnengel@gmail.com

- Update to version 4.11.0beta
  + Bugfixes by Elias Oltmanns

-------------------------------------------------------------------
Sun Feb  9 19:55:20 UTC 2014 - jcnengel@gmail.com

- Update to version 4.10.0beta
  + Add functions for individual plugin paths for other libraries
- Create Fox16 GUI
- Move documentation to separate package to enable multi-version
  coexistence of the library

-------------------------------------------------------------------
Mon Jan  6 21:31:06 UTC 2014 - nico.kruber@gmail.com

- Update to version 4.9.0beta:
  + adds new code for cipher selection with SSL connections
    (still some problems with the Netbank, please report back)
  + Netbank works setting the GWEN_TLS_CIPHER_PRIORITIES
    environment variable to "NORMAL:-AES-256-CBC"

-------------------------------------------------------------------
Wed Oct 23 14:42:06 UTC 2013 - nico.kruber@gmail.com

- Update to version 4.8.0beta:
  + new functions to work with dates (module GWEN_DATE,
    e.g.  GWEN_Date_GetLastHalfYearStart())
  + fix some errors in the layout of the  FOX 1.6 GUI module.
  + some improvements in typemaker2. 

-------------------------------------------------------------------
Wed Aug 21 19:57:46 UTC 2013 - nico.kruber@gmail.com

- Update to version 4.7.0beta:
  + contains improvements if the TypeMaker2 tool
  + fixes an error linking libgpg-error.so
  + adds some functions to the GWEN_XML and GWEN_DATE modules
    used by the new AqBanking version 5.0.31beta
  + Info: this is still beta because the MULTICACHE module is
    still work in progress

-------------------------------------------------------------------
Sun Jun 23 11:09:55 UTC 2013 - nico.kruber@gmail.com

- Update to version 4.6.0beta:
  + adds a new module for cache handling and some widely used
    functionality
  + major (internal) improvements to typemaker2
  + complete German translation (thanks to Christian)
- Update to version 4.5.0beta:
  + adds some small changes for SEPA transactions needed by
    aqbanking

-------------------------------------------------------------------
Sat Mar  2 08:18:17 UTC 2013 - coolo@suse.com

- update license to new format

-------------------------------------------------------------------
Tue Jul  3 11:20:52 UTC 2012 - aj@suse.de

- Change lang package Requires to Recommends since it is not
  mandatory at runtime.

-------------------------------------------------------------------
Wed May  9 20:35:41 UTC 2012 - Nico.Laus.2001@gmx.de

- Update to version 4.3.3:
  + do not use the deprecated libgcrypt interface for RSA keys
    anymore (allows compilation with newer libgcrypt versions)

-------------------------------------------------------------------
Fri Mar  9 07:37:01 UTC 2012 - Nico.Laus.2001@gmx.de

- Update to version 4.3.2:
  + fixes network problems on Windows

-------------------------------------------------------------------
Mon Jan  2 20:35:40 UTC 2012 - Nico.Laus.2001@gmx.de

- included %{_datadir}/aclocal in the devel package

-------------------------------------------------------------------
Tue Dec 20 08:39:50 UTC 2011 - Nico.Laus.2001@gmx.de

- removed gwenhywfar-gnutls-3.0.3.patch (fixed upstream in 4.3.1)

-------------------------------------------------------------------
Mon Dec 19 23:11:41 UTC 2011 - Nico.Laus.2001@gmx.de

- Update to version 4.3.1:
  + this version is needed for AqBanking's new support for the
    optical chipTAN method
  + some improvements to the typemaker2 tool

-------------------------------------------------------------------
Wed Sep 28 08:41:14 UTC 2011 - vuntz@opensuse.org

- Add gwenhywfar-gnutls-3.0.3.patch: fix build with gnutls 3.0.3.

-------------------------------------------------------------------
Wed Sep 21 08:37:48 UTC 2011 - kruber@zib.de

- Update to version 4.3.0:
  + added a new method for converting charsets
  + better error handling in the build system

-------------------------------------------------------------------
Fri Aug 12 11:37:22 UTC 2011 - dimstar@opensuse.org

- Add GPL-2.0+ tag to the main package and the tools subpackage, as
  this is the correct license for the tools and related sources.
  See also bnc#710065.

-------------------------------------------------------------------
Tue Aug  2 09:33:34 CEST 2011 - dimstar@opensuse.org

- Update to version 4.2.1:
  + Make QLabel in GUI wrap words.
  + Relaxed http code.

-------------------------------------------------------------------
Sat Jul 16 04:14:05 CEST 2011 - malcolmlewis@opensuse.org

- Update to version 4.2.0:
  + Marked argument list of GWEN_StringList_new() as void.
  + Added keyword "void" to functions with empty argument list.
  + Let typemaker tools use "void" for empty argument lists in
    constructors.
  + Added field "CustomerId" to GWEN_Crypt_Token_Context.
  + Added function GWEN_DB_GetParentGroup().
  + Added line for "hasKeyNumber" flag.
  + Show customer if available.
  + Added some tm2 files to ignore list.
  + typemaker2: added type uint64_t.
  + Improved and fixed GWEN_TLV, added functions
    GWEN_TLV_ReadHeader() and GWEN_TLV_WriteHeader().
  + Started working on a simple archiver.
  + Fixed a few bugs in new TLV code.
  + Added tool "gsa" ("Gwen's simple archiver").
  + Improved HTTP handling:
    - added function GWEN_SyncIo_Http_RecvBodyToSio().
    - added function GWEN_HttpSession_RecvPacketToFile().
  + Added function GWEN_Directory_GetAbsoluteFolderPath().
  + Added convenience function GWEN_Sar_UnpackArchive().
  + Added code and commands to sign a sar archive.
  + Improved progress handling in network code.
  + Fixed GWEN_MDigest__HashFileTree().
  + Added missing include.
  + Various bug fixes and code cleanup.
- Update Url as Gwenhywfar is now being hosted at
  http://www.aqbanking.de/.
- Update spec file License field from LGPLv2.1+ to LGPL-2.1+ to
  conform with spdx.org identifier.
- Minor reformatting in spec file.
- Remove service usage, following the new consensus on Factory
  packaging.

-------------------------------------------------------------------
Sat Jun 11 21:02:36 UTC 2011 - Nico.Laus.2001@gmx.de

- Update to version 4.1.0:
  + new code for sorting any GWEN_LIST
  + some bug fixes

-------------------------------------------------------------------
Thu Mar 17 20:18:46 UTC 2011 - Nico.Laus.2001@gmx.de

- Update to version 4.0.9:
  + fixes a bug in the Qt4 frontend
  + fixes a bug in the LIST1 module
  + fixes xml file generation using the XMLDB module

-------------------------------------------------------------------
Sun Feb 20 12:24:52 UTC 2011 - Nico.Laus.2001@gmx.de

- Update to version 4.0.7:
  + fixes problems with smsTAN/mTAN
  + keep the focus chain intact in QT4 GUI
- Update to version 4.0.5:
  + fixes a bug with chunked HTTP

-------------------------------------------------------------------
Thu Jan 27 20:41:17 UTC 2011 - Nico.Laus.2001@gmx.de

- Update to version 4.0.4:
  + fixes a bug in the GTK2 front-end
  + fixes a bug in the network code on MaxOSX

-------------------------------------------------------------------
Sat Jan 15 09:50:16 UTC 2011 - Nico.Laus.2001@gmx.de

- Update to version 4.0.3:
  + improved error messages
  + several bug fixes

-------------------------------------------------------------------
Fri Dec 10 10:05:23 CET 2010 - vuntz@opensuse.org

- Update to version 4.0.2:
  + Fix GTK+ password entry.
  + Build fixes.
- Split libgwengui_gtk2-0 and libgwengui_qt4-0 subpackages, as we
  don't want libgwenhywfar60 to depend on both GTK+ and Qt.
- Add libgwengui-gtk2-0 and libgwengui-qt4-0 Requires to devel
  package.

-------------------------------------------------------------------
Thu Sep  2 20:30:28 UTC 2010 - dimstar@opensuse.org

- Update to version 4.0.1:
  + Fix gtk2 building for Windows
  + Improved HTTP handling.

-------------------------------------------------------------------
Thu Sep  2 10:27:29 CEST 2010 - dimstar@opensuse.org

- Update to version 4.0.0:
  + Gwenhywfar4 features a new XML-based platform and toolkit.
  + Independent dialog framework which is heavily used by
    AqBanking5.
  + Provide generic UI implementations for GTK-2, Qt-4, and
    FOX-1.6.
  + The network code has been rewritten and thereby changed from
    asynchronous to synchronous access to fix some strange timeout
    problems.
  + Many bugs and problems have been fixed.
- Add gtk2-devel and libqt4-devel BuildRequires.
- Follow the so bump of the library, change the library package
  name to from libgwenhywfar47 to libgwenhywfar60
- Remove Provides/Obsoletes of gwenhywfar$sover from
  libgwenhywfar$sover-plugins: it was there for upgrades of the old
  package.
- Pass --with-qt4-libs=%{_libdir} to configure.
- Use _smp_mflags.

-------------------------------------------------------------------
Sat Jan  2 16:17:01 CET 2010 - vuntz@opensuse.org

- Update to version 3.11.3:
  + GWEN_DB: Escape and unescape group names upon read/write,
    respectively.
  + Show a more informative erro message when a false chipcard has
    been inserted.
- Changes from version 3.11.2:
  + Add unittest for GWEN_Url_fromString that checks those cases
    that work.
  + Do not abort on unknown port number.
  + Improve error messages.
  + Check for NULL token name before crashing in FSLock_new so that
    a more clear error message is printed instead.
  + Decrease debug level of non-critical info message.
  + Improved handling of file/directory locks on POSIX systems.
  + Windows fixes.
  + Build system fixes.

-------------------------------------------------------------------
Tue Dec 15 14:55:58 CET 2009 - vuntz@opensuse.org

- Remove unneeded libxml2-devel BuildRequires.
- Remove autoreconf call since we have no patch.
- Rework the install section to be more readable.
- Rename gwenhywfar47 to libgwenhywfar47-plugins, since it's a more
  appropriate name. Add Provides/Obsoletes for the old package.
- Make libgwenhywfar47 recommends the libgwenhywfar47-plugins
  package. Also remove any Requires/Recommends from the main
  package to libgwenhywfar47-plugins or gwenhywfar47 since
  libgwenhywfar47 should be enough.
- Rename the main package to gwenhywfar-tools and move some tools
  from devel subpackage there.
- Split a lang package, that is required by the library package,
  and make the library package now provide gwenhywfar to make the
  lang package installable.

-------------------------------------------------------------------
Sun Dec  1 22:00:00 CET 2009 - Nico.Laus.2001@gmx.de

- Update to version 3.11.1:
  + compile on windows
- Changes from version 3.11.0:
  + fixes some minor bugs
  + extended the HTTP session module to allow testing connections
    (used by the AqBanking-EBICS module to download new
    certificates)
  + special support for statistical modules has been removed again
    to simplify the build system
- Changes from version 3.10.1:
  + fixes a bug in GWEN_Url_fromString() and supports username and
    password with HTTP proxies (tested with squid2)
  + fixed a problem on MacOSX
- Changes from version 3.10.0
  + adds new support for RDH-10
  + includes the tool typemaker2, an improved version of the old
    typemaker which includes support for AqFinance
  + added the data type GWEN_DATE which is now used by AqFinance
    instead of GWEN_TIME when only a date is required instead of a
    full timestamp

-------------------------------------------------------------------
Mon Oct 12 02:02:57 UTC 2009 - crrodriguez@opensuse.org

- fix dependencies (was using >= instead of =)

-------------------------------------------------------------------
Thu Sep  3 16:05:28 CEST 2009 - sbrabec@suse.cz

- Typo fix in dependencies.

-------------------------------------------------------------------
Fri Aug 14 17:34:35 CEST 2009 - sbrabec@suse.cz

- Split package to allow parrallel installation of more versions.

-------------------------------------------------------------------
Wed Jun 24 19:35:29 CEST 2009 - mkudlvasr@suse.cz

- update to version 3.8.3
  * lots of bugs fixed, lots of new features
- removed patch0 (tests/gwenhywfar.c). not needed anymore

-------------------------------------------------------------------
Thu Jan 24 11:32:18 CET 2008 - coolo@suse.de

- fixing open call

-------------------------------------------------------------------
Fri Nov  9 06:17:34 CET 2007 - crrodriguez@suse.de

- update to version 2.6.2
  * Release is only interesting for windows or NetBSD users
- disable static libraries
- remove "la" files
- remove unnedded dependency on libopenssl-devel in the -devel package

-------------------------------------------------------------------
Fri Jul 27 12:55:13 CEST 2007 - sbrabec@suse.cz

- Updated to version 2.6.1:
  * Minor bugs have been fixed.
  * Cross-compiling is now supported.
  * Some missing list functions have been added.
  * Decreases the verbosity.
  * Makes gwenhywfar completely relocatable using binreloc.
- Split package according to shared library packaging policy.
- Build with libxml2.
- Build and create api docs.

-------------------------------------------------------------------
Mon Oct  2 18:05:46 CEST 2006 - sbrabec@suse.cz

- Updated to version 2.4.1:
  * bug fixes
  * removed debugging messages
  * clean up the API

-------------------------------------------------------------------
Fri Sep 15 23:56:04 CEST 2006 - jhargadon@suse.de

- update to version 2.4.0
- This release adds GWEN_DBIO plugin which writes GWEN_DB's as XML files 

-------------------------------------------------------------------
Tue Jun 20 09:10:57 CEST 2006 - stbinner@suse.de

- Update to version 2.3.0:
   * Adds a new module for fast lookup of objects via integer IDs. 
   * Adds a storage module to be used by further projects.

-------------------------------------------------------------------
Thu May 11 13:56:26 CEST 2006 - sbrabec@suse.cz

- Updated to version 2.2.0.

-------------------------------------------------------------------
Wed Jan 25 21:36:24 CET 2006 - mls@suse.de

- converted neededforbuild to BuildRequires

-------------------------------------------------------------------
Mon Jan 16 19:02:19 CET 2006 - sbrabec@suse.cz

- Updated to version 1.19.2.

-------------------------------------------------------------------
Wed Oct 19 16:34:46 CEST 2005 - sbrabec@suse.cz

- New SuSE package, version 1.18.0.
  Based on spec file from Rajesh Singh <rajeshsingh.geo@yahoo.com>.