File php7-systemd-0.1.2-fix-outdated-build-config.patch of Package php7-systemd

From: Matthias Fehring <buschmann23@opensuse.org>
Date: 2018-09-13 09:52:00 +0200
Subject: Fixes outdated build config
Upstream: merged

Fixes outdated build config

---
 config.m4 |    6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

--- a/config.m4	2014-03-07 21:05:05.000000000 +0100
+++ b/config.m4	2018-09-13 09:49:14.841160777 +0200
@@ -5,7 +5,7 @@
 if test "$PHP_SYSTEMD" != "no"; then
 
   SEARCH_PATH="/usr /usr/local"
-  SEARCH_FOR="/include/sd-journal.h"
+  SEARCH_FOR="/include/systemd/sd-journal.h"
 
   SYSTEMD_DIR=
 
@@ -32,7 +32,7 @@
 
   PHP_ADD_INCLUDE($SYSTEMD_DIR/include)
 
-  LIBNAME=systemd-journal
+  LIBNAME=systemd
   LIBSYMBOL=sd_journal_sendv
 
   if test "x$PHP_LIBDIR" = "x"; then
@@ -45,7 +45,7 @@
   ],[
     AC_MSG_ERROR([wrong systemd version {44.+ is required} or lib not found])
   ],[
-    -L$SYSTEMD_DIR/$PHP_LIBDIR 
+    -L$SYSTEMD_DIR/$PHP_LIBDIR
   ])
 
   PHP_ADD_EXTENSION_DEP(systemd, sockets, true)