A new user interface for you! Read more...

File rubygem-bundler.changes of Package rubygem-bundler

-------------------------------------------------------------------
Tue Jun 19 10:05:00 UTC 2012 - gebhardt@pre-sense.de

- upgrade to 1.1.3

-------------------------------------------------------------------
Tue Apr 24 10:27:00 UTC 2012 - gebhardt@pre-sense.de

- downgrade to 1.0.21

-------------------------------------------------------------------
Wed Apr  4 15:43:11 UTC 2012 - coolo@suse.com

- update to 1.1.3, see CHANGELOG.md

-------------------------------------------------------------------
Fri Mar 23 11:21:49 UTC 2012 - saschpe@suse.de

- Spec file cleanup:
  * Factory preparation

-------------------------------------------------------------------
Thu Nov  3 16:13:56 UTC 2011 - mrueckert@suse.de

- update to 1.0.21 (bnc#727772)
  - Load Psych unless Syck is defined, because 1.9.2 defines YAML
  - Add platform :maglev (@timfel, #1444)
  - Ensure YAML is required even if Psych is found
  - Handle directory names that contain invalid regex characters
  - Rescue interrupts to `bundle` while loading bundler.rb (#1395)
  - Allow clearing without groups by passing `--without ''` (#1259)
  - Manually sort requirements in the lockfile (#1375)
  - Remove several warnings generated by ruby -w (@stephencelis)
  - Handle trailing slashes on names passed to `gem` (#1372)
  - Name modules for gems like 'test-foo_bar' correctly (#1303)
  - Don't require Psych if Syck is already loaded (#1239)
  - Compatability with Rubygems 1.8.10 installer changes
  - Report gem installation failures clearly (@rwilcox, #1380)
  - Useful error for cap and vlad on first deploy (@nexmat, @kirs)
  - `exec` now works when the command contains 'exec'
  - Only touch lock after changes on Windows (@robertwahler, #1358)
  - Keep load paths when #setup is called multiple times (@radsaq,
    #1379)
  - Fix typo in DEBUG_RESOLVER (@geemus)
  - Fixes rake 0.9.x warning (@mtylty, #1333)
  - Fix `bundle cache` again for rubygems 1.3.x
  - Run the bundle install earlier in a Capistrano deployment
    (@cgriego, #1300)
  - Support hidden gemspec (@trans, @cldwalker, #827)
  - Make fetch_specs faster (@zeha, #1294)
  - Allow overriding development deps loaded by #gemspec (@lgierth,
    #1245)
  - Fix rake issues with rubygems 1.3.x (#1342)
  - Fixed invalid byte sequence error while installing gem on Ruby
    1.9 (#1341)
  - Performance fix for MRI 1.9 (@efficientcloud, #1288)
  - Shortcuts (like `bundle i`) for all commands (@amatsuda)
  - Correcly identify missing child dependency in error message
  - Allow Windows network share paths with forward slashes
    (@mtscout6, #1253)
  - Check for rubygems.org credentials so `rake release` doesn't
    hang (#980)
  - Find cached prerelease gems on rubygems 1.3.x (@dburt, #1202)
  - Fix `bundle install --without` on kiji (@tmm1, #1287)
  - Get rid of warning in ruby 1.9.3 (@smartinez87, #1231)
  - Documentation for `gem ..., :require => false` (@kmayer, #1292)
  - Gems provide "executables", they are rarely also binaries
    (@fxn, #1242)

-------------------------------------------------------------------
Tue Aug 16 12:40:35 UTC 2011 - mrueckert@suse.de

- change license header to list MIT and Ruby (bnc#712391)

-------------------------------------------------------------------
Wed Jul 20 20:17:13 UTC 2011 - mrueckert@suse.de

- update to 1.0.15
  - Improved Rubygems integration, removed many deprecation notices
  - Escape URL arguments to git correctly on Windows (1.0.14
    regression)
- additional changes from 1.0.14
  - Rubinius platform :rbx (@rkbodenner)
  - Include gem rake tasks with "require 'bundler/gem_tasks"
    (@indirect)
  - Include user name and email from git config in new gemspec
    (@ognevsky)
  - Set file permissions after checking out git repos (@tissak)
  - Remove deprecated call to Gem::SourceIndex#all_gems (@mpj)
  - Require the version file in new gemspecs (@rubiii)
  - Allow relative paths from the Gemfile in gems with no gemspec
    (@mbirk)
  - Install gems that contain 'bundler', e.g. guard-bundler (@hone)
  - Display installed path correctly on Windows (@tadman)
  - Escape quotes in git URIs (@mheffner)
  - Improve Rake 0.9 support (@quix)
  - Handle certain directories already existing (@raggi)
  - Escape filenames containing regex characters (@indirect)
- additional changes from 1.0.13
  - Compatibility with Rubygems master (soon to be v1.8) (@evanphx)
  - Informative error when --path points to a broken symlink
  - Support Rake 0.9 and greater (@e2)
  - Output full errors for non-TTYs e.g. pow (@josh)
  - Allow spaces in gem path names for gem tasks (@rslifka)
  - Have cap run bundle install from release_path (@martinjagusch)
  - Quote git refspec so zsh doesn't expand it (@goneflyin)
- additional changes from 1.0.12
  - Add --no-deployment option to `install` for disabling it on dev
    machines
  - Better error message when git fails and cache is present
    (@parndt)
  - Honor :bundle_cmd in cap `rake` command (@voidlock, @cgriego)
  - Compatibility with Rubygems 1.7 and Rails 2.3 and vendored gems
    (@evanphx)
  - Fix changing gem order in lock (@gucki)
  - Remove color escape sequences when displaying man pages
    (@bgreenlee)
  - Fix creating GEM_HOME on both JRuby 1.5 and 1.6 (@nickseiger)
  - Fix gems without a gemspec and directories in bin/ (@epall)
  - Fix --no-prune option for `bundle install` (@cmeiklejohn)
- additional changes from 1.0.11
  - Compatibility with Rubygems 1.6 and 1.7
  - Better error messages when a git command fails
  - Don't always update gemspec gems (@carllerche)
  - Remove ivar warnings (@jackdempsey)
  - Fix occasional git failures in zsh (@jonah-carbonfive)
  - Consistent lock for gems with double deps like Cap (@akahn)

-------------------------------------------------------------------
Thu Feb  3 10:27:51 UTC 2011 - dmacvicar@suse.de

- update to 1.0.10
  - Fix a regression loading YAML gemspecs from :git and :path gems
  - Requires, namespaces, etc. to work with changes in Rubygems 1.5
- update to 1.0.9
  - Fix a bug where Bundler.require could remove gems from the load
    path.
    In Rails apps with a default application.rb, this removed all
    gems in groups other than :default and Rails.env.
- update to 1.0.8
  - Allow overriding gemspec() deps with :git deps
  - Add --local option to bundle update
  - Ignore Gemfile.lock in newly generated gems
  - Use less as help pager instead of more
  - Run bundle exec rake instead of rake in Capistrano tasks
  - Fix --no-cache option for bundle install
  - Allow Vlad deploys to work without Capistrano gem installed
  - Fix group arguments to bundle console
  - Allow groups to be loaded even if other groups were loaded
  - Evaluate gemspec() gemspecs in their directory not the cwd
  - Count on Rake to chdir to the right place in GemHelper
  - Change Pathnames to Strings for MacRuby
  - Check git process exit status correctly
  - Fix some warnings in 1.9.3-trunk (thanks tenderlove)

-------------------------------------------------------------------
Thu Nov 18 17:51:59 UTC 2010 - mrueckert@suse.de

- update to 1.0.7
  - Remove Bundler version from the lockfile because it broke
    backwards compatibility with 1.0.0-1.0.5. Sorry. :(
- update to 1.0.6
  - Fix regression in `update` that caused long/wrong results
  - Allow git gems on other platforms while installing (#579)
  - Speed up `install` command using various optimizations
  - Significantly increase performance of resolver
  - Use upcoming Rubygems performance improvements (@tmm1)
  - Warn if the lockfile was generated by a newer version
  - Set generated gems' homepage to "", so Rubygems will warn
- update to 1.0.5
  - Fix regression disabling all operations that employ sudo
- update to 1.0.4
  - Expand relative :paths from Bundler.root (eg ./foogem)
  - Allow git gems in --without groups while --frozen
  - Allow gem :ref to be a symbol as well as a string
  - Fix exception when Gemfile needs a newer Bundler version
  - Explanation when the current Bundler version conflicts
  - Explicit error message if Gemfile needs newer Bundler
  - Ignore an empty string BUNDLE_GEMFILE
  - Skeleton gemspec now works with older versions of git
  - Fix shell quoting and ref fetching in GemHelper
  - Disable colored output in --deployment
  - Preserve line endings in lock file
  - Add support for 'mingw32' platform (aka RubyInstaller)
  - Large speed increase when Gemfile.lock is already present
  - Huge speed increase when many (100+) system gems are present
  - Significant expansion of ISSUES, man pages, and docs site
  - Remove Open3 from GemHelper (now it works on Windows™®©)
  - Allow setting roles in built-in cap and vlad tasks

-------------------------------------------------------------------
Thu Nov 11 15:41:03 UTC 2010 - mrueckert@suse.de

- update to 1.0.3

-------------------------------------------------------------------
Mon Aug 30 13:53:32 UTC 2010 - dmacvicar@novell.com

- update to 1.0.0

-------------------------------------------------------------------
Tue Aug  3 22:05:29 UTC 2010 - dmacvicar@novell.com

- update to 1.0rc2

-------------------------------------------------------------------
Thu Jun 10 15:59:37 UTC 2010 - mrueckert@suse.de

- update to version 0.9.26
  - error nicely on incompatible 0.10 lockfiles

-------------------------------------------------------------------
Fri May 14 16:08:56 UTC 2010 - dmacvicar@novell.com

- update to 0.9.25
  - explicitly coerce Pathname objects to Strings for Ruby 1.9
  - fix some newline weirdness in output from install command

-------------------------------------------------------------------
Thu Feb 18 18:39:07 UTC 2010 - mrueckert@suse.de

- update to 0.9.7

-------------------------------------------------------------------
Thu Feb 11 08:47:04 UTC 2010 - dmacvicar@novell.com

- update to 0.9.4

-------------------------------------------------------------------
Thu Feb  4 11:37:21 UTC 2010 - dmacvicar@novell.com

- update to 0.9.1

-------------------------------------------------------------------
Fri Jan 15 14:31:18 UTC 2010 - mrueckert@suse.de

- initial package. used for rails 3