File yum-HEAD.patch of Package yum

diff --git a/cli.py b/cli.py
index ff4c7d6..e3a4161 100644
--- a/cli.py
+++ b/cli.py
@@ -398,6 +398,8 @@ class YumBaseCli(yum.YumBase, output.YumOutput):
         if self.gpgsigcheck(downloadpkgs) != 0:
             return 1
         
+        self.verbose_logger.log(yum.logginglevels.INFO_2, 
+                                self.fmtSection(_("Entering rpm code")))
         if self.conf.rpm_check_debug:
             rcd_st = time.time()
             self.verbose_logger.log(yum.logginglevels.INFO_2, 
@@ -408,7 +410,7 @@ class YumBaseCli(yum.YumBase, output.YumOutput):
                 for msg in msgs:
                     print to_utf8(msg)
     
-                return 1, [_('Please report this error in bugzilla')]
+                return 1, [_('Please report this error in %s') % self.conf.bugtracker_url]
 
             self.verbose_logger.debug('rpm_check_debug time: %0.3f' % (time.time() - rcd_st))
 
@@ -464,6 +466,8 @@ class YumBaseCli(yum.YumBase, output.YumOutput):
         resultobject = self.runTransaction(cb=cb)
 
         self.verbose_logger.debug('Transaction time: %0.3f' % (time.time() - ts_st))
+        self.verbose_logger.log(yum.logginglevels.INFO_2, 
+                                self.fmtSection(_("Leaving rpm code")))
         # close things
         self.verbose_logger.log(yum.logginglevels.INFO_1,
             self.postTransactionOutput())
@@ -519,8 +523,9 @@ class YumBaseCli(yum.YumBase, output.YumOutput):
         # always_output is a wart due to update/remove not producing the
         # same output.
         matches = self.doPackageLists(patterns=[arg], ignore_case=False)
-        if matches.installed: # Found a match so ignore
-            return
+        if (matches.installed or (not matches.available and
+                                  self.returnInstalledPackagesByDep(arg))):
+            return # Found a match so ignore
         hibeg = self.term.MODE['bold']
         hiend = self.term.MODE['normal']
         if matches.available:
@@ -657,7 +662,7 @@ class YumBaseCli(yum.YumBase, output.YumOutput):
             return 2, [_('Package(s) to install')]
         return 0, [_('Nothing to do')]
 
-    def returnPkgLists(self, extcmds):
+    def returnPkgLists(self, extcmds, installed_available=False):
         """Returns packages lists based on arguments on the cli.returns a 
            GenericHolder instance with the following lists defined:
            available = list of packageObjects
@@ -666,18 +671,32 @@ class YumBaseCli(yum.YumBase, output.YumOutput):
            extras = list of packageObjects
            obsoletes = tuples of packageObjects (obsoleting, installed)
            recent = list of packageObjects
+
+           installed_available = that the available package list is present
+                                 as .hidden_available when doing any of:
+                                 all/available/installed
            """
         
         special = ['available', 'installed', 'all', 'extras', 'updates', 'recent',
                    'obsoletes']
         
         pkgnarrow = 'all'
+        done_hidden_available = False
+        done_hidden_installed = False
         if len(extcmds) > 0:
-            if extcmds[0] in special:
+            if installed_available and extcmds[0] == 'installed':
+                done_hidden_available = True
+                extcmds.pop(0)
+            elif installed_available and extcmds[0] == 'available':
+                done_hidden_installed = True
+                extcmds.pop(0)
+            elif extcmds[0] in special:
                 pkgnarrow = extcmds.pop(0)
             
         ypl = self.doPackageLists(pkgnarrow=pkgnarrow, patterns=extcmds,
                                   ignore_case=True)
+        if self.conf.showdupesfromrepos:
+            ypl.available += ypl.reinstall_available
 
         # This is mostly leftover from when patterns didn't exist
         # FIXME: However when returnPackages() has already been run, we
@@ -699,6 +718,13 @@ class YumBaseCli(yum.YumBase, output.YumOutput):
         ypl.extras = _shrinklist(ypl.extras, extcmds)
         ypl.obsoletes = _shrinklist(ypl.obsoletes, extcmds)
         
+        if installed_available:
+            ypl.hidden_available = ypl.available
+            ypl.hidden_installed = ypl.installed
+        if done_hidden_available:
+            ypl.available = []
+        if done_hidden_installed:
+            ypl.installed = []
         return ypl
 
     def search(self, args):
@@ -843,8 +869,12 @@ class YumBaseCli(yum.YumBase, output.YumOutput):
         if len(userlist) > 0:
             if userlist[0] == 'hidden':
                 uservisible=0
+                userlist.pop(0)
+        if not userlist:
+            userlist = None # Match everything...
 
-        installed, available = self.doGroupLists(uservisible=uservisible)
+        installed, available = self.doGroupLists(uservisible=uservisible,
+                                                 patterns=userlist)
         
         if len(installed) > 0:
             self.verbose_logger.log(yum.logginglevels.INFO_2,
@@ -1079,6 +1109,22 @@ class YumOptionParser(OptionParser):
             if opts.showdupesfromrepos:
                 self.base.conf.showdupesfromrepos = True
 
+            if opts.color not in (None, 'auto', 'always', 'never',
+                                  'tty', 'if-tty', 'yes', 'no', 'on', 'off'):
+                raise ValueError, _("--color takes one of: auto, always, never")
+            elif opts.color is None:
+                if self.base.conf.color != 'auto':
+                    self.base.term.reinit(color=self.base.conf.color)
+            else:
+                _remap = {'tty' : 'auto', 'if-tty' : 'auto',
+                          '1' : 'always', 'true' : 'always',
+                          'yes' : 'always', 'on' : 'always',
+                          '0' : 'always', 'false' : 'always',
+                          'no' : 'never', 'off' : 'never'}
+                opts.color = _remap.get(opts.color, opts.color)
+                if opts.color != 'auto':
+                    self.base.term.reinit(color=opts.color)
+
             if opts.disableexcludes:
                 disable_excludes = self._splitArg(opts.disableexcludes)
             else:
@@ -1224,6 +1270,8 @@ class YumOptionParser(OptionParser):
                 metavar='[plugin]')
         self.add_option("--skip-broken", action="store_true", dest="skipbroken",
                 help=_("skip packages with depsolving problems"))
+        self.add_option("", "--color", dest="color", default=None, 
+                help=_("control whether color is used"))
 
 
         
diff --git a/docs/yum.8 b/docs/yum.8
index 4ebd19d..e31ce0f 100644
--- a/docs/yum.8
+++ b/docs/yum.8
@@ -87,7 +87,8 @@ will ensure that all dependencies are satisfied\&.  If no package
 matches the given package name(s), they are assumed to be a shell glob
 and any matches are then installed\&. 
 
-If the \-\-obsoletes flag is present \fByum\fP will include package 
+If the main obsoletes configure option is true (default) or the \-\-obsoletes
+flag is present \fByum\fP will include package 
 obsoletes in its calculations - this makes it better for distro\-version 
 changes, for example: upgrading from somelinux 8.0 to somelinux 9.
 .IP 
@@ -97,6 +98,7 @@ be applied without running it interactively. Returns exit value of 100 if
 there are packages available for an update. Also returns a list of the pkgs
 to be updated in list format. Returns 0 if no packages are available for
 update. Returns 1 if an error occured.
+Running in verbose mode also shows obsoletes.
 .IP
 .IP "\fBupgrade\fP"
 Is the same as the update command with the \-\-obsoletes flag set. See update 
@@ -262,6 +264,11 @@ Configuration Option: \fBobsoletes\fP
 Exclude a specific package by name or glob from updates on all repositories.
 Configuration Option: \fBexclude\fP
 .br
+.IP "\fB\-\-color=[always|auto|never]\fP"
+Display colorized output automatically, depending on the output terminal,
+always (using ANSI codes) or never.
+Configuration Option: \fBcolor\fP
+.br
 .IP "\fB\-\-disableexcludes=[all|main|repoid]\fP"
 Disable the excludes defined in your config files. Takes one of three options:
 .br
diff --git a/docs/yum.conf.5 b/docs/yum.conf.5
index 40148a6..15462b7 100644
--- a/docs/yum.conf.5
+++ b/docs/yum.conf.5
@@ -124,6 +124,7 @@ Default is `0'.
 This option only has affect during an \fBupdate\fR. It enables yum's
 obsoletes processing logic. Useful when doing distribution level upgrades. See
 also the yum \fBupgrade\fR command documentation for more details (yum(8)).
+Default is `true'.
 .br
 Command-line option: \fB\-\-obsoletes\fP
 
@@ -305,6 +306,59 @@ Can be set to 'all' or 'best'. All means install all possible arches for any pac
 want to install. Therefore yum install foo will install foo.i386 and foo.x86_64 on x86_64, 
 if it is available. Best means install the best arch for this platform, only.
 
+.IP \fBbugtracker_url \fR
+Url where bugs should be filed for yum. Configurable for local versions or distro-specific
+bugtrackers.
+
+.IP \fBcolor \fR
+Display colorized output automatically, depending on the output terminal,
+always (using ANSI codes) or never.
+Command-line option: \fB\-\-color\fP
+
+.IP \fBcolor_list_installed_older \fR
+The colorization/highlighting for pacakges in list/info installed which are
+older than the latest available package with the same name and arch.
+Default is `bold'.
+Possible values are a comma seperated list containing: bold, blink, dim,
+reverse, underline, fg:black, fg:red, fg:green, fg:yellow, fg:blue, fg:magenta,
+fg:cyan, fg:white, bg:black, bg:red, bg:green, bg:yellow, bg:blue, bg:magenta,
+bg:cyan, bg:white.
+
+.IP \fBcolor_list_installed_newer \fR
+The colorization/highlighting for pacakges in list/info installed which are
+newer than the latest available package with the same name and arch.
+Default is `bold,yellow'.
+See color_list_installed_older for possible values.
+
+.IP \fBcolor_list_installed_extra \fR
+The colorization/highlighting for pacakges in list/info installed which has
+no available package with the same name and arch.
+Default is `bold,red'.
+See color_list_installed_older for possible values.
+
+.IP \fBcolor_list_available_upgrade \fR
+The colorization/highlighting for pacakges in list/info available which is
+an upgrade for the latest installed package with the same name and arch.
+Default is `bold,blue'.
+See color_list_installed_older for possible values.
+
+.IP \fBcolor_list_available_downgrade \fR
+The colorization/highlighting for pacakges in list/info available which is
+a downgrade for the latest installed package with the same name and arch.
+Default is `dim,cyan'.
+See color_list_installed_older for possible values.
+
+.IP \fBcolor_list_available_install \fR
+The colorization/highlighting for pacakges in list/info available which has
+no installed package with the same name and arch.
+Default is `normal'.
+See color_list_installed_older for possible values.
+
+.IP \fBcolor_search_match \fR
+The colorization/highlighting for text matches in search.
+Default is `bold'.
+See color_list_installed_older for possible values.
+
 .SH "[repository] OPTIONS"
 .LP 
 The repository section(s) take the following form:
diff --git a/output.py b/output.py
old mode 100644
new mode 100755
index 502aa4b..3416459
--- a/output.py
+++ b/output.py
@@ -38,7 +38,7 @@ from yum import logginglevels, _
 from yum.rpmtrans import RPMBaseCallback
 from yum.packageSack import packagesNewestByNameArch
 
-from textwrap import fill
+from yum.i18n import utf8_width, utf8_width_fill, utf8_text_fill
 
 def _term_width():
     """ Simple terminal width, limit to 20 chars. and make 0 == 80. """
@@ -75,42 +75,7 @@ class YumTerm:
     __enabled = True
 
     if hasattr(urlgrabber.progress, 'terminal_width_cached'):
-        columns = property(lambda self: _term_width())
-    else:
-        columns = 80
-    lines   = 24
-    # Output modes:
-    MODE = {
-        'bold' : '',
-        'blink' : '',
-        'dim' : '',
-        'reverse' : '',
-        'underline' : '',
-        'normal' : ''
-        }
-
-    # Colours
-    FG_COLOR = {
-        'black' : '',
-        'blue' : '',
-        'green' : '',
-        'cyan' : '',
-        'red' : '',
-        'magenta' : '',
-        'yellow' : '',
-        'white' : ''
-        }
-
-    BG_COLOR = {
-        'black' : '',
-        'blue' : '',
-        'green' : '',
-        'cyan' : '',
-        'red' : '',
-        'magenta' : '',
-        'yellow' : '',
-        'white' : ''
-        }
+        __auto_columns = property(lambda self: _term_width())
 
     __cap_names = {
         'underline' : 'smul',
@@ -138,8 +103,90 @@ class YumTerm:
         'cyan' : 6,
         'white' : 7
         }
+    __ansi_forced_MODE = {
+        'bold' : '\x1b[1m',
+        'blink' : '\x1b[5m',
+        'dim' : '',
+        'reverse' : '\x1b[7m',
+        'underline' : '\x1b[4m',
+        'normal' : '\x1b(B\x1b[m'
+        }
+    __ansi_forced_FG_COLOR = {
+        'black' : '\x1b[30m',
+        'red' : '\x1b[31m',
+        'green' : '\x1b[32m',
+        'yellow' : '\x1b[33m',
+        'blue' : '\x1b[34m',
+        'magenta' : '\x1b[35m',
+        'cyan' : '\x1b[36m',
+        'white' : '\x1b[37m'
+        }
+    __ansi_forced_BG_COLOR = {
+        'black' : '\x1b[40m',
+        'red' : '\x1b[41m',
+        'green' : '\x1b[42m',
+        'yellow' : '\x1b[43m',
+        'blue' : '\x1b[44m',
+        'magenta' : '\x1b[45m',
+        'cyan' : '\x1b[46m',
+        'white' : '\x1b[47m'
+        }
+
+    def __forced_init(self):
+        self.MODE = self.__ansi_forced_MODE
+        self.FG_COLOR = self.__ansi_forced_FG_COLOR
+        self.BG_COLOR = self.__ansi_forced_BG_COLOR
+
+    def reinit(self, term_stream=None, color='auto'):
+        if color == 'never':
+            self.__enabled = False
+            return
+
+        self.__enabled = True
+        if hasattr(urlgrabber.progress, 'terminal_width_cached'):
+            self.columns = self.__auto_columns
+        else:
+            self.columns = 80
+        self.lines = 24
+
+        if color == 'always':
+            self.__forced_init()
+            return
+        assert color == 'auto'
+
+        # Output modes:
+        self.MODE = {
+            'bold' : '',
+            'blink' : '',
+            'dim' : '',
+            'reverse' : '',
+            'underline' : '',
+            'normal' : ''
+            }
+
+        # Colours
+        self.FG_COLOR = {
+            'black' : '',
+            'blue' : '',
+            'green' : '',
+            'cyan' : '',
+            'red' : '',
+            'magenta' : '',
+            'yellow' : '',
+            'white' : ''
+            }
+
+        self.BG_COLOR = {
+            'black' : '',
+            'blue' : '',
+            'green' : '',
+            'cyan' : '',
+            'red' : '',
+            'magenta' : '',
+            'yellow' : '',
+            'white' : ''
+            }
 
-    def __init__(self, term_stream=None):
         # Curses isn't available on all platforms
         try:
             import curses
@@ -165,7 +212,7 @@ class YumTerm:
 
         if not hasattr(urlgrabber.progress, 'terminal_width_cached'):
             self.columns = curses.tigetnum('cols')
-        self.lines   = curses.tigetnum('lines')
+        self.lines = curses.tigetnum('lines')
         
         # Look up string capabilities.
         for cap_name in self.MODE:
@@ -192,6 +239,9 @@ class YumTerm:
             for (color, val) in self.__ansi_colors.items():
                 self.BG_COLOR[color] = curses.tparm(set_bg_ansi, val) or ''
 
+    def __init__(self, term_stream=None, color='auto'):
+        self.reinit(term_stream, color)
+
     def _tigetstr(self, cap_name):
         # String capabilities can include "delays" of the form "$<2>".
         # For any modern terminal, we should be able to just ignore
@@ -199,7 +249,7 @@ class YumTerm:
         cap = self._ctigetstr(cap_name) or ''
         return re.sub(r'\$<\d+>[/*]?', '', cap)
 
-    def sub(self, haystack, beg, end, needles, escape=None):
+    def sub(self, haystack, beg, end, needles, escape=None, ignore_case=False):
         if not self.__enabled:
             return haystack
 
@@ -208,7 +258,10 @@ class YumTerm:
 
         render = lambda match: beg + match.group() + end
         for needle in needles:
-            haystack = re.sub(escape(needle), render, haystack)
+            pat = escape(needle)
+            if ignore_case:
+                pat = re.template(pat, re.I)
+            haystack = re.sub(pat, render, haystack)
         return haystack
     def sub_norm(self, haystack, beg, needles, **kwds):
         return self.sub(haystack, beg, self.MODE['normal'], needles, **kwds)
@@ -217,7 +270,7 @@ class YumTerm:
         return self.sub_norm(haystack, self.MODE[mode], needles, **kwds)
 
     def sub_bold(self, haystack, needles, **kwds):
-        return self.sub_mode(haystack, 'bold', needles)
+        return self.sub_mode(haystack, 'bold', needles, **kwds)
     
     def sub_fg(self, haystack, color, needles, **kwds):
         return self.sub_norm(haystack, self.FG_COLOR[color], needles, **kwds)
@@ -263,14 +316,39 @@ class YumOutput:
         progressbar(current, total, name)
 
     def _highlight(self, highlight):
-        if highlight:
+        hibeg = ''
+        hiend = ''
+        if not highlight:
+            pass
+        elif not isinstance(highlight, basestring) or highlight == 'bold':
             hibeg = self.term.MODE['bold']
-            hiend = self.term.MODE['normal']
+        elif highlight == 'normal':
+            pass # Minor opt.
         else:
-            hibeg = ''
-            hiend = ''
+            # Turn a string into a specific output: colour, bold, etc.
+            for high in highlight.replace(',', ' ').split():
+                if False: pass
+                elif high == 'normal':
+                    hibeg = ''
+                elif high in self.term.MODE:
+                    hibeg += self.term.MODE[high]
+                elif high in self.term.FG_COLOR:
+                    hibeg += self.term.FG_COLOR[high]
+                elif (high.startswith('fg:') and
+                      high[3:] in self.term.FG_COLOR):
+                    hibeg += self.term.FG_COLOR[high[3:]]
+                elif (high.startswith('bg:') and
+                      high[3:] in self.term.BG_COLOR):
+                    hibeg += self.term.BG_COLOR[high[3:]]
+
+        if hibeg:
+            hiend = self.term.MODE['normal']
         return (hibeg, hiend)
 
+    def _sub_highlight(self, haystack, highlight, needles, **kwds):
+        hibeg, hiend = self._highlight(highlight)
+        return self.term.sub(haystack, hibeg, hiend, needles, **kwds)
+
     @staticmethod
     def _calc_columns_spaces_helps(current, data_tups, left):
         """ Spaces left on the current field will help how many pkgs? """
@@ -299,7 +377,7 @@ class YumOutput:
         if columns is None:
             columns = [1] * cols
 
-        total_width -= (sum(columns) + (cols - 1) + len(indent))
+        total_width -= (sum(columns) + (cols - 1) + utf8_width(indent))
         while total_width > 0:
             # Find which field all the spaces left will help best
             helps = 0
@@ -339,28 +417,45 @@ class YumOutput:
             return (u"-", -width)
         return (u"", width)
 
+    def _col_data(self, col_data):
+        assert len(col_data) == 2 or len(col_data) == 3
+        if len(col_data) == 2:
+            (val, width) = col_data
+            hibeg = hiend = ''
+        if len(col_data) == 3:
+            (val, width, highlight) = col_data
+            (hibeg, hiend) = self._highlight(highlight)
+        return (val, width, hibeg, hiend)
+
     def fmtColumns(self, columns, msg=u'', end=u''):
         """ Return a string for columns of data, which can overflow."""
 
         total_width = len(msg)
         data = []
-        for (val, width) in columns[:-1]:
+        for col_data in columns[:-1]:
+            (val, width, hibeg, hiend) = self._col_data(col_data)
+
             if not width: # Don't count this column, invisible text
                 msg += u"%s"
                 data.append(val)
                 continue
 
             (align, width) = self._fmt_column_align_width(width)
-            if len(val) <= width:
-                msg += u"%%%s%ds " % (align, width)
+            if utf8_width(val) <= width:
+                msg += u"%s "
+                val = utf8_width_fill(val, width, left=(align == u'-'),
+                                      prefix=hibeg, suffix=hiend)
+                data.append(val)
             else:
-                msg += u"%s\n" + " " * (total_width + width + 1)
+                msg += u"%s%s%s\n" + " " * (total_width + width + 1)
+                data.extend([hibeg, val, hiend])
             total_width += width
             total_width += 1
-            data.append(val)
-        (val, width) = columns[-1]
+        (val, width, hibeg, hiend) = self._col_data(columns[-1])
         (align, width) = self._fmt_column_align_width(width)
-        msg += u"%%%s%ds%s" % (align, width, end)
+        val = utf8_width_fill(val, width, left=(align == u'-'),
+                              prefix=hibeg, suffix=hiend)
+        msg += u"%%s%s" % end
         data.append(val)
         return msg % tuple(data)
 
@@ -370,12 +465,10 @@ class YumOutput:
 
         if columns is None:
             columns = (-40, -22, -16) # Old default
-        (hibeg, hiend) = self._highlight(highlight)
         ver = pkg.printVer()
         na = '%s%s.%s' % (indent, pkg.name, pkg.arch)
-        columns = zip((na, ver, pkg.repoid), columns)
-        columns.insert(1, (hiend, 0))
-        columns.insert(0, (hibeg, 0))
+        hi_cols = [highlight, 'normal', 'normal']
+        columns = zip((na, ver, pkg.repoid), columns, hi_cols)
         print self.fmtColumns(columns)
 
     def simpleEnvraList(self, pkg, ui_overflow=False,
@@ -385,31 +478,30 @@ class YumOutput:
 
         if columns is None:
             columns = (-63, -16) # Old default
-        (hibeg, hiend) = self._highlight(highlight)
         envra = '%s%s' % (indent, str(pkg))
-        columns = zip((envra, pkg.repoid), columns)
-        columns.insert(1, (hiend, 0))
-        columns.insert(0, (hibeg, 0))
+        hi_cols = [highlight, 'normal', 'normal']
+        columns = zip((envra, pkg.repoid), columns, hi_cols)
         print self.fmtColumns(columns)
 
     def fmtKeyValFill(self, key, val):
         """ Return a key value pair in the common two column output format. """
         val = to_str(val)
-        keylen = len(key)
+        keylen = utf8_width(key)
         cols = self.term.columns
         nxt = ' ' * (keylen - 2) + ': '
-        ret = fill(val, width=cols,
-                   initial_indent=key, subsequent_indent=nxt)
+        ret = utf8_text_fill(val, width=cols,
+                             initial_indent=key, subsequent_indent=nxt)
         if ret.count("\n") > 1 and keylen > (cols / 3):
             # If it's big, redo it again with a smaller subsequent off
-            ret = fill(val, width=cols,
-                       initial_indent=key, subsequent_indent='     ...: ')
+            ret = utf8_text_fill(val, width=cols,
+                                 initial_indent=key,
+                                 subsequent_indent='     ...: ')
         return ret
     
     def fmtSection(self, name, fill='='):
         name = to_str(name)
         cols = self.term.columns - 2
-        name_len = len(name)
+        name_len = utf8_width(name)
         if name_len >= (cols - 4):
             beg = end = fill * 2
         else:
@@ -421,8 +513,7 @@ class YumOutput:
     def _enc(self, s):
         """Get the translated version from specspo and ensure that
         it's actually encoded in UTF-8."""
-        if type(s) == unicode:
-            s = s.encode("UTF-8")
+        s = to_utf8(s)
         if len(s) > 0:
             for d in self.i18ndomains:
                 t = gettext.dgettext(d, s)
@@ -433,24 +524,24 @@ class YumOutput:
 
     def infoOutput(self, pkg, highlight=False):
         (hibeg, hiend) = self._highlight(highlight)
-        print _("Name       : %s%s%s") % (hibeg, pkg.name, hiend)
-        print _("Arch       : %s") % pkg.arch
+        print _("Name       : %s%s%s") % (hibeg, to_unicode(pkg.name), hiend)
+        print _("Arch       : %s") % to_unicode(pkg.arch)
         if pkg.epoch != "0":
-            print _("Epoch      : %s") % pkg.epoch
-        print _("Version    : %s") % pkg.version
-        print _("Release    : %s") % pkg.release
+            print _("Epoch      : %s") % to_unicode(pkg.epoch)
+        print _("Version    : %s") % to_unicode(pkg.version)
+        print _("Release    : %s") % to_unicode(pkg.release)
         print _("Size       : %s") % self.format_number(float(pkg.size))
-        print _("Repo       : %s") % pkg.repoid
+        print _("Repo       : %s") % to_unicode(pkg.repoid)
         if self.verbose_logger.isEnabledFor(logginglevels.DEBUG_3):
-            print _("Committer  : %s") % pkg.committer
+            print _("Committer  : %s") % to_unicode(pkg.committer)
             print _("Committime : %s") % time.ctime(pkg.committime)
             print _("Buildtime  : %s") % time.ctime(pkg.buildtime)
             if hasattr(pkg, 'installtime'):
                 print _("Installtime: %s") % time.ctime(pkg.installtime)
         print self.fmtKeyValFill(_("Summary    : "), self._enc(pkg.summary))
         if pkg.url:
-            print _("URL        : %s") % pkg.url
-        print _("License    : %s") % pkg.license
+            print _("URL        : %s") % to_unicode(pkg.url)
+        print _("License    : %s") % to_unicode(pkg.license)
         print self.fmtKeyValFill(_("Description: "), self._enc(pkg.description))
         print ""
     
@@ -473,7 +564,7 @@ class YumOutput:
         print '%-35.35s [%.12s] %.10s %-20.20s' % (c_compact, c_repo, changetype, i_compact)
 
     def listPkgs(self, lst, description, outputType, highlight_na={},
-                 columns=None):
+                 columns=None, highlight_modes={}):
         """outputs based on whatever outputType is. Current options:
            'list' - simple pkg list
            'info' - similar to rpm -qi output
@@ -488,8 +579,15 @@ class YumOutput:
                 for pkg in sorted(lst):
                     key = (pkg.name, pkg.arch)
                     highlight = False
-                    if key in highlight_na and pkg.verLT(highlight_na[key]):
-                        highlight = True
+                    if False: pass
+                    elif key not in highlight_na:
+                        highlight = highlight_modes.get('not in', 'normal')
+                    elif pkg.verEQ(highlight_na[key]):
+                        highlight = highlight_modes.get('=', 'normal')
+                    elif pkg.verLT(highlight_na[key]):
+                        highlight = highlight_modes.get('>', 'bold')
+                    else:
+                        highlight = highlight_modes.get('<', 'normal')
 
                     if outputType == 'list':
                         self.simpleList(pkg, ui_overflow=True,
@@ -572,7 +670,7 @@ class YumOutput:
                 continue
             for (apkg, ipkg) in pkg_names2pkgs[item]:
                 pkg = ipkg or apkg
-                envra = len(str(pkg)) + len(indent)
+                envra = utf8_width(str(pkg)) + utf8_width(indent)
                 rid   = len(pkg.repoid)
                 for (d, v) in (('envra', envra), ('rid', rid)):
                     data[d].setdefault(v, 0)
@@ -590,8 +688,14 @@ class YumOutput:
                     continue
                 for (apkg, ipkg) in sorted(pkg_names2pkgs[item],
                                            key=lambda x: x[1] or x[0]):
+                    if ipkg and apkg:
+                        highlight = self.conf.color_list_installed_older
+                    elif apkg:
+                        highlight = self.conf.color_list_available_install
+                    else:
+                        highlight = False
                     self.simpleEnvraList(ipkg or apkg, ui_overflow=True,
-                                         indent=indent, highlight=ipkg and apkg,
+                                         indent=indent, highlight=highlight,
                                          columns=columns)
     
     def displayPkgsInGroups(self, group):
@@ -659,18 +763,15 @@ class YumOutput:
     
         thresh = 999
         depth = 0
+        max_depth = len(symbols) - 1
     
-        # we want numbers between 
-        while number > thresh:
+        # we want numbers between 0 and thresh, but don't exceed the length
+        # of our list.  In that event, the formatting will be screwed up,
+        # but it'll still show the right number.
+        while number > thresh and depth < max_depth:
             depth  = depth + 1
             number = number / step
     
-        # just in case someone needs more than 1000 yottabytes!
-        diff = depth - len(symbols) + 1
-        if diff > 0:
-            depth = depth - diff
-            number = number * thresh**depth
-    
         if type(number) == type(1) or type(number) == type(1L):
             format = '%i%s%s'
         elif number < 9.95:
@@ -680,13 +781,14 @@ class YumOutput:
         else:
             format = '%.0f%s%s'
     
-        return(format % (number, space, symbols[depth]))
+        return(format % (float(number or 0), space, symbols[depth]))
 
     @staticmethod
     def format_time(seconds, use_hours=0):
         return urlgrabber.progress.format_time(seconds, use_hours)
 
-    def matchcallback(self, po, values, matchfor=None, verbose=None):
+    def matchcallback(self, po, values, matchfor=None, verbose=None,
+                      highlight=None):
         """ Output search/provides type callback matches. po is the pkg object,
             values are the things in the po that we've matched.
             If matchfor is passed, all the strings in that list will be
@@ -699,7 +801,9 @@ class YumOutput:
             msg = '%s.%s : ' % (po.name, po.arch)
         msg = self.fmtKeyValFill(msg, self._enc(po.summary))
         if matchfor:
-            msg = self.term.sub_bold(msg, matchfor)
+            if highlight is None:
+                highlight = self.conf.color_search_match
+            msg = self._sub_highlight(msg, highlight, matchfor,ignore_case=True)
         
         print msg
 
@@ -708,6 +812,7 @@ class YumOutput:
         if not verbose:
             return
 
+        print _("Repo        : %s") % po.repoid
         print _('Matched from:')
         for item in yum.misc.unique(values):
             if po.name == item or po.summary == item:
@@ -732,7 +837,8 @@ class YumOutput:
                 key = _("Other       : ")
 
             if matchfor:
-                item = self.term.sub_bold(item, matchfor)
+                item = self._sub_highlight(item, highlight, matchfor,
+                                           ignore_case=True)
             if can_overflow:
                 print self.fmtKeyValFill(key, item)
             else:
@@ -778,38 +884,46 @@ class YumOutput:
         self.tsInfo.makelists()
         out = u""
         pkglist_lines = []
-        #  Tried to do this statically using:
-        #   http://fedorapeople.org/~james/yum/commands/length_distributions.py
-        # but it sucked for corner cases, so this is dynamic...
-
         data  = {'n' : {}, 'v' : {}, 'r' : {}}
         a_wid = 0 # Arch can't get "that big" ... so always use the max.
+
+        def _add_line(lines, data, a_wid, po, obsoletes=[]):
+            (n,a,e,v,r) = po.pkgtup
+            evr = po.printVer()
+            repoid = po.repoid
+            pkgsize = float(po.size)
+            size = self.format_number(pkgsize)
+
+            if a is None: # gpgkeys are weird
+                a = 'noarch'
+
+            lines.append((n, a, evr, repoid, size, obsoletes))
+            #  Create a dict of field_length => number of packages, for
+            # each field.
+            for (d, v) in (("n",len(n)), ("v",len(evr)), ("r",len(repoid))):
+                data[d].setdefault(v, 0)
+                data[d][v] += 1
+            if a_wid < len(a): # max() is only in 2.5.z
+                a_wid = len(a)
+            return a_wid
+
         for (action, pkglist) in [(_('Installing'), self.tsInfo.installed),
                             (_('Updating'), self.tsInfo.updated),
                             (_('Removing'), self.tsInfo.removed),
                             (_('Installing for dependencies'), self.tsInfo.depinstalled),
                             (_('Updating for dependencies'), self.tsInfo.depupdated),
-                            (_('Removing for dependencies'), self.tsInfo.depremoved),
-                            (_('Skipped (dependency problems)'), self.skipped_packages),]:
+                            (_('Removing for dependencies'), self.tsInfo.depremoved)]:
             lines = []
             for txmbr in pkglist:
-                (n,a,e,v,r) = txmbr.pkgtup
-                evr = txmbr.po.printVer()
-                repoid = txmbr.repoid
-                pkgsize = float(txmbr.po.size)
-                size = self.format_number(pkgsize)
-
-                if a is None: # gpgkeys are weird
-                    a = 'noarch'
-
-                lines.append((n, a, evr, repoid, size, txmbr.obsoletes))
-                #  Create a dict of field_length => number of packages, for
-                # each field.
-                for (d, v) in (("n",len(n)), ("v",len(evr)), ("r",len(repoid))):
-                    data[d].setdefault(v, 0)
-                    data[d][v] += 1
-                if a_wid < len(a): # max() is only in 2.5.z
-                    a_wid = len(a)
+                a_wid = _add_line(lines, data, a_wid, txmbr.po, txmbr.obsoletes)
+
+            pkglist_lines.append((action, lines))
+
+        for (action, pkglist) in [(_('Skipped (dependency problems)'),
+                                   self.skipped_packages),]:
+            lines = []
+            for po in pkglist:
+                a_wid = _add_line(lines, data, a_wid, po)
 
             pkglist_lines.append((action, lines))
 
@@ -1001,8 +1115,8 @@ Remove   %5.5s Package(s)
         ui_time = tl.add(' %9s' % self.format_time(dl_time))
         ui_end  = tl.add(' ' * 5)
         ui_bs   = tl.add(' %5sB/s' % self.format_number(remote_size / dl_time))
-        msg = "%-*.*s%s%s%s%s" % (tl.rest(), tl.rest(), _("Total"),
-                                  ui_bs, ui_size, ui_time, ui_end)
+        msg = "%s%s%s%s%s" % (utf8_width_fill(_("Total"), tl.rest(), tl.rest()),
+                              ui_bs, ui_size, ui_time, ui_end)
         self.verbose_logger.log(logginglevels.INFO_2, msg)
 
 
@@ -1099,7 +1213,7 @@ class YumCliRPMCallBack(RPMBaseCallback):
 
     def __init__(self):
         RPMBaseCallback.__init__(self)
-        self.lastmsg = None
+        self.lastmsg = to_unicode("")
         self.lastpackage = None # name of last package we looked at
         self.output = logging.getLogger("yum.verbose.cli").isEnabledFor(logginglevels.INFO_2)
         
@@ -1125,10 +1239,10 @@ class YumCliRPMCallBack(RPMBaseCallback):
             percent = (te_current*100L)/te_total
         
         if self.output and (sys.stdout.isatty() or te_current == te_total):
-            fmt = self._makefmt(percent, ts_current, ts_total, pkgname=pkgname)
-            # FIXME: Converting to utf8 here is a HACK ... but it's better
-            # to underflow than overflow, see the i18n-rpm-progress example
-            msg = fmt % (to_utf8(process), pkgname)
+            (fmt, wid1, wid2) = self._makefmt(percent, ts_current, ts_total,
+                                              pkgname=pkgname)
+            msg = fmt % (utf8_width_fill(process, wid1, wid1),
+                         utf8_width_fill(pkgname, wid2, wid2))
             if msg != self.lastmsg:
                 sys.stdout.write(to_unicode(msg))
                 sys.stdout.flush()
@@ -1153,7 +1267,7 @@ class YumCliRPMCallBack(RPMBaseCallback):
         if pkgname is None:
             pnl = 22
         else:
-            pnl = len(pkgname)
+            pnl = utf8_width(pkgname)
 
         overhead  = (2 * l) + 2 # Length of done, above
         overhead += 19          # Length of begining
@@ -1171,20 +1285,23 @@ class YumCliRPMCallBack(RPMBaseCallback):
         width = "%s.%s" % (marks, marks)
         fmt_bar = "[%-" + width + "s]"
         # pnl = str(28 + marks + 1)
-        full_pnl = "%%-%d.%ds" % (pnl + marks + 1, pnl + marks + 1)
-        half_pnl = "%%-%d.%ds" % (pnl, pnl)
+        full_pnl = pnl + marks + 1
 
         if progress and percent == 100: # Don't chop pkg name on 100%
-            fmt = "\r  %-15.15s: " + full_pnl + "   " + done
+            fmt = "\r  %s: %s   " + done
+            wid2 = full_pnl
         elif progress:
             bar = fmt_bar % (self.mark * int(marks * (percent / 100.0)), )
-            fmt = "\r  %-15.15s: " + half_pnl + " " + bar + " " + done
+            fmt = "\r  %s: %s " + bar + " " + done
+            wid2 = pnl
         elif percent == 100:
-            fmt = "  %-15.15s: " + full_pnl + "   " + done
+            fmt = "  %s: %s   " + done
+            wid2 = full_pnl
         else:
             bar = fmt_bar % (self.mark * marks, )
-            fmt = "  %-15.15s: " + half_pnl + " " + bar + " " + done
-        return fmt
+            fmt = "  %s: %s " + bar + " " + done
+            wid2 = pnl
+        return fmt, 15, wid2
 
 
 def progressbar(current, total, name=None):
@@ -1206,8 +1323,6 @@ def progressbar(current, total, name=None):
 
     if name is None and current == total:
         name = '-'
-    if name is not None: # FIXME: This is a hack without utf8_width()
-        width -= len(to_utf8(name)) - len(name)
 
     end = ' %d/%d' % (current, total)
     width -= len(end) + 1
@@ -1220,17 +1335,18 @@ def progressbar(current, total, name=None):
         hashbar = mark * int(width * percent)
         output = '\r[%-*s]%s' % (width, hashbar, end)
     elif current == total: # Don't chop name on 100%
-        output = '\r%-*.*s%s' % (width, width, name, end)
+        output = '\r%s%s' % (utf8_width_fill(name, width, width), end)
     else:
         width -= 4
         if width < 0:
             width = 0
         nwid = width / 2
-        if nwid > len(name):
-            nwid = len(name)
+        if nwid > utf8_width(name):
+            nwid = utf8_width(name)
         width -= nwid
         hashbar = mark * int(width * percent)
-        output = '\r%-*.*s: [%-*s]%s' % (nwid, nwid, name, width, hashbar, end)
+        output = '\r%s: [%-*s]%s' % (utf8_width_fill(name, nwid, nwid), width,
+                                     hashbar, end)
      
     if current <= total:
         sys.stdout.write(output)
diff --git a/po/ca.po b/po/ca.po
index 4af6f82..f4a0eb3 100644
--- a/po/ca.po
+++ b/po/ca.po
@@ -4,6 +4,7 @@
 #  yum package.
 #
 # Josep Maria Brunetti Fernández <josepb@gmail.com>, 2008
+# Xavier Conde Rueda <xavi.conde@gmail.com>, 2008
 #
 # This file is translated according to the glossary and style guide of
 #   Softcatalà. If you plan to modify this file, please read first the page
@@ -20,16 +21,16 @@ msgid ""
 msgstr ""
 "Project-Id-Version: yum\n"
 "Report-Msgid-Bugs-To: \n"
-"POT-Creation-Date: 2008-10-17 02:09+0000\n"
-"PO-Revision-Date: 2008-10-18 19:39+0200\n"
-"Last-Translator: Josep Maria Brunetti Fernández <josepb@gmail.com>\n"
+"POT-Creation-Date: 2008-11-06 01:31+0000\n"
+"PO-Revision-Date: 2008-11-06 19:39+0200\n"
+"Last-Translator: Xavier Conde Rueda <xavi.conde@gmail.com>\n"
 "Language-Team: Language-Team: Catalan <fedora@softcatala.net>\n"
 "MIME-Version: 1.0\n"
 "Content-Type: text/plain; charset=UTF-8\n"
 "Content-Transfer-Encoding: 8bit\n"
 "Plural-Forms: nplurals=2; plural=n != 1;\n"
 
-#: ../callback.py:48 ../output.py:777 ../yum/rpmtrans.py:71
+#: ../callback.py:48 ../output.py:808 ../yum/rpmtrans.py:71
 msgid "Updating"
 msgstr "S'està actualitzant"
 
@@ -37,8 +38,7 @@ msgstr "S'està actualitzant"
 msgid "Erasing"
 msgstr "S'està esborrant"
 
-#. Arch can't get "that big" ... so always use the max.
-#: ../callback.py:50 ../callback.py:51 ../callback.py:53 ../output.py:776
+#: ../callback.py:50 ../callback.py:51 ../callback.py:53 ../output.py:807
 #: ../yum/rpmtrans.py:73 ../yum/rpmtrans.py:74 ../yum/rpmtrans.py:76
 msgid "Installing"
 msgstr "S'està instal·lant"
@@ -47,7 +47,7 @@ msgstr "S'està instal·lant"
 msgid "Obsoleted"
 msgstr "Obsolet"
 
-#: ../callback.py:54 ../output.py:890
+#: ../callback.py:54 ../output.py:913
 msgid "Updated"
 msgstr "Actualitzat"
 
@@ -55,7 +55,7 @@ msgstr "Actualitzat"
 msgid "Erased"
 msgstr "Esborrat"
 
-#: ../callback.py:56 ../callback.py:57 ../callback.py:59 ../output.py:888
+#: ../callback.py:56 ../callback.py:57 ../callback.py:59 ../output.py:911
 msgid "Installed"
 msgstr "Instal·lat"
 
@@ -77,7 +77,7 @@ msgstr "Error: estat de sortida invàlid: %s per a %s"
 msgid "Erased: %s"
 msgstr "Esborrat: %s"
 
-#: ../callback.py:217 ../output.py:778
+#: ../callback.py:217 ../output.py:809
 msgid "Removing"
 msgstr "S'està esborrant"
 
@@ -103,7 +103,7 @@ msgstr "S'estan llegint les metadades de repositoris des de fitxers locals"
 msgid "Config Error: %s"
 msgstr "Error de configuració: %s"
 
-#: ../cli.py:190 ../cli.py:1125 ../utils.py:74
+#: ../cli.py:190 ../cli.py:1128 ../utils.py:74
 #, python-format
 msgid "Options Error: %s"
 msgstr "Error d'opcions: %s"
@@ -149,7 +149,7 @@ msgstr ""
 #: ../cli.py:351
 msgid "Trying to run the transaction but nothing to do. Exiting."
 msgstr ""
-"S'ha intentat executar la transacció però no hi ha res a fer. S'està sortint."
+"S'ha intentat executar la transacció però no hi ha cap tasca a fer. S'està sortint."
 
 #: ../cli.py:381
 msgid "Exiting on user Command"
@@ -163,15 +163,15 @@ msgstr "S'estan descarregant els següents paquets:"
 msgid "Error Downloading Packages:\n"
 msgstr "S'ha produït un error descarregant els següents paquets:\n"
 
-#: ../cli.py:404 ../yum/__init__.py:3133
+#: ../cli.py:404 ../yum/__init__.py:3244
 msgid "Running rpm_check_debug"
 msgstr "S'està executant rpm_check_debug"
 
-#: ../cli.py:407 ../yum/__init__.py:3136
+#: ../cli.py:407 ../yum/__init__.py:3247
 msgid "ERROR with rpm_check_debug vs depsolve:"
 msgstr "ERROR amb rpm_check_debug vs depsolve:"
 
-#: ../cli.py:411 ../yum/__init__.py:3138
+#: ../cli.py:411 ../yum/__init__.py:3249
 msgid "Please report this error in bugzilla"
 msgstr "Siusplau, informeu d'aquest error al bugzilla"
 
@@ -215,17 +215,17 @@ msgstr "Paquets %s%s%s disponibles, però no instal·lats."
 #: ../cli.py:542 ../cli.py:577
 #, python-format
 msgid "No package %s%s%s available."
-msgstr "El paquet %s%s%s està disponible."
+msgstr "El paquet %s%s%s no està disponible."
 
 #: ../cli.py:567
 msgid "Parsing package install arguments"
 msgstr "S'estan analitzant els arguments del paquet a instal·lar"
 
-#: ../cli.py:582 ../cli.py:657 ../yumcommands.py:889
+#: ../cli.py:582 ../cli.py:657 ../yumcommands.py:933
 msgid "Package(s) to install"
 msgstr "Paquets a instal·lar"
 
-#: ../cli.py:583 ../cli.py:658 ../yumcommands.py:150 ../yumcommands.py:890
+#: ../cli.py:583 ../cli.py:658 ../yumcommands.py:151 ../yumcommands.py:934
 msgid "Nothing to do"
 msgstr "Res a fer"
 
@@ -272,7 +272,8 @@ msgid ""
 "Warning: 3.0.x versions of yum would erronously match against filenames.\n"
 " You can use \"%s*/%s%s\" and/or \"%s*bin/%s%s\" to get that behaviour"
 msgstr ""
-"Avís: les versions 3.0.x del yum comproven incorrectament els noms de fitxer.\n"
+"Avís: les versions 3.0.x del yum comproven incorrectament els noms de "
+"fitxer.\n"
 " Podeu usar \"%s*/%s%s\" i/o \"%s*bin/%s%s\" per obtenir aquest comportament"
 
 #: ../cli.py:789
@@ -320,7 +321,7 @@ msgstr "Grups disponibles:"
 msgid "Done"
 msgstr "Fet"
 
-#: ../cli.py:875 ../cli.py:893 ../cli.py:899 ../yum/__init__.py:2245
+#: ../cli.py:875 ../cli.py:893 ../cli.py:899 ../yum/__init__.py:2336
 #, python-format
 msgid "Warning: Group %s does not exist."
 msgstr "Avís: El grup %s no existeix"
@@ -336,7 +337,7 @@ msgstr ""
 msgid "%d Package(s) to Install"
 msgstr "%d paquets a instal·lar"
 
-#: ../cli.py:915 ../yum/__init__.py:2257
+#: ../cli.py:915 ../yum/__init__.py:2348
 #, python-format
 msgid "No group named %s exists"
 msgstr "No existeix cap grup anomenat %s"
@@ -384,246 +385,246 @@ msgstr ""
 "\n"
 "%s: l'opció %s necessita un argument"
 
-#: ../cli.py:1167
+#: ../cli.py:1170
 msgid "show this help message and exit"
 msgstr "mostra el missatge d'ajuda i surt"
 
-#: ../cli.py:1171
+#: ../cli.py:1174
 msgid "be tolerant of errors"
-msgstr "sigues tolerant a errors"
+msgstr "sigues tolerant amb els errors"
 
-#: ../cli.py:1173
+#: ../cli.py:1176
 msgid "run entirely from cache, don't update cache"
-msgstr "executa totalment des de la memòria cau, no actualitzis la memòria cau"
+msgstr "executa totalment des de la memòria cau, no l'actualitzis"
 
-#: ../cli.py:1175
+#: ../cli.py:1178
 msgid "config file location"
 msgstr "ubicació del fitxer de configuració"
 
-#: ../cli.py:1177
+#: ../cli.py:1180
 msgid "maximum command wait time"
 msgstr "temps màxim d'espera d'ordres"
 
-#: ../cli.py:1179
+#: ../cli.py:1182
 msgid "debugging output level"
 msgstr "nivell de sortida de depuració"
 
-#: ../cli.py:1183
+#: ../cli.py:1186
 msgid "show duplicates, in repos, in list/search commands"
-msgstr "mostra duplicats, en repositoris, en les ordres llista i cerca"
+msgstr "mostra duplicats, en repositoris, en les ordres per llistar i cercar"
 
-#: ../cli.py:1185
+#: ../cli.py:1188
 msgid "error output level"
-msgstr "error en el nivell de sortida"
+msgstr "nivell de sortida d'error"
 
-#: ../cli.py:1188
+#: ../cli.py:1191
 msgid "quiet operation"
 msgstr "operació silenciosa"
 
-#: ../cli.py:1190
+#: ../cli.py:1193
 msgid "verbose operation"
 msgstr "operació descriptiva"
 
-#: ../cli.py:1192
+#: ../cli.py:1195
 msgid "answer yes for all questions"
 msgstr "respon sí a totes les preguntes"
 
-#: ../cli.py:1194
+#: ../cli.py:1197
 msgid "show Yum version and exit"
-msgstr "mostra la versió de Yum i surt"
+msgstr "mostra la versió del Yum i surt"
 
-#: ../cli.py:1195
+#: ../cli.py:1198
 msgid "set install root"
 msgstr "estableix l'arrel de la instal·lació"
 
-#: ../cli.py:1199
+#: ../cli.py:1202
 msgid "enable one or more repositories (wildcards allowed)"
 msgstr "habilita un o més repositoris (es permeten caràcters de reemplaçament)"
 
-#: ../cli.py:1203
+#: ../cli.py:1206
 msgid "disable one or more repositories (wildcards allowed)"
 msgstr ""
 "deshabilita un o més repositoris (es permeten caràcters de reemplaçament)"
 
-#: ../cli.py:1206
+#: ../cli.py:1209
 msgid "exclude package(s) by name or glob"
 msgstr "exclou els paquets per nom o expressió regular del glob"
 
-#: ../cli.py:1208
+#: ../cli.py:1211
 msgid "disable exclude from main, for a repo or for everything"
-msgstr "deshabilita l'exclusió des de l'inici, per a un repositori o per a tot"
+msgstr "inhabilita l'exclusió des de l'inici, per a un repositori o per a tot"
 
-#: ../cli.py:1211
+#: ../cli.py:1214
 msgid "enable obsoletes processing during updates"
 msgstr "habilita el processament d'obsolets durant les actualitzacions"
 
-#: ../cli.py:1213
+#: ../cli.py:1216
 msgid "disable Yum plugins"
-msgstr "deshabilita les extensions de Yum"
+msgstr "inhabilita les extensions de Yum"
 
-#: ../cli.py:1215
+#: ../cli.py:1218
 msgid "disable gpg signature checking"
-msgstr "deshabilita la comprobació de signatures gpg"
+msgstr "inhabilita la comprobació de signatures gpg"
 
-#: ../cli.py:1217
+#: ../cli.py:1220
 msgid "disable plugins by name"
-msgstr "deshabilita extensions per nom"
+msgstr "inhabilita extensions per nom"
 
-#: ../cli.py:1220
+#: ../cli.py:1223
 msgid "enable plugins by name"
 msgstr "habilita extensions per nom"
 
-#: ../cli.py:1223
+#: ../cli.py:1226
 msgid "skip packages with depsolving problems"
 msgstr "omet paquets amb problemes de resolució de dependències"
 
-#: ../output.py:236
+#: ../output.py:248
 msgid "Jan"
 msgstr "Gen"
 
-#: ../output.py:236
+#: ../output.py:248
 msgid "Feb"
 msgstr "Feb"
 
-#: ../output.py:236
+#: ../output.py:248
 msgid "Mar"
 msgstr "Mar"
 
-#: ../output.py:236
+#: ../output.py:248
 msgid "Apr"
 msgstr "Abr"
 
-#: ../output.py:236
+#: ../output.py:248
 msgid "May"
 msgstr "Mai"
 
-#: ../output.py:236
+#: ../output.py:248
 msgid "Jun"
 msgstr "Jun"
 
-#: ../output.py:237
+#: ../output.py:249
 msgid "Jul"
 msgstr "Jul"
 
-#: ../output.py:237
+#: ../output.py:249
 msgid "Aug"
 msgstr "Ago"
 
-#: ../output.py:237
+#: ../output.py:249
 msgid "Sep"
 msgstr "Set"
 
-#: ../output.py:237
+#: ../output.py:249
 msgid "Oct"
 msgstr "Oct"
 
-#: ../output.py:237
+#: ../output.py:249
 msgid "Nov"
 msgstr "Nov"
 
-#: ../output.py:237
+#: ../output.py:249
 msgid "Dec"
 msgstr "Des"
 
-#: ../output.py:247
+#: ../output.py:259
 msgid "Trying other mirror."
 msgstr "S'està intentant un altre servidor rèplica."
 
-#: ../output.py:425
+#: ../output.py:439
 #, python-format
 msgid "Name       : %s%s%s"
 msgstr "Nom       : %s%s%s"
 
-#: ../output.py:426
+#: ../output.py:440
 #, python-format
 msgid "Arch       : %s"
 msgstr "Arq       : %s"
 
-#: ../output.py:428
+#: ../output.py:442
 #, python-format
 msgid "Epoch      : %s"
 msgstr "Època      : %s"
 
-#: ../output.py:429
+#: ../output.py:443
 #, python-format
 msgid "Version    : %s"
 msgstr "Versió    : %s"
 
-#: ../output.py:430
+#: ../output.py:444
 #, python-format
 msgid "Release    : %s"
 msgstr "Release    : %s"
 
-#: ../output.py:431
+#: ../output.py:445
 #, python-format
 msgid "Size       : %s"
 msgstr "Mida       : %s"
 
-#: ../output.py:432
+#: ../output.py:446
 #, python-format
 msgid "Repo       : %s"
 msgstr "Repo       : %s"
 
-#: ../output.py:434
+#: ../output.py:448
 #, python-format
 msgid "Committer  : %s"
 msgstr "Desenvolupador  : %s"
 
-#: ../output.py:435
+#: ../output.py:449
 #, python-format
 msgid "Committime : %s"
 msgstr "Pujat : %s"
 
-#: ../output.py:436
+#: ../output.py:450
 #, python-format
 msgid "Buildtime  : %s"
 msgstr "Temps de creació  : %s"
 
-#: ../output.py:438
+#: ../output.py:452
 #, python-format
 msgid "Installtime: %s"
 msgstr "Temps d'instal·lació: %s"
 
-#: ../output.py:439
+#: ../output.py:453
 msgid "Summary    : "
 msgstr "Resum    : "
 
-#: ../output.py:441
+#: ../output.py:455
 #, python-format
 msgid "URL        : %s"
 msgstr "URL        : %s"
 
-#: ../output.py:442
+#: ../output.py:456
 #, python-format
 msgid "License    : %s"
 msgstr "Llicència    : %s"
 
-#: ../output.py:443
+#: ../output.py:457
 msgid "Description: "
 msgstr "Descripció: "
 
-#: ../output.py:500
+#: ../output.py:514
 msgid "y"
 msgstr "s"
 
-#: ../output.py:500
+#: ../output.py:514
 msgid "yes"
 msgstr "sí"
 
-#: ../output.py:501
+#: ../output.py:515
 msgid "n"
 msgstr "n"
 
-#: ../output.py:501
+#: ../output.py:515
 msgid "no"
 msgstr "no"
 
 # REMEMBER to Translate [Y/N] to the current locale
-#: ../output.py:505
+#: ../output.py:519
 msgid "Is this ok [y/N]: "
 msgstr "És correcte [s/N]: "
 
-#: ../output.py:587
+#: ../output.py:601
 #, python-format
 msgid ""
 "\n"
@@ -632,119 +633,123 @@ msgstr ""
 "\n"
 "Grup: %s"
 
-#: ../output.py:594
+#: ../output.py:608
 #, python-format
 msgid " Description: %s"
 msgstr " Descripció: %s"
 
-#: ../output.py:596
+#: ../output.py:610
 msgid " Mandatory Packages:"
 msgstr " Paquets obligatoris:"
 
-#: ../output.py:597
+#: ../output.py:611
 msgid " Default Packages:"
 msgstr " Paquets per defecte:"
 
-#: ../output.py:598
+#: ../output.py:612
 msgid " Optional Packages:"
 msgstr " Paquets opcionals:"
 
-#: ../output.py:599
+#: ../output.py:613
 msgid " Conditional Packages:"
 msgstr " Paquets condicionals:"
 
-#: ../output.py:619
+#: ../output.py:633
 #, python-format
 msgid "package: %s"
 msgstr "paquet: %s"
 
-#: ../output.py:621
+#: ../output.py:635
 msgid "  No dependencies for this package"
 msgstr "  No hi ha dependències per a aquest paquet"
 
-#: ../output.py:626
+#: ../output.py:640
 #, python-format
 msgid "  dependency: %s"
 msgstr "  dependència: %s"
 
-#: ../output.py:628
+#: ../output.py:642
 msgid "   Unsatisfied dependency"
 msgstr "   Dependència insatisfeta"
 
-#: ../output.py:700
+#: ../output.py:714
 msgid "Matched from:"
 msgstr "Coincidències amb:"
 
-#: ../output.py:708
+#: ../output.py:722
 msgid "Description : "
 msgstr "Descripció: "
 
-#: ../output.py:711
+#: ../output.py:725
 #, python-format
 msgid "URL         : %s"
 msgstr "URL         : %s"
 
-#: ../output.py:714
+#: ../output.py:728
 #, python-format
 msgid "License     : %s"
 msgstr "Llicència   : %s"
 
-#: ../output.py:717
+#: ../output.py:731
 #, python-format
 msgid "Filename    : %s"
 msgstr "Fitxer      : %s"
 
-#: ../output.py:721
+#: ../output.py:735
 msgid "Other       : "
 msgstr "Altre       : "
 
-#: ../output.py:753
+#: ../output.py:767
 msgid "There was an error calculating total download size"
 msgstr "S'ha produït un error en calcular la mida total de la descàrrega"
 
-#: ../output.py:758
+#: ../output.py:772
 #, python-format
 msgid "Total size: %s"
 msgstr "Mida total: %s"
 
-#: ../output.py:761
+#: ../output.py:775
 #, python-format
 msgid "Total download size: %s"
 msgstr "Mida total de la descàrrega: %s"
 
-#: ../output.py:779
+#: ../output.py:810
 msgid "Installing for dependencies"
 msgstr "S'està instal·lant per dependències"
 
-#: ../output.py:780
+#: ../output.py:811
 msgid "Updating for dependencies"
-msgstr "S'està actualitzant per dependències"
+msgstr "S'està actualitzant degut a les dependències"
 
-#: ../output.py:781
+#: ../output.py:812
 msgid "Removing for dependencies"
-msgstr "S'està esborrant per dependències"
+msgstr "S'està esborrant degut a les dependències"
+
+#: ../output.py:819 ../output.py:915
+msgid "Skipped (dependency problems)"
+msgstr "Ignorat degut a problemes de dependències:"
 
-#: ../output.py:817
+#: ../output.py:840
 msgid "Package"
 msgstr "Paquet"
 
-#: ../output.py:817
+#: ../output.py:840
 msgid "Arch"
 msgstr "Arq"
 
-#: ../output.py:818
+#: ../output.py:841
 msgid "Version"
 msgstr "Versió"
 
-#: ../output.py:818
+#: ../output.py:841
 msgid "Repository"
 msgstr "Repositori"
 
-#: ../output.py:819
+#: ../output.py:842
 msgid "Size"
 msgstr "Mida"
 
-#: ../output.py:830
+#: ../output.py:853
 #, python-format
 msgid ""
 "     replacing  %s.%s %s\n"
@@ -753,7 +758,7 @@ msgstr ""
 "     s'està reemplaçant  %s.%s %s\n"
 "\n"
 
-#: ../output.py:838
+#: ../output.py:861
 #, python-format
 msgid ""
 "\n"
@@ -770,27 +775,27 @@ msgstr ""
 "Actualitza %5.5s paquets         \n"
 "Esborra    %5.5s paquets         \n"
 
-#: ../output.py:886
+#: ../output.py:909
 msgid "Removed"
 msgstr "Esborrat"
 
-#: ../output.py:887
+#: ../output.py:910
 msgid "Dependency Removed"
 msgstr "Dependència esborrada"
 
-#: ../output.py:889
+#: ../output.py:912
 msgid "Dependency Installed"
 msgstr "Dependència instal·lada"
 
-#: ../output.py:891
+#: ../output.py:914
 msgid "Dependency Updated"
 msgstr "Dependència actualitzada"
 
-#: ../output.py:892
+#: ../output.py:916
 msgid "Replaced"
 msgstr "Reemplaçat"
 
-#: ../output.py:965
+#: ../output.py:989
 #, python-format
 msgid ""
 "\n"
@@ -801,81 +806,81 @@ msgstr ""
 "S'ha cancel·lat la descàrrega actual, %sinterromp (crtl-c) de nou%s en %s%s%"
 "s segons per a sortir.\n"
 
-#: ../output.py:975
+#: ../output.py:999
 msgid "user interrupt"
 msgstr "interrupció de l'usuari"
 
-#: ../output.py:991
+#: ../output.py:1015
 msgid "Total"
 msgstr "Total"
 
-#: ../output.py:1005
+#: ../output.py:1029
 msgid "installed"
 msgstr "instal·lat"
 
-#: ../output.py:1006
+#: ../output.py:1030
 msgid "updated"
 msgstr "actualitzat"
 
-#: ../output.py:1007
+#: ../output.py:1031
 msgid "obsoleted"
 msgstr "obsolet"
 
-#: ../output.py:1008
+#: ../output.py:1032
 msgid "erased"
 msgstr "esborrat"
 
-#: ../output.py:1012
+#: ../output.py:1036
 #, python-format
 msgid "---> Package %s.%s %s:%s-%s set to be %s"
 msgstr "---> Paquet %s.%s %s:%s-%s passarà a ser %s"
 
-#: ../output.py:1019
+#: ../output.py:1043
 msgid "--> Running transaction check"
 msgstr "--> S'està executant la transacció de prova"
 
-#: ../output.py:1024
+#: ../output.py:1048
 msgid "--> Restarting Dependency Resolution with new changes."
 msgstr ""
 "--> Tornant a calcular la resolució de dependències amb els nous canvis."
 
-#: ../output.py:1029
+#: ../output.py:1053
 msgid "--> Finished Dependency Resolution"
 msgstr "--> Ha finalitzat la resolució de dependències"
 
-#: ../output.py:1034
+#: ../output.py:1058
 #, python-format
 msgid "--> Processing Dependency: %s for package: %s"
 msgstr "--> S'està processant la dependència %s per al paquet: %s"
 
-#: ../output.py:1039
+#: ../output.py:1063
 #, python-format
 msgid "--> Unresolved Dependency: %s"
 msgstr "--> Dependència no resolta: %s"
 
-#: ../output.py:1045
+#: ../output.py:1069
 #, python-format
 msgid "--> Processing Conflict: %s conflicts %s"
 msgstr "--> S'està processant el conflicte: %s té un conflicte amb %s"
 
-#: ../output.py:1048
+#: ../output.py:1072
 msgid "--> Populating transaction set with selected packages. Please wait."
 msgstr ""
 "--> S'està poblant la transacció amb els paquets sel·leccionats. Si us plau, "
 "espereu."
 
-#: ../output.py:1052
+#: ../output.py:1076
 #, python-format
 msgid "---> Downloading header for %s to pack into transaction set."
 msgstr ""
 "---> S'està descarregant la capçalera per a %s per a empaquetar dins de la "
 "transacció de prova."
 
-#: ../yumcommands.py:40
+#: ../yumcommands.py:41
 msgid "You need to be root to perform this command."
 msgstr "Heu de ser root per a executar aquesta ordre."
 
-#: ../yumcommands.py:47
+#: ../yumcommands.py:48
 msgid ""
 "\n"
 "You have enabled checking of packages via GPG keys. This is a good thing. \n"
@@ -897,7 +902,7 @@ msgstr ""
 "opció. \n"
 "No obstant, no teniu cap clau pública GPG instal·lada. Necessiteu "
 "descarregar\n"
-"les claus per als paquets paquets que desitdeu instal·lar i instal·lar-les.\n"
+"les claus per als paquets que desitgeu instal·lar i instal·lar-les.\n"
 "Podeu fer-ho executant l'ordre:\n"
 "    rpm --import clau.pública.gpg\n"
 "\n"
@@ -906,295 +911,312 @@ msgstr ""
 "per a un repositori en l'opció 'gpgkey' en la secció d'un repositori i yum \n"
 "la instal·larà per vosaltres.\n"
 "\n"
-"Per a més informació contacteu el vostre distribuidor o proveïdor de "
+"Per a més informació contacteu el vostre distribuÏdor o proveïdor de "
 "paquets.\n"
 
-#: ../yumcommands.py:67
+#: ../yumcommands.py:68
 #, python-format
 msgid "Error: Need to pass a list of pkgs to %s"
 msgstr "Error: es necessita passar una llista de paquets a %s"
 
-#: ../yumcommands.py:73
+#: ../yumcommands.py:74
 msgid "Error: Need an item to match"
 msgstr "Error: es necessita algun element per comparar"
 
-#: ../yumcommands.py:79
+#: ../yumcommands.py:80
 msgid "Error: Need a group or list of groups"
 msgstr "Error: es necessita un grup o una llista de grups"
 
-#: ../yumcommands.py:88
+#: ../yumcommands.py:89
 #, python-format
 msgid "Error: clean requires an option: %s"
 msgstr "Error: la neteja requereix una opció: %s"
 
-#: ../yumcommands.py:93
+#: ../yumcommands.py:94
 #, python-format
 msgid "Error: invalid clean argument: %r"
 msgstr "Error: argument invàlid per a la neteja: %r"
 
-#: ../yumcommands.py:106
+#: ../yumcommands.py:107
 msgid "No argument to shell"
 msgstr "No hi ha arguments per a l'intèrpret d'ordres"
 
-#: ../yumcommands.py:109
+#: ../yumcommands.py:110
 #, python-format
 msgid "Filename passed to shell: %s"
 msgstr "Nom del fitxer passat a l'intèrpret d'ordres: %s"
 
-#: ../yumcommands.py:113
+#: ../yumcommands.py:114
 #, python-format
 msgid "File %s given as argument to shell does not exist."
 msgstr "El fitxer %s donat com a argument a l'intèrpret d'ordres no existeix."
 
-#: ../yumcommands.py:119
+#: ../yumcommands.py:120
 msgid "Error: more than one file given as argument to shell."
 msgstr ""
-"Error: s'ha donat més d'un fitxer com a arguments per a l'intèrpret d'ordres."
+"Error: s'ha donat més d'un fitxer com a argument per a l'intèrpret d'ordres."
 
-#: ../yumcommands.py:160
+#: ../yumcommands.py:161
 msgid "PACKAGE..."
 msgstr "PAQUET..."
 
-#: ../yumcommands.py:163
+#: ../yumcommands.py:164
 msgid "Install a package or packages on your system"
 msgstr "Instal·la un o més paquets al vostre sistema"
 
-#: ../yumcommands.py:172
+#: ../yumcommands.py:173
 msgid "Setting up Install Process"
 msgstr "S'està preparant el procés d'instal·lació"
 
-#: ../yumcommands.py:183
+#: ../yumcommands.py:184
 msgid "[PACKAGE...]"
 msgstr "[PAQUET...]"
 
-#: ../yumcommands.py:186
+#: ../yumcommands.py:187
 msgid "Update a package or packages on your system"
 msgstr "S'ha actualitzat un o més paquets al vostre sistema"
 
-#: ../yumcommands.py:194
+#: ../yumcommands.py:195
 msgid "Setting up Update Process"
 msgstr "S'està preparant el procés d'actualització"
 
-#: ../yumcommands.py:236
+#: ../yumcommands.py:237
 msgid "Display details about a package or group of packages"
 msgstr "Mostra detalls sobre un paquet o un grup de paquets"
 
 #. Output the packages:
-#: ../yumcommands.py:261
+#: ../yumcommands.py:262
 msgid "Installed Packages"
 msgstr "Paquets instal·lats"
 
-#: ../yumcommands.py:263
+#: ../yumcommands.py:264
 msgid "Available Packages"
 msgstr "Paquets disponibles"
 
-#: ../yumcommands.py:265
+#: ../yumcommands.py:266
 msgid "Extra Packages"
 msgstr "Paquets extra"
 
-#: ../yumcommands.py:267
+#: ../yumcommands.py:268
 msgid "Updated Packages"
 msgstr "Paquets actualitzats"
 
-#: ../yumcommands.py:274 ../yumcommands.py:281
+#: ../yumcommands.py:275 ../yumcommands.py:282 ../yumcommands.py:551
 msgid "Obsoleting Packages"
-msgstr "Paquets fets obsolets"
+msgstr "Paquets obsolets"
 
-#: ../yumcommands.py:283
+#: ../yumcommands.py:284
 msgid "Recently Added Packages"
 msgstr "Paquets recentment afegits"
 
-#: ../yumcommands.py:290
+#: ../yumcommands.py:291
 msgid "No matching Packages to list"
 msgstr "No hi ha paquets coincidents per llistar"
 
-#: ../yumcommands.py:304
+#: ../yumcommands.py:305
 msgid "List a package or groups of packages"
 msgstr "Llista un paquet o un grup de paquets"
 
-#: ../yumcommands.py:316
+#: ../yumcommands.py:317
 msgid "Remove a package or packages from your system"
 msgstr "Esborra un o més paquets del vostre sistema"
 
-#: ../yumcommands.py:324
+#: ../yumcommands.py:325
 msgid "Setting up Remove Process"
 msgstr "S'està preparant el procés d'esborrat"
 
-#: ../yumcommands.py:339
+#: ../yumcommands.py:340
 msgid "Setting up Group Process"
 msgstr "S'està preparant el procés de grup"
 
-#: ../yumcommands.py:345
+#: ../yumcommands.py:346
 msgid "No Groups on which to run command"
 msgstr "No hi ha cap grup on executar l'ordre"
 
-#: ../yumcommands.py:358
+#: ../yumcommands.py:359
 msgid "List available package groups"
 msgstr "Llista els grups de paquets disponibles"
 
-#: ../yumcommands.py:375
+#: ../yumcommands.py:376
 msgid "Install the packages in a group on your system"
 msgstr "Instal·la els paquets en un grup en el vostre sistema"
 
-#: ../yumcommands.py:397
+#: ../yumcommands.py:398
 msgid "Remove the packages in a group from your system"
 msgstr "Esborra els paquets en un grup en el vostre sistema"
 
-#: ../yumcommands.py:424
+#: ../yumcommands.py:425
 msgid "Display details about a package group"
 msgstr "Mostra detalls sobre un grup de paquets"
 
-#: ../yumcommands.py:448
+#: ../yumcommands.py:449
 msgid "Generate the metadata cache"
 msgstr "Genera les metadades de la memòria cau"
 
-#: ../yumcommands.py:454
+#: ../yumcommands.py:455
 msgid "Making cache files for all metadata files."
 msgstr ""
 "S'estan fent els fitxers de memòria cau per a tots els fitxers de metadades."
 
-#: ../yumcommands.py:455
+#: ../yumcommands.py:456
 msgid "This may take a while depending on the speed of this computer"
 msgstr "Això pot trigar una estona depenent de la velocitat d'aquest ordinador"
 
-#: ../yumcommands.py:476
+#: ../yumcommands.py:477
 msgid "Metadata Cache Created"
 msgstr "S'han creat les metadades per a la memòria cau"
 
-#: ../yumcommands.py:490
+#: ../yumcommands.py:491
 msgid "Remove cached data"
 msgstr "S'han esborrat les dades de la memòria cau"
 
-#: ../yumcommands.py:511
+#: ../yumcommands.py:512
 msgid "Find what package provides the given value"
 msgstr "Troba quin paquet proporciona el valor donat"
 
-#: ../yumcommands.py:531
+#: ../yumcommands.py:532
 msgid "Check for available package updates"
 msgstr "Comprova si hi ha actualitzacions de paquets disponibles"
 
-#: ../yumcommands.py:556
+#: ../yumcommands.py:571
 msgid "Search package details for the given string"
 msgstr "Busca detalls del paquet per la cadena donada"
 
-#: ../yumcommands.py:562
+#: ../yumcommands.py:577
 msgid "Searching Packages: "
 msgstr "S'estan buscant paquets: "
 
-#: ../yumcommands.py:579
+#: ../yumcommands.py:594
 msgid "Update packages taking obsoletes into account"
 msgstr "Actualitza paquets tenint en compte els obsolets"
 
-#: ../yumcommands.py:588
+#: ../yumcommands.py:603
 msgid "Setting up Upgrade Process"
 msgstr "S'està preparant el procés d'actualització"
 
-#: ../yumcommands.py:602
+#: ../yumcommands.py:617
 msgid "Install a local RPM"
 msgstr "Instal·la un RPM local"
 
-#: ../yumcommands.py:611
+#: ../yumcommands.py:626
 msgid "Setting up Local Package Process"
 msgstr "S'està configurant el procés local de paquets"
 
-#: ../yumcommands.py:630
+#: ../yumcommands.py:645
 msgid "Determine which package provides the given dependency"
 msgstr "Determina quin paquet satisfà la dependència donada"
 
-#: ../yumcommands.py:633
+#: ../yumcommands.py:648
 msgid "Searching Packages for Dependency:"
 msgstr "S'estan buscant paquets per a la dependència:"
 
-#: ../yumcommands.py:647
+#: ../yumcommands.py:662
 msgid "Run an interactive yum shell"
 msgstr "Executa un intèrpret d'ordres interactiu de yum"
 
-#: ../yumcommands.py:653
+#: ../yumcommands.py:668
 msgid "Setting up Yum Shell"
 msgstr "S'està preparant l'intèrpret d'ordres de yum"
 
-#: ../yumcommands.py:671
+#: ../yumcommands.py:686
 msgid "List a package's dependencies"
 msgstr "Llista les dependències d'un paquet"
 
-#: ../yumcommands.py:677
+#: ../yumcommands.py:692
 msgid "Finding dependencies: "
 msgstr "S'estan trobant dependències: "
 
-#: ../yumcommands.py:693
+#: ../yumcommands.py:708
 msgid "Display the configured software repositories"
 msgstr "Mostra els repositoris de programari configurats"
 
-#: ../yumcommands.py:742
+#: ../yumcommands.py:756 ../yumcommands.py:769 ../yumcommands.py:770
 msgid "enabled"
 msgstr "habilitat"
 
-#: ../yumcommands.py:751
+#: ../yumcommands.py:765 ../yumcommands.py:768
 msgid "disabled"
 msgstr "deshabilitat"
 
-#: ../yumcommands.py:760
+#: ../yumcommands.py:777
 msgid "repo id"
 msgstr "id repo"
 
-#: ../yumcommands.py:761
+#: ../yumcommands.py:778
 msgid "repo name"
 msgstr "nom repo"
 
-#: ../yumcommands.py:761
+#: ../yumcommands.py:780
 msgid "status"
 msgstr "estat"
 
-#: ../yumcommands.py:764
+#: ../yumcommands.py:790
 msgid "Repo-id     : "
 msgstr "Id-repo         : "
 
-#: ../yumcommands.py:765
+#: ../yumcommands.py:791
 msgid "Repo-name   : "
 msgstr "Nom-repo        : "
 
-#: ../yumcommands.py:766
+#: ../yumcommands.py:792
 msgid "Repo-status : "
 msgstr "Estat-repo      : "
 
-#: ../yumcommands.py:768
+#: ../yumcommands.py:794
+
+msgid "Repo-revision: "
+msgstr "Repo-revisió    : "
+
+#: ../yumcommands.py:798
+msgid "Repo-tags   : "
+msgstr "Repo-etiquetes  : "
+
+#: ../yumcommands.py:804
+msgid "Repo-distro-tags: "
+msgstr "Repo-etiq-dist  : "
+
+#: ../yumcommands.py:809
 msgid "Repo-updated: "
 msgstr "Repo-actualitzat: "
 
-#: ../yumcommands.py:770
+#: ../yumcommands.py:811
 msgid "Repo-pkgs   : "
 msgstr "Paquets-repo    : "
 
-#: ../yumcommands.py:771
+#: ../yumcommands.py:812
 msgid "Repo-size   : "
 msgstr "Mida-repo       : "
 
-#: ../yumcommands.py:774
+#: ../yumcommands.py:819
 msgid "Repo-baseurl: "
 msgstr "URL-base-repo   : "
 
-#: ../yumcommands.py:778
+#: ../yumcommands.py:823
+msgid "Repo-metalink: "
+msgstr "Repo-metaenllaç : "
+
+#: ../yumcommands.py:826
 msgid "Repo-mirrors: "
 msgstr "Miralls-repo    : "
 
-#: ../yumcommands.py:782
+#: ../yumcommands.py:830
 msgid "Repo-exclude: "
 msgstr "Repo-exclou     : "
 
-#: ../yumcommands.py:786
+#: ../yumcommands.py:834
 msgid "Repo-include: "
 msgstr "Repo-inclou     : "
 
-#: ../yumcommands.py:812
+#: ../yumcommands.py:856
 msgid "Display a helpful usage message"
 msgstr "Mostra un missatge d'ajuda d'ús"
 
-#: ../yumcommands.py:846
+#: ../yumcommands.py:890
 #, python-format
 msgid "No help available for %s"
 msgstr "No hi ha ajuda disponible per a %s"
 
-#: ../yumcommands.py:851
+#: ../yumcommands.py:895
 msgid ""
 "\n"
 "\n"
@@ -1204,7 +1226,7 @@ msgstr ""
 "\n"
 "àlies: "
 
-#: ../yumcommands.py:853
+#: ../yumcommands.py:897
 msgid ""
 "\n"
 "\n"
@@ -1214,11 +1236,11 @@ msgstr ""
 "\n"
 "àlies: "
 
-#: ../yumcommands.py:882
+#: ../yumcommands.py:926
 msgid "Setting up Reinstall Process"
 msgstr "S'està preparant el procés de reinstal·lació"
 
-#: ../yumcommands.py:896
+#: ../yumcommands.py:940
 msgid "reinstall a package"
 msgstr "reinstal·la un paquet"
 
@@ -1289,201 +1311,201 @@ msgstr ""
 msgid "doTsSetup() will go away in a future version of Yum.\n"
 msgstr "doTsSetup() desapareixerà en una futura versió de Yum.\n"
 
-#: ../yum/depsolve.py:97
+#: ../yum/depsolve.py:99
 msgid "Setting up TransactionSets before config class is up"
 msgstr ""
 "S'està configurant TransactionSets abans que la classe de configuració "
 "estigui iniciada"
 
-#: ../yum/depsolve.py:148
+#: ../yum/depsolve.py:150
 #, python-format
 msgid "Invalid tsflag in config file: %s"
 msgstr "Tsflag invàlid en el fitxer de configuració: %s"
 
-#: ../yum/depsolve.py:159
+#: ../yum/depsolve.py:161
 #, python-format
 msgid "Searching pkgSack for dep: %s"
 msgstr "S'està buscant pkgSack per a la dependència: %s"
 
-#: ../yum/depsolve.py:182
+#: ../yum/depsolve.py:184
 #, python-format
 msgid "Potential match for %s from %s"
 msgstr "Coincidència potencial per a %s de %s"
 
-#: ../yum/depsolve.py:190
+#: ../yum/depsolve.py:192
 #, python-format
 msgid "Matched %s to require for %s"
 msgstr "La coincidència %s es requereix per a %s"
 
-#: ../yum/depsolve.py:231
+#: ../yum/depsolve.py:233
 #, python-format
 msgid "Member: %s"
 msgstr "Membre: %s"
 
-#: ../yum/depsolve.py:245 ../yum/depsolve.py:732
+#: ../yum/depsolve.py:247 ../yum/depsolve.py:734
 #, python-format
 msgid "%s converted to install"
 msgstr "%s convertits per a instal·lar"
 
-#: ../yum/depsolve.py:252
+#: ../yum/depsolve.py:254
 #, python-format
 msgid "Adding Package %s in mode %s"
 msgstr "S'està afegint el paquet %s en mode %s"
 
-#: ../yum/depsolve.py:262
+#: ../yum/depsolve.py:264
 #, python-format
 msgid "Removing Package %s"
 msgstr "S'està esborrant el paquet %s"
 
-#: ../yum/depsolve.py:273
+#: ../yum/depsolve.py:275
 #, python-format
 msgid "%s requires: %s"
 msgstr "%s requereix: %s"
 
-#: ../yum/depsolve.py:331
+#: ../yum/depsolve.py:333
 msgid "Needed Require has already been looked up, cheating"
 msgstr ""
 "El requeriment necessari ja s'ha buscat anteriorment, s'estan fent trampes"
 
-#: ../yum/depsolve.py:341
+#: ../yum/depsolve.py:343
 #, python-format
 msgid "Needed Require is not a package name. Looking up: %s"
 msgstr "El requeriment necessari no és un nom de paquet. S'està buscant: %s"
 
-#: ../yum/depsolve.py:348
+#: ../yum/depsolve.py:350
 #, python-format
 msgid "Potential Provider: %s"
 msgstr "Proveïdor potencial: %s"
 
-#: ../yum/depsolve.py:371
+#: ../yum/depsolve.py:373
 #, python-format
 msgid "Mode is %s for provider of %s: %s"
 msgstr "El mode és %s per al proveïdor de %s: %s"
 
-#: ../yum/depsolve.py:375
+#: ../yum/depsolve.py:377
 #, python-format
 msgid "Mode for pkg providing %s: %s"
 msgstr "Mode per al paquet que proporciona %s: %s"
 
-#: ../yum/depsolve.py:379
+#: ../yum/depsolve.py:381
 #, python-format
 msgid "TSINFO: %s package requiring %s marked as erase"
 msgstr "TSINFO: el paquet %s requereix %s marcat per a esborrar"
 
-#: ../yum/depsolve.py:391
+#: ../yum/depsolve.py:393
 #, python-format
 msgid "TSINFO: Obsoleting %s with %s to resolve dep."
 msgstr ""
 "TSINFO: S'està marcant com a obsolet %s amb %s per resoldre dependències."
 
-#: ../yum/depsolve.py:394
+#: ../yum/depsolve.py:396
 #, python-format
 msgid "TSINFO: Updating %s to resolve dep."
 msgstr "TSINFO: S'està actualitzant %s per a resoldre dependències."
 
-#: ../yum/depsolve.py:402
+#: ../yum/depsolve.py:404
 #, python-format
 msgid "Cannot find an update path for dep for: %s"
 msgstr "No es pot trobar un camí d'actualització de dependències per a: %s"
 
-#: ../yum/depsolve.py:412
+#: ../yum/depsolve.py:414
 #, python-format
 msgid "Unresolvable requirement %s for %s"
 msgstr "No es pot resoldre el requeriment %s per a %s"
 
-#: ../yum/depsolve.py:435
+#: ../yum/depsolve.py:437
 #, python-format
 msgid "Quick matched %s to require for %s"
 msgstr "La coincidència %s es requereix per a %s"
 
 #. is it already installed?
-#: ../yum/depsolve.py:477
+#: ../yum/depsolve.py:479
 #, python-format
 msgid "%s is in providing packages but it is already installed, removing."
 msgstr ""
 "%s es troba en els paquets proporcionats però ja es troba instal·lat, s'està "
 "esborrant."
 
-#: ../yum/depsolve.py:492
+#: ../yum/depsolve.py:494
 #, python-format
 msgid "Potential resolving package %s has newer instance in ts."
 msgstr ""
 "El paquet potencial que resol dependències %s té una instància nova a ts"
 
-#: ../yum/depsolve.py:503
+#: ../yum/depsolve.py:505
 #, python-format
 msgid "Potential resolving package %s has newer instance installed."
 msgstr ""
 "El paquet potencial que resol dependències %s té una nova instància "
 "insta·lada."
 
-#: ../yum/depsolve.py:511 ../yum/depsolve.py:560
+#: ../yum/depsolve.py:513 ../yum/depsolve.py:562
 #, python-format
 msgid "Missing Dependency: %s is needed by package %s"
 msgstr "La dependència que falta: %s es necessita per al paquet %s"
 
-#: ../yum/depsolve.py:524
+#: ../yum/depsolve.py:526
 #, python-format
 msgid "%s already in ts, skipping this one"
 msgstr "%s ja es troba en ts, s'està ometent"
 
-#: ../yum/depsolve.py:570
+#: ../yum/depsolve.py:572
 #, python-format
 msgid "TSINFO: Marking %s as update for %s"
 msgstr "TSINFO: S'està marcant %s com a actualització per a %s"
 
-#: ../yum/depsolve.py:578
+#: ../yum/depsolve.py:580
 #, python-format
 msgid "TSINFO: Marking %s as install for %s"
 msgstr "TSINFO: S'està marcant %s com a instal·lació per a %s"
 
-#: ../yum/depsolve.py:670 ../yum/depsolve.py:750
+#: ../yum/depsolve.py:672 ../yum/depsolve.py:752
 msgid "Success - empty transaction"
 msgstr "Èxit - transacció buida"
 
-#: ../yum/depsolve.py:709 ../yum/depsolve.py:722
+#: ../yum/depsolve.py:711 ../yum/depsolve.py:724
 msgid "Restarting Loop"
 msgstr "S'està recomençant el bucle"
 
-#: ../yum/depsolve.py:738
+#: ../yum/depsolve.py:740
 msgid "Dependency Process ending"
 msgstr "Està acabant el procés de dependències"
 
-#: ../yum/depsolve.py:744
+#: ../yum/depsolve.py:746
 #, python-format
 msgid "%s from %s has depsolving problems"
 msgstr "%s de %s té problemes resolent dependències"
 
-#: ../yum/depsolve.py:751
+#: ../yum/depsolve.py:753
 msgid "Success - deps resolved"
 msgstr "Èxit - dependències resoltes"
 
-#: ../yum/depsolve.py:765
+#: ../yum/depsolve.py:767
 #, python-format
 msgid "Checking deps for %s"
 msgstr "S'estan comprobant les dependències per a %s"
 
-#: ../yum/depsolve.py:848
+#: ../yum/depsolve.py:850
 #, python-format
 msgid "looking for %s as a requirement of %s"
 msgstr "s'està buscant %s com a requeriment de %s"
 
-#: ../yum/depsolve.py:988
+#: ../yum/depsolve.py:990
 #, python-format
 msgid "Running compare_providers() for %s"
 msgstr "S'està executant compare_providers() per a %s"
 
-#: ../yum/depsolve.py:1016 ../yum/depsolve.py:1022
+#: ../yum/depsolve.py:1018 ../yum/depsolve.py:1024
 #, python-format
 msgid "better arch in po %s"
 msgstr "millor arq en el po %s"
 
-#: ../yum/depsolve.py:1061
+#: ../yum/depsolve.py:1063
 #, python-format
 msgid "%s obsoletes %s"
 msgstr "%s fa obsolet %s"
 
-#: ../yum/depsolve.py:1077
+#: ../yum/depsolve.py:1079
 #, python-format
 msgid ""
 "archdist compared %s to %s on %s\n"
@@ -1492,116 +1514,116 @@ msgstr ""
 "archdist ha comparat %s amb %s a %s\n"
 "  Ha guanyat: %s"
 
-#: ../yum/depsolve.py:1084
+#: ../yum/depsolve.py:1086
 #, python-format
 msgid "common sourcerpm %s and %s"
 msgstr "rpm font comú %s i %s"
 
-#: ../yum/depsolve.py:1090
+#: ../yum/depsolve.py:1092
 #, python-format
 msgid "common prefix of %s between %s and %s"
 msgstr "prefix comú de %s entre %s i %s"
 
-#: ../yum/depsolve.py:1098
+#: ../yum/depsolve.py:1100
 #, python-format
 msgid "Best Order: %s"
 msgstr "Millor ordre: %s"
 
-#: ../yum/__init__.py:134
+#: ../yum/__init__.py:135
 msgid "doConfigSetup() will go away in a future version of Yum.\n"
 msgstr "doConfigsetup() desapareixerà en una futura versió de Yum.\n"
 
-#: ../yum/__init__.py:314
+#: ../yum/__init__.py:315
 #, python-format
 msgid "Repository %r is missing name in configuration, using id"
 msgstr "Falta el nom del repositori %r en la configuració, s'utilitzarà l'id"
 
-#: ../yum/__init__.py:352
+#: ../yum/__init__.py:353
 msgid "plugins already initialised"
 msgstr "els connectors ja estan inicialitzats"
 
-#: ../yum/__init__.py:359
+#: ../yum/__init__.py:360
 msgid "doRpmDBSetup() will go away in a future version of Yum.\n"
 msgstr "doRpmDBSetup() desapareixerà en una futura versió de Yum.\n"
 
-#: ../yum/__init__.py:369
+#: ../yum/__init__.py:370
 msgid "Reading Local RPMDB"
 msgstr "S'està llegint un RPMDB local"
 
-#: ../yum/__init__.py:387
+#: ../yum/__init__.py:388
 msgid "doRepoSetup() will go away in a future version of Yum.\n"
 msgstr "doRepoSetup() desapareixerà en una futura versió de Yum.\n"
 
-#: ../yum/__init__.py:407
+#: ../yum/__init__.py:408
 msgid "doSackSetup() will go away in a future version of Yum.\n"
 msgstr "doSackSetup() desapareixerà en una versió futura de Yum.\n"
 
-#: ../yum/__init__.py:424
+#: ../yum/__init__.py:425
 msgid "Setting up Package Sacks"
 msgstr "S'estan configurant els sacs de paquets"
 
-#: ../yum/__init__.py:467
+#: ../yum/__init__.py:468
 #, python-format
 msgid "repo object for repo %s lacks a _resetSack method\n"
 msgstr "l'objecte repositori per al repositori %s no té un mètode _resetSack\n"
 
-#: ../yum/__init__.py:468
+#: ../yum/__init__.py:469
 msgid "therefore this repo cannot be reset.\n"
 msgstr "Aquest repositori no es pot reiniciar.\n"
 
-#: ../yum/__init__.py:473
+#: ../yum/__init__.py:474
 msgid "doUpdateSetup() will go away in a future version of Yum.\n"
 msgstr "doUpdateSetup() desapareixerà en una futura versió de Yum.\n"
 
-#: ../yum/__init__.py:485
+#: ../yum/__init__.py:486
 msgid "Building updates object"
 msgstr "S'està construint l'objecte d'actualitzacions"
 
-#: ../yum/__init__.py:516
+#: ../yum/__init__.py:517
 msgid "doGroupSetup() will go away in a future version of Yum.\n"
 msgstr "doGroupSetup() desapareixerà en una futura versió de Yum.\n"
 
-#: ../yum/__init__.py:540
+#: ../yum/__init__.py:541
 msgid "Getting group metadata"
 msgstr "S'estan obtenint les metadades del grup"
 
-#: ../yum/__init__.py:566
+#: ../yum/__init__.py:567
 #, python-format
 msgid "Adding group file from repository: %s"
 msgstr "S'està afegint el fitxer del grup des del repositori: %s"
 
-#: ../yum/__init__.py:575
+#: ../yum/__init__.py:576
 #, python-format
 msgid "Failed to add groups file for repository: %s - %s"
 msgstr "No s'ha pogut afegir el fitxer dels grups des del repositori: %s - %s"
 
-#: ../yum/__init__.py:581
+#: ../yum/__init__.py:582
 msgid "No Groups Available in any repository"
 msgstr "No hi ha cap grup disponible en cap repositori"
 
-#: ../yum/__init__.py:631
+#: ../yum/__init__.py:632
 msgid "Importing additional filelist information"
 msgstr "S'està important informació adicional de la llista de fitxers"
 
-#: ../yum/__init__.py:639
+#: ../yum/__init__.py:641
 msgid ""
-"There are unfinished transactions remaining. You mightconsider running yum-"
+"There are unfinished transactions remaining. You might consider running yum-"
 "complete-transaction first to finish them."
 msgstr ""
-"Encara hi ha transaccions sense acabar. Hauríeu de considerar executar "
-"yum-complete-transaction abans per acabar-ho."
+"Encara hi ha transaccions sense acabar. Hauríeu de considerar executar yum-"
+"complete-transaction abans per acabar-les."
 
-#: ../yum/__init__.py:689
+#: ../yum/__init__.py:702
 #, python-format
 msgid "Skip-broken round %i"
 msgstr "Intent %i d'omissió dels trencats"
 
-#: ../yum/__init__.py:712
+#: ../yum/__init__.py:751
 #, python-format
 msgid "Skip-broken took %i rounds "
 msgstr "L'omisió dels trencats ha necessitat %i intents"
 
-#: ../yum/__init__.py:713
+#: ../yum/__init__.py:752
 msgid ""
 "\n"
 "Packages skipped because of dependency problems:"
@@ -1609,93 +1631,93 @@ msgstr ""
 "\n"
 "Paquets omesos degut a problemes de dependències:"
 
-#: ../yum/__init__.py:717
+#: ../yum/__init__.py:756
 #, python-format
 msgid "    %s from %s"
 msgstr "    %s des de %s"
 
-#: ../yum/__init__.py:802
+#: ../yum/__init__.py:878
 msgid ""
 "Warning: scriptlet or other non-fatal errors occurred during transaction."
 msgstr ""
 "Avís: ha fallat l'scriptlet o s'han produït altre tipus d'errors no fatals "
 "durant la transacció."
 
-#: ../yum/__init__.py:818
+#: ../yum/__init__.py:894
 #, python-format
 msgid "Failed to remove transaction file %s"
 msgstr "No s'ha pogut esborrar el fitxer de transaccions %s"
 
-#: ../yum/__init__.py:859
+#: ../yum/__init__.py:935
 #, python-format
 msgid "excluding for cost: %s from %s"
 msgstr "s'està excloent per cost: %s de %s"
 
-#: ../yum/__init__.py:890
+#: ../yum/__init__.py:966
 msgid "Excluding Packages in global exclude list"
 msgstr "S'estan excloent paquets en la llista global d'exclusió"
 
-#: ../yum/__init__.py:892
+#: ../yum/__init__.py:968
 #, python-format
 msgid "Excluding Packages from %s"
 msgstr "S'estan excloent paquets de %s"
 
-#: ../yum/__init__.py:919
+#: ../yum/__init__.py:995
 #, python-format
 msgid "Reducing %s to included packages only"
 msgstr "S'està reduint %s únicament a paquets inclosos."
 
-#: ../yum/__init__.py:925
+#: ../yum/__init__.py:1001
 #, python-format
 msgid "Keeping included package %s"
 msgstr "S'està mantenint el paquet inclòs %s"
 
-#: ../yum/__init__.py:931
+#: ../yum/__init__.py:1007
 #, python-format
 msgid "Removing unmatched package %s"
 msgstr "S'està esborrant el paquet sense coincidències %s"
 
-#: ../yum/__init__.py:934
+#: ../yum/__init__.py:1010
 msgid "Finished"
 msgstr "Finalitzat"
 
 #. Whoa. What the heck happened?
-#: ../yum/__init__.py:964
+#: ../yum/__init__.py:1040
 #, python-format
 msgid "Unable to check if PID %s is active"
 msgstr "No s'ha pogut comprovar si el PID %s es troba actiu"
 
 #. Another copy seems to be running.
-#: ../yum/__init__.py:968
+#: ../yum/__init__.py:1044
 #, python-format
 msgid "Existing lock %s: another copy is running as pid %s."
 msgstr "Bloqueig existent %s: una altra còpia s'està executant amb pid %s."
 
-#: ../yum/__init__.py:1039
+#: ../yum/__init__.py:1115
 msgid "Package does not match intended download"
 msgstr "El paquet no coincideix amb la descàrrega intentada"
 
-#: ../yum/__init__.py:1054
+#: ../yum/__init__.py:1130
 msgid "Could not perform checksum"
 msgstr "No s'ha pogut realitzar la suma de verificació"
 
-#: ../yum/__init__.py:1057
+#: ../yum/__init__.py:1133
 msgid "Package does not match checksum"
 msgstr "No coincideix la suma de verificació del paquet"
 
-#: ../yum/__init__.py:1100
+#: ../yum/__init__.py:1176
 #, python-format
 msgid "package fails checksum but caching is enabled for %s"
 msgstr ""
 "la suma de verificació del paquet falla però l'ús de memòria cau està "
 "habilitat per a %s"
 
-#: ../yum/__init__.py:1103
+#: ../yum/__init__.py:1179 ../yum/__init__.py:1207
 #, python-format
 msgid "using local copy of %s"
 msgstr "s'està utilitzant la còpia local de %s"
 
-#: ../yum/__init__.py:1130
+#: ../yum/__init__.py:1221
 #, python-format
 msgid ""
 "Insufficient space in download directory %s\n"
@@ -1706,11 +1728,11 @@ msgstr ""
 "    * lliure    %s\n"
 "    * necessari %s"
 
-#: ../yum/__init__.py:1177
+#: ../yum/__init__.py:1268
 msgid "Header is not complete."
 msgstr "La capçalera no està completa."
 
-#: ../yum/__init__.py:1217
+#: ../yum/__init__.py:1308
 #, python-format
 msgid ""
 "Header not in local cache and caching-only mode enabled. Cannot download %s"
@@ -1718,62 +1740,62 @@ msgstr ""
 "La capçalera no es troba en la memòria cau local i està habilitat el mode de "
 "només memòria cau. No es pot descarregar %s"
 
-#: ../yum/__init__.py:1272
+#: ../yum/__init__.py:1363
 #, python-format
 msgid "Public key for %s is not installed"
 msgstr "La clau pública per a %s no està instal·lada"
 
-#: ../yum/__init__.py:1276
+#: ../yum/__init__.py:1367
 #, python-format
 msgid "Problem opening package %s"
 msgstr "Hi ha hagut un problema obrint el paquet %s"
 
-#: ../yum/__init__.py:1284
+#: ../yum/__init__.py:1375
 #, python-format
 msgid "Public key for %s is not trusted"
 msgstr "La clau pública per a %s no és de confiança"
 
-#: ../yum/__init__.py:1288
+#: ../yum/__init__.py:1379
 #, python-format
 msgid "Package %s is not signed"
 msgstr "El paquet %s no està signat"
 
-#: ../yum/__init__.py:1326
+#: ../yum/__init__.py:1417
 #, python-format
 msgid "Cannot remove %s"
 msgstr "No es pot esborrar %s"
 
-#: ../yum/__init__.py:1330
+#: ../yum/__init__.py:1421
 #, python-format
 msgid "%s removed"
 msgstr "S'ha esborrat %s"
 
-#: ../yum/__init__.py:1367
+#: ../yum/__init__.py:1458
 #, python-format
 msgid "Cannot remove %s file %s"
 msgstr "No es pot esborrar %s fitxer %s"
 
-#: ../yum/__init__.py:1371
+#: ../yum/__init__.py:1462
 #, python-format
 msgid "%s file %s removed"
 msgstr "%s fitxer %s esborrat"
 
-#: ../yum/__init__.py:1373
+#: ../yum/__init__.py:1464
 #, python-format
 msgid "%d %s files removed"
 msgstr "%d %s fitxers esborrats"
 
-#: ../yum/__init__.py:1435
+#: ../yum/__init__.py:1526
 #, python-format
 msgid "More than one identical match in sack for %s"
 msgstr "Hi ha més d'una coincidència idèntica en el sac per a %s"
 
-#: ../yum/__init__.py:1441
+#: ../yum/__init__.py:1532
 #, python-format
 msgid "Nothing matches %s.%s %s:%s-%s from update"
 msgstr "No hi ha coincidències %s.%s-%s:%s-%s de l'actualització"
 
-#: ../yum/__init__.py:1649
+#: ../yum/__init__.py:1740
 msgid ""
 "searchPackages() will go away in a future version of "
 "Yum.                      Use searchGenerator() instead. \n"
@@ -1781,179 +1803,180 @@ msgstr ""
 "searchPackages() desapareixerà en una futura versió de "
 "Yum.                      Useu searchGenerator(). \n"
 
-#: ../yum/__init__.py:1687
+#: ../yum/__init__.py:1778
 #, python-format
 msgid "Searching %d packages"
 msgstr "S'estan buscant %d paquets"
 
-#: ../yum/__init__.py:1691
+#: ../yum/__init__.py:1782
 #, python-format
 msgid "searching package %s"
 msgstr "s'està buscant el paquet %s"
 
-#: ../yum/__init__.py:1703
+#: ../yum/__init__.py:1794
 msgid "searching in file entries"
 msgstr "s'està buscant en les entrades de fitxers"
 
-#: ../yum/__init__.py:1710
+#: ../yum/__init__.py:1801
 msgid "searching in provides entries"
 msgstr "s'està buscant en les entrades proporcionades"
 
-#: ../yum/__init__.py:1743
+#: ../yum/__init__.py:1834
 #, python-format
 msgid "Provides-match: %s"
 msgstr "Proporciona-coincideix: %s"
 
-#: ../yum/__init__.py:1792
+#: ../yum/__init__.py:1883
 msgid "No group data available for configured repositories"
 msgstr "No hi ha dades de grup disponible en cap dels repositoris configurats"
 
-#: ../yum/__init__.py:1818 ../yum/__init__.py:1837 ../yum/__init__.py:1868
-#: ../yum/__init__.py:1874 ../yum/__init__.py:1947 ../yum/__init__.py:1951
+#: ../yum/__init__.py:1909 ../yum/__init__.py:1928 ../yum/__init__.py:1959
+#: ../yum/__init__.py:1965 ../yum/__init__.py:2038 ../yum/__init__.py:2042
 #, python-format
 msgid "No Group named %s exists"
 msgstr "No existeix cap grup anomenat %s"
 
-#: ../yum/__init__.py:1849 ../yum/__init__.py:1964
+#: ../yum/__init__.py:1940 ../yum/__init__.py:2055
 #, python-format
 msgid "package %s was not marked in group %s"
 msgstr "el paquet %s no estava marcat en el grup %s"
 
-#: ../yum/__init__.py:1896
+#: ../yum/__init__.py:1987
 #, python-format
 msgid "Adding package %s from group %s"
 msgstr "S'està afegint el paquet %s del grup %s"
 
-#: ../yum/__init__.py:1900
+#: ../yum/__init__.py:1991
 #, python-format
 msgid "No package named %s available to be installed"
 msgstr "No hi ha cap paquet anomenat %s disponible per a ser instal·lat"
 
-#: ../yum/__init__.py:1989
+#: ../yum/__init__.py:2080
 #, python-format
 msgid "Package tuple %s could not be found in packagesack"
 msgstr "No s'ha pogut trobar la tupla de paquets %s al sac de paquets"
 
-#: ../yum/__init__.py:2004
+#: ../yum/__init__.py:2095
 msgid ""
 "getInstalledPackageObject() will go away, use self.rpmdb.searchPkgTuple().\n"
 msgstr ""
-"getInstalledPackageObject() desapareixarà, useu self.rpmdb.searchPkgTuple().\n"
+"getInstalledPackageObject() desapareixarà, useu self.rpmdb.searchPkgTuple"
+"().\n"
 
-#: ../yum/__init__.py:2056 ../yum/__init__.py:2099
+#: ../yum/__init__.py:2147 ../yum/__init__.py:2190
 msgid "Invalid versioned dependency string, try quoting it."
 msgstr ""
 "La cadena de versió de dependència és invàlida, proveu-ho entre cometes."
 
-#: ../yum/__init__.py:2058 ../yum/__init__.py:2101
+#: ../yum/__init__.py:2149 ../yum/__init__.py:2192
 msgid "Invalid version flag"
 msgstr "Versió de flag invàlida"
 
-#: ../yum/__init__.py:2073 ../yum/__init__.py:2077
+#: ../yum/__init__.py:2164 ../yum/__init__.py:2168
 #, python-format
 msgid "No Package found for %s"
 msgstr "No s'ha trobat cap paquet per a %s"
 
-#: ../yum/__init__.py:2276
+#: ../yum/__init__.py:2367
 msgid "Package Object was not a package object instance"
 msgstr "L'objecte paquet no era una instància d'objecte paquet"
 
-#: ../yum/__init__.py:2280
+#: ../yum/__init__.py:2371
 msgid "Nothing specified to install"
 msgstr "No hi ha res especificat per a instal·lar"
 
 #. only one in there
-#: ../yum/__init__.py:2298
+#: ../yum/__init__.py:2389
 #, python-format
 msgid "Checking for virtual provide or file-provide for %s"
 msgstr ""
 "S'està verificant si hi ha un proveïdor virtual o un fitxer proveïdor per a %"
 "s"
 
-#: ../yum/__init__.py:2304 ../yum/__init__.py:2680
+#: ../yum/__init__.py:2395 ../yum/__init__.py:2777
 #, python-format
 msgid "No Match for argument: %s"
 msgstr "No hi ha cap coincidència per a l'argument: %s"
 
-#: ../yum/__init__.py:2370
+#: ../yum/__init__.py:2461
 #, python-format
 msgid "Package %s installed and not available"
 msgstr "El paquet %s es troba instal·lat però no és disponible"
 
-#: ../yum/__init__.py:2373
+#: ../yum/__init__.py:2464
 msgid "No package(s) available to install"
 msgstr "No hi ha cap paquet disponible per a instal·lar"
 
-#: ../yum/__init__.py:2385
+#: ../yum/__init__.py:2476
 #, python-format
 msgid "Package: %s  - already in transaction set"
 msgstr "El paquet: %s  - ja està en la transacció"
 
-#: ../yum/__init__.py:2398
+#: ../yum/__init__.py:2489
 #, python-format
 msgid "Package %s already installed and latest version"
 msgstr "El paquet %s ja es troba instal·lat i en l'última versió."
 
-#: ../yum/__init__.py:2405
+#: ../yum/__init__.py:2496
 #, python-format
 msgid "Package matching %s already installed. Checking for update."
 msgstr ""
 "El paquet coincident %s ja es troba instal·lat. S'està buscant una "
 "actualització."
 
-#: ../yum/__init__.py:2415
+#: ../yum/__init__.py:2506
 #, python-format
 msgid "Package %s is obsoleted by %s, trying to install %s instead"
 msgstr "El paquet %s és obsolet degut a %s, es provarà d'instal·lar %s"
 
 #. update everything (the easy case)
-#: ../yum/__init__.py:2485
+#: ../yum/__init__.py:2576
 msgid "Updating Everything"
 msgstr "S'està actualitzant tot"
 
-#: ../yum/__init__.py:2497 ../yum/__init__.py:2602 ../yum/__init__.py:2613
-#: ../yum/__init__.py:2635
+#: ../yum/__init__.py:2588 ../yum/__init__.py:2693 ../yum/__init__.py:2704
+#: ../yum/__init__.py:2726
 #, python-format
 msgid "Not Updating Package that is already obsoleted: %s.%s %s:%s-%s"
 msgstr "No s'actualitzarà el paquet obsolet: %s.%s %s:%s-%s"
 
-#: ../yum/__init__.py:2593
+#: ../yum/__init__.py:2684
 #, python-format
 msgid "Package is already obsoleted: %s.%s %s:%s-%s"
 msgstr "El paquet és obsolet: %s.%s. %s:%s-%s"
 
-#: ../yum/__init__.py:2616 ../yum/__init__.py:2638
+#: ../yum/__init__.py:2707 ../yum/__init__.py:2729
 #, python-format
 msgid "Not Updating Package that is already updated: %s.%s %s:%s-%s"
 msgstr "No s'actualitzarà el paquet actualitzat: %s.%s %s:%s-%s"
 
-#: ../yum/__init__.py:2677
+#: ../yum/__init__.py:2774
 #, python-format
 msgid "%s"
 msgstr "%s"
 
-#: ../yum/__init__.py:2693
+#: ../yum/__init__.py:2790
 msgid "No package matched to remove"
 msgstr "No hi ha cap paquet coincident per a esborrar"
 
-#: ../yum/__init__.py:2727
+#: ../yum/__init__.py:2824
 #, python-format
 msgid "Cannot open file: %s. Skipping."
 msgstr "No es pot obrir el fitxer %s. S'ometrà."
 
-#: ../yum/__init__.py:2730
+#: ../yum/__init__.py:2827
 #, python-format
 msgid "Examining %s: %s"
 msgstr "S'està examinant %s: %s"
 
-#: ../yum/__init__.py:2738
+#: ../yum/__init__.py:2835
 #, python-format
 msgid "Cannot add package %s to transaction. Not a compatible architecture: %s"
 msgstr ""
 "No s'ha pogut afegir el paquet %s a la transacció. No és una arquitectura "
 "compatible: %s"
 
-#: ../yum/__init__.py:2746
+#: ../yum/__init__.py:2843
 #, python-format
 msgid ""
 "Package %s not installed, cannot update it. Run yum install to install it "
@@ -1962,81 +1985,81 @@ msgstr ""
 "El paquet %s no està instal·lat; no es pot actualitzar. Executa yum install "
 "per a instal·lar-lo."
 
-#: ../yum/__init__.py:2779
+#: ../yum/__init__.py:2876
 #, python-format
 msgid "Excluding %s"
 msgstr "S'està excloent %s"
 
-#: ../yum/__init__.py:2784
+#: ../yum/__init__.py:2881
 #, python-format
 msgid "Marking %s to be installed"
 msgstr "S'està marcant %s per a ser instal·lat"
 
-#: ../yum/__init__.py:2790
+#: ../yum/__init__.py:2887
 #, python-format
 msgid "Marking %s as an update to %s"
 msgstr "S'està marcant %s com a actualització de %s"
 
-#: ../yum/__init__.py:2797
+#: ../yum/__init__.py:2894
 #, python-format
 msgid "%s: does not update installed package."
 msgstr "%s no actualitza el paquet instal·lat."
 
-#: ../yum/__init__.py:2815
+#: ../yum/__init__.py:2912
 msgid "Problem in reinstall: no package matched to remove"
 msgstr ""
 "Hi ha un problema en reinstal·lar: no hi ha cap paquet marcat per a esborrar"
 
-#: ../yum/__init__.py:2826
+#: ../yum/__init__.py:2923
 #, python-format
 msgid "Package %s is allowed multiple installs, skipping"
 msgstr "El paquet %s permet múltiples instal·lacions, s'està ometent"
 
-#: ../yum/__init__.py:2833
+#: ../yum/__init__.py:2930
 msgid "Problem in reinstall: no package matched to install"
 msgstr ""
 "Hi ha un problema en reinstal·lar: no hi ha cap paquet marcat per a "
 "instal·lar"
 
-#: ../yum/__init__.py:2868
+#: ../yum/__init__.py:2965
 #, python-format
 msgid "Retrieving GPG key from %s"
 msgstr "S'està recuperant la clau GPG des de %s"
 
-#: ../yum/__init__.py:2874
+#: ../yum/__init__.py:2985
 msgid "GPG key retrieval failed: "
 msgstr "La recuperació de la clau GPG ha fallat: "
 
-#: ../yum/__init__.py:2885
+#: ../yum/__init__.py:2996
 #, python-format
 msgid "GPG key parsing failed: key does not have value %s"
 msgstr "L'ànalisi de la clau GPG ha fallat: la clau no té el valor %s"
 
-#: ../yum/__init__.py:2917
+#: ../yum/__init__.py:3028
 #, python-format
 msgid "GPG key at %s (0x%s) is already installed"
 msgstr "La clau GPG de %s (0x%s) ja està instal·lada"
 
 #. Try installing/updating GPG key
-#: ../yum/__init__.py:2922 ../yum/__init__.py:2984
+#: ../yum/__init__.py:3033 ../yum/__init__.py:3095
 #, python-format
 msgid "Importing GPG key 0x%s \"%s\" from %s"
 msgstr "S'està important la clau GPG 0x%s \"%s\" des de %s"
 
-#: ../yum/__init__.py:2939
+#: ../yum/__init__.py:3050
 msgid "Not installing key"
 msgstr "No s'està instal·lant la clau"
 
-#: ../yum/__init__.py:2945
+#: ../yum/__init__.py:3056
 #, python-format
 msgid "Key import failed (code %d)"
 msgstr "L'importació de la clau ha fallat (codi %d)"
 
-#: ../yum/__init__.py:2946 ../yum/__init__.py:3005
+#: ../yum/__init__.py:3057 ../yum/__init__.py:3116
 msgid "Key imported successfully"
 msgstr "La clau s'ha importat amb èxit"
 
-#: ../yum/__init__.py:2951 ../yum/__init__.py:3010
+#: ../yum/__init__.py:3062 ../yum/__init__.py:3121
 #, python-format
 msgid ""
 "The GPG keys listed for the \"%s\" repository are already installed but they "
@@ -2048,73 +2071,73 @@ msgstr ""
 "Comproveu que les URL de clau correctes estan configurades per a aquest "
 "repositori."
 
-#: ../yum/__init__.py:2960
+#: ../yum/__init__.py:3071
 msgid "Import of key(s) didn't help, wrong key(s)?"
 msgstr "La importació de claus no ha ajudat, eren claus incorrectes?"
 
-#: ../yum/__init__.py:2979
+#: ../yum/__init__.py:3090
 #, python-format
 msgid "GPG key at %s (0x%s) is already imported"
 msgstr "La clau GPG a %s (0x%s) ja ha estat importada"
 
-#: ../yum/__init__.py:2999
+#: ../yum/__init__.py:3110
 #, python-format
 msgid "Not installing key for repo %s"
 msgstr "No s'està instal·lant la clau per al repositori %s"
 
-#: ../yum/__init__.py:3004
+#: ../yum/__init__.py:3115
 msgid "Key import failed"
 msgstr "Ha fallat la importació de la clau"
 
-#: ../yum/__init__.py:3095
+#: ../yum/__init__.py:3206
 msgid "Unable to find a suitable mirror."
 msgstr "No s'ha pogut trobar un servidor rèplica vàlid."
 
-#: ../yum/__init__.py:3097
+#: ../yum/__init__.py:3208
 msgid "Errors were encountered while downloading packages."
 msgstr "S'han trobat errors descarregant paquets."
 
-#: ../yum/__init__.py:3161
+#: ../yum/__init__.py:3272
 msgid "Test Transaction Errors: "
 msgstr "Errors en la transacció de prova: "
 
 #. Mostly copied from YumOutput._outKeyValFill()
-#: ../yum/plugins.py:199
+#: ../yum/plugins.py:201
 msgid "Loaded plugins: "
 msgstr "Connectors carregats: "
 
-#: ../yum/plugins.py:213 ../yum/plugins.py:219
+#: ../yum/plugins.py:215 ../yum/plugins.py:221
 #, python-format
 msgid "No plugin match for: %s"
 msgstr "No hi ha cap connector que coincideixi amb: %s"
 
-#: ../yum/plugins.py:249
+#: ../yum/plugins.py:251
 #, python-format
 msgid "\"%s\" plugin is disabled"
 msgstr "El connector \"%s\" està deshabilitat"
 
 #. Give full backtrace:
-#: ../yum/plugins.py:261
+#: ../yum/plugins.py:263
 #, python-format
 msgid "Plugin \"%s\" can't be imported"
 msgstr "No s'ha pogut importar el connector «%s»"
 
-#: ../yum/plugins.py:268
+#: ../yum/plugins.py:270
 #, python-format
 msgid "Plugin \"%s\" doesn't specify required API version"
 msgstr "El connector \"%s\" no especifica la versió de l'API requerida."
 
-#: ../yum/plugins.py:273
+#: ../yum/plugins.py:275
 #, python-format
 msgid "Plugin \"%s\" requires API %s. Supported API is %s."
 msgstr "El connector \"%s\" requereix l'API %s. L'API disponible és %s"
 
-#: ../yum/plugins.py:306
+#: ../yum/plugins.py:308
 #, python-format
 msgid "Loading \"%s\" plugin"
 msgstr "S'està carregant el connector \"%s\""
 
-#: ../yum/plugins.py:313
+#: ../yum/plugins.py:315
 #, python-format
 msgid ""
 "Two or more plugins with the name \"%s\" exist in the plugin search path"
@@ -2122,19 +2145,19 @@ msgstr ""
 "Existeixen dos o més connectors amb el mateix nom \"%s\" en el camí de cerca "
 "de connectors"
 
-#: ../yum/plugins.py:333
+#: ../yum/plugins.py:335
 #, python-format
 msgid "Configuration file %s not found"
 msgstr "No s'ha trobat el fitxer de configuració %s"
 
 #. for
 #. Configuration files for the plugin not found
-#: ../yum/plugins.py:336
+#: ../yum/plugins.py:338
 #, python-format
 msgid "Unable to find configuration file for plugin %s"
 msgstr "No s'ha pogut trobar un fitxer de configuració per al connector %s"
 
-#: ../yum/plugins.py:490
+#: ../yum/plugins.py:492
 msgid "registration of commands not supported"
 msgstr "l'enregistrament d'ordres no està suportat"
 
diff --git a/po/de.po b/po/de.po
index 2e31f46..f4e419d 100644
--- a/po/de.po
+++ b/po/de.po
@@ -9,8 +9,8 @@ msgid ""
 msgstr ""
 "Project-Id-Version: yum\n"
 "Report-Msgid-Bugs-To: \n"
-"POT-Creation-Date: 2008-10-17 02:09+0000\n"
-"PO-Revision-Date: 2008-10-23 09:23+0100\n"
+"POT-Creation-Date: 2008-11-13 05:44+0000\n"
+"PO-Revision-Date: 2008-11-15 21:05+0100\n"
 "Last-Translator: Fabian Affolter <fab@fedoraproject.org>\n"
 "Language-Team: German <fedora-trans-de@redhat.com>\n"
 "MIME-Version: 1.0\n"
@@ -20,7 +20,7 @@ msgstr ""
 "X-Poedit-Language: German\n"
 
 #: ../callback.py:48
-#: ../output.py:777
+#: ../output.py:808
 #: ../yum/rpmtrans.py:71
 msgid "Updating"
 msgstr "Aktualisieren"
@@ -30,11 +30,10 @@ msgstr "Aktualisieren"
 msgid "Erasing"
 msgstr "Löschen"
 
-#. Arch can't get "that big" ... so always use the max.
 #: ../callback.py:50
 #: ../callback.py:51
 #: ../callback.py:53
-#: ../output.py:776
+#: ../output.py:807
 #: ../yum/rpmtrans.py:73
 #: ../yum/rpmtrans.py:74
 #: ../yum/rpmtrans.py:76
@@ -48,7 +47,7 @@ msgid "Obsoleted"
 msgstr "Veraltet"
 
 #: ../callback.py:54
-#: ../output.py:890
+#: ../output.py:913
 msgid "Updated"
 msgstr "Aktualisiert"
 
@@ -59,7 +58,7 @@ msgstr "Gelöscht"
 #: ../callback.py:56
 #: ../callback.py:57
 #: ../callback.py:59
-#: ../output.py:888
+#: ../output.py:911
 msgid "Installed"
 msgstr "Installiert"
 
@@ -83,7 +82,7 @@ msgid "Erased: %s"
 msgstr "Gelöscht: %s"
 
 #: ../callback.py:217
-#: ../output.py:778
+#: ../output.py:809
 msgid "Removing"
 msgstr "Entfernen"
 
@@ -106,14 +105,14 @@ msgid "Reading repository metadata in from local files"
 msgstr "Lese Repository-Metadaten aus lokalen Dateien ein"
 
 #: ../cli.py:187
-#: ../utils.py:71
+#: ../utils.py:79
 #, python-format
 msgid "Config Error: %s"
 msgstr "Konfigurationsfehler: %s"
 
 #: ../cli.py:190
-#: ../cli.py:1125
-#: ../utils.py:74
+#: ../cli.py:1132
+#: ../utils.py:82
 #, python-format
 msgid "Options Error: %s"
 msgstr "Optionenfehler: %s"
@@ -173,17 +172,17 @@ msgid "Error Downloading Packages:\n"
 msgstr "Fehler beim Herunterladen der Pakete:\n"
 
 #: ../cli.py:404
-#: ../yum/__init__.py:3133
+#: ../yum/__init__.py:3287
 msgid "Running rpm_check_debug"
 msgstr "Führe rpm_check_debug durch"
 
 #: ../cli.py:407
-#: ../yum/__init__.py:3136
+#: ../yum/__init__.py:3290
 msgid "ERROR with rpm_check_debug vs depsolve:"
 msgstr "FEHLER mit rpm_check_debug gegen depsolve:"
 
 #: ../cli.py:411
-#: ../yum/__init__.py:3138
+#: ../yum/__init__.py:3292
 msgid "Please report this error in bugzilla"
 msgstr "Bitte melden Sie diesen Fehler in Bugzilla"
 
@@ -238,14 +237,14 @@ msgstr "Analysiere Installationsargumente des Pakets"
 
 #: ../cli.py:582
 #: ../cli.py:657
-#: ../yumcommands.py:889
+#: ../yumcommands.py:933
 msgid "Package(s) to install"
 msgstr "Paket(e) zum Installieren"
 
 #: ../cli.py:583
 #: ../cli.py:658
-#: ../yumcommands.py:150
-#: ../yumcommands.py:890
+#: ../yumcommands.py:151
+#: ../yumcommands.py:934
 msgid "Nothing to do"
 msgstr "Nichts zu tun"
 
@@ -328,72 +327,72 @@ msgstr "Räume Metadaten für abgelaufene Caches auf"
 msgid "Cleaning up plugins"
 msgstr "Räume Plugins auf"
 
-#: ../cli.py:851
+#: ../cli.py:855
 msgid "Installed Groups:"
 msgstr "Installierte Gruppen:"
 
-#: ../cli.py:858
+#: ../cli.py:862
 msgid "Available Groups:"
 msgstr "Verfügbare Gruppen:"
 
-#: ../cli.py:864
+#: ../cli.py:868
 msgid "Done"
 msgstr "Fertig"
 
-#: ../cli.py:875
-#: ../cli.py:893
-#: ../cli.py:899
-#: ../yum/__init__.py:2245
+#: ../cli.py:879
+#: ../cli.py:897
+#: ../cli.py:903
+#: ../yum/__init__.py:2368
 #, python-format
 msgid "Warning: Group %s does not exist."
 msgstr "Warnung: Gruppe %s existiert nicht."
 
-#: ../cli.py:903
+#: ../cli.py:907
 msgid "No packages in any requested group available to install or update"
 msgstr "Keine Pakete in irgendeiner Gruppe verfügbar zum Installieren oder Aktualisieren"
 
-#: ../cli.py:905
+#: ../cli.py:909
 #, python-format
 msgid "%d Package(s) to Install"
 msgstr "%d Paket(e) zum Installieren"
 
-#: ../cli.py:915
-#: ../yum/__init__.py:2257
+#: ../cli.py:919
+#: ../yum/__init__.py:2380
 #, python-format
 msgid "No group named %s exists"
 msgstr "Es existiert keine Gruppe mit dem Namen %s"
 
-#: ../cli.py:921
+#: ../cli.py:925
 msgid "No packages to remove from groups"
 msgstr "Keine Pakete zum Entfernen aus dem Gruppen gefunden"
 
-#: ../cli.py:923
+#: ../cli.py:927
 #, python-format
 msgid "%d Package(s) to remove"
 msgstr "%d Paket(e) zum Entfernen"
 
-#: ../cli.py:965
+#: ../cli.py:969
 #, python-format
 msgid "Package %s is already installed, skipping"
 msgstr "Paket %s ist bereits installiert, überspringe"
 
-#: ../cli.py:976
+#: ../cli.py:980
 #, python-format
 msgid "Discarding non-comparable pkg %s.%s"
 msgstr "Verwerfe nicht vergleichbare Pakete %s.%s"
 
 #. we've not got any installed that match n or n+a
-#: ../cli.py:1002
+#: ../cli.py:1006
 #, python-format
 msgid "No other %s installed, adding to list for potential install"
 msgstr "Kein anderes %s installiert, füge es zur Liste für eine potentielle Installation hinzu"
 
-#: ../cli.py:1021
+#: ../cli.py:1025
 #, python-format
 msgid "Command line error: %s"
 msgstr "Kommandozeilen-Fehler: %s"
 
-#: ../cli.py:1034
+#: ../cli.py:1038
 #, python-format
 msgid ""
 "\n"
@@ -404,244 +403,244 @@ msgstr ""
 "\n"
 "%s: %s Option benötigt ein Argument"
 
-#: ../cli.py:1167
+#: ../cli.py:1174
 msgid "show this help message and exit"
 msgstr "Hilfeinformation anzeigen und beenden"
 
-#: ../cli.py:1171
+#: ../cli.py:1178
 msgid "be tolerant of errors"
 msgstr "fehlertolerant sein"
 
-#: ../cli.py:1173
+#: ../cli.py:1180
 msgid "run entirely from cache, don't update cache"
 msgstr "laufe komplett aus dem Zwischenspeicher, aktualisiere Zwischenspeicher nicht"
 
-#: ../cli.py:1175
+#: ../cli.py:1182
 msgid "config file location"
 msgstr "Ort der Konfigurationsdatei"
 
-#: ../cli.py:1177
+#: ../cli.py:1184
 msgid "maximum command wait time"
 msgstr "maximale Befehlswartezeit"
 
-#: ../cli.py:1179
+#: ../cli.py:1186
 msgid "debugging output level"
 msgstr "Debugging-Ausgabe-Stufe"
 
-#: ../cli.py:1183
+#: ../cli.py:1190
 msgid "show duplicates, in repos, in list/search commands"
 msgstr "Zeige Duplikate, in Repos, in Listen/Suchen-Befehlen"
 
-#: ../cli.py:1185
+#: ../cli.py:1192
 msgid "error output level"
 msgstr "Fehler-Ausgabe-Stufe"
 
-#: ../cli.py:1188
+#: ../cli.py:1195
 msgid "quiet operation"
 msgstr "Stiller Betrieb"
 
-#: ../cli.py:1190
+#: ../cli.py:1197
 msgid "verbose operation"
 msgstr "Wortreicher Betrieb"
 
-#: ../cli.py:1192
+#: ../cli.py:1199
 msgid "answer yes for all questions"
 msgstr "Beantworte alle Fragen mit 'ja'"
 
-#: ../cli.py:1194
+#: ../cli.py:1201
 msgid "show Yum version and exit"
 msgstr "Yum-Version anzeigen und Programm beenden"
 
-#: ../cli.py:1195
+#: ../cli.py:1202
 msgid "set install root"
 msgstr "Wurzel-Installationsverzeichnis setzen"
 
-#: ../cli.py:1199
+#: ../cli.py:1206
 msgid "enable one or more repositories (wildcards allowed)"
 msgstr "aktiviere eines oder mehrere Repositories (Wildcards erlaubt)"
 
-#: ../cli.py:1203
+#: ../cli.py:1210
 msgid "disable one or more repositories (wildcards allowed)"
 msgstr "deaktiviere eines oder mehrere Repositories (Wildcards erlaubt)"
 
-#: ../cli.py:1206
+#: ../cli.py:1213
 msgid "exclude package(s) by name or glob"
 msgstr "schliesse Paket(e) nach Namen oder global aus"
 
-#: ../cli.py:1208
+#: ../cli.py:1215
 msgid "disable exclude from main, for a repo or for everything"
 msgstr "deaktiviere Ausschluss von 'main', einem Repository oder allem"
 
-#: ../cli.py:1211
+#: ../cli.py:1218
 msgid "enable obsoletes processing during updates"
 msgstr "aktiviere veraltetes Verarbeiten während Aktualisierung"
 
-#: ../cli.py:1213
+#: ../cli.py:1220
 msgid "disable Yum plugins"
 msgstr "deaktiviere Yum-Plugins"
 
-#: ../cli.py:1215
+#: ../cli.py:1222
 msgid "disable gpg signature checking"
 msgstr "deaktiviere GPG-Signatur-Prüfung"
 
-#: ../cli.py:1217
+#: ../cli.py:1224
 msgid "disable plugins by name"
 msgstr "deaktiviere Plugins nach Namen"
 
-#: ../cli.py:1220
+#: ../cli.py:1227
 msgid "enable plugins by name"
 msgstr "aktiviere Plugins nach Namen"
 
-#: ../cli.py:1223
+#: ../cli.py:1230
 msgid "skip packages with depsolving problems"
 msgstr "überspringe Pakete mit Abhängigkeitsauflösungsproblemen"
 
-#: ../output.py:236
+#: ../output.py:248
 msgid "Jan"
 msgstr "Jan"
 
-#: ../output.py:236
+#: ../output.py:248
 msgid "Feb"
 msgstr "Feb"
 
-#: ../output.py:236
+#: ../output.py:248
 msgid "Mar"
 msgstr "Mär"
 
-#: ../output.py:236
+#: ../output.py:248
 msgid "Apr"
 msgstr "Apr"
 
-#: ../output.py:236
+#: ../output.py:248
 msgid "May"
 msgstr "Mai"
 
-#: ../output.py:236
+#: ../output.py:248
 msgid "Jun"
 msgstr "Jun"
 
-#: ../output.py:237
+#: ../output.py:249
 msgid "Jul"
 msgstr "Jul"
 
-#: ../output.py:237
+#: ../output.py:249
 msgid "Aug"
 msgstr "Aug"
 
-#: ../output.py:237
+#: ../output.py:249
 msgid "Sep"
 msgstr "Sep"
 
-#: ../output.py:237
+#: ../output.py:249
 msgid "Oct"
 msgstr "Okt"
 
-#: ../output.py:237
+#: ../output.py:249
 msgid "Nov"
 msgstr "Nov"
 
-#: ../output.py:237
+#: ../output.py:249
 msgid "Dec"
 msgstr "Dez"
 
-#: ../output.py:247
+#: ../output.py:259
 msgid "Trying other mirror."
 msgstr "Versuche anderen Spiegel-Server."
 
-#: ../output.py:425
+#: ../output.py:439
 #, python-format
 msgid "Name       : %s%s%s"
 msgstr "Name       : %s%s%s"
 
-#: ../output.py:426
+#: ../output.py:440
 #, python-format
 msgid "Arch       : %s"
 msgstr "Architektur : %s"
 
-#: ../output.py:428
+#: ../output.py:442
 #, python-format
 msgid "Epoch      : %s"
 msgstr "Epoch      : %s"
 
-#: ../output.py:429
+#: ../output.py:443
 #, python-format
 msgid "Version    : %s"
 msgstr "Version    : %s"
 
-#: ../output.py:430
+#: ../output.py:444
 #, python-format
 msgid "Release    : %s"
 msgstr "Ausgabe    : %s"
 
-#: ../output.py:431
+#: ../output.py:445
 #, python-format
 msgid "Size       : %s"
 msgstr "Grösse     : %s"
 
-#: ../output.py:432
+#: ../output.py:446
 #, python-format
 msgid "Repo       : %s"
 msgstr "Repo       : %s"
 
-#: ../output.py:434
+#: ../output.py:448
 #, python-format
 msgid "Committer  : %s"
 msgstr "Übermittler  : %s"
 
-#: ../output.py:435
+#: ../output.py:449
 #, python-format
 msgid "Committime : %s"
-msgstr "Übermittllungszeit  : %s"
+msgstr "Übermittlungszeit  : %s"
 
-#: ../output.py:436
+#: ../output.py:450
 #, python-format
 msgid "Buildtime  : %s"
 msgstr "Build-Zeit  : %s"
 
-#: ../output.py:438
+#: ../output.py:452
 #, python-format
 msgid "Installtime: %s"
 msgstr "Installationszeit: %s"
 
-#: ../output.py:439
+#: ../output.py:453
 msgid "Summary    : "
 msgstr "Zusammenfassung    : "
 
-#: ../output.py:441
+#: ../output.py:455
 #, python-format
 msgid "URL        : %s"
 msgstr "URL        : %s"
 
-#: ../output.py:442
+#: ../output.py:456
 #, python-format
 msgid "License    : %s"
 msgstr "Lizenz     : %s"
 
-#: ../output.py:443
+#: ../output.py:457
 msgid "Description: "
 msgstr "Beschreibung:"
 
-#: ../output.py:500
+#: ../output.py:514
 msgid "y"
 msgstr "j"
 
-#: ../output.py:500
+#: ../output.py:514
 msgid "yes"
 msgstr "ja"
 
-#: ../output.py:501
+#: ../output.py:515
 msgid "n"
 msgstr "n"
 
-#: ../output.py:501
+#: ../output.py:515
 msgid "no"
 msgstr "nein"
 
-#: ../output.py:505
+#: ../output.py:519
 msgid "Is this ok [y/N]: "
 msgstr "Ist dies in Ordnung? [j/N] :"
 
-#: ../output.py:587
+#: ../output.py:601
 #, python-format
 msgid ""
 "\n"
@@ -650,119 +649,124 @@ msgstr ""
 "\n"
 "Gruppe: %s"
 
-#: ../output.py:594
+#: ../output.py:608
 #, python-format
 msgid " Description: %s"
 msgstr " Beschreibung: %s"
 
-#: ../output.py:596
+#: ../output.py:610
 msgid " Mandatory Packages:"
 msgstr " Obligatorische Pakete:"
 
-#: ../output.py:597
+#: ../output.py:611
 msgid " Default Packages:"
 msgstr " Standard-Pakete:"
 
-#: ../output.py:598
+#: ../output.py:612
 msgid " Optional Packages:"
 msgstr " Optionale Pakete:"
 
-#: ../output.py:599
+#: ../output.py:613
 msgid " Conditional Packages:"
 msgstr " Zwangsbedingte Pakete:"
 
-#: ../output.py:619
+#: ../output.py:633
 #, python-format
 msgid "package: %s"
 msgstr "Paket: %s"
 
-#: ../output.py:621
+#: ../output.py:635
 msgid "  No dependencies for this package"
 msgstr "  Keine Abhängigkeiten für dieses Paket"
 
-#: ../output.py:626
+#: ../output.py:640
 #, python-format
 msgid "  dependency: %s"
 msgstr "  Abhängigkeit: %s"
 
-#: ../output.py:628
+#: ../output.py:642
 msgid "   Unsatisfied dependency"
 msgstr "   Nicht erfüllte Abhängigkeit"
 
-#: ../output.py:700
+#: ../output.py:714
 msgid "Matched from:"
 msgstr "Übereinstimmung von:"
 
-#: ../output.py:708
+#: ../output.py:722
 msgid "Description : "
 msgstr "Beschreibung : "
 
-#: ../output.py:711
+#: ../output.py:725
 #, python-format
 msgid "URL         : %s"
 msgstr "URL        : %s"
 
-#: ../output.py:714
+#: ../output.py:728
 #, python-format
 msgid "License     : %s"
 msgstr "Lizenz     : %s"
 
-#: ../output.py:717
+#: ../output.py:731
 #, python-format
 msgid "Filename    : %s"
 msgstr "Dateiname     : %s"
 
-#: ../output.py:721
+#: ../output.py:735
 msgid "Other       : "
 msgstr "Andere     : "
 
-#: ../output.py:753
+#: ../output.py:767
 msgid "There was an error calculating total download size"
 msgstr "Fehler beim Berechnen der Gesamtgrösse der Downloads"
 
-#: ../output.py:758
+#: ../output.py:772
 #, python-format
 msgid "Total size: %s"
 msgstr "Gesamtgrösse: %s"
 
-#: ../output.py:761
+#: ../output.py:775
 #, python-format
 msgid "Total download size: %s"
 msgstr "Gesamte Downloadgrösse: %s"
 
-#: ../output.py:779
+#: ../output.py:810
 msgid "Installing for dependencies"
 msgstr "Installiert für Abhängigkeiten"
 
-#: ../output.py:780
+#: ../output.py:811
 msgid "Updating for dependencies"
 msgstr "Aktualisiert für Abhängigkeiten"
 
-#: ../output.py:781
+#: ../output.py:812
 msgid "Removing for dependencies"
 msgstr "Entfernt für Abhängigkeiten"
 
-#: ../output.py:817
+#: ../output.py:819
+#: ../output.py:915
+msgid "Skipped (dependency problems)"
+msgstr "Übersprungen (Abhängigkeitsprobleme)"
+
+#: ../output.py:840
 msgid "Package"
 msgstr "Paket"
 
-#: ../output.py:817
+#: ../output.py:840
 msgid "Arch"
 msgstr "Arch"
 
-#: ../output.py:818
+#: ../output.py:841
 msgid "Version"
 msgstr "Version"
 
-#: ../output.py:818
+#: ../output.py:841
 msgid "Repository"
 msgstr "Repository"
 
-#: ../output.py:819
+#: ../output.py:842
 msgid "Size"
 msgstr "Grösse"
 
-#: ../output.py:830
+#: ../output.py:853
 #, python-format
 msgid ""
 "     replacing  %s.%s %s\n"
@@ -771,7 +775,7 @@ msgstr ""
 "     ersetze  %s.%s %s\n"
 "\n"
 
-#: ../output.py:838
+#: ../output.py:861
 #, python-format
 msgid ""
 "\n"
@@ -788,27 +792,27 @@ msgstr ""
 "Aktualisieren     %5.5s Paket(e)         \n"
 "Enfernen          %5.5s Paket(e)         \n"
 
-#: ../output.py:886
+#: ../output.py:909
 msgid "Removed"
 msgstr "Entfernt"
 
-#: ../output.py:887
+#: ../output.py:910
 msgid "Dependency Removed"
 msgstr "Abhängigkeiten entfernt"
 
-#: ../output.py:889
+#: ../output.py:912
 msgid "Dependency Installed"
 msgstr "Abhängigkeit installiert"
 
-#: ../output.py:891
+#: ../output.py:914
 msgid "Dependency Updated"
 msgstr "Abhängigkeit aktualisiert"
 
-#: ../output.py:892
+#: ../output.py:916
 msgid "Replaced"
 msgstr "Ersetzt       "
 
-#: ../output.py:965
+#: ../output.py:989
 #, python-format
 msgid ""
 "\n"
@@ -817,77 +821,77 @@ msgstr ""
 "\n"
 " Aktueller Download abgebrochen, %s unterbrechen Sie (ctrl-c) erneut %s innerhalb %s%s%s Sekunden zum Beenden.\n"
 
-#: ../output.py:975
+#: ../output.py:999
 msgid "user interrupt"
 msgstr "Benutzer-Unterbrechung"
 
-#: ../output.py:991
+#: ../output.py:1015
 msgid "Total"
 msgstr "Total"
 
-#: ../output.py:1005
+#: ../output.py:1029
 msgid "installed"
 msgstr "installiert"
 
-#: ../output.py:1006
+#: ../output.py:1030
 msgid "updated"
 msgstr "aktualisiert"
 
-#: ../output.py:1007
+#: ../output.py:1031
 msgid "obsoleted"
 msgstr "veraltet"
 
-#: ../output.py:1008
+#: ../output.py:1032
 msgid "erased"
 msgstr "gelöscht"
 
 # Dies ist das Sorgenkind. So weit ich weiss, werden die Verben von oben bezogen. Eventuell könnte auch eine radikale Änderung eine Lösung sein. Fabian
-#: ../output.py:1012
+#: ../output.py:1036
 #, python-format
 msgid "---> Package %s.%s %s:%s-%s set to be %s"
 msgstr "---> Paket %s.%s %s:%s-%s markiert, um %s zu werden"
 
-#: ../output.py:1019
+#: ../output.py:1043
 msgid "--> Running transaction check"
 msgstr "--> Führe Transaktionsprüfung aus"
 
-#: ../output.py:1024
+#: ../output.py:1048
 msgid "--> Restarting Dependency Resolution with new changes."
 msgstr "--> Starte Abhängigkeitsauflösung mit den neuen Änderungen neu."
 
-#: ../output.py:1029
+#: ../output.py:1053
 msgid "--> Finished Dependency Resolution"
 msgstr "--> Abhängigkeitsauflösung beendet"
 
-#: ../output.py:1034
+#: ../output.py:1058
 #, python-format
 msgid "--> Processing Dependency: %s for package: %s"
 msgstr "--> Verarbeite Abhängigkeiten: %s für Paket: %s"
 
-#: ../output.py:1039
+#: ../output.py:1063
 #, python-format
 msgid "--> Unresolved Dependency: %s"
 msgstr "--> Nicht aufgelöste Abhängigkeit: %s"
 
-#: ../output.py:1045
+#: ../output.py:1069
 #, python-format
 msgid "--> Processing Conflict: %s conflicts %s"
 msgstr "--> Verarbeite Konflikt: %s kollidiert mit %s"
 
-#: ../output.py:1048
+#: ../output.py:1072
 msgid "--> Populating transaction set with selected packages. Please wait."
 msgstr "--> Fülle Verarbeitungsset mit ausgewählten Paketen. Bitte warten."
 
-#: ../output.py:1052
+#: ../output.py:1076
 #, python-format
 msgid "---> Downloading header for %s to pack into transaction set."
 msgstr "---> Lade Header für %s herunter, um ins Verarbeitungsset zu packen."
 
-#: ../yumcommands.py:40
+#: ../yumcommands.py:41
 msgid "You need to be root to perform this command."
 msgstr "Sie müssen root sein, um diesen Befehl ausführen zu können."
 
-#: ../yumcommands.py:47
+#: ../yumcommands.py:48
 msgid ""
 "\n"
 "You have enabled checking of packages via GPG keys. This is a good thing. \n"
@@ -917,291 +921,311 @@ msgstr ""
 "\n"
 "Für weitere Informationen kontaktieren Sie Ihre Distribution oder Ihren Paket-Anbieter.\n"
 
-#: ../yumcommands.py:67
+#: ../yumcommands.py:68
 #, python-format
 msgid "Error: Need to pass a list of pkgs to %s"
 msgstr "Fehler: Muss eine Liste von Paketen an %s übergeben"
 
-#: ../yumcommands.py:73
+#: ../yumcommands.py:74
 msgid "Error: Need an item to match"
 msgstr "Fehler: Brauche einen Begriff, der passt"
 
-#: ../yumcommands.py:79
+#: ../yumcommands.py:80
 msgid "Error: Need a group or list of groups"
 msgstr "Fehler: Brauche eine Gruppe oder eine Liste von Gruppen"
 
-#: ../yumcommands.py:88
+#: ../yumcommands.py:89
 #, python-format
 msgid "Error: clean requires an option: %s"
 msgstr "Fehler: Aufräumen benötigt eine Option: %s"
 
-#: ../yumcommands.py:93
+#: ../yumcommands.py:94
 #, python-format
 msgid "Error: invalid clean argument: %r"
 msgstr "Fehler: Ungültiges Argument für Aufräumen: %r"
 
-#: ../yumcommands.py:106
+#: ../yumcommands.py:107
 msgid "No argument to shell"
 msgstr "Kein Argument für Shell"
 
-#: ../yumcommands.py:109
+#: ../yumcommands.py:110
 #, python-format
 msgid "Filename passed to shell: %s"
 msgstr "Dateinamen an Shell übergeben: %s"
 
-#: ../yumcommands.py:113
+#: ../yumcommands.py:114
 #, python-format
 msgid "File %s given as argument to shell does not exist."
 msgstr "Datei %s, angegeben als Argument für Shell, existiert nicht."
 
-#: ../yumcommands.py:119
+#: ../yumcommands.py:120
 msgid "Error: more than one file given as argument to shell."
 msgstr "Fehler: mehr als eine Datei als Argument an die Shell übergeben."
 
-#: ../yumcommands.py:160
+#: ../yumcommands.py:161
 msgid "PACKAGE..."
 msgstr "PAKET..."
 
-#: ../yumcommands.py:163
+#: ../yumcommands.py:164
 msgid "Install a package or packages on your system"
 msgstr "Installiere ein Paket oder Pakete auf Ihrem System"
 
-#: ../yumcommands.py:172
+#: ../yumcommands.py:173
 msgid "Setting up Install Process"
 msgstr "Einrichten des Installationsprozess"
 
-#: ../yumcommands.py:183
+#: ../yumcommands.py:184
 msgid "[PACKAGE...]"
 msgstr "[PAKET...]"
 
-#: ../yumcommands.py:186
+#: ../yumcommands.py:187
 msgid "Update a package or packages on your system"
 msgstr "Aktualisiere ein Paket oder Pakete auf Ihrem System"
 
-#: ../yumcommands.py:194
+#: ../yumcommands.py:195
 msgid "Setting up Update Process"
 msgstr "Einrichten des Aktualisierungsprozess"
 
-#: ../yumcommands.py:236
+#: ../yumcommands.py:237
 msgid "Display details about a package or group of packages"
 msgstr "Zeige Details über ein Paket oder einer Gruppe von Pakete an"
 
 #. Output the packages:
-#: ../yumcommands.py:261
+#: ../yumcommands.py:262
 msgid "Installed Packages"
 msgstr "Installierte Pakete"
 
-#: ../yumcommands.py:263
+#: ../yumcommands.py:264
 msgid "Available Packages"
 msgstr "Verfügbare Pakete"
 
-#: ../yumcommands.py:265
+#: ../yumcommands.py:266
 msgid "Extra Packages"
 msgstr "Extra-Pakete"
 
-#: ../yumcommands.py:267
+#: ../yumcommands.py:268
 msgid "Updated Packages"
 msgstr "Aktualisierte Pakete"
 
-#: ../yumcommands.py:274
-#: ../yumcommands.py:281
+#: ../yumcommands.py:275
+#: ../yumcommands.py:282
+#: ../yumcommands.py:551
 msgid "Obsoleting Packages"
 msgstr "Veraltete Pakete"
 
-#: ../yumcommands.py:283
+#: ../yumcommands.py:284
 msgid "Recently Added Packages"
 msgstr "Kürzlich hinzugefügte Pakete"
 
-#: ../yumcommands.py:290
+#: ../yumcommands.py:291
 msgid "No matching Packages to list"
 msgstr "Keine übereinstimmenden Pakete zum Auflisten"
 
-#: ../yumcommands.py:304
+#: ../yumcommands.py:305
 msgid "List a package or groups of packages"
 msgstr "Liste von Pakete oder Gruppen von Paketen"
 
-#: ../yumcommands.py:316
+#: ../yumcommands.py:317
 msgid "Remove a package or packages from your system"
 msgstr "Entferne ein Paket oder Pakete auf Ihrem System"
 
-#: ../yumcommands.py:324
+#: ../yumcommands.py:325
 msgid "Setting up Remove Process"
 msgstr "Einrichten des Entfernungsprozess"
 
-#: ../yumcommands.py:339
+#: ../yumcommands.py:340
 msgid "Setting up Group Process"
 msgstr "Einrichten des Gruppenprozess"
 
-#: ../yumcommands.py:345
+#: ../yumcommands.py:346
 msgid "No Groups on which to run command"
 msgstr "Keine Gruppe, auf welcher der Befehl ausgeführt werden kann"
 
-#: ../yumcommands.py:358
+#: ../yumcommands.py:359
 msgid "List available package groups"
 msgstr "Verfügbare Gruppen anzeigen"
 
-#: ../yumcommands.py:375
+#: ../yumcommands.py:376
 msgid "Install the packages in a group on your system"
 msgstr "Installiere die Pakete in einer Gruppe auf Ihrem System"
 
-#: ../yumcommands.py:397
+#: ../yumcommands.py:398
 msgid "Remove the packages in a group from your system"
 msgstr "Entferne die Pakete in einer Gruppe von Ihrem System"
 
-#: ../yumcommands.py:424
+#: ../yumcommands.py:425
 msgid "Display details about a package group"
 msgstr "Zeigt Details über eine Paket-Gruppe an"
 
-#: ../yumcommands.py:448
+#: ../yumcommands.py:449
 msgid "Generate the metadata cache"
 msgstr "Generiere den Metadaten-Zwischenspeicher"
 
-#: ../yumcommands.py:454
+#: ../yumcommands.py:455
 msgid "Making cache files for all metadata files."
 msgstr "Erstelle Zwischenspeicherungsdatei für alle Metadaten-Dateien."
 
-#: ../yumcommands.py:455
+#: ../yumcommands.py:456
 msgid "This may take a while depending on the speed of this computer"
 msgstr "Dies kann eine Weile dauert, abhängig von der Geschwindigkeit dieses Computers"
 
-#: ../yumcommands.py:476
+#: ../yumcommands.py:477
 msgid "Metadata Cache Created"
 msgstr "Metadaten-Zwischenspeicher erstellt"
 
-#: ../yumcommands.py:490
+#: ../yumcommands.py:491
 msgid "Remove cached data"
 msgstr "Entferne gespeicherte Daten"
 
-#: ../yumcommands.py:511
+#: ../yumcommands.py:512
 msgid "Find what package provides the given value"
 msgstr "Suche ein Paket, welches den gegebenen Wert bereitstellen"
 
-#: ../yumcommands.py:531
+#: ../yumcommands.py:532
 msgid "Check for available package updates"
 msgstr "Überprüfe auf verfügbare Paket-Aktualisierungen"
 
-#: ../yumcommands.py:556
+#: ../yumcommands.py:571
 msgid "Search package details for the given string"
 msgstr "Suche nach Paket-Details für die gegebene Zeichenkette"
 
-#: ../yumcommands.py:562
+#: ../yumcommands.py:577
 msgid "Searching Packages: "
 msgstr "Suche Pakete:"
 
-#: ../yumcommands.py:579
+#: ../yumcommands.py:594
 msgid "Update packages taking obsoletes into account"
 msgstr "Aktualisiere Pakete, berücksichtige veraltete"
 
-#: ../yumcommands.py:588
+#: ../yumcommands.py:603
 msgid "Setting up Upgrade Process"
 msgstr "Einrichten des Upgradeprozess"
 
-#: ../yumcommands.py:602
+#: ../yumcommands.py:617
 msgid "Install a local RPM"
 msgstr "Installiere ein lokales RPM"
 
-#: ../yumcommands.py:611
+#: ../yumcommands.py:626
 msgid "Setting up Local Package Process"
 msgstr "Einrichten der lokalen Paketverarbeitung"
 
-#: ../yumcommands.py:630
+#: ../yumcommands.py:645
 msgid "Determine which package provides the given dependency"
 msgstr "Bestimme, welche Pakete die gegebenen Abhängigkeiten bereitstellen"
 
-#: ../yumcommands.py:633
+#: ../yumcommands.py:648
 msgid "Searching Packages for Dependency:"
 msgstr "Suche Pakete für Abhängigkeit:"
 
-#: ../yumcommands.py:647
+#: ../yumcommands.py:662
 msgid "Run an interactive yum shell"
 msgstr "Führe eine interaktive Yum-Shell aus"
 
-#: ../yumcommands.py:653
+#: ../yumcommands.py:668
 msgid "Setting up Yum Shell"
 msgstr "Einrichten der Yum-Shell"
 
-#: ../yumcommands.py:671
+#: ../yumcommands.py:686
 msgid "List a package's dependencies"
 msgstr "Liste von Paket-Abhängigkeiten"
 
-#: ../yumcommands.py:677
+#: ../yumcommands.py:692
 msgid "Finding dependencies: "
 msgstr "Suche Abhängigkeiten:"
 
-#: ../yumcommands.py:693
+#: ../yumcommands.py:708
 msgid "Display the configured software repositories"
 msgstr "Zeige die konfigurierten Software-Repositories an"
 
-#: ../yumcommands.py:742
+#: ../yumcommands.py:756
+#: ../yumcommands.py:769
+#: ../yumcommands.py:770
 msgid "enabled"
 msgstr "aktiviert"
 
-#: ../yumcommands.py:751
+#: ../yumcommands.py:765
+#: ../yumcommands.py:768
 msgid "disabled"
 msgstr "deaktiviert"
 
-#: ../yumcommands.py:760
+#: ../yumcommands.py:777
 msgid "repo id"
 msgstr "Repo-ID"
 
-#: ../yumcommands.py:761
+#: ../yumcommands.py:778
 msgid "repo name"
 msgstr "Repo-Name:"
 
-#: ../yumcommands.py:761
+#: ../yumcommands.py:780
 msgid "status"
 msgstr "Status"
 
-#: ../yumcommands.py:764
+#: ../yumcommands.py:790
 msgid "Repo-id     : "
 msgstr "Repo-ID       : "
 
-#: ../yumcommands.py:765
+#: ../yumcommands.py:791
 msgid "Repo-name   : "
 msgstr "Repo-Name   : "
 
-#: ../yumcommands.py:766
+#: ../yumcommands.py:792
 msgid "Repo-status : "
 msgstr "Repo-Status : "
 
-#: ../yumcommands.py:768
+#: ../yumcommands.py:794
+msgid "Repo-revision: "
+msgstr "Repo-Revision: "
+
+#: ../yumcommands.py:798
+msgid "Repo-tags   : "
+msgstr "Repo-Tags   : "
+
+#: ../yumcommands.py:804
+msgid "Repo-distro-tags: "
+msgstr "Repo-Distro-Tags: "
+
+#: ../yumcommands.py:809
 msgid "Repo-updated: "
 msgstr "Repo aktualisiert:"
 
-#: ../yumcommands.py:770
+#: ../yumcommands.py:811
 msgid "Repo-pkgs   : "
 msgstr "Repo-PKGS   : "
 
-#: ../yumcommands.py:771
+#: ../yumcommands.py:812
 msgid "Repo-size   : "
 msgstr "Repo-Grösse   : "
 
-#: ../yumcommands.py:774
+#: ../yumcommands.py:819
 msgid "Repo-baseurl: "
 msgstr "Repo BaseURL:"
 
-#: ../yumcommands.py:778
+#: ../yumcommands.py:823
+msgid "Repo-metalink: "
+msgstr "Repo-Metalink: "
+
+#: ../yumcommands.py:826
 msgid "Repo-mirrors: "
 msgstr "Repo-Spiegel: "
 
-#: ../yumcommands.py:782
+#: ../yumcommands.py:830
 msgid "Repo-exclude: "
 msgstr "Repo ausgeschlossen:"
 
-#: ../yumcommands.py:786
+#: ../yumcommands.py:834
 msgid "Repo-include: "
 msgstr "Repo eingeschlossen:"
 
-#: ../yumcommands.py:812
+#: ../yumcommands.py:856
 msgid "Display a helpful usage message"
 msgstr "Zeigt eine kurze Verwendungsinformation"
 
-#: ../yumcommands.py:846
+#: ../yumcommands.py:890
 #, python-format
 msgid "No help available for %s"
 msgstr "Keine Hilfe für %s vorhanden"
 
-#: ../yumcommands.py:851
+#: ../yumcommands.py:895
 msgid ""
 "\n"
 "\n"
@@ -1211,7 +1235,7 @@ msgstr ""
 "\n"
 "Aliase: "
 
-#: ../yumcommands.py:853
+#: ../yumcommands.py:897
 msgid ""
 "\n"
 "\n"
@@ -1221,11 +1245,11 @@ msgstr ""
 "\n"
 "Alias: "
 
-#: ../yumcommands.py:882
+#: ../yumcommands.py:926
 msgid "Setting up Reinstall Process"
 msgstr "Einrichten des Neuinstallationsprozess"
 
-#: ../yumcommands.py:896
+#: ../yumcommands.py:940
 msgid "reinstall a package"
 msgstr "Installiere Paket neu"
 
@@ -1297,197 +1321,197 @@ msgstr ""
 msgid "doTsSetup() will go away in a future version of Yum.\n"
 msgstr "doTsSetup() wird in zukünftigen Version von Yum verschwinden.\n"
 
-#: ../yum/depsolve.py:97
+#: ../yum/depsolve.py:99
 msgid "Setting up TransactionSets before config class is up"
 msgstr "Konfiguriere TransactionSets bevor die Konfigurationsklasse gestartet ist"
 
-#: ../yum/depsolve.py:148
+#: ../yum/depsolve.py:150
 #, python-format
 msgid "Invalid tsflag in config file: %s"
 msgstr "Ungültiges tsflag in Konfigurationsdatei: %s"
 
-#: ../yum/depsolve.py:159
+#: ../yum/depsolve.py:161
 #, python-format
 msgid "Searching pkgSack for dep: %s"
 msgstr "Suche pkgSack für Abhängigkeiten: %s"
 
-#: ../yum/depsolve.py:182
+#: ../yum/depsolve.py:184
 #, python-format
 msgid "Potential match for %s from %s"
 msgstr "Potentielle Übereinstimmung für %s von %s"
 
-#: ../yum/depsolve.py:190
+#: ../yum/depsolve.py:192
 #, python-format
 msgid "Matched %s to require for %s"
 msgstr "Übereinstimmung von %s, welche gebraucht wird für %s"
 
-#: ../yum/depsolve.py:231
+#: ../yum/depsolve.py:233
 #, python-format
 msgid "Member: %s"
 msgstr "Mitglied: %s"
 
-#: ../yum/depsolve.py:245
-#: ../yum/depsolve.py:732
+#: ../yum/depsolve.py:247
+#: ../yum/depsolve.py:734
 #, python-format
 msgid "%s converted to install"
 msgstr "%s konvertiert zum Installieren"
 
-#: ../yum/depsolve.py:252
+#: ../yum/depsolve.py:254
 #, python-format
 msgid "Adding Package %s in mode %s"
 msgstr "Füge Paket %s hinzu in Modus %s"
 
-#: ../yum/depsolve.py:262
+#: ../yum/depsolve.py:264
 #, python-format
 msgid "Removing Package %s"
 msgstr "Entferne Paket %s"
 
-#: ../yum/depsolve.py:273
+#: ../yum/depsolve.py:275
 #, python-format
 msgid "%s requires: %s"
 msgstr "%s benötigt: %s"
 
-#: ../yum/depsolve.py:331
+#: ../yum/depsolve.py:333
 msgid "Needed Require has already been looked up, cheating"
 msgstr "Benötigte Anforderung wurde bereits nachgeschlagen, betrüge"
 
-#: ../yum/depsolve.py:341
+#: ../yum/depsolve.py:343
 #, python-format
 msgid "Needed Require is not a package name. Looking up: %s"
 msgstr "Benötigte Anforderung ist kein Paket-Name. Schlagen nach: %s"
 
-#: ../yum/depsolve.py:348
+#: ../yum/depsolve.py:350
 #, python-format
 msgid "Potential Provider: %s"
 msgstr "Potentieller Anbieter: %s"
 
-#: ../yum/depsolve.py:371
+#: ../yum/depsolve.py:373
 #, python-format
 msgid "Mode is %s for provider of %s: %s"
 msgstr "Modus ist %s für Anbieter von %s: %s"
 
-#: ../yum/depsolve.py:375
+#: ../yum/depsolve.py:377
 #, python-format
 msgid "Mode for pkg providing %s: %s"
 msgstr "Modus für pkg-Bereitstellung %s: %s"
 
-#: ../yum/depsolve.py:379
+#: ../yum/depsolve.py:381
 #, python-format
 msgid "TSINFO: %s package requiring %s marked as erase"
 msgstr "TSINFO: %s Paket benötigt %s markiert als gelöscht"
 
-#: ../yum/depsolve.py:391
+#: ../yum/depsolve.py:393
 #, python-format
 msgid "TSINFO: Obsoleting %s with %s to resolve dep."
 msgstr "TSINFO: Veraltetes %s mit %s zum Auflösen der Abhängigkeit."
 
-#: ../yum/depsolve.py:394
+#: ../yum/depsolve.py:396
 #, python-format
 msgid "TSINFO: Updating %s to resolve dep."
 msgstr "TSINFO: Aktualisiere %s zum Auflösen der Abhängigkeit."
 
-#: ../yum/depsolve.py:402
+#: ../yum/depsolve.py:404
 #, python-format
 msgid "Cannot find an update path for dep for: %s"
 msgstr "Kann keine Aktualisierungspfad für Abhängigkeit finden für: %s"
 
-#: ../yum/depsolve.py:412
+#: ../yum/depsolve.py:414
 #, python-format
 msgid "Unresolvable requirement %s for %s"
 msgstr "Unlösbare Anforderung %s für %s"
 
-#: ../yum/depsolve.py:435
+#: ../yum/depsolve.py:437
 #, python-format
 msgid "Quick matched %s to require for %s"
 msgstr "Übereinstimmung von %s, welche gebraucht wird für %s"
 
 #. is it already installed?
-#: ../yum/depsolve.py:477
+#: ../yum/depsolve.py:479
 #, python-format
 msgid "%s is in providing packages but it is already installed, removing."
 msgstr "%s ist in einem bereitgestellten Paket, aber bereits installiert, entferne."
 
-#: ../yum/depsolve.py:492
+#: ../yum/depsolve.py:494
 #, python-format
 msgid "Potential resolving package %s has newer instance in ts."
 msgstr "Potentielles aufgelöste Paket %s hat eine neuere Instanz in ts."
 
-#: ../yum/depsolve.py:503
+#: ../yum/depsolve.py:505
 #, python-format
 msgid "Potential resolving package %s has newer instance installed."
 msgstr "Potentielles aufgelöste Paket %s hat eine neuere Instanz installiert."
 
-#: ../yum/depsolve.py:511
-#: ../yum/depsolve.py:560
+#: ../yum/depsolve.py:513
+#: ../yum/depsolve.py:562
 #, python-format
 msgid "Missing Dependency: %s is needed by package %s"
 msgstr "Fehlende Abhängigkeit: %s wird benötigt von Paket %s"
 
-#: ../yum/depsolve.py:524
+#: ../yum/depsolve.py:526
 #, python-format
 msgid "%s already in ts, skipping this one"
 msgstr "%s bereits in ts, überspringe dies"
 
-#: ../yum/depsolve.py:570
+#: ../yum/depsolve.py:572
 #, python-format
 msgid "TSINFO: Marking %s as update for %s"
 msgstr "TSINFO: Markiere %s als Aktualisierung für %s"
 
-#: ../yum/depsolve.py:578
+#: ../yum/depsolve.py:580
 #, python-format
 msgid "TSINFO: Marking %s as install for %s"
 msgstr "TSINFO: Markiert %s als Installation für %s"
 
-#: ../yum/depsolve.py:670
-#: ../yum/depsolve.py:750
+#: ../yum/depsolve.py:672
+#: ../yum/depsolve.py:752
 msgid "Success - empty transaction"
 msgstr "Erfolg - Leere Transaktion"
 
-#: ../yum/depsolve.py:709
-#: ../yum/depsolve.py:722
+#: ../yum/depsolve.py:711
+#: ../yum/depsolve.py:724
 msgid "Restarting Loop"
 msgstr "Starte Schleife neu"
 
-#: ../yum/depsolve.py:738
+#: ../yum/depsolve.py:740
 msgid "Dependency Process ending"
 msgstr "Abhängigkeitsverarbeitung beendet"
 
-#: ../yum/depsolve.py:744
+#: ../yum/depsolve.py:746
 #, python-format
 msgid "%s from %s has depsolving problems"
 msgstr "%s von %s hat Abhängigkeitsauflöse-Probleme"
 
-#: ../yum/depsolve.py:751
+#: ../yum/depsolve.py:753
 msgid "Success - deps resolved"
 msgstr "Erfolg - Abhängigkeiten aufgelöst"
 
-#: ../yum/depsolve.py:765
+#: ../yum/depsolve.py:767
 #, python-format
 msgid "Checking deps for %s"
 msgstr "Prüfe Abhängigkeiten für %s"
 
-#: ../yum/depsolve.py:848
+#: ../yum/depsolve.py:850
 #, python-format
 msgid "looking for %s as a requirement of %s"
 msgstr "schauen nach %s als eine Anforderung von %s"
 
-#: ../yum/depsolve.py:988
+#: ../yum/depsolve.py:990
 #, python-format
 msgid "Running compare_providers() for %s"
 msgstr "Führe compare_providers() aus für %s"
 
-#: ../yum/depsolve.py:1016
-#: ../yum/depsolve.py:1022
+#: ../yum/depsolve.py:1018
+#: ../yum/depsolve.py:1024
 #, python-format
 msgid "better arch in po %s"
 msgstr "bessere Architektur in po %s"
 
-#: ../yum/depsolve.py:1061
+#: ../yum/depsolve.py:1063
 #, python-format
 msgid "%s obsoletes %s"
 msgstr " %s veraltete %s"
 
-#: ../yum/depsolve.py:1077
+#: ../yum/depsolve.py:1079
 #, python-format
 msgid ""
 "archdist compared %s to %s on %s\n"
@@ -1496,115 +1520,115 @@ msgstr ""
 "Archdist verglichen %s zu %s auf %s\n"
 "  Gewinner: %s"
 
-#: ../yum/depsolve.py:1084
+#: ../yum/depsolve.py:1086
 #, python-format
 msgid "common sourcerpm %s and %s"
 msgstr "Gemeinsames Quellen-RPM %s und %s"
 
-#: ../yum/depsolve.py:1090
+#: ../yum/depsolve.py:1092
 #, python-format
 msgid "common prefix of %s between %s and %s"
 msgstr "Gemeinsamer Prefix von %s zwischen %s und %s"
 
 # Hat jemand eine Idee für eine bessere Übersetzung? Fabian
-#: ../yum/depsolve.py:1098
+#: ../yum/depsolve.py:1100
 #, python-format
 msgid "Best Order: %s"
 msgstr "Beste Bestellung: %s"
 
-#: ../yum/__init__.py:134
+#: ../yum/__init__.py:135
 msgid "doConfigSetup() will go away in a future version of Yum.\n"
 msgstr "doConfigSetup() wird in zukünftigen Version von Yum verschwinden.\n"
 
-#: ../yum/__init__.py:314
+#: ../yum/__init__.py:315
 #, python-format
 msgid "Repository %r is missing name in configuration, using id"
 msgstr "Bei Repository %r fehlt der Name in der Konfiguration, benutze id"
 
-#: ../yum/__init__.py:352
+#: ../yum/__init__.py:353
 msgid "plugins already initialised"
 msgstr "Plugins bereits initialisiert"
 
-#: ../yum/__init__.py:359
+#: ../yum/__init__.py:360
 msgid "doRpmDBSetup() will go away in a future version of Yum.\n"
 msgstr "doRpmDBSetup() wird in zukünftigen Version von Yum verschwinden.\n"
 
-#: ../yum/__init__.py:369
+#: ../yum/__init__.py:370
 msgid "Reading Local RPMDB"
 msgstr "Lese lokale RPMDB"
 
-#: ../yum/__init__.py:387
+#: ../yum/__init__.py:388
 msgid "doRepoSetup() will go away in a future version of Yum.\n"
 msgstr "doRepoSetup() wird in zukünftigen Version von Yum verschwinden.\n"
 
-#: ../yum/__init__.py:407
+#: ../yum/__init__.py:408
 msgid "doSackSetup() will go away in a future version of Yum.\n"
 msgstr "doSackSetup() wird in zukünftigen Version von Yum verschwinden \n"
 
-#: ../yum/__init__.py:424
+#: ../yum/__init__.py:425
 msgid "Setting up Package Sacks"
 msgstr "Einrichten des Paket-Behälters"
 
-#: ../yum/__init__.py:467
+#: ../yum/__init__.py:468
 #, python-format
 msgid "repo object for repo %s lacks a _resetSack method\n"
 msgstr "Repository-Objekt für Repository %s fehlt a _resetSack method\n"
 
-#: ../yum/__init__.py:468
+#: ../yum/__init__.py:469
 msgid "therefore this repo cannot be reset.\n"
 msgstr "deshalb dieses Repository kann nicht zurückgesetzt werden.\n"
 
-#: ../yum/__init__.py:473
+#: ../yum/__init__.py:474
 msgid "doUpdateSetup() will go away in a future version of Yum.\n"
 msgstr "doUpdateSetup() wird in zukünftigen Version von Yum verschwinden.\n"
 
-#: ../yum/__init__.py:485
+#: ../yum/__init__.py:486
 msgid "Building updates object"
 msgstr "Baue Aktualisierungsobjekt"
 
-#: ../yum/__init__.py:516
+#: ../yum/__init__.py:517
 msgid "doGroupSetup() will go away in a future version of Yum.\n"
 msgstr "doGroupSetup() wird in zukünftigen Version von Yum verschwinden .\n"
 
-#: ../yum/__init__.py:540
+#: ../yum/__init__.py:541
 msgid "Getting group metadata"
 msgstr "Beziehe Gruppen-Metadaten"
 
-#: ../yum/__init__.py:566
+#: ../yum/__init__.py:567
 #, python-format
 msgid "Adding group file from repository: %s"
 msgstr "Füge Gruppen-Datei von Repository hinzu: %s"
 
-#: ../yum/__init__.py:575
+#: ../yum/__init__.py:576
 #, python-format
 msgid "Failed to add groups file for repository: %s - %s"
 msgstr "Hinzufügen von Gruppen-Datei für Repository fehlgeschlagen: %s - %s"
 
-#: ../yum/__init__.py:581
+#: ../yum/__init__.py:582
 msgid "No Groups Available in any repository"
 msgstr "Keine Gruppen in irgendeinem Repository verfügbar"
 
-#: ../yum/__init__.py:631
+#: ../yum/__init__.py:632
 msgid "Importing additional filelist information"
 msgstr "Importiere zusätzlichen Dateilisten-Informationen"
 
-#: ../yum/__init__.py:639
-msgid "There are unfinished transactions remaining. You mightconsider running yum-complete-transaction first to finish them."
+#: ../yum/__init__.py:641
+msgid "There are unfinished transactions remaining. You might consider running yum-complete-transaction first to finish them."
 msgstr "Es gibt noch nicht abgeschlossene Transaktionen. Sie sollten in Betracht ziehen, zuerst  yum-complete-transaction auszuführen, um sie abzuschliessen."
 
 # Ob da die Übersetzung den Punkt trifft...Fabian
-#: ../yum/__init__.py:689
+#: ../yum/__init__.py:707
 #, python-format
 msgid "Skip-broken round %i"
 msgstr "Überspringe defekte Runde %i"
 
 # Ob da die Übersetzung den Punkt trifft...Fabian
-#: ../yum/__init__.py:712
+#: ../yum/__init__.py:756
 #, python-format
 msgid "Skip-broken took %i rounds "
 msgstr "Überspringen der defekte brachte %i Runden"
 
-#: ../yum/__init__.py:713
+#: ../yum/__init__.py:757
 msgid ""
 "\n"
 "Packages skipped because of dependency problems:"
@@ -1612,90 +1636,91 @@ msgstr ""
 "\n"
 "Pakete übersprungen wegen Abhängigkeitsproblemen:"
 
-#: ../yum/__init__.py:717
+#: ../yum/__init__.py:761
 #, python-format
 msgid "    %s from %s"
 msgstr "    %s von %s"
 
-#: ../yum/__init__.py:802
+#: ../yum/__init__.py:905
 msgid "Warning: scriptlet or other non-fatal errors occurred during transaction."
 msgstr "Warnung: Es sind Scriptlet- oder andere nicht-fatale Fehler bei der Verarbeitung aufgetreten."
 
-#: ../yum/__init__.py:818
+#: ../yum/__init__.py:921
 #, python-format
 msgid "Failed to remove transaction file %s"
 msgstr "Entfernen der Verarbeitungsdatei %s fehlgeschlagen"
 
 # verstehe ich nicht ganz, was gemeint ist. Fabian
-#: ../yum/__init__.py:859
+#: ../yum/__init__.py:962
 #, python-format
 msgid "excluding for cost: %s from %s"
 msgstr "Ausschluss für Aufwand: %s from %s"
 
 # Dies gefällt auch nicht allen. Fabian
-#: ../yum/__init__.py:890
+#: ../yum/__init__.py:993
 msgid "Excluding Packages in global exclude list"
-msgstr "Schliessen Pakete, welche in der globalen Ausschlussliste sind, aus"
+msgstr "Schliesse Pakete, welche in der globalen Ausschlussliste sind, aus"
 
-#: ../yum/__init__.py:892
+#: ../yum/__init__.py:995
 #, python-format
 msgid "Excluding Packages from %s"
 msgstr "Schliesse Pakete aus von %s"
 
-#: ../yum/__init__.py:919
+#: ../yum/__init__.py:1022
 #, python-format
 msgid "Reducing %s to included packages only"
 msgstr "Reduziere %s nur zum Einbeziehen der Pakete"
 
-#: ../yum/__init__.py:925
+#: ../yum/__init__.py:1028
 #, python-format
 msgid "Keeping included package %s"
 msgstr "Behalte integriertes Paket %s"
 
-#: ../yum/__init__.py:931
+#: ../yum/__init__.py:1034
 #, python-format
 msgid "Removing unmatched package %s"
 msgstr "Entferne nicht übereinstimmendes Paket %s"
 
-#: ../yum/__init__.py:934
+#: ../yum/__init__.py:1037
 msgid "Finished"
 msgstr "Abgeschlossen"
 
 #. Whoa. What the heck happened?
-#: ../yum/__init__.py:964
+#: ../yum/__init__.py:1067
 #, python-format
 msgid "Unable to check if PID %s is active"
 msgstr "Unfähig zum Prüfen, ob PID %s ist aktiv"
 
 #. Another copy seems to be running.
-#: ../yum/__init__.py:968
+#: ../yum/__init__.py:1071
 #, python-format
 msgid "Existing lock %s: another copy is running as pid %s."
 msgstr "Existierende Blockierung %s: eine andere Kopie läuft mit PID %s."
 
-#: ../yum/__init__.py:1039
+#: ../yum/__init__.py:1142
 msgid "Package does not match intended download"
 msgstr "Paket stimmt nicht mit dem vorgesehenen Herunterladen überein."
 
-#: ../yum/__init__.py:1054
+#: ../yum/__init__.py:1157
 msgid "Could not perform checksum"
 msgstr "Konnte Prüfsumme nicht bilden"
 
-#: ../yum/__init__.py:1057
+#: ../yum/__init__.py:1160
 msgid "Package does not match checksum"
 msgstr "Paket stimmt nicht mit der Prüfsumme überein"
 
-#: ../yum/__init__.py:1100
+#: ../yum/__init__.py:1203
 #, python-format
 msgid "package fails checksum but caching is enabled for %s"
 msgstr "Paket bei Checksumme-Prüfung durchgefallen, aber Zwischenspeicherung ist aktiviert für %s"
 
-#: ../yum/__init__.py:1103
+#: ../yum/__init__.py:1206
+#: ../yum/__init__.py:1234
 #, python-format
 msgid "using local copy of %s"
 msgstr "benutze lokale Kopie von %s"
 
-#: ../yum/__init__.py:1130
+#: ../yum/__init__.py:1248
 #, python-format
 msgid ""
 "Insufficient space in download directory %s\n"
@@ -1706,330 +1731,330 @@ msgstr ""
 "    * frei   %s\n"
 "    * benötigt %s"
 
-#: ../yum/__init__.py:1177
+#: ../yum/__init__.py:1295
 msgid "Header is not complete."
 msgstr "Header ist nicht vollständig."
 
-#: ../yum/__init__.py:1217
+#: ../yum/__init__.py:1335
 #, python-format
 msgid "Header not in local cache and caching-only mode enabled. Cannot download %s"
 msgstr "Header ist nicht im lokalen Zwischenspeicher und Nur-Zwischenspeicher-Modus aktiviert. Kann %s nicht herunterladen"
 
-#: ../yum/__init__.py:1272
+#: ../yum/__init__.py:1390
 #, python-format
 msgid "Public key for %s is not installed"
 msgstr "Öffentlicher Schlüssel für %s ist nicht installiert"
 
-#: ../yum/__init__.py:1276
+#: ../yum/__init__.py:1394
 #, python-format
 msgid "Problem opening package %s"
 msgstr "Problem beim Öffnen des Paketes %s"
 
-#: ../yum/__init__.py:1284
+#: ../yum/__init__.py:1402
 #, python-format
 msgid "Public key for %s is not trusted"
 msgstr "Öffentlicher Schlüssel für %s ist nicht vertrauenswürdig"
 
-#: ../yum/__init__.py:1288
+#: ../yum/__init__.py:1406
 #, python-format
 msgid "Package %s is not signed"
 msgstr "Paket %s ist nicht unterschrieben"
 
-#: ../yum/__init__.py:1326
+#: ../yum/__init__.py:1444
 #, python-format
 msgid "Cannot remove %s"
 msgstr "Kann %s nicht entfernen"
 
-#: ../yum/__init__.py:1330
+#: ../yum/__init__.py:1448
 #, python-format
 msgid "%s removed"
 msgstr "%s entfernt"
 
-#: ../yum/__init__.py:1367
+#: ../yum/__init__.py:1485
 #, python-format
 msgid "Cannot remove %s file %s"
 msgstr "Kann %s Datei nicht entfernt %s"
 
-#: ../yum/__init__.py:1371
+#: ../yum/__init__.py:1489
 #, python-format
 msgid "%s file %s removed"
 msgstr "%s Datei %s entfernt"
 
-#: ../yum/__init__.py:1373
+#: ../yum/__init__.py:1491
 #, python-format
 msgid "%d %s files removed"
 msgstr "%d %s Dateien entfernt"
 
-#: ../yum/__init__.py:1435
+#: ../yum/__init__.py:1553
 #, python-format
 msgid "More than one identical match in sack for %s"
 msgstr "Mehr als eine identische Übereinstimmung im Behälter für %s"
 
-#: ../yum/__init__.py:1441
+#: ../yum/__init__.py:1559
 #, python-format
 msgid "Nothing matches %s.%s %s:%s-%s from update"
 msgstr "Keine Übereinstimmungen  %s.%s %s:%s-%s mit der Aktualisierung"
 
-#: ../yum/__init__.py:1649
+#: ../yum/__init__.py:1767
 msgid "searchPackages() will go away in a future version of Yum.                      Use searchGenerator() instead. \n"
 msgstr "searchPackages() wird in zukünftigen Version von Yum verschwinden.                      Benutze stattdessen searchGenerator(). \n"
 
-#: ../yum/__init__.py:1687
+#: ../yum/__init__.py:1805
 #, python-format
 msgid "Searching %d packages"
 msgstr "Suche %d Pakete"
 
-#: ../yum/__init__.py:1691
+#: ../yum/__init__.py:1809
 #, python-format
 msgid "searching package %s"
 msgstr "Suche Paket %s"
 
-#: ../yum/__init__.py:1703
+#: ../yum/__init__.py:1821
 msgid "searching in file entries"
 msgstr "Suche in Datei-Einträgen"
 
-#: ../yum/__init__.py:1710
+#: ../yum/__init__.py:1828
 msgid "searching in provides entries"
 msgstr "suche in bereitgestellten Einträgen"
 
-#: ../yum/__init__.py:1743
+#: ../yum/__init__.py:1861
 #, python-format
 msgid "Provides-match: %s"
 msgstr "Stelle Übereinstimmung bereit: %s"
 
-#: ../yum/__init__.py:1792
+#: ../yum/__init__.py:1910
 msgid "No group data available for configured repositories"
 msgstr "Keine Gruppe für konfigurierte Repositories verfügbar"
 
-#: ../yum/__init__.py:1818
-#: ../yum/__init__.py:1837
-#: ../yum/__init__.py:1868
-#: ../yum/__init__.py:1874
-#: ../yum/__init__.py:1947
-#: ../yum/__init__.py:1951
+#: ../yum/__init__.py:1941
+#: ../yum/__init__.py:1960
+#: ../yum/__init__.py:1991
+#: ../yum/__init__.py:1997
+#: ../yum/__init__.py:2070
+#: ../yum/__init__.py:2074
 #, python-format
 msgid "No Group named %s exists"
 msgstr "Kein Gruppe mit dem Namen %s vorhanden"
 
-#: ../yum/__init__.py:1849
-#: ../yum/__init__.py:1964
+#: ../yum/__init__.py:1972
+#: ../yum/__init__.py:2087
 #, python-format
 msgid "package %s was not marked in group %s"
 msgstr "Paket %s war nicht markiert in Gruppe %s"
 
-#: ../yum/__init__.py:1896
+#: ../yum/__init__.py:2019
 #, python-format
 msgid "Adding package %s from group %s"
 msgstr "Füge Paket %s aus Gruppe %s hinzu"
 
-#: ../yum/__init__.py:1900
+#: ../yum/__init__.py:2023
 #, python-format
 msgid "No package named %s available to be installed"
 msgstr "Kein Paket mit Namen %s verfügbar zum Installieren"
 
 # Paket-Behälter wird sicher nicht allen gefallen. Fabian
-#: ../yum/__init__.py:1989
+#: ../yum/__init__.py:2112
 #, python-format
 msgid "Package tuple %s could not be found in packagesack"
 msgstr "Paket-Tupel %s kann nicht gefunden werden im Paket-Behälter"
 
-#: ../yum/__init__.py:2004
+#: ../yum/__init__.py:2127
 msgid "getInstalledPackageObject() will go away, use self.rpmdb.searchPkgTuple().\n"
 msgstr "getInstalledPackageObject() wird verschwinden, benutze self.rpmdb.searchPkgTuple().\n"
 
-#: ../yum/__init__.py:2056
-#: ../yum/__init__.py:2099
+#: ../yum/__init__.py:2179
+#: ../yum/__init__.py:2222
 msgid "Invalid versioned dependency string, try quoting it."
 msgstr "Ungültig versionierte Abhängigkeitszeichenkette, versuche es zu notieren."
 
-#: ../yum/__init__.py:2058
-#: ../yum/__init__.py:2101
+#: ../yum/__init__.py:2181
+#: ../yum/__init__.py:2224
 msgid "Invalid version flag"
 msgstr "Ungültiges Versionsflag"
 
-#: ../yum/__init__.py:2073
-#: ../yum/__init__.py:2077
+#: ../yum/__init__.py:2196
+#: ../yum/__init__.py:2200
 #, python-format
 msgid "No Package found for %s"
 msgstr "Kein Paket gefunden für %s"
 
-#: ../yum/__init__.py:2276
+#: ../yum/__init__.py:2399
 msgid "Package Object was not a package object instance"
 msgstr "Paketobjekt war keine Paketobjektinstanz"
 
-#: ../yum/__init__.py:2280
+#: ../yum/__init__.py:2403
 msgid "Nothing specified to install"
 msgstr "Nichts angegeben zum Installieren"
 
 #. only one in there
-#: ../yum/__init__.py:2298
+#: ../yum/__init__.py:2421
 #, python-format
 msgid "Checking for virtual provide or file-provide for %s"
 msgstr "Überprüfe nach virtueller Bereitstellung oder Datei-Bereitstellung für %s"
 
-#: ../yum/__init__.py:2304
-#: ../yum/__init__.py:2680
+#: ../yum/__init__.py:2427
+#: ../yum/__init__.py:2820
 #, python-format
 msgid "No Match for argument: %s"
 msgstr "Kein Übereinstimmung für Argument: %s"
 
-#: ../yum/__init__.py:2370
+#: ../yum/__init__.py:2493
 #, python-format
 msgid "Package %s installed and not available"
 msgstr "Paket %s installiert und nicht verfügbar"
 
-#: ../yum/__init__.py:2373
+#: ../yum/__init__.py:2496
 msgid "No package(s) available to install"
 msgstr "Kein(e) Paket(e) zum Installieren verfügbar."
 
-#: ../yum/__init__.py:2385
+#: ../yum/__init__.py:2508
 #, python-format
 msgid "Package: %s  - already in transaction set"
 msgstr "Paket: %s - bereits im Transaktionsset"
 
-#: ../yum/__init__.py:2398
+#: ../yum/__init__.py:2521
 #, python-format
 msgid "Package %s already installed and latest version"
 msgstr "Paket %s ist bereits installiert und ist in der neusten Version vorhanden."
 
-#: ../yum/__init__.py:2405
+#: ../yum/__init__.py:2528
 #, python-format
 msgid "Package matching %s already installed. Checking for update."
 msgstr "Paket, das auf %s passt, ist bereits installiert. Überprüfe auf Aktualisierung."
 
-#: ../yum/__init__.py:2415
+#: ../yum/__init__.py:2538
 #, python-format
 msgid "Package %s is obsoleted by %s, trying to install %s instead"
 msgstr "Paket %svon %s ist veraltet, versuche stattdessen %s zu installieren."
 
 #. update everything (the easy case)
-#: ../yum/__init__.py:2485
+#: ../yum/__init__.py:2619
 msgid "Updating Everything"
 msgstr "Aktualisiere alles"
 
-#: ../yum/__init__.py:2497
-#: ../yum/__init__.py:2602
-#: ../yum/__init__.py:2613
-#: ../yum/__init__.py:2635
+#: ../yum/__init__.py:2631
+#: ../yum/__init__.py:2736
+#: ../yum/__init__.py:2747
+#: ../yum/__init__.py:2769
 #, python-format
 msgid "Not Updating Package that is already obsoleted: %s.%s %s:%s-%s"
 msgstr "Aktualisiere Paket nicht, da es bereits veraltet ist: %s.%s %s:%s-%s"
 
-#: ../yum/__init__.py:2593
+#: ../yum/__init__.py:2727
 #, python-format
 msgid "Package is already obsoleted: %s.%s %s:%s-%s"
 msgstr "Paket ist bereits veraltet: %s.%s %s:%s-%s"
 
-#: ../yum/__init__.py:2616
-#: ../yum/__init__.py:2638
+#: ../yum/__init__.py:2750
+#: ../yum/__init__.py:2772
 #, python-format
 msgid "Not Updating Package that is already updated: %s.%s %s:%s-%s"
 msgstr "Aktualisiere Paket nicht, da es bereits veraltet ist:  %s.%s %s:%s-%s"
 
-#: ../yum/__init__.py:2677
+#: ../yum/__init__.py:2817
 #, python-format
 msgid "%s"
 msgstr "%s"
 
-#: ../yum/__init__.py:2693
+#: ../yum/__init__.py:2833
 msgid "No package matched to remove"
 msgstr "Kein Paket stimmt zum Entfernen überein"
 
-#: ../yum/__init__.py:2727
+#: ../yum/__init__.py:2867
 #, python-format
 msgid "Cannot open file: %s. Skipping."
 msgstr "Kann Datei nicht öffnen: %s. Überspringen."
 
-#: ../yum/__init__.py:2730
+#: ../yum/__init__.py:2870
 #, python-format
 msgid "Examining %s: %s"
 msgstr "Untersuche %s: %s"
 
-#: ../yum/__init__.py:2738
+#: ../yum/__init__.py:2878
 #, python-format
 msgid "Cannot add package %s to transaction. Not a compatible architecture: %s"
 msgstr "Kann Paket %s nicht zur Transaktion hinzufügen. Keine kompatible Architektur: %s"
 
-#: ../yum/__init__.py:2746
+#: ../yum/__init__.py:2886
 #, python-format
 msgid "Package %s not installed, cannot update it. Run yum install to install it instead."
 msgstr "Paket %s nicht installiert, kann es nicht aktualisieren. Führen Sie stattdessen yum install aus, um es zu installieren."
 
-#: ../yum/__init__.py:2779
+#: ../yum/__init__.py:2919
 #, python-format
 msgid "Excluding %s"
 msgstr "Exklusive %s"
 
-#: ../yum/__init__.py:2784
+#: ../yum/__init__.py:2924
 #, python-format
 msgid "Marking %s to be installed"
 msgstr "Markiere %s zum Installieren"
 
-#: ../yum/__init__.py:2790
+#: ../yum/__init__.py:2930
 #, python-format
 msgid "Marking %s as an update to %s"
 msgstr "Markiere %s als eine Aktualisierung für %s"
 
-#: ../yum/__init__.py:2797
+#: ../yum/__init__.py:2937
 #, python-format
 msgid "%s: does not update installed package."
 msgstr "%s: aktualisiert installierte Pakete nicht."
 
-#: ../yum/__init__.py:2815
+#: ../yum/__init__.py:2955
 msgid "Problem in reinstall: no package matched to remove"
 msgstr "Probleme beim Neuinstallieren: kein Paket stimmt zum Entfernen überein"
 
-#: ../yum/__init__.py:2826
+#: ../yum/__init__.py:2966
 #, python-format
 msgid "Package %s is allowed multiple installs, skipping"
 msgstr "Paket %s darf mehrfach installiert sein, überspringe"
 
-#: ../yum/__init__.py:2833
+#: ../yum/__init__.py:2973
 msgid "Problem in reinstall: no package matched to install"
 msgstr "Probleme beim Neuinstallieren: kein Paket stimmt zum Installieren überein"
 
-#: ../yum/__init__.py:2868
+#: ../yum/__init__.py:3008
 #, python-format
 msgid "Retrieving GPG key from %s"
 msgstr "GPG-Schlüssel abrufen von %s"
 
-#: ../yum/__init__.py:2874
+#: ../yum/__init__.py:3028
 msgid "GPG key retrieval failed: "
 msgstr "GPG-Schlüssel-Abruf fehlgeschlagen:"
 
-#: ../yum/__init__.py:2885
+#: ../yum/__init__.py:3039
 #, python-format
 msgid "GPG key parsing failed: key does not have value %s"
 msgstr "GPG-Schlüssel-Analyse fehlgeschlagen: Schlüssel hat keinen Wert %s"
 
-#: ../yum/__init__.py:2917
+#: ../yum/__init__.py:3071
 #, python-format
 msgid "GPG key at %s (0x%s) is already installed"
 msgstr "GPG-Schlüssel unter %s (0x%s) ist bereits installiert"
 
 #. Try installing/updating GPG key
-#: ../yum/__init__.py:2922
-#: ../yum/__init__.py:2984
+#: ../yum/__init__.py:3076
+#: ../yum/__init__.py:3138
 #, python-format
 msgid "Importing GPG key 0x%s \"%s\" from %s"
 msgstr "Importiere GPG-Schlüssel 0x%s \"%s\" von %s"
 
-#: ../yum/__init__.py:2939
+#: ../yum/__init__.py:3093
 msgid "Not installing key"
 msgstr "Nicht installierter Schlüssel"
 
-#: ../yum/__init__.py:2945
+#: ../yum/__init__.py:3099
 #, python-format
 msgid "Key import failed (code %d)"
 msgstr "Schlüssel-Import fehlgeschlagen (Code %d)"
 
-#: ../yum/__init__.py:2946
-#: ../yum/__init__.py:3005
+#: ../yum/__init__.py:3100
+#: ../yum/__init__.py:3159
 msgid "Key imported successfully"
 msgstr "Schlüssel erfolgreich importiert"
 
-#: ../yum/__init__.py:2951
-#: ../yum/__init__.py:3010
+#: ../yum/__init__.py:3105
+#: ../yum/__init__.py:3164
 #, python-format
 msgid ""
 "The GPG keys listed for the \"%s\" repository are already installed but they are not correct for this package.\n"
@@ -2038,91 +2063,91 @@ msgstr ""
 "Die aufgelisteten GPG-Schlüssel für das \"%s\"-Repository sind bereits installiert, aber sie sind nicht korrekt für dieses Paket.\n"
 "Stellen Sie sicher, dass die korrekten Schlüssel-URLs für dieses Repository konfiguriert sind."
 
-#: ../yum/__init__.py:2960
+#: ../yum/__init__.py:3114
 msgid "Import of key(s) didn't help, wrong key(s)?"
 msgstr "Importieren der Schlüssel hat nicht geholfen, falsche Schlüssel?"
 
-#: ../yum/__init__.py:2979
+#: ../yum/__init__.py:3133
 #, python-format
 msgid "GPG key at %s (0x%s) is already imported"
 msgstr "GPG-Schlüssel unter %s (0x%s) ist bereits importiert"
 
-#: ../yum/__init__.py:2999
+#: ../yum/__init__.py:3153
 #, python-format
 msgid "Not installing key for repo %s"
 msgstr "Nicht installierter Schlüssel für Repo %s"
 
-#: ../yum/__init__.py:3004
+#: ../yum/__init__.py:3158
 msgid "Key import failed"
 msgstr "Schlüssel-Import fehlgeschlagen"
 
-#: ../yum/__init__.py:3095
+#: ../yum/__init__.py:3249
 msgid "Unable to find a suitable mirror."
 msgstr "Es kann kein geeigneter Mirror gefunden werden."
 
-#: ../yum/__init__.py:3097
+#: ../yum/__init__.py:3251
 msgid "Errors were encountered while downloading packages."
 msgstr "Beim Herunterladen der Pakete sind Fehler aufgetreten."
 
-#: ../yum/__init__.py:3161
+#: ../yum/__init__.py:3315
 msgid "Test Transaction Errors: "
 msgstr "Test-Transaktionsfehler"
 
 #. Mostly copied from YumOutput._outKeyValFill()
-#: ../yum/plugins.py:199
+#: ../yum/plugins.py:201
 msgid "Loaded plugins: "
 msgstr "Geladene Plugins: "
 
-#: ../yum/plugins.py:213
-#: ../yum/plugins.py:219
+#: ../yum/plugins.py:215
+#: ../yum/plugins.py:221
 #, python-format
 msgid "No plugin match for: %s"
 msgstr "Kein Plugin für Argument: %s"
 
-#: ../yum/plugins.py:249
+#: ../yum/plugins.py:251
 #, python-format
 msgid "\"%s\" plugin is disabled"
 msgstr "\"%s\" Plugin ist deaktiviert"
 
 #. Give full backtrace:
-#: ../yum/plugins.py:261
+#: ../yum/plugins.py:263
 #, python-format
 msgid "Plugin \"%s\" can't be imported"
 msgstr "Plugin \"%s\" kann nicht importiert werden"
 
-#: ../yum/plugins.py:268
+#: ../yum/plugins.py:270
 #, python-format
 msgid "Plugin \"%s\" doesn't specify required API version"
 msgstr "Plugin \"%s\" gibt keine benötigte API-Version an"
 
-#: ../yum/plugins.py:273
+#: ../yum/plugins.py:275
 #, python-format
 msgid "Plugin \"%s\" requires API %s. Supported API is %s."
 msgstr "Plugin \"%s\" benötigt API %s. Unterstützte API ist %s."
 
-#: ../yum/plugins.py:306
+#: ../yum/plugins.py:308
 #, python-format
 msgid "Loading \"%s\" plugin"
 msgstr "Lade \"%s\" Plugin"
 
-#: ../yum/plugins.py:313
+#: ../yum/plugins.py:315
 #, python-format
 msgid "Two or more plugins with the name \"%s\" exist in the plugin search path"
 msgstr "Zwei oder mehr Plugins mit dem Namen \"%s\" existieren im Plugin-Suchpfad"
 
-#: ../yum/plugins.py:333
+#: ../yum/plugins.py:335
 #, python-format
 msgid "Configuration file %s not found"
 msgstr "Konfigurationsdatei %s nicht gefunden"
 
 #. for
 #. Configuration files for the plugin not found
-#: ../yum/plugins.py:336
+#: ../yum/plugins.py:338
 #, python-format
 msgid "Unable to find configuration file for plugin %s"
 msgstr "Kann Konfigurationsdatei für Plugin %s nicht finden"
 
-#: ../yum/plugins.py:490
+#: ../yum/plugins.py:492
 msgid "registration of commands not supported"
 msgstr "Registrierung von Befehlen nicht unterstützt"
 
diff --git a/po/nb.po b/po/nb.po
index a4214b1..512a227 100644
--- a/po/nb.po
+++ b/po/nb.po
@@ -3,36 +3,39 @@
 # Copyright (C) 2008 Terje Røsten
 # This file is distributed under the same license as the yum package.
 # Terje Røsten <terje.rosten@ntnu.no>, 2008.
-#, fuzzy
+# Kjartan Maraas <kmaraas@broadpark.no>, 2008.
+#
+
 msgid ""
 msgstr ""
 "Project-Id-Version: yum 3.2.10\n"
 "Report-Msgid-Bugs-To: \n"
-"POT-Creation-Date: 2008-03-25 11:29+0100\n"
-"PO-Revision-Date: 2008-02-12 11:16+0100\n"
-"Last-Translator: Terje Røsten <terje.rosten@ntnu.no>\n"
-"Language-Team: Norwegian (bokmål) <i18n-no@lister.ping.uio.no>\n"
+"POT-Creation-Date: 2008-10-31 13:29+0000\n"
+"PO-Revision-Date: 2008-10-31 20:25+0100\n"
+"Last-Translator: Kjartan Maraas <kmaraas@broadpark.no>\n"
+"Language-Team: Norwegian bokmål <i18n-nb@lister.ping.uio.no>\n"
 "MIME-Version: 1.0\n"
 "Content-Type: text/plain; charset=UTF-8\n"
 "Content-Transfer-Encoding: 8bit\n"
 
-#: ../callback.py:48 ../output.py:512
+#: ../callback.py:48 ../output.py:516 ../yum/rpmtrans.py:71
 msgid "Updating"
 msgstr "Oppdaterer"
 
-#: ../callback.py:49
+#: ../callback.py:49 ../yum/rpmtrans.py:72
 msgid "Erasing"
 msgstr "Fjerner"
 
-#: ../callback.py:50 ../callback.py:51 ../callback.py:53 ../output.py:511
+#: ../callback.py:50 ../callback.py:51 ../callback.py:53 ../output.py:515
+#: ../yum/rpmtrans.py:73 ../yum/rpmtrans.py:74 ../yum/rpmtrans.py:76
 msgid "Installing"
 msgstr "Legger inn"
 
-#: ../callback.py:52 ../callback.py:58
+#: ../callback.py:52 ../callback.py:58 ../yum/rpmtrans.py:75
 msgid "Obsoleted"
 msgstr "Er utgått"
 
-#: ../callback.py:54 ../output.py:558
+#: ../callback.py:54 ../output.py:562
 msgid "Updated"
 msgstr "Oppdatert"
 
@@ -40,7 +43,7 @@ msgstr "Oppdatert"
 msgid "Erased"
 msgstr "Fjernet"
 
-#: ../callback.py:56 ../callback.py:57 ../callback.py:59 ../output.py:556
+#: ../callback.py:56 ../callback.py:57 ../callback.py:59 ../output.py:560
 msgid "Installed"
 msgstr "Lagt inn"
 
@@ -50,7 +53,7 @@ msgstr "Intet hode - merksnodig?!"
 
 #: ../callback.py:168
 msgid "Repackage"
-msgstr "Pakker på nytt"
+msgstr "Pakk på nytt"
 
 #: ../callback.py:189
 #, python-format
@@ -62,405 +65,425 @@ msgstr "Feil: ugyldig tilstand ut: %s for %s"
 msgid "Erased: %s"
 msgstr "Fjernet: %s"
 
-#: ../callback.py:217 ../output.py:513
+#: ../callback.py:217 ../output.py:517
 msgid "Removing"
 msgstr "Fjerner"
 
-#: ../callback.py:219
+#: ../callback.py:219 ../yum/rpmtrans.py:77
 msgid "Cleanup"
 msgstr "Rydder opp"
 
-#: ../cli.py:103
+#: ../cli.py:105
 #, python-format
 msgid "Command \"%s\" already defined"
-msgstr "Kommando \"%s\" er allerede definert"
+msgstr "Kommando «%s» er allerede definert"
 
-#: ../cli.py:115
+#: ../cli.py:117
 msgid "Setting up repositories"
-msgstr "Lager pakkeoversikt"
+msgstr "Konfigurerer lagre"
 
-#: ../cli.py:126
+#: ../cli.py:128
 msgid "Reading repository metadata in from local files"
-msgstr "Leser inn data om pakker fra lokale filer"
+msgstr "Leser inn data om lager fra lokale filer"
 
-#: ../cli.py:183 ../utils.py:72
+#: ../cli.py:186 ../utils.py:71
 #, python-format
 msgid "Config Error: %s"
-msgstr "Feil ved konfigurasjon: %s"
+msgstr "Feil i konfigurasjon: %s"
 
-#: ../cli.py:186 ../cli.py:1068 ../utils.py:75
+#: ../cli.py:189 ../cli.py:1081 ../utils.py:74
 #, python-format
 msgid "Options Error: %s"
-msgstr "Feil med opsjoner: %s"
+msgstr "Feil i flagg: %s"
 
-#: ../cli.py:229
+#: ../cli.py:232
 msgid "You need to give some command"
-msgstr "Vennligst oppgi minst en kommando"
+msgstr "Du må oppgi en kommando"
 
-#: ../cli.py:271
+#: ../cli.py:274
 msgid "Disk Requirements:\n"
-msgstr "Krav til ledig diskplass\n"
+msgstr "Krav til ledig diskplass:\n"
 
-#: ../cli.py:273
+#: ../cli.py:276
 #, python-format
 msgid "  At least %dMB needed on the %s filesystem.\n"
-msgstr "Minst %dMB er nødvendig i filsystemet %s.\n"
+msgstr "Minst %dMB kreves på filsystem %s.\n"
 
 #. TODO: simplify the dependency errors?
 #. Fixup the summary
-#: ../cli.py:278
+#: ../cli.py:281
 msgid ""
 "Error Summary\n"
 "-------------\n"
 msgstr ""
-"Oversikt over feil\n"
-"------------------\n"
+"Sammendrag for feil\n"
+"---------------------\n"
 
-#: ../cli.py:317
+#: ../cli.py:320
 msgid "Trying to run the transaction but nothing to do. Exiting."
-msgstr "Prøver og fullføre transaksjonen, men den er tom. Avslutter."
+msgstr "Prøver å kjøre transaksjonen, men den er tom. Avslutter."
 
-#: ../cli.py:347
+#: ../cli.py:350
 msgid "Exiting on user Command"
 msgstr "Avslutter på grunn av kommando fra bruker"
 
-#: ../cli.py:351
+#: ../cli.py:354
 msgid "Downloading Packages:"
 msgstr "Laster ned pakker:"
 
-#: ../cli.py:356
+#: ../cli.py:359
 msgid "Error Downloading Packages:\n"
 msgstr "Kunne ikke laste ned pakkene:\n"
 
-#: ../cli.py:370 ../yum/__init__.py:2746
+#: ../cli.py:373 ../yum/__init__.py:2826
 msgid "Running rpm_check_debug"
-msgstr "Kjører rpm-sjekker"
+msgstr "Kjører rpm_check_debug"
 
-#: ../cli.py:373 ../yum/__init__.py:2749
+#: ../cli.py:376 ../yum/__init__.py:2829
 msgid "ERROR with rpm_check_debug vs depsolve:"
-msgstr "Feil: en forskjell mellom rpm-sjekker og yum har oppstått"
+msgstr "FEIL med rpm_check_debug i forhold til løsing av avhengigheter:"
 
-#: ../cli.py:377 ../yum/__init__.py:2751
+#: ../cli.py:380 ../yum/__init__.py:2831
 msgid "Please report this error in bugzilla"
 msgstr "Vennligst send en feilrapport til bugzilla"
 
-#: ../cli.py:383
+#: ../cli.py:386
 msgid "Running Transaction Test"
-msgstr "Gjennomfører en test av transaksjonen"
+msgstr "Gjennomfører test av transaksjonen"
 
-#: ../cli.py:399
+#: ../cli.py:402
 msgid "Finished Transaction Test"
 msgstr "Transaksjonstesten er fullført"
 
-#: ../cli.py:401
+#: ../cli.py:404
 msgid "Transaction Check Error:\n"
-msgstr "Feil ved sjekk av transaksjonen:\n"
+msgstr "Feil ved test av transaksjonen:\n"
 
-#: ../cli.py:408
+#: ../cli.py:411
 msgid "Transaction Test Succeeded"
 msgstr "Test av transaksjonen var vellykket"
 
-#: ../cli.py:429
+#: ../cli.py:432
 msgid "Running Transaction"
 msgstr "Utfører transaksjonen"
 
-#: ../cli.py:459
+#: ../cli.py:462
 msgid ""
 "Refusing to automatically import keys when running unattended.\n"
 "Use \"-y\" to override."
 msgstr ""
-"Nekter og automatisk importere nøkler når man kjører uten oppsyn.\n"
-"Bruk \"-y\" for uansett å godta import."
+"Nekter å importere nøkler automatisk ved kjøring uten oppsyn.\n"
+"Bruk «-y» for å overstyre."
 
-#: ../cli.py:491
+#: ../cli.py:494
 msgid "Parsing package install arguments"
 msgstr "Analyserer argumentene for pakkeinstallasjon"
 
-#: ../cli.py:501
+#: ../cli.py:504
 #, python-format
 msgid "No package %s available."
-msgstr "Ingen pakke: %s er tilgjengelig."
+msgstr "Pakke: %s er ikke tilgjengelig."
 
-#: ../cli.py:505 ../cli.py:623 ../yumcommands.py:748
+#: ../cli.py:508 ../cli.py:626 ../yumcommands.py:790
 msgid "Package(s) to install"
-msgstr "Pakker som legges"
+msgstr "Pakke(r) som skal legges inn"
 
-#: ../cli.py:506 ../cli.py:624 ../yumcommands.py:146 ../yumcommands.py:749
+#: ../cli.py:509 ../cli.py:627 ../yumcommands.py:147 ../yumcommands.py:791
 msgid "Nothing to do"
-msgstr "Ingenting og gjøre"
+msgstr "Ingenting å gjøre"
 
-#: ../cli.py:536 ../yum/__init__.py:2232 ../yum/__init__.py:2311
-#: ../yum/__init__.py:2340
+#: ../cli.py:539 ../yum/__init__.py:2275 ../yum/__init__.py:2375
+#: ../yum/__init__.py:2387
 #, python-format
 msgid "Not Updating Package that is already obsoleted: %s.%s %s:%s-%s"
 msgstr "Vil ikke oppdatere pakke som allerede er foreldet: %s.%s %s:%s-%s"
 
-#: ../cli.py:568
+#: ../cli.py:571
 #, python-format
 msgid "Could not find update match for %s"
 msgstr "Kunne ikke finne oppdatering som passet for %s"
 
-#: ../cli.py:580
+#: ../cli.py:583
 #, python-format
 msgid "%d packages marked for Update"
-msgstr "%d pakker er vil bli oppdatert"
+msgstr "%d pakker merket for oppdatering"
 
-#: ../cli.py:583
+#: ../cli.py:586
 msgid "No Packages marked for Update"
-msgstr "Ingen pakker vil bli oppdatert"
+msgstr "Ingen pakker merket for oppdatering"
 
-#: ../cli.py:599
+#: ../cli.py:602
 #, python-format
 msgid "%d packages marked for removal"
-msgstr "%d pakker vil bli fjernet"
+msgstr "%d pakker merket for fjerning"
 
-#: ../cli.py:602
+#: ../cli.py:605
 msgid "No Packages marked for removal"
-msgstr "Ingen pakker vil bli fjernet"
+msgstr "Ingen pakker merket for fjerning"
 
-#: ../cli.py:614
+#: ../cli.py:617
 msgid "No Packages Provided"
 msgstr "Ingen pakker ble tilbudt"
 
-#: ../cli.py:654
+#: ../cli.py:657
 msgid "Matching packages for package list to user args"
 msgstr "Tilpasser pakkeliste etter brukers ønske"
 
-#: ../cli.py:701
-#, fuzzy, python-format
+#: ../cli.py:705
+#, python-format
 msgid "Warning: No matches found for: %s"
-msgstr "Ingen pakke for %s er funnet"
+msgstr "Advarsel: Ingen treff funnet for: %s"
 
-#: ../cli.py:704
+#: ../cli.py:708
 msgid "No Matches found"
-msgstr "Ingen passende pakker ble funnet"
+msgstr "Fant ingen treff"
 
-#: ../cli.py:745
+#: ../cli.py:749
 #, python-format
 msgid "No Package Found for %s"
 msgstr "Ingen pakke ble funnet for %s"
 
-#: ../cli.py:757
+#: ../cli.py:761
 msgid "Cleaning up Everything"
 msgstr "Rydder opp alt"
 
-#: ../cli.py:771
+#: ../cli.py:775
 msgid "Cleaning up Headers"
-msgstr "Rydder opp metadata"
+msgstr "Rydder opp pakkehoder"
 
-#: ../cli.py:774
+#: ../cli.py:778
 msgid "Cleaning up Packages"
-msgstr "Fjerner lagrede pakker"
+msgstr "Rydder opp pakker"
 
-#: ../cli.py:777
+#: ../cli.py:781
 msgid "Cleaning up xml metadata"
 msgstr "Rydder opp i XML-metadata"
 
-#: ../cli.py:780
+#: ../cli.py:784
 msgid "Cleaning up database cache"
-msgstr "Rydder opp i databasen"
+msgstr "Rydder opp i mellomlager for database"
 
-#: ../cli.py:783
-#, fuzzy
+#: ../cli.py:787
 msgid "Cleaning up expire-cache metadata"
-msgstr "Rydder opp i XML-metadata"
+msgstr "Rydder opp i metadata for expire-cache"
 
-#: ../cli.py:786
+#: ../cli.py:790
 msgid "Cleaning up plugins"
 msgstr "Rydder opp i tillegg"
 
-#: ../cli.py:807
+#: ../cli.py:812
 msgid "Installed Groups:"
 msgstr "Installerte grupper:"
 
-#: ../cli.py:814
+#: ../cli.py:819
 msgid "Available Groups:"
 msgstr "Tilgjengelig grupper:"
 
-#: ../cli.py:820
+#: ../cli.py:825
 msgid "Done"
 msgstr "Ferdig"
 
-#: ../cli.py:829 ../cli.py:841 ../cli.py:847
+#: ../cli.py:836 ../cli.py:854 ../cli.py:860
 #, python-format
 msgid "Warning: Group %s does not exist."
-msgstr "Advarsel: gruppe %s eksisterer ikke."
+msgstr "Advarsel: Gruppe %s eksisterer ikke."
 
-#: ../cli.py:853
+#: ../cli.py:864
 msgid "No packages in any requested group available to install or update"
-msgstr "Ingen pakker i aktuelle grupper er tilgjengelig"
+msgstr ""
+"Ingen pakker tilgjengelig for installering eller oppdatering i aktuelle "
+"grupper"
 
-#: ../cli.py:855
+#: ../cli.py:866
 #, python-format
 msgid "%d Package(s) to Install"
-msgstr "%d pakker vil bli installert"
+msgstr "%d pakke(r) vil bli installert"
 
-#: ../cli.py:865
+#: ../cli.py:876
 #, python-format
 msgid "No group named %s exists"
-msgstr "Ingen gruppe med navn %s er tilgjengelig"
+msgstr "Det finnes ingen gruppe med navn %s"
 
-#: ../cli.py:871
+#: ../cli.py:882
 msgid "No packages to remove from groups"
-msgstr "Ingen pakker og fjerne fra gruppe"
+msgstr "Ingen pakker å fjerne fra grupper"
 
-#: ../cli.py:873
+#: ../cli.py:884
 #, python-format
 msgid "%d Package(s) to remove"
 msgstr "%d pakker vil bli fjernet"
 
-#: ../cli.py:915
+#: ../cli.py:926
 #, python-format
 msgid "Package %s is already installed, skipping"
 msgstr "Pakke %s er allerede lagt inn, hopper over"
 
-#: ../cli.py:926
+#: ../cli.py:937
 #, python-format
 msgid "Discarding non-comparable pkg %s.%s"
-msgstr "Vraker pakke som ikke sammenlignes %s.%s"
+msgstr "Vraker pakke som ikke kan sammenlignes %s.%s"
 
 #. we've not got any installed that match n or n+a
-#: ../cli.py:952
+#: ../cli.py:963
 #, python-format
 msgid "No other %s installed, adding to list for potential install"
 msgstr ""
-"Ingen annen pakke %s er lagt inn, legger til pakke til liste over "
-"potensielle pakker"
+"Ingen annen %s er lagt inn, legger til pakke til liste over potensielle "
+"pakker"
 
-#: ../cli.py:971
+#: ../cli.py:982
 #, python-format
 msgid "Command line error: %s"
-msgstr "Feil ved kommandolinje: %s"
+msgstr "Feil med kommandolinje: %s"
+
+#: ../cli.py:994
+#, python-format
+msgid ""
+"\n"
+"\n"
+"%s: %s option requires an argument"
+msgstr ""
+"\n"
+"\n"
+"%s: flagg %s krever et argument"
 
-#: ../cli.py:1101
+#: ../cli.py:1123
+msgid "show this help message and exit"
+msgstr "vis denne hjelpteksten og avslutt"
+
+#: ../cli.py:1127
 msgid "be tolerant of errors"
 msgstr "vær tolerant ved feil"
 
-#: ../cli.py:1103
+#: ../cli.py:1129
 msgid "run entirely from cache, don't update cache"
 msgstr "bruk kun lagrede filer ved kjøring, ikke oppdater lagrede filer"
 
-#: ../cli.py:1105
+#: ../cli.py:1131
 msgid "config file location"
 msgstr "plassering av konfigurasjonsfil"
 
-#: ../cli.py:1107
+#: ../cli.py:1133
 msgid "maximum command wait time"
 msgstr "maksimaltid for å vente på kommando"
 
-#: ../cli.py:1109
+#: ../cli.py:1135
 msgid "debugging output level"
-msgstr "mengde tilbakemelding ved avlusing"
+msgstr "nivå for tilbakemeldinger ved avlusing"
 
-#: ../cli.py:1113
+#: ../cli.py:1139
 msgid "show duplicates, in repos, in list/search commands"
-msgstr ""
+msgstr "vis duplikater i lager og i kommandoer for å liste/søke i pakker"
 
-#: ../cli.py:1115
+#: ../cli.py:1141
 msgid "error output level"
 msgstr "mengde tilbakemelding ved feil"
 
-#: ../cli.py:1118
+#: ../cli.py:1144
 msgid "quiet operation"
-msgstr "utfører med minimalt av tilbakemelding"
+msgstr "stille operasjon"
+
+#: ../cli.py:1146
+msgid "verbose operation"
+msgstr "vis ekstra informasjon"
 
-#: ../cli.py:1122
+#: ../cli.py:1148
 msgid "answer yes for all questions"
-msgstr "svar Ja til alle eventuelle spørsmål som kan oppstå"
+msgstr "svar Ja til alle spørsmål"
 
-#: ../cli.py:1124
+#: ../cli.py:1150
 msgid "show Yum version and exit"
-msgstr "vis versjon til Yum og avslutt deretter"
+msgstr "vis Yum-versjon og avslutt"
 
-#: ../cli.py:1125
+#: ../cli.py:1151
 msgid "set install root"
-msgstr "setter laveste filtre-nivå for intallering (standard er /)"
+msgstr "sett rot for installasjonen"
 
-#: ../cli.py:1129
+#: ../cli.py:1155
 msgid "enable one or more repositories (wildcards allowed)"
-msgstr "legger til en eller flere pakkeoversikter (jokertegn er tillatt)"
+msgstr "legger til et eller flere lager (jokertegn er tillatt)"
 
-#: ../cli.py:1133
+#: ../cli.py:1159
 msgid "disable one or more repositories (wildcards allowed)"
-msgstr "fjernet en eller flere pakkeoversikter (jokertegn er tillatt)"
+msgstr "slå av et eller flere lager (jokertegn er tillatt)"
 
-#: ../cli.py:1136
+#: ../cli.py:1162
 msgid "exclude package(s) by name or glob"
-msgstr "overse pakke(r) ved navn eller glob"
+msgstr "overse pakke(r) ved navn eller mønster"
 
-#: ../cli.py:1138
+#: ../cli.py:1164
 msgid "disable exclude from main, for a repo or for everything"
-msgstr "fjerner ekskludering av pakker, for en pakkeoversikt eller fullstendig"
+msgstr "fjerner ekskludering av pakker, for et lager eller alle pakker"
 
-#: ../cli.py:1141
+#: ../cli.py:1167
 msgid "enable obsoletes processing during updates"
 msgstr "ta med foreldede pakker i beregningen ved oppdatering"
 
-#: ../cli.py:1143
+#: ../cli.py:1169
 msgid "disable Yum plugins"
 msgstr "ikke bruk tillegg til Yum"
 
-#: ../cli.py:1145
+#: ../cli.py:1171
 msgid "disable gpg signature checking"
-msgstr "ikke gjennomfør sjekk av GPG-signaturer"
+msgstr "ikke sjekk GPG-signaturer"
 
-#: ../cli.py:1147
+#: ../cli.py:1173
 msgid "disable plugins by name"
-msgstr "ikke bruk tillegg til yum ved navn"
+msgstr "slå av tillegg til yum etter navn"
 
-#: ../cli.py:1150
+#: ../cli.py:1176
 msgid "skip packages with depsolving problems"
-msgstr "hoppe over pakker som har problemer med avhengigheter"
+msgstr "hopp over pakker som har problemer med avhengigheter"
 
-#: ../output.py:229
+#: ../output.py:228
 msgid "Jan"
 msgstr "jan"
 
-#: ../output.py:229
+#: ../output.py:228
 msgid "Feb"
 msgstr "feb"
 
-#: ../output.py:229
+#: ../output.py:228
 msgid "Mar"
 msgstr "mar"
 
-#: ../output.py:229
+#: ../output.py:228
 msgid "Apr"
 msgstr "apr"
 
-#: ../output.py:229
+#: ../output.py:228
 msgid "May"
 msgstr "mai"
 
-#: ../output.py:229
+#: ../output.py:228
 msgid "Jun"
 msgstr "jun"
 
-#: ../output.py:230
+#: ../output.py:229
 msgid "Jul"
 msgstr "jul"
 
-#: ../output.py:230
+#: ../output.py:229
 msgid "Aug"
 msgstr "aug"
 
-#: ../output.py:230
+#: ../output.py:229
 msgid "Sep"
 msgstr "sep"
 
-#: ../output.py:230
+#: ../output.py:229
 msgid "Oct"
 msgstr "okt"
 
-#: ../output.py:230
+#: ../output.py:229
 msgid "Nov"
 msgstr "nov"
 
-#: ../output.py:230
+#: ../output.py:229
 msgid "Dec"
 msgstr "des"
 
-#: ../output.py:240
+#: ../output.py:239
 msgid "Trying other mirror."
 msgstr "Prøver et annet speil."
 
@@ -524,25 +547,25 @@ msgstr "Beskrivelse:"
 
 #: ../output.py:351
 msgid "Is this ok [y/N]: "
-msgstr "Er dette greit [y/N]:"
+msgstr "Er dette ok [j/N]:"
 
-#: ../output.py:357 ../output.py:360
+#: ../output.py:359 ../output.py:362
 msgid "y"
-msgstr ""
+msgstr "j"
 
-#: ../output.py:357
+#: ../output.py:359
 msgid "n"
-msgstr ""
+msgstr "n"
 
-#: ../output.py:357 ../output.py:360
+#: ../output.py:359 ../output.py:362
 msgid "yes"
-msgstr ""
+msgstr "ja"
 
-#: ../output.py:357
+#: ../output.py:359
 msgid "no"
-msgstr ""
+msgstr "nei"
 
-#: ../output.py:367
+#: ../output.py:370
 #, python-format
 msgid ""
 "\n"
@@ -551,96 +574,96 @@ msgstr ""
 "\n"
 "Gruppe:%s"
 
-#: ../output.py:369
+#: ../output.py:372
 #, python-format
 msgid " Description: %s"
 msgstr " Beskrivelse: %s"
 
-#: ../output.py:371
+#: ../output.py:374
 msgid " Mandatory Packages:"
 msgstr "Obligatoriske pakker:"
 
-#: ../output.py:376
+#: ../output.py:379
 msgid " Default Packages:"
 msgstr "Standard pakker:"
 
-#: ../output.py:381
+#: ../output.py:384
 msgid " Optional Packages:"
 msgstr "Valgfrie pakker:"
 
-#: ../output.py:386
+#: ../output.py:389
 msgid " Conditional Packages:"
 msgstr "Betingede pakker:"
 
-#: ../output.py:394
+#: ../output.py:398
 #, python-format
 msgid "package: %s"
 msgstr "pakke: %s"
 
-#: ../output.py:396
+#: ../output.py:400
 msgid "  No dependencies for this package"
 msgstr " Ingen avhengigheter for denne pakka"
 
-#: ../output.py:401
+#: ../output.py:405
 #, python-format
 msgid "  dependency: %s"
 msgstr " avhengighet: %s"
 
-#: ../output.py:403
+#: ../output.py:407
 msgid "   Unsatisfied dependency"
 msgstr " avhengighet som ikke kunne tilfredstilles"
 
-#: ../output.py:461
+#: ../output.py:465
 msgid "Matched from:"
 msgstr "Treff fra:"
 
-#: ../output.py:487
+#: ../output.py:491
 msgid "There was an error calculating total download size"
 msgstr "Kunne ikke finne ut størrelse på det som skal hentes ned"
 
-#: ../output.py:492
+#: ../output.py:496
 #, python-format
 msgid "Total size: %s"
 msgstr "Totale størrelse: %s"
 
-#: ../output.py:495
+#: ../output.py:499
 #, python-format
 msgid "Total download size: %s"
 msgstr "Totale størrelse på pakker som hentes: %s"
 
-#: ../output.py:507
+#: ../output.py:511
 msgid "Package"
 msgstr "Pakke"
 
-#: ../output.py:507
+#: ../output.py:511
 msgid "Arch"
 msgstr "Arkitektur"
 
-#: ../output.py:507
+#: ../output.py:511
 msgid "Version"
 msgstr "Versjon"
 
-#: ../output.py:507
+#: ../output.py:511
 msgid "Repository"
 msgstr "Pakkeoversikt"
 
-#: ../output.py:507
+#: ../output.py:511
 msgid "Size"
 msgstr "Størrelse"
 
-#: ../output.py:514
+#: ../output.py:518
 msgid "Installing for dependencies"
 msgstr "Legges inn på grunn avhengigheter"
 
-#: ../output.py:515
+#: ../output.py:519
 msgid "Updating for dependencies"
 msgstr "Oppdateres på grunn avhengigheter"
 
-#: ../output.py:516
+#: ../output.py:520
 msgid "Removing for dependencies"
 msgstr "Fjernes på grunn avhengigheter"
 
-#: ../output.py:528
+#: ../output.py:532
 #, python-format
 msgid ""
 "     replacing  %s.%s %s\n"
@@ -649,7 +672,7 @@ msgstr ""
 "     erstatter   %s.%s %s\"\n"
 "\n"
 
-#: ../output.py:536
+#: ../output.py:540
 #, python-format
 msgid ""
 "\n"
@@ -666,27 +689,27 @@ msgstr ""
 "Oppdaterer %5.5s pakker\n"
 "Fjerner    %5.5s pakker\n"
 
-#: ../output.py:554
+#: ../output.py:558
 msgid "Removed"
 msgstr "Fjernet"
 
-#: ../output.py:555
+#: ../output.py:559
 msgid "Dependency Removed"
 msgstr "Fjernet på grunn avhengighet"
 
-#: ../output.py:557
+#: ../output.py:561
 msgid "Dependency Installed"
 msgstr "Lagt inn på grunn av avhengighet"
 
-#: ../output.py:559
+#: ../output.py:563
 msgid "Dependency Updated"
 msgstr "Oppdatert på grunn avhengighet"
 
-#: ../output.py:560
+#: ../output.py:564
 msgid "Replaced"
 msgstr "Erstattet"
 
-#: ../output.py:618
+#: ../output.py:622
 #, python-format
 msgid ""
 "\n"
@@ -697,72 +720,72 @@ msgstr ""
 " Pågående nedlastning er avbrutt, %s avbryt (ved å trykke Ctrl-C) %s ganger "
 "til innen %s%s%s sekunder for å avslutte helt.\n"
 
-#: ../output.py:628
+#: ../output.py:632
 msgid "user interrupt"
-msgstr "avbryt av bruker"
+msgstr "avbrutt av bruker"
 
-#: ../output.py:639
+#: ../output.py:643
 msgid "installed"
 msgstr "lagt inn"
 
-#: ../output.py:640
+#: ../output.py:644
 msgid "updated"
 msgstr "oppdatert"
 
-#: ../output.py:641
+#: ../output.py:645
 msgid "obsoleted"
 msgstr "foreldet"
 
-#: ../output.py:642
+#: ../output.py:646
 msgid "erased"
 msgstr "fjernet"
 
-#: ../output.py:646
+#: ../output.py:650
 #, python-format
 msgid "---> Package %s.%s %s:%s-%s set to be %s"
 msgstr "---> pakke %s.%s %s:%s-%s er satt til %s"
 
-#: ../output.py:653
+#: ../output.py:657
 msgid "--> Running transaction check"
 msgstr "--> Utfører sjekk av transaksjonen"
 
-#: ../output.py:658
+#: ../output.py:662
 msgid "--> Restarting Dependency Resolution with new changes."
-msgstr "--> Starter løsning av avhengigheter på nytt"
+msgstr "--> Starter løsing av avhengigheter på nytt med endringer"
 
-#: ../output.py:663
+#: ../output.py:667
 msgid "--> Finished Dependency Resolution"
 msgstr "--> Alle avhengigheter er løst"
 
-#: ../output.py:668
+#: ../output.py:672
 #, python-format
 msgid "--> Processing Dependency: %s for package: %s"
 msgstr "--> Beregner avhengighet: %s for pakke: %s"
 
-#: ../output.py:673
+#: ../output.py:677
 #, python-format
 msgid "--> Unresolved Dependency: %s"
 msgstr "--> Avhengigheter som ikke kunne bli tilfredstilt: %s"
 
-#: ../output.py:679
+#: ../output.py:683
 #, python-format
 msgid "--> Processing Conflict: %s conflicts %s"
 msgstr "--> Beregner konflikter: %s er i konflikt med %s"
 
-#: ../output.py:682
+#: ../output.py:686
 msgid "--> Populating transaction set with selected packages. Please wait."
-msgstr "--> Fyller transaksjonen med valgt pakker. Vennligst vent."
+msgstr "--> Fyller transaksjonen med valgte pakker. Vennligst vent."
 
-#: ../output.py:686
+#: ../output.py:690
 #, python-format
 msgid "---> Downloading header for %s to pack into transaction set."
 msgstr "---> Henter ned filhode for pakke %s for å fylle transaksjonen."
 
-#: ../yumcommands.py:36
+#: ../yumcommands.py:37
 msgid "You need to be root to perform this command."
 msgstr "Du må være rootbruker for å utføre denne kommandoen."
 
-#: ../yumcommands.py:43
+#: ../yumcommands.py:44
 msgid ""
 "\n"
 "You have enabled checking of packages via GPG keys. This is a good thing. \n"
@@ -780,261 +803,277 @@ msgid ""
 "For more information contact your distribution or package provider.\n"
 msgstr ""
 "\n"
-"Du har valgt og sjekk pakkene ved hjelp av GPG-nøkler. Det er fornufting.\n"
+"Du har valgt å sjekke pakkene ved hjelp av GPG-nøkler. Det er fornuftig.\n"
 "Du har imidlertid ingen offentlige GPG-nøkler installert\n"
-"Du må hente ned og legge inn nøklene. Du kan legge de inn med kommandoen:\n"
+"Du må hente ned og legge inn nøklene. Du kan legge dem inn med kommandoen:\n"
 "\n"
 "  rpm --import public.gpg.key\n"
 "\n"
-"Et annet og bedre alternativ er og oppgi URL til de nøklene du vil bruke.\n"
-"Bruk opsjonen 'gpgkey' for hver pakkeoversikt for å ta dette i bruk.\n"
-"\n"
+"Et annet og bedre alternativ er å oppgi URL til de nøklene du vil bruke.\n"
+"Bruk opsjonen 'gpgkey' for hvert lager for å ta dette i bruk.\n"
 "\n"
+"Kontakt din distribusjon eller pakkeansvarlig for mer informasjon.\n"
 
-#: ../yumcommands.py:63
+#: ../yumcommands.py:64
 #, python-format
 msgid "Error: Need to pass a list of pkgs to %s"
-msgstr "Feil: du må oppgi ei liste over pakker som skal %s"
+msgstr "Feil: du må oppgi en liste med pakker som skal %s"
 
-#: ../yumcommands.py:69
+#: ../yumcommands.py:70
 msgid "Error: Need an item to match"
-msgstr "Feil: trenger noe og sammenligne med"
+msgstr "Feil: trenger noe å sammenligne med"
 
-#: ../yumcommands.py:75
+#: ../yumcommands.py:76
 msgid "Error: Need a group or list of groups"
-msgstr "Feil: trenger ei gruppe eller ei liste med grupper"
+msgstr "Feil: trenger en gruppe eller en liste med grupper"
 
-#: ../yumcommands.py:84
+#: ../yumcommands.py:85
 #, python-format
 msgid "Error: clean requires an option: %s"
 msgstr "Feil: clean trenger minst et argument: %s"
 
-#: ../yumcommands.py:89
+#: ../yumcommands.py:90
 #, python-format
 msgid "Error: invalid clean argument: %r"
 msgstr "Feil: ugyldig argument gitt til kommandoen clean: %r"
 
-#: ../yumcommands.py:102
+#: ../yumcommands.py:103
 msgid "No argument to shell"
 msgstr "Ingen argumenter ble gitt til kommandoen shell"
 
-#: ../yumcommands.py:105
+#: ../yumcommands.py:106
 #, python-format
 msgid "Filename passed to shell: %s"
-msgstr "Følgende filnavn ble som argument til shell: %s"
+msgstr "Følgende filnavn ble sendt til skallet: %s"
 
-#: ../yumcommands.py:109
+#: ../yumcommands.py:110
 #, python-format
 msgid "File %s given as argument to shell does not exist."
 msgstr ""
 "Filen %s som ble gitt som argument til kommandoen shell eksisterer ikke."
 
-#: ../yumcommands.py:115
+#: ../yumcommands.py:116
 msgid "Error: more than one file given as argument to shell."
-msgstr "Feil: mer enn ei fil ble gitt som argument til kommandoen shell."
+msgstr "Feil: mer enn en fil ble gitt som argument til kommandoen shell."
 
-#: ../yumcommands.py:156
+#: ../yumcommands.py:157
 msgid "PACKAGE..."
-msgstr "Pakke..."
+msgstr "PAKKE..."
 
-#: ../yumcommands.py:159
+#: ../yumcommands.py:160
 msgid "Install a package or packages on your system"
-msgstr "Legger inn pakke(r) på ditt system"
+msgstr "Legg inn en eller flere pakker på systemet"
 
-#: ../yumcommands.py:168
+#: ../yumcommands.py:169
 msgid "Setting up Install Process"
 msgstr "Forberedelser for installasjon"
 
-#: ../yumcommands.py:179
+#: ../yumcommands.py:180
 msgid "[PACKAGE...]"
-msgstr "[Pakke...}"
+msgstr "[PAKKE...]"
 
-#: ../yumcommands.py:182
+#: ../yumcommands.py:183
 msgid "Update a package or packages on your system"
-msgstr "Oppdaterer pakke(r) på ditt system"
+msgstr "Oppdater en eller flere pakker på systemet"
 
-#: ../yumcommands.py:190
+#: ../yumcommands.py:191
 msgid "Setting up Update Process"
 msgstr "Forberedelser for oppdatering"
 
-#: ../yumcommands.py:204
+#: ../yumcommands.py:205
 msgid "Display details about a package or group of packages"
 msgstr "Viser detaljer om en pakke eller en gruppe av grupper"
 
-#: ../yumcommands.py:212
+#: ../yumcommands.py:213
 msgid "Installed Packages"
 msgstr "Pakker som er installert"
 
-#: ../yumcommands.py:213
+#: ../yumcommands.py:214
 msgid "Available Packages"
-msgstr "Tilgjengelig pakker"
+msgstr "Tilgjengelige pakker"
 
-#: ../yumcommands.py:214
+#: ../yumcommands.py:215
 msgid "Extra Packages"
 msgstr "Tilleggspakker"
 
-#: ../yumcommands.py:215
+#: ../yumcommands.py:216
 msgid "Updated Packages"
 msgstr "Oppdaterte pakker"
 
-#: ../yumcommands.py:221 ../yumcommands.py:225
+#: ../yumcommands.py:222 ../yumcommands.py:228
 msgid "Obsoleting Packages"
 msgstr "Utdaterte pakker"
 
-#: ../yumcommands.py:226
+#: ../yumcommands.py:229
 msgid "Recently Added Packages"
-msgstr "Pakker som nylig er blitt lagt til"
+msgstr "Pakker som nylig er lagt til"
 
-#: ../yumcommands.py:232
+#: ../yumcommands.py:235
 msgid "No matching Packages to list"
-msgstr "Ingen passende pakker og liste opp"
+msgstr "Ingen passende pakker å liste opp"
 
-#: ../yumcommands.py:246
+#: ../yumcommands.py:249
 msgid "List a package or groups of packages"
-msgstr "Lag en liste over pakker eller gruppe av pakker"
+msgstr "Lag en liste med pakker eller grupper av pakker"
 
-#: ../yumcommands.py:258
+#: ../yumcommands.py:261
 msgid "Remove a package or packages from your system"
-msgstr "Fjerner pakke(r) fra ditt system"
+msgstr "Fjern en eller flere pakker fra systemet"
 
-#: ../yumcommands.py:266
+#: ../yumcommands.py:269
 msgid "Setting up Remove Process"
 msgstr "Klargjør for fjerning av pakker"
 
-#: ../yumcommands.py:278
+#: ../yumcommands.py:281
 msgid "Setting up Group Process"
-msgstr "Klargjør grupper av pakker"
+msgstr "Klargjør grupper med pakker"
 
-#: ../yumcommands.py:284
+#: ../yumcommands.py:287
 msgid "No Groups on which to run command"
-msgstr "Ingen gruppe er valgt for aktuelle kommando"
+msgstr "Ingen gruppe er valgt for aktuell kommando"
 
-#: ../yumcommands.py:297
+#: ../yumcommands.py:300
 msgid "List available package groups"
-msgstr "Lag liste over tilgjengelig grupper"
+msgstr "Lag liste over tilgjengelige pakkegrupper"
 
-#: ../yumcommands.py:314
+#: ../yumcommands.py:317
 msgid "Install the packages in a group on your system"
-msgstr "Legger inn pakkene i gruppe av pakker"
+msgstr "Legger inn pakkene i en gruppe på systemet"
 
-#: ../yumcommands.py:336
+#: ../yumcommands.py:339
 msgid "Remove the packages in a group from your system"
-msgstr "Fjerner alle pakkene i en gruppe av pakker"
+msgstr "Fjern pakkene i en gruppe fra systemet"
 
-#: ../yumcommands.py:360
+#: ../yumcommands.py:363
 msgid "Display details about a package group"
 msgstr "Viser detaljer om en gruppe av pakker"
 
-#: ../yumcommands.py:384
+#: ../yumcommands.py:387
 msgid "Generate the metadata cache"
-msgstr "Generer mellomlager av metadata"
+msgstr "Lag mellomlager med metadata"
 
-#: ../yumcommands.py:390
+#: ../yumcommands.py:393
 msgid "Making cache files for all metadata files."
 msgstr "Lager mellomlager for samtlige filer med metadata."
 
-#: ../yumcommands.py:391
+#: ../yumcommands.py:394
 msgid "This may take a while depending on the speed of this computer"
-msgstr "Dette kan ei stund alt ettersom hvor rask din maskin er"
+msgstr "Dette kan en stund avhengig av hvor rask datamaskinen er"
 
-#: ../yumcommands.py:412
+#: ../yumcommands.py:415
 msgid "Metadata Cache Created"
 msgstr "Mellomlager er ferdig lagd"
 
-#: ../yumcommands.py:426
+#: ../yumcommands.py:429
 msgid "Remove cached data"
 msgstr "Fjern mellomlager med metadata"
 
-#: ../yumcommands.py:447
+#: ../yumcommands.py:450
 msgid "Find what package provides the given value"
-msgstr "Finn hvilken pakke som tilbyr den søkte verdi"
+msgstr "Finn hvilken pakke som inneholder etterspurt verdi"
 
-#: ../yumcommands.py:467
+#: ../yumcommands.py:470
 msgid "Check for available package updates"
-msgstr "Sjekker om det oppdatering tilgjengelig for gruppene av pakker"
+msgstr "Se etter tilgjengelige pakkeoppdateringer"
 
-#: ../yumcommands.py:490
+#: ../yumcommands.py:493
 msgid "Search package details for the given string"
-msgstr "Søker etter detaljer om pakke utenifra den aktuelle strengen"
+msgstr "Søker etter oppgitt streng i pakkedetaljene"
 
-#: ../yumcommands.py:496
+#: ../yumcommands.py:499
 msgid "Searching Packages: "
-msgstr "Søker etter pakker: "
+msgstr "Søker i pakker: "
 
-#: ../yumcommands.py:513
+#: ../yumcommands.py:516
 msgid "Update packages taking obsoletes into account"
-msgstr "Oppdatering pakker og tar samtidig hensyn til pakker som er utdatert"
+msgstr "Oppdater pakker og ta hensyn til pakker som blir utdatert"
 
-#: ../yumcommands.py:522
+#: ../yumcommands.py:525
 msgid "Setting up Upgrade Process"
 msgstr "Klargjør for oppdatering"
 
-#: ../yumcommands.py:536
+#: ../yumcommands.py:539
 msgid "Install a local RPM"
 msgstr "Legger inn en RPM fra filsystemet"
 
-#: ../yumcommands.py:545
+#: ../yumcommands.py:548
 msgid "Setting up Local Package Process"
 msgstr "Klargjøring for pakker på lokalt filsystem"
 
-#: ../yumcommands.py:564
+#: ../yumcommands.py:567
 msgid "Determine which package provides the given dependency"
 msgstr "Finner hvilken pakke som tilbyr den gitte avhengigheten"
 
-#: ../yumcommands.py:567
+#: ../yumcommands.py:570
 msgid "Searching Packages for Dependency:"
-msgstr "Søker etter pakker med avhengighet:"
+msgstr "Søker i pakker etter avhengighet:"
 
-#: ../yumcommands.py:581
+#: ../yumcommands.py:584
 msgid "Run an interactive yum shell"
 msgstr "Kjører det interaktive Yum-skallet"
 
-#: ../yumcommands.py:587
+#: ../yumcommands.py:590
 msgid "Setting up Yum Shell"
 msgstr "Klargjør Yum-skallet"
 
-#: ../yumcommands.py:605
+#: ../yumcommands.py:608
 msgid "List a package's dependencies"
-msgstr "Lister opp avhengighetene til pakka"
+msgstr "Vis avhengigheter for en pakke"
 
-#: ../yumcommands.py:611
+#: ../yumcommands.py:614
 msgid "Finding dependencies: "
 msgstr "Finner avhengigheter: "
 
-#: ../yumcommands.py:627
+#: ../yumcommands.py:630
 msgid "Display the configured software repositories"
 msgstr "Viser de pakkeoversiktene som er satt opp"
 
-#: ../yumcommands.py:645
+#: ../yumcommands.py:666
+msgid "enabled"
+msgstr "aktiv"
+
+#: ../yumcommands.py:673
+msgid "disabled"
+msgstr "inaktiv"
+
+#: ../yumcommands.py:682
 msgid "repo id"
 msgstr "id"
 
-#: ../yumcommands.py:645
+#: ../yumcommands.py:683
 msgid "repo name"
 msgstr "navn"
 
-#: ../yumcommands.py:645
+#: ../yumcommands.py:683
 msgid "status"
 msgstr "status"
 
-#: ../yumcommands.py:651
-msgid "enabled"
-msgstr "aktiv"
+#: ../yumcommands.py:686
+msgid "Repo-id     : "
+msgstr "ID for lager: "
 
-#: ../yumcommands.py:654
-msgid "disabled"
-msgstr "inaktiv"
+#: ../yumcommands.py:687
+msgid "Repo-name   : "
+msgstr "Navn på lager : "
+
+#: ../yumcommands.py:688
+msgid "Repo-enabled: "
+msgstr "Lager aktivt: "
+
+#: ../yumcommands.py:689
+msgid "Repo-size   : "
+msgstr "Størrelse på lager : "
 
-#: ../yumcommands.py:671
+#: ../yumcommands.py:713
 msgid "Display a helpful usage message"
 msgstr "Viser en hjelpetekst"
 
-#: ../yumcommands.py:705
+#: ../yumcommands.py:747
 #, python-format
 msgid "No help available for %s"
 msgstr "Ingen hjelp er tilgjengelig for %s"
 
-#: ../yumcommands.py:710
+#: ../yumcommands.py:752
 msgid ""
 "\n"
 "\n"
@@ -1042,9 +1081,9 @@ msgid ""
 msgstr ""
 "\n"
 "\n"
-"aliaser:"
+"alias:"
 
-#: ../yumcommands.py:712
+#: ../yumcommands.py:754
 msgid ""
 "\n"
 "\n"
@@ -1054,15 +1093,15 @@ msgstr ""
 "\n"
 "alias:"
 
-#: ../yumcommands.py:741
+#: ../yumcommands.py:783
 msgid "Setting up Reinstall Process"
 msgstr "Klargjør for å legge inn pakke(r) på nytt"
 
-#: ../yumcommands.py:755
+#: ../yumcommands.py:797
 msgid "reinstall a package"
-msgstr "Legger inn en pakke på nytt"
+msgstr "legg inn en pakke på nytt"
 
-#: ../yummain.py:41
+#: ../yummain.py:55
 msgid ""
 "\n"
 "\n"
@@ -1072,7 +1111,7 @@ msgstr ""
 "\n"
 "Avslutter etter ønske"
 
-#: ../yummain.py:47
+#: ../yummain.py:61
 msgid ""
 "\n"
 "\n"
@@ -1080,42 +1119,42 @@ msgid ""
 msgstr ""
 "\n"
 "\n"
-"Avslutter på grunn ødelagt programrør"
+"Avslutter på grunn av brutt rør"
 
-#: ../yummain.py:105
+#: ../yummain.py:112
 msgid ""
 "Another app is currently holding the yum lock; waiting for it to exit..."
 msgstr ""
 "Et annet program holder en fillås for Yum, venter til fillåsen frigjøres..."
 
-#: ../yummain.py:132 ../yummain.py:171
+#: ../yummain.py:139 ../yummain.py:178
 #, python-format
 msgid "Error: %s"
 msgstr "Feil: %s"
 
-#: ../yummain.py:142 ../yummain.py:178
+#: ../yummain.py:149 ../yummain.py:185
 #, python-format
 msgid "Unknown Error(s): Exit Code: %d:"
-msgstr "Ukjent feil: feilkode: %d"
+msgstr "Ukjent feil: feilkode: %d:"
 
 #. Depsolve stage
-#: ../yummain.py:149
+#: ../yummain.py:156
 msgid "Resolving Dependencies"
-msgstr "Løser opp i avhengigheter"
+msgstr "Løser avhengigheter"
 
-#: ../yummain.py:184
+#: ../yummain.py:191
 msgid ""
 "\n"
 "Dependencies Resolved"
 msgstr ""
 "\n"
-"Alle avhengigheter er oppløst"
+"Alle avhengigheter er løst"
 
-#: ../yummain.py:198
+#: ../yummain.py:205
 msgid "Complete!"
 msgstr "Ferdig!"
 
-#: ../yummain.py:245
+#: ../yummain.py:252
 msgid ""
 "\n"
 "\n"
@@ -1125,319 +1164,258 @@ msgstr ""
 "\n"
 "Avslutter etter ønske"
 
-#: ../yum/depsolve.py:82
+#: ../yum/depsolve.py:78
 msgid "doTsSetup() will go away in a future version of Yum.\n"
 msgstr "doTsSetup() vil forsvinne i en kommende utgave av Yum.\n"
 
-#: ../yum/depsolve.py:95
+#: ../yum/depsolve.py:91
 msgid "Setting up TransactionSets before config class is up"
 msgstr "Setter opp transaksjons-sett før config klassen er klar"
 
-#: ../yum/depsolve.py:136
+#: ../yum/depsolve.py:132
 #, python-format
 msgid "Invalid tsflag in config file: %s"
 msgstr "Ugyldig tsflag in konfigurasjonsfil: %s"
 
-#: ../yum/depsolve.py:147
-#, python-format
-msgid "Searching pkgSack for dep: %s"
-msgstr "Søker i pkgSack etter avhengighet: %s"
-
-#: ../yum/depsolve.py:170
-#, python-format
-msgid "Potential match for %s from %s"
-msgstr "Potensielt treff for %s i %s"
-
-#: ../yum/depsolve.py:178
-#, python-format
-msgid "Matched %s to require for %s"
-msgstr "Passende %s for å tilfredstille %s"
-
-#: ../yum/depsolve.py:219
+#: ../yum/depsolve.py:176
 #, python-format
 msgid "Member: %s"
 msgstr "Medlem: %s"
 
-#: ../yum/depsolve.py:233 ../yum/depsolve.py:696
+#: ../yum/depsolve.py:190 ../yum/depsolve.py:592
 #, python-format
 msgid "%s converted to install"
 msgstr "%s ble omdannet til installering"
 
-#: ../yum/depsolve.py:240
+#: ../yum/depsolve.py:197
 #, python-format
 msgid "Adding Package %s in mode %s"
 msgstr "Legger til pakke %s in modus %s"
 
-#: ../yum/depsolve.py:250
+#: ../yum/depsolve.py:207
 #, python-format
 msgid "Removing Package %s"
 msgstr "Fjerner pakke %s"
 
-#: ../yum/depsolve.py:261
+#: ../yum/depsolve.py:218
 #, python-format
 msgid "%s requires: %s"
-msgstr "%s avhenger av: %s"
-
-#: ../yum/depsolve.py:312
-msgid "Needed Require has already been looked up, cheating"
-msgstr "Nødvendig avhengighet har allerede blitt plukket opp, jukser"
+msgstr "%s krever: %s"
 
-#: ../yum/depsolve.py:322
-#, python-format
-msgid "Needed Require is not a package name. Looking up: %s"
-msgstr "Nødvendig avhengighet er ikke et navn på pakke. Ser etter: %s"
-
-#: ../yum/depsolve.py:329
-#, python-format
-msgid "Potential Provider: %s"
-msgstr "Potensiell tilbyder: %s"
-
-#: ../yum/depsolve.py:352
-#, python-format
-msgid "Mode is %s for provider of %s: %s"
-msgstr "Modus er %s for tilbyder av %s: %s"
-
-#: ../yum/depsolve.py:356
-#, python-format
-msgid "Mode for pkg providing %s: %s"
-msgstr "Modus for pakke som tilbyr %s: %s"
-
-#: ../yum/depsolve.py:360
-#, python-format
-msgid "TSINFO: %s package requiring %s marked as erase"
-msgstr "TSINFO: pakke %s som er nødvendig for %s vil bli fjernet"
-
-#: ../yum/depsolve.py:372
+#: ../yum/depsolve.py:273
 #, python-format
 msgid "TSINFO: Obsoleting %s with %s to resolve dep."
 msgstr "TSINFO: Bytter ut %s med %s for å løse opp i avhengighet."
 
-#: ../yum/depsolve.py:375
+#: ../yum/depsolve.py:276
 #, python-format
 msgid "TSINFO: Updating %s to resolve dep."
 msgstr "TSINFO: Oppdaterer %s for å løse opp i avhengighet."
 
-#: ../yum/depsolve.py:378
+#: ../yum/depsolve.py:279
 #, python-format
 msgid "Cannot find an update path for dep for: %s"
 msgstr "Kunne ikke finne måte å oppdatere sti for avhengighet: %s."
 
-#: ../yum/depsolve.py:388
+#: ../yum/depsolve.py:283
 #, python-format
-msgid "Unresolvable requirement %s for %s"
-msgstr "Avhengighet %s kan ikke løses opp: %s"
+msgid "TSINFO: %s package requiring %s marked as erase"
+msgstr "TSINFO: pakke %s som er nødvendig for %s vil bli fjernet"
 
 #. is it already installed?
-#: ../yum/depsolve.py:434
+#: ../yum/depsolve.py:329
 #, python-format
 msgid "%s is in providing packages but it is already installed, removing."
 msgstr "%s tilbyr pakker, men er allerede installert, fjerner denne."
 
-#: ../yum/depsolve.py:449
+#: ../yum/depsolve.py:344
 #, python-format
 msgid "Potential resolving package %s has newer instance in ts."
-msgstr ""
-"Pakke %s som potensielt tilbyder løsning har allerede nyere instans in ts."
+msgstr "Pakke %s som potensielt løser opp avhengighet har nyere instans in ts."
 
-#: ../yum/depsolve.py:460
+#: ../yum/depsolve.py:355
 #, python-format
 msgid "Potential resolving package %s has newer instance installed."
 msgstr "Pakke %s som potensielt løser opp avhengighet er allerde installert."
 
-#: ../yum/depsolve.py:468 ../yum/depsolve.py:527
+#: ../yum/depsolve.py:363 ../yum/depsolve.py:410
 #, python-format
 msgid "Missing Dependency: %s is needed by package %s"
 msgstr "Uløst avhengighet: %s trengs av pakke %s"
 
-#: ../yum/depsolve.py:481
+#: ../yum/depsolve.py:376
 #, python-format
 msgid "%s already in ts, skipping this one"
 msgstr "%s er allerde i ts, hopper over denne"
 
-#: ../yum/depsolve.py:510
-#, python-format
-msgid ""
-"Failure finding best provider of %s for %s, exceeded maximum loop length"
-msgstr ""
-
-#: ../yum/depsolve.py:537
+#: ../yum/depsolve.py:420
 #, python-format
 msgid "TSINFO: Marking %s as update for %s"
 msgstr "TSINFO: Setter opp %s som oppdatering av %s"
 
-#: ../yum/depsolve.py:544
+#: ../yum/depsolve.py:427
 #, python-format
 msgid "TSINFO: Marking %s as install for %s"
 msgstr "TSINFO: Setter opp %s som pakke for installering av %s"
 
-#: ../yum/depsolve.py:635 ../yum/depsolve.py:714
+#: ../yum/depsolve.py:518 ../yum/depsolve.py:610
 msgid "Success - empty transaction"
-msgstr "Suksess- transaksjonen er tom"
+msgstr "Suksess - transaksjonen er tom"
 
-#: ../yum/depsolve.py:673 ../yum/depsolve.py:686
+#: ../yum/depsolve.py:562 ../yum/depsolve.py:582
 msgid "Restarting Loop"
 msgstr "Starter sløyfe på nytt"
 
-#: ../yum/depsolve.py:702
+#: ../yum/depsolve.py:598
 msgid "Dependency Process ending"
 msgstr "Beregning av avhengighet avsluttes"
 
-#: ../yum/depsolve.py:708
+#: ../yum/depsolve.py:604
 #, python-format
 msgid "%s from %s has depsolving problems"
-msgstr "%s to %s har problemer med avhengigheter"
+msgstr "%s fra %s har problemer med avhengigheter"
 
-#: ../yum/depsolve.py:715
+#: ../yum/depsolve.py:611
 msgid "Success - deps resolved"
 msgstr "Suksess - alle avhengigheter er tilfredstilt"
 
-#: ../yum/depsolve.py:729
+#: ../yum/depsolve.py:625
 #, python-format
 msgid "Checking deps for %s"
 msgstr "Sjekker avhengigheter for %s"
 
-#: ../yum/depsolve.py:782
+#: ../yum/depsolve.py:687
 #, python-format
 msgid "looking for %s as a requirement of %s"
-msgstr "leter etter %s som en nødvendighet fra %s"
-
-#: ../yum/depsolve.py:933
-#, python-format
-msgid "Comparing best: %s to po: %s"
-msgstr ""
+msgstr "leter etter %s som kreves av %s"
 
-#: ../yum/depsolve.py:937
+#: ../yum/depsolve.py:814
 #, python-format
-msgid "Same: best %s == po: %s"
-msgstr ""
-
-#: ../yum/depsolve.py:952 ../yum/depsolve.py:963
-#, python-format
-msgid "best %s obsoletes po: %s"
-msgstr ""
+msgid "Running compare_providers() for %s"
+msgstr "Kjører compare_providers() for %s"
 
-#: ../yum/depsolve.py:955
+#: ../yum/depsolve.py:842 ../yum/depsolve.py:848
 #, python-format
-msgid "po %s obsoletes best: %s"
-msgstr ""
-
-#: ../yum/depsolve.py:972 ../yum/depsolve.py:979 ../yum/depsolve.py:1036
-#, fuzzy, python-format
 msgid "better arch in po %s"
-msgstr "søker etter pakke %s"
+msgstr "bedre arch i po %s"
 
-#: ../yum/depsolve.py:988 ../yum/depsolve.py:1010
+#: ../yum/depsolve.py:887
 #, python-format
-msgid "po %s shares a sourcerpm with %s"
-msgstr ""
+msgid "%s obsoletes %s"
+msgstr "%s faser ut %s"
 
-#: ../yum/depsolve.py:992 ../yum/depsolve.py:1015
+#: ../yum/depsolve.py:898
 #, python-format
-msgid "best %s shares a sourcerpm with %s"
+msgid ""
+"archdist compared %s to %s on %s\n"
+"  Winner: %s"
 msgstr ""
+"archdist sammenlignet %s med %s på %s\n"
+" Vinner: %s"
 
-#: ../yum/depsolve.py:999 ../yum/depsolve.py:1020
+#: ../yum/depsolve.py:905
 #, python-format
-msgid "po %s shares more of the name prefix with %s"
+msgid "common sourcerpm %s and %s"
 msgstr ""
 
-#: ../yum/depsolve.py:1003 ../yum/depsolve.py:1029
+#: ../yum/depsolve.py:911
 #, python-format
-msgid "po %s has a shorter name than best %s"
+msgid "common prefix of %s between %s and %s"
 msgstr ""
 
-#: ../yum/depsolve.py:1025
+#: ../yum/depsolve.py:919
 #, python-format
-msgid "bestpkg %s shares more of the name prefix with %s"
-msgstr ""
+msgid "Best Order: %s"
+msgstr "Beste rekkefølge: %s"
 
-#: ../yum/__init__.py:119
+#: ../yum/__init__.py:148
 msgid "doConfigSetup() will go away in a future version of Yum.\n"
 msgstr "doConfigSetup() vil forsvinne i en kommende utgave av Yum.\n"
 
-#: ../yum/__init__.py:296
+#. FIXME: Use critical? or exception?
+#: ../yum/__init__.py:323
 #, python-format
 msgid "Repository %r is missing name in configuration, using id"
-msgstr "Pakkeoversikt %r har intet navn i konfigurasjonsfilen(e), bruker id"
+msgstr "Pakkelager %r mangler navn i konfigurasjonsfilen(e), bruker id"
 
-#: ../yum/__init__.py:332
+#: ../yum/__init__.py:359
 msgid "plugins already initialised"
-msgstr "tillegg til yum er allerede satt opp"
+msgstr "tillegg til yum er allerede initiert"
 
-#: ../yum/__init__.py:339
+#: ../yum/__init__.py:366
 msgid "doRpmDBSetup() will go away in a future version of Yum.\n"
 msgstr "doRepoSetup() vil forsvinne i en kommende utgave av Yum.\n"
 
-#: ../yum/__init__.py:349
+#: ../yum/__init__.py:376
 msgid "Reading Local RPMDB"
-msgstr "Leser inn lokale RPM-database"
+msgstr "Leser inn lokal RPM-database"
 
-#: ../yum/__init__.py:367
+#: ../yum/__init__.py:394
 msgid "doRepoSetup() will go away in a future version of Yum.\n"
 msgstr "doRepoSetup() vil forsvinne i en kommende utgave av Yum\n"
 
-#: ../yum/__init__.py:387
+#: ../yum/__init__.py:414
 msgid "doSackSetup() will go away in a future version of Yum.\n"
 msgstr "doSackSetup() vil forsvinne i en kommende utgave av Yum\n"
 
-#: ../yum/__init__.py:404
+#: ../yum/__init__.py:431
 msgid "Setting up Package Sacks"
 msgstr "Lager sekker med pakker"
 
-#: ../yum/__init__.py:447
+#: ../yum/__init__.py:474
 #, python-format
 msgid "repo object for repo %s lacks a _resetSack method\n"
-msgstr "objekt for pakkesoversikt %s mangler metoden _resetSack\n"
+msgstr "objekt for pakkelager %s mangler metoden _resetSack\n"
 
-#: ../yum/__init__.py:448
+#: ../yum/__init__.py:475
 msgid "therefore this repo cannot be reset.\n"
-msgstr "derfor kan ikke denne pakkeoversikten bli nullstilt\n"
+msgstr "derfor kan ikke denne pakkeoversikten nullstilles\n"
 
-#: ../yum/__init__.py:453
+#: ../yum/__init__.py:480
 msgid "doUpdateSetup() will go away in a future version of Yum.\n"
 msgstr "doUpdateSetup() vil forsvinne i en kommende utgave av Yum.\n"
 
-#: ../yum/__init__.py:465
+#: ../yum/__init__.py:492
 msgid "Building updates object"
-msgstr "Bygger opp oppdateringobject"
+msgstr "Bygger opp oppdateringsobjekt"
 
-#: ../yum/__init__.py:496
+#: ../yum/__init__.py:523
 msgid "doGroupSetup() will go away in a future version of Yum.\n"
 msgstr "doGroupSetup() vil forsvinne i en kommende utgave av Yum.\n"
 
-#: ../yum/__init__.py:520
+#: ../yum/__init__.py:547
 msgid "Getting group metadata"
-msgstr "Henter metadata om grupper"
+msgstr "Henter metadata for grupper"
 
-#: ../yum/__init__.py:546
+#: ../yum/__init__.py:572
 #, python-format
 msgid "Adding group file from repository: %s"
 msgstr "Legger til gruppefil fra pakkeoversikt: %s"
 
-#: ../yum/__init__.py:555
+#: ../yum/__init__.py:577
 #, python-format
 msgid "Failed to add groups file for repository: %s - %s"
-msgstr "Kunne ike legge til gruppefil for pakkeoversikt: %s - %s"
+msgstr "Kunne ikke legge til gruppefil for pakkeoversikt: %s - %s"
 
-#: ../yum/__init__.py:561
+#: ../yum/__init__.py:583
 msgid "No Groups Available in any repository"
-msgstr "Ingen grupper overhode tilgjengelig"
+msgstr "Ingen grupper tilgjengelig fra noen lagre"
 
-#: ../yum/__init__.py:611
+#: ../yum/__init__.py:633
 msgid "Importing additional filelist information"
-msgstr "Henter ytterligere informasjon om fil-lister"
+msgstr "Henter mer informasjon om fil-lister"
 
-#: ../yum/__init__.py:657
+#: ../yum/__init__.py:684
 #, python-format
 msgid "Skip-broken round %i"
-msgstr "Runde %i på grunn av ødelagte avhengigheter."
+msgstr "Runde %i for å hoppe over feil avhengighet"
 
-#: ../yum/__init__.py:680
+#: ../yum/__init__.py:707
 #, python-format
 msgid "Skip-broken took %i rounds "
-msgstr "På grunn ødelagte avhengigheter ble det gjennomført %i runder "
+msgstr "På grunn feil i avhengigheter ble det gjennomført %i runder "
 
-#: ../yum/__init__.py:681
+#: ../yum/__init__.py:708
 msgid ""
 "\n"
 "Packages skipped because of dependency problems:"
@@ -1445,157 +1423,161 @@ msgstr ""
 "\n"
 "Pakker som ble oversett på grunn av problemer med avhengigheter:"
 
-#: ../yum/__init__.py:685
+#: ../yum/__init__.py:712
 #, python-format
 msgid "    %s from %s"
 msgstr "    %s fra %s"
 
-#: ../yum/__init__.py:774
+#: ../yum/__init__.py:792
+msgid ""
+"Warning: scriptlet or other non-fatal errors occurred during transaction."
+msgstr ""
+
+#: ../yum/__init__.py:807
 #, python-format
 msgid "Failed to remove transaction file %s"
 msgstr "Kunne ikke fjerne transaksjonsfil %s"
 
-#: ../yum/__init__.py:814
+#: ../yum/__init__.py:847
 #, python-format
 msgid "excluding for cost: %s from %s"
 msgstr "ekskluderer på grunn av kostnad: %s fra %s"
 
-#: ../yum/__init__.py:845
+#: ../yum/__init__.py:878
 msgid "Excluding Packages in global exclude list"
-msgstr "Ekskluderer pakker som er i global liste av ekskluderte pakker"
+msgstr "Ekskluderer pakker som er i global liste med ekskluderte pakker"
 
-#: ../yum/__init__.py:847
+#: ../yum/__init__.py:880
 #, python-format
 msgid "Excluding Packages from %s"
 msgstr "Ekskluderer pakker fra %s"
 
-#: ../yum/__init__.py:875
+#: ../yum/__init__.py:906
 #, python-format
 msgid "Reducing %s to included packages only"
 msgstr "Reduserer %s til kun inkluderte pakker"
 
-#: ../yum/__init__.py:880
+#: ../yum/__init__.py:911
 #, python-format
 msgid "Keeping included package %s"
 msgstr "Tar vare på inkludert pakke %s"
 
-#: ../yum/__init__.py:886
+#: ../yum/__init__.py:917
 #, python-format
 msgid "Removing unmatched package %s"
 msgstr "Fjerner upassende pakke: %s"
 
-#: ../yum/__init__.py:889
+#: ../yum/__init__.py:920
 msgid "Finished"
 msgstr "Ferdig"
 
 #. Whoa. What the heck happened?
-#: ../yum/__init__.py:919
+#: ../yum/__init__.py:950
 #, python-format
 msgid "Unable to check if PID %s is active"
 msgstr "Kunne ikke sjekke om PID %s er aktiv"
 
 #. Another copy seems to be running.
-#: ../yum/__init__.py:923
+#: ../yum/__init__.py:954
 #, python-format
 msgid "Existing lock %s: another copy is running as pid %s."
-msgstr ""
-"Det fins allerede en låsefil: %s, en annen Yum kjører med PID %s allerede."
+msgstr "Det fins allerede en låsfil %s: en annen Yum kjører med PID %s."
 
-#: ../yum/__init__.py:970 ../yum/__init__.py:977
+#: ../yum/__init__.py:1017
 msgid "Package does not match intended download"
 msgstr "Det er forskjell mellom nedlastet og forventet størrelse"
 
-#: ../yum/__init__.py:991
+#: ../yum/__init__.py:1032
 msgid "Could not perform checksum"
-msgstr "Kunne ikke beregne tverrsum"
+msgstr "Kunne ikke beregne sjekksum"
 
-#: ../yum/__init__.py:994
+#: ../yum/__init__.py:1035
 msgid "Package does not match checksum"
-msgstr "Pakka har ikke korrekt tverrsum"
+msgstr "Pakken har ikke korrekt sjekksum"
 
-#: ../yum/__init__.py:1036
+#: ../yum/__init__.py:1079
 #, python-format
 msgid "package fails checksum but caching is enabled for %s"
-msgstr "tverrsummen til pakka er feil, men mellomlagring er satt på for %s"
+msgstr "sjekksummen til pakken er feil, men mellomlagring er satt på for %s"
 
-#: ../yum/__init__.py:1042
+#: ../yum/__init__.py:1082
 #, python-format
 msgid "using local copy of %s"
-msgstr "bruker lokal kop av %s"
+msgstr "bruker lokal kopi av %s"
 
-#: ../yum/__init__.py:1061
+#: ../yum/__init__.py:1107
 #, python-format
 msgid "Insufficient space in download directory %s to download"
 msgstr "Det er ikke nok ledig plass i katalogen %s hvor pakkene blir lagret"
 
-#: ../yum/__init__.py:1094
+#: ../yum/__init__.py:1140
 msgid "Header is not complete."
-msgstr "Filhode er ikke komplett."
+msgstr "Filhode er ikke fullstendig."
 
-#: ../yum/__init__.py:1134
+#: ../yum/__init__.py:1180
 #, python-format
 msgid ""
 "Header not in local cache and caching-only mode enabled. Cannot download %s"
 msgstr ""
-"Filhode er ikke tilgjengelig lokalt og i vi er mellomlager-modes. Kan ikke "
-"hente ned %s"
+"Filhode er ikke tilgjengelig lokalt og mellomlager-modus er aktivert Kan "
+"ikke hente ned %s"
 
-#: ../yum/__init__.py:1189
+#: ../yum/__init__.py:1235
 #, python-format
 msgid "Public key for %s is not installed"
 msgstr "Offentlig nøkkel for %s er ikke lagt inn"
 
-#: ../yum/__init__.py:1193
+#: ../yum/__init__.py:1239
 #, python-format
 msgid "Problem opening package %s"
-msgstr "Kunne ved åpning av pakke %s"
+msgstr "Problem ved åpning av pakke %s"
 
-#: ../yum/__init__.py:1201
+#: ../yum/__init__.py:1247
 #, python-format
 msgid "Public key for %s is not trusted"
 msgstr "Offentlig nøkkel %s er ikke til å stole på"
 
-#: ../yum/__init__.py:1205
+#: ../yum/__init__.py:1251
 #, python-format
 msgid "Package %s is not signed"
-msgstr "Pakka %s er ikke signert"
+msgstr "Pakken %s er ikke signert"
 
-#: ../yum/__init__.py:1243
+#: ../yum/__init__.py:1289
 #, python-format
 msgid "Cannot remove %s"
-msgstr "Kunne ikke fjern %s"
+msgstr "Kan ikke fjerne %s"
 
-#: ../yum/__init__.py:1247
+#: ../yum/__init__.py:1292
 #, python-format
 msgid "%s removed"
 msgstr "%s fjernet"
 
-#: ../yum/__init__.py:1283
+#: ../yum/__init__.py:1328
 #, python-format
 msgid "Cannot remove %s file %s"
-msgstr "Kan ikke fjerne %s fra fila %s"
+msgstr "Kan ikke fjerne %s fra fil %s"
 
-#: ../yum/__init__.py:1287
+#: ../yum/__init__.py:1331
 #, python-format
 msgid "%s file %s removed"
-msgstr "%s fila %s er fjernet"
+msgstr "%s fil %s er fjernet"
 
-#: ../yum/__init__.py:1289
+#: ../yum/__init__.py:1333
 #, python-format
 msgid "%d %s files removed"
-msgstr "%d %s filer er fjernet"
+msgstr "%d %s filer fjernet"
 
-#: ../yum/__init__.py:1329
+#: ../yum/__init__.py:1386
 #, python-format
 msgid "More than one identical match in sack for %s"
-msgstr "Mer enn en identisk passende treff i sekken %s"
+msgstr "Mer enn ett identisk passende treff i sekken %s"
 
-#: ../yum/__init__.py:1335
+#: ../yum/__init__.py:1391
 #, python-format
 msgid "Nothing matches %s.%s %s:%s-%s from update"
 msgstr "Ingenting passer %s.%s %s:%s-%s fra oppdatering"
 
-#: ../yum/__init__.py:1543
+#: ../yum/__init__.py:1585
 msgid ""
 "searchPackages() will go away in a future version of "
 "Yum.                      Use searchGenerator() instead. \n"
@@ -1603,140 +1585,165 @@ msgstr ""
 "searchPackages() vil forsvinne i en kommende utgave av Yum.\n"
 "Bruk heller searchGenerator()\n"
 
-#: ../yum/__init__.py:1580
+#: ../yum/__init__.py:1621
 #, python-format
 msgid "Searching %d packages"
 msgstr "Søker etter %d pakker"
 
-#: ../yum/__init__.py:1584
+#: ../yum/__init__.py:1624
 #, python-format
 msgid "searching package %s"
 msgstr "søker etter pakke %s"
 
-#: ../yum/__init__.py:1596
+#: ../yum/__init__.py:1635
 msgid "searching in file entries"
 msgstr "søker i filoversikt"
 
-#: ../yum/__init__.py:1603
+#: ../yum/__init__.py:1641
 msgid "searching in provides entries"
-msgstr "søker i oppføringer av tilbydere"
+msgstr "søker i oppføringer av tilbud"
 
-#: ../yum/__init__.py:1633
+#: ../yum/__init__.py:1671
 #, python-format
 msgid "Provides-match: %s"
 msgstr "Tilbyder-treff: %s"
 
-#: ../yum/__init__.py:1702 ../yum/__init__.py:1720 ../yum/__init__.py:1748
-#: ../yum/__init__.py:1753 ../yum/__init__.py:1808 ../yum/__init__.py:1812
+#: ../yum/__init__.py:1717
+msgid "No group data available for configured repositories"
+msgstr "Ingen gruppedata tilgjengelig for konfigurerte pakkelager"
+
+#: ../yum/__init__.py:1743 ../yum/__init__.py:1762 ../yum/__init__.py:1788
+#: ../yum/__init__.py:1794 ../yum/__init__.py:1850 ../yum/__init__.py:1854
 #, python-format
 msgid "No Group named %s exists"
-msgstr "Ikke gruppe med navn %s er tilgjengelig"
+msgstr "Det eksisterer ingen gruppe med navn %s "
 
-#: ../yum/__init__.py:1731 ../yum/__init__.py:1824
+#: ../yum/__init__.py:1773 ../yum/__init__.py:1866
 #, python-format
 msgid "package %s was not marked in group %s"
-msgstr "pakka %s var ikke med i gruppa %s"
+msgstr "pakke %s var ikke med i gruppe %s"
 
-#: ../yum/__init__.py:1770
+#: ../yum/__init__.py:1811
 #, python-format
 msgid "Adding package %s from group %s"
 msgstr "Legger til pakke %s fra gruppe %s"
 
-#: ../yum/__init__.py:1774
+#: ../yum/__init__.py:1816
 #, python-format
 msgid "No package named %s available to be installed"
 msgstr "Ingen pakke med navn %s er tilgjendelig for installering"
 
-#: ../yum/__init__.py:1849
+#: ../yum/__init__.py:1891
 #, python-format
 msgid "Package tuple %s could not be found in packagesack"
 msgstr "Pakke tuppel %s ble ikke funnet i sekken med pakker"
 
-#: ../yum/__init__.py:1917 ../yum/__init__.py:1960
+#: ../yum/__init__.py:1959 ../yum/__init__.py:1999
 msgid "Invalid versioned dependency string, try quoting it."
 msgstr ""
-"Den versjonerte strengen med avhengigheter er ugyldig, prøv og sette den i "
+"Den versjonerte strengen med avhengigheter er ugyldig, prøv å sette den i "
 "anførelsestegn."
 
-#: ../yum/__init__.py:1919 ../yum/__init__.py:1962
+#: ../yum/__init__.py:1961 ../yum/__init__.py:2001
 msgid "Invalid version flag"
 msgstr "Ugyldig versjonsflagg"
 
-#: ../yum/__init__.py:1934 ../yum/__init__.py:1938
+#: ../yum/__init__.py:1973 ../yum/__init__.py:1977
 #, python-format
 msgid "No Package found for %s"
 msgstr "Ingen pakke for %s er funnet"
 
-#: ../yum/__init__.py:2066
+#: ../yum/__init__.py:2105
 msgid "Package Object was not a package object instance"
-msgstr "Pakkeobjekt var ikke en pakkeobjekt instans"
+msgstr "Pakkeobjekt var ikke en pakkeobjektinstans"
 
-#: ../yum/__init__.py:2070
+#: ../yum/__init__.py:2109
 msgid "Nothing specified to install"
-msgstr "Det ble ikke bedt om og installere noe som helst"
+msgstr "Ingenting oppgitt for installasjon"
 
 #. only one in there
-#: ../yum/__init__.py:2085
+#: ../yum/__init__.py:2124
 #, python-format
 msgid "Checking for virtual provide or file-provide for %s"
 msgstr "Sjekker for virtuelle tilbydere eller tilbydere av filer for %s"
 
-#: ../yum/__init__.py:2091 ../yum/__init__.py:2380
+#: ../yum/__init__.py:2130 ../yum/__init__.py:2446
 #, python-format
 msgid "No Match for argument: %s"
-msgstr "Intet treff for argument: %s"
+msgstr "Ingen treff for argument: %s"
 
 #. FIXME - this is where we could check to see if it already installed
 #. for returning better errors
-#: ../yum/__init__.py:2146
+#: ../yum/__init__.py:2185
 msgid "No package(s) available to install"
 msgstr "Ingen pakke(r) er tilgjengelig for installering"
 
-#: ../yum/__init__.py:2158
+#: ../yum/__init__.py:2198
 #, python-format
 msgid "Package: %s  - already in transaction set"
 msgstr "Pakke: %s - allerede i transaksjonensettet"
 
-#: ../yum/__init__.py:2171
+#: ../yum/__init__.py:2212
 #, python-format
 msgid "Package %s already installed and latest version"
-msgstr "Pakke %s er allerede installert i siste og beste versjon"
+msgstr "Pakke %s er allerede installert i siste versjon"
 
-#: ../yum/__init__.py:2178
-#, fuzzy, python-format
+#: ../yum/__init__.py:2219
+#, python-format
 msgid "Package matching %s already installed. Checking for update."
-msgstr "Pakke %s er allerede lagt inn, hopper over"
+msgstr "Pakke med treff på %s er allerede lagt inn. Ser etter oppdatering"
+
+#: ../yum/__init__.py:2230
+#, fuzzy, python-format
+msgid "Package %s is obsoleted by %s, trying to install %s instead"
+msgstr ""
+"Pakka %s er ikke installert, så den kan ikke oppdateres. Bruk kommandoen yum "
+"install for å legge den inn."
 
 #. update everything (the easy case)
-#: ../yum/__init__.py:2220
+#: ../yum/__init__.py:2263
 msgid "Updating Everything"
 msgstr "Oppdaterer alt"
 
-#: ../yum/__init__.py:2304
+#: ../yum/__init__.py:2366
 #, python-format
 msgid "Package is already obsoleted: %s.%s %s:%s-%s"
 msgstr "Pakka er allerede foreldet:  %s.%s %s:%s-%s"
 
-#: ../yum/__init__.py:2377
+#: ../yum/__init__.py:2390
+#, fuzzy, python-format
+msgid "Not Updating Package that is already updated: %s.%s %s:%s-%s"
+msgstr "Vil ikke oppdatere pakke som allerede er foreldet: %s.%s %s:%s-%s"
+
+#: ../yum/__init__.py:2443
 #, python-format
 msgid "%s"
 msgstr "%s"
 
-#: ../yum/__init__.py:2392
+#. FIXME we should give the caller some nice way to hush this warning
+#. probably just a kwarg of 'silence_warnings' or something
+#. b/c when this is called from groupRemove() it makes a lot of
+#. garbage noise
+#: ../yum/__init__.py:2462
 msgid "No package matched to remove"
 msgstr "Kunne ikke finne noen passende pakke for fjerning"
 
-#: ../yum/__init__.py:2426
+#: ../yum/__init__.py:2496
 #, python-format
 msgid "Cannot open file: %s. Skipping."
 msgstr "Kunne ikke åpne fil: %s. Hopper over."
 
-#: ../yum/__init__.py:2429
+#: ../yum/__init__.py:2498
 #, python-format
 msgid "Examining %s: %s"
-msgstr "Gransker: %s: %s"
+msgstr "Undersøker: %s: %s"
+
+#: ../yum/__init__.py:2504
+#, python-format
+msgid "Cannot add package %s to transaction. Not a compatible architecture: %s"
+msgstr ""
 
-#: ../yum/__init__.py:2436
+#: ../yum/__init__.py:2512
 #, python-format
 msgid ""
 "Package %s not installed, cannot update it. Run yum install to install it "
@@ -1745,77 +1752,77 @@ msgstr ""
 "Pakka %s er ikke installert, så den kan ikke oppdateres. Bruk kommandoen yum "
 "install for å legge den inn."
 
-#: ../yum/__init__.py:2468
+#: ../yum/__init__.py:2545
 #, python-format
 msgid "Excluding %s"
 msgstr "Ekskluderer %s"
 
-#: ../yum/__init__.py:2473
+#: ../yum/__init__.py:2549
 #, python-format
 msgid "Marking %s to be installed"
 msgstr "Setter av %s for kommende installering"
 
-#: ../yum/__init__.py:2479
+#: ../yum/__init__.py:2554
 #, python-format
 msgid "Marking %s as an update to %s"
 msgstr "Setter av %s som en oppdatering av %s"
 
-#: ../yum/__init__.py:2486
+#: ../yum/__init__.py:2559
 #, python-format
 msgid "%s: does not update installed package."
 msgstr "%s: vil ikke oppdatere installert pakke."
 
-#: ../yum/__init__.py:2504
+#: ../yum/__init__.py:2576
 msgid "Problem in reinstall: no package matched to remove"
 msgstr "Problem ved reinstall: kunne ikke finne passende pakke og fjerne"
 
-#: ../yum/__init__.py:2515
+#: ../yum/__init__.py:2587
 #, fuzzy, python-format
 msgid "Package %s is allowed multiple installs, skipping"
 msgstr "Pakke %s er allerede lagt inn, hopper over"
 
-#: ../yum/__init__.py:2522
+#: ../yum/__init__.py:2594
 msgid "Problem in reinstall: no package matched to install"
 msgstr "Problem ved reinstall: kunne ikke finne passende pakke og installere "
 
-#: ../yum/__init__.py:2570
+#: ../yum/__init__.py:2641
 #, python-format
 msgid "Retrieving GPG key from %s"
 msgstr "Henter GPG-nøkkel fra %s"
 
-#: ../yum/__init__.py:2576
+#: ../yum/__init__.py:2647
 msgid "GPG key retrieval failed: "
 msgstr "Henting av GPG-nøkkel feilet: "
 
-#: ../yum/__init__.py:2589
+#: ../yum/__init__.py:2663
 msgid "GPG key parsing failed: "
 msgstr "Analyse av GPG-nøkkel feilet: "
 
-#: ../yum/__init__.py:2593
+#: ../yum/__init__.py:2667
 #, python-format
 msgid "GPG key at %s (0x%s) is already installed"
 msgstr "GPG-nøkkel ved %s (0x%s) er allerede lagt inn"
 
 #. Try installing/updating GPG key
-#: ../yum/__init__.py:2598
+#: ../yum/__init__.py:2672
 #, python-format
 msgid "Importing GPG key 0x%s \"%s\" from %s"
 msgstr "Legger inn GPG-nøkkel 0x%s \"%s\" fra %s"
 
-#: ../yum/__init__.py:2610
+#: ../yum/__init__.py:2685
 msgid "Not installing key"
 msgstr "Legger ikke inn nøkkel"
 
-#: ../yum/__init__.py:2616
+#: ../yum/__init__.py:2691
 #, python-format
 msgid "Key import failed (code %d)"
 msgstr "Import av nøkkel feilet (kode %d)"
 
-#: ../yum/__init__.py:2619
+#: ../yum/__init__.py:2694
 msgid "Key imported successfully"
 msgstr "Nøkler ble lagt inn med suksess"
 
-#: ../yum/__init__.py:2624
+#: ../yum/__init__.py:2699
 #, python-format
 msgid ""
 "The GPG keys listed for the \"%s\" repository are already installed but they "
@@ -1827,74 +1834,79 @@ msgstr ""
 "Sjekk at korrekt URL (gpgkey opsjonen) er oppgitt for denne\n"
 "pakkeoversikten."
 
-#: ../yum/__init__.py:2633
+#: ../yum/__init__.py:2708
 msgid "Import of key(s) didn't help, wrong key(s)?"
 msgstr "Import av nøkler hjalp ikke, feil nøkler?"
 
-#: ../yum/__init__.py:2707
+#: ../yum/__init__.py:2789
 msgid "Unable to find a suitable mirror."
 msgstr "Kunne ikke finne passende filspeil"
 
-#: ../yum/__init__.py:2709
+#: ../yum/__init__.py:2791
 msgid "Errors were encountered while downloading packages."
 msgstr "Det oppstod feil ved nedlastning av pakker."
 
-#: ../yum/__init__.py:2774
+#: ../yum/__init__.py:2854
 msgid "Test Transaction Errors: "
 msgstr "Feil ved testtransaksjon: "
 
 #. Mostly copied from YumOutput._outKeyValFill()
-#: ../yum/plugins.py:195
+#: ../yum/plugins.py:197
 msgid "Loaded plugins: "
 msgstr "Tillegg som er i bruk:"
 
-#: ../yum/plugins.py:206
+#: ../yum/plugins.py:208
 #, fuzzy, python-format
 msgid "No plugin match for: %s"
 msgstr "Intet treff for argument: %s"
 
-#: ../yum/plugins.py:219
+#: ../yum/plugins.py:221
 #, python-format
 msgid "\"%s\" plugin is disabled"
 msgstr "Tillegg: %s er ikke aktiv."
 
-#: ../yum/plugins.py:231
+#: ../yum/plugins.py:233
 #, python-format
 msgid "Plugin \"%s\" doesn't specify required API version"
 msgstr "Tillegg \"%s\" tilfredstiller ikke versjonskravene fra Yum."
 
-#: ../yum/plugins.py:235
+#: ../yum/plugins.py:237
 #, python-format
 msgid "Plugin \"%s\" requires API %s. Supported API is %s."
 msgstr "Tillegg \"%s\" krever API versjon: %s. Men støttet API versjon er %s."
 
-#: ../yum/plugins.py:264
+#: ../yum/plugins.py:266
 #, python-format
 msgid "Loading \"%s\" plugin"
 msgstr "Laster tillegg \"%s\""
 
-#: ../yum/plugins.py:271
+#: ../yum/plugins.py:273
 #, python-format
 msgid ""
 "Two or more plugins with the name \"%s\" exist in the plugin search path"
-msgstr "To eller flere tillegg har samme navn."
+msgstr "Det finnes to eller flere tillegg med navn «%s» i søkestien for tillegg"
 
-#: ../yum/plugins.py:291
+#: ../yum/plugins.py:293
 #, python-format
 msgid "Configuration file %s not found"
 msgstr "Konfigurasjonsfila %s ble ikke funnet"
 
 #. for
 #. Configuration files for the plugin not found
-#: ../yum/plugins.py:294
+#: ../yum/plugins.py:296
 #, python-format
 msgid "Unable to find configuration file for plugin %s"
 msgstr "Kunne ikke finne konfigurasjon for tillegg %s"
 
-#: ../yum/plugins.py:448
+#: ../yum/plugins.py:450
 msgid "registration of commands not supported"
 msgstr "registering av kommandoer er ikke støttet"
 
+#: ../yum/rpmtrans.py:78
+#, fuzzy
+msgid "Repackaging"
+msgstr "Pakker på nytt"
+
 #: ../rpmUtils/oldUtils.py:26
 #, python-format
 msgid "Header cannot be opened or does not match %s, %s."
@@ -1924,6 +1936,33 @@ msgstr "Filhode til %s er ødelagt"
 msgid "Error opening rpm %s - error %s"
 msgstr "Kunne ikke åpen rpm pakke %s - feilen er %s"
 
+#~ msgid "Searching pkgSack for dep: %s"
+#~ msgstr "Søker i pkgSack etter avhengighet: %s"
+
+#~ msgid "Potential match for %s from %s"
+#~ msgstr "Potensielt treff for %s i %s"
+
+#~ msgid "Matched %s to require for %s"
+#~ msgstr "Passende %s for å tilfredstille %s"
+
+#~ msgid "Needed Require has already been looked up, cheating"
+#~ msgstr "Nødvendig avhengighet har allerede blitt plukket opp, jukser"
+
+#~ msgid "Needed Require is not a package name. Looking up: %s"
+#~ msgstr "Nødvendig avhengighet er ikke et navn på pakke. Ser etter: %s"
+
+#~ msgid "Potential Provider: %s"
+#~ msgstr "Potensiell tilbyder: %s"
+
+#~ msgid "Mode is %s for provider of %s: %s"
+#~ msgstr "Modus er %s for tilbyder av %s: %s"
+
+#~ msgid "Mode for pkg providing %s: %s"
+#~ msgstr "Modus for pakke som tilbyr %s: %s"
+
+#~ msgid "Unresolvable requirement %s for %s"
+#~ msgstr "Avhengighet %s kan ikke løses opp: %s"
+
 #~ msgid "Looking for Obsoletes for %s"
 #~ msgstr "Leter opp informasjon utgåtte pakker for %s"
 
diff --git a/po/pl.po b/po/pl.po
index 51e5f29..e1e4000 100644
--- a/po/pl.po
+++ b/po/pl.po
@@ -5,15 +5,15 @@ msgid ""
 msgstr ""
 "Project-Id-Version: pl\n"
 "Report-Msgid-Bugs-To: \n"
-"POT-Creation-Date: 2008-10-26 15:54+0100\n"
-"PO-Revision-Date: 2008-10-22 00:15+0200\n"
+"POT-Creation-Date: 2008-11-22 03:51+0100\n"
+"PO-Revision-Date: 2008-11-22 03:55+0100\n"
 "Last-Translator: Piotr Drąg <piotrdrag@gmail.com>\n"
 "Language-Team: Polish <pl@li.org>\n"
 "MIME-Version: 1.0\n"
 "Content-Type: text/plain; charset=UTF-8\n"
 "Content-Transfer-Encoding: 8bit\n"
 
-#: ../callback.py:48 ../output.py:777 ../yum/rpmtrans.py:71
+#: ../callback.py:48 ../output.py:914 ../yum/rpmtrans.py:71
 msgid "Updating"
 msgstr "Aktualizowanie"
 
@@ -21,8 +21,7 @@ msgstr "Aktualizowanie"
 msgid "Erasing"
 msgstr "Usuwanie"
 
-#. Arch can't get "that big" ... so always use the max.
-#: ../callback.py:50 ../callback.py:51 ../callback.py:53 ../output.py:776
+#: ../callback.py:50 ../callback.py:51 ../callback.py:53 ../output.py:913
 #: ../yum/rpmtrans.py:73 ../yum/rpmtrans.py:74 ../yum/rpmtrans.py:76
 msgid "Installing"
 msgstr "Instalowanie"
@@ -31,7 +30,7 @@ msgstr "Instalowanie"
 msgid "Obsoleted"
 msgstr "Przestarzałe"
 
-#: ../callback.py:54 ../output.py:890
+#: ../callback.py:54 ../output.py:1019
 msgid "Updated"
 msgstr "Zaktualizowano"
 
@@ -39,7 +38,7 @@ msgstr "Zaktualizowano"
 msgid "Erased"
 msgstr "Usunięto"
 
-#: ../callback.py:56 ../callback.py:57 ../callback.py:59 ../output.py:888
+#: ../callback.py:56 ../callback.py:57 ../callback.py:59 ../output.py:1017
 msgid "Installed"
 msgstr "Zainstalowano"
 
@@ -61,7 +60,7 @@ msgstr "Błąd: nieprawidłowy stan wyjścia: %s dla %s"
 msgid "Erased: %s"
 msgstr "Usunięto: %s"
 
-#: ../callback.py:217 ../output.py:778
+#: ../callback.py:217 ../output.py:915
 msgid "Removing"
 msgstr "Usuwanie"
 
@@ -82,47 +81,47 @@ msgstr "Ustawianie repozytoriów"
 msgid "Reading repository metadata in from local files"
 msgstr "Odczytywanie metadanych repozytoriów z lokalnych plików"
 
-#: ../cli.py:187 ../utils.py:71
+#: ../cli.py:188 ../utils.py:79
 #, python-format
 msgid "Config Error: %s"
 msgstr "Błąd konfiguracji: %s"
 
-#: ../cli.py:190 ../cli.py:1128 ../utils.py:74
+#: ../cli.py:191 ../cli.py:1172 ../utils.py:82
 #, python-format
 msgid "Options Error: %s"
 msgstr "Błąd opcji: %s"
 
-#: ../cli.py:218
+#: ../cli.py:219
 #, python-format
 msgid "  Installed: %s-%s at %s"
 msgstr "  Zainstalowane: %s-%s at %s"
 
-#: ../cli.py:220
+#: ../cli.py:221
 #, python-format
 msgid "  Built    : %s at %s"
 msgstr "  Zbudowane    : %s o %s"
 
-#: ../cli.py:222
+#: ../cli.py:223
 #, python-format
 msgid "  Committed: %s at %s"
 msgstr "  Wysłane: %s o %s"
 
-#: ../cli.py:259
+#: ../cli.py:260
 msgid "You need to give some command"
 msgstr "Musisz podać jakieś polecenie"
 
-#: ../cli.py:301
+#: ../cli.py:302
 msgid "Disk Requirements:\n"
 msgstr "Wymagana przestrzeń na dysku:\n"
 
-#: ../cli.py:303
+#: ../cli.py:304
 #, python-format
 msgid "  At least %dMB needed on the %s filesystem.\n"
 msgstr "  Potrzeba co najmniej %d MB w systemie plików %s.\n"
 
 #. TODO: simplify the dependency errors?
 #. Fixup the summary
-#: ../cli.py:308
+#: ../cli.py:309
 msgid ""
 "Error Summary\n"
 "-------------\n"
@@ -130,55 +129,64 @@ msgstr ""
 "Podsumowanie błędów\n"
 "-------------------\n"
 
-#: ../cli.py:351
+#: ../cli.py:352
 msgid "Trying to run the transaction but nothing to do. Exiting."
 msgstr "Próbowano wykonać transakcję, ale nie ma nic do zrobienia. Zamykanie."
 
-#: ../cli.py:381
+#: ../cli.py:382
 msgid "Exiting on user Command"
 msgstr "Zamykanie na polecenie użytkownika"
 
-#: ../cli.py:385
+#: ../cli.py:386
 msgid "Downloading Packages:"
 msgstr "Pobieranie pakietów:"
 
-#: ../cli.py:390
+#: ../cli.py:391
 msgid "Error Downloading Packages:\n"
 msgstr "Błąd podczas pobierania pakietów:\n"
 
-#: ../cli.py:404 ../yum/__init__.py:3154
+#: ../cli.py:403
+msgid "Entering rpm code"
+msgstr "Przechodzenie do kodu RPM"
+
+#: ../cli.py:407 ../yum/__init__.py:3312
 msgid "Running rpm_check_debug"
 msgstr "Wykonywanie rpm_check_debug"
 
-#: ../cli.py:407 ../yum/__init__.py:3157
+#: ../cli.py:410 ../yum/__init__.py:3315
 msgid "ERROR with rpm_check_debug vs depsolve:"
 msgstr "BŁĄD rpm_check_debug i rozwiązywania zależności:"
 
-#: ../cli.py:411 ../yum/__init__.py:3159
-msgid "Please report this error in bugzilla"
-msgstr "Zgłoś ten błąd w Bugzilli"
+#: ../cli.py:414
+#, python-format
+msgid "Please report this error in %s"
+msgstr "Zgłoś ten błąd na %s"
 
-#: ../cli.py:417
+#: ../cli.py:420
 msgid "Running Transaction Test"
 msgstr "Wykonywanie testu transakcji"
 
-#: ../cli.py:433
+#: ../cli.py:436
 msgid "Finished Transaction Test"
 msgstr "Zakończono test transakcji"
 
-#: ../cli.py:435
+#: ../cli.py:438
 msgid "Transaction Check Error:\n"
 msgstr "Błąd podczas sprawdzania transakcji:\n"
 
-#: ../cli.py:442
+#: ../cli.py:445
 msgid "Transaction Test Succeeded"
 msgstr "Test transakcji został zakończony powodzeniem"
 
-#: ../cli.py:463
+#: ../cli.py:466
 msgid "Running Transaction"
 msgstr "Wykonywanie transakcji"
 
-#: ../cli.py:493
+#: ../cli.py:471
+msgid "Leaving rpm code"
+msgstr "Opuszczanie kodu RPM"
+
+#: ../cli.py:498
 msgid ""
 "Refusing to automatically import keys when running unattended.\n"
 "Use \"-y\" to override."
@@ -187,68 +195,68 @@ msgstr ""
 "uruchomienia.\n"
 "Użyj \"-y\", aby wymusić."
 
-#: ../cli.py:512 ../cli.py:545
+#: ../cli.py:517 ../cli.py:550
 msgid "  * Maybe you meant: "
 msgstr "  * Czy chodziło o: "
 
-#: ../cli.py:528 ../cli.py:536
+#: ../cli.py:533 ../cli.py:541
 #, python-format
 msgid "Package(s) %s%s%s available, but not installed."
 msgstr "Pakiety %s%s%s są dostępne, ale nie są zainstalowane."
 
-#: ../cli.py:542 ../cli.py:577
+#: ../cli.py:547 ../cli.py:582
 #, python-format
 msgid "No package %s%s%s available."
 msgstr "Nie ma pakietu %s%s%s."
 
-#: ../cli.py:567
+#: ../cli.py:572
 msgid "Parsing package install arguments"
 msgstr "Analizowanie parametrów instalacji pakietów"
 
-#: ../cli.py:582 ../cli.py:657 ../yumcommands.py:912
+#: ../cli.py:587 ../cli.py:662 ../yumcommands.py:984
 msgid "Package(s) to install"
 msgstr "Pakiety do zainstalowania"
 
-#: ../cli.py:583 ../cli.py:658 ../yumcommands.py:150 ../yumcommands.py:913
+#: ../cli.py:588 ../cli.py:663 ../yumcommands.py:151 ../yumcommands.py:985
 msgid "Nothing to do"
 msgstr "Nie ma niczego do zrobienia"
 
-#: ../cli.py:616
+#: ../cli.py:621
 #, python-format
 msgid "%d packages marked for Update"
 msgstr "%d pakietów oznaczonych do aktualizacji"
 
-#: ../cli.py:619
+#: ../cli.py:624
 msgid "No Packages marked for Update"
 msgstr "Brak pakietów oznaczonych do aktualizacji"
 
-#: ../cli.py:633
+#: ../cli.py:638
 #, python-format
 msgid "%d packages marked for removal"
 msgstr "%d pakietów oznaczonych do usunięcia"
 
-#: ../cli.py:636
+#: ../cli.py:641
 msgid "No Packages marked for removal"
 msgstr "Brak pakietów oznaczonych do usunięcia"
 
-#: ../cli.py:648
+#: ../cli.py:653
 msgid "No Packages Provided"
 msgstr "Nie podano pakietów"
 
-#: ../cli.py:689
+#: ../cli.py:706
 msgid "Matching packages for package list to user args"
 msgstr "Dopasowywanie listy pakietów do parametrów użytkownika"
 
-#: ../cli.py:731
+#: ../cli.py:755
 #, python-format
 msgid "Warning: No matches found for: %s"
 msgstr "Ostrzeżenie: nie znaleziono wyników dla: %s"
 
-#: ../cli.py:734
+#: ../cli.py:758
 msgid "No Matches found"
 msgstr "Brak wyników"
 
-#: ../cli.py:773
+#: ../cli.py:797
 #, python-format
 msgid ""
 "Warning: 3.0.x versions of yum would erronously match against filenames.\n"
@@ -257,104 +265,104 @@ msgstr ""
 "Ostrzeżenie: wersje yuma 3.0.x błędnie dopasowują nazwy plików.\n"
 " Można użyć \"%s*/%s%s\" i/lub \"%s*bin/%s%s\", aby uzyskać to zachowanie"
 
-#: ../cli.py:789
+#: ../cli.py:813
 #, python-format
 msgid "No Package Found for %s"
 msgstr "Nie znaleziono pakietów dla %s"
 
-#: ../cli.py:801
+#: ../cli.py:825
 msgid "Cleaning up Everything"
 msgstr "Czyszczenie wszystkiego"
 
-#: ../cli.py:815
+#: ../cli.py:839
 msgid "Cleaning up Headers"
 msgstr "Czyszczenie nagłówków"
 
-#: ../cli.py:818
+#: ../cli.py:842
 msgid "Cleaning up Packages"
 msgstr "Czyszczenie pakietów"
 
-#: ../cli.py:821
+#: ../cli.py:845
 msgid "Cleaning up xml metadata"
 msgstr "Czytanie metadanych XML"
 
-#: ../cli.py:824
+#: ../cli.py:848
 msgid "Cleaning up database cache"
 msgstr "Czyszczenie pamięci podręcznej bazy danych"
 
-#: ../cli.py:827
+#: ../cli.py:851
 msgid "Cleaning up expire-cache metadata"
 msgstr "Czytanie metadanych wygasłej pamięci podręcznej"
 
-#: ../cli.py:830
+#: ../cli.py:854
 msgid "Cleaning up plugins"
 msgstr "Czyszczenie wtyczek"
 
-#: ../cli.py:851
+#: ../cli.py:879
 msgid "Installed Groups:"
 msgstr "Zainstalowane grupy:"
 
-#: ../cli.py:858
+#: ../cli.py:886
 msgid "Available Groups:"
 msgstr "Dostępne grupy:"
 
-#: ../cli.py:864
+#: ../cli.py:892
 msgid "Done"
 msgstr "Zakończono"
 
-#: ../cli.py:875 ../cli.py:893 ../cli.py:899 ../yum/__init__.py:2246
+#: ../cli.py:903 ../cli.py:921 ../cli.py:927 ../yum/__init__.py:2387
 #, python-format
 msgid "Warning: Group %s does not exist."
 msgstr "Ostrzeżenie: grupa %s nie istnieje."
 
-#: ../cli.py:903
+#: ../cli.py:931
 msgid "No packages in any requested group available to install or update"
 msgstr ""
 "Brak pakietów dostępnych do instalacji lub aktualizacji w żadnej z żądanych "
 "grup"
 
-#: ../cli.py:905
+#: ../cli.py:933
 #, python-format
 msgid "%d Package(s) to Install"
 msgstr "%d pakietów do instalacji"
 
-#: ../cli.py:915 ../yum/__init__.py:2258
+#: ../cli.py:943 ../yum/__init__.py:2399
 #, python-format
 msgid "No group named %s exists"
 msgstr "Grupa o nazwie %s nie istnieje"
 
-#: ../cli.py:921
+#: ../cli.py:949
 msgid "No packages to remove from groups"
 msgstr "Brak pakietów do usunięcia z grup"
 
-#: ../cli.py:923
+#: ../cli.py:951
 #, python-format
 msgid "%d Package(s) to remove"
 msgstr "%d pakietów do usunięcia"
 
-#: ../cli.py:965
+#: ../cli.py:993
 #, python-format
 msgid "Package %s is already installed, skipping"
 msgstr "Pakiet %s jest już zainstalowany, pomijanie"
 
-#: ../cli.py:976
+#: ../cli.py:1004
 #, python-format
 msgid "Discarding non-comparable pkg %s.%s"
 msgstr "Odrzucanie pakietu %s.%s, którego nie można porównać"
 
 #. we've not got any installed that match n or n+a
-#: ../cli.py:1002
+#: ../cli.py:1030
 #, python-format
 msgid "No other %s installed, adding to list for potential install"
 msgstr ""
 "Inne %s nie są zainstalowane, dodawanie do listy potencjalnie instalowanych"
 
-#: ../cli.py:1021
+#: ../cli.py:1049
 #, python-format
 msgid "Command line error: %s"
 msgstr "Błąd wiersza poleceń: %s"
 
-#: ../cli.py:1034
+#: ../cli.py:1062
 #, python-format
 msgid ""
 "\n"
@@ -365,244 +373,252 @@ msgstr ""
 "\n"
 "%s: opcja %s wymaga parametru"
 
-#: ../cli.py:1170
+#: ../cli.py:1112
+msgid "--color takes one of: auto, always, never"
+msgstr "--color przyjmuje jedną z: auto, always, never"
+
+#: ../cli.py:1214
 msgid "show this help message and exit"
 msgstr "wyświetla ten komunikat pomocy i wyłącza"
 
-#: ../cli.py:1174
+#: ../cli.py:1218
 msgid "be tolerant of errors"
 msgstr "toleruje błędy"
 
-#: ../cli.py:1176
+#: ../cli.py:1220
 msgid "run entirely from cache, don't update cache"
 msgstr "uruchamia wyłącznie z pamięci podręcznej i nie aktualizuje jej"
 
-#: ../cli.py:1178
+#: ../cli.py:1222
 msgid "config file location"
 msgstr "położenie pliku konfiguracji"
 
-#: ../cli.py:1180
+#: ../cli.py:1224
 msgid "maximum command wait time"
 msgstr "maksymalny czas oczekiwania na polecenie"
 
-#: ../cli.py:1182
+#: ../cli.py:1226
 msgid "debugging output level"
 msgstr "poziom wyjścia debugowania"
 
-#: ../cli.py:1186
+#: ../cli.py:1230
 msgid "show duplicates, in repos, in list/search commands"
 msgstr "wyświetla duplikaty w repozytoriach w poleceniach list/search"
 
-#: ../cli.py:1188
+#: ../cli.py:1232
 msgid "error output level"
 msgstr "poziom wyjścia błędów"
 
-#: ../cli.py:1191
+#: ../cli.py:1235
 msgid "quiet operation"
 msgstr "mało komunikatów"
 
-#: ../cli.py:1193
+#: ../cli.py:1237
 msgid "verbose operation"
 msgstr "dużo komunikatów"
 
-#: ../cli.py:1195
+#: ../cli.py:1239
 msgid "answer yes for all questions"
 msgstr "odpowiada tak na wszystkie pytania"
 
-#: ../cli.py:1197
+#: ../cli.py:1241
 msgid "show Yum version and exit"
 msgstr "wyświetla wersję yuma i wyłącza"
 
-#: ../cli.py:1198
+#: ../cli.py:1242
 msgid "set install root"
 msgstr "ustawia roota instalacji"
 
-#: ../cli.py:1202
+#: ../cli.py:1246
 msgid "enable one or more repositories (wildcards allowed)"
 msgstr "włącza jedno lub więcej repozytoriów (wieloznaczniki są dozwolone)"
 
-#: ../cli.py:1206
+#: ../cli.py:1250
 msgid "disable one or more repositories (wildcards allowed)"
 msgstr "wyłącza jedno lub więcej repozytoriów (wieloznaczniki są dozwolone)"
 
-#: ../cli.py:1209
+#: ../cli.py:1253
 msgid "exclude package(s) by name or glob"
 msgstr "wyklucza pakiety po nazwie lub wyrażeniu regularnym"
 
-#: ../cli.py:1211
+#: ../cli.py:1255
 msgid "disable exclude from main, for a repo or for everything"
 msgstr "wyłącza wykluczanie z głównego, dla repozytorium lub wszystkiego"
 
-#: ../cli.py:1214
+#: ../cli.py:1258
 msgid "enable obsoletes processing during updates"
 msgstr "włącza przetwarzanie przestarzałych pakietów podczas aktualizacji"
 
-#: ../cli.py:1216
+#: ../cli.py:1260
 msgid "disable Yum plugins"
 msgstr "wyłącza wtyczki yuma"
 
-#: ../cli.py:1218
+#: ../cli.py:1262
 msgid "disable gpg signature checking"
 msgstr "wyłącza sprawdzanie podpisu GPG"
 
-#: ../cli.py:1220
+#: ../cli.py:1264
 msgid "disable plugins by name"
 msgstr "wyłącza wtyczki po nazwie"
 
-#: ../cli.py:1223
+#: ../cli.py:1267
 msgid "enable plugins by name"
 msgstr "włącza wtyczki po nazwie"
 
-#: ../cli.py:1226
+#: ../cli.py:1270
 msgid "skip packages with depsolving problems"
 msgstr "pomija pakiety mające problemy z rozwiązaniem zależności"
 
-#: ../output.py:236
+#: ../cli.py:1272
+msgid "control whether color is used"
+msgstr "kontroluje użycie kolorów"
+
+#: ../output.py:301
 msgid "Jan"
 msgstr "sty"
 
-#: ../output.py:236
+#: ../output.py:301
 msgid "Feb"
 msgstr "lut"
 
-#: ../output.py:236
+#: ../output.py:301
 msgid "Mar"
 msgstr "mar"
 
-#: ../output.py:236
+#: ../output.py:301
 msgid "Apr"
 msgstr "kwi"
 
-#: ../output.py:236
+#: ../output.py:301
 msgid "May"
 msgstr "maj"
 
-#: ../output.py:236
+#: ../output.py:301
 msgid "Jun"
 msgstr "cze"
 
-#: ../output.py:237
+#: ../output.py:302
 msgid "Jul"
 msgstr "lip"
 
-#: ../output.py:237
+#: ../output.py:302
 msgid "Aug"
 msgstr "sie"
 
-#: ../output.py:237
+#: ../output.py:302
 msgid "Sep"
 msgstr "wrz"
 
-#: ../output.py:237
+#: ../output.py:302
 msgid "Oct"
 msgstr "paź"
 
-#: ../output.py:237
+#: ../output.py:302
 msgid "Nov"
 msgstr "lis"
 
-#: ../output.py:237
+#: ../output.py:302
 msgid "Dec"
 msgstr "gru"
 
-#: ../output.py:247
+#: ../output.py:312
 msgid "Trying other mirror."
 msgstr "Próbowanie innego serwera lustrzanego."
 
-#: ../output.py:425
+#: ../output.py:527
 #, python-format
 msgid "Name       : %s%s%s"
 msgstr "Nazwa              : %s%s%s"
 
-#: ../output.py:426
+#: ../output.py:528
 #, python-format
 msgid "Arch       : %s"
 msgstr "Architektura       : %s"
 
-#: ../output.py:428
+#: ../output.py:530
 #, python-format
 msgid "Epoch      : %s"
 msgstr "Epoka              : %s"
 
-#: ../output.py:429
+#: ../output.py:531
 #, python-format
 msgid "Version    : %s"
 msgstr "Wersja             : %s"
 
-#: ../output.py:430
+#: ../output.py:532
 #, python-format
 msgid "Release    : %s"
 msgstr "Wydanie            : %s"
 
-#: ../output.py:431
+#: ../output.py:533
 #, python-format
 msgid "Size       : %s"
 msgstr "Rozmiar            : %s"
 
-#: ../output.py:432
+#: ../output.py:534
 #, python-format
 msgid "Repo       : %s"
 msgstr "Repozytorium       : %s"
 
-#: ../output.py:434
+#: ../output.py:536
 #, python-format
 msgid "Committer  : %s"
 msgstr "Twórca             : %s"
 
-#: ../output.py:435
+#: ../output.py:537
 #, python-format
 msgid "Committime : %s"
 msgstr "Czas wysłania      : %s"
 
-#: ../output.py:436
+#: ../output.py:538
 #, python-format
 msgid "Buildtime  : %s"
 msgstr "Czas zbudowania    : %s"
 
-#: ../output.py:438
+#: ../output.py:540
 #, python-format
 msgid "Installtime: %s"
 msgstr "Czas zainstalowania: %s"
 
-#: ../output.py:439
+#: ../output.py:541
 msgid "Summary    : "
 msgstr "Podsumowanie       : "
 
-#: ../output.py:441
+#: ../output.py:543
 #, python-format
 msgid "URL        : %s"
 msgstr "URL                : %s"
 
-#: ../output.py:442
+#: ../output.py:544
 #, python-format
 msgid "License    : %s"
 msgstr "Licencja           : %s"
 
-#: ../output.py:443
+#: ../output.py:545
 msgid "Description: "
 msgstr "Opis               : "
 
-#: ../output.py:500
+#: ../output.py:609
 msgid "y"
 msgstr "t"
 
-#: ../output.py:500
+#: ../output.py:609
 msgid "yes"
 msgstr "tak"
 
-#: ../output.py:501
+#: ../output.py:610
 msgid "n"
 msgstr "n"
 
-#: ../output.py:501
+#: ../output.py:610
 msgid "no"
 msgstr "nie"
 
-#: ../output.py:505
+#: ../output.py:614
 msgid "Is this ok [y/N]: "
 msgstr "W porządku? [t/N]: "
 
-#: ../output.py:587
+#: ../output.py:702
 #, python-format
 msgid ""
 "\n"
@@ -611,119 +627,128 @@ msgstr ""
 "\n"
 "Grupa: %s"
 
-#: ../output.py:594
+#: ../output.py:709
 #, python-format
 msgid " Description: %s"
 msgstr " Opis: %s"
 
-#: ../output.py:596
+#: ../output.py:711
 msgid " Mandatory Packages:"
 msgstr " Pakiety obowiązkowe:"
 
-#: ../output.py:597
+#: ../output.py:712
 msgid " Default Packages:"
 msgstr " Domyślne pakiety:"
 
-#: ../output.py:598
+#: ../output.py:713
 msgid " Optional Packages:"
 msgstr " Pakiety opcjonalne:"
 
-#: ../output.py:599
+#: ../output.py:714
 msgid " Conditional Packages:"
 msgstr " Pakiety warunkowe:"
 
-#: ../output.py:619
+#: ../output.py:734
 #, python-format
 msgid "package: %s"
 msgstr "pakiet: %s"
 
-#: ../output.py:621
+#: ../output.py:736
 msgid "  No dependencies for this package"
 msgstr "  Brak zależności dla tego pakietu"
 
-#: ../output.py:626
+#: ../output.py:741
 #, python-format
 msgid "  dependency: %s"
 msgstr "  zależność: %s"
 
-#: ../output.py:628
+#: ../output.py:743
 msgid "   Unsatisfied dependency"
 msgstr "   Nierozwiązana zależność"
 
-#: ../output.py:700
+#: ../output.py:818
+#, python-format
+msgid "Repo        : %s"
+msgstr "Repozytorium: %s"
+
+#: ../output.py:819
 msgid "Matched from:"
 msgstr "Dopasowano z:"
 
-#: ../output.py:708
+#: ../output.py:827
 msgid "Description : "
 msgstr "Opis        : "
 
-#: ../output.py:711
+#: ../output.py:830
 #, python-format
 msgid "URL         : %s"
 msgstr "URL         : %s"
 
-#: ../output.py:714
+#: ../output.py:833
 #, python-format
 msgid "License     : %s"
 msgstr "Licencja    : %s"
 
-#: ../output.py:717
+#: ../output.py:836
 #, python-format
 msgid "Filename    : %s"
 msgstr "Nazwa pliku : %s"
 
-#: ../output.py:721
+#: ../output.py:840
 msgid "Other       : "
 msgstr "Inne        : "
 
-#: ../output.py:753
+#: ../output.py:873
 msgid "There was an error calculating total download size"
 msgstr "Wystąpił błąd podczas obliczania całkowitego rozmiaru pobierania"
 
-#: ../output.py:758
+#: ../output.py:878
 #, python-format
 msgid "Total size: %s"
 msgstr "Całkowity rozmiar: %s"
 
-#: ../output.py:761
+#: ../output.py:881
 #, python-format
 msgid "Total download size: %s"
 msgstr "Całkowity rozmiar pobierania: %s"
 
-#: ../output.py:779
+#: ../output.py:916
 msgid "Installing for dependencies"
 msgstr "Instalowanie, aby rozwiązać zależności"
 
-#: ../output.py:780
+#: ../output.py:917
 msgid "Updating for dependencies"
 msgstr "Aktualizowanie, aby rozwiązać zależności"
 
-#: ../output.py:781
+#: ../output.py:918
 msgid "Removing for dependencies"
 msgstr "Usuwanie, aby rozwiązać zależności"
 
-#: ../output.py:817
+#: ../output.py:925 ../output.py:1021
+msgid "Skipped (dependency problems)"
+msgstr "Pominięto (problemy z zależnościami)"
+
+#: ../output.py:946
 msgid "Package"
 msgstr "Pakiet"
 
-#: ../output.py:817
+#: ../output.py:946
 msgid "Arch"
 msgstr "Architektura"
 
-#: ../output.py:818
+#: ../output.py:947
 msgid "Version"
 msgstr "Wersja"
 
-#: ../output.py:818
+#: ../output.py:947
 msgid "Repository"
 msgstr "Repozytorium"
 
-#: ../output.py:819
+#: ../output.py:948
 msgid "Size"
 msgstr "Rozmiar"
 
-#: ../output.py:830
+#: ../output.py:959
 #, python-format
 msgid ""
 "     replacing  %s.%s %s\n"
@@ -732,7 +757,7 @@ msgstr ""
 "     zastępuje  %s.%s %s\n"
 "\n"
 
-#: ../output.py:838
+#: ../output.py:967
 #, python-format
 msgid ""
 "\n"
@@ -749,27 +774,27 @@ msgstr ""
 "Aktualizowanie %5.5s pakietów     \n"
 "Usuwanie       %5.5s pakietów     \n"
 
-#: ../output.py:886
+#: ../output.py:1015
 msgid "Removed"
 msgstr "Usunięto"
 
-#: ../output.py:887
+#: ../output.py:1016
 msgid "Dependency Removed"
 msgstr "Usunięto zależność"
 
-#: ../output.py:889
+#: ../output.py:1018
 msgid "Dependency Installed"
 msgstr "Zainstalowano zależność"
 
-#: ../output.py:891
+#: ../output.py:1020
 msgid "Dependency Updated"
 msgstr "Zaktualizowano zależność"
 
-#: ../output.py:892
+#: ../output.py:1022
 msgid "Replaced"
 msgstr "Zastąpiono"
 
-#: ../output.py:965
+#: ../output.py:1095
 #, python-format
 msgid ""
 "\n"
@@ -780,76 +805,76 @@ msgstr ""
 " Obecne pobieranie zostało anulowane, %sprzerwij (Ctrl-C) ponownie%s w ciągu "
 "%s%s%s sekund, aby zakończyć.\n"
 
-#: ../output.py:975
+#: ../output.py:1105
 msgid "user interrupt"
 msgstr "przerwane przez użytkownika"
 
-#: ../output.py:991
+#: ../output.py:1121
 msgid "Total"
 msgstr "Razem"
 
-#: ../output.py:1005
+#: ../output.py:1135
 msgid "installed"
 msgstr "zainstalowany"
 
-#: ../output.py:1006
+#: ../output.py:1136
 msgid "updated"
 msgstr "zaktualizowany"
 
-#: ../output.py:1007
+#: ../output.py:1137
 msgid "obsoleted"
 msgstr "zastąpiony"
 
-#: ../output.py:1008
+#: ../output.py:1138
 msgid "erased"
 msgstr "usunięty"
 
-#: ../output.py:1012
+#: ../output.py:1142
 #, python-format
 msgid "---> Package %s.%s %s:%s-%s set to be %s"
 msgstr "---> Pakiet %s.%s %s:%s-%s zostanie %s"
 
-#: ../output.py:1019
+#: ../output.py:1149
 msgid "--> Running transaction check"
 msgstr "--> Wykonywanie sprawdzania transakcji"
 
-#: ../output.py:1024
+#: ../output.py:1154
 msgid "--> Restarting Dependency Resolution with new changes."
 msgstr "--> Ponowne uruchamianie rozwiązywania zależności z nowymi zmianami."
 
-#: ../output.py:1029
+#: ../output.py:1159
 msgid "--> Finished Dependency Resolution"
 msgstr "--> Zakończono rozwiązywanie zależności"
 
-#: ../output.py:1034
+#: ../output.py:1164
 #, python-format
 msgid "--> Processing Dependency: %s for package: %s"
 msgstr "--> Przetwarzanie zależności: %s dla pakietu: %s"
 
-#: ../output.py:1039
+#: ../output.py:1169
 #, python-format
 msgid "--> Unresolved Dependency: %s"
 msgstr "--> Nierozwiązana zależność: %s"
 
-#: ../output.py:1045
+#: ../output.py:1175
 #, python-format
 msgid "--> Processing Conflict: %s conflicts %s"
 msgstr "--> Przetwarzanie konfliktów: %s jest w konflikcie z %s"
 
-#: ../output.py:1048
+#: ../output.py:1178
 msgid "--> Populating transaction set with selected packages. Please wait."
 msgstr "--> Układanie zestawu transakcji z wybranymi pakietami. Proszę czekać."
 
-#: ../output.py:1052
+#: ../output.py:1182
 #, python-format
 msgid "---> Downloading header for %s to pack into transaction set."
 msgstr "---> Pobieranie nagłówka dla %s do umieszczenia w zestawie transakcji."
 
-#: ../yumcommands.py:40
+#: ../yumcommands.py:41
 msgid "You need to be root to perform this command."
 msgstr "Musisz być zalogowany jako root, aby wykonać to polecenie."
 
-#: ../yumcommands.py:47
+#: ../yumcommands.py:48
 msgid ""
 "\n"
 "You have enabled checking of packages via GPG keys. This is a good thing. \n"
@@ -880,306 +905,307 @@ msgstr ""
 "Aby dowiedzieć się więcej, skontaktuj się z dostawcą dystrybucji lub\n"
 "pakietu.\n"
 
-#: ../yumcommands.py:67
+#: ../yumcommands.py:68
 #, python-format
 msgid "Error: Need to pass a list of pkgs to %s"
 msgstr "Błąd: wymagane jest przekazanie listy pakietów do %s"
 
-#: ../yumcommands.py:73
+#: ../yumcommands.py:74
 msgid "Error: Need an item to match"
 msgstr "Błąd: wymagany jest parametr do dopasowania"
 
-#: ../yumcommands.py:79
+#: ../yumcommands.py:80
 msgid "Error: Need a group or list of groups"
 msgstr "Błąd: wymagana jest grupa lub lista grup"
 
-#: ../yumcommands.py:88
+#: ../yumcommands.py:89
 #, python-format
 msgid "Error: clean requires an option: %s"
 msgstr "Błąd: czyszczenie wymaga opcji: %s"
 
-#: ../yumcommands.py:93
+#: ../yumcommands.py:94
 #, python-format
 msgid "Error: invalid clean argument: %r"
 msgstr "Błąd: nieprawidłowy parametr czyszczenia: %r"
 
-#: ../yumcommands.py:106
+#: ../yumcommands.py:107
 msgid "No argument to shell"
 msgstr "Brak parametrów dla powłoki"
 
-#: ../yumcommands.py:109
+#: ../yumcommands.py:110
 #, python-format
 msgid "Filename passed to shell: %s"
 msgstr "Przekazano nazwę pliku do powłoki: %s"
 
-#: ../yumcommands.py:113
+#: ../yumcommands.py:114
 #, python-format
 msgid "File %s given as argument to shell does not exist."
 msgstr "Plik %s podany powłoce jako parametr nie istnieje."
 
-#: ../yumcommands.py:119
+#: ../yumcommands.py:120
 msgid "Error: more than one file given as argument to shell."
 msgstr "Błąd: podano powłoce więcej niż jeden plik jako parametr."
 
-#: ../yumcommands.py:160
+#: ../yumcommands.py:161
 msgid "PACKAGE..."
 msgstr "PAKIET..."
 
-#: ../yumcommands.py:163
+#: ../yumcommands.py:164
 msgid "Install a package or packages on your system"
 msgstr "Zainstaluj pakiet lub pakiety w systemie"
 
-#: ../yumcommands.py:172
+#: ../yumcommands.py:173
 msgid "Setting up Install Process"
 msgstr "Ustawianie procesu instalacji"
 
-#: ../yumcommands.py:183
+#: ../yumcommands.py:184
 msgid "[PACKAGE...]"
 msgstr "[PAKIET...]"
 
-#: ../yumcommands.py:186
+#: ../yumcommands.py:187
 msgid "Update a package or packages on your system"
 msgstr "Zaktualizuj pakiet lub pakiety w systemie"
 
-#: ../yumcommands.py:194
+#: ../yumcommands.py:195
 msgid "Setting up Update Process"
 msgstr "Ustawianie procesu aktualizacji"
 
-#: ../yumcommands.py:236
+#: ../yumcommands.py:237
 msgid "Display details about a package or group of packages"
 msgstr "Wyświetl szczegóły o pakiecie lub grupie pakietów"
 
-#. Output the packages:
-#: ../yumcommands.py:261
+#: ../yumcommands.py:278
 msgid "Installed Packages"
 msgstr "Zainstalowane pakiety"
 
-#: ../yumcommands.py:263
+#: ../yumcommands.py:285
 msgid "Available Packages"
 msgstr "Dostępne pakiety"
 
-#: ../yumcommands.py:265
+#: ../yumcommands.py:289
 msgid "Extra Packages"
 msgstr "Dodatkowe pakiety"
 
-#: ../yumcommands.py:267
+#: ../yumcommands.py:291
 msgid "Updated Packages"
 msgstr "Zaktualizowane pakiety"
 
-#: ../yumcommands.py:274 ../yumcommands.py:281
+#: ../yumcommands.py:298 ../yumcommands.py:305 ../yumcommands.py:574
 msgid "Obsoleting Packages"
 msgstr "Zastępowanie przestarzałych pakietów"
 
-#: ../yumcommands.py:283
+#: ../yumcommands.py:307
 msgid "Recently Added Packages"
 msgstr "Ostatnio dodane pakiety"
 
-#: ../yumcommands.py:290
+#: ../yumcommands.py:314
 msgid "No matching Packages to list"
 msgstr "Brak pakietów pasujących do listy"
 
-#: ../yumcommands.py:304
+#: ../yumcommands.py:328
 msgid "List a package or groups of packages"
 msgstr "Wyświetl listę pakietów lub grup pakietów"
 
-#: ../yumcommands.py:316
+#: ../yumcommands.py:340
 msgid "Remove a package or packages from your system"
 msgstr "Usuń pakiet lub pakiety z systemu"
 
-#: ../yumcommands.py:324
+#: ../yumcommands.py:348
 msgid "Setting up Remove Process"
 msgstr "Ustawianie procesu usuwania"
 
-#: ../yumcommands.py:339
+#: ../yumcommands.py:363
 msgid "Setting up Group Process"
 msgstr "Ustawianie procesu grup"
 
-#: ../yumcommands.py:345
+#: ../yumcommands.py:369
 msgid "No Groups on which to run command"
 msgstr "Brak grup, na których można wykonać polecenie"
 
-#: ../yumcommands.py:358
+#: ../yumcommands.py:382
 msgid "List available package groups"
 msgstr "Wyświetl listę dostępnych grup pakietów"
 
-#: ../yumcommands.py:375
+#: ../yumcommands.py:399
 msgid "Install the packages in a group on your system"
 msgstr "Zainstaluj pakiety z grupy w systemie"
 
-#: ../yumcommands.py:397
+#: ../yumcommands.py:421
 msgid "Remove the packages in a group from your system"
 msgstr "Usuń pakiety z grupy z systemu"
 
-#: ../yumcommands.py:424
+#: ../yumcommands.py:448
 msgid "Display details about a package group"
 msgstr "Wyświetl szczegóły o grupie pakietów"
 
-#: ../yumcommands.py:448
+#: ../yumcommands.py:472
 msgid "Generate the metadata cache"
 msgstr "Utwórz pamięć podręczną metadanych"
 
-#: ../yumcommands.py:454
+#: ../yumcommands.py:478
 msgid "Making cache files for all metadata files."
 msgstr "Tworzenie plików pamięci podręcznej ze wszystkich plików metadanych."
 
-#: ../yumcommands.py:455
+#: ../yumcommands.py:479
 msgid "This may take a while depending on the speed of this computer"
 msgstr "Może to chwilę zająć, z zależności od szybkości komputera"
 
-#: ../yumcommands.py:476
+#: ../yumcommands.py:500
 msgid "Metadata Cache Created"
 msgstr "Utworzono pamięć podręczną metadanych"
 
-#: ../yumcommands.py:490
+#: ../yumcommands.py:514
 msgid "Remove cached data"
 msgstr "Usunięto dane z pamięci podręcznej"
 
-#: ../yumcommands.py:511
+#: ../yumcommands.py:535
 msgid "Find what package provides the given value"
 msgstr "Znajdź pakiet dostarczający podaną wartość"
 
-#: ../yumcommands.py:531
+#: ../yumcommands.py:555
 msgid "Check for available package updates"
 msgstr "Sprawdź dostępne aktualizacje pakietów"
 
-#: ../yumcommands.py:556
+#: ../yumcommands.py:594
 msgid "Search package details for the given string"
 msgstr "Znajdź szczegóły pakietów dla podanego łańcucha tekstowego"
 
-#: ../yumcommands.py:562
+#: ../yumcommands.py:600
 msgid "Searching Packages: "
 msgstr "Wyszukiwanie pakietów: "
 
-#: ../yumcommands.py:579
+#: ../yumcommands.py:617
 msgid "Update packages taking obsoletes into account"
 msgstr "Zaktualizuj pakiety, w tym przestarzałe"
 
-#: ../yumcommands.py:588
+#: ../yumcommands.py:626
 msgid "Setting up Upgrade Process"
 msgstr "Ustawianie procesu aktualizacji"
 
-#: ../yumcommands.py:602
+#: ../yumcommands.py:640
 msgid "Install a local RPM"
 msgstr "Zainstaluj lokalny pakiet RPM"
 
-#: ../yumcommands.py:611
+#: ../yumcommands.py:649
 msgid "Setting up Local Package Process"
 msgstr "Ustawianie procesu lokalnego pakietu"
 
-#: ../yumcommands.py:630
+#: ../yumcommands.py:668
 msgid "Determine which package provides the given dependency"
 msgstr "Określ, który pakiet dostarcza podaną zależność"
 
-#: ../yumcommands.py:633
+#: ../yumcommands.py:671
 msgid "Searching Packages for Dependency:"
 msgstr "Wyszukiwanie pakietów dla zależności:"
 
-#: ../yumcommands.py:647
+#: ../yumcommands.py:685
 msgid "Run an interactive yum shell"
 msgstr "Uruchom interaktywną powłokę yuma"
 
-#: ../yumcommands.py:653
+#: ../yumcommands.py:691
 msgid "Setting up Yum Shell"
 msgstr "Ustawianie powłoki yuma"
 
-#: ../yumcommands.py:671
+#: ../yumcommands.py:709
 msgid "List a package's dependencies"
 msgstr "Wyświetl listę zależności pakietu"
 
-#: ../yumcommands.py:677
+#: ../yumcommands.py:715
 msgid "Finding dependencies: "
 msgstr "Wyszukiwanie zależności: "
 
-#: ../yumcommands.py:693
+#: ../yumcommands.py:731
 msgid "Display the configured software repositories"
 msgstr "Wyświetl skonfigurowane repozytoria oprogramowania"
 
-#: ../yumcommands.py:742
+#: ../yumcommands.py:779 ../yumcommands.py:780
 msgid "enabled"
 msgstr "włączone"
 
-#: ../yumcommands.py:751
+#: ../yumcommands.py:788 ../yumcommands.py:789
 msgid "disabled"
 msgstr "wyłączone"
 
-#: ../yumcommands.py:760
-msgid "repo id"
-msgstr "ID repozytorium"
-
-#: ../yumcommands.py:761
-msgid "repo name"
-msgstr "nazwa repozytorium"
-
-#: ../yumcommands.py:761
-msgid "status"
-msgstr "stan"
-
-#: ../yumcommands.py:765
+#: ../yumcommands.py:800
 msgid "Repo-id     : "
 msgstr "Identyfikator repozytorium        : "
 
-#: ../yumcommands.py:766
+#: ../yumcommands.py:801
 msgid "Repo-name   : "
 msgstr "Nazwa repozytorium                : "
 
-#: ../yumcommands.py:767
+#: ../yumcommands.py:802
 msgid "Repo-status : "
 msgstr "Stan repozytorium                 : "
 
-#: ../yumcommands.py:769
+#: ../yumcommands.py:804
 msgid "Repo-revision: "
 msgstr "Wersja repozytorium               : "
 
-#: ../yumcommands.py:773
+#: ../yumcommands.py:808
 msgid "Repo-tags   : "
 msgstr "Znaczniki repozytorium            : "
 
-#: ../yumcommands.py:779
+#: ../yumcommands.py:814
 msgid "Repo-distro-tags: "
 msgstr "Znaczniki dystrybucji repozytorium: "
 
-#: ../yumcommands.py:784
+#: ../yumcommands.py:819
 msgid "Repo-updated: "
 msgstr "Aktualizacje repozytorium         : "
 
-#: ../yumcommands.py:786
+#: ../yumcommands.py:821
 msgid "Repo-pkgs   : "
 msgstr "Pakiety repozytorium              : "
 
-#: ../yumcommands.py:787
+#: ../yumcommands.py:822
 msgid "Repo-size   : "
 msgstr "Rozmiar repozytorium              : "
 
-#: ../yumcommands.py:794
+#: ../yumcommands.py:829
 msgid "Repo-baseurl: "
 msgstr "Podstawowy URL repozytorium       : "
 
-#: ../yumcommands.py:798
+#: ../yumcommands.py:833
 msgid "Repo-metalink: "
 msgstr "Metaodnośnik repozytorium         : "
 
-#: ../yumcommands.py:801
+#: ../yumcommands.py:836
 msgid "Repo-mirrors: "
 msgstr "Serwery lustrzane repozytorium    : "
 
-#: ../yumcommands.py:805
+#: ../yumcommands.py:840
 msgid "Repo-exclude: "
 msgstr "Wykluczenia z repozytorium        : "
 
-#: ../yumcommands.py:809
+#: ../yumcommands.py:844
 msgid "Repo-include: "
 msgstr "Dołączone z repozytorium          : "
 
-#: ../yumcommands.py:835
+#. Work out the first (id) and last (enabled/disalbed/count),
+#. then chop the middle (name)...
+#: ../yumcommands.py:854 ../yumcommands.py:880
+msgid "repo id"
+msgstr "ID repozytorium"
+
+#: ../yumcommands.py:868 ../yumcommands.py:869 ../yumcommands.py:883
+msgid "status"
+msgstr "stan"
+
+#: ../yumcommands.py:881
+msgid "repo name"
+msgstr "nazwa repozytorium"
+
+#: ../yumcommands.py:907
 msgid "Display a helpful usage message"
 msgstr "Wyświetl pomocny komunikat o używaniu"
 
-#: ../yumcommands.py:869
+#: ../yumcommands.py:941
 #, python-format
 msgid "No help available for %s"
 msgstr "Brak pomocy dla %s"
 
-#: ../yumcommands.py:874
+#: ../yumcommands.py:946
 msgid ""
 "\n"
 "\n"
@@ -1189,7 +1215,7 @@ msgstr ""
 "\n"
 "aliasy: "
 
-#: ../yumcommands.py:876
+#: ../yumcommands.py:948
 msgid ""
 "\n"
 "\n"
@@ -1199,11 +1225,11 @@ msgstr ""
 "\n"
 "alias: "
 
-#: ../yumcommands.py:905
+#: ../yumcommands.py:977
 msgid "Setting up Reinstall Process"
 msgstr "Ustawianie procesu ponownej instalacji"
 
-#: ../yumcommands.py:919
+#: ../yumcommands.py:991
 msgid "reinstall a package"
 msgstr "ponownie zainstaluj pakiet"
 
@@ -1273,196 +1299,196 @@ msgstr ""
 msgid "doTsSetup() will go away in a future version of Yum.\n"
 msgstr "doTsSetup() zostanie usunięte w przyszłych wersjach yuma.\n"
 
-#: ../yum/depsolve.py:97
+#: ../yum/depsolve.py:99
 msgid "Setting up TransactionSets before config class is up"
 msgstr "Ustawianie zestawów transakcji przed włączeniem klasy konfiguracji"
 
-#: ../yum/depsolve.py:148
+#: ../yum/depsolve.py:150
 #, python-format
 msgid "Invalid tsflag in config file: %s"
 msgstr "Nieprawidłowa flaga zestawu transakcji tsflag w pliku konfiguracji: %s"
 
-#: ../yum/depsolve.py:159
+#: ../yum/depsolve.py:161
 #, python-format
 msgid "Searching pkgSack for dep: %s"
 msgstr "Wyszukiwanie zestawu pakietów dla zależności: %s"
 
-#: ../yum/depsolve.py:182
+#: ../yum/depsolve.py:184
 #, python-format
 msgid "Potential match for %s from %s"
 msgstr "Potencjalny wynik dla %s z %s"
 
-#: ../yum/depsolve.py:190
+#: ../yum/depsolve.py:192
 #, python-format
 msgid "Matched %s to require for %s"
 msgstr "%s pasuje jako wymaganie dla %s"
 
-#: ../yum/depsolve.py:231
+#: ../yum/depsolve.py:233
 #, python-format
 msgid "Member: %s"
 msgstr "Członek: %s"
 
-#: ../yum/depsolve.py:245 ../yum/depsolve.py:732
+#: ../yum/depsolve.py:247 ../yum/depsolve.py:733
 #, python-format
 msgid "%s converted to install"
 msgstr "%s przekonwertowano do zainstalowania"
 
-#: ../yum/depsolve.py:252
+#: ../yum/depsolve.py:254
 #, python-format
 msgid "Adding Package %s in mode %s"
 msgstr "Dodawanie pakietu %s w trybie %s"
 
-#: ../yum/depsolve.py:262
+#: ../yum/depsolve.py:264
 #, python-format
 msgid "Removing Package %s"
 msgstr "Usuwanie pakietu %s"
 
-#: ../yum/depsolve.py:273
+#: ../yum/depsolve.py:275
 #, python-format
 msgid "%s requires: %s"
 msgstr "%s wymaga: %s"
 
-#: ../yum/depsolve.py:331
+#: ../yum/depsolve.py:333
 msgid "Needed Require has already been looked up, cheating"
 msgstr "Wymagana zależność została już znaleziona, oszukiwanie"
 
-#: ../yum/depsolve.py:341
+#: ../yum/depsolve.py:343
 #, python-format
 msgid "Needed Require is not a package name. Looking up: %s"
 msgstr "Wymagana zależność nie jest nazwą pakietu. Wyszukiwanie: %s"
 
-#: ../yum/depsolve.py:348
+#: ../yum/depsolve.py:350
 #, python-format
 msgid "Potential Provider: %s"
 msgstr "Potencjalny dostawca: %s"
 
-#: ../yum/depsolve.py:371
+#: ../yum/depsolve.py:373
 #, python-format
 msgid "Mode is %s for provider of %s: %s"
 msgstr "Tryb to %s dla dostawcy %s: %s"
 
-#: ../yum/depsolve.py:375
+#: ../yum/depsolve.py:377
 #, python-format
 msgid "Mode for pkg providing %s: %s"
 msgstr "Tryb dla pakietu dostarczającego %s: %s"
 
-#: ../yum/depsolve.py:379
+#: ../yum/depsolve.py:381
 #, python-format
 msgid "TSINFO: %s package requiring %s marked as erase"
 msgstr "TSINFO: pakiet %s wymagający %s został oznaczony jako do usunięcia"
 
-#: ../yum/depsolve.py:391
+#: ../yum/depsolve.py:393
 #, python-format
 msgid "TSINFO: Obsoleting %s with %s to resolve dep."
 msgstr ""
 "TSINFO: zastępowanie przestarzałego pakietu %s pakietem %s, aby rozwiązać "
 "zależność."
 
-#: ../yum/depsolve.py:394
+#: ../yum/depsolve.py:396
 #, python-format
 msgid "TSINFO: Updating %s to resolve dep."
 msgstr "TSINFO: aktualizowanie %s, aby rozwiązać zależność."
 
-#: ../yum/depsolve.py:402
+#: ../yum/depsolve.py:404
 #, python-format
 msgid "Cannot find an update path for dep for: %s"
 msgstr "Nie można znaleźć ścieżki aktualizacji dla zależności dla: %s"
 
-#: ../yum/depsolve.py:412
+#: ../yum/depsolve.py:414
 #, python-format
 msgid "Unresolvable requirement %s for %s"
 msgstr "Nie można rozwiązać wymagania %s dla %s"
 
-#: ../yum/depsolve.py:435
+#: ../yum/depsolve.py:437
 #, python-format
 msgid "Quick matched %s to require for %s"
 msgstr "Szybko dopasowano %s jako wymaganie %s"
 
 #. is it already installed?
-#: ../yum/depsolve.py:477
+#: ../yum/depsolve.py:479
 #, python-format
 msgid "%s is in providing packages but it is already installed, removing."
 msgstr ""
 "%s jest w dostarczających pakietach, ale jest już zainstalowany, usuwanie."
 
-#: ../yum/depsolve.py:492
+#: ../yum/depsolve.py:494
 #, python-format
 msgid "Potential resolving package %s has newer instance in ts."
 msgstr ""
 "Pakiet %s potencjalnie rozwiązujący ma nowszą wersję w zestawie transakcji."
 
-#: ../yum/depsolve.py:503
+#: ../yum/depsolve.py:505
 #, python-format
 msgid "Potential resolving package %s has newer instance installed."
 msgstr "Pakiet %s potencjalnie rozwiązujący ma zainstalowaną nowszą wersję."
 
-#: ../yum/depsolve.py:511 ../yum/depsolve.py:560
+#: ../yum/depsolve.py:513 ../yum/depsolve.py:562
 #, python-format
 msgid "Missing Dependency: %s is needed by package %s"
 msgstr "Brakująca zależność: %s jest wymagane przez pakiet %s"
 
-#: ../yum/depsolve.py:524
+#: ../yum/depsolve.py:526
 #, python-format
 msgid "%s already in ts, skipping this one"
 msgstr "%s jest już w zestawie transakcji, pomijanie"
 
-#: ../yum/depsolve.py:570
+#: ../yum/depsolve.py:572
 #, python-format
 msgid "TSINFO: Marking %s as update for %s"
 msgstr "TSINFO: oznaczanie %s jako aktualizacji dla %s"
 
-#: ../yum/depsolve.py:578
+#: ../yum/depsolve.py:580
 #, python-format
 msgid "TSINFO: Marking %s as install for %s"
 msgstr "TSINFO: oznaczanie %s jako do zainstalowania dla %s"
 
-#: ../yum/depsolve.py:670 ../yum/depsolve.py:750
+#: ../yum/depsolve.py:672 ../yum/depsolve.py:751
 msgid "Success - empty transaction"
 msgstr "Powodzenie - pusta transakcja"
 
-#: ../yum/depsolve.py:709 ../yum/depsolve.py:722
+#: ../yum/depsolve.py:710 ../yum/depsolve.py:723
 msgid "Restarting Loop"
 msgstr "Ponowne uruchamianie pętli"
 
-#: ../yum/depsolve.py:738
+#: ../yum/depsolve.py:739
 msgid "Dependency Process ending"
 msgstr "Kończenie procesu zależności"
 
-#: ../yum/depsolve.py:744
+#: ../yum/depsolve.py:745
 #, python-format
 msgid "%s from %s has depsolving problems"
 msgstr "%s z %s ma problemy z rozwiązywaniem zależności"
 
-#: ../yum/depsolve.py:751
+#: ../yum/depsolve.py:752
 msgid "Success - deps resolved"
 msgstr "Powodzenie - rozwiązano zależności"
 
-#: ../yum/depsolve.py:765
+#: ../yum/depsolve.py:766
 #, python-format
 msgid "Checking deps for %s"
 msgstr "Sprawdzanie zależności dla %s"
 
-#: ../yum/depsolve.py:848
+#: ../yum/depsolve.py:849
 #, python-format
 msgid "looking for %s as a requirement of %s"
 msgstr "wyszukiwanie %s jako wymagania %s"
 
-#: ../yum/depsolve.py:988
+#: ../yum/depsolve.py:989
 #, python-format
 msgid "Running compare_providers() for %s"
 msgstr "Wykonywanie compare_providers() dla %s"
 
-#: ../yum/depsolve.py:1016 ../yum/depsolve.py:1022
+#: ../yum/depsolve.py:1017 ../yum/depsolve.py:1023
 #, python-format
 msgid "better arch in po %s"
 msgstr "lepsze arch w po %s"
 
-#: ../yum/depsolve.py:1061
+#: ../yum/depsolve.py:1062
 #, python-format
 msgid "%s obsoletes %s"
 msgstr "%s zastępuje %s"
 
-#: ../yum/depsolve.py:1077
+#: ../yum/depsolve.py:1078
 #, python-format
 msgid ""
 "archdist compared %s to %s on %s\n"
@@ -1471,98 +1497,99 @@ msgstr ""
 "archdist porównało %s do %s na %s\n"
 "  Zwycięzca: %s"
 
-#: ../yum/depsolve.py:1084
+#: ../yum/depsolve.py:1085
 #, python-format
 msgid "common sourcerpm %s and %s"
-msgstr "wspólny RPM źródłowy %s i %s"
+msgstr "wspólny źródłowy pakiet RPM %s i %s"
 
-#: ../yum/depsolve.py:1090
+#: ../yum/depsolve.py:1091
 #, python-format
 msgid "common prefix of %s between %s and %s"
 msgstr "wspólny przedrostek %s dla %s i %s"
 
-#: ../yum/depsolve.py:1098
+#: ../yum/depsolve.py:1099
 #, python-format
 msgid "Best Order: %s"
 msgstr "Najlepszy porządek: %s"
 
-#: ../yum/__init__.py:134
+#: ../yum/__init__.py:154
 msgid "doConfigSetup() will go away in a future version of Yum.\n"
 msgstr "doConfigSetup() zostanie usunięte w przyszłych wersjach yuma.\n"
 
-#: ../yum/__init__.py:314
+#. FIXME: Use critical? or exception?
+#: ../yum/__init__.py:335
 #, python-format
 msgid "Repository %r is missing name in configuration, using id"
 msgstr "Repozytorium %r nie posiada nazwy w konfiguracji, używanie ID"
 
-#: ../yum/__init__.py:352
+#: ../yum/__init__.py:373
 msgid "plugins already initialised"
 msgstr "wtyczki zostały już zainicjowane"
 
-#: ../yum/__init__.py:359
+#: ../yum/__init__.py:380
 msgid "doRpmDBSetup() will go away in a future version of Yum.\n"
 msgstr "doRpmDBSetup() zostanie usunięte w przyszłych wersjach yuma.\n"
 
-#: ../yum/__init__.py:369
+#: ../yum/__init__.py:390
 msgid "Reading Local RPMDB"
 msgstr "Odczytywanie lokalnej bazy danych RPM"
 
-#: ../yum/__init__.py:387
+#: ../yum/__init__.py:408
 msgid "doRepoSetup() will go away in a future version of Yum.\n"
 msgstr "doRepoSetup() zostanie usunięte w przyszłych wersjach yuma.\n"
 
-#: ../yum/__init__.py:407
+#: ../yum/__init__.py:428
 msgid "doSackSetup() will go away in a future version of Yum.\n"
 msgstr "doSackSetup() zostanie usunięte w przyszłych wersjach yuma.\n"
 
-#: ../yum/__init__.py:424
+#: ../yum/__init__.py:445
 msgid "Setting up Package Sacks"
 msgstr "Ustawianie zestawów pakietów"
 
-#: ../yum/__init__.py:467
+#: ../yum/__init__.py:488
 #, python-format
 msgid "repo object for repo %s lacks a _resetSack method\n"
 msgstr "obiekt repozytorium %s nie posiada metody _resetSack\n"
 
-#: ../yum/__init__.py:468
+#: ../yum/__init__.py:489
 msgid "therefore this repo cannot be reset.\n"
 msgstr "więc to repozytorium nie może zostać przywrócone.\n"
 
-#: ../yum/__init__.py:473
+#: ../yum/__init__.py:494
 msgid "doUpdateSetup() will go away in a future version of Yum.\n"
 msgstr "doUpdateSetup() zostanie usunięte w przyszłych wersjach yuma.\n"
 
-#: ../yum/__init__.py:485
+#: ../yum/__init__.py:506
 msgid "Building updates object"
 msgstr "Budowanie obiektu aktualizacji"
 
-#: ../yum/__init__.py:516
+#: ../yum/__init__.py:537
 msgid "doGroupSetup() will go away in a future version of Yum.\n"
 msgstr "doGroupSetup() zostanie usunięte w przyszłych wersjach yuma.\n"
 
-#: ../yum/__init__.py:540
+#: ../yum/__init__.py:561
 msgid "Getting group metadata"
 msgstr "Pobieranie metadanych grup"
 
-#: ../yum/__init__.py:566
+#: ../yum/__init__.py:586
 #, python-format
 msgid "Adding group file from repository: %s"
 msgstr "Dodawanie pliku grup z repozytorium: %s"
 
-#: ../yum/__init__.py:575
+#: ../yum/__init__.py:591
 #, python-format
 msgid "Failed to add groups file for repository: %s - %s"
 msgstr "Dodanie pliku grup dla repozytorium nie powiodło się: %s - %s"
 
-#: ../yum/__init__.py:581
+#: ../yum/__init__.py:597
 msgid "No Groups Available in any repository"
 msgstr "Brak dostępnych grup we wszystkich repozytoriach"
 
-#: ../yum/__init__.py:631
+#: ../yum/__init__.py:647
 msgid "Importing additional filelist information"
 msgstr "Importowanie dodatkowych informacji o liście plików"
 
-#: ../yum/__init__.py:640
+#: ../yum/__init__.py:655
 msgid ""
 "There are unfinished transactions remaining. You might consider running yum-"
 "complete-transaction first to finish them."
@@ -1570,17 +1597,17 @@ msgstr ""
 "Pozostały niezakończone transakcje. Rozważ wykonanie yum-complete-"
 "transaction, aby najpierw je zakończyć."
 
-#: ../yum/__init__.py:690
+#: ../yum/__init__.py:721
 #, python-format
 msgid "Skip-broken round %i"
 msgstr "Pierwsza runda pomijania uszkodzonych %i"
 
-#: ../yum/__init__.py:713
+#: ../yum/__init__.py:770
 #, python-format
 msgid "Skip-broken took %i rounds "
 msgstr "Pomijanie uszkodzonych zajęło %i rund "
 
-#: ../yum/__init__.py:714
+#: ../yum/__init__.py:771
 msgid ""
 "\n"
 "Packages skipped because of dependency problems:"
@@ -1588,92 +1615,92 @@ msgstr ""
 "\n"
 "Pakiety pominięto z powodu problemów z zależnościami:"
 
-#: ../yum/__init__.py:718
+#: ../yum/__init__.py:775
 #, python-format
 msgid "    %s from %s"
 msgstr "    %s z %s"
 
-#: ../yum/__init__.py:803
+#: ../yum/__init__.py:918
 msgid ""
 "Warning: scriptlet or other non-fatal errors occurred during transaction."
 msgstr ""
 "Ostrzeżenie: podczas transakcji wystąpił skrypt lub inne nie fatalne błędy."
 
-#: ../yum/__init__.py:819
+#: ../yum/__init__.py:934
 #, python-format
 msgid "Failed to remove transaction file %s"
 msgstr "Usunięcie pliku transakcji %s nie powiodło się"
 
-#: ../yum/__init__.py:860
+#: ../yum/__init__.py:975
 #, python-format
 msgid "excluding for cost: %s from %s"
 msgstr "wykluczanie z kosztów: %s z %s"
 
-#: ../yum/__init__.py:891
+#: ../yum/__init__.py:1006
 msgid "Excluding Packages in global exclude list"
 msgstr "Wykluczanie pakietów na globalnej liście wykluczonych pakietów"
 
-#: ../yum/__init__.py:893
+#: ../yum/__init__.py:1008
 #, python-format
 msgid "Excluding Packages from %s"
 msgstr "Wykluczanie pakietów z %s"
 
-#: ../yum/__init__.py:920
+#: ../yum/__init__.py:1033
 #, python-format
 msgid "Reducing %s to included packages only"
 msgstr "Zmniejszanie %s tylko do dołączonych pakietów"
 
-#: ../yum/__init__.py:926
+#: ../yum/__init__.py:1039
 #, python-format
 msgid "Keeping included package %s"
 msgstr "Utrzymywanie dołączonego pakietu %s"
 
-#: ../yum/__init__.py:932
+#: ../yum/__init__.py:1045
 #, python-format
 msgid "Removing unmatched package %s"
 msgstr "Usuwanie niepasującego pakietu %s"
 
-#: ../yum/__init__.py:935
+#: ../yum/__init__.py:1048
 msgid "Finished"
 msgstr "Zakończono"
 
 #. Whoa. What the heck happened?
-#: ../yum/__init__.py:965
+#: ../yum/__init__.py:1078
 #, python-format
 msgid "Unable to check if PID %s is active"
 msgstr "Nie można sprawdzić, czy PID %s jest aktywny"
 
 #. Another copy seems to be running.
-#: ../yum/__init__.py:969
+#: ../yum/__init__.py:1082
 #, python-format
 msgid "Existing lock %s: another copy is running as pid %s."
 msgstr "Istnieje blokada %s: inna kopia jest uruchomiona jako PID %s."
 
-#: ../yum/__init__.py:1040
+#: ../yum/__init__.py:1153
 msgid "Package does not match intended download"
 msgstr "Pakiet nie zgadza się z zamierzonym pobieraniem"
 
-#: ../yum/__init__.py:1055
+#: ../yum/__init__.py:1168
 msgid "Could not perform checksum"
 msgstr "Nie można wykonać sprawdzenia sum kontrolnych"
 
-#: ../yum/__init__.py:1058
+#: ../yum/__init__.py:1171
 msgid "Package does not match checksum"
 msgstr "Sumy kontrolne pakietu nie zgadzają się"
 
-#: ../yum/__init__.py:1101
+#: ../yum/__init__.py:1214
 #, python-format
 msgid "package fails checksum but caching is enabled for %s"
 msgstr ""
 "sprawdzenie sum kontrolnych pakietu nie powiodło się, ale zapisywanie w "
 "pamięci podręcznej dla %s jest włączone"
 
-#: ../yum/__init__.py:1104
+#: ../yum/__init__.py:1217 ../yum/__init__.py:1245
 #, python-format
 msgid "using local copy of %s"
 msgstr "używanie lokalnej kopii %s"
 
-#: ../yum/__init__.py:1131
+#: ../yum/__init__.py:1259
 #, python-format
 msgid ""
 "Insufficient space in download directory %s\n"
@@ -1684,11 +1711,11 @@ msgstr ""
 "    * wolne   %s\n"
 "    * wymagane %s"
 
-#: ../yum/__init__.py:1178
+#: ../yum/__init__.py:1306
 msgid "Header is not complete."
 msgstr "Nagłówek nie jest kompletny."
 
-#: ../yum/__init__.py:1218
+#: ../yum/__init__.py:1346
 #, python-format
 msgid ""
 "Header not in local cache and caching-only mode enabled. Cannot download %s"
@@ -1696,62 +1723,62 @@ msgstr ""
 "Nagłówek nie jest w lokalnej pamięci podręcznej, a tryb używania tylko "
 "pamięci podręcznej jest włączony. Nie można pobrać %s"
 
-#: ../yum/__init__.py:1273
+#: ../yum/__init__.py:1401
 #, python-format
 msgid "Public key for %s is not installed"
 msgstr "Klucz publiczny dla %s nie jest zainstalowany"
 
-#: ../yum/__init__.py:1277
+#: ../yum/__init__.py:1405
 #, python-format
 msgid "Problem opening package %s"
 msgstr "Podczas otwierania pakietu %s wystąpił problem"
 
-#: ../yum/__init__.py:1285
+#: ../yum/__init__.py:1413
 #, python-format
 msgid "Public key for %s is not trusted"
 msgstr "Klucz publiczny dla %s nie jest zaufany"
 
-#: ../yum/__init__.py:1289
+#: ../yum/__init__.py:1417
 #, python-format
 msgid "Package %s is not signed"
 msgstr "Pakiet %s nie jest podpisany"
 
-#: ../yum/__init__.py:1327
+#: ../yum/__init__.py:1455
 #, python-format
 msgid "Cannot remove %s"
 msgstr "Nie można usunąć %s"
 
-#: ../yum/__init__.py:1331
+#: ../yum/__init__.py:1458
 #, python-format
 msgid "%s removed"
 msgstr "Usunięto %s"
 
-#: ../yum/__init__.py:1368
+#: ../yum/__init__.py:1495
 #, python-format
 msgid "Cannot remove %s file %s"
 msgstr "Nie można usunąć %s pliku %s"
 
-#: ../yum/__init__.py:1372
+#: ../yum/__init__.py:1498
 #, python-format
 msgid "%s file %s removed"
 msgstr "Usunięto %s plik %s"
 
-#: ../yum/__init__.py:1374
+#: ../yum/__init__.py:1500
 #, python-format
 msgid "%d %s files removed"
 msgstr "Usunięto %d %s plików"
 
-#: ../yum/__init__.py:1436
+#: ../yum/__init__.py:1568
 #, python-format
 msgid "More than one identical match in sack for %s"
 msgstr "Więcej niż jeden identyczny wynik znajduje się w zestawie dla %s"
 
-#: ../yum/__init__.py:1442
+#: ../yum/__init__.py:1573
 #, python-format
 msgid "Nothing matches %s.%s %s:%s-%s from update"
 msgstr "Nic nie pasuje do %s.%s %s:%s-%s z aktualizacji"
 
-#: ../yum/__init__.py:1650
+#: ../yum/__init__.py:1792
 msgid ""
 "searchPackages() will go away in a future version of "
 "Yum.                      Use searchGenerator() instead. \n"
@@ -1759,175 +1786,175 @@ msgstr ""
 "searchPackages()  zostanie usunięte w przyszłych wersjach "
 "yuma.                      Zamiast tego użyj searchGenerator(). \n"
 
-#: ../yum/__init__.py:1688
+#: ../yum/__init__.py:1829
 #, python-format
 msgid "Searching %d packages"
 msgstr "Wyszukiwanie %d pakietów"
 
-#: ../yum/__init__.py:1692
+#: ../yum/__init__.py:1832
 #, python-format
 msgid "searching package %s"
 msgstr "wyszukiwanie pakietu %s"
 
-#: ../yum/__init__.py:1704
+#: ../yum/__init__.py:1843
 msgid "searching in file entries"
 msgstr "wyszukiwanie we wpisach plików"
 
-#: ../yum/__init__.py:1711
+#: ../yum/__init__.py:1849
 msgid "searching in provides entries"
 msgstr "wyszukiwanie we wpisach dostarczania"
 
-#: ../yum/__init__.py:1744
+#: ../yum/__init__.py:1882
 #, python-format
 msgid "Provides-match: %s"
 msgstr "Wyniki dostarczania: %s"
 
-#: ../yum/__init__.py:1793
+#: ../yum/__init__.py:1931
 msgid "No group data available for configured repositories"
 msgstr "Brak dostępnych danych grup dla skonfigurowanych repozytoriów"
 
-#: ../yum/__init__.py:1819 ../yum/__init__.py:1838 ../yum/__init__.py:1869
-#: ../yum/__init__.py:1875 ../yum/__init__.py:1948 ../yum/__init__.py:1952
+#: ../yum/__init__.py:1962 ../yum/__init__.py:1981 ../yum/__init__.py:2011
+#: ../yum/__init__.py:2017 ../yum/__init__.py:2090 ../yum/__init__.py:2094
 #, python-format
 msgid "No Group named %s exists"
 msgstr "Grupa o nazwie %s nie istnieje"
 
-#: ../yum/__init__.py:1850 ../yum/__init__.py:1965
+#: ../yum/__init__.py:1992 ../yum/__init__.py:2106
 #, python-format
 msgid "package %s was not marked in group %s"
 msgstr "pakiet %s nie został oznaczony w grupie %s"
 
-#: ../yum/__init__.py:1897
+#: ../yum/__init__.py:2038
 #, python-format
 msgid "Adding package %s from group %s"
 msgstr "Dodawanie pakietu %s z grupy %s"
 
-#: ../yum/__init__.py:1901
+#: ../yum/__init__.py:2043
 #, python-format
 msgid "No package named %s available to be installed"
 msgstr "Brak dostępnego pakietu o nazwie %s do zainstalowania"
 
-#: ../yum/__init__.py:1990
+#: ../yum/__init__.py:2131
 #, python-format
 msgid "Package tuple %s could not be found in packagesack"
 msgstr "Nie można znaleźć krotki pakietu %s w zestawie pakietów"
 
-#: ../yum/__init__.py:2005
+#: ../yum/__init__.py:2146
 msgid ""
 "getInstalledPackageObject() will go away, use self.rpmdb.searchPkgTuple().\n"
 msgstr ""
 "getInstalledPackageObject() zostanie usunięte, użyj self.rpmdb.searchPkgTuple"
 "().\n"
 
-#: ../yum/__init__.py:2057 ../yum/__init__.py:2100
+#: ../yum/__init__.py:2198 ../yum/__init__.py:2241
 msgid "Invalid versioned dependency string, try quoting it."
 msgstr "Nieprawidłowy łańcuch tekstowy wersji, spróbuj go zacytować."
 
-#: ../yum/__init__.py:2059 ../yum/__init__.py:2102
+#: ../yum/__init__.py:2200 ../yum/__init__.py:2243
 msgid "Invalid version flag"
 msgstr "Nieprawidłowa flaga wersji"
 
-#: ../yum/__init__.py:2074 ../yum/__init__.py:2078
+#: ../yum/__init__.py:2215 ../yum/__init__.py:2219
 #, python-format
 msgid "No Package found for %s"
 msgstr "Nie znaleziono pakietu %s"
 
-#: ../yum/__init__.py:2277
+#: ../yum/__init__.py:2427
 msgid "Package Object was not a package object instance"
 msgstr "Obiekt pakietu nie był instancją obiektu pakietu"
 
-#: ../yum/__init__.py:2281
+#: ../yum/__init__.py:2431
 msgid "Nothing specified to install"
 msgstr "Nie podano nic do zainstalowania"
 
 #. only one in there
-#: ../yum/__init__.py:2299
+#: ../yum/__init__.py:2449
 #, python-format
 msgid "Checking for virtual provide or file-provide for %s"
 msgstr "Sprawdzanie wirtualnych zależności lub plików dla %s"
 
-#: ../yum/__init__.py:2305 ../yum/__init__.py:2687
+#: ../yum/__init__.py:2455 ../yum/__init__.py:2853
 #, python-format
 msgid "No Match for argument: %s"
 msgstr "Brak wyników dla parametru: %s"
 
-#: ../yum/__init__.py:2371
+#: ../yum/__init__.py:2521
 #, python-format
 msgid "Package %s installed and not available"
 msgstr "Pakiet %s jest zainstalowany, ale nie jest dostępny"
 
-#: ../yum/__init__.py:2374
+#: ../yum/__init__.py:2524
 msgid "No package(s) available to install"
 msgstr "Brak pakietów dostępnych do instalacji"
 
-#: ../yum/__init__.py:2386
+#: ../yum/__init__.py:2537
 #, python-format
 msgid "Package: %s  - already in transaction set"
 msgstr "Pakiet: %s  - jest już w zestawie transakcji"
 
-#: ../yum/__init__.py:2399
+#: ../yum/__init__.py:2551
 #, python-format
 msgid "Package %s already installed and latest version"
 msgstr "Pakiet %s jest już zainstalowany w najnowszej wersji"
 
-#: ../yum/__init__.py:2406
+#: ../yum/__init__.py:2558
 #, python-format
 msgid "Package matching %s already installed. Checking for update."
 msgstr ""
 "Pakiet pasujący do %s jest już zainstalowany. Sprawdzanie aktualizacji."
 
-#: ../yum/__init__.py:2416
+#: ../yum/__init__.py:2568
 #, python-format
 msgid "Package %s is obsoleted by %s, trying to install %s instead"
 msgstr ""
 "Pakiet %s został zastąpiony przez %s, próbowanie instalacji %s zamiast niego"
 
 #. update everything (the easy case)
-#: ../yum/__init__.py:2486
+#: ../yum/__init__.py:2646
 msgid "Updating Everything"
 msgstr "Aktualizowanie wszystkiego"
 
-#: ../yum/__init__.py:2498 ../yum/__init__.py:2603 ../yum/__init__.py:2614
-#: ../yum/__init__.py:2636
+#: ../yum/__init__.py:2658 ../yum/__init__.py:2758 ../yum/__init__.py:2780
+#: ../yum/__init__.py:2802
 #, python-format
 msgid "Not Updating Package that is already obsoleted: %s.%s %s:%s-%s"
 msgstr "Przestarzały pakiet nie zostanie zaktualizowany: %s.%s %s:%s-%s"
 
-#: ../yum/__init__.py:2594
+#: ../yum/__init__.py:2749
 #, python-format
 msgid "Package is already obsoleted: %s.%s %s:%s-%s"
 msgstr "Pakiet został już zastąpiony: %s.%s %s:%s-%s"
 
-#: ../yum/__init__.py:2617 ../yum/__init__.py:2639
+#: ../yum/__init__.py:2783 ../yum/__init__.py:2805
 #, python-format
 msgid "Not Updating Package that is already updated: %s.%s %s:%s-%s"
 msgstr "Już zaktualizowany pakiet nie zostanie zaktualizowany: %s.%s %s:%s-%s"
 
-#: ../yum/__init__.py:2684
+#: ../yum/__init__.py:2850
 #, python-format
 msgid "%s"
 msgstr "%s"
 
-#: ../yum/__init__.py:2700
+#: ../yum/__init__.py:2866
 msgid "No package matched to remove"
 msgstr "Brak pasujących pakietów do usunięcia"
 
-#: ../yum/__init__.py:2734
+#: ../yum/__init__.py:2900
 #, python-format
 msgid "Cannot open file: %s. Skipping."
 msgstr "Nie można otworzyć pliku: %s. Pomijanie."
 
-#: ../yum/__init__.py:2737
+#: ../yum/__init__.py:2902
 #, python-format
 msgid "Examining %s: %s"
 msgstr "Sprawdzanie %s: %s"
 
-#: ../yum/__init__.py:2745
+#: ../yum/__init__.py:2910
 #, python-format
 msgid "Cannot add package %s to transaction. Not a compatible architecture: %s"
 msgstr "Nie można dodać pakietu %s do transakcji. Niezgodna architektura: %s"
 
-#: ../yum/__init__.py:2753
+#: ../yum/__init__.py:2918
 #, python-format
 msgid ""
 "Package %s not installed, cannot update it. Run yum install to install it "
@@ -1936,83 +1963,83 @@ msgstr ""
 "Pakiet %s nie jest zainstalowany, nie można go zaktualizować. Uruchom yum "
 "install, aby go zainstalować."
 
-#: ../yum/__init__.py:2786
+#: ../yum/__init__.py:2951
 #, python-format
 msgid "Excluding %s"
 msgstr "Wykluczanie %s"
 
-#: ../yum/__init__.py:2791
+#: ../yum/__init__.py:2955
 #, python-format
 msgid "Marking %s to be installed"
 msgstr "Oznaczanie %s do zainstalowania"
 
-#: ../yum/__init__.py:2797
+#: ../yum/__init__.py:2960
 #, python-format
 msgid "Marking %s as an update to %s"
 msgstr "Oznaczanie %s jako aktualizacji %s"
 
-#: ../yum/__init__.py:2804
+#: ../yum/__init__.py:2965
 #, python-format
 msgid "%s: does not update installed package."
 msgstr "%s: nie aktualizuj zainstalowanego pakietu."
 
-#: ../yum/__init__.py:2822
+#: ../yum/__init__.py:2982
 msgid "Problem in reinstall: no package matched to remove"
 msgstr ""
 "Podczas ponownego instalowania wystąpił problem: brak pasujących pakietów do "
 "usunięcia"
 
-#: ../yum/__init__.py:2833
+#: ../yum/__init__.py:2993
 #, python-format
 msgid "Package %s is allowed multiple installs, skipping"
 msgstr "Pakiet %s może być wielokrotnie instalowany, pomijanie"
 
-#: ../yum/__init__.py:2840
+#: ../yum/__init__.py:3000
 msgid "Problem in reinstall: no package matched to install"
 msgstr ""
 "Podczas ponownego instalowania wystąpił problem: brak pasujących pakietów do "
 "zainstalowania"
 
-#: ../yum/__init__.py:2875
+#: ../yum/__init__.py:3035
 #, python-format
 msgid "Retrieving GPG key from %s"
 msgstr "Pobieranie klucza GPG z %s"
 
-#: ../yum/__init__.py:2895
+#: ../yum/__init__.py:3055
 msgid "GPG key retrieval failed: "
 msgstr "Pobranie klucza GPG nie powiodło się: "
 
-#: ../yum/__init__.py:2906
+#: ../yum/__init__.py:3066
 #, python-format
 msgid "GPG key parsing failed: key does not have value %s"
 msgstr ""
 "Przeanalizowanie klucza GPG nie powiodło się: klucz nie posiada wartości %s"
 
-#: ../yum/__init__.py:2938
+#: ../yum/__init__.py:3098
 #, python-format
 msgid "GPG key at %s (0x%s) is already installed"
 msgstr "Klucz GPG %s (0x%s) jest już zainstalowany"
 
 #. Try installing/updating GPG key
-#: ../yum/__init__.py:2943 ../yum/__init__.py:3005
+#: ../yum/__init__.py:3103 ../yum/__init__.py:3164
 #, python-format
 msgid "Importing GPG key 0x%s \"%s\" from %s"
 msgstr "Importowanie klucza GPG 0x%s \"%s\" z %s"
 
-#: ../yum/__init__.py:2960
+#: ../yum/__init__.py:3119
 msgid "Not installing key"
 msgstr "Klucz nie zostanie zainstalowany"
 
-#: ../yum/__init__.py:2966
+#: ../yum/__init__.py:3125
 #, python-format
 msgid "Key import failed (code %d)"
 msgstr "Zaimportowanie klucza nie powiodło się (kod %d)"
 
-#: ../yum/__init__.py:2967 ../yum/__init__.py:3026
+#: ../yum/__init__.py:3126 ../yum/__init__.py:3186
 msgid "Key imported successfully"
 msgstr "Klucz został pomyślnie zaimportowany"
 
-#: ../yum/__init__.py:2972 ../yum/__init__.py:3031
+#: ../yum/__init__.py:3131 ../yum/__init__.py:3191
 #, python-format
 msgid ""
 "The GPG keys listed for the \"%s\" repository are already installed but they "
@@ -2024,73 +2051,78 @@ msgstr ""
 "Sprawdź, czy dla tego repozytorium skonfigurowane są poprawne adresy do "
 "kluczy."
 
-#: ../yum/__init__.py:2981
+#: ../yum/__init__.py:3140
 msgid "Import of key(s) didn't help, wrong key(s)?"
 msgstr "Zaimportowanie kluczy nie pomogło, błędne klucze?"
 
-#: ../yum/__init__.py:3000
+#: ../yum/__init__.py:3159
 #, python-format
 msgid "GPG key at %s (0x%s) is already imported"
 msgstr "Klucz GPG %s (0x%s) został już zaimportowany"
 
-#: ../yum/__init__.py:3020
+#: ../yum/__init__.py:3178
 #, python-format
 msgid "Not installing key for repo %s"
 msgstr "Klucz dla repozytorium %s nie zostanie zainstalowany"
 
-#: ../yum/__init__.py:3025
+#: ../yum/__init__.py:3185
 msgid "Key import failed"
 msgstr "Zaimportowanie klucza nie powiodło się"
 
-#: ../yum/__init__.py:3116
+#: ../yum/__init__.py:3275
 msgid "Unable to find a suitable mirror."
 msgstr "Nie można znaleźć odpowiedniego serwera lustrzanego."
 
-#: ../yum/__init__.py:3118
+#: ../yum/__init__.py:3277
 msgid "Errors were encountered while downloading packages."
 msgstr "Podczas pobierania pakietów wystąpiły błędy."
 
-#: ../yum/__init__.py:3182
+#: ../yum/__init__.py:3317
+#, python-format
+msgid "Please report this error at %s"
+msgstr "Zgłoś ten błąd na %s"
+
+#: ../yum/__init__.py:3341
 msgid "Test Transaction Errors: "
 msgstr "Błędy testu transakcji: "
 
 #. Mostly copied from YumOutput._outKeyValFill()
-#: ../yum/plugins.py:199
+#: ../yum/plugins.py:201
 msgid "Loaded plugins: "
 msgstr "Wczytane wtyczki: "
 
-#: ../yum/plugins.py:213 ../yum/plugins.py:219
+#: ../yum/plugins.py:215 ../yum/plugins.py:221
 #, python-format
 msgid "No plugin match for: %s"
 msgstr "Brak wyników dla wtyczki: %s"
 
-#: ../yum/plugins.py:249
+#: ../yum/plugins.py:251
 #, python-format
 msgid "\"%s\" plugin is disabled"
 msgstr "Wtyczka \"%s\" jest wyłączona"
 
 #. Give full backtrace:
-#: ../yum/plugins.py:261
+#: ../yum/plugins.py:263
 #, python-format
 msgid "Plugin \"%s\" can't be imported"
 msgstr "Nie można zaimportować wtyczki \"%s\""
 
-#: ../yum/plugins.py:268
+#: ../yum/plugins.py:270
 #, python-format
 msgid "Plugin \"%s\" doesn't specify required API version"
 msgstr "Wtyczka \"%s\" nie określa wymaganej wersji API"
 
-#: ../yum/plugins.py:273
+#: ../yum/plugins.py:275
 #, python-format
 msgid "Plugin \"%s\" requires API %s. Supported API is %s."
 msgstr "Wtyczka \"%s\" wymaga API %s. Obsługiwane API to %s."
 
-#: ../yum/plugins.py:306
+#: ../yum/plugins.py:308
 #, python-format
 msgid "Loading \"%s\" plugin"
 msgstr "Wczytywanie wtyczki \"%s\""
 
-#: ../yum/plugins.py:313
+#: ../yum/plugins.py:315
 #, python-format
 msgid ""
 "Two or more plugins with the name \"%s\" exist in the plugin search path"
@@ -2098,19 +2130,19 @@ msgstr ""
 "Istnieją dwie lub więcej wtyczek o nazwie \"%s\" w ścieżce wyszukiwania "
 "wtyczek"
 
-#: ../yum/plugins.py:333
+#: ../yum/plugins.py:335
 #, python-format
 msgid "Configuration file %s not found"
 msgstr "Nie znaleziono pliku konfiguracji %s"
 
 #. for
 #. Configuration files for the plugin not found
-#: ../yum/plugins.py:336
+#: ../yum/plugins.py:338
 #, python-format
 msgid "Unable to find configuration file for plugin %s"
 msgstr "Nie można naleźć pliku konfiguracji dla wtyczki %s"
 
-#: ../yum/plugins.py:490
+#: ../yum/plugins.py:492
 msgid "registration of commands not supported"
 msgstr "rejestracja poleceń nie jest obsługiwana"
 
@@ -2146,4 +2178,4 @@ msgstr "Uszkodzony nagłówek %s"
 #: ../rpmUtils/oldUtils.py:272
 #, python-format
 msgid "Error opening rpm %s - error %s"
-msgstr "Błąd podczas otwierania RPM-a %s - błąd %s"
+msgstr "Błąd podczas otwierania pakietu RPM %s - błąd %s"
diff --git a/po/pt_BR.po b/po/pt_BR.po
index 919c002..fe1a944 100644
--- a/po/pt_BR.po
+++ b/po/pt_BR.po
@@ -6,8 +6,8 @@ msgid ""
 msgstr ""
 "Project-Id-Version: Yum\n"
 "Report-Msgid-Bugs-To: \n"
-"POT-Creation-Date: 2008-03-25 11:29+0100\n"
-"PO-Revision-Date: 2008-04-12 00:41-0300\n"
+"POT-Creation-Date: 2008-12-16 01:25+0000\n"
+"PO-Revision-Date: 2008-12-16 00:40-0300\n"
 "Last-Translator: Igor Pires Soares <igor@projetofedora.org>\n"
 "Language-Team: Brazilian Portuguese <fedora-trans-pt_br@redhat.com>\n"
 "MIME-Version: 1.0\n"
@@ -17,23 +17,35 @@ msgstr ""
 "X-Poedit-Language: Portuguese\n"
 "X-Poedit-Country: BRAZIL\n"
 
-#: ../callback.py:48 ../output.py:512
+#: ../callback.py:48
+#: ../output.py:911
+#: ../yum/rpmtrans.py:71
 msgid "Updating"
 msgstr "Atualizando"
 
 #: ../callback.py:49
+#: ../yum/rpmtrans.py:72
 msgid "Erasing"
 msgstr "Apagando"
 
-#: ../callback.py:50 ../callback.py:51 ../callback.py:53 ../output.py:511
+#: ../callback.py:50
+#: ../callback.py:51
+#: ../callback.py:53
+#: ../output.py:910
+#: ../yum/rpmtrans.py:73
+#: ../yum/rpmtrans.py:74
+#: ../yum/rpmtrans.py:76
 msgid "Installing"
 msgstr "Instalando"
 
-#: ../callback.py:52 ../callback.py:58
+#: ../callback.py:52
+#: ../callback.py:58
+#: ../yum/rpmtrans.py:75
 msgid "Obsoleted"
 msgstr "Obsoletos"
 
-#: ../callback.py:54 ../output.py:558
+#: ../callback.py:54
+#: ../output.py:1016
 msgid "Updated"
 msgstr "Atualizados"
 
@@ -41,7 +53,10 @@ msgstr "Atualizados"
 msgid "Erased"
 msgstr "Removidos"
 
-#: ../callback.py:56 ../callback.py:57 ../callback.py:59 ../output.py:556
+#: ../callback.py:56
+#: ../callback.py:57
+#: ../callback.py:59
+#: ../output.py:1014
 msgid "Installed"
 msgstr "Instalados"
 
@@ -51,7 +66,7 @@ msgstr "Sem cabeçalho - huh?"
 
 #: ../callback.py:168
 msgid "Repackage"
-msgstr "Reempacotados"
+msgstr "Reempacotar"
 
 #: ../callback.py:189
 #, python-format
@@ -63,491 +78,580 @@ msgstr "Erro: estado de saída inválido: %s de %s"
 msgid "Erased: %s"
 msgstr "Removidos: %s"
 
-#: ../callback.py:217 ../output.py:513
+#: ../callback.py:217
+#: ../output.py:912
 msgid "Removing"
 msgstr "Removendo"
 
 #: ../callback.py:219
+#: ../yum/rpmtrans.py:77
 msgid "Cleanup"
 msgstr "Limpeza"
 
-#: ../cli.py:103
+#: ../cli.py:105
 #, python-format
 msgid "Command \"%s\" already defined"
 msgstr "Comando \"%s\" já definido"
 
-#: ../cli.py:115
+#: ../cli.py:117
 msgid "Setting up repositories"
 msgstr "Configurando repositórios"
 
-#: ../cli.py:126
+#: ../cli.py:128
 msgid "Reading repository metadata in from local files"
 msgstr "Lendo metadados do repositório a partir dos arquivos locais"
 
-#: ../cli.py:183 ../utils.py:72
+#: ../cli.py:187
+#: ../utils.py:79
 #, python-format
 msgid "Config Error: %s"
-msgstr "Erro de Configuração: %s"
+msgstr "Erro de configuração: %s"
 
-#: ../cli.py:186 ../cli.py:1068 ../utils.py:75
+#: ../cli.py:190
+#: ../cli.py:1174
+#: ../utils.py:82
 #, python-format
 msgid "Options Error: %s"
-msgstr "Erro nas Opções: %s"
+msgstr "Erro nas opções: %s"
 
-#: ../cli.py:229
+#: ../cli.py:218
+#, python-format
+msgid "  Installed: %s-%s at %s"
+msgstr "  Instalados: %s-%s em %s"
+
+#: ../cli.py:220
+#, python-format
+msgid "  Built    : %s at %s"
+msgstr "  Construídos    : %s em %s"
+
+#: ../cli.py:222
+#, python-format
+msgid "  Committed: %s at %s"
+msgstr "  Enviados: %s em %s"
+
+#: ../cli.py:259
 msgid "You need to give some command"
 msgstr "Você precisa dar algum comando"
 
-#: ../cli.py:271
+#: ../cli.py:301
 msgid "Disk Requirements:\n"
-msgstr "Requerimentos de Disco:\n"
+msgstr "Requisitos de disco:\n"
 
-#: ../cli.py:273
+#: ../cli.py:303
 #, python-format
 msgid "  At least %dMB needed on the %s filesystem.\n"
 msgstr "  Pelo menos %d MB são necessários no sistema de arquivos %s.\n"
 
 #. TODO: simplify the dependency errors?
 #. Fixup the summary
-#: ../cli.py:278
+#: ../cli.py:308
 msgid ""
 "Error Summary\n"
 "-------------\n"
 msgstr ""
-"Sumário de Erros\n"
+"Sumário de erros\n"
 "-------------\n"
 
-#: ../cli.py:317
+#: ../cli.py:351
 msgid "Trying to run the transaction but nothing to do. Exiting."
 msgstr "Tentando executar a transação, mas não há nada a ser feito. Saindo."
 
-#: ../cli.py:347
+#: ../cli.py:381
 msgid "Exiting on user Command"
 msgstr "Saindo pelo comando do usuário"
 
-#: ../cli.py:351
+#: ../cli.py:385
 msgid "Downloading Packages:"
-msgstr "Baixando Pacotes:"
+msgstr "Baixando pacotes:"
 
-#: ../cli.py:356
+#: ../cli.py:390
 msgid "Error Downloading Packages:\n"
-msgstr "Erro ao Baixar Pacotes:\n"
+msgstr "Erro ao baixar pacotes:\n"
+
+#: ../cli.py:402
+msgid "Entering rpm code"
+msgstr "Entrando no código rpm"
 
-#: ../cli.py:370 ../yum/__init__.py:2746
+#: ../cli.py:406
+#: ../yum/__init__.py:3330
 msgid "Running rpm_check_debug"
 msgstr "Executando o rpm_check_debug"
 
-#: ../cli.py:373 ../yum/__init__.py:2749
+#: ../cli.py:409
+#: ../yum/__init__.py:3333
 msgid "ERROR with rpm_check_debug vs depsolve:"
 msgstr "Erro com o rpm_check_debug vs depsolve:"
 
-#: ../cli.py:377 ../yum/__init__.py:2751
-msgid "Please report this error in bugzilla"
-msgstr "Por favor, reporte esse erro ao bugzilla"
+#: ../cli.py:413
+#, python-format
+msgid "Please report this error in %s"
+msgstr "Por favor, relate esse erro em %s"
 
-#: ../cli.py:383
+#: ../cli.py:419
 msgid "Running Transaction Test"
-msgstr "Executando Teste de Transação"
+msgstr "Executando teste de transação"
 
-#: ../cli.py:399
+#: ../cli.py:435
 msgid "Finished Transaction Test"
-msgstr "Teste de Transação Finalizado"
+msgstr "Teste de transação finalizado"
 
-#: ../cli.py:401
+#: ../cli.py:437
 msgid "Transaction Check Error:\n"
-msgstr "Erro na Verificação da Transação:\n"
+msgstr "Erro na verificação da transação:\n"
 
-#: ../cli.py:408
+#: ../cli.py:444
 msgid "Transaction Test Succeeded"
-msgstr "Teste de Transação Completo"
+msgstr "Teste de transação completo"
 
-#: ../cli.py:429
+#: ../cli.py:465
 msgid "Running Transaction"
-msgstr "Executando a Transação"
+msgstr "Executando a transação"
+
+#: ../cli.py:470
+msgid "Leaving rpm code"
+msgstr "Saindo do código rpm"
 
-#: ../cli.py:459
+#: ../cli.py:497
 msgid ""
 "Refusing to automatically import keys when running unattended.\n"
 "Use \"-y\" to override."
 msgstr ""
-"Recusa de importação automática das chaves ao executar de forma não "
-"assistida.\n"
+"Recusa de importação automática das chaves ao executar de forma não assistida.\n"
 "Use \"-y\" para sobrescrever."
 
-#: ../cli.py:491
-msgid "Parsing package install arguments"
-msgstr "Analisando argumentos da instalação de pacotes"
+#: ../cli.py:516
+#: ../cli.py:550
+msgid "  * Maybe you meant: "
+msgstr "  * Talvez você queira dizer: "
 
-#: ../cli.py:501
+#: ../cli.py:533
+#: ../cli.py:541
 #, python-format
-msgid "No package %s available."
-msgstr "Nenhum pacote %s disponível."
+msgid "Package(s) %s%s%s available, but not installed."
+msgstr "Pacotes %s%s%s disponíveis, mas já instalados."
+
+#: ../cli.py:547
+#: ../cli.py:582
+#, python-format
+msgid "No package %s%s%s available."
+msgstr "Nenhum pacote %s%s%s disponível."
+
+#: ../cli.py:572
+msgid "Parsing package install arguments"
+msgstr "Analisando argumentos da instalação de pacotes"
 
-#: ../cli.py:505 ../cli.py:623 ../yumcommands.py:748
+#: ../cli.py:587
+#: ../cli.py:662
+#: ../yumcommands.py:984
 msgid "Package(s) to install"
 msgstr "Pacotes a serem instalados"
 
-#: ../cli.py:506 ../cli.py:624 ../yumcommands.py:146 ../yumcommands.py:749
+#: ../cli.py:588
+#: ../cli.py:663
+#: ../yumcommands.py:151
+#: ../yumcommands.py:985
 msgid "Nothing to do"
 msgstr "Nada a ser feito"
 
-#: ../cli.py:536 ../yum/__init__.py:2232 ../yum/__init__.py:2311
-#: ../yum/__init__.py:2340
-#, python-format
-msgid "Not Updating Package that is already obsoleted: %s.%s %s:%s-%s"
-msgstr "Pacote já obsoleto não será atualizado: %s.%s %s:%s-%s"
-
-#: ../cli.py:568
-#, python-format
-msgid "Could not find update match for %s"
-msgstr "Não foi possível encontrar uma atualização correspondente ao %s"
-
-#: ../cli.py:580
+#: ../cli.py:621
 #, python-format
 msgid "%d packages marked for Update"
 msgstr "%d pacotes marcados para atualização"
 
-#: ../cli.py:583
+#: ../cli.py:624
 msgid "No Packages marked for Update"
 msgstr "Nenhum pacote marcado para atualização"
 
-#: ../cli.py:599
+#: ../cli.py:638
 #, python-format
 msgid "%d packages marked for removal"
 msgstr "%d pacotes marcados para remoção"
 
-#: ../cli.py:602
+#: ../cli.py:641
 msgid "No Packages marked for removal"
 msgstr "Nenhum pacote marcado para remoção"
 
-#: ../cli.py:614
+#: ../cli.py:653
 msgid "No Packages Provided"
-msgstr "Nenhum Pacote Fornecido"
+msgstr "Nenhum pacote fornecido"
 
-#: ../cli.py:654
+#: ../cli.py:708
 msgid "Matching packages for package list to user args"
-msgstr ""
-"Resultado dos pacotes para a lista de pacotes dos argumentos do usuário"
+msgstr "Resultado dos pacotes para a lista de pacotes dos argumentos do usuário"
 
-#: ../cli.py:701
+#: ../cli.py:757
 #, python-format
 msgid "Warning: No matches found for: %s"
-msgstr "Aviso: Nenhum resultado para: %s"
+msgstr "Aviso: nenhum resultado para: %s"
 
-#: ../cli.py:704
+#: ../cli.py:760
 msgid "No Matches found"
-msgstr "Nenhum pacote encontrado"
+msgstr "Nenhum pacote localizado"
 
-#: ../cli.py:745
+#: ../cli.py:799
+#, python-format
+msgid ""
+"Warning: 3.0.x versions of yum would erronously match against filenames.\n"
+" You can use \"%s*/%s%s\" and/or \"%s*bin/%s%s\" to get that behaviour"
+msgstr ""
+"Aviso: as versões 3.0.x do yum iriam corresponder erroneamente pelos nomes de arquivos\n"
+" Você pode usar \"%s*/%s%s\" e/ou \"%s*bin/%s%s\" para obter esse comportamento"
+
+#: ../cli.py:815
 #, python-format
 msgid "No Package Found for %s"
-msgstr "Nenhum Pacote Encontrado para %s"
+msgstr "Nenhum pacote localizado para %s"
 
-#: ../cli.py:757
+#: ../cli.py:827
 msgid "Cleaning up Everything"
-msgstr "Limpando Tudo"
+msgstr "Limpando tudo"
 
-#: ../cli.py:771
+#: ../cli.py:841
 msgid "Cleaning up Headers"
-msgstr "Limpando Cabeçalhos"
+msgstr "Limpando cabeçalhos"
 
-#: ../cli.py:774
+#: ../cli.py:844
 msgid "Cleaning up Packages"
-msgstr "Limpando Pacotes"
+msgstr "Limpando pacotes"
 
-#: ../cli.py:777
+#: ../cli.py:847
 msgid "Cleaning up xml metadata"
 msgstr "Limpando metadados em xml"
 
-#: ../cli.py:780
+#: ../cli.py:850
 msgid "Cleaning up database cache"
 msgstr "Limpando cache do banco de dados"
 
-#: ../cli.py:783
+#: ../cli.py:853
 msgid "Cleaning up expire-cache metadata"
 msgstr "Limpando metadados expirados do cache"
 
-#: ../cli.py:786
+#: ../cli.py:856
 msgid "Cleaning up plugins"
 msgstr "Limpando plugins"
 
-#: ../cli.py:807
+#: ../cli.py:881
 msgid "Installed Groups:"
-msgstr "Grupos Instalados:"
+msgstr "Grupos instalados:"
 
-#: ../cli.py:814
+#: ../cli.py:888
 msgid "Available Groups:"
-msgstr "Grupos Disponíveis:"
+msgstr "Grupos disponíveis:"
 
-#: ../cli.py:820
+#: ../cli.py:894
 msgid "Done"
 msgstr "Concluído"
 
-#: ../cli.py:829 ../cli.py:841 ../cli.py:847
+#: ../cli.py:905
+#: ../cli.py:923
+#: ../cli.py:929
+#: ../yum/__init__.py:2388
 #, python-format
 msgid "Warning: Group %s does not exist."
 msgstr "Aviso: O grupo %s não existe."
 
-#: ../cli.py:853
+#: ../cli.py:933
 msgid "No packages in any requested group available to install or update"
-msgstr ""
-"Nenhum pacote disponível para instalação ou atualização nos grupos "
-"requisitados"
+msgstr "Nenhum pacote disponível para instalação ou atualização nos grupos requisitados"
 
-#: ../cli.py:855
+#: ../cli.py:935
 #, python-format
 msgid "%d Package(s) to Install"
-msgstr "%d Pacote(s) a Ser(em) Instalado(s)"
+msgstr "%d pacote(s) a ser(em) instalado(s)"
 
-#: ../cli.py:865
+#: ../cli.py:945
+#: ../yum/__init__.py:2400
 #, python-format
 msgid "No group named %s exists"
 msgstr "Nenhum grupo de nome %s existe"
 
-#: ../cli.py:871
+#: ../cli.py:951
 msgid "No packages to remove from groups"
 msgstr "Nenhum pacote a ser removido a partir dos grupos"
 
-#: ../cli.py:873
+#: ../cli.py:953
 #, python-format
 msgid "%d Package(s) to remove"
-msgstr "%d Pacote(s) a Ser(em) Removido(s)"
+msgstr "%d pacote(s) a ser(em) removido(s)"
 
-#: ../cli.py:915
+#: ../cli.py:995
 #, python-format
 msgid "Package %s is already installed, skipping"
 msgstr "O pacote %s já está instalado, ignorando"
 
-#: ../cli.py:926
+#: ../cli.py:1006
 #, python-format
 msgid "Discarding non-comparable pkg %s.%s"
 msgstr "Descartando pacote não comparável %s.%s"
 
 #. we've not got any installed that match n or n+a
-#: ../cli.py:952
+#: ../cli.py:1032
 #, python-format
 msgid "No other %s installed, adding to list for potential install"
-msgstr ""
-"Nenhum outro %s instalado, adicionado à lista para potencial instalação"
+msgstr "Nenhum outro %s instalado, adicionado à lista para potencial instalação"
 
-#: ../cli.py:971
+#: ../cli.py:1051
 #, python-format
 msgid "Command line error: %s"
 msgstr "Erro na linha de comando: %s"
 
-#: ../cli.py:1101
+#: ../cli.py:1064
+#, python-format
+msgid ""
+"\n"
+"\n"
+"%s: %s option requires an argument"
+msgstr ""
+"\n"
+"\n"
+"%s: a opção %s requer um argumento"
+
+#: ../cli.py:1114
+msgid "--color takes one of: auto, always, never"
+msgstr "--color aceita uma destas opções: auto, always, never"
+
+#: ../cli.py:1216
+msgid "show this help message and exit"
+msgstr "mostrar essa mensagem ajuda e sai"
+
+#: ../cli.py:1220
 msgid "be tolerant of errors"
 msgstr "ser tolerante com os erros"
 
-#: ../cli.py:1103
+#: ../cli.py:1222
 msgid "run entirely from cache, don't update cache"
 msgstr "executar por completo a partir do cache, não atualiza o cache"
 
-#: ../cli.py:1105
+#: ../cli.py:1224
 msgid "config file location"
 msgstr "configurar localização do arquivo"
 
-#: ../cli.py:1107
+#: ../cli.py:1226
 msgid "maximum command wait time"
 msgstr "Tempo máximo de espera do comando"
 
-#: ../cli.py:1109
+#: ../cli.py:1228
 msgid "debugging output level"
 msgstr "nível de depuração na saída"
 
-#: ../cli.py:1113
+#: ../cli.py:1232
 msgid "show duplicates, in repos, in list/search commands"
 msgstr "mostrar duplicados em repos e em comandos de pesquisa/listagem"
 
-#: ../cli.py:1115
+#: ../cli.py:1234
 msgid "error output level"
 msgstr "nível de erro na saída"
 
-#: ../cli.py:1118
+#: ../cli.py:1237
 msgid "quiet operation"
 msgstr "operação discreta"
 
-#: ../cli.py:1122
+#: ../cli.py:1239
+msgid "verbose operation"
+msgstr "operação detalhada"
+
+#: ../cli.py:1241
 msgid "answer yes for all questions"
 msgstr "responder sim para todas as perguntas"
 
-#: ../cli.py:1124
+#: ../cli.py:1243
 msgid "show Yum version and exit"
 msgstr "mostrar versão do Yum ao sair"
 
-#: ../cli.py:1125
+#: ../cli.py:1244
 msgid "set install root"
 msgstr "definir raiz de instalação"
 
-#: ../cli.py:1129
+#: ../cli.py:1248
 msgid "enable one or more repositories (wildcards allowed)"
 msgstr "habilitar um ou mais repositórios (curingas são permitidos)"
 
-#: ../cli.py:1133
+#: ../cli.py:1252
 msgid "disable one or more repositories (wildcards allowed)"
 msgstr "desabilitar um ou mais repositórios (curingas são permitidos)"
 
-#: ../cli.py:1136
+#: ../cli.py:1255
 msgid "exclude package(s) by name or glob"
 msgstr "excluir pacote(s) por nome ou glob"
 
-#: ../cli.py:1138
+#: ../cli.py:1257
 msgid "disable exclude from main, for a repo or for everything"
-msgstr ""
-"desabilitar a exclusão a partir do principal, para um repositório ou para "
-"tudo"
+msgstr "desabilitar a exclusão a partir do principal, para um repositório ou para tudo"
 
-#: ../cli.py:1141
+#: ../cli.py:1260
 msgid "enable obsoletes processing during updates"
 msgstr "Habilitar processo de obsolescência durante as atualizações"
 
-#: ../cli.py:1143
+#: ../cli.py:1262
 msgid "disable Yum plugins"
 msgstr "desabilitar plugins do Yum"
 
-#: ../cli.py:1145
+#: ../cli.py:1264
 msgid "disable gpg signature checking"
 msgstr "desabilitar verificação de assinaturas gpg"
 
-#: ../cli.py:1147
+#: ../cli.py:1266
 msgid "disable plugins by name"
 msgstr "desabilitar plugins pelo nome"
 
-#: ../cli.py:1150
+#: ../cli.py:1269
+msgid "enable plugins by name"
+msgstr "habilita plugins pelo nome"
+
+#: ../cli.py:1272
 msgid "skip packages with depsolving problems"
 msgstr "ignorar pacotes com problemas de solução de dependências"
 
-#: ../output.py:229
+#: ../cli.py:1274
+msgid "control whether color is used"
+msgstr "controla o uso da cor"
+
+#: ../output.py:300
 msgid "Jan"
 msgstr "Jan"
 
-#: ../output.py:229
+#: ../output.py:300
 msgid "Feb"
 msgstr "Fev"
 
-#: ../output.py:229
+#: ../output.py:300
 msgid "Mar"
 msgstr "Mar"
 
-#: ../output.py:229
+#: ../output.py:300
 msgid "Apr"
 msgstr "Abr"
 
-#: ../output.py:229
+#: ../output.py:300
 msgid "May"
 msgstr "Mai"
 
-#: ../output.py:229
+#: ../output.py:300
 msgid "Jun"
 msgstr "Jun"
 
-#: ../output.py:230
+#: ../output.py:301
 msgid "Jul"
 msgstr "Jul"
 
-#: ../output.py:230
+#: ../output.py:301
 msgid "Aug"
 msgstr "Ago"
 
-#: ../output.py:230
+#: ../output.py:301
 msgid "Sep"
 msgstr "Set"
 
-#: ../output.py:230
+#: ../output.py:301
 msgid "Oct"
 msgstr "Out"
 
-#: ../output.py:230
+#: ../output.py:301
 msgid "Nov"
 msgstr "Nov"
 
-#: ../output.py:230
+#: ../output.py:301
 msgid "Dec"
 msgstr "Dez"
 
-#: ../output.py:240
+#: ../output.py:311
 msgid "Trying other mirror."
 msgstr "Tentando outro espelho."
 
-#: ../output.py:293
+#: ../output.py:527
 #, python-format
-msgid "Name       : %s"
-msgstr "Nome       : %s"
+msgid "Name       : %s%s%s"
+msgstr "Nome       : %s%s%s"
 
-#: ../output.py:294
+#: ../output.py:528
 #, python-format
 msgid "Arch       : %s"
 msgstr "Arq.   : %s"
 
-#: ../output.py:296
+#: ../output.py:530
 #, python-format
 msgid "Epoch      : %s"
 msgstr "Período      : %s"
 
-#: ../output.py:297
+#: ../output.py:531
 #, python-format
 msgid "Version    : %s"
 msgstr "Versão    : %s"
 
-#: ../output.py:298
+#: ../output.py:532
 #, python-format
 msgid "Release    : %s"
 msgstr "Lançamento  : %s"
 
-#: ../output.py:299
+#: ../output.py:533
 #, python-format
 msgid "Size       : %s"
 msgstr "Tamanho   : %s"
 
-#: ../output.py:300
+#: ../output.py:534
 #, python-format
 msgid "Repo       : %s"
 msgstr "Repo       : %s"
 
-#: ../output.py:302
+#: ../output.py:536
 #, python-format
 msgid "Committer  : %s"
 msgstr "Enviado por  : %s"
 
-#: ../output.py:303
+#: ../output.py:537
+#, python-format
+msgid "Committime : %s"
+msgstr "Horário do envio : %s"
+
+#: ../output.py:538
+#, python-format
+msgid "Buildtime  : %s"
+msgstr "Horário da construção  : %s"
+
+#: ../output.py:540
+#, python-format
+msgid "Installtime: %s"
+msgstr "Horário da instalação: %s"
+
+#: ../output.py:541
 msgid "Summary    : "
 msgstr "Sumário    : "
 
-#: ../output.py:305
+#: ../output.py:543
 #, python-format
 msgid "URL        : %s"
 msgstr "URL        : %s"
 
-#: ../output.py:306
+#: ../output.py:544
 #, python-format
 msgid "License    : %s"
 msgstr "Licença   : %s"
 
-#: ../output.py:307
+#: ../output.py:545
 msgid "Description: "
 msgstr "Descrição: "
 
-#: ../output.py:351
-msgid "Is this ok [y/N]: "
-msgstr "Correto? [s/N]:"
-
-#: ../output.py:357 ../output.py:360
+#: ../output.py:609
 msgid "y"
 msgstr "s"
 
-#: ../output.py:357
-msgid "n"
-msgstr "n"
-
-#: ../output.py:357 ../output.py:360
+#: ../output.py:609
 msgid "yes"
 msgstr "sim"
 
-#: ../output.py:357
+#: ../output.py:610
+msgid "n"
+msgstr "n"
+
+#: ../output.py:610
 msgid "no"
 msgstr "não"
 
-#: ../output.py:367
+#: ../output.py:614
+msgid "Is this ok [y/N]: "
+msgstr "Correto? [s/N]:"
+
+#: ../output.py:702
 #, python-format
 msgid ""
 "\n"
@@ -556,96 +660,129 @@ msgstr ""
 "\n"
 "Grupo: %s"
 
-#: ../output.py:369
+#: ../output.py:709
 #, python-format
 msgid " Description: %s"
 msgstr " Descrição: %s"
 
-#: ../output.py:371
+#: ../output.py:711
 msgid " Mandatory Packages:"
-msgstr " Pacotes Obrigatórios:"
+msgstr " Pacotes obrigatórios:"
 
-#: ../output.py:376
+#: ../output.py:712
 msgid " Default Packages:"
-msgstr " Pacotes Padrão:"
+msgstr " Pacotes padrão:"
 
-#: ../output.py:381
+#: ../output.py:713
 msgid " Optional Packages:"
-msgstr " Pacotes Opcionais:"
+msgstr " Pacotes opcionais:"
 
-#: ../output.py:386
+#: ../output.py:714
 msgid " Conditional Packages:"
-msgstr " Pacotes Condicionais:"
+msgstr " Pacotes condicionais:"
 
-#: ../output.py:394
+#: ../output.py:734
 #, python-format
 msgid "package: %s"
 msgstr "pacote: %s"
 
-#: ../output.py:396
+#: ../output.py:736
 msgid "  No dependencies for this package"
 msgstr "  Nenhuma dependência para este pacote"
 
-#: ../output.py:401
+#: ../output.py:741
 #, python-format
 msgid "  dependency: %s"
 msgstr "  dependência: %s"
 
-#: ../output.py:403
+#: ../output.py:743
 msgid "   Unsatisfied dependency"
 msgstr "   Dependência não satisfeita"
 
-#: ../output.py:461
+#: ../output.py:815
+#, python-format
+msgid "Repo        : %s"
+msgstr "Repo        : %s"
+
+#: ../output.py:816
 msgid "Matched from:"
 msgstr "Resultado a partir de:"
 
-#: ../output.py:487
+#: ../output.py:824
+msgid "Description : "
+msgstr "Descrição : "
+
+#: ../output.py:827
+#, python-format
+msgid "URL         : %s"
+msgstr "URL         : %s"
+
+#: ../output.py:830
+#, python-format
+msgid "License     : %s"
+msgstr "Licença     : %s"
+
+#: ../output.py:833
+#, python-format
+msgid "Filename    : %s"
+msgstr "Nome de arquivo    : %s"
+
+#: ../output.py:837
+msgid "Other       : "
+msgstr "Outro       : "
+
+#: ../output.py:870
 msgid "There was an error calculating total download size"
 msgstr "Houve um erro no cálculo do tamanho total do download"
 
-#: ../output.py:492
+#: ../output.py:875
 #, python-format
 msgid "Total size: %s"
 msgstr "Tamanho total: %s"
 
-#: ../output.py:495
+#: ../output.py:878
 #, python-format
 msgid "Total download size: %s"
 msgstr "Tamanho total do download: %s"
 
-#: ../output.py:507
+#: ../output.py:913
+msgid "Installing for dependencies"
+msgstr "Instalando para as dependências"
+
+#: ../output.py:914
+msgid "Updating for dependencies"
+msgstr "Atualizando para as dependências"
+
+#: ../output.py:915
+msgid "Removing for dependencies"
+msgstr "Removendo para as dependências"
+
+#: ../output.py:922
+#: ../output.py:1018
+msgid "Skipped (dependency problems)"
+msgstr "Ignorado (problemas de dependências)"
+
+#: ../output.py:943
 msgid "Package"
 msgstr "Pacote"
 
-#: ../output.py:507
+#: ../output.py:943
 msgid "Arch"
 msgstr "Arq."
 
-#: ../output.py:507
+#: ../output.py:944
 msgid "Version"
 msgstr "Versão"
 
-#: ../output.py:507
+#: ../output.py:944
 msgid "Repository"
-msgstr "Repositório"
+msgstr "Repo"
 
-#: ../output.py:507
+#: ../output.py:945
 msgid "Size"
 msgstr "Tamanho"
 
-#: ../output.py:514
-msgid "Installing for dependencies"
-msgstr "Instalando para as dependências"
-
-#: ../output.py:515
-msgid "Updating for dependencies"
-msgstr "Atualizando para as dependências"
-
-#: ../output.py:516
-msgid "Removing for dependencies"
-msgstr "Removendo para as dependências"
-
-#: ../output.py:528
+#: ../output.py:956
 #, python-format
 msgid ""
 "     replacing  %s.%s %s\n"
@@ -654,127 +791,126 @@ msgstr ""
 "     substituindo  %s.%s %s\n"
 "\n"
 
-#: ../output.py:536
+#: ../output.py:964
 #, python-format
 msgid ""
 "\n"
 "Transaction Summary\n"
-"=============================================================================\n"
+"%s\n"
 "Install  %5.5s Package(s)         \n"
 "Update   %5.5s Package(s)         \n"
 "Remove   %5.5s Package(s)         \n"
 msgstr ""
 "\n"
-"Sumário da Transação\n"
-"=============================================================================\n"
-"Instalar  %5.5s Pacote(s)         \n"
-"Atualizar   %5.5s Pacote(s)         \n"
-"Remover   %5.5s Pacote(s)         \n"
+"Sumário da transação\n"
+"%s\n"
+"Instalar  %5.5s pacote(s)         \n"
+"Atualizar   %5.5s pacote(s)         \n"
+"Remover   %5.5s pacote(s)         \n"
 
-#: ../output.py:554
+#: ../output.py:1012
 msgid "Removed"
-msgstr "Removidos"
+msgstr "Removido(s)"
 
-#: ../output.py:555
+#: ../output.py:1013
 msgid "Dependency Removed"
-msgstr "Dependência Removida"
+msgstr "Dependência(s) removida(s)"
 
-#: ../output.py:557
+#: ../output.py:1015
 msgid "Dependency Installed"
-msgstr "Dependência Instalada"
+msgstr "Dependência(s) instalada(s)"
 
-#: ../output.py:559
+#: ../output.py:1017
 msgid "Dependency Updated"
-msgstr "Dependência Atualizada"
+msgstr "Dependência(s) atualizada(s)"
 
-#: ../output.py:560
+#: ../output.py:1019
 msgid "Replaced"
 msgstr "Substituído(s)"
 
-#: ../output.py:618
+#: ../output.py:1092
 #, python-format
 msgid ""
 "\n"
-" Current download cancelled, %sinterrupt (ctrl-c) again%s within %s%s%s "
-"seconds to exit.\n"
+" Current download cancelled, %sinterrupt (ctrl-c) again%s within %s%s%s seconds to exit.\n"
 msgstr ""
 "\n"
-" Download atual cancelado, interrupção %s, (ctrl-c) novamente %s com %s%s%s "
-"segundos até sair.\n"
+" Download atual cancelado, interrupção %s, (ctrl-c) novamente %s com %s%s%s segundos até sair.\n"
 
-#: ../output.py:628
+#: ../output.py:1102
 msgid "user interrupt"
-msgstr "interrupção pelo usuário"
+msgstr "interrupção do usuário"
 
-#: ../output.py:639
+#: ../output.py:1118
+msgid "Total"
+msgstr "Total"
+
+#: ../output.py:1132
 msgid "installed"
 msgstr "instalado"
 
-#: ../output.py:640
+#: ../output.py:1133
 msgid "updated"
 msgstr "atualizado"
 
-#: ../output.py:641
+#: ../output.py:1134
 msgid "obsoleted"
 msgstr "obsoleto"
 
-#: ../output.py:642
+#: ../output.py:1135
 msgid "erased"
 msgstr "removido"
 
-#: ../output.py:646
+#: ../output.py:1139
 #, python-format
 msgid "---> Package %s.%s %s:%s-%s set to be %s"
 msgstr "---> Pacote %s.%s %s:%s-%s definido para ser %s"
 
-#: ../output.py:653
+#: ../output.py:1146
 msgid "--> Running transaction check"
 msgstr "--> Executando verificação da transação"
 
-#: ../output.py:658
+#: ../output.py:1151
 msgid "--> Restarting Dependency Resolution with new changes."
-msgstr "--> Reiniciando Resolução de Dependências com as novas alterações."
+msgstr "--> Reiniciando resolução de dependências com as novas alterações."
 
-#: ../output.py:663
+#: ../output.py:1156
 msgid "--> Finished Dependency Resolution"
-msgstr "--> Resolução de Dependências Finalizada"
+msgstr "--> Resolução de dependências finalizada"
 
-#: ../output.py:668
+#: ../output.py:1161
 #, python-format
 msgid "--> Processing Dependency: %s for package: %s"
-msgstr "--> Processando Dependência: %s para o pacote: %s"
+msgstr "--> Processando dependência: %s para o pacote: %s"
 
-#: ../output.py:673
+#: ../output.py:1166
 #, python-format
 msgid "--> Unresolved Dependency: %s"
-msgstr "--> Dependência Não Resolvida: %s"
+msgstr "--> Dependência não resolvida: %s"
 
-#: ../output.py:679
+#: ../output.py:1172
 #, python-format
 msgid "--> Processing Conflict: %s conflicts %s"
-msgstr "--> Processando Conflito: %s conflita com %s"
+msgstr "--> Processando conflito: %s conflita com %s"
 
-#: ../output.py:682
+#: ../output.py:1175
 msgid "--> Populating transaction set with selected packages. Please wait."
-msgstr ""
-"--> Construindo conjunto de transações com os pacotes selecionados. Por "
-"favor aguarde."
+msgstr "--> Construindo conjunto de transações com os pacotes selecionados. Por favor aguarde."
 
-#: ../output.py:686
+#: ../output.py:1179
 #, python-format
 msgid "---> Downloading header for %s to pack into transaction set."
 msgstr "--> Baixando cabeçalho do %s para inclusão no conjunto de transações."
 
-#: ../yumcommands.py:36
+#: ../yumcommands.py:41
 msgid "You need to be root to perform this command."
 msgstr "Você precisa ser root para executar este comando."
 
-#: ../yumcommands.py:43
+#: ../yumcommands.py:48
 msgid ""
 "\n"
 "You have enabled checking of packages via GPG keys. This is a good thing. \n"
-"However, you do not have any GPG public keys installed. You need to "
-"download\n"
+"However, you do not have any GPG public keys installed. You need to download\n"
 "the keys for packages you wish to install and install them.\n"
 "You can do that by running the command:\n"
 "    rpm --import public.gpg.key\n"
@@ -787,10 +923,8 @@ msgid ""
 "For more information contact your distribution or package provider.\n"
 msgstr ""
 "\n"
-"Você habilitou a verificação de pacotes através de chaves GPG. Isso é uma "
-"boa coisa.\n"
-"Entretanto, você não tem nenhuma chave GPG pública instalada. Você precisa "
-"baixar\n"
+"Você habilitou a verificação de pacotes através de chaves GPG. Isso é uma boa coisa.\n"
+"Entretanto, você não tem nenhuma chave GPG pública instalada. Você precisa baixar\n"
 "e instalar essas chaves para os pacotes que deseja instalar.\n"
 "Você pode fazer isso executando o comando:\n"
 "    rpm --import public.gpg.key\n"
@@ -800,252 +934,316 @@ msgstr ""
 " do repositório, a url da chave que você gostaria de usar\n"
 "para ele e o yum irá instalá-la para você.\n"
 "\n"
-"Para mais informações contate o fornecedor da sua distribuição ou do "
-"pacote.\n"
+"Para mais informações contate o fornecedor da sua distribuição ou do pacote.\n"
 
-#: ../yumcommands.py:63
+#: ../yumcommands.py:68
 #, python-format
 msgid "Error: Need to pass a list of pkgs to %s"
 msgstr "Erro: É necessário passar uma lista de pacotes para %s"
 
-#: ../yumcommands.py:69
+#: ../yumcommands.py:74
 msgid "Error: Need an item to match"
 msgstr "Erro: É necessário um item para corresponder"
 
-#: ../yumcommands.py:75
+#: ../yumcommands.py:80
 msgid "Error: Need a group or list of groups"
 msgstr "Erro: É necessário um grupo ou uma lista de grupos"
 
-#: ../yumcommands.py:84
+#: ../yumcommands.py:89
 #, python-format
 msgid "Error: clean requires an option: %s"
 msgstr "Erro: a limpeza requer uma opção: %s"
 
-#: ../yumcommands.py:89
+#: ../yumcommands.py:94
 #, python-format
 msgid "Error: invalid clean argument: %r"
 msgstr "Erro: argumento de limpeza inválido: %r"
 
-#: ../yumcommands.py:102
+#: ../yumcommands.py:107
 msgid "No argument to shell"
 msgstr "Nenhum argumento para o shell"
 
-#: ../yumcommands.py:105
+#: ../yumcommands.py:110
 #, python-format
 msgid "Filename passed to shell: %s"
 msgstr "Nome de arquivo passado para o shell: %s"
 
-#: ../yumcommands.py:109
+#: ../yumcommands.py:114
 #, python-format
 msgid "File %s given as argument to shell does not exist."
 msgstr "O arquivo %s, passado como um argumento para o shell, não existe."
 
-#: ../yumcommands.py:115
+#: ../yumcommands.py:120
 msgid "Error: more than one file given as argument to shell."
 msgstr "Erro: mais de um arquivo passado como argumento para o shell."
 
-#: ../yumcommands.py:156
+#: ../yumcommands.py:161
 msgid "PACKAGE..."
 msgstr "PACOTE..."
 
-#: ../yumcommands.py:159
+#: ../yumcommands.py:164
 msgid "Install a package or packages on your system"
 msgstr "Instala um ou mais pacotes no seu sistema"
 
-#: ../yumcommands.py:168
+#: ../yumcommands.py:173
 msgid "Setting up Install Process"
-msgstr "Configurando o Processo de Instalação"
+msgstr "Configurando o processo de instalação"
 
-#: ../yumcommands.py:179
+#: ../yumcommands.py:184
 msgid "[PACKAGE...]"
 msgstr "[PACOTE...]"
 
-#: ../yumcommands.py:182
+#: ../yumcommands.py:187
 msgid "Update a package or packages on your system"
 msgstr "Atualiza um ou mais pacotes do seu sistema"
 
-#: ../yumcommands.py:190
+#: ../yumcommands.py:195
 msgid "Setting up Update Process"
-msgstr "Configurando o Processo de Atualização"
+msgstr "Configurando o processo de atualização"
 
-#: ../yumcommands.py:204
+#: ../yumcommands.py:237
 msgid "Display details about a package or group of packages"
 msgstr "Mostra detalhes sobre um pacote ou grupos de pacotes"
 
-#: ../yumcommands.py:212
+#: ../yumcommands.py:278
 msgid "Installed Packages"
-msgstr "Pacotes Instalados"
+msgstr "Pacotes instalados"
 
-#: ../yumcommands.py:213
+#: ../yumcommands.py:285
 msgid "Available Packages"
-msgstr "Pacotes Disponíveis"
+msgstr "Pacotes disponíveis"
 
-#: ../yumcommands.py:214
+#: ../yumcommands.py:289
 msgid "Extra Packages"
-msgstr "Pacotes Extras"
+msgstr "Pacotes extras"
 
-#: ../yumcommands.py:215
+#: ../yumcommands.py:291
 msgid "Updated Packages"
-msgstr "Pacotes Atualizados"
+msgstr "Pacotes atualizados"
 
-#: ../yumcommands.py:221 ../yumcommands.py:225
+#: ../yumcommands.py:298
+#: ../yumcommands.py:305
+#: ../yumcommands.py:574
 msgid "Obsoleting Packages"
-msgstr "Tornando Pacotes Obsoletos"
+msgstr "Tornando pacotes obsoletos"
 
-#: ../yumcommands.py:226
+#: ../yumcommands.py:307
 msgid "Recently Added Packages"
-msgstr "Pacotes Adicionados Recentemente"
+msgstr "Pacotes adicionados recentemente"
 
-#: ../yumcommands.py:232
+#: ../yumcommands.py:314
 msgid "No matching Packages to list"
-msgstr "Nenhum Pacote Correspondente para Listar"
+msgstr "Nenhum pacote correspondente a ser listado"
 
-#: ../yumcommands.py:246
+#: ../yumcommands.py:328
 msgid "List a package or groups of packages"
 msgstr "Lista um pacote ou grupos de pacotes"
 
-#: ../yumcommands.py:258
+#: ../yumcommands.py:340
 msgid "Remove a package or packages from your system"
 msgstr "Remove um ou mais pacotes do seu sistema"
 
-#: ../yumcommands.py:266
+#: ../yumcommands.py:348
 msgid "Setting up Remove Process"
-msgstr "Configurando o Processo de Remoção"
+msgstr "Configurando o processo de remoção"
 
-#: ../yumcommands.py:278
+#: ../yumcommands.py:363
 msgid "Setting up Group Process"
-msgstr "Configurando Processo de Grupos"
+msgstr "Configurando o processo de grupos"
 
-#: ../yumcommands.py:284
+#: ../yumcommands.py:369
 msgid "No Groups on which to run command"
 msgstr "Não há grupos nos quais executar o comando"
 
-#: ../yumcommands.py:297
+#: ../yumcommands.py:382
 msgid "List available package groups"
 msgstr "Lista os grupos de pacotes disponíveis"
 
-#: ../yumcommands.py:314
+#: ../yumcommands.py:399
 msgid "Install the packages in a group on your system"
 msgstr "Instala pacotes em um grupo ou no seu sistema"
 
-#: ../yumcommands.py:336
+#: ../yumcommands.py:421
 msgid "Remove the packages in a group from your system"
 msgstr "Remove pacotes de um grupo ou do seu sistema"
 
-#: ../yumcommands.py:360
+#: ../yumcommands.py:448
 msgid "Display details about a package group"
 msgstr "Mostra detalhes sobre um grupo de pacotes"
 
-#: ../yumcommands.py:384
+#: ../yumcommands.py:472
 msgid "Generate the metadata cache"
 msgstr "Gera o cache de metadados"
 
-#: ../yumcommands.py:390
+#: ../yumcommands.py:478
 msgid "Making cache files for all metadata files."
 msgstr "Realizando cache de arquivos para todos os metadados."
 
-#: ../yumcommands.py:391
+#: ../yumcommands.py:479
 msgid "This may take a while depending on the speed of this computer"
 msgstr "Isso pode demorar um pouco, dependendo da velocidade deste computador"
 
-#: ../yumcommands.py:412
+#: ../yumcommands.py:500
 msgid "Metadata Cache Created"
-msgstr "Cache de Metadados Criado"
+msgstr "Cache de metadados criado"
 
-#: ../yumcommands.py:426
+#: ../yumcommands.py:514
 msgid "Remove cached data"
 msgstr "Remove os dados do cache"
 
-#: ../yumcommands.py:447
+#: ../yumcommands.py:535
 msgid "Find what package provides the given value"
 msgstr "Localiza qual pacote fornece o valor dado"
 
-#: ../yumcommands.py:467
+#: ../yumcommands.py:555
 msgid "Check for available package updates"
 msgstr "Verifica por atualizações de pacotes disponíveis"
 
-#: ../yumcommands.py:490
+#: ../yumcommands.py:594
 msgid "Search package details for the given string"
 msgstr "Pesquisa detalhes do pacote para a string fornecida"
 
-#: ../yumcommands.py:496
+#: ../yumcommands.py:600
 msgid "Searching Packages: "
-msgstr "Pesquisando por Pacotes:"
+msgstr "Pesquisando por pacotes:"
 
-#: ../yumcommands.py:513
+#: ../yumcommands.py:617
 msgid "Update packages taking obsoletes into account"
 msgstr "Atualiza pacotes levando em conta os obsoletos"
 
-#: ../yumcommands.py:522
+#: ../yumcommands.py:626
 msgid "Setting up Upgrade Process"
-msgstr "Configurando o Processo de Atualização"
+msgstr "Configurando o processo de atualização"
 
-#: ../yumcommands.py:536
+#: ../yumcommands.py:640
 msgid "Install a local RPM"
 msgstr "Instala um RPM local"
 
-#: ../yumcommands.py:545
+#: ../yumcommands.py:649
 msgid "Setting up Local Package Process"
-msgstr "Configurando o Processo de Pacote Local"
+msgstr "Configurando o processo de pacote local"
 
-#: ../yumcommands.py:564
+#: ../yumcommands.py:668
 msgid "Determine which package provides the given dependency"
 msgstr "Determina qual pacote fornece a dependência dada"
 
-#: ../yumcommands.py:567
+#: ../yumcommands.py:671
 msgid "Searching Packages for Dependency:"
-msgstr "Pesquisando Pacotes por Dependência:"
+msgstr "Pesquisando pacotes por dependência:"
 
-#: ../yumcommands.py:581
+#: ../yumcommands.py:685
 msgid "Run an interactive yum shell"
 msgstr "Executa um shell interativo do yum"
 
-#: ../yumcommands.py:587
+#: ../yumcommands.py:691
 msgid "Setting up Yum Shell"
-msgstr "Configurando o Shell do Yum"
+msgstr "Configurando o shell do Yum"
 
-#: ../yumcommands.py:605
+#: ../yumcommands.py:709
 msgid "List a package's dependencies"
 msgstr "Lista as dependências de um pacote"
 
-#: ../yumcommands.py:611
+#: ../yumcommands.py:715
 msgid "Finding dependencies: "
 msgstr "Localizando dependências:"
 
-#: ../yumcommands.py:627
+#: ../yumcommands.py:731
 msgid "Display the configured software repositories"
 msgstr "Exibe os repositórios de software configurados"
 
-#: ../yumcommands.py:645
+#: ../yumcommands.py:779
+#: ../yumcommands.py:780
+msgid "enabled"
+msgstr "habilitado"
+
+#: ../yumcommands.py:788
+#: ../yumcommands.py:789
+msgid "disabled"
+msgstr "desabilitado"
+
+#: ../yumcommands.py:800
+msgid "Repo-id     : "
+msgstr "Repo-id     : "
+
+#: ../yumcommands.py:801
+msgid "Repo-name   : "
+msgstr "Repo-name   : "
+
+#: ../yumcommands.py:802
+msgid "Repo-status : "
+msgstr "Repo-status : "
+
+#: ../yumcommands.py:804
+msgid "Repo-revision: "
+msgstr "Repo-revision: "
+
+#: ../yumcommands.py:808
+msgid "Repo-tags   : "
+msgstr "Repo-tags   : "
+
+#: ../yumcommands.py:814
+msgid "Repo-distro-tags: "
+msgstr "Repo-distro-tags: "
+
+#: ../yumcommands.py:819
+msgid "Repo-updated: "
+msgstr "Repo-updated: "
+
+#: ../yumcommands.py:821
+msgid "Repo-pkgs   : "
+msgstr "Repo-pkgs   : "
+
+#: ../yumcommands.py:822
+msgid "Repo-size   : "
+msgstr "Repo-size   : "
+
+#: ../yumcommands.py:829
+msgid "Repo-baseurl: "
+msgstr "Repo-baseurl: "
+
+#: ../yumcommands.py:833
+msgid "Repo-metalink: "
+msgstr "Repo-metalink: "
+
+#: ../yumcommands.py:836
+msgid "Repo-mirrors: "
+msgstr "Repo-mirrors: "
+
+#: ../yumcommands.py:840
+msgid "Repo-exclude: "
+msgstr "Repo-exclude: "
+
+#: ../yumcommands.py:844
+msgid "Repo-include: "
+msgstr "Repo-include: "
+
+#. Work out the first (id) and last (enabled/disalbed/count),
+#. then chop the middle (name)...
+#: ../yumcommands.py:854
+#: ../yumcommands.py:880
 msgid "repo id"
 msgstr "id do repo"
 
-#: ../yumcommands.py:645
-msgid "repo name"
-msgstr "nome do repo"
-
-#: ../yumcommands.py:645
+#: ../yumcommands.py:868
+#: ../yumcommands.py:869
+#: ../yumcommands.py:883
 msgid "status"
 msgstr "status"
 
-#: ../yumcommands.py:651
-msgid "enabled"
-msgstr "habilitado"
-
-#: ../yumcommands.py:654
-msgid "disabled"
-msgstr "desabilitado"
+#: ../yumcommands.py:881
+msgid "repo name"
+msgstr "nome do repo"
 
-#: ../yumcommands.py:671
+#: ../yumcommands.py:907
 msgid "Display a helpful usage message"
 msgstr "Exibe uma mensagem de uso para ajuda"
 
-#: ../yumcommands.py:705
+#: ../yumcommands.py:941
 #, python-format
 msgid "No help available for %s"
 msgstr "Nenhuma ajuda disponível para %s"
 
-#: ../yumcommands.py:710
+#: ../yumcommands.py:946
 msgid ""
 "\n"
 "\n"
@@ -1055,7 +1253,7 @@ msgstr ""
 "\n"
 "apelidos: "
 
-#: ../yumcommands.py:712
+#: ../yumcommands.py:948
 msgid ""
 "\n"
 "\n"
@@ -1065,11 +1263,11 @@ msgstr ""
 "\n"
 "apelido: "
 
-#: ../yumcommands.py:741
+#: ../yumcommands.py:977
 msgid "Setting up Reinstall Process"
-msgstr "Configurando o Processo de Reinstalação"
+msgstr "Configurando o processo de reinstalação"
 
-#: ../yumcommands.py:755
+#: ../yumcommands.py:991
 msgid "reinstall a package"
 msgstr "reinstala um pacote"
 
@@ -1091,43 +1289,42 @@ msgid ""
 msgstr ""
 "\n"
 "\n"
-"Saindo por um Pipe Defeituoso"
+"Saindo por um pipe defeituoso"
 
-#: ../yummain.py:105
-msgid ""
-"Another app is currently holding the yum lock; waiting for it to exit..."
-msgstr ""
-"Outra aplicação está retendo o bloqueio do yum; esperando por ele para "
-"sair..."
+#: ../yummain.py:98
+msgid "Another app is currently holding the yum lock; waiting for it to exit..."
+msgstr "Outra aplicação está retendo o bloqueio do yum; esperando por ele para sair..."
 
-#: ../yummain.py:132 ../yummain.py:171
+#: ../yummain.py:125
+#: ../yummain.py:164
 #, python-format
 msgid "Error: %s"
 msgstr "Error: %s"
 
-#: ../yummain.py:142 ../yummain.py:178
+#: ../yummain.py:135
+#: ../yummain.py:171
 #, python-format
 msgid "Unknown Error(s): Exit Code: %d:"
-msgstr "Erro(s) Desconhecido(s): Código de Saída: %d:"
+msgstr "Erro(s) desconhecido(s): código de saída: %d:"
 
 #. Depsolve stage
-#: ../yummain.py:149
+#: ../yummain.py:142
 msgid "Resolving Dependencies"
-msgstr "Resolvendo Dependências"
+msgstr "Resolvendo dependências"
 
-#: ../yummain.py:184
+#: ../yummain.py:177
 msgid ""
 "\n"
 "Dependencies Resolved"
 msgstr ""
 "\n"
-"Dependências Resolvidas"
+"Dependências resolvidas"
 
-#: ../yummain.py:198
+#: ../yummain.py:191
 msgid "Complete!"
 msgstr "Concluído!"
 
-#: ../yummain.py:245
+#: ../yummain.py:238
 msgid ""
 "\n"
 "\n"
@@ -1137,323 +1334,315 @@ msgstr ""
 "\n"
 "Saindo pelo cancelamento do usuário."
 
-#: ../yum/depsolve.py:82
+#: ../yum/depsolve.py:84
 msgid "doTsSetup() will go away in a future version of Yum.\n"
 msgstr "doTsSetup() será removida em uma futura versão do Yum.\n"
 
-#: ../yum/depsolve.py:95
+#: ../yum/depsolve.py:99
 msgid "Setting up TransactionSets before config class is up"
-msgstr ""
-"Configurando TransactionSets antes da ativação da classe de configuração"
+msgstr "Configurando TransactionSets antes da ativação da classe de configuração"
 
-#: ../yum/depsolve.py:136
+#: ../yum/depsolve.py:150
 #, python-format
 msgid "Invalid tsflag in config file: %s"
 msgstr "tsflag inválido no arquivo de configuração: %s"
 
-#: ../yum/depsolve.py:147
+#: ../yum/depsolve.py:161
 #, python-format
 msgid "Searching pkgSack for dep: %s"
 msgstr "Pesquisando pkgSack para a dep.: %s"
 
-#: ../yum/depsolve.py:170
+#: ../yum/depsolve.py:184
 #, python-format
 msgid "Potential match for %s from %s"
 msgstr "Correspondência potencial para o %s a partir de %s"
 
-#: ../yum/depsolve.py:178
+#: ../yum/depsolve.py:192
 #, python-format
 msgid "Matched %s to require for %s"
 msgstr "%s encontrado para solicitar o %s"
 
-#: ../yum/depsolve.py:219
+#: ../yum/depsolve.py:233
 #, python-format
 msgid "Member: %s"
 msgstr "Membro: %s"
 
-#: ../yum/depsolve.py:233 ../yum/depsolve.py:696
+#: ../yum/depsolve.py:247
+#: ../yum/depsolve.py:734
 #, python-format
 msgid "%s converted to install"
 msgstr "%s convertido para instalar"
 
-#: ../yum/depsolve.py:240
+#: ../yum/depsolve.py:254
 #, python-format
 msgid "Adding Package %s in mode %s"
-msgstr "Adicionando Pacote %s ao modo %s"
+msgstr "Adicionando pacote %s no modo %s"
 
-#: ../yum/depsolve.py:250
+#: ../yum/depsolve.py:264
 #, python-format
 msgid "Removing Package %s"
-msgstr "Removendo Pacote %s"
+msgstr "Removendo pacote %s"
 
-#: ../yum/depsolve.py:261
+#: ../yum/depsolve.py:275
 #, python-format
 msgid "%s requires: %s"
 msgstr "%s requer: %s"
 
-#: ../yum/depsolve.py:312
+#: ../yum/depsolve.py:333
 msgid "Needed Require has already been looked up, cheating"
 msgstr "O requerimento necessário já foi localizado, enganando"
 
-#: ../yum/depsolve.py:322
+#: ../yum/depsolve.py:343
 #, python-format
 msgid "Needed Require is not a package name. Looking up: %s"
 msgstr "O requerimento necessário não é o nome de um pacote. Localizando: %s"
 
-#: ../yum/depsolve.py:329
+#: ../yum/depsolve.py:350
 #, python-format
 msgid "Potential Provider: %s"
 msgstr "Fornecedor em potencial: %s"
 
-#: ../yum/depsolve.py:352
+#: ../yum/depsolve.py:373
 #, python-format
 msgid "Mode is %s for provider of %s: %s"
 msgstr "O modo é %s para o fornecedor do %s: %s"
 
-#: ../yum/depsolve.py:356
+#: ../yum/depsolve.py:377
 #, python-format
 msgid "Mode for pkg providing %s: %s"
 msgstr "Modo para o pacote que fornece o %s: %s"
 
-#: ../yum/depsolve.py:360
+#: ../yum/depsolve.py:381
 #, python-format
 msgid "TSINFO: %s package requiring %s marked as erase"
 msgstr "TSINFO: o pacote %s que requer o %s foi marcado para remoção"
 
-#: ../yum/depsolve.py:372
+#: ../yum/depsolve.py:393
 #, python-format
 msgid "TSINFO: Obsoleting %s with %s to resolve dep."
 msgstr "TSINFO: Tornando %s obsoleto com o %s para resolver a dependência."
 
-#: ../yum/depsolve.py:375
+#: ../yum/depsolve.py:396
 #, python-format
 msgid "TSINFO: Updating %s to resolve dep."
 msgstr "TSINFO: Atualizando %s para resolver a dependência."
 
-#: ../yum/depsolve.py:378
+#: ../yum/depsolve.py:404
 #, python-format
 msgid "Cannot find an update path for dep for: %s"
-msgstr ""
-"Não foi possível encontrar um caminho de atualização para a dep. para: %s"
+msgstr "Não foi possível encontrar um caminho de atualização para a dep. para: %s"
 
-#: ../yum/depsolve.py:388
+#: ../yum/depsolve.py:414
 #, python-format
 msgid "Unresolvable requirement %s for %s"
 msgstr "Requerimento %s insolúvel para o %s"
 
+#: ../yum/depsolve.py:437
+#, python-format
+msgid "Quick matched %s to require for %s"
+msgstr "%s localizado rapidamente a ser requerido por %s"
+
 #. is it already installed?
-#: ../yum/depsolve.py:434
+#: ../yum/depsolve.py:479
 #, python-format
 msgid "%s is in providing packages but it is already installed, removing."
 msgstr "%s está nos pacotes fornecedores mas já está instalado, removendo."
 
-#: ../yum/depsolve.py:449
+#: ../yum/depsolve.py:494
 #, python-format
 msgid "Potential resolving package %s has newer instance in ts."
 msgstr "O pacote de solução em potencial %s tem uma instância mais nova no ct."
 
-#: ../yum/depsolve.py:460
+#: ../yum/depsolve.py:505
 #, python-format
 msgid "Potential resolving package %s has newer instance installed."
-msgstr ""
-"O pacote de solução em potencial %s tem uma instância mais nova instalada."
+msgstr "O pacote de solução em potencial %s tem uma instância mais nova instalada."
 
-#: ../yum/depsolve.py:468 ../yum/depsolve.py:527
+#: ../yum/depsolve.py:513
+#: ../yum/depsolve.py:562
 #, python-format
 msgid "Missing Dependency: %s is needed by package %s"
-msgstr "Dependência Faltando: %s é requerido pelo pacote %s"
+msgstr "Dependência faltando: %s é requerido pelo pacote %s"
 
-#: ../yum/depsolve.py:481
+#: ../yum/depsolve.py:526
 #, python-format
 msgid "%s already in ts, skipping this one"
 msgstr "%s já está no ct, pulando esse"
 
-#: ../yum/depsolve.py:510
-#, python-format
-msgid ""
-"Failure finding best provider of %s for %s, exceeded maximum loop length"
-msgstr ""
-"Falha ao encontrar o melhor fornecedor de %s para %s, tamanho máximo do loop "
-"excedido"
-
-#: ../yum/depsolve.py:537
+#: ../yum/depsolve.py:572
 #, python-format
 msgid "TSINFO: Marking %s as update for %s"
 msgstr "TSINFO: Marcando %s como uma atualização para o %s"
 
-#: ../yum/depsolve.py:544
+#: ../yum/depsolve.py:580
 #, python-format
 msgid "TSINFO: Marking %s as install for %s"
 msgstr "TSINFO: Marcando %s como uma instalação para o %s"
 
-#: ../yum/depsolve.py:635 ../yum/depsolve.py:714
+#: ../yum/depsolve.py:672
+#: ../yum/depsolve.py:752
 msgid "Success - empty transaction"
 msgstr "Sucesso - transação vazia"
 
-#: ../yum/depsolve.py:673 ../yum/depsolve.py:686
+#: ../yum/depsolve.py:711
+#: ../yum/depsolve.py:724
 msgid "Restarting Loop"
-msgstr "Reiniciando o Loop"
+msgstr "Reiniciando o loop"
 
-#: ../yum/depsolve.py:702
+#: ../yum/depsolve.py:740
 msgid "Dependency Process ending"
-msgstr "Término do Processo de Dependências"
+msgstr "Término do processo de dependências"
 
-#: ../yum/depsolve.py:708
+#: ../yum/depsolve.py:746
 #, python-format
 msgid "%s from %s has depsolving problems"
 msgstr "%s a partir de %s tem problemas de resolução de dependências"
 
-#: ../yum/depsolve.py:715
+#: ../yum/depsolve.py:753
 msgid "Success - deps resolved"
 msgstr "Sucesso - dependências resolvidas"
 
-#: ../yum/depsolve.py:729
+#: ../yum/depsolve.py:767
 #, python-format
 msgid "Checking deps for %s"
 msgstr "Verificando dependências para %s"
 
-#: ../yum/depsolve.py:782
+#: ../yum/depsolve.py:850
 #, python-format
 msgid "looking for %s as a requirement of %s"
 msgstr "procurando por %s como um requerimento do %s"
 
-#: ../yum/depsolve.py:933
-#, python-format
-msgid "Comparing best: %s to po: %s"
-msgstr "Comparando melhor: %s para po: %s"
-
-#: ../yum/depsolve.py:937
-#, python-format
-msgid "Same: best %s == po: %s"
-msgstr "Igual: melhor %s == po: %s"
-
-#: ../yum/depsolve.py:952 ../yum/depsolve.py:963
+#: ../yum/depsolve.py:990
 #, python-format
-msgid "best %s obsoletes po: %s"
-msgstr "melhor %s torna po obsoleto: %s"
+msgid "Running compare_providers() for %s"
+msgstr "Executando compare_providers() para %s"
 
-#: ../yum/depsolve.py:955
-#, python-format
-msgid "po %s obsoletes best: %s"
-msgstr "po %s torna melhor obsoleto: %s"
-
-#: ../yum/depsolve.py:972 ../yum/depsolve.py:979 ../yum/depsolve.py:1036
+#: ../yum/depsolve.py:1018
+#: ../yum/depsolve.py:1024
 #, python-format
 msgid "better arch in po %s"
 msgstr "melhor arquitetura no po %s"
 
-#: ../yum/depsolve.py:988 ../yum/depsolve.py:1010
+#: ../yum/depsolve.py:1063
 #, python-format
-msgid "po %s shares a sourcerpm with %s"
-msgstr "po %s compartilha um sourcerpm com %s"
+msgid "%s obsoletes %s"
+msgstr "%s torna %s obsoleto"
 
-#: ../yum/depsolve.py:992 ../yum/depsolve.py:1015
+#: ../yum/depsolve.py:1079
 #, python-format
-msgid "best %s shares a sourcerpm with %s"
-msgstr "melhor %s compartilha um sourcerpm com %s"
+msgid ""
+"archdist compared %s to %s on %s\n"
+"  Winner: %s"
+msgstr ""
+"archdist comparou %s com %s em %s\n"
+"  Vencedor: %s"
 
-#: ../yum/depsolve.py:999 ../yum/depsolve.py:1020
+#: ../yum/depsolve.py:1086
 #, python-format
-msgid "po %s shares more of the name prefix with %s"
-msgstr "po %s compartilha mais do prefixo do nome com %s"
+msgid "common sourcerpm %s and %s"
+msgstr "Sourcerpm comum %s e %s"
 
-#: ../yum/depsolve.py:1003 ../yum/depsolve.py:1029
+#: ../yum/depsolve.py:1092
 #, python-format
-msgid "po %s has a shorter name than best %s"
-msgstr "po %s tem um nome mais curto do que o melhor %s"
+msgid "common prefix of %s between %s and %s"
+msgstr "prefixo comum de %s entre %s e %s"
 
-#: ../yum/depsolve.py:1025
+#: ../yum/depsolve.py:1100
 #, python-format
-msgid "bestpkg %s shares more of the name prefix with %s"
-msgstr "bestpkg %s compartilha mais do prefixo do nome com %s"
+msgid "Best Order: %s"
+msgstr "Melhor ordem: %s"
 
-#: ../yum/__init__.py:119
+#: ../yum/__init__.py:135
 msgid "doConfigSetup() will go away in a future version of Yum.\n"
 msgstr "doConfigSetup() será removida em uma futura versão do Yum.\n"
 
-#: ../yum/__init__.py:296
+#: ../yum/__init__.py:315
 #, python-format
 msgid "Repository %r is missing name in configuration, using id"
 msgstr "O repositório %r não tem nome na configuração, usando o id"
 
-#: ../yum/__init__.py:332
+#: ../yum/__init__.py:353
 msgid "plugins already initialised"
 msgstr "plugins já inicializados"
 
-#: ../yum/__init__.py:339
+#: ../yum/__init__.py:360
 msgid "doRpmDBSetup() will go away in a future version of Yum.\n"
 msgstr "doRpmDBSetup() será removida em uma futura versão do Yum.\n"
 
-#: ../yum/__init__.py:349
+#: ../yum/__init__.py:370
 msgid "Reading Local RPMDB"
-msgstr "Lendo RPMDB Local"
+msgstr "Lendo RPMDB local"
 
-#: ../yum/__init__.py:367
+#: ../yum/__init__.py:388
 msgid "doRepoSetup() will go away in a future version of Yum.\n"
 msgstr "doRepoSetup() será removida em uma futura versão do Yum.\n"
 
-#: ../yum/__init__.py:387
+#: ../yum/__init__.py:408
 msgid "doSackSetup() will go away in a future version of Yum.\n"
 msgstr "doSackSetup() será removida em uma futura versão do Yum.\n"
 
-#: ../yum/__init__.py:404
+#: ../yum/__init__.py:425
 msgid "Setting up Package Sacks"
-msgstr "Configurando Sacos de Pacotes"
+msgstr "Configurando sacos de pacotes"
 
-#: ../yum/__init__.py:447
+#: ../yum/__init__.py:468
 #, python-format
 msgid "repo object for repo %s lacks a _resetSack method\n"
 msgstr "o objeto de repositório para o %s necessita de um método _resetSack\n"
 
-#: ../yum/__init__.py:448
+#: ../yum/__init__.py:469
 msgid "therefore this repo cannot be reset.\n"
 msgstr "conseqüentemente este repo não pode ser restaurado.\n"
 
-#: ../yum/__init__.py:453
+#: ../yum/__init__.py:474
 msgid "doUpdateSetup() will go away in a future version of Yum.\n"
 msgstr "doUpdateSetup() será removida em uma futura versão do Yum.\n"
 
-#: ../yum/__init__.py:465
+#: ../yum/__init__.py:486
 msgid "Building updates object"
 msgstr "Construindo objeto de atualizações"
 
-#: ../yum/__init__.py:496
+#: ../yum/__init__.py:517
 msgid "doGroupSetup() will go away in a future version of Yum.\n"
 msgstr "doGroupSetup() será removida em uma futura versão do Yum.\n"
 
-#: ../yum/__init__.py:520
+#: ../yum/__init__.py:541
 msgid "Getting group metadata"
 msgstr "Obtendo metadados do grupo"
 
-#: ../yum/__init__.py:546
+#: ../yum/__init__.py:567
 #, python-format
 msgid "Adding group file from repository: %s"
 msgstr "Adicionando arquivo de grupo a partir do repositório: %s"
 
-#: ../yum/__init__.py:555
+#: ../yum/__init__.py:576
 #, python-format
 msgid "Failed to add groups file for repository: %s - %s"
 msgstr "Falha ao adicionar o arquivo de grupos para o repositório: %s - %s"
 
-#: ../yum/__init__.py:561
+#: ../yum/__init__.py:582
 msgid "No Groups Available in any repository"
 msgstr "Nenhum grupo disponível em nenhum repositório"
 
-#: ../yum/__init__.py:611
+#: ../yum/__init__.py:632
 msgid "Importing additional filelist information"
 msgstr "Importando informações adicionais da lista de arquivos"
 
-#: ../yum/__init__.py:657
+#: ../yum/__init__.py:641
+msgid "There are unfinished transactions remaining. You might consider running yum-complete-transaction first to finish them."
+msgstr "Há transações não finalizadas restantes. Você pode considerar executar o yum-complete-transaction primeiro para finalizá-las."
+
+#: ../yum/__init__.py:707
 #, python-format
 msgid "Skip-broken round %i"
 msgstr "Rodada de ignoração de dependências quebradas %i"
 
-#: ../yum/__init__.py:680
+#: ../yum/__init__.py:759
 #, python-format
 msgid "Skip-broken took %i rounds "
 msgstr "A ignoração de dependências quebradas levou %i rodadas"
 
-#: ../yum/__init__.py:681
+#: ../yum/__init__.py:760
 msgid ""
 "\n"
 "Packages skipped because of dependency problems:"
@@ -1461,455 +1650,529 @@ msgstr ""
 "\n"
 "Pacotes ignorados devido a problemas de dependências:"
 
-#: ../yum/__init__.py:685
+#: ../yum/__init__.py:764
 #, python-format
 msgid "    %s from %s"
 msgstr "    %s a partir de %s"
 
-#: ../yum/__init__.py:774
+#: ../yum/__init__.py:908
+msgid "Warning: scriptlet or other non-fatal errors occurred during transaction."
+msgstr "Aviso: scriptlet ou outros erros não fatais ocorreram durante a transação."
+
+#: ../yum/__init__.py:924
 #, python-format
 msgid "Failed to remove transaction file %s"
 msgstr "Falha ao remover o arquivo de transação %s"
 
-#: ../yum/__init__.py:814
+#: ../yum/__init__.py:965
 #, python-format
 msgid "excluding for cost: %s from %s"
 msgstr "excluindo para custo: %s a partir de %s"
 
-#: ../yum/__init__.py:845
+#: ../yum/__init__.py:996
 msgid "Excluding Packages in global exclude list"
 msgstr "Excluindo pacotes na lista global de excluídos"
 
-#: ../yum/__init__.py:847
+#: ../yum/__init__.py:998
 #, python-format
 msgid "Excluding Packages from %s"
-msgstr "Excluindo Pacotes de %s"
+msgstr "Excluindo pacotes de %s"
 
-#: ../yum/__init__.py:875
+#: ../yum/__init__.py:1025
 #, python-format
 msgid "Reducing %s to included packages only"
 msgstr "Reduzindo %s apenas aos pacotes inclusos"
 
-#: ../yum/__init__.py:880
+#: ../yum/__init__.py:1031
 #, python-format
 msgid "Keeping included package %s"
 msgstr "Mantendo o pacote incluso %s"
 
-#: ../yum/__init__.py:886
+#: ../yum/__init__.py:1037
 #, python-format
 msgid "Removing unmatched package %s"
 msgstr "Removendo pacote não encontrado %s"
 
-#: ../yum/__init__.py:889
+#: ../yum/__init__.py:1040
 msgid "Finished"
 msgstr "Concluído"
 
 #. Whoa. What the heck happened?
-#: ../yum/__init__.py:919
+#: ../yum/__init__.py:1070
 #, python-format
 msgid "Unable to check if PID %s is active"
 msgstr "Não foi possível verificar se o PID %s está ativo"
 
 #. Another copy seems to be running.
-#: ../yum/__init__.py:923
+#: ../yum/__init__.py:1074
 #, python-format
 msgid "Existing lock %s: another copy is running as pid %s."
 msgstr "Bloqueio existente em %s: outra cópia está em execução com o pid %s."
 
-#: ../yum/__init__.py:970 ../yum/__init__.py:977
+#: ../yum/__init__.py:1145
 msgid "Package does not match intended download"
 msgstr "O pacote não corresponde ao download pretendido"
 
-#: ../yum/__init__.py:991
+#: ../yum/__init__.py:1160
 msgid "Could not perform checksum"
 msgstr "Não foi possível realizar a soma de verificação"
 
-#: ../yum/__init__.py:994
+#: ../yum/__init__.py:1163
 msgid "Package does not match checksum"
 msgstr "O pacote não corresponde à soma de verificação"
 
-#: ../yum/__init__.py:1036
+#: ../yum/__init__.py:1206
 #, python-format
 msgid "package fails checksum but caching is enabled for %s"
-msgstr ""
-"o pacote falhou na soma de verificação mas o cache está habilitado para o %s"
+msgstr "o pacote falhou na soma de verificação mas o cache está habilitado para o %s"
 
-#: ../yum/__init__.py:1042
+#: ../yum/__init__.py:1209
+#: ../yum/__init__.py:1237
 #, python-format
 msgid "using local copy of %s"
 msgstr "usando cópia local do %s"
 
-#: ../yum/__init__.py:1061
+#: ../yum/__init__.py:1251
 #, python-format
-msgid "Insufficient space in download directory %s to download"
-msgstr "Espaço insuficiente no diretório de download %s para baixar o arquivo"
+msgid ""
+"Insufficient space in download directory %s\n"
+"    * free   %s\n"
+"    * needed %s"
+msgstr ""
+"Espaço insuficiente no diretório de download %s\n"
+"    * livre   %s\n"
+"    * necessário %s"
 
-#: ../yum/__init__.py:1094
+#: ../yum/__init__.py:1298
 msgid "Header is not complete."
 msgstr "O cabeçalho não está completo."
 
-#: ../yum/__init__.py:1134
+#: ../yum/__init__.py:1338
 #, python-format
-msgid ""
-"Header not in local cache and caching-only mode enabled. Cannot download %s"
-msgstr ""
-"O cabeçalho não está no cache local e o modo de somente cache está "
-"habilitado. Não foi possível baixar o %s."
+msgid "Header not in local cache and caching-only mode enabled. Cannot download %s"
+msgstr "O cabeçalho não está no cache local e o modo de somente cache está habilitado. Não foi possível baixar o %s."
 
-#: ../yum/__init__.py:1189
+#: ../yum/__init__.py:1393
 #, python-format
 msgid "Public key for %s is not installed"
 msgstr "A chave pública para o %s não está instalada"
 
-#: ../yum/__init__.py:1193
+#: ../yum/__init__.py:1397
 #, python-format
 msgid "Problem opening package %s"
 msgstr "Problema ao abrir o pacote %s"
 
-#: ../yum/__init__.py:1201
+#: ../yum/__init__.py:1405
 #, python-format
 msgid "Public key for %s is not trusted"
 msgstr "A chave pública para o %s não é confiável"
 
-#: ../yum/__init__.py:1205
+#: ../yum/__init__.py:1409
 #, python-format
 msgid "Package %s is not signed"
 msgstr "O pacote %s não está assinado"
 
-#: ../yum/__init__.py:1243
+#: ../yum/__init__.py:1447
 #, python-format
 msgid "Cannot remove %s"
 msgstr "Não foi possível remover %s"
 
-#: ../yum/__init__.py:1247
+#: ../yum/__init__.py:1451
 #, python-format
 msgid "%s removed"
 msgstr "%s removido"
 
-#: ../yum/__init__.py:1283
+#: ../yum/__init__.py:1488
 #, python-format
 msgid "Cannot remove %s file %s"
 msgstr "Não foi possível remover %s arquivo %s"
 
-#: ../yum/__init__.py:1287
+#: ../yum/__init__.py:1492
 #, python-format
 msgid "%s file %s removed"
 msgstr "%s arquivo %s removido"
 
-#: ../yum/__init__.py:1289
+#: ../yum/__init__.py:1494
 #, python-format
 msgid "%d %s files removed"
 msgstr "%d %s arquivos removidos"
 
-#: ../yum/__init__.py:1329
+#: ../yum/__init__.py:1563
 #, python-format
 msgid "More than one identical match in sack for %s"
 msgstr "Mais de uma correspondência idêntica no saco para %s"
 
-#: ../yum/__init__.py:1335
+#: ../yum/__init__.py:1569
 #, python-format
 msgid "Nothing matches %s.%s %s:%s-%s from update"
 msgstr "Nada corresponde ao %s.%s %s:%s-%s a partir da atualização"
 
-#: ../yum/__init__.py:1543
-msgid ""
-"searchPackages() will go away in a future version of "
-"Yum.                      Use searchGenerator() instead. \n"
-msgstr ""
-"searchPackages() será removida em uma futura versão do Yum. Ao invés disso, "
-"use a searchGenerator().\n"
+#: ../yum/__init__.py:1787
+msgid "searchPackages() will go away in a future version of Yum.                      Use searchGenerator() instead. \n"
+msgstr "searchPackages() será removida em uma futura versão do Yum. Ao invés disso, use a searchGenerator().\n"
 
-#: ../yum/__init__.py:1580
+#: ../yum/__init__.py:1825
 #, python-format
 msgid "Searching %d packages"
 msgstr "Pesquisando por %d pacotes"
 
-#: ../yum/__init__.py:1584
+#: ../yum/__init__.py:1829
 #, python-format
 msgid "searching package %s"
 msgstr "pesquisando pelo pacote %s"
 
-#: ../yum/__init__.py:1596
+#: ../yum/__init__.py:1841
 msgid "searching in file entries"
 msgstr "pesquisando nas entradas do arquivo"
 
-#: ../yum/__init__.py:1603
+#: ../yum/__init__.py:1848
 msgid "searching in provides entries"
 msgstr "pesquisando nas entradas dos fornecimentos"
 
-#: ../yum/__init__.py:1633
+#: ../yum/__init__.py:1881
 #, python-format
 msgid "Provides-match: %s"
 msgstr "Fornecimento combina com: %s"
 
-#: ../yum/__init__.py:1702 ../yum/__init__.py:1720 ../yum/__init__.py:1748
-#: ../yum/__init__.py:1753 ../yum/__init__.py:1808 ../yum/__init__.py:1812
+#: ../yum/__init__.py:1930
+msgid "No group data available for configured repositories"
+msgstr "Nenhum dado de grupos disponível para os repositório configurados"
+
+#: ../yum/__init__.py:1961
+#: ../yum/__init__.py:1980
+#: ../yum/__init__.py:2011
+#: ../yum/__init__.py:2017
+#: ../yum/__init__.py:2090
+#: ../yum/__init__.py:2094
 #, python-format
 msgid "No Group named %s exists"
 msgstr "Não existe nenhum grupo de nome %s"
 
-#: ../yum/__init__.py:1731 ../yum/__init__.py:1824
+#: ../yum/__init__.py:1992
+#: ../yum/__init__.py:2107
 #, python-format
 msgid "package %s was not marked in group %s"
 msgstr "o pacote %s não foi marcado no grupo %s"
 
-#: ../yum/__init__.py:1770
+#: ../yum/__init__.py:2039
 #, python-format
 msgid "Adding package %s from group %s"
 msgstr "Adicionando o pacote %s do grupo %s"
 
-#: ../yum/__init__.py:1774
+#: ../yum/__init__.py:2043
 #, python-format
 msgid "No package named %s available to be installed"
 msgstr "Nenhum pacote de nome %s disponível para ser instalado"
 
-#: ../yum/__init__.py:1849
+#: ../yum/__init__.py:2132
 #, python-format
 msgid "Package tuple %s could not be found in packagesack"
 msgstr "A tupla %s do pacote não pôde ser encontrada no packagesack"
 
-#: ../yum/__init__.py:1917 ../yum/__init__.py:1960
+#: ../yum/__init__.py:2147
+msgid "getInstalledPackageObject() will go away, use self.rpmdb.searchPkgTuple().\n"
+msgstr "getInstalledPackageObject() será deixada de lado, use a self.rpmdb.searchPkgTuple().\n"
+
+#: ../yum/__init__.py:2199
+#: ../yum/__init__.py:2242
 msgid "Invalid versioned dependency string, try quoting it."
 msgstr "String de dependência versionada inválida, tente citá-la."
 
-#: ../yum/__init__.py:1919 ../yum/__init__.py:1962
+#: ../yum/__init__.py:2201
+#: ../yum/__init__.py:2244
 msgid "Invalid version flag"
 msgstr "Sinalizador de versão inválido"
 
-#: ../yum/__init__.py:1934 ../yum/__init__.py:1938
+#: ../yum/__init__.py:2216
+#: ../yum/__init__.py:2220
 #, python-format
 msgid "No Package found for %s"
 msgstr "Nenhum pacote encontrado para %s"
 
-#: ../yum/__init__.py:2066
+#: ../yum/__init__.py:2428
 msgid "Package Object was not a package object instance"
-msgstr "O Pacote de Objeto não era uma instância de pacote de objeto"
+msgstr "O pacote de objeto não era uma instância de pacote de objeto"
 
-#: ../yum/__init__.py:2070
+#: ../yum/__init__.py:2432
 msgid "Nothing specified to install"
 msgstr "Nada especificado para instalar"
 
 #. only one in there
-#: ../yum/__init__.py:2085
+#: ../yum/__init__.py:2450
 #, python-format
 msgid "Checking for virtual provide or file-provide for %s"
 msgstr "Verificando por fornecimento virtual ou de arquivo para %s"
 
-#: ../yum/__init__.py:2091 ../yum/__init__.py:2380
+#: ../yum/__init__.py:2456
+#: ../yum/__init__.py:2696
+#: ../yum/__init__.py:2863
 #, python-format
 msgid "No Match for argument: %s"
 msgstr "Nenhuma correspondência para o argumento: %s"
 
-#. FIXME - this is where we could check to see if it already installed
-#. for returning better errors
-#: ../yum/__init__.py:2146
+#: ../yum/__init__.py:2522
+#, python-format
+msgid "Package %s installed and not available"
+msgstr "Pacote %s instalado, mas não disponível"
+
+#: ../yum/__init__.py:2525
 msgid "No package(s) available to install"
 msgstr "Nenhum pacote disponível para instalar"
 
-#: ../yum/__init__.py:2158
+#: ../yum/__init__.py:2537
 #, python-format
 msgid "Package: %s  - already in transaction set"
 msgstr "Pacote: %s - já está no conjunto de transações"
 
-#: ../yum/__init__.py:2171
+#: ../yum/__init__.py:2552
+#, python-format
+msgid "Package %s is obsoleted by %s, trying to install %s instead"
+msgstr "O pacote %s foi tornado obsoleto por %s, tentando instalar %s ao invés disso"
+
+#: ../yum/__init__.py:2560
 #, python-format
 msgid "Package %s already installed and latest version"
 msgstr "O pacote %s já está instalado em sua última versão"
 
-#: ../yum/__init__.py:2178
+#: ../yum/__init__.py:2567
 #, python-format
 msgid "Package matching %s already installed. Checking for update."
 msgstr "O pacote %s já está instalado. Verificando por uma atualização."
 
 #. update everything (the easy case)
-#: ../yum/__init__.py:2220
+#: ../yum/__init__.py:2640
 msgid "Updating Everything"
-msgstr "Atualizando Tudo"
+msgstr "Atualizando tudo"
 
-#: ../yum/__init__.py:2304
+#: ../yum/__init__.py:2658
+#: ../yum/__init__.py:2768
+#: ../yum/__init__.py:2790
+#: ../yum/__init__.py:2812
 #, python-format
-msgid "Package is already obsoleted: %s.%s %s:%s-%s"
-msgstr "O pacote já está obsoleto: %s.%s %s:%s-%s"
+msgid "Not Updating Package that is already obsoleted: %s.%s %s:%s-%s"
+msgstr "Pacote já obsoleto não será atualizado: %s.%s %s:%s-%s"
 
-#: ../yum/__init__.py:2377
+#: ../yum/__init__.py:2693
+#: ../yum/__init__.py:2860
 #, python-format
 msgid "%s"
 msgstr "%s"
 
-#: ../yum/__init__.py:2392
+#: ../yum/__init__.py:2759
+#, python-format
+msgid "Package is already obsoleted: %s.%s %s:%s-%s"
+msgstr "O pacote já está obsoleto: %s.%s %s:%s-%s"
+
+#: ../yum/__init__.py:2793
+#: ../yum/__init__.py:2815
+#, python-format
+msgid "Not Updating Package that is already updated: %s.%s %s:%s-%s"
+msgstr "Pacote já atualizado não será atualizado novamente: %s.%s %s:%s-%s"
+
+#: ../yum/__init__.py:2876
 msgid "No package matched to remove"
 msgstr "Nenhum pacote encontrado para remoção"
 
-#: ../yum/__init__.py:2426
+#: ../yum/__init__.py:2910
 #, python-format
 msgid "Cannot open file: %s. Skipping."
 msgstr "Não foi possível abrir o arquivo: %s. Ignorando."
 
-#: ../yum/__init__.py:2429
+#: ../yum/__init__.py:2913
 #, python-format
 msgid "Examining %s: %s"
 msgstr "Examinando %s: %s"
 
-#: ../yum/__init__.py:2436
+#: ../yum/__init__.py:2921
 #, python-format
-msgid ""
-"Package %s not installed, cannot update it. Run yum install to install it "
-"instead."
-msgstr ""
-"O pacote %s não está instalado, não é possível atualizá-lo. Execute o yum "
-"install para instalá-lo."
+msgid "Cannot add package %s to transaction. Not a compatible architecture: %s"
+msgstr "Não foi possível adicionar o pacote %s à transação. %s não é uma arquitetura compatível."
 
-#: ../yum/__init__.py:2468
+#: ../yum/__init__.py:2929
+#, python-format
+msgid "Package %s not installed, cannot update it. Run yum install to install it instead."
+msgstr "O pacote %s não está instalado, não é possível atualizá-lo. Execute o yum install para instalá-lo."
+
+#: ../yum/__init__.py:2962
 #, python-format
 msgid "Excluding %s"
 msgstr "Excluindo %s"
 
-#: ../yum/__init__.py:2473
+#: ../yum/__init__.py:2967
 #, python-format
 msgid "Marking %s to be installed"
 msgstr "Marcando %s para ser instalado"
 
-#: ../yum/__init__.py:2479
+#: ../yum/__init__.py:2973
 #, python-format
 msgid "Marking %s as an update to %s"
 msgstr "Marcando %s como uma atualização do %s"
 
-#: ../yum/__init__.py:2486
+#: ../yum/__init__.py:2980
 #, python-format
 msgid "%s: does not update installed package."
 msgstr "%s: não atualiza o pacote instalado."
 
-#: ../yum/__init__.py:2504
+#: ../yum/__init__.py:2998
 msgid "Problem in reinstall: no package matched to remove"
 msgstr "Problema na reinstalação: nenhum pacote encontrado para remoção"
 
-#: ../yum/__init__.py:2515
+#: ../yum/__init__.py:3009
 #, python-format
 msgid "Package %s is allowed multiple installs, skipping"
 msgstr "O pacote %s permite múltiplas instalações, ignorando"
 
-#: ../yum/__init__.py:2522
+#: ../yum/__init__.py:3016
 msgid "Problem in reinstall: no package matched to install"
 msgstr "Problema na reinstalação: nenhum pacote encontrado para instalação"
 
-#: ../yum/__init__.py:2570
+#: ../yum/__init__.py:3051
 #, python-format
 msgid "Retrieving GPG key from %s"
 msgstr "Obtendo a chave GPG a partir de %s"
 
-#: ../yum/__init__.py:2576
+#: ../yum/__init__.py:3071
 msgid "GPG key retrieval failed: "
 msgstr "A obtenção da chave GPG falhou:"
 
-#: ../yum/__init__.py:2589
-msgid "GPG key parsing failed: "
-msgstr "A análise da chave GPG falhou:"
+#: ../yum/__init__.py:3082
+#, python-format
+msgid "GPG key parsing failed: key does not have value %s"
+msgstr "Falha na análise da chave GPG: ela não tem o valor %s"
 
-#: ../yum/__init__.py:2593
+#: ../yum/__init__.py:3114
 #, python-format
 msgid "GPG key at %s (0x%s) is already installed"
 msgstr "A chave GPG em %s (0x%s) já está instalada"
 
 #. Try installing/updating GPG key
-#: ../yum/__init__.py:2598
+#: ../yum/__init__.py:3119
+#: ../yum/__init__.py:3181
 #, python-format
 msgid "Importing GPG key 0x%s \"%s\" from %s"
 msgstr "Importando chave GPG 0x%s \"%s\" a partir de %s"
 
-#: ../yum/__init__.py:2610
+#: ../yum/__init__.py:3136
 msgid "Not installing key"
 msgstr "Não está instalando a chave"
 
-#: ../yum/__init__.py:2616
+#: ../yum/__init__.py:3142
 #, python-format
 msgid "Key import failed (code %d)"
 msgstr "Falha na importação da chave (código %d)"
 
-#: ../yum/__init__.py:2619
+#: ../yum/__init__.py:3143
+#: ../yum/__init__.py:3202
 msgid "Key imported successfully"
 msgstr "Chave importada com sucesso"
 
-#: ../yum/__init__.py:2624
+#: ../yum/__init__.py:3148
+#: ../yum/__init__.py:3207
 #, python-format
 msgid ""
-"The GPG keys listed for the \"%s\" repository are already installed but they "
-"are not correct for this package.\n"
+"The GPG keys listed for the \"%s\" repository are already installed but they are not correct for this package.\n"
 "Check that the correct key URLs are configured for this repository."
 msgstr ""
-"As chaves GPG listadas para o repositório \"%s\" já estão instaladas, mas "
-"não estão corretas para este pacote.\n"
-"Verifique se as URLs corretas das chaves estão configuradas para esse "
-"repositório."
+"As chaves GPG listadas para o repositório \"%s\" já estão instaladas, mas não estão corretas para este pacote.\n"
+"Verifique se as URLs corretas das chaves estão configuradas para esse repositório."
 
-#: ../yum/__init__.py:2633
+#: ../yum/__init__.py:3157
 msgid "Import of key(s) didn't help, wrong key(s)?"
 msgstr "A importação da(s) chave(s) não ajudou, chave(s) errada(s)?"
 
-#: ../yum/__init__.py:2707
+#: ../yum/__init__.py:3176
+#, python-format
+msgid "GPG key at %s (0x%s) is already imported"
+msgstr "A chave GPG em %s (0x%s) já foi importada"
+
+#: ../yum/__init__.py:3196
+#, python-format
+msgid "Not installing key for repo %s"
+msgstr "A chave para o repositório %s não será instalada"
+
+#: ../yum/__init__.py:3201
+msgid "Key import failed"
+msgstr "Falha na importação da chave"
+
+#: ../yum/__init__.py:3292
 msgid "Unable to find a suitable mirror."
 msgstr "Não foi possível encontrar um espelho apropriado."
 
-#: ../yum/__init__.py:2709
+#: ../yum/__init__.py:3294
 msgid "Errors were encountered while downloading packages."
 msgstr "Foram encontrados erros ao baixar os pacotes."
 
-#: ../yum/__init__.py:2774
+#: ../yum/__init__.py:3335
+#, python-format
+msgid "Please report this error at %s"
+msgstr "Por favor, relate esse erro em %s"
+
+#: ../yum/__init__.py:3359
 msgid "Test Transaction Errors: "
-msgstr "Erros do Teste de Transação:"
+msgstr "Erros do teste de transação:"
 
 #. Mostly copied from YumOutput._outKeyValFill()
-#: ../yum/plugins.py:195
+#: ../yum/plugins.py:201
 msgid "Loaded plugins: "
 msgstr "Plugins carregados: "
 
-#: ../yum/plugins.py:206
+#: ../yum/plugins.py:215
+#: ../yum/plugins.py:221
 #, python-format
 msgid "No plugin match for: %s"
-msgstr "Nenhum plugin correspondente com: %s"
+msgstr "Nenhum plugin correspondente para: %s"
 
-#: ../yum/plugins.py:219
+#: ../yum/plugins.py:251
 #, python-format
 msgid "\"%s\" plugin is disabled"
 msgstr "O plugin \"%s\" está desabilitado"
 
-#: ../yum/plugins.py:231
+#. Give full backtrace:
+#: ../yum/plugins.py:263
+#, python-format
+msgid "Plugin \"%s\" can't be imported"
+msgstr "O plugin \"%s\" não pôde ser importado"
+
+#: ../yum/plugins.py:270
 #, python-format
 msgid "Plugin \"%s\" doesn't specify required API version"
 msgstr "O plugin \"%s\" não especifica a versão requerida da API"
 
-#: ../yum/plugins.py:235
+#: ../yum/plugins.py:275
 #, python-format
 msgid "Plugin \"%s\" requires API %s. Supported API is %s."
 msgstr "O plugin \"%s\" requer a API %s. A API suportada é a %s."
 
-#: ../yum/plugins.py:264
+#: ../yum/plugins.py:308
 #, python-format
 msgid "Loading \"%s\" plugin"
 msgstr "Carregando o plugin \"%s\""
 
-#: ../yum/plugins.py:271
+#: ../yum/plugins.py:315
 #, python-format
-msgid ""
-"Two or more plugins with the name \"%s\" exist in the plugin search path"
-msgstr ""
-"Dois ou mais plugins com o nome \"%s\" existem no caminho de pesquisa plugins"
+msgid "Two or more plugins with the name \"%s\" exist in the plugin search path"
+msgstr "Dois ou mais plugins com o nome \"%s\" existem no caminho de pesquisa plugins"
 
-#: ../yum/plugins.py:291
+#: ../yum/plugins.py:335
 #, python-format
 msgid "Configuration file %s not found"
 msgstr "Arquivos de configuração %s não encontrado"
 
 #. for
 #. Configuration files for the plugin not found
-#: ../yum/plugins.py:294
+#: ../yum/plugins.py:338
 #, python-format
 msgid "Unable to find configuration file for plugin %s"
 msgstr "Não foi possível encontrar o arquivo de configuração para o plugin %s"
 
-#: ../yum/plugins.py:448
+#: ../yum/plugins.py:492
 msgid "registration of commands not supported"
 msgstr "O registro de comandos não é suportado"
 
+#: ../yum/rpmtrans.py:78
+msgid "Repackaging"
+msgstr "Reempacotando"
+
 #: ../rpmUtils/oldUtils.py:26
 #, python-format
 msgid "Header cannot be opened or does not match %s, %s."
@@ -1922,58 +2185,68 @@ msgstr "O RPM %s não passou na verificação md5"
 
 #: ../rpmUtils/oldUtils.py:144
 msgid "Could not open RPM database for reading. Perhaps it is already in use?"
-msgstr ""
-"Não foi possível abrir o banco de dados RPM para leitura. Talvez por que ele "
-"já esteja em uso?"
+msgstr "Não foi possível abrir o banco de dados RPM para leitura. Talvez por que ele já esteja em uso?"
 
 #: ../rpmUtils/oldUtils.py:174
 msgid "Got an empty Header, something has gone wrong"
 msgstr "Um cabeçalho vazio foi obtido, algo deu errado"
 
-#: ../rpmUtils/oldUtils.py:244 ../rpmUtils/oldUtils.py:251
-#: ../rpmUtils/oldUtils.py:254 ../rpmUtils/oldUtils.py:257
+#: ../rpmUtils/oldUtils.py:244
+#: ../rpmUtils/oldUtils.py:251
+#: ../rpmUtils/oldUtils.py:254
+#: ../rpmUtils/oldUtils.py:257
 #, python-format
 msgid "Damaged Header %s"
-msgstr "Cabeçalho %s Danificado"
+msgstr "Cabeçalho %s danificado"
 
 #: ../rpmUtils/oldUtils.py:272
 #, python-format
 msgid "Error opening rpm %s - error %s"
 msgstr "Erro ao abrir o rpm %s - erro %s"
 
+#~ msgid "Could not find update match for %s"
+#~ msgstr "Não foi possível encontrar uma atualização correspondente ao %s"
+#~ msgid ""
+#~ "Failure finding best provider of %s for %s, exceeded maximum loop length"
+#~ msgstr ""
+#~ "Falha ao encontrar o melhor fornecedor de %s para %s, tamanho máximo do "
+#~ "loop excedido"
+#~ msgid "Comparing best: %s to po: %s"
+#~ msgstr "Comparando melhor: %s para po: %s"
+#~ msgid "Same: best %s == po: %s"
+#~ msgstr "Igual: melhor %s == po: %s"
+#~ msgid "po %s obsoletes best: %s"
+#~ msgstr "po %s torna melhor obsoleto: %s"
+#~ msgid "po %s shares a sourcerpm with %s"
+#~ msgstr "po %s compartilha um sourcerpm com %s"
+#~ msgid "best %s shares a sourcerpm with %s"
+#~ msgstr "melhor %s compartilha um sourcerpm com %s"
+#~ msgid "po %s shares more of the name prefix with %s"
+#~ msgstr "po %s compartilha mais do prefixo do nome com %s"
+#~ msgid "po %s has a shorter name than best %s"
+#~ msgstr "po %s tem um nome mais curto do que o melhor %s"
+#~ msgid "bestpkg %s shares more of the name prefix with %s"
+#~ msgstr "bestpkg %s compartilha mais do prefixo do nome com %s"
 #~ msgid "Looking for Obsoletes for %s"
 #~ msgstr "Localizando Obsoletos para %s"
-
 #~ msgid "unable to find newer package for %s"
 #~ msgstr "não foi possível encontrar um pacote mais recente para o %s"
-
 #~ msgid "TSINFO: Updating %s to resolve conflict."
 #~ msgstr "TSINFO: Atualizando o %s para resolver o conflito."
-
 #~ msgid "%s conflicts: %s"
 #~ msgstr "%s conflita com: %s"
-
 #~ msgid "%s conflicts with %s"
 #~ msgstr "%s conflita com %s"
-
-#~ msgid "Package %s needs %s, this is not available."
-#~ msgstr "O pacote %s necessita do %s, que não está disponível."
-
 #~ msgid "Package %s conflicts with %s."
 #~ msgstr "O pacote %s conflita com %s."
-
 #~ msgid "Running \"%s\" handler for \"%s\" plugin"
 #~ msgstr "Executando o manipulador \"%s\" para o plugin \"%s\""
-
 #~ msgid "Directory of rpms must exist"
 #~ msgstr "O diretório de rpms precisa existir"
-
 #~ msgid "Error accessing URL: %s"
 #~ msgstr "Erro ao acessar a URL: %s"
-
 #~ msgid "No Packages installed not included in a repository"
 #~ msgstr "Nenhum pacote instalado não incluído em um repositório"
-
 #~ msgid ""
 #~ "\n"
 #~ "   Total: %d\n"
@@ -1984,13 +2257,10 @@ msgstr "Erro ao abrir o rpm %s - erro %s"
 #~ "   Total: %d\n"
 #~ "   Usado: %d\n"
 #~ "   Src: %d"
-
 #~ msgid "Error restoring the backup of lilo.conf  The backup was:\n"
 #~ msgstr "Erro ao restaurar o backup do lilo.conf. O backup era:\n"
-
 #~ msgid "Looking in available packages for a providing package"
 #~ msgstr "Procurando pelo pacote fornecido nos pacotes disponíveis"
-
 #~ msgid ""
 #~ "retrygrab() failed for:\n"
 #~ "  %s%s\n"
@@ -1999,16 +2269,12 @@ msgstr "Erro ao abrir o rpm %s - erro %s"
 #~ "retrygrab() falhou para:\n"
 #~ "  %s%s\n"
 #~ "  Executando método de recuperação"
-
 #~ msgid "I will install/upgrade these to satisfy the dependencies:"
 #~ msgstr "Eu irei instalar/atualizar isto para satisfazer as dependências:"
-
 #~ msgid "Cannot delete %s - check perms"
 #~ msgstr "Não foi possível remover %s - verifique as permissões"
-
 #~ msgid "Need a provides to match"
 #~ msgstr "É necessário fornecer uma informação para corresponder"
-
 #~ msgid ""
 #~ "lilo options that are not supported by yum are used in the default lilo."
 #~ "conf. This file will not be modified. The options include:\n"
@@ -2016,13 +2282,10 @@ msgstr "Erro ao abrir o rpm %s - erro %s"
 #~ "opções do lilo que não são suportadas pelo yum estão sendo utilizadas no "
 #~ "arquivo lilo.conf padrão. Este arquivo não será modificado. Dentre as "
 #~ "opções estão:\n"
-
 #~ msgid "Error getting file %s"
 #~ msgstr "Erro ao obter arquivo %s"
-
 #~ msgid "%s is not writable"
 #~ msgstr "%s não é gravável"
-
 #~ msgid ""
 #~ "\n"
 #~ "Already found tuple: %s %s:\n"
@@ -2031,117 +2294,86 @@ msgstr "Erro ao abrir o rpm %s - erro %s"
 #~ "\n"
 #~ "Tupla já encontrada: %s %s:\n"
 #~ "%s "
-
 #~ msgid "errors found"
 #~ msgstr "erros encontrados"
-
 #~ msgid "Unable to determine boot loader."
 #~ msgstr "Não foi possível determinar o gerenciador de inicialização."
-
 #~ msgid "getting %s"
 #~ msgstr "obtendo %s"
-
 #~ msgid "Error Reading Header on %s"
 #~ msgstr "Erro ao Ler Cabeçalho em %s"
-
 #~ msgid "Error accessing File: %s"
 #~ msgstr "Erro ao acessar arquivo: %s"
-
 #~ msgid "You're not root, we can't install things"
 #~ msgstr "Você não é root, nós não podemos instalar coisas"
-
 #~ msgid "Cannot find any conf file."
 #~ msgstr "Não foi possível encontrar um arquivo de configuração."
-
 #~ msgid "Local file does not exist: %s"
 #~ msgstr "O arquivo local não existe: %s"
-
 #~ msgid "using ftp, http[s], or file for servers, Aborting - %s"
 #~ msgstr "usando ftp, http[s] ou arquivos para servidores. Abortando - %s"
-
 #~ msgid "Found %s."
 #~ msgstr "%s encontrado."
-
 #~ msgid "Transaction(s) Complete"
 #~ msgstr "Transação Completa"
-
 #~ msgid "IOError: %s"
 #~ msgstr "IOError (Erro E/S): %s"
-
 #~ msgid "Cleaning packages and old headers"
 #~ msgstr "Limpando pacotes e cabeçalhos antigos"
-
 #~ msgid ""
 #~ "Cannot download %s in caching only mode or when running as non-root user."
 #~ msgstr ""
 #~ "Não é possível baixar %s no modo \"somente cache\" ou quando estiver "
 #~ "executando com um usuário não root."
-
 #~ msgid ""
 #~ "Error: You may want to run yum clean or remove the file: \n"
 #~ " %s"
 #~ msgstr ""
 #~ "Erro: Você pode querer executar a limpeza do yum ou remover o arquivo: \n"
 #~ " %s"
-
 #~ msgid "Error reading lilo.conf: The messages was:\n"
 #~ msgstr "Erro ao ler o lilo.conf: A mensagem foi:\n"
-
 #~ msgid "No groups provided or accessible on any server."
 #~ msgstr "Nenhum grupo fornecido ou acessível em nenhum servidor."
-
 #~ msgid "%s results returned"
 #~ msgstr "%s resultados retornados"
-
 #~ msgid "Error moving %s to %s, fatal"
 #~ msgstr "Erro ao mover %s para %s, fatal"
-
 #~ msgid ""
 #~ "\n"
 #~ "ignoring bad rpm: %s"
 #~ msgstr ""
 #~ "\n"
 #~ "ignorando rpm defeituoso: %s"
-
 #~ msgid "[erase: %s]"
 #~ msgstr "[remover: %s]"
-
 #~ msgid "%s is not a dir"
 #~ msgstr "%s não é um diretório"
-
 #~ msgid "Best version for %s is %s:%s-%s"
 #~ msgstr "A melhor versão para %s é %s:%s-%s"
-
 #~ msgid "[deps: %s]"
 #~ msgstr "[deps: %s]"
-
 #~ msgid ""
 #~ "\n"
 #~ "ignoring srpm: %s"
 #~ msgstr ""
 #~ "\n"
 #~ "ignorando srpm: %s"
-
 #~ msgid "Checking deps %d/%d complete"
 #~ msgstr "Checando dependências, %d/%d completo"
-
 #~ msgid ""
 #~ "Errors within the dir(s):\n"
 #~ " %s"
 #~ msgstr ""
 #~ "Erro dentro do(s) diretório(s):\n"
 #~ " %s"
-
 #~ msgid "Please run yum in non-caching mode to correct this header."
 #~ msgstr ""
 #~ "Por favor, execute o yum no modo sem cache para corrigir este cabeçalho."
-
 #~ msgid "Error installing lilo.conf  The message was:\n"
 #~ msgstr "Erro ao instalar o lilo.conf. A mensagem foi:\n"
-
 #~ msgid "Error: Untrusted GPG key on %s"
 #~ msgstr "Erro: Chave GPG não confiável em %s"
-
 #~ msgid ""
 #~ "\n"
 #~ "\n"
@@ -2152,69 +2384,50 @@ msgstr "Erro ao abrir o rpm %s - erro %s"
 #~ "\n"
 #~ "Problema com a assinatura gpg ou com o md5sum em %s\n"
 #~ "\n"
-
 #~ msgid "No Packages Available for Update or Install"
 #~ msgstr "Nenhum Pacote Disponível para Atualização ou Instalação"
-
 #~ msgid "Found best arch for install only pkg %s"
 #~ msgstr "Encontre a melhor arquitetura para instalar apenas o pacote %s"
-
 #~ msgid "I will do the following:"
 #~ msgstr "Eu farei o seguinte:"
-
 #~ msgid "Bad URL: %s"
 #~ msgstr "URL Inválida: %s"
-
 #~ msgid "NonMatching RPM version, %s, removing."
 #~ msgstr "Versão do RPM não coincide, %s, removendo."
-
 #~ msgid "I will erase these to satisfy the dependencies:"
 #~ msgstr "Eu irei apagar isto para satisfazer as dependências:"
-
 #~ msgid "HTTP Error (%s): %s"
 #~ msgstr "Erro HTTP (%s): %s"
-
 #~ msgid "Please ask your sysadmin to update the headers on this system."
 #~ msgstr ""
 #~ "Por favor, peça ao administrador do seu sistema para atualizar os "
 #~ "cabeçalhos."
-
 #~ msgid "Putting back old headers"
 #~ msgstr "Recolocando cabeçalhos antigos"
-
 #~ msgid "CacheDir: %s"
 #~ msgstr "CacheDir (diretório de cache): %s"
-
 #~ msgid "Completing update for %s  - %d/%d"
 #~ msgstr "Completando atualização para %s - %d/%d"
-
 #~ msgid ""
 #~ "Error: You may need to disable gpg checking to install this package\n"
 #~ msgstr ""
 #~ "Erro: Talvez seja necessário desabilitar a verificação gpg para instalar "
 #~ "este pacote\n"
-
 #~ msgid "Options Error: no commands found"
 #~ msgstr "Erro nas opções: nenhum comando encontrado"
-
 #~ msgid "Unable to run grubby correctly: the message was:\n"
 #~ msgstr "Não foi possível executar o grubby corretamente: a mensagem foi:\n"
-
 #~ msgid "IOError - # %s - %s"
 #~ msgstr "IOError (Erro E/S) - # %s - %s"
-
 #~ msgid "Kernel Updated/Installed, checking for bootloader"
 #~ msgstr ""
 #~ "Kernel atualizado/instalado, verificando gerenciador de inicialização"
-
 #~ msgid "Need to pass a list of pkgs to install"
 #~ msgstr "É necessário passar uma lista de pacotes para instalar"
-
 #~ msgid "Insufficient server config - no servers found. Aborting."
 #~ msgstr ""
 #~ "Configuração de servidor insuficiente - nenhum servidor encontrado. "
 #~ "Abortando."
-
 #~ msgid ""
 #~ "\n"
 #~ "    Usage:  yum [options] <update | upgrade | install | info | remove | "
@@ -2260,102 +2473,76 @@ msgstr "Erro ao abrir o rpm %s - erro %s"
 #~ "          --version - exibe a versão do yum\n"
 #~ "          -h, --help - exibe esta tela\n"
 #~ "    "
-
 #~ msgid "From %s installing %s"
 #~ msgstr "A partir de %s, instalando %s"
-
 #~ msgid "No bootloader found, Cannot configure kernel, continuing."
 #~ msgstr ""
 #~ "Nenhum gerenciador de inicialização encontrado. Não é possível configurar "
 #~ "o kernel, continuando."
-
 #~ msgid "Attempt to delete a missing file %s - ignoring."
 #~ msgstr "Tentativa de remover um arquivo faltando %s - ignorando."
-
 #~ msgid "Getting %s"
 #~ msgstr "Obtendo %s"
-
 #~ msgid ""
 #~ "\n"
 #~ "Writing header.info file"
 #~ msgstr ""
 #~ "\n"
 #~ "Gravando arquivo header.info"
-
 #~ msgid "Gathering header information file(s) from server(s)"
 #~ msgstr ""
 #~ "Coletando arquivo(s) de informações de cabeçalhos a partir do(s) servidor"
 #~ "(es)"
-
 #~ msgid "Using cached header.info file"
 #~ msgstr "Utilizando arquivo header.info do cache"
-
 #~ msgid "localrpmdb not defined"
 #~ msgstr "localrpmdb não definido"
-
 #~ msgid "Error installing the new bootloader: \n"
 #~ msgstr "Erro ao instalar o novo gerenciador de inicialização: \n"
-
 #~ msgid "Error: Could not find the GPG Key necessary to validate pkg %s"
 #~ msgstr ""
 #~ "Erro: Não foi possível localizar a Chave GPG necessária para validar o "
 #~ "pacote %s"
-
 #~ msgid "No actions to take"
 #~ msgstr "Nenhuma ação a ser tomada"
-
 #~ msgid ""
 #~ "Available package: %s.%s %s:%s-%s from %s matches with\n"
 #~ " %s"
 #~ msgstr ""
 #~ "Pacote disponível: %s.%s %s:%s-%s de %s resultados com\n"
 #~ " %s"
-
 #~ msgid "   "
 #~ msgstr "   "
-
 #~ msgid "Error: Cannot find baseurl or name for server '%s'. Skipping"
 #~ msgstr ""
 #~ "Erro: Não foi possível localizar a baseurl ou o nome do servidor \"%s\". "
 #~ "Ignorando."
-
 #~ msgid "Odd header %s suddenly disappeared"
 #~ msgstr "Cabeçalho indefinido %s desapareceu repentinamente"
-
 #~ msgid "All dependencies resolved and no conflicts detected"
 #~ msgstr "Todas as dependências resolvidas e nenhum conflito detectado"
-
 #~ msgid "using cached groups from server: %s"
 #~ msgstr "usando grupos em cache a partir do servidor: %s"
-
 #~ msgid "Exiting."
 #~ msgstr "Saindo."
-
 #~ msgid ""
 #~ "asking for package %s.%s - does not exist in nevral - bailing out - check "
 #~ "rpmdb for errors"
 #~ msgstr ""
 #~ "perguntando pelo pacote %s.%s - não existe no nevral - saindo "
 #~ "abruptamente - verifique por erros no rpmdb"
-
 #~ msgid "Errors reported doing trial run"
 #~ msgstr "Erros reportados na execução experimental"
-
 #~ msgid "Lilo found - adding kernel to lilo and making it the default"
 #~ msgstr "Lilo encontrado - adicionando o kernel ao lilo e tornando-o padrão"
-
 #~ msgid "[update: %s]"
 #~ msgstr "[atualizar: %s]"
-
 #~ msgid "ERROR: Url Return no Content-Length  - something is wrong"
 #~ msgstr "ERRO: A URL retornou conteúdo vazio - algo está errado"
-
 #~ msgid "Got a file - yay"
 #~ msgstr "Obteve um arquivo - yay"
-
 #~ msgid "From %s updating %s"
 #~ msgstr "A partir de %s, atualizando %s"
-
 #~ msgid ""
 #~ "Usage:\n"
 #~ "yum-arch [-v] [-z] [-l] [-c] [-n] [-d] [-q] [-vv] (path of dir where "
@@ -2385,77 +2572,54 @@ msgstr "Erro ao abrir o rpm %s - erro %s"
 #~ "   -l  = utiliza links simbólicos como rpms válidos ao compilar "
 #~ "cabeçalhos\n"
 #~ "   -q  = faz uma exibição mais discreta"
-
 #~ msgid "The file %s is damaged."
 #~ msgstr "O arquivo %s está danificado."
-
 #~ msgid "Repo"
 #~ msgstr "Repo"
-
 #~ msgid "No bootloader found, Cannot configure kernel."
 #~ msgstr ""
 #~ "Nenhum gerenciador de inicialização encontrado. Não é possível configurar "
 #~ "o kernel."
-
 #~ msgid "Name"
 #~ msgstr "Nome"
-
-#~ msgid "[install: %s]"
-#~ msgstr "[instalar: %s]"
-
 #~ msgid "Downloading needed headers"
 #~ msgstr "Baixando os cabeçalhos necessários"
-
 #~ msgid "Header for pkg %s not found"
 #~ msgstr "O cabeçalho para o pacote %s não foi encontrado"
-
 #~ msgid "Cleaning all headers"
 #~ msgstr "Limpando todos os cabeçalhos"
-
 #~ msgid "depcheck: package %s needs %s"
 #~ msgstr "verificação de dependências: o pacote %s precisa do %s"
-
 #~ msgid "Error - %s cannot be found"
 #~ msgstr "Erro - %s não pôde ser encontrado"
-
 #~ msgid "Erasing: %s %d/%d"
 #~ msgstr "Apagando: %s %d/%d"
-
 #~ msgid "Nothing in any group to update or install"
 #~ msgstr "Nada em nenhum grupo para atualizar ou instalar"
-
 #~ msgid "Grub found - making this kernel the default"
 #~ msgstr "Grub encontrado - tornando este kernel o padrão"
-
 #~ msgid "Digesting rpm - %s - %d/%d"
 #~ msgstr "Preparando rpm - %s - %d/%d"
-
 #~ msgid "Damaged RPM %s, removing."
 #~ msgstr "RPM %s danificado, removendo."
-
 #~ msgid ""
 #~ "Bad Header for pkg %s.%s trying to get headers for the nevral - exiting"
 #~ msgstr ""
 #~ "Cabeçalho danificado para o pacote %s.%s, tentando obter cabeçalhos para "
 #~ "o nevral - saindo"
-
 #~ msgid ""
 #~ "Error: You may also check that you have the correct GPG keys installed"
 #~ msgstr ""
 #~ "Erro: Você também pode verificar se tem as Chaves GPG corretas instaladas"
-
 #~ msgid "No rpms to work with and no header dir. Exiting."
 #~ msgstr ""
 #~ "Nenhum diretório de cabeçalhos e nenhum rpm para ser utilizado. Saindo."
-
 #~ msgid "ignoring bad rpm: %s"
 #~ msgstr "ignorando rpm danificado: %s"
-
 #~ msgid "Directory of rpms must be a directory."
 #~ msgstr "O diretório de rpms deve ser um diretório."
-
 #~ msgid "failover: out of servers to try"
 #~ msgstr "recuperação: não há mais servidores para tentar"
-
 #~ msgid "Getting header.info from server"
 #~ msgstr "Obtendo header.info do servidor"
+
diff --git a/po/sr.po b/po/sr.po
old mode 100644
new mode 100755
index afff3ea..a8de8e7
--- a/po/sr.po
+++ b/po/sr.po
@@ -1,42 +1,43 @@
-# translation of sr.po to Serbian
 # Serbian translations for yum
 # Copyright (C) 2008 Linux@Duke
 # This file is distributed under the same license as the yum package.
-#
 # Jovan Krunic <jovan.krunic@gmail.com>, 2008.
 # Igor Miletic <grejigl-gnomeprevod@yahoo.ca>, 2008.
 # Miloš Komarčević <kmilos@gmail.com>, 2008.
+#
 msgid ""
 msgstr ""
 "Project-Id-Version: yum\n"
 "Report-Msgid-Bugs-To: \n"
-"POT-Creation-Date: 2008-03-25 11:29+0100\n"
-"PO-Revision-Date: 2008-05-26 20:30-0000\n"
+"POT-Creation-Date: 2008-10-27 13:29+0000\n"
+"PO-Revision-Date: 2008-10-27 22:52+0000\n"
 "Last-Translator: Miloš Komarčević <kmilos@gmail.com>\n"
 "Language-Team: Serbian (sr) <fedora-trans-sr@redhat.com>\n"
 "MIME-Version: 1.0\n"
 "Content-Type: text/plain; charset=UTF-8\n"
 "Content-Transfer-Encoding: 8bit\n"
-"Plural-Forms: nplurals=3; plural=(n%10==1 && n%100!=11 ? 0 : n%10>=2 && n%"
-"10<=4 && (n%100<10 || n%100>=20) ? 1 : 2);\n"
+"Plural-Forms: nplurals=3; plural=n%10==1 && n%100!=11 ? 0 : n%10>=2 && n%"
+"10<=4 && (n%100<10 || n%100>=20) ? 1 : 2;\n"
 
-#: ../callback.py:48 ../output.py:512
+#: ../callback.py:48 ../output.py:777 ../yum/rpmtrans.py:71
 msgid "Updating"
-msgstr "Aжурирам"
+msgstr "Ажурирам"
 
-#: ../callback.py:49
+#: ../callback.py:49 ../yum/rpmtrans.py:72
 msgid "Erasing"
 msgstr "Бришем"
 
-#: ../callback.py:50 ../callback.py:51 ../callback.py:53 ../output.py:511
+#. Arch can't get "that big" ... so always use the max.
+#: ../callback.py:50 ../callback.py:51 ../callback.py:53 ../output.py:776
+#: ../yum/rpmtrans.py:73 ../yum/rpmtrans.py:74 ../yum/rpmtrans.py:76
 msgid "Installing"
 msgstr "Инсталирам"
 
-#: ../callback.py:52 ../callback.py:58
+#: ../callback.py:52 ../callback.py:58 ../yum/rpmtrans.py:75
 msgid "Obsoleted"
 msgstr "Превазиђени"
 
-#: ../callback.py:54 ../output.py:558
+#: ../callback.py:54 ../output.py:891
 msgid "Updated"
 msgstr "Ажурирани"
 
@@ -44,7 +45,7 @@ msgstr "Ажурирани"
 msgid "Erased"
 msgstr "Обрисани"
 
-#: ../callback.py:56 ../callback.py:57 ../callback.py:59 ../output.py:556
+#: ../callback.py:56 ../callback.py:57 ../callback.py:59 ../output.py:889
 msgid "Installed"
 msgstr "Инсталирани"
 
@@ -66,53 +67,68 @@ msgstr "Грешка: погрешно излазно стање: %s за %s"
 msgid "Erased: %s"
 msgstr "Обрисано: %s"
 
-#: ../callback.py:217 ../output.py:513
+#: ../callback.py:217 ../output.py:778
 msgid "Removing"
 msgstr "Уклањам"
 
-#: ../callback.py:219
+#: ../callback.py:219 ../yum/rpmtrans.py:77
 msgid "Cleanup"
 msgstr "Чишћење"
 
-#: ../cli.py:103
+#: ../cli.py:105
 #, python-format
 msgid "Command \"%s\" already defined"
 msgstr "Наредба „%s“ је већ дефинисана"
 
-#: ../cli.py:115
+#: ../cli.py:117
 msgid "Setting up repositories"
 msgstr "Постављам ризнице"
 
-#: ../cli.py:126
+#: ../cli.py:128
 msgid "Reading repository metadata in from local files"
 msgstr "Читам метаподатке ризница из локалних датотека"
 
-#: ../cli.py:183 ../utils.py:72
+#: ../cli.py:187 ../utils.py:71
 #, python-format
 msgid "Config Error: %s"
 msgstr "Грешка при подешавању: %s"
 
-#: ../cli.py:186 ../cli.py:1068 ../utils.py:75
+#: ../cli.py:190 ../cli.py:1128 ../utils.py:74
 #, python-format
 msgid "Options Error: %s"
 msgstr "Грешка у опцијама: %s"
 
-#: ../cli.py:229
+#: ../cli.py:218
+#, python-format
+msgid "  Installed: %s-%s at %s"
+msgstr "  Инсталирано: %s-%s на %s"
+
+#: ../cli.py:220
+#, fuzzy, python-format
+msgid "  Built    : %s at %s"
+msgstr "УРЛ        : %s"
+
+#: ../cli.py:222
+#, fuzzy, python-format
+msgid "  Committed: %s at %s"
+msgstr "Објављивач : %s"
+
+#: ../cli.py:259
 msgid "You need to give some command"
 msgstr "Морате да унесете неку команду"
 
-#: ../cli.py:271
+#: ../cli.py:301
 msgid "Disk Requirements:\n"
 msgstr "Захтеви диска:\n"
 
-#: ../cli.py:273
+#: ../cli.py:303
 #, python-format
 msgid "  At least %dMB needed on the %s filesystem.\n"
 msgstr "  Потребно је најмање %dМБ на %s систему датотека.\n"
 
 #. TODO: simplify the dependency errors?
 #. Fixup the summary
-#: ../cli.py:278
+#: ../cli.py:308
 msgid ""
 "Error Summary\n"
 "-------------\n"
@@ -120,55 +136,55 @@ msgstr ""
 "Сажетак грешака\n"
 "-------------\n"
 
-#: ../cli.py:317
+#: ../cli.py:351
 msgid "Trying to run the transaction but nothing to do. Exiting."
 msgstr "Покушавам да извршим трансакцију али нема шта да се ради. Излазим."
 
-#: ../cli.py:347
+#: ../cli.py:381
 msgid "Exiting on user Command"
 msgstr "Излазим на команду корисника"
 
-#: ../cli.py:351
+#: ../cli.py:385
 msgid "Downloading Packages:"
 msgstr "Преузимам пакете:"
 
-#: ../cli.py:356
+#: ../cli.py:390
 msgid "Error Downloading Packages:\n"
 msgstr "Грешка при преузимању пакета:\n"
 
-#: ../cli.py:370 ../yum/__init__.py:2746
+#: ../cli.py:404 ../yum/__init__.py:3182
 msgid "Running rpm_check_debug"
 msgstr "Извршавам rpm_check_debug"
 
-#: ../cli.py:373 ../yum/__init__.py:2749
+#: ../cli.py:407 ../yum/__init__.py:3185
 msgid "ERROR with rpm_check_debug vs depsolve:"
 msgstr "ГРЕШКА са rpm_check_debug у односу на depsolve:"
 
-#: ../cli.py:377 ../yum/__init__.py:2751
+#: ../cli.py:411 ../yum/__init__.py:3187
 msgid "Please report this error in bugzilla"
 msgstr "Молим вас, пријавите ову грешку у bugzilla-и"
 
-#: ../cli.py:383
+#: ../cli.py:417
 msgid "Running Transaction Test"
 msgstr "Извршавам проверу трансакције"
 
-#: ../cli.py:399
+#: ../cli.py:433
 msgid "Finished Transaction Test"
-msgstr "Завршио сам проверу трансакције"
+msgstr "Завршена је провера трансакције"
 
-#: ../cli.py:401
+#: ../cli.py:435
 msgid "Transaction Check Error:\n"
 msgstr "Грешка при провери трансакције:\n"
 
-#: ../cli.py:408
+#: ../cli.py:442
 msgid "Transaction Test Succeeded"
 msgstr "Провера трансакције је успела"
 
-#: ../cli.py:429
+#: ../cli.py:463
 msgid "Running Transaction"
 msgstr "Извршавам трансакцију"
 
-#: ../cli.py:459
+#: ../cli.py:493
 msgid ""
 "Refusing to automatically import keys when running unattended.\n"
 "Use \"-y\" to override."
@@ -176,378 +192,426 @@ msgstr ""
 "Одбијам да аутоматски увезем кључеве када се извршавање не надгледа.\n"
 "За превазилажење овога користите „-y“."
 
-#: ../cli.py:491
-msgid "Parsing package install arguments"
-msgstr "Рашчлањујем аргументе инсталације пакета"
+#: ../cli.py:512 ../cli.py:545
+msgid "  * Maybe you meant: "
+msgstr "  * Можда сте мислили: "
+
+#: ../cli.py:528 ../cli.py:536
+#, python-format
+msgid "Package(s) %s%s%s available, but not installed."
+msgstr "%s%s%s пакет је доступан, али није инсталиран."
 
-#: ../cli.py:501
+#: ../cli.py:542 ../cli.py:577
 #, python-format
-msgid "No package %s available."
-msgstr "Не постоји доступан %s пакет."
+msgid "No package %s%s%s available."
+msgstr "Не постоји доступан %s%s%s пакет."
 
-#: ../cli.py:505 ../cli.py:623 ../yumcommands.py:748
+#: ../cli.py:567
+msgid "Parsing package install arguments"
+msgstr "Рашчлањујем аргументе инсталације пакета"
+
+#: ../cli.py:582 ../cli.py:657 ../yumcommands.py:912
 msgid "Package(s) to install"
 msgstr "Пакет(и) који ће се инсталирати"
 
-#: ../cli.py:506 ../cli.py:624 ../yumcommands.py:146 ../yumcommands.py:749
+#: ../cli.py:583 ../cli.py:658 ../yumcommands.py:150 ../yumcommands.py:913
 msgid "Nothing to do"
 msgstr "Нема шта да се ради"
 
-#: ../cli.py:536 ../yum/__init__.py:2232 ../yum/__init__.py:2311
-#: ../yum/__init__.py:2340
-#, python-format
-msgid "Not Updating Package that is already obsoleted: %s.%s %s:%s-%s"
-msgstr "Не ажурирам пакете који су већ превазиђени: %s.%s %s:%s-%s"
-
-#: ../cli.py:568
-#, python-format
-msgid "Could not find update match for %s"
-msgstr "Не могу да пронађем одговарајуће ажурирање за %s"
-
-#: ../cli.py:580
+#: ../cli.py:616
 #, python-format
 msgid "%d packages marked for Update"
 msgstr "%d пакети означени за ажурирање"
 
-#: ../cli.py:583
+#: ../cli.py:619
 msgid "No Packages marked for Update"
 msgstr "Нема пакета означених за ажурирање"
 
-#: ../cli.py:599
+#: ../cli.py:633
 #, python-format
 msgid "%d packages marked for removal"
 msgstr "%d пакети означени за уклањање"
 
-#: ../cli.py:602
+#: ../cli.py:636
 msgid "No Packages marked for removal"
 msgstr "Нема пакета означених за уклањање"
 
-#: ../cli.py:614
+#: ../cli.py:648
 msgid "No Packages Provided"
 msgstr "Ниједан пакет није добављен"
 
-#: ../cli.py:654
+#: ../cli.py:689
+#, fuzzy
 msgid "Matching packages for package list to user args"
 msgstr "Повезивање пакета за списак пакета по аргументима корисника"
 
-#: ../cli.py:701
+#: ../cli.py:731
 #, python-format
 msgid "Warning: No matches found for: %s"
 msgstr "Упозорење: није нађено подударање за %s"
 
-#: ../cli.py:704
+#: ../cli.py:734
 msgid "No Matches found"
 msgstr "Нису пронађена подударања"
 
-#: ../cli.py:745
+#: ../cli.py:773
+#, python-format
+msgid ""
+"Warning: 3.0.x versions of yum would erronously match against filenames.\n"
+" You can use \"%s*/%s%s\" and/or \"%s*bin/%s%s\" to get that behaviour"
+msgstr ""
+"Упозорење: 3.0.x yum верзије би грешком вршиле подударање са називима "
+"датотека.\n"
+" Можете употребити „%s*/%s%s“ и/или „%s*bin/%s%s“ да бисте добили такво "
+"понашање"
+
+#: ../cli.py:789
 #, python-format
 msgid "No Package Found for %s"
 msgstr "Нису пронађени пакети за %s"
 
-#: ../cli.py:757
+#: ../cli.py:801
 msgid "Cleaning up Everything"
 msgstr "Чистим све"
 
-#: ../cli.py:771
+#: ../cli.py:815
 msgid "Cleaning up Headers"
 msgstr "Чистим заглавља"
 
-#: ../cli.py:774
+#: ../cli.py:818
 msgid "Cleaning up Packages"
 msgstr "Чистим пакете"
 
-#: ../cli.py:777
+#: ../cli.py:821
 msgid "Cleaning up xml metadata"
 msgstr "Чистим xml метаподатке"
 
-#: ../cli.py:780
+#: ../cli.py:824
 msgid "Cleaning up database cache"
-msgstr "Чистим кеш база података"
+msgstr "Чистим кеш базе података"
 
-#: ../cli.py:783
+#: ../cli.py:827
 msgid "Cleaning up expire-cache metadata"
 msgstr "Чистим expire-cache метаподатке"
 
-#: ../cli.py:786
+#: ../cli.py:830
 msgid "Cleaning up plugins"
 msgstr "Чистим додатке"
 
-#: ../cli.py:807
+#: ../cli.py:851
 msgid "Installed Groups:"
 msgstr "Инсталиране групе:"
 
-#: ../cli.py:814
+#: ../cli.py:858
 msgid "Available Groups:"
 msgstr "Доступне групе:"
 
-#: ../cli.py:820
+#: ../cli.py:864
 msgid "Done"
 msgstr "Урађено"
 
-#: ../cli.py:829 ../cli.py:841 ../cli.py:847
+#: ../cli.py:875 ../cli.py:893 ../cli.py:899 ../yum/__init__.py:2274
 #, python-format
 msgid "Warning: Group %s does not exist."
 msgstr "Упозорење: група %s не постоји."
 
-#: ../cli.py:853
+#: ../cli.py:903
 msgid "No packages in any requested group available to install or update"
 msgstr ""
 "Нема доступних пакета за инсталацију или ажурирање у свим захтеваним групама"
 
-#: ../cli.py:855
+#: ../cli.py:905
 #, python-format
 msgid "%d Package(s) to Install"
 msgstr "%d пакет(и) за инсталацију"
 
-#: ../cli.py:865
+#: ../cli.py:915 ../yum/__init__.py:2286
 #, python-format
 msgid "No group named %s exists"
 msgstr "Не постоји група под именом %s"
 
-#: ../cli.py:871
+#: ../cli.py:921
 msgid "No packages to remove from groups"
 msgstr "Нема пакета за уклањање из група"
 
-#: ../cli.py:873
+#: ../cli.py:923
 #, python-format
 msgid "%d Package(s) to remove"
 msgstr "%d  пакет(и) за уклањање"
 
-#: ../cli.py:915
+#: ../cli.py:965
 #, python-format
 msgid "Package %s is already installed, skipping"
 msgstr "Пакет %s је већ инсталиран, прескачем га"
 
-#: ../cli.py:926
+#: ../cli.py:976
 #, python-format
 msgid "Discarding non-comparable pkg %s.%s"
 msgstr "Уклањам неупоредив пакет %s.%s"
 
 #. we've not got any installed that match n or n+a
-#: ../cli.py:952
+#: ../cli.py:1002
 #, python-format
 msgid "No other %s installed, adding to list for potential install"
 msgstr ""
 "Не постоји инсталиран други %s, додајем га у списак за потенцијалну "
 "инсталацију"
 
-#: ../cli.py:971
+#: ../cli.py:1021
 #, python-format
 msgid "Command line error: %s"
 msgstr "Грешка командне линије: %s"
 
-#: ../cli.py:1101
+#: ../cli.py:1034
+#, python-format
+msgid ""
+"\n"
+"\n"
+"%s: %s option requires an argument"
+msgstr ""
+"\n"
+"\n"
+"%s: %s опција захтева аргумент"
+
+#: ../cli.py:1170
+msgid "show this help message and exit"
+msgstr "прикажи ову помоћну поруку и изађи"
+
+#: ../cli.py:1174
 msgid "be tolerant of errors"
 msgstr "буди толерантан на грешке"
 
-#: ../cli.py:1103
+#: ../cli.py:1176
 msgid "run entirely from cache, don't update cache"
 msgstr "извршавај се у потпуности из кеша, не ажурирај кеш"
 
-#: ../cli.py:1105
+#: ../cli.py:1178
 msgid "config file location"
 msgstr "место датотеке подешавања"
 
-#: ../cli.py:1107
+#: ../cli.py:1180
 msgid "maximum command wait time"
 msgstr "најдуже време чекања на команду"
 
-#: ../cli.py:1109
+#: ../cli.py:1182
 msgid "debugging output level"
 msgstr "ниво излазног приказа за проналажење грешака"
 
-#: ../cli.py:1113
+#: ../cli.py:1186
 msgid "show duplicates, in repos, in list/search commands"
 msgstr ""
 "приказуј дупликате, у ризницама, у командама за излиставање/претраживање"
 
-#: ../cli.py:1115
+#: ../cli.py:1188
 msgid "error output level"
 msgstr "ниво излазног приказа грешака"
 
-#: ../cli.py:1118
+#: ../cli.py:1191
 msgid "quiet operation"
 msgstr "тиха радња"
 
-#: ../cli.py:1122
+#: ../cli.py:1193
+msgid "verbose operation"
+msgstr "опширна радња"
+
+#: ../cli.py:1195
 msgid "answer yes for all questions"
 msgstr "одговори са да на сва питања"
 
-#: ../cli.py:1124
+#: ../cli.py:1197
 msgid "show Yum version and exit"
-msgstr "прикажи верзију Yum-а и изађи"
+msgstr "прикажи Yum верзију и изађи"
 
-#: ../cli.py:1125
+#: ../cli.py:1198
 msgid "set install root"
 msgstr "постави корени директоријум инсталације"
 
-#: ../cli.py:1129
+#: ../cli.py:1202
 msgid "enable one or more repositories (wildcards allowed)"
 msgstr "укључи једну или више ризница (скраћенице су дозвољене)"
 
-#: ../cli.py:1133
+#: ../cli.py:1206
 msgid "disable one or more repositories (wildcards allowed)"
 msgstr "искључи једну или више ризница (скраћенице су дозвољене)"
 
-#: ../cli.py:1136
+#: ../cli.py:1209
 msgid "exclude package(s) by name or glob"
-msgstr "изузмите пакет(е) по имену или glob-у"
+msgstr "изузми пакет(е) по имену или глобу"
 
-#: ../cli.py:1138
+#: ../cli.py:1211
 msgid "disable exclude from main, for a repo or for everything"
 msgstr "искључи изузимање из главног скупа, за ризницу или за све"
 
-#: ../cli.py:1141
+#: ../cli.py:1214
 msgid "enable obsoletes processing during updates"
 msgstr "укључи обраду застарелих пакета у току ажурирања"
 
-#: ../cli.py:1143
+#: ../cli.py:1216
 msgid "disable Yum plugins"
 msgstr "искључи додатке за Yum"
 
-#: ../cli.py:1145
+#: ../cli.py:1218
 msgid "disable gpg signature checking"
 msgstr "искључи проверу gpg потписа"
 
-#: ../cli.py:1147
+#: ../cli.py:1220
 msgid "disable plugins by name"
 msgstr "искључи додатке по имену"
 
-#: ../cli.py:1150
+#: ../cli.py:1223
+msgid "enable plugins by name"
+msgstr "укључи додатке по имену"
+
+#: ../cli.py:1226
 msgid "skip packages with depsolving problems"
 msgstr "прескочи пакете који имају проблема са решавањем зависности"
 
-#: ../output.py:229
+#: ../output.py:236
 msgid "Jan"
 msgstr "јан"
 
-#: ../output.py:229
+#: ../output.py:236
 msgid "Feb"
 msgstr "феб"
 
-#: ../output.py:229
+#: ../output.py:236
 msgid "Mar"
 msgstr "мар"
 
-#: ../output.py:229
+#: ../output.py:236
 msgid "Apr"
 msgstr "апр"
 
-#: ../output.py:229
+#: ../output.py:236
 msgid "May"
 msgstr "мај"
 
-#: ../output.py:229
+#: ../output.py:236
 msgid "Jun"
 msgstr "јун"
 
-#: ../output.py:230
+#: ../output.py:237
 msgid "Jul"
 msgstr "јул"
 
-#: ../output.py:230
+#: ../output.py:237
 msgid "Aug"
 msgstr "авг"
 
-#: ../output.py:230
+#: ../output.py:237
 msgid "Sep"
 msgstr "сеп"
 
-#: ../output.py:230
+#: ../output.py:237
 msgid "Oct"
 msgstr "окт"
 
-#: ../output.py:230
+#: ../output.py:237
 msgid "Nov"
 msgstr "нов"
 
-#: ../output.py:230
+#: ../output.py:237
 msgid "Dec"
 msgstr "дец"
 
-#: ../output.py:240
+#: ../output.py:247
 msgid "Trying other mirror."
 msgstr "Покушавам други одраз."
 
-#: ../output.py:293
+#: ../output.py:425
 #, python-format
-msgid "Name       : %s"
-msgstr "Име        : %s"
+msgid "Name       : %s%s%s"
+msgstr "Име        : %s%s%s"
 
-#: ../output.py:294
+#: ../output.py:426
 #, python-format
 msgid "Arch       : %s"
 msgstr "Архитектура: %s"
 
-#: ../output.py:296
+#: ../output.py:428
 #, python-format
 msgid "Epoch      : %s"
 msgstr "Период     : %s"
 
-#: ../output.py:297
+#: ../output.py:429
 #, python-format
 msgid "Version    : %s"
 msgstr "Верзија    : %s"
 
-#: ../output.py:298
+#: ../output.py:430
 #, python-format
 msgid "Release    : %s"
 msgstr "Издање     : %s"
 
-#: ../output.py:299
+#: ../output.py:431
 #, python-format
 msgid "Size       : %s"
 msgstr "Величина   : %s"
 
-#: ../output.py:300
+#: ../output.py:432
 #, python-format
 msgid "Repo       : %s"
 msgstr "Ризница    : %s"
 
-#: ../output.py:302
+#: ../output.py:434
 #, python-format
 msgid "Committer  : %s"
 msgstr "Објављивач : %s"
 
-#: ../output.py:303
+#: ../output.py:435
+#, fuzzy, python-format
+msgid "Committime : %s"
+msgstr "Објављивач : %s"
+
+#: ../output.py:436
+#, fuzzy, python-format
+msgid "Buildtime  : %s"
+msgstr "Објављивач : %s"
+
+#: ../output.py:438
+#, fuzzy, python-format
+msgid "Installtime: %s"
+msgstr "Инсталирани"
+
+#: ../output.py:439
 msgid "Summary    : "
 msgstr "Сажетак    :"
 
-#: ../output.py:305
+#: ../output.py:441
 #, python-format
 msgid "URL        : %s"
 msgstr "УРЛ        : %s"
 
-#: ../output.py:306
+#: ../output.py:442
 #, python-format
 msgid "License    : %s"
 msgstr "Лиценца    : %s"
 
-#: ../output.py:307
+#: ../output.py:443
 msgid "Description: "
 msgstr "Опис       : "
 
-#: ../output.py:351
-msgid "Is this ok [y/N]: "
-msgstr "Да ли је ово у реду [d/N]: "
-
-#: ../output.py:357 ../output.py:360
+#: ../output.py:500
 msgid "y"
 msgstr "d"
 
-#: ../output.py:357
-msgid "n"
-msgstr "n"
-
-#: ../output.py:357 ../output.py:360
+#: ../output.py:500
 msgid "yes"
 msgstr "da"
 
-#: ../output.py:357
+#: ../output.py:501
+msgid "n"
+msgstr "n"
+
+#: ../output.py:501
 msgid "no"
 msgstr "ne"
 
-#: ../output.py:367
+#: ../output.py:505
+msgid "Is this ok [y/N]: "
+msgstr "Да ли је ово у реду [d/N]: "
+
+#: ../output.py:587
 #, python-format
 msgid ""
 "\n"
@@ -556,96 +620,123 @@ msgstr ""
 "\n"
 "Група: %s"
 
-#: ../output.py:369
+#: ../output.py:594
 #, python-format
 msgid " Description: %s"
 msgstr " Опис: %s"
 
-#: ../output.py:371
+#: ../output.py:596
 msgid " Mandatory Packages:"
 msgstr " Обавезни пакети:"
 
-#: ../output.py:376
+#: ../output.py:597
 msgid " Default Packages:"
 msgstr " Подразумевани пакети:"
 
-#: ../output.py:381
+#: ../output.py:598
 msgid " Optional Packages:"
 msgstr " Изборни пакети:"
 
-#: ../output.py:386
+#: ../output.py:599
 msgid " Conditional Packages:"
 msgstr " Условљени пакети:"
 
-#: ../output.py:394
+#: ../output.py:619
 #, python-format
 msgid "package: %s"
 msgstr "пакет: %s"
 
-#: ../output.py:396
+#: ../output.py:621
 msgid "  No dependencies for this package"
 msgstr "  Не постоје зависности овог пакета"
 
-#: ../output.py:401
+#: ../output.py:626
 #, python-format
 msgid "  dependency: %s"
 msgstr "  зависност: %s"
 
-#: ../output.py:403
+#: ../output.py:628
 msgid "   Unsatisfied dependency"
 msgstr "   Незадовољена зависност"
 
-#: ../output.py:461
+#: ../output.py:700
 msgid "Matched from:"
 msgstr "Повезан из:"
 
-#: ../output.py:487
+#: ../output.py:708
+msgid "Description : "
+msgstr "Опис        : "
+
+#: ../output.py:711
+#, python-format
+msgid "URL         : %s"
+msgstr "УРЛ         : %s"
+
+#: ../output.py:714
+#, python-format
+msgid "License     : %s"
+msgstr "Лиценца     : %s"
+
+#: ../output.py:717
+#, python-format
+msgid "Filename    : %s"
+msgstr "Име датотеке: %s"
+
+#: ../output.py:721
+msgid "Other       : "
+msgstr "Остало      : "
+
+#: ../output.py:753
 msgid "There was an error calculating total download size"
 msgstr "Догодила се грешка при рачунању укупне величине за преузимање"
 
-#: ../output.py:492
+#: ../output.py:758
 #, python-format
 msgid "Total size: %s"
 msgstr "Укупна величина: %s"
 
-#: ../output.py:495
+#: ../output.py:761
 #, python-format
 msgid "Total download size: %s"
 msgstr "Укупна величина за преузимање: %s"
 
-#: ../output.py:507
+#: ../output.py:779
+msgid "Installing for dependencies"
+msgstr "Инсталирам због зависности"
+
+#: ../output.py:780
+msgid "Updating for dependencies"
+msgstr "Ажурирам због зависности"
+
+#: ../output.py:781
+msgid "Removing for dependencies"
+msgstr "Уклањам због зависности"
+
+#: ../output.py:782 ../output.py:893
+msgid "Skipped (dependency problems)"
+msgstr "Прескочено (проблеми са зависностима)"
+
+#: ../output.py:818
 msgid "Package"
 msgstr "Пакет"
 
-#: ../output.py:507
+#: ../output.py:818
 msgid "Arch"
 msgstr "Архитектура"
 
-#: ../output.py:507
+#: ../output.py:819
 msgid "Version"
 msgstr "Верзија"
 
-#: ../output.py:507
+#: ../output.py:819
 msgid "Repository"
 msgstr "Ризница"
 
-#: ../output.py:507
+#: ../output.py:820
 msgid "Size"
 msgstr "Величина"
 
-#: ../output.py:514
-msgid "Installing for dependencies"
-msgstr "Инсталирам због зависности"
-
-#: ../output.py:515
-msgid "Updating for dependencies"
-msgstr "Ажурирам због зависности"
-
-#: ../output.py:516
-msgid "Removing for dependencies"
-msgstr "Уклањам због зависности"
-
-#: ../output.py:528
+#: ../output.py:831
 #, python-format
 msgid ""
 "     replacing  %s.%s %s\n"
@@ -654,44 +745,44 @@ msgstr ""
 "     уклањам  %s.%s %s\n"
 "\n"
 
-#: ../output.py:536
+#: ../output.py:839
 #, python-format
 msgid ""
 "\n"
 "Transaction Summary\n"
-"=============================================================================\n"
+"%s\n"
 "Install  %5.5s Package(s)         \n"
 "Update   %5.5s Package(s)         \n"
 "Remove   %5.5s Package(s)         \n"
 msgstr ""
 "\n"
 "Сажетак трансакције\n"
-"=============================================================================\n"
-"инсталирање  %5.5s пакет(а)       \n"
-"ажурирање    %5.5s пакет(а)       \n"
-"уклањање     %5.5s пакет(а)       \n"
+"%s\n"
+"Инсталација  %5.5s пакет(а)       \n"
+"Ажурирање    %5.5s пакет(а)       \n"
+"Уклањање     %5.5s пакет(а)       \n"
 
-#: ../output.py:554
+#: ../output.py:887
 msgid "Removed"
 msgstr "Уклоњено"
 
-#: ../output.py:555
+#: ../output.py:888
 msgid "Dependency Removed"
 msgstr "Зависност уклоњена"
 
-#: ../output.py:557
+#: ../output.py:890
 msgid "Dependency Installed"
 msgstr "Зависност инсталирана"
 
-#: ../output.py:559
+#: ../output.py:892
 msgid "Dependency Updated"
 msgstr "Зависност ажурирана"
 
-#: ../output.py:560
+#: ../output.py:894
 msgid "Replaced"
 msgstr "Замењено"
 
-#: ../output.py:618
+#: ../output.py:967
 #, python-format
 msgid ""
 "\n"
@@ -702,73 +793,77 @@ msgstr ""
 " Тренутно преузимање је обустављено, %sinterrupt (ctrl-c) још једном%s у "
 "току %s%s%s секунди да бисте изашли.\n"
 
-#: ../output.py:628
+#: ../output.py:977
 msgid "user interrupt"
 msgstr "прекид од стране корисника"
 
-#: ../output.py:639
+#: ../output.py:993
+msgid "Total"
+msgstr "Укупно"
+
+#: ../output.py:1007
 msgid "installed"
 msgstr "инсталиран"
 
-#: ../output.py:640
+#: ../output.py:1008
 msgid "updated"
 msgstr "ажуриран"
 
-#: ../output.py:641
+#: ../output.py:1009
 msgid "obsoleted"
 msgstr "превазиђен"
 
-#: ../output.py:642
+#: ../output.py:1010
 msgid "erased"
 msgstr "обрисан"
 
-#: ../output.py:646
+#: ../output.py:1014
 #, python-format
 msgid "---> Package %s.%s %s:%s-%s set to be %s"
 msgstr "---> Пакет %s.%s %s:%s-%s постављен да буде %s"
 
-#: ../output.py:653
+#: ../output.py:1021
 msgid "--> Running transaction check"
 msgstr "--> Извршава се провера трансакције"
 
-#: ../output.py:658
+#: ../output.py:1026
 msgid "--> Restarting Dependency Resolution with new changes."
 msgstr "--> Поновно покретање разрешавања зависности са новим променама."
 
-#: ../output.py:663
+#: ../output.py:1031
 msgid "--> Finished Dependency Resolution"
 msgstr "--> Завршено је разрешавање зависности"
 
-#: ../output.py:668
+#: ../output.py:1036
 #, python-format
 msgid "--> Processing Dependency: %s for package: %s"
 msgstr "--> Обрађујем зависност: %s за пакет: %s"
 
-#: ../output.py:673
+#: ../output.py:1041
 #, python-format
 msgid "--> Unresolved Dependency: %s"
 msgstr "--> Неразрешена зависност: %s"
 
-#: ../output.py:679
+#: ../output.py:1047
 #, python-format
 msgid "--> Processing Conflict: %s conflicts %s"
 msgstr "--> Сукоб при обради: %s се сукоби са %s"
 
-#: ../output.py:682
+#: ../output.py:1050
 msgid "--> Populating transaction set with selected packages. Please wait."
 msgstr ""
 "--> Попуњавам скуп трансакције са изабраним пакетима. Молим вас, сачекајте."
 
-#: ../output.py:686
+#: ../output.py:1054
 #, python-format
 msgid "---> Downloading header for %s to pack into transaction set."
 msgstr "---> Преузимам заглавље за %s ради паковања у скуп трансакције."
 
-#: ../yumcommands.py:36
+#: ../yumcommands.py:40
 msgid "You need to be root to perform this command."
 msgstr "Морате бити root корисник да бисте извршили ову команду."
 
-#: ../yumcommands.py:43
+#: ../yumcommands.py:47
 msgid ""
 "\n"
 "You have enabled checking of packages via GPG keys. This is a good thing. \n"
@@ -799,251 +894,312 @@ msgstr ""
 "\n"
 "За више информација контактирајте добављача ваше дистрибуције или пакета.\n"
 
-#: ../yumcommands.py:63
+#: ../yumcommands.py:67
 #, python-format
 msgid "Error: Need to pass a list of pkgs to %s"
 msgstr "Грешка: потребно је да додате списак пакета %s-у"
 
-#: ../yumcommands.py:69
+#: ../yumcommands.py:73
 msgid "Error: Need an item to match"
 msgstr "Грешка: потребно је придружити ставку"
 
-#: ../yumcommands.py:75
+#: ../yumcommands.py:79
 msgid "Error: Need a group or list of groups"
 msgstr "Грешка: потребна је група или списак група"
 
-#: ../yumcommands.py:84
+#: ../yumcommands.py:88
 #, python-format
 msgid "Error: clean requires an option: %s"
 msgstr "Грешка: clean захтева опцију: %s"
 
-#: ../yumcommands.py:89
+#: ../yumcommands.py:93
 #, python-format
 msgid "Error: invalid clean argument: %r"
 msgstr "Грешка: погрешан clean аргумент:%r"
 
-#: ../yumcommands.py:102
+#: ../yumcommands.py:106
 msgid "No argument to shell"
 msgstr "Не постоји аргумент за командно окружење"
 
-#: ../yumcommands.py:105
+#: ../yumcommands.py:109
 #, python-format
 msgid "Filename passed to shell: %s"
 msgstr "Име датотеке је прослеђено командном окружењу: %s"
 
-#: ../yumcommands.py:109
+#: ../yumcommands.py:113
 #, python-format
 msgid "File %s given as argument to shell does not exist."
 msgstr ""
-"Не постоји датотека %s, која је прослеђена као аргумент комадном окружењу."
+"Не постоји датотека %s, која је прослеђена као аргумент командном окружењу."
 
-#: ../yumcommands.py:115
+#: ../yumcommands.py:119
 msgid "Error: more than one file given as argument to shell."
 msgstr ""
 "Грешка: више од једне датотеке је прослеђено као аргумент командном окружењу."
 
-#: ../yumcommands.py:156
+#: ../yumcommands.py:160
 msgid "PACKAGE..."
 msgstr "ПАКЕТ..."
 
-#: ../yumcommands.py:159
+#: ../yumcommands.py:163
 msgid "Install a package or packages on your system"
 msgstr "Инсталирајте пакет или пакете на ваш систем"
 
-#: ../yumcommands.py:168
+#: ../yumcommands.py:172
 msgid "Setting up Install Process"
 msgstr "Постављам процес инсталације"
 
-#: ../yumcommands.py:179
+#: ../yumcommands.py:183
 msgid "[PACKAGE...]"
 msgstr "[ПАКЕТ...]"
 
-#: ../yumcommands.py:182
+#: ../yumcommands.py:186
 msgid "Update a package or packages on your system"
 msgstr "Ажурирај пакет или пакете на вашем систему"
 
-#: ../yumcommands.py:190
+#: ../yumcommands.py:194
 msgid "Setting up Update Process"
 msgstr "Постављам процес ажурирања"
 
-#: ../yumcommands.py:204
+#: ../yumcommands.py:236
 msgid "Display details about a package or group of packages"
 msgstr "Прикажи детаље о сваком пакету или групи пакета"
 
-#: ../yumcommands.py:212
+#. Output the packages:
+#: ../yumcommands.py:261
 msgid "Installed Packages"
 msgstr "Инсталирани пакети"
 
-#: ../yumcommands.py:213
+#: ../yumcommands.py:263
 msgid "Available Packages"
 msgstr "Доступни пакети"
 
-#: ../yumcommands.py:214
+#: ../yumcommands.py:265
 msgid "Extra Packages"
 msgstr "Додатни пакети"
 
-#: ../yumcommands.py:215
+#: ../yumcommands.py:267
 msgid "Updated Packages"
 msgstr "Ажурирани пакети"
 
-#: ../yumcommands.py:221 ../yumcommands.py:225
+#: ../yumcommands.py:274 ../yumcommands.py:281
 msgid "Obsoleting Packages"
 msgstr "Превазиђени пакети"
 
-#: ../yumcommands.py:226
+#: ../yumcommands.py:283
 msgid "Recently Added Packages"
 msgstr "Недавно додати пакети"
 
-#: ../yumcommands.py:232
+#: ../yumcommands.py:290
 msgid "No matching Packages to list"
 msgstr "Не постоје одговарајући пакети за излиставање"
 
-#: ../yumcommands.py:246
+#: ../yumcommands.py:304
 msgid "List a package or groups of packages"
 msgstr "Излистај пакете или групе пакета"
 
-#: ../yumcommands.py:258
+#: ../yumcommands.py:316
 msgid "Remove a package or packages from your system"
 msgstr "Уклоните пакет или пакете са вашег система"
 
-#: ../yumcommands.py:266
+#: ../yumcommands.py:324
 msgid "Setting up Remove Process"
 msgstr "Постављам процес уклањања"
 
-#: ../yumcommands.py:278
+#: ../yumcommands.py:339
 msgid "Setting up Group Process"
 msgstr "Постављам процес за групе"
 
-#: ../yumcommands.py:284
+#: ../yumcommands.py:345
 msgid "No Groups on which to run command"
 msgstr "Не постоји група над којом се може извршити команда"
 
-#: ../yumcommands.py:297
+#: ../yumcommands.py:358
 msgid "List available package groups"
 msgstr "Излистај доступне групе пакета"
 
-#: ../yumcommands.py:314
+#: ../yumcommands.py:375
 msgid "Install the packages in a group on your system"
 msgstr "Инсталирајте пакете у групи на вашем систему"
 
-#: ../yumcommands.py:336
+#: ../yumcommands.py:397
 msgid "Remove the packages in a group from your system"
 msgstr "Уклоните пакете у групи са вашег система"
 
-#: ../yumcommands.py:360
+#: ../yumcommands.py:424
 msgid "Display details about a package group"
 msgstr "Прикажи детаље о групи пакета"
 
-#: ../yumcommands.py:384
+#: ../yumcommands.py:448
 msgid "Generate the metadata cache"
 msgstr "Направи кеш са метаподацима"
 
-#: ../yumcommands.py:390
+#: ../yumcommands.py:454
 msgid "Making cache files for all metadata files."
 msgstr "Правим кеш датотеке за све датотеке са метаподацима."
 
-#: ../yumcommands.py:391
+#: ../yumcommands.py:455
 msgid "This may take a while depending on the speed of this computer"
 msgstr "Ово може да потраје у зависности од брзине вашег рачунара"
 
-#: ../yumcommands.py:412
+#: ../yumcommands.py:476
 msgid "Metadata Cache Created"
 msgstr "Направљен је кеш са метаподацима"
 
-#: ../yumcommands.py:426
+#: ../yumcommands.py:490
 msgid "Remove cached data"
 msgstr "Уклони кеширане податке"
 
-#: ../yumcommands.py:447
+#: ../yumcommands.py:511
 msgid "Find what package provides the given value"
 msgstr "Пронађи који пакет пружа дату вредност"
 
-#: ../yumcommands.py:467
+#: ../yumcommands.py:531
 msgid "Check for available package updates"
 msgstr "Проверите да ли су доступна ажурирања пакета"
 
-#: ../yumcommands.py:490
+#: ../yumcommands.py:556
 msgid "Search package details for the given string"
 msgstr "Претражите детаље о пакету за задату ниску"
 
-#: ../yumcommands.py:496
+#: ../yumcommands.py:562
 msgid "Searching Packages: "
 msgstr "Претражујем пакете: "
 
-#: ../yumcommands.py:513
+#: ../yumcommands.py:579
 msgid "Update packages taking obsoletes into account"
 msgstr "Ажурирајте пакете узимајући превазиђене у обзир"
 
-#: ../yumcommands.py:522
+#: ../yumcommands.py:588
 msgid "Setting up Upgrade Process"
 msgstr "Постављам процес надградње"
 
-#: ../yumcommands.py:536
+#: ../yumcommands.py:602
 msgid "Install a local RPM"
 msgstr "Инсталирај локални RPM"
 
-#: ../yumcommands.py:545
+#: ../yumcommands.py:611
 msgid "Setting up Local Package Process"
 msgstr "Постављам процес локалних пакета"
 
-#: ../yumcommands.py:564
+#: ../yumcommands.py:630
 msgid "Determine which package provides the given dependency"
 msgstr "Одреди који пакети пружају дату зависност"
 
-#: ../yumcommands.py:567
+#: ../yumcommands.py:633
 msgid "Searching Packages for Dependency:"
 msgstr "Претражујем пакете у потрази за зависностима:"
 
-#: ../yumcommands.py:581
+#: ../yumcommands.py:647
 msgid "Run an interactive yum shell"
 msgstr "Извршавај интерактивно командно окружење yum-а"
 
-#: ../yumcommands.py:587
+#: ../yumcommands.py:653
 msgid "Setting up Yum Shell"
 msgstr "Постављам Yum командно окружење"
 
-#: ../yumcommands.py:605
+#: ../yumcommands.py:671
 msgid "List a package's dependencies"
 msgstr "Излистај зависности пакета"
 
-#: ../yumcommands.py:611
+#: ../yumcommands.py:677
 msgid "Finding dependencies: "
 msgstr "Тражим зависности: "
 
-#: ../yumcommands.py:627
+#: ../yumcommands.py:693
 msgid "Display the configured software repositories"
 msgstr "Прикажи подешене софтверске ризнице"
 
-#: ../yumcommands.py:645
+#: ../yumcommands.py:742
+msgid "enabled"
+msgstr "укључена"
+
+#: ../yumcommands.py:751
+msgid "disabled"
+msgstr "искључена"
+
+#: ../yumcommands.py:760
 msgid "repo id"
 msgstr "репо id"
 
-#: ../yumcommands.py:645
+#: ../yumcommands.py:761
 msgid "repo name"
 msgstr "репо име"
 
-#: ../yumcommands.py:645
+#: ../yumcommands.py:761
 msgid "status"
 msgstr "статус"
 
-#: ../yumcommands.py:651
-msgid "enabled"
-msgstr "укључена"
+#: ../yumcommands.py:765
+msgid "Repo-id     : "
+msgstr "ИБ ризнице         : "
 
-#: ../yumcommands.py:654
-msgid "disabled"
-msgstr "искључена"
+#: ../yumcommands.py:766
+msgid "Repo-name   : "
+msgstr "Име ризнице        : "
 
-#: ../yumcommands.py:671
+#: ../yumcommands.py:767
+msgid "Repo-status : "
+msgstr "Статус ризнице     : "
+
+#: ../yumcommands.py:769
+#, fuzzy
+msgid "Repo-revision: "
+msgstr "Величина ризнице   : "
+
+#: ../yumcommands.py:773
+#, fuzzy
+msgid "Repo-tags   : "
+msgstr "Пакети ризнице     : "
+
+#: ../yumcommands.py:779
+#, fuzzy
+msgid "Repo-distro-tags: "
+msgstr "Статус ризнице     : "
+
+#: ../yumcommands.py:784
+msgid "Repo-updated: "
+msgstr "Ризница ажурирана  : "
+
+#: ../yumcommands.py:786
+msgid "Repo-pkgs   : "
+msgstr "Пакети ризнице     : "
+
+#: ../yumcommands.py:787
+msgid "Repo-size   : "
+msgstr "Величина ризнице   : "
+
+#: ../yumcommands.py:794
+msgid "Repo-baseurl: "
+msgstr "Основни УРЛ ризнице: "
+
+#: ../yumcommands.py:798
+#, fuzzy
+msgid "Repo-metalink: "
+msgstr "Име ризнице        : "
+
+#: ../yumcommands.py:801
+msgid "Repo-mirrors: "
+msgstr "Одрази ризнице     : "
+
+#: ../yumcommands.py:805
+msgid "Repo-exclude: "
+msgstr "Ризница искључена  : "
+
+#: ../yumcommands.py:809
+msgid "Repo-include: "
+msgstr "Ризница укључена   : "
+
+#: ../yumcommands.py:835
 msgid "Display a helpful usage message"
 msgstr "Прикажи корисну поруку о употреби"
 
-#: ../yumcommands.py:705
+#: ../yumcommands.py:869
 #, python-format
 msgid "No help available for %s"
 msgstr "Није доступна помоћ за %s"
 
-#: ../yumcommands.py:710
+#: ../yumcommands.py:874
 msgid ""
 "\n"
 "\n"
@@ -1051,9 +1207,9 @@ msgid ""
 msgstr ""
 "\n"
 "\n"
-"алијаси: "
+"псеудоними: "
 
-#: ../yumcommands.py:712
+#: ../yumcommands.py:876
 msgid ""
 "\n"
 "\n"
@@ -1061,13 +1217,13 @@ msgid ""
 msgstr ""
 "\n"
 "\n"
-"алијас: "
+"псеудоним: "
 
-#: ../yumcommands.py:741
+#: ../yumcommands.py:905
 msgid "Setting up Reinstall Process"
 msgstr "Постављам процес поновне инсталације"
 
-#: ../yumcommands.py:755
+#: ../yumcommands.py:919
 msgid "reinstall a package"
 msgstr "поновно инсталирам пакет"
 
@@ -1091,29 +1247,29 @@ msgstr ""
 "\n"
 "Излазим када се сломи цев"
 
-#: ../yummain.py:105
+#: ../yummain.py:98
 msgid ""
 "Another app is currently holding the yum lock; waiting for it to exit..."
 msgstr ""
-"Неки други програм тренутно држи yum закључавање, чекам да се тај програм "
-"искључи..."
+"Неки други програм тренутно држи yum закључаним; чекам да тај програм "
+"изађе..."
 
-#: ../yummain.py:132 ../yummain.py:171
+#: ../yummain.py:125 ../yummain.py:164
 #, python-format
 msgid "Error: %s"
 msgstr "Грешка: %s"
 
-#: ../yummain.py:142 ../yummain.py:178
+#: ../yummain.py:135 ../yummain.py:171
 #, python-format
 msgid "Unknown Error(s): Exit Code: %d:"
 msgstr "Непозната грешка(е): излазни код: %d:"
 
 #. Depsolve stage
-#: ../yummain.py:149
+#: ../yummain.py:142
 msgid "Resolving Dependencies"
 msgstr "Разрешавам зависности"
 
-#: ../yummain.py:184
+#: ../yummain.py:177
 msgid ""
 "\n"
 "Dependencies Resolved"
@@ -1121,11 +1277,11 @@ msgstr ""
 "\n"
 "Зависности су разрешене"
 
-#: ../yummain.py:198
+#: ../yummain.py:191
 msgid "Complete!"
 msgstr "Завршено!"
 
-#: ../yummain.py:245
+#: ../yummain.py:238
 msgid ""
 "\n"
 "\n"
@@ -1135,318 +1291,315 @@ msgstr ""
 "\n"
 "Излазим када корисник откаже."
 
-#: ../yum/depsolve.py:82
+#: ../yum/depsolve.py:84
 msgid "doTsSetup() will go away in a future version of Yum.\n"
 msgstr "doTsSetup() неће бити присутна у будућим верзијама Yum-а.\n"
 
-#: ../yum/depsolve.py:95
+#: ../yum/depsolve.py:97
 msgid "Setting up TransactionSets before config class is up"
 msgstr "Постављам TransactionSets пре него што се подигне класа подешавања"
 
-#: ../yum/depsolve.py:136
+#: ../yum/depsolve.py:148
 #, python-format
 msgid "Invalid tsflag in config file: %s"
 msgstr "Погрешан tsflag у датотеци подешавања: %s"
 
-#: ../yum/depsolve.py:147
+#: ../yum/depsolve.py:159
 #, fuzzy, python-format
 msgid "Searching pkgSack for dep: %s"
 msgstr "тражим пакет %s"
 
-#: ../yum/depsolve.py:170
+#: ../yum/depsolve.py:182
 #, fuzzy, python-format
 msgid "Potential match for %s from %s"
 msgstr "Постоји више од једног идентичног слагања у групи за %s"
 
-#: ../yum/depsolve.py:178
+#: ../yum/depsolve.py:190
 #, fuzzy, python-format
 msgid "Matched %s to require for %s"
 msgstr "%s захтева: %s"
 
-#: ../yum/depsolve.py:219
+#: ../yum/depsolve.py:231
 #, python-format
 msgid "Member: %s"
 msgstr "Члан: %s"
 
-#: ../yum/depsolve.py:233 ../yum/depsolve.py:696
+#: ../yum/depsolve.py:245 ../yum/depsolve.py:732
 #, python-format
 msgid "%s converted to install"
 msgstr "%s пребачен за инсталацију"
 
-#: ../yum/depsolve.py:240
+#: ../yum/depsolve.py:252
 #, python-format
 msgid "Adding Package %s in mode %s"
 msgstr "Додајем пакет %s у начину рада %s"
 
-#: ../yum/depsolve.py:250
+#: ../yum/depsolve.py:262
 #, python-format
 msgid "Removing Package %s"
 msgstr "Уклањам пакет %s"
 
-#: ../yum/depsolve.py:261
+#: ../yum/depsolve.py:273
 #, python-format
 msgid "%s requires: %s"
 msgstr "%s захтева: %s"
 
-#: ../yum/depsolve.py:312
+#: ../yum/depsolve.py:331
 msgid "Needed Require has already been looked up, cheating"
-msgstr ""
+msgstr "Потребан захтев је већ потражен, обмањујем"
 
-#: ../yum/depsolve.py:322
+#: ../yum/depsolve.py:341
 #, python-format
 msgid "Needed Require is not a package name. Looking up: %s"
-msgstr ""
+msgstr "Потребан захтев није име пакета. Тражим: %s"
 
-#: ../yum/depsolve.py:329
-#, fuzzy, python-format
+#: ../yum/depsolve.py:348
+#, python-format
 msgid "Potential Provider: %s"
-msgstr "Укупна величина: %s"
+msgstr "Могући снабдевач: %s"
 
-#: ../yum/depsolve.py:352
+#: ../yum/depsolve.py:371
 #, python-format
 msgid "Mode is %s for provider of %s: %s"
-msgstr ""
+msgstr "Режим је %s за снабдевача %s: %s"
 
-#: ../yum/depsolve.py:356
+#: ../yum/depsolve.py:375
 #, python-format
 msgid "Mode for pkg providing %s: %s"
-msgstr ""
+msgstr "Режим за пакет који снабдева %s: %s"
 
-#: ../yum/depsolve.py:360
+#: ../yum/depsolve.py:379
 #, python-format
 msgid "TSINFO: %s package requiring %s marked as erase"
 msgstr "TSINFO: %s пакет захтева да %s буде означен за брисање"
 
-#: ../yum/depsolve.py:372
+#: ../yum/depsolve.py:391
 #, python-format
 msgid "TSINFO: Obsoleting %s with %s to resolve dep."
-msgstr "TSINFO: мењам %s са %s да бих разрешио зависност."
+msgstr "TSINFO: мењам %s са %s ради разрешавања зависности."
 
-#: ../yum/depsolve.py:375
+#: ../yum/depsolve.py:394
 #, python-format
 msgid "TSINFO: Updating %s to resolve dep."
-msgstr "TSINFO: ажурирам %s да бих разрешио зависност."
+msgstr "TSINFO: ажурирам %s ради разрешавања зависности."
 
-#: ../yum/depsolve.py:378
+#: ../yum/depsolve.py:402
 #, python-format
 msgid "Cannot find an update path for dep for: %s"
 msgstr "Не могу да пронађем путању ажурирања за зависност за: %s"
 
-#: ../yum/depsolve.py:388
+#: ../yum/depsolve.py:412
 #, python-format
 msgid "Unresolvable requirement %s for %s"
-msgstr ""
+msgstr "Неразрешив захтев пакета %s за %s"
+
+#: ../yum/depsolve.py:435
+#, python-format
+msgid "Quick matched %s to require for %s"
+msgstr "Брзо повезивање пакета %s као захтева за %s"
 
 #. is it already installed?
-#: ../yum/depsolve.py:434
+#: ../yum/depsolve.py:477
 #, python-format
 msgid "%s is in providing packages but it is already installed, removing."
-msgstr "%s је у пруженим пакета али је већ инсталиран, уклањам га."
+msgstr "%s је у пруженим пакетима али је већ инсталиран, уклањам га."
 
-#: ../yum/depsolve.py:449
+#: ../yum/depsolve.py:492
 #, python-format
 msgid "Potential resolving package %s has newer instance in ts."
 msgstr "Потенцијално разрешавање пакета %s има новији примерак у ts-у."
 
-#: ../yum/depsolve.py:460
+#: ../yum/depsolve.py:503
 #, python-format
 msgid "Potential resolving package %s has newer instance installed."
-msgstr "Потенцијално разрешавање пакета %s има инсталиран нови примерак."
+msgstr "Потенцијално разрешавање пакета %s има инсталиран новији примерак."
 
-#: ../yum/depsolve.py:468 ../yum/depsolve.py:527
+#: ../yum/depsolve.py:511 ../yum/depsolve.py:560
 #, python-format
 msgid "Missing Dependency: %s is needed by package %s"
 msgstr "Недостаје зависност: %s је потребан од стране пакета %s"
 
-#: ../yum/depsolve.py:481
+#: ../yum/depsolve.py:524
 #, python-format
 msgid "%s already in ts, skipping this one"
 msgstr "%s је већ у ts-у, прескачем га"
 
-#: ../yum/depsolve.py:510
-#, python-format
-msgid ""
-"Failure finding best provider of %s for %s, exceeded maximum loop length"
-msgstr ""
-
-#: ../yum/depsolve.py:537
+#: ../yum/depsolve.py:570
 #, python-format
 msgid "TSINFO: Marking %s as update for %s"
 msgstr "TSINFO: означавам %s као ажурирање за %s"
 
-#: ../yum/depsolve.py:544
+#: ../yum/depsolve.py:578
 #, python-format
 msgid "TSINFO: Marking %s as install for %s"
 msgstr "TSINFO: означавам %s као инсталацију за %s"
 
-#: ../yum/depsolve.py:635 ../yum/depsolve.py:714
+#: ../yum/depsolve.py:670 ../yum/depsolve.py:750
 msgid "Success - empty transaction"
 msgstr "Успех - празна трансакција"
 
-#: ../yum/depsolve.py:673 ../yum/depsolve.py:686
+#: ../yum/depsolve.py:709 ../yum/depsolve.py:722
 msgid "Restarting Loop"
 msgstr "Поново покрећем петљу"
 
-#: ../yum/depsolve.py:702
+#: ../yum/depsolve.py:738
 msgid "Dependency Process ending"
 msgstr "Завршетак процеса зависности"
 
-#: ../yum/depsolve.py:708
+#: ../yum/depsolve.py:744
 #, python-format
 msgid "%s from %s has depsolving problems"
 msgstr "%s из %s има проблема са разрешавањем зависности"
 
-#: ../yum/depsolve.py:715
+#: ../yum/depsolve.py:751
 msgid "Success - deps resolved"
 msgstr "Успех - зависности су разрешене"
 
-#: ../yum/depsolve.py:729
+#: ../yum/depsolve.py:765
 #, python-format
 msgid "Checking deps for %s"
 msgstr "Проверавам зависности за %s"
 
-#: ../yum/depsolve.py:782
+#: ../yum/depsolve.py:848
 #, python-format
 msgid "looking for %s as a requirement of %s"
 msgstr "тражим %s као захтев за %s"
 
-#: ../yum/depsolve.py:933
-#, python-format
-msgid "Comparing best: %s to po: %s"
-msgstr ""
-
-#: ../yum/depsolve.py:937
+#: ../yum/depsolve.py:988
 #, python-format
-msgid "Same: best %s == po: %s"
-msgstr ""
+msgid "Running compare_providers() for %s"
+msgstr "Покрећем compare_providers() за %s"
 
-#: ../yum/depsolve.py:952 ../yum/depsolve.py:963
+#: ../yum/depsolve.py:1016 ../yum/depsolve.py:1022
 #, fuzzy, python-format
-msgid "best %s obsoletes po: %s"
-msgstr "%s превазилази %s"
-
-#: ../yum/depsolve.py:955
-#, fuzzy, python-format
-msgid "po %s obsoletes best: %s"
-msgstr "%s превазилази %s"
-
-#: ../yum/depsolve.py:972 ../yum/depsolve.py:979 ../yum/depsolve.py:1036
-#, python-format
 msgid "better arch in po %s"
 msgstr "боља архитектура у po %s"
 
-#: ../yum/depsolve.py:988 ../yum/depsolve.py:1010
+#: ../yum/depsolve.py:1061
 #, python-format
-msgid "po %s shares a sourcerpm with %s"
-msgstr ""
+msgid "%s obsoletes %s"
+msgstr "%s превазилази %s"
 
-#: ../yum/depsolve.py:992 ../yum/depsolve.py:1015
+#: ../yum/depsolve.py:1077
 #, python-format
-msgid "best %s shares a sourcerpm with %s"
+msgid ""
+"archdist compared %s to %s on %s\n"
+"  Winner: %s"
 msgstr ""
+"archdist упоредио %s са %s на %s\n"
+"  Победник: %s"
 
-#: ../yum/depsolve.py:999 ../yum/depsolve.py:1020
+#: ../yum/depsolve.py:1084
 #, python-format
-msgid "po %s shares more of the name prefix with %s"
-msgstr ""
+msgid "common sourcerpm %s and %s"
+msgstr "заједнички изворни rpm %s и %s"
 
-#: ../yum/depsolve.py:1003 ../yum/depsolve.py:1029
+#: ../yum/depsolve.py:1090
 #, python-format
-msgid "po %s has a shorter name than best %s"
-msgstr ""
+msgid "common prefix of %s between %s and %s"
+msgstr "заједнички префикс %s између %s и %s"
 
-#: ../yum/depsolve.py:1025
+#: ../yum/depsolve.py:1098
 #, python-format
-msgid "bestpkg %s shares more of the name prefix with %s"
-msgstr ""
+msgid "Best Order: %s"
+msgstr "Најбољи редослед: %s"
 
-#: ../yum/__init__.py:119
+#: ../yum/__init__.py:135
 msgid "doConfigSetup() will go away in a future version of Yum.\n"
 msgstr "doConfigSetup() неће бити присутна у будућим верзијама Yum-а.\n"
 
-#: ../yum/__init__.py:296
+#: ../yum/__init__.py:315
 #, python-format
 msgid "Repository %r is missing name in configuration, using id"
 msgstr "Ризници %r недостаје име у подешавањима, користим id"
 
-#: ../yum/__init__.py:332
+#: ../yum/__init__.py:353
 msgid "plugins already initialised"
 msgstr "већ иницијализовани додаци"
 
-#: ../yum/__init__.py:339
+#: ../yum/__init__.py:360
 msgid "doRpmDBSetup() will go away in a future version of Yum.\n"
 msgstr "doRpmDBSetup() неће бити присутна у будућим верзијама Yum-а.\n"
 
-#: ../yum/__init__.py:349
+#: ../yum/__init__.py:370
 msgid "Reading Local RPMDB"
 msgstr "Читам локални RPMDB"
 
-#: ../yum/__init__.py:367
+#: ../yum/__init__.py:388
 msgid "doRepoSetup() will go away in a future version of Yum.\n"
 msgstr "doRepoSetup() неће бити присутна у будућим верзијама Yum-а.\n"
 
-#: ../yum/__init__.py:387
+#: ../yum/__init__.py:408
 msgid "doSackSetup() will go away in a future version of Yum.\n"
 msgstr "doSackSetup() неће бити присутна у будућим верзијама Yum-а.\n"
 
-#: ../yum/__init__.py:404
+#: ../yum/__init__.py:425
 msgid "Setting up Package Sacks"
 msgstr "Постављам групе пакета"
 
-#: ../yum/__init__.py:447
+#: ../yum/__init__.py:468
 #, python-format
 msgid "repo object for repo %s lacks a _resetSack method\n"
 msgstr "репо објекту за репо %s недостаје a _resetSack метода\n"
 
-#: ../yum/__init__.py:448
+#: ../yum/__init__.py:469
 msgid "therefore this repo cannot be reset.\n"
 msgstr "због тога се овај репо не може вратити на почетну поставку.\n"
 
-#: ../yum/__init__.py:453
+#: ../yum/__init__.py:474
 msgid "doUpdateSetup() will go away in a future version of Yum.\n"
 msgstr "doUpdateSetup() неће бити присутна у будућим верзијама Yum-а.\n"
 
-#: ../yum/__init__.py:465
+#: ../yum/__init__.py:486
 msgid "Building updates object"
-msgstr "Изграђујем објекат ажурирња"
+msgstr "Изграђујем објекат ажурирања"
 
-#: ../yum/__init__.py:496
+#: ../yum/__init__.py:517
 msgid "doGroupSetup() will go away in a future version of Yum.\n"
 msgstr "doGroupSetup() неће бити присутна у будућим верзијама Yum-а.\n"
 
-#: ../yum/__init__.py:520
+#: ../yum/__init__.py:541
 msgid "Getting group metadata"
 msgstr "Добављам метаподатке групе"
 
-#: ../yum/__init__.py:546
+#: ../yum/__init__.py:567
 #, python-format
 msgid "Adding group file from repository: %s"
 msgstr "Додајем датотеку групе из ризнице: %s"
 
-#: ../yum/__init__.py:555
+#: ../yum/__init__.py:576
 #, python-format
 msgid "Failed to add groups file for repository: %s - %s"
-msgstr "Нисам успео да додам датотеку групе за ризницу: %s - %s"
+msgstr "Није успело додавање датотеке групе за ризницу: %s - %s"
 
-#: ../yum/__init__.py:561
+#: ../yum/__init__.py:582
 msgid "No Groups Available in any repository"
 msgstr "Не постоји група која је доступна у било којој ризници"
 
-#: ../yum/__init__.py:611
+#: ../yum/__init__.py:632
 msgid "Importing additional filelist information"
 msgstr "Увозим додатне информације о списковима датотека"
 
-#: ../yum/__init__.py:657
+#: ../yum/__init__.py:641
+#, fuzzy
+msgid ""
+"There are unfinished transactions remaining. You might consider running yum-"
+"complete-transaction first to finish them."
+msgstr ""
+"Остале су недовршене трансакције. Можда би требало да извршите yum-complete-"
+"transaction да бисте их завршили."
+
+#: ../yum/__init__.py:698
 #, python-format
 msgid "Skip-broken round %i"
 msgstr "Skip-broken етапа %i"
 
-#: ../yum/__init__.py:680
+#: ../yum/__init__.py:724
 #, python-format
 msgid "Skip-broken took %i rounds "
 msgstr "Skip-broken је завршен у %i етапа "
 
-#: ../yum/__init__.py:681
+#: ../yum/__init__.py:725
 msgid ""
 "\n"
 "Packages skipped because of dependency problems:"
@@ -1454,95 +1607,108 @@ msgstr ""
 "\n"
 "Пакети су прескочени због проблема са зависностима:"
 
-#: ../yum/__init__.py:685
+#: ../yum/__init__.py:729
 #, python-format
 msgid "    %s from %s"
 msgstr "    %s из %s"
 
-#: ../yum/__init__.py:774
+#: ../yum/__init__.py:816
+msgid ""
+"Warning: scriptlet or other non-fatal errors occurred during transaction."
+msgstr ""
+"Упозорење: дошло је до грешке у скриптици или неке друге некритичне грешке "
+"током трансакције."
+
+#: ../yum/__init__.py:832
 #, python-format
 msgid "Failed to remove transaction file %s"
-msgstr "Нисам успео да уклоним датотеку трансакције %s"
+msgstr "Није успело уклањање датотеке трансакције %s"
 
-#: ../yum/__init__.py:814
+#: ../yum/__init__.py:873
 #, python-format
 msgid "excluding for cost: %s from %s"
 msgstr "изузимам из трошка: %s из %s"
 
-#: ../yum/__init__.py:845
+#: ../yum/__init__.py:904
 msgid "Excluding Packages in global exclude list"
 msgstr "Изузимам пакете у глобалном списку за изузимање"
 
-#: ../yum/__init__.py:847
+#: ../yum/__init__.py:906
 #, python-format
 msgid "Excluding Packages from %s"
 msgstr "Изузимам пакете из %s"
 
-#: ../yum/__init__.py:875
+#: ../yum/__init__.py:933
 #, python-format
 msgid "Reducing %s to included packages only"
 msgstr "Сажимам %s само у садржане пакете"
 
-#: ../yum/__init__.py:880
+#: ../yum/__init__.py:939
 #, python-format
 msgid "Keeping included package %s"
 msgstr "Задржавам садржани пакет %s"
 
-#: ../yum/__init__.py:886
+#: ../yum/__init__.py:945
 #, python-format
 msgid "Removing unmatched package %s"
 msgstr "Уклањам неповезани пакет %s"
 
-#: ../yum/__init__.py:889
+#: ../yum/__init__.py:948
 msgid "Finished"
 msgstr "Завршио"
 
 #. Whoa. What the heck happened?
-#: ../yum/__init__.py:919
+#: ../yum/__init__.py:978
 #, python-format
 msgid "Unable to check if PID %s is active"
-msgstr "Нисам у могућнисти да проверим да ли је PID %s активан"
+msgstr "Нисам у могућности да проверим да ли је PID %s активан"
 
 #. Another copy seems to be running.
-#: ../yum/__init__.py:923
+#: ../yum/__init__.py:982
 #, python-format
 msgid "Existing lock %s: another copy is running as pid %s."
 msgstr "Постоји закључавање %s: друга копија се извршава као pid %s."
 
-#: ../yum/__init__.py:970 ../yum/__init__.py:977
+#: ../yum/__init__.py:1053
 msgid "Package does not match intended download"
 msgstr "Пакет није одговарајући за намеравано преузимање"
 
-#: ../yum/__init__.py:991
+#: ../yum/__init__.py:1068
 msgid "Could not perform checksum"
 msgstr "Не могу да извршим контролу суме"
 
-#: ../yum/__init__.py:994
+#: ../yum/__init__.py:1071
 msgid "Package does not match checksum"
 msgstr "Пакет нема одговарајући контролну суму"
 
-#: ../yum/__init__.py:1036
+#: ../yum/__init__.py:1114
 #, python-format
 msgid "package fails checksum but caching is enabled for %s"
 msgstr ""
 "пакет нема одговарајућу вредност контролне суме или је за %s укључено "
 "кеширање"
 
-#: ../yum/__init__.py:1042
+#: ../yum/__init__.py:1117 ../yum/__init__.py:1145
 #, python-format
 msgid "using local copy of %s"
 msgstr "користим локални умножак %s-а"
 
-#: ../yum/__init__.py:1061
+#: ../yum/__init__.py:1159
 #, python-format
-msgid "Insufficient space in download directory %s to download"
-msgstr "Недовољна количина простора у директоријуму %s намењеног за преузимање"
+msgid ""
+"Insufficient space in download directory %s\n"
+"    * free   %s\n"
+"    * needed %s"
+msgstr ""
+"Недовољна количина простора у директоријуму %s за преузимање\n"
+"    * слободно је %s\n"
+"    * потребно је %s"
 
-#: ../yum/__init__.py:1094
+#: ../yum/__init__.py:1206
 msgid "Header is not complete."
 msgstr "Заглавље није потпуно."
 
-#: ../yum/__init__.py:1134
+#: ../yum/__init__.py:1246
 #, python-format
 msgid ""
 "Header not in local cache and caching-only mode enabled. Cannot download %s"
@@ -1550,204 +1716,240 @@ msgstr ""
 "Заглавље није у локалном кешу и само начин рада са кеширањем је укључен. Не "
 "могу да преузмем %s"
 
-#: ../yum/__init__.py:1189
+#: ../yum/__init__.py:1301
 #, python-format
 msgid "Public key for %s is not installed"
 msgstr "Јавни кључ за %s није инсталиран"
 
-#: ../yum/__init__.py:1193
+#: ../yum/__init__.py:1305
 #, python-format
 msgid "Problem opening package %s"
 msgstr "Проблем са отварањем пакета %s"
 
-#: ../yum/__init__.py:1201
+#: ../yum/__init__.py:1313
 #, python-format
 msgid "Public key for %s is not trusted"
 msgstr "Јавни кључ за %s није поверљив"
 
-#: ../yum/__init__.py:1205
+#: ../yum/__init__.py:1317
 #, python-format
 msgid "Package %s is not signed"
 msgstr "Пакет %s није потписан"
 
-#: ../yum/__init__.py:1243
+#: ../yum/__init__.py:1355
 #, python-format
 msgid "Cannot remove %s"
 msgstr "Не могу да уклоним %s"
 
-#: ../yum/__init__.py:1247
+#: ../yum/__init__.py:1359
 #, python-format
 msgid "%s removed"
 msgstr "%s је уклоњен"
 
-#: ../yum/__init__.py:1283
+#: ../yum/__init__.py:1396
 #, python-format
 msgid "Cannot remove %s file %s"
 msgstr "Не могу да уклоним %s датотеку %s"
 
-#: ../yum/__init__.py:1287
+#: ../yum/__init__.py:1400
 #, python-format
 msgid "%s file %s removed"
 msgstr "%s датотека %s је уклоњена"
 
-#: ../yum/__init__.py:1289
+#: ../yum/__init__.py:1402
 #, python-format
 msgid "%d %s files removed"
 msgstr "%d %s датотеке су уклоњене"
 
-#: ../yum/__init__.py:1329
+#: ../yum/__init__.py:1464
 #, python-format
 msgid "More than one identical match in sack for %s"
 msgstr "Постоји више од једног идентичног слагања у групи за %s"
 
-#: ../yum/__init__.py:1335
+#: ../yum/__init__.py:1470
 #, python-format
 msgid "Nothing matches %s.%s %s:%s-%s from update"
 msgstr "Ништа се не слаже са %s.%s %s:%s-%s из ажурирања"
 
-#: ../yum/__init__.py:1543
+#: ../yum/__init__.py:1678
 msgid ""
 "searchPackages() will go away in a future version of "
 "Yum.                      Use searchGenerator() instead. \n"
 msgstr ""
-"searchPackages() неће бити присутна у будућим верзијама Yum-"
-"а.                      Уместо ње користите searchGenerator(). \n"
+"searchPackages() неће бити присутна у будућим Yum "
+"верзијама.                      Уместо ње користите searchGenerator(). \n"
 
-#: ../yum/__init__.py:1580
+#: ../yum/__init__.py:1716
 #, python-format
 msgid "Searching %d packages"
 msgstr "Претражујем %d пакете"
 
-#: ../yum/__init__.py:1584
+#: ../yum/__init__.py:1720
 #, python-format
 msgid "searching package %s"
 msgstr "тражим пакет %s"
 
-#: ../yum/__init__.py:1596
+#: ../yum/__init__.py:1732
 msgid "searching in file entries"
 msgstr "тражим у уносима датотека"
 
-#: ../yum/__init__.py:1603
+#: ../yum/__init__.py:1739
 msgid "searching in provides entries"
 msgstr "тражим у уносима достављача"
 
-#: ../yum/__init__.py:1633
+#: ../yum/__init__.py:1772
 #, python-format
 msgid "Provides-match: %s"
 msgstr "Доставља-слагање: %s"
 
-#: ../yum/__init__.py:1702 ../yum/__init__.py:1720 ../yum/__init__.py:1748
-#: ../yum/__init__.py:1753 ../yum/__init__.py:1808 ../yum/__init__.py:1812
+#: ../yum/__init__.py:1821
+msgid "No group data available for configured repositories"
+msgstr "Нема доступних података о групама за подешене ризнице"
+
+#: ../yum/__init__.py:1847 ../yum/__init__.py:1866 ../yum/__init__.py:1897
+#: ../yum/__init__.py:1903 ../yum/__init__.py:1976 ../yum/__init__.py:1980
 #, python-format
 msgid "No Group named %s exists"
 msgstr "Не постоји група под именом %s"
 
-#: ../yum/__init__.py:1731 ../yum/__init__.py:1824
+#: ../yum/__init__.py:1878 ../yum/__init__.py:1993
 #, python-format
 msgid "package %s was not marked in group %s"
 msgstr "пакет %s није означен у групи %s"
 
-#: ../yum/__init__.py:1770
+#: ../yum/__init__.py:1925
 #, python-format
 msgid "Adding package %s from group %s"
 msgstr "Додајем пакет %s из групе %s"
 
-#: ../yum/__init__.py:1774
+#: ../yum/__init__.py:1929
 #, python-format
 msgid "No package named %s available to be installed"
 msgstr "Ниједан пакет под именом %s није доступан за инсталацију"
 
-#: ../yum/__init__.py:1849
+#: ../yum/__init__.py:2018
 #, python-format
 msgid "Package tuple %s could not be found in packagesack"
 msgstr "Група пакета %s није нађена у packagesack-у"
 
-#: ../yum/__init__.py:1917 ../yum/__init__.py:1960
+#: ../yum/__init__.py:2033
+msgid ""
+"getInstalledPackageObject() will go away, use self.rpmdb.searchPkgTuple().\n"
+msgstr ""
+"getInstalledPackageObject() ће нестати, користите self.rpmdb.searchPkgTuple"
+"().\n"
+
+#: ../yum/__init__.py:2085 ../yum/__init__.py:2128
 msgid "Invalid versioned dependency string, try quoting it."
 msgstr ""
 "Неисправна ниска зависности са верзијом, покушајте да је обележите "
 "наводницима."
 
-#: ../yum/__init__.py:1919 ../yum/__init__.py:1962
+#: ../yum/__init__.py:2087 ../yum/__init__.py:2130
 msgid "Invalid version flag"
 msgstr "Погрешна ознака верзије"
 
-#: ../yum/__init__.py:1934 ../yum/__init__.py:1938
+#: ../yum/__init__.py:2102 ../yum/__init__.py:2106
 #, python-format
 msgid "No Package found for %s"
 msgstr "Нема пронађених пакета за %s"
 
-#: ../yum/__init__.py:2066
+#: ../yum/__init__.py:2305
 msgid "Package Object was not a package object instance"
 msgstr "Објекат пакета није био примерак објекта пакета"
 
-#: ../yum/__init__.py:2070
+#: ../yum/__init__.py:2309
 msgid "Nothing specified to install"
 msgstr "Није одређено ништа за инсталацију"
 
 #. only one in there
-#: ../yum/__init__.py:2085
+#: ../yum/__init__.py:2327
 #, python-format
 msgid "Checking for virtual provide or file-provide for %s"
 msgstr "Проверавам виртуелну доставу или доставу датотеке за %s"
 
-#: ../yum/__init__.py:2091 ../yum/__init__.py:2380
+#: ../yum/__init__.py:2333 ../yum/__init__.py:2715
 #, python-format
 msgid "No Match for argument: %s"
 msgstr "Не постоји слагање за аргумент: %s"
 
-#. FIXME - this is where we could check to see if it already installed
-#. for returning better errors
-#: ../yum/__init__.py:2146
+#: ../yum/__init__.py:2399
+#, python-format
+msgid "Package %s installed and not available"
+msgstr "Пакет %s је инсталиран и није доступан"
+
+#: ../yum/__init__.py:2402
 msgid "No package(s) available to install"
 msgstr "Нема пакета доступних за инсталацију"
 
-#: ../yum/__init__.py:2158
+#: ../yum/__init__.py:2414
 #, python-format
 msgid "Package: %s  - already in transaction set"
 msgstr "Пакет: %s  - већ је у скупу трансакције"
 
-#: ../yum/__init__.py:2171
+#: ../yum/__init__.py:2427
 #, python-format
 msgid "Package %s already installed and latest version"
 msgstr "Већ је инсталирана најновија верзија пакета %s"
 
-#: ../yum/__init__.py:2178
+#: ../yum/__init__.py:2434
 #, python-format
 msgid "Package matching %s already installed. Checking for update."
 msgstr ""
 "Пакет који се поклапа са %s је већ инсталиран. Проверавам за новију верзију."
 
+#: ../yum/__init__.py:2444
+#, python-format
+msgid "Package %s is obsoleted by %s, trying to install %s instead"
+msgstr "Пакет %s је замењен пакетом %s, покушавам да наместо инсталирам %s"
+
 #. update everything (the easy case)
-#: ../yum/__init__.py:2220
+#: ../yum/__init__.py:2514
 msgid "Updating Everything"
 msgstr "Ажурирам све"
 
-#: ../yum/__init__.py:2304
+#: ../yum/__init__.py:2526 ../yum/__init__.py:2631 ../yum/__init__.py:2642
+#: ../yum/__init__.py:2664
+#, python-format
+msgid "Not Updating Package that is already obsoleted: %s.%s %s:%s-%s"
+msgstr "Не ажурирам пакете који су већ превазиђени: %s.%s %s:%s-%s"
+
+#: ../yum/__init__.py:2622
 #, python-format
 msgid "Package is already obsoleted: %s.%s %s:%s-%s"
 msgstr "Пакет је већ превазиђен: %s.%s %s:%s-%s"
 
-#: ../yum/__init__.py:2377
+#: ../yum/__init__.py:2645 ../yum/__init__.py:2667
+#, python-format
+msgid "Not Updating Package that is already updated: %s.%s %s:%s-%s"
+msgstr "Не ажурирам пакете који су већ ажурирани: %s.%s %s:%s-%s"
+
+#: ../yum/__init__.py:2712
 #, python-format
 msgid "%s"
 msgstr "%s"
 
-#: ../yum/__init__.py:2392
+#: ../yum/__init__.py:2728
 msgid "No package matched to remove"
 msgstr "Ниједан пакет није одређен за уклањање"
 
-#: ../yum/__init__.py:2426
+#: ../yum/__init__.py:2762
 #, python-format
 msgid "Cannot open file: %s. Skipping."
 msgstr "Не могу да отворим датотеку: %s. Прескачем је."
 
-#: ../yum/__init__.py:2429
+#: ../yum/__init__.py:2765
 #, python-format
 msgid "Examining %s: %s"
 msgstr "Испитујем %s: %s"
 
-#: ../yum/__init__.py:2436
+#: ../yum/__init__.py:2773
+#, python-format
+msgid "Cannot add package %s to transaction. Not a compatible architecture: %s"
+msgstr ""
+"Не могу да додам пакет %s у трансакцију. Архитектура није усаглашена: %s"
+
+#: ../yum/__init__.py:2781
 #, python-format
 msgid ""
 "Package %s not installed, cannot update it. Run yum install to install it "
@@ -1756,136 +1958,157 @@ msgstr ""
 "Пакет %s није инсталиран, не могу да га ажурирам. Извршите yum инсталацију "
 "да бисте га инсталирали."
 
-#: ../yum/__init__.py:2468
+#: ../yum/__init__.py:2814
 #, python-format
 msgid "Excluding %s"
 msgstr "Изузимам %s"
 
-#: ../yum/__init__.py:2473
+#: ../yum/__init__.py:2819
 #, python-format
 msgid "Marking %s to be installed"
 msgstr "Означавам %s за инсталацију"
 
-#: ../yum/__init__.py:2479
+#: ../yum/__init__.py:2825
 #, python-format
 msgid "Marking %s as an update to %s"
 msgstr "Означавам %s као ажурирање за %s"
 
-#: ../yum/__init__.py:2486
+#: ../yum/__init__.py:2832
 #, python-format
 msgid "%s: does not update installed package."
 msgstr "%s: не ажурира инсталирани пакет."
 
-#: ../yum/__init__.py:2504
+#: ../yum/__init__.py:2850
 msgid "Problem in reinstall: no package matched to remove"
 msgstr ""
 "Проблем при поновној инсталацији: ниједан пакет није одређен за уклањање"
 
-#: ../yum/__init__.py:2515
+#: ../yum/__init__.py:2861
 #, python-format
 msgid "Package %s is allowed multiple installs, skipping"
 msgstr "Пакету %s су дозвољене многоструке инсталације, прескачем га"
 
-#: ../yum/__init__.py:2522
+#: ../yum/__init__.py:2868
 msgid "Problem in reinstall: no package matched to install"
 msgstr ""
 "Проблем при поновној инсталацији: ниједан пакет није одређен за инсталацију"
 
-#: ../yum/__init__.py:2570
+#: ../yum/__init__.py:2903
 #, python-format
 msgid "Retrieving GPG key from %s"
 msgstr "Добављам GPG кључ са %s"
 
-#: ../yum/__init__.py:2576
+#: ../yum/__init__.py:2923
 msgid "GPG key retrieval failed: "
 msgstr "Добављање GPG кључа није успело: "
 
-#: ../yum/__init__.py:2589
-msgid "GPG key parsing failed: "
-msgstr "Рашчлањивање GPG кључа није успело: "
+#: ../yum/__init__.py:2934
+#, python-format
+msgid "GPG key parsing failed: key does not have value %s"
+msgstr "Рашчлањивање GPG кључа није успело: кључ нема вредност %s"
 
-#: ../yum/__init__.py:2593
+#: ../yum/__init__.py:2966
 #, python-format
 msgid "GPG key at %s (0x%s) is already installed"
 msgstr "GPG кључ на %s (0x%s) је већ инсталиран"
 
 #. Try installing/updating GPG key
-#: ../yum/__init__.py:2598
+#: ../yum/__init__.py:2971 ../yum/__init__.py:3033
 #, python-format
 msgid "Importing GPG key 0x%s \"%s\" from %s"
 msgstr "Увозим GPG кључ 0x%s „%s“ из %s"
 
-#: ../yum/__init__.py:2610
+#: ../yum/__init__.py:2988
 msgid "Not installing key"
 msgstr "Не инсталирам кључ"
 
-#: ../yum/__init__.py:2616
+#: ../yum/__init__.py:2994
 #, python-format
 msgid "Key import failed (code %d)"
 msgstr "Није успео увоз кључа (код %d)"
 
-#: ../yum/__init__.py:2619
+#: ../yum/__init__.py:2995 ../yum/__init__.py:3054
 msgid "Key imported successfully"
 msgstr "Кључ је успешно увезен"
 
-#: ../yum/__init__.py:2624
+#: ../yum/__init__.py:3000 ../yum/__init__.py:3059
 #, python-format
 msgid ""
 "The GPG keys listed for the \"%s\" repository are already installed but they "
 "are not correct for this package.\n"
 "Check that the correct key URLs are configured for this repository."
 msgstr ""
-"GPG кључеви излистани за „%s“ ризницу су већ исталирани али нису "
+"GPG кључеви излистани за „%s“ ризницу су већ инсталирани али нису "
 "одговарајући за овај пакет.\n"
 "Проверите да ли су подешени одговарајући УРЛ-ови кључева за ову ризницу."
 
-#: ../yum/__init__.py:2633
+#: ../yum/__init__.py:3009
 msgid "Import of key(s) didn't help, wrong key(s)?"
 msgstr "Увоз кључа(кључева) није помогао, погрешан кључ(кључеви)?"
 
-#: ../yum/__init__.py:2707
+#: ../yum/__init__.py:3028
+#, python-format
+msgid "GPG key at %s (0x%s) is already imported"
+msgstr "GPG кључ на %s (0x%s) је већ увезен"
+
+#: ../yum/__init__.py:3048
+#, python-format
+msgid "Not installing key for repo %s"
+msgstr "Не инсталирам кључ за ризницу %s"
+
+#: ../yum/__init__.py:3053
+msgid "Key import failed"
+msgstr "Није успео увоз кључа"
+
+#: ../yum/__init__.py:3144
 msgid "Unable to find a suitable mirror."
 msgstr "Не могу да пронађем одговарајући одраз."
 
-#: ../yum/__init__.py:2709
+#: ../yum/__init__.py:3146
 msgid "Errors were encountered while downloading packages."
 msgstr "Појавиле су се грешке за време преузимања пакета."
 
-#: ../yum/__init__.py:2774
+#: ../yum/__init__.py:3210
 msgid "Test Transaction Errors: "
 msgstr "Грешке при провери трансакције: "
 
 #. Mostly copied from YumOutput._outKeyValFill()
-#: ../yum/plugins.py:195
+#: ../yum/plugins.py:199
 msgid "Loaded plugins: "
 msgstr "Учитани додаци: "
 
-#: ../yum/plugins.py:206
+#: ../yum/plugins.py:213 ../yum/plugins.py:219
 #, python-format
 msgid "No plugin match for: %s"
 msgstr "Не постоји слагање за додатак: %s"
 
-#: ../yum/plugins.py:219
+#: ../yum/plugins.py:249
 #, python-format
 msgid "\"%s\" plugin is disabled"
 msgstr "„%s“ додатак је искључен"
 
-#: ../yum/plugins.py:231
+#. Give full backtrace:
+#: ../yum/plugins.py:261
+#, python-format
+msgid "Plugin \"%s\" can't be imported"
+msgstr "Додатак „%s“ не може да буде увезен"
+
+#: ../yum/plugins.py:268
 #, python-format
 msgid "Plugin \"%s\" doesn't specify required API version"
 msgstr "Додатак „%s“ не одређује верзију захтеваног API-а"
 
-#: ../yum/plugins.py:235
+#: ../yum/plugins.py:273
 #, python-format
 msgid "Plugin \"%s\" requires API %s. Supported API is %s."
 msgstr "Додатак „%s“ захтева API %s. Подржани API је %s."
 
-#: ../yum/plugins.py:264
+#: ../yum/plugins.py:306
 #, python-format
 msgid "Loading \"%s\" plugin"
 msgstr "Учитавам „%s“ додатак"
 
-#: ../yum/plugins.py:271
+#: ../yum/plugins.py:313
 #, python-format
 msgid ""
 "Two or more plugins with the name \"%s\" exist in the plugin search path"
@@ -1893,22 +2116,26 @@ msgstr ""
 "У путањи за претраживање додатака постоје два или више додатака под именом „%"
 "s“"
 
-#: ../yum/plugins.py:291
+#: ../yum/plugins.py:333
 #, python-format
 msgid "Configuration file %s not found"
 msgstr "Датотека подешавања %s није пронађена"
 
 #. for
 #. Configuration files for the plugin not found
-#: ../yum/plugins.py:294
+#: ../yum/plugins.py:336
 #, python-format
 msgid "Unable to find configuration file for plugin %s"
 msgstr "Не могу да пронађем датотеку подешавања за додатак %s"
 
-#: ../yum/plugins.py:448
+#: ../yum/plugins.py:490
 msgid "registration of commands not supported"
 msgstr "регистрација команди није подржана"
 
+#: ../yum/rpmtrans.py:78
+msgid "Repackaging"
+msgstr "Поновно паковање"
+
 #: ../rpmUtils/oldUtils.py:26
 #, python-format
 msgid "Header cannot be opened or does not match %s, %s."
@@ -1927,7 +2154,7 @@ msgstr ""
 
 #: ../rpmUtils/oldUtils.py:174
 msgid "Got an empty Header, something has gone wrong"
-msgstr "Добио сам празно заглавље, нешто је пошло наопако"
+msgstr "Примљено је празно заглавље, нешто је пошло наопако"
 
 #: ../rpmUtils/oldUtils.py:244 ../rpmUtils/oldUtils.py:251
 #: ../rpmUtils/oldUtils.py:254 ../rpmUtils/oldUtils.py:257
@@ -1939,64 +2166,3 @@ msgstr "Оштећено заглавље %s"
 #, python-format
 msgid "Error opening rpm %s - error %s"
 msgstr "Грешка при отварању rpm-а %s - грешка %s"
-
-#~ msgid ""
-#~ "\n"
-#~ "\n"
-#~ "%s: %s option requires an argument"
-#~ msgstr ""
-#~ "\n"
-#~ "\n"
-#~ "%s: %s опција захтева аргумент"
-
-#~ msgid "show this help message and exit"
-#~ msgstr "прикажи ову помоћну поруку и изађи"
-
-#~ msgid "verbose operation"
-#~ msgstr "опширна радња"
-
-#~ msgid "Repo-id     : "
-#~ msgstr "ИБ ризнице      : "
-
-#~ msgid "Repo-name   : "
-#~ msgstr "Име ризнице     : "
-
-#~ msgid "Repo-enabled: "
-#~ msgstr "Ризница укључена: "
-
-#~ msgid "Repo-size   : "
-#~ msgstr "Величина ризнице: "
-
-#~ msgid "Running compare_providers() for %s"
-#~ msgstr "Покрећем compare_providers() за %s"
-
-#~ msgid ""
-#~ "archdist compared %s to %s on %s\n"
-#~ "  Winner: %s"
-#~ msgstr ""
-#~ "archdist упоредио %s са %s на %s\n"
-#~ "  Победник: %s"
-
-#~ msgid "common sourcerpm %s and %s"
-#~ msgstr "заједнички изворни rpm %s и %s"
-
-#~ msgid "common prefix of %s between %s and %s"
-#~ msgstr "заједнички префикс %s између %s и %s"
-
-#~ msgid "Best Order: %s"
-#~ msgstr "Најбољи редослед: %s"
-
-#~ msgid ""
-#~ "Warning: scriptlet or other non-fatal errors occurred during transaction."
-#~ msgstr ""
-#~ "Упозорење: дошло је до грешке у скриптици или неке друге некритичне "
-#~ "грешке током транскације."
-
-#~ msgid "Package %s is obsoleted by %s, trying to install %s instead"
-#~ msgstr "Пакет %s је замењен пакетом %s, покушавам да наместо инсталирам %s"
-
-#~ msgid "Not Updating Package that is already updated: %s.%s %s:%s-%s"
-#~ msgstr "Не ажурирам пакете који су већ ажурирани: %s.%s %s:%s-%s"
-
-#~ msgid "Repackaging"
-#~ msgstr "Поновно паковање"
diff --git a/po/sr@latin.po b/po/sr@latin.po
old mode 100644
new mode 100755
index dba9dcc..58af237
--- a/po/sr@latin.po
+++ b/po/sr@latin.po
@@ -1,42 +1,43 @@
-# translation of sr.po to Serbian
 # Serbian(Latin) translations for yum
 # Copyright (C) 2008 Linux@Duke
 # This file is distributed under the same license as the yum package.
-#
 # Jovan Krunic <jovan.krunic@gmail.com>, 2008.
 # Igor Miletic <grejigl-gnomeprevod@yahoo.ca>, 2008.
 # Miloš Komarčević <kmilos@gmail.com>, 2008.
+#
 msgid ""
 msgstr ""
 "Project-Id-Version: yum\n"
 "Report-Msgid-Bugs-To: \n"
-"POT-Creation-Date: 2008-03-25 11:29+0100\n"
-"PO-Revision-Date: 2008-05-26 20:30-0000\n"
+"POT-Creation-Date: 2008-10-27 13:29+0000\n"
+"PO-Revision-Date: 2008-10-27 22:52+0000\n"
 "Last-Translator: Miloš Komarčević <kmilos@gmail.com>\n"
 "Language-Team: Serbian (sr) <fedora-trans-sr@redhat.com>\n"
 "MIME-Version: 1.0\n"
 "Content-Type: text/plain; charset=UTF-8\n"
 "Content-Transfer-Encoding: 8bit\n"
-"Plural-Forms: nplurals=3; plural=(n%10==1 && n%100!=11 ? 0 : n%10>=2 && n%"
-"10<=4 && (n%100<10 || n%100>=20) ? 1 : 2);\n"
+"Plural-Forms: nplurals=3; plural=n%10==1 && n%100!=11 ? 0 : n%10>=2 && n%"
+"10<=4 && (n%100<10 || n%100>=20) ? 1 : 2;\n"
 
-#: ../callback.py:48 ../output.py:512
+#: ../callback.py:48 ../output.py:777 ../yum/rpmtrans.py:71
 msgid "Updating"
 msgstr "Ažuriram"
 
-#: ../callback.py:49
+#: ../callback.py:49 ../yum/rpmtrans.py:72
 msgid "Erasing"
 msgstr "Brišem"
 
-#: ../callback.py:50 ../callback.py:51 ../callback.py:53 ../output.py:511
+#. Arch can't get "that big" ... so always use the max.
+#: ../callback.py:50 ../callback.py:51 ../callback.py:53 ../output.py:776
+#: ../yum/rpmtrans.py:73 ../yum/rpmtrans.py:74 ../yum/rpmtrans.py:76
 msgid "Installing"
 msgstr "Instaliram"
 
-#: ../callback.py:52 ../callback.py:58
+#: ../callback.py:52 ../callback.py:58 ../yum/rpmtrans.py:75
 msgid "Obsoleted"
 msgstr "Prevaziđeni"
 
-#: ../callback.py:54 ../output.py:558
+#: ../callback.py:54 ../output.py:891
 msgid "Updated"
 msgstr "Ažurirani"
 
@@ -44,7 +45,7 @@ msgstr "Ažurirani"
 msgid "Erased"
 msgstr "Obrisani"
 
-#: ../callback.py:56 ../callback.py:57 ../callback.py:59 ../output.py:556
+#: ../callback.py:56 ../callback.py:57 ../callback.py:59 ../output.py:889
 msgid "Installed"
 msgstr "Instalirani"
 
@@ -66,53 +67,68 @@ msgstr "Greška: pogrešno izlazno stanje: %s za %s"
 msgid "Erased: %s"
 msgstr "Obrisano: %s"
 
-#: ../callback.py:217 ../output.py:513
+#: ../callback.py:217 ../output.py:778
 msgid "Removing"
 msgstr "Uklanjam"
 
-#: ../callback.py:219
+#: ../callback.py:219 ../yum/rpmtrans.py:77
 msgid "Cleanup"
 msgstr "Čišćenje"
 
-#: ../cli.py:103
+#: ../cli.py:105
 #, python-format
 msgid "Command \"%s\" already defined"
 msgstr "Naredba „%s“ je već definisana"
 
-#: ../cli.py:115
+#: ../cli.py:117
 msgid "Setting up repositories"
 msgstr "Postavljam riznice"
 
-#: ../cli.py:126
+#: ../cli.py:128
 msgid "Reading repository metadata in from local files"
 msgstr "Čitam metapodatke riznica iz lokalnih datoteka"
 
-#: ../cli.py:183 ../utils.py:72
+#: ../cli.py:187 ../utils.py:71
 #, python-format
 msgid "Config Error: %s"
 msgstr "Greška pri podešavanju: %s"
 
-#: ../cli.py:186 ../cli.py:1068 ../utils.py:75
+#: ../cli.py:190 ../cli.py:1128 ../utils.py:74
 #, python-format
 msgid "Options Error: %s"
 msgstr "Greška u opcijama: %s"
 
-#: ../cli.py:229
+#: ../cli.py:218
+#, python-format
+msgid "  Installed: %s-%s at %s"
+msgstr "  Instalirano: %s-%s na %s"
+
+#: ../cli.py:220
+#, fuzzy, python-format
+msgid "  Built    : %s at %s"
+msgstr "URL        : %s"
+
+#: ../cli.py:222
+#, fuzzy, python-format
+msgid "  Committed: %s at %s"
+msgstr "Objavljivač : %s"
+
+#: ../cli.py:259
 msgid "You need to give some command"
 msgstr "Morate da unesete neku komandu"
 
-#: ../cli.py:271
+#: ../cli.py:301
 msgid "Disk Requirements:\n"
 msgstr "Zahtevi diska:\n"
 
-#: ../cli.py:273
+#: ../cli.py:303
 #, python-format
 msgid "  At least %dMB needed on the %s filesystem.\n"
 msgstr "  Potrebno je najmanje %dMB na %s sistemu datoteka.\n"
 
 #. TODO: simplify the dependency errors?
 #. Fixup the summary
-#: ../cli.py:278
+#: ../cli.py:308
 msgid ""
 "Error Summary\n"
 "-------------\n"
@@ -120,55 +136,55 @@ msgstr ""
 "Sažetak grešaka\n"
 "-------------\n"
 
-#: ../cli.py:317
+#: ../cli.py:351
 msgid "Trying to run the transaction but nothing to do. Exiting."
 msgstr "Pokušavam da izvršim transakciju ali nema šta da se radi. Izlazim."
 
-#: ../cli.py:347
+#: ../cli.py:381
 msgid "Exiting on user Command"
 msgstr "Izlazim na komandu korisnika"
 
-#: ../cli.py:351
+#: ../cli.py:385
 msgid "Downloading Packages:"
 msgstr "Preuzimam pakete:"
 
-#: ../cli.py:356
+#: ../cli.py:390
 msgid "Error Downloading Packages:\n"
 msgstr "Greška pri preuzimanju paketa:\n"
 
-#: ../cli.py:370 ../yum/__init__.py:2746
+#: ../cli.py:404 ../yum/__init__.py:3182
 msgid "Running rpm_check_debug"
 msgstr "Izvršavam rpm_check_debug"
 
-#: ../cli.py:373 ../yum/__init__.py:2749
+#: ../cli.py:407 ../yum/__init__.py:3185
 msgid "ERROR with rpm_check_debug vs depsolve:"
 msgstr "GREŠKA sa rpm_check_debug u odnosu na depsolve:"
 
-#: ../cli.py:377 ../yum/__init__.py:2751
+#: ../cli.py:411 ../yum/__init__.py:3187
 msgid "Please report this error in bugzilla"
 msgstr "Molim vas, prijavite ovu grešku u bugzilli"
 
-#: ../cli.py:383
+#: ../cli.py:417
 msgid "Running Transaction Test"
 msgstr "Izvršavam proveru transakcije"
 
-#: ../cli.py:399
+#: ../cli.py:433
 msgid "Finished Transaction Test"
-msgstr "Završio sam proveru transakcije"
+msgstr "Završena je provera transakcije"
 
-#: ../cli.py:401
+#: ../cli.py:435
 msgid "Transaction Check Error:\n"
 msgstr "Greška pri proveri transakcije:\n"
 
-#: ../cli.py:408
+#: ../cli.py:442
 msgid "Transaction Test Succeeded"
 msgstr "Provera transakcije je uspela"
 
-#: ../cli.py:429
+#: ../cli.py:463
 msgid "Running Transaction"
 msgstr "Izvršavam transakciju"
 
-#: ../cli.py:459
+#: ../cli.py:493
 msgid ""
 "Refusing to automatically import keys when running unattended.\n"
 "Use \"-y\" to override."
@@ -176,378 +192,426 @@ msgstr ""
 "Odbijam da automatski uvezem ključeve kada se izvršavanje ne nadgleda.\n"
 "Za prevazilaženje ovoga koristite „-y“."
 
-#: ../cli.py:491
-msgid "Parsing package install arguments"
-msgstr "Raščlanjujem argumente instalacije paketa"
+#: ../cli.py:512 ../cli.py:545
+msgid "  * Maybe you meant: "
+msgstr "  * Možda ste mislili: "
+
+#: ../cli.py:528 ../cli.py:536
+#, python-format
+msgid "Package(s) %s%s%s available, but not installed."
+msgstr "%s%s%s paket je dostupan, ali nije instaliran."
 
-#: ../cli.py:501
+#: ../cli.py:542 ../cli.py:577
 #, python-format
-msgid "No package %s available."
-msgstr "Ne postoji dostupan %s paket."
+msgid "No package %s%s%s available."
+msgstr "Ne postoji dostupan %s%s%s paket."
 
-#: ../cli.py:505 ../cli.py:623 ../yumcommands.py:748
+#: ../cli.py:567
+msgid "Parsing package install arguments"
+msgstr "Raščlanjujem argumente instalacije paketa"
+
+#: ../cli.py:582 ../cli.py:657 ../yumcommands.py:912
 msgid "Package(s) to install"
 msgstr "Paket(i) koji će se instalirati"
 
-#: ../cli.py:506 ../cli.py:624 ../yumcommands.py:146 ../yumcommands.py:749
+#: ../cli.py:583 ../cli.py:658 ../yumcommands.py:150 ../yumcommands.py:913
 msgid "Nothing to do"
 msgstr "Nema šta da se radi"
 
-#: ../cli.py:536 ../yum/__init__.py:2232 ../yum/__init__.py:2311
-#: ../yum/__init__.py:2340
-#, python-format
-msgid "Not Updating Package that is already obsoleted: %s.%s %s:%s-%s"
-msgstr "Ne ažuriram pakete koji su već prevaziđeni: %s.%s %s:%s-%s"
-
-#: ../cli.py:568
-#, python-format
-msgid "Could not find update match for %s"
-msgstr "Ne mogu da pronađem odgovarajuće ažuriranje za %s"
-
-#: ../cli.py:580
+#: ../cli.py:616
 #, python-format
 msgid "%d packages marked for Update"
 msgstr "%d paketi označeni za ažuriranje"
 
-#: ../cli.py:583
+#: ../cli.py:619
 msgid "No Packages marked for Update"
 msgstr "Nema paketa označenih za ažuriranje"
 
-#: ../cli.py:599
+#: ../cli.py:633
 #, python-format
 msgid "%d packages marked for removal"
 msgstr "%d paketi označeni za uklanjanje"
 
-#: ../cli.py:602
+#: ../cli.py:636
 msgid "No Packages marked for removal"
 msgstr "Nema paketa označenih za uklanjanje"
 
-#: ../cli.py:614
+#: ../cli.py:648
 msgid "No Packages Provided"
 msgstr "Nijedan paket nije dobavljen"
 
-#: ../cli.py:654
+#: ../cli.py:689
+#, fuzzy
 msgid "Matching packages for package list to user args"
 msgstr "Povezivanje paketa za spisak paketa po argumentima korisnika"
 
-#: ../cli.py:701
+#: ../cli.py:731
 #, python-format
 msgid "Warning: No matches found for: %s"
 msgstr "Upozorenje: nije nađeno podudaranje za %s"
 
-#: ../cli.py:704
+#: ../cli.py:734
 msgid "No Matches found"
 msgstr "Nisu pronađena podudaranja"
 
-#: ../cli.py:745
+#: ../cli.py:773
+#, python-format
+msgid ""
+"Warning: 3.0.x versions of yum would erronously match against filenames.\n"
+" You can use \"%s*/%s%s\" and/or \"%s*bin/%s%s\" to get that behaviour"
+msgstr ""
+"Upozorenje: 3.0.x yum verzije bi greškom vršile podudaranje sa nazivima "
+"datoteka.\n"
+" Možete upotrebiti „%s*/%s%s“ i/ili „%s*bin/%s%s“ da biste dobili takvo "
+"ponašanje"
+
+#: ../cli.py:789
 #, python-format
 msgid "No Package Found for %s"
 msgstr "Nisu pronađeni paketi za %s"
 
-#: ../cli.py:757
+#: ../cli.py:801
 msgid "Cleaning up Everything"
 msgstr "Čistim sve"
 
-#: ../cli.py:771
+#: ../cli.py:815
 msgid "Cleaning up Headers"
 msgstr "Čistim zaglavlja"
 
-#: ../cli.py:774
+#: ../cli.py:818
 msgid "Cleaning up Packages"
 msgstr "Čistim pakete"
 
-#: ../cli.py:777
+#: ../cli.py:821
 msgid "Cleaning up xml metadata"
 msgstr "Čistim xml metapodatke"
 
-#: ../cli.py:780
+#: ../cli.py:824
 msgid "Cleaning up database cache"
-msgstr "Čistim keš baza podataka"
+msgstr "Čistim keš baze podataka"
 
-#: ../cli.py:783
+#: ../cli.py:827
 msgid "Cleaning up expire-cache metadata"
 msgstr "Čistim expire-cache metapodatke"
 
-#: ../cli.py:786
+#: ../cli.py:830
 msgid "Cleaning up plugins"
 msgstr "Čistim dodatke"
 
-#: ../cli.py:807
+#: ../cli.py:851
 msgid "Installed Groups:"
 msgstr "Instalirane grupe:"
 
-#: ../cli.py:814
+#: ../cli.py:858
 msgid "Available Groups:"
 msgstr "Dostupne grupe:"
 
-#: ../cli.py:820
+#: ../cli.py:864
 msgid "Done"
 msgstr "Urađeno"
 
-#: ../cli.py:829 ../cli.py:841 ../cli.py:847
+#: ../cli.py:875 ../cli.py:893 ../cli.py:899 ../yum/__init__.py:2274
 #, python-format
 msgid "Warning: Group %s does not exist."
 msgstr "Upozorenje: grupa %s ne postoji."
 
-#: ../cli.py:853
+#: ../cli.py:903
 msgid "No packages in any requested group available to install or update"
 msgstr ""
 "Nema dostupnih paketa za instalaciju ili ažuriranje u svim zahtevanim grupama"
 
-#: ../cli.py:855
+#: ../cli.py:905
 #, python-format
 msgid "%d Package(s) to Install"
 msgstr "%d paket(i) za instalaciju"
 
-#: ../cli.py:865
+#: ../cli.py:915 ../yum/__init__.py:2286
 #, python-format
 msgid "No group named %s exists"
 msgstr "Ne postoji grupa pod imenom %s"
 
-#: ../cli.py:871
+#: ../cli.py:921
 msgid "No packages to remove from groups"
 msgstr "Nema paketa za uklanjanje iz grupa"
 
-#: ../cli.py:873
+#: ../cli.py:923
 #, python-format
 msgid "%d Package(s) to remove"
 msgstr "%d  paket(i) za uklanjanje"
 
-#: ../cli.py:915
+#: ../cli.py:965
 #, python-format
 msgid "Package %s is already installed, skipping"
 msgstr "Paket %s je već instaliran, preskačem ga"
 
-#: ../cli.py:926
+#: ../cli.py:976
 #, python-format
 msgid "Discarding non-comparable pkg %s.%s"
 msgstr "Uklanjam neuporediv paket %s.%s"
 
 #. we've not got any installed that match n or n+a
-#: ../cli.py:952
+#: ../cli.py:1002
 #, python-format
 msgid "No other %s installed, adding to list for potential install"
 msgstr ""
 "Ne postoji instaliran drugi %s, dodajem ga u spisak za potencijalnu "
 "instalaciju"
 
-#: ../cli.py:971
+#: ../cli.py:1021
 #, python-format
 msgid "Command line error: %s"
 msgstr "Greška komandne linije: %s"
 
-#: ../cli.py:1101
+#: ../cli.py:1034
+#, python-format
+msgid ""
+"\n"
+"\n"
+"%s: %s option requires an argument"
+msgstr ""
+"\n"
+"\n"
+"%s: %s opcija zahteva argument"
+
+#: ../cli.py:1170
+msgid "show this help message and exit"
+msgstr "prikaži ovu pomoćnu poruku i izađi"
+
+#: ../cli.py:1174
 msgid "be tolerant of errors"
 msgstr "budi tolerantan na greške"
 
-#: ../cli.py:1103
+#: ../cli.py:1176
 msgid "run entirely from cache, don't update cache"
 msgstr "izvršavaj se u potpunosti iz keša, ne ažuriraj keš"
 
-#: ../cli.py:1105
+#: ../cli.py:1178
 msgid "config file location"
 msgstr "mesto datoteke podešavanja"
 
-#: ../cli.py:1107
+#: ../cli.py:1180
 msgid "maximum command wait time"
 msgstr "najduže vreme čekanja na komandu"
 
-#: ../cli.py:1109
+#: ../cli.py:1182
 msgid "debugging output level"
 msgstr "nivo izlaznog prikaza za pronalaženje grešaka"
 
-#: ../cli.py:1113
+#: ../cli.py:1186
 msgid "show duplicates, in repos, in list/search commands"
 msgstr ""
 "prikazuj duplikate, u riznicama, u komandama za izlistavanje/pretraživanje"
 
-#: ../cli.py:1115
+#: ../cli.py:1188
 msgid "error output level"
 msgstr "nivo izlaznog prikaza grešaka"
 
-#: ../cli.py:1118
+#: ../cli.py:1191
 msgid "quiet operation"
 msgstr "tiha radnja"
 
-#: ../cli.py:1122
+#: ../cli.py:1193
+msgid "verbose operation"
+msgstr "opširna radnja"
+
+#: ../cli.py:1195
 msgid "answer yes for all questions"
 msgstr "odgovori sa da na sva pitanja"
 
-#: ../cli.py:1124
+#: ../cli.py:1197
 msgid "show Yum version and exit"
-msgstr "prikaži verziju Yum-a i izađi"
+msgstr "prikaži Yum verziju i izađi"
 
-#: ../cli.py:1125
+#: ../cli.py:1198
 msgid "set install root"
 msgstr "postavi koreni direktorijum instalacije"
 
-#: ../cli.py:1129
+#: ../cli.py:1202
 msgid "enable one or more repositories (wildcards allowed)"
 msgstr "uključi jednu ili više riznica (skraćenice su dozvoljene)"
 
-#: ../cli.py:1133
+#: ../cli.py:1206
 msgid "disable one or more repositories (wildcards allowed)"
 msgstr "isključi jednu ili više riznica (skraćenice su dozvoljene)"
 
-#: ../cli.py:1136
+#: ../cli.py:1209
 msgid "exclude package(s) by name or glob"
-msgstr "izuzmite paket(e) po imenu ili glob-u"
+msgstr "izuzmi paket(e) po imenu ili globu"
 
-#: ../cli.py:1138
+#: ../cli.py:1211
 msgid "disable exclude from main, for a repo or for everything"
 msgstr "isključi izuzimanje iz glavnog skupa, za riznicu ili za sve"
 
-#: ../cli.py:1141
+#: ../cli.py:1214
 msgid "enable obsoletes processing during updates"
 msgstr "uključi obradu zastarelih paketa u toku ažuriranja"
 
-#: ../cli.py:1143
+#: ../cli.py:1216
 msgid "disable Yum plugins"
 msgstr "isključi dodatke za Yum"
 
-#: ../cli.py:1145
+#: ../cli.py:1218
 msgid "disable gpg signature checking"
 msgstr "isključi proveru gpg potpisa"
 
-#: ../cli.py:1147
+#: ../cli.py:1220
 msgid "disable plugins by name"
 msgstr "isključi dodatke po imenu"
 
-#: ../cli.py:1150
+#: ../cli.py:1223
+msgid "enable plugins by name"
+msgstr "uključi dodatke po imenu"
+
+#: ../cli.py:1226
 msgid "skip packages with depsolving problems"
 msgstr "preskoči pakete koji imaju problema sa rešavanjem zavisnosti"
 
-#: ../output.py:229
+#: ../output.py:236
 msgid "Jan"
 msgstr "jan"
 
-#: ../output.py:229
+#: ../output.py:236
 msgid "Feb"
 msgstr "feb"
 
-#: ../output.py:229
+#: ../output.py:236
 msgid "Mar"
 msgstr "mar"
 
-#: ../output.py:229
+#: ../output.py:236
 msgid "Apr"
 msgstr "apr"
 
-#: ../output.py:229
+#: ../output.py:236
 msgid "May"
 msgstr "maj"
 
-#: ../output.py:229
+#: ../output.py:236
 msgid "Jun"
 msgstr "jun"
 
-#: ../output.py:230
+#: ../output.py:237
 msgid "Jul"
 msgstr "jul"
 
-#: ../output.py:230
+#: ../output.py:237
 msgid "Aug"
 msgstr "avg"
 
-#: ../output.py:230
+#: ../output.py:237
 msgid "Sep"
 msgstr "sep"
 
-#: ../output.py:230
+#: ../output.py:237
 msgid "Oct"
 msgstr "okt"
 
-#: ../output.py:230
+#: ../output.py:237
 msgid "Nov"
 msgstr "nov"
 
-#: ../output.py:230
+#: ../output.py:237
 msgid "Dec"
 msgstr "dec"
 
-#: ../output.py:240
+#: ../output.py:247
 msgid "Trying other mirror."
 msgstr "Pokušavam drugi odraz."
 
-#: ../output.py:293
+#: ../output.py:425
 #, python-format
-msgid "Name       : %s"
-msgstr "Ime        : %s"
+msgid "Name       : %s%s%s"
+msgstr "Ime        : %s%s%s"
 
-#: ../output.py:294
+#: ../output.py:426
 #, python-format
 msgid "Arch       : %s"
 msgstr "Arhitektura: %s"
 
-#: ../output.py:296
+#: ../output.py:428
 #, python-format
 msgid "Epoch      : %s"
 msgstr "Period     : %s"
 
-#: ../output.py:297
+#: ../output.py:429
 #, python-format
 msgid "Version    : %s"
 msgstr "Verzija    : %s"
 
-#: ../output.py:298
+#: ../output.py:430
 #, python-format
 msgid "Release    : %s"
-msgstr "Izdanje     : %s"
+msgstr "Izdanje    : %s"
 
-#: ../output.py:299
+#: ../output.py:431
 #, python-format
 msgid "Size       : %s"
 msgstr "Veličina   : %s"
 
-#: ../output.py:300
+#: ../output.py:432
 #, python-format
 msgid "Repo       : %s"
 msgstr "Riznica    : %s"
 
-#: ../output.py:302
+#: ../output.py:434
 #, python-format
 msgid "Committer  : %s"
+msgstr "Objavljivač: %s"
+
+#: ../output.py:435
+#, fuzzy, python-format
+msgid "Committime : %s"
+msgstr "Objavljivač : %s"
+
+#: ../output.py:436
+#, fuzzy, python-format
+msgid "Buildtime  : %s"
 msgstr "Objavljivač : %s"
 
-#: ../output.py:303
+#: ../output.py:438
+#, fuzzy, python-format
+msgid "Installtime: %s"
+msgstr "Instalirani"
+
+#: ../output.py:439
 msgid "Summary    : "
 msgstr "Sažetak    :"
 
-#: ../output.py:305
+#: ../output.py:441
 #, python-format
 msgid "URL        : %s"
 msgstr "URL        : %s"
 
-#: ../output.py:306
+#: ../output.py:442
 #, python-format
 msgid "License    : %s"
 msgstr "Licenca    : %s"
 
-#: ../output.py:307
+#: ../output.py:443
 msgid "Description: "
 msgstr "Opis       : "
 
-#: ../output.py:351
-msgid "Is this ok [y/N]: "
-msgstr "Da li je ovo u redu [d/N]: "
-
-#: ../output.py:357 ../output.py:360
+#: ../output.py:500
 msgid "y"
 msgstr "d"
 
-#: ../output.py:357
-msgid "n"
-msgstr "n"
-
-#: ../output.py:357 ../output.py:360
+#: ../output.py:500
 msgid "yes"
 msgstr "da"
 
-#: ../output.py:357
+#: ../output.py:501
+msgid "n"
+msgstr "n"
+
+#: ../output.py:501
 msgid "no"
 msgstr "ne"
 
-#: ../output.py:367
+#: ../output.py:505
+msgid "Is this ok [y/N]: "
+msgstr "Da li je ovo u redu [d/N]: "
+
+#: ../output.py:587
 #, python-format
 msgid ""
 "\n"
@@ -556,96 +620,123 @@ msgstr ""
 "\n"
 "Grupa: %s"
 
-#: ../output.py:369
+#: ../output.py:594
 #, python-format
 msgid " Description: %s"
 msgstr " Opis: %s"
 
-#: ../output.py:371
+#: ../output.py:596
 msgid " Mandatory Packages:"
 msgstr " Obavezni paketi:"
 
-#: ../output.py:376
+#: ../output.py:597
 msgid " Default Packages:"
 msgstr " Podrazumevani paketi:"
 
-#: ../output.py:381
+#: ../output.py:598
 msgid " Optional Packages:"
 msgstr " Izborni paketi:"
 
-#: ../output.py:386
+#: ../output.py:599
 msgid " Conditional Packages:"
 msgstr " Uslovljeni paketi:"
 
-#: ../output.py:394
+#: ../output.py:619
 #, python-format
 msgid "package: %s"
 msgstr "paket: %s"
 
-#: ../output.py:396
+#: ../output.py:621
 msgid "  No dependencies for this package"
 msgstr "  Ne postoje zavisnosti ovog paketa"
 
-#: ../output.py:401
+#: ../output.py:626
 #, python-format
 msgid "  dependency: %s"
 msgstr "  zavisnost: %s"
 
-#: ../output.py:403
+#: ../output.py:628
 msgid "   Unsatisfied dependency"
 msgstr "   Nezadovoljena zavisnost"
 
-#: ../output.py:461
+#: ../output.py:700
 msgid "Matched from:"
 msgstr "Povezan iz:"
 
-#: ../output.py:487
+#: ../output.py:708
+msgid "Description : "
+msgstr "Opis        : "
+
+#: ../output.py:711
+#, python-format
+msgid "URL         : %s"
+msgstr "URL         : %s"
+
+#: ../output.py:714
+#, python-format
+msgid "License     : %s"
+msgstr "Licenca     : %s"
+
+#: ../output.py:717
+#, python-format
+msgid "Filename    : %s"
+msgstr "Ime datoteke: %s"
+
+#: ../output.py:721
+msgid "Other       : "
+msgstr "Ostalo      : "
+
+#: ../output.py:753
 msgid "There was an error calculating total download size"
 msgstr "Dogodila se greška pri računanju ukupne veličine za preuzimanje"
 
-#: ../output.py:492
+#: ../output.py:758
 #, python-format
 msgid "Total size: %s"
 msgstr "Ukupna veličina: %s"
 
-#: ../output.py:495
+#: ../output.py:761
 #, python-format
 msgid "Total download size: %s"
 msgstr "Ukupna veličina za preuzimanje: %s"
 
-#: ../output.py:507
+#: ../output.py:779
+msgid "Installing for dependencies"
+msgstr "Instaliram zbog zavisnosti"
+
+#: ../output.py:780
+msgid "Updating for dependencies"
+msgstr "Ažuriram zbog zavisnosti"
+
+#: ../output.py:781
+msgid "Removing for dependencies"
+msgstr "Uklanjam zbog zavisnosti"
+
+#: ../output.py:782 ../output.py:893
+msgid "Skipped (dependency problems)"
+msgstr "Preskočeno (problemi sa zavisnostima)"
+
+#: ../output.py:818
 msgid "Package"
 msgstr "Paket"
 
-#: ../output.py:507
+#: ../output.py:818
 msgid "Arch"
 msgstr "Arhitektura"
 
-#: ../output.py:507
+#: ../output.py:819
 msgid "Version"
 msgstr "Verzija"
 
-#: ../output.py:507
+#: ../output.py:819
 msgid "Repository"
 msgstr "Riznica"
 
-#: ../output.py:507
+#: ../output.py:820
 msgid "Size"
 msgstr "Veličina"
 
-#: ../output.py:514
-msgid "Installing for dependencies"
-msgstr "Instaliram zbog zavisnosti"
-
-#: ../output.py:515
-msgid "Updating for dependencies"
-msgstr "Ažuriram zbog zavisnosti"
-
-#: ../output.py:516
-msgid "Removing for dependencies"
-msgstr "Uklanjam zbog zavisnosti"
-
-#: ../output.py:528
+#: ../output.py:831
 #, python-format
 msgid ""
 "     replacing  %s.%s %s\n"
@@ -654,44 +745,44 @@ msgstr ""
 "     uklanjam  %s.%s %s\n"
 "\n"
 
-#: ../output.py:536
+#: ../output.py:839
 #, python-format
 msgid ""
 "\n"
 "Transaction Summary\n"
-"=============================================================================\n"
+"%s\n"
 "Install  %5.5s Package(s)         \n"
 "Update   %5.5s Package(s)         \n"
 "Remove   %5.5s Package(s)         \n"
 msgstr ""
 "\n"
 "Sažetak transakcije\n"
-"=============================================================================\n"
-"instaliranje  %5.5s paket(a)       \n"
-"ažuriranje    %5.5s paket(a)       \n"
-"uklanjanje     %5.5s paket(a)       \n"
+"%s\n"
+"Instalacija  %5.5s paket(a)       \n"
+"Ažuriranje   %5.5s paket(a)       \n"
+"Uklanjanje   %5.5s paket(a)       \n"
 
-#: ../output.py:554
+#: ../output.py:887
 msgid "Removed"
 msgstr "Uklonjeno"
 
-#: ../output.py:555
+#: ../output.py:888
 msgid "Dependency Removed"
 msgstr "Zavisnost uklonjena"
 
-#: ../output.py:557
+#: ../output.py:890
 msgid "Dependency Installed"
 msgstr "Zavisnost instalirana"
 
-#: ../output.py:559
+#: ../output.py:892
 msgid "Dependency Updated"
 msgstr "Zavisnost ažurirana"
 
-#: ../output.py:560
+#: ../output.py:894
 msgid "Replaced"
 msgstr "Zamenjeno"
 
-#: ../output.py:618
+#: ../output.py:967
 #, python-format
 msgid ""
 "\n"
@@ -702,73 +793,77 @@ msgstr ""
 " Trenutno preuzimanje je obustavljeno, %sinterrupt (ctrl-c) još jednom%s u "
 "toku %s%s%s sekundi da biste izašli.\n"
 
-#: ../output.py:628
+#: ../output.py:977
 msgid "user interrupt"
 msgstr "prekid od strane korisnika"
 
-#: ../output.py:639
+#: ../output.py:993
+msgid "Total"
+msgstr "Ukupno"
+
+#: ../output.py:1007
 msgid "installed"
 msgstr "instaliran"
 
-#: ../output.py:640
+#: ../output.py:1008
 msgid "updated"
 msgstr "ažuriran"
 
-#: ../output.py:641
+#: ../output.py:1009
 msgid "obsoleted"
 msgstr "prevaziđen"
 
-#: ../output.py:642
+#: ../output.py:1010
 msgid "erased"
 msgstr "obrisan"
 
-#: ../output.py:646
+#: ../output.py:1014
 #, python-format
 msgid "---> Package %s.%s %s:%s-%s set to be %s"
 msgstr "---> Paket %s.%s %s:%s-%s postavljen da bude %s"
 
-#: ../output.py:653
+#: ../output.py:1021
 msgid "--> Running transaction check"
 msgstr "--> Izvršava se provera transakcije"
 
-#: ../output.py:658
+#: ../output.py:1026
 msgid "--> Restarting Dependency Resolution with new changes."
 msgstr "--> Ponovno pokretanje razrešavanja zavisnosti sa novim promenama."
 
-#: ../output.py:663
+#: ../output.py:1031
 msgid "--> Finished Dependency Resolution"
 msgstr "--> Završeno je razrešavanje zavisnosti"
 
-#: ../output.py:668
+#: ../output.py:1036
 #, python-format
 msgid "--> Processing Dependency: %s for package: %s"
 msgstr "--> Obrađujem zavisnost: %s za paket: %s"
 
-#: ../output.py:673
+#: ../output.py:1041
 #, python-format
 msgid "--> Unresolved Dependency: %s"
 msgstr "--> Nerazrešena zavisnost: %s"
 
-#: ../output.py:679
+#: ../output.py:1047
 #, python-format
 msgid "--> Processing Conflict: %s conflicts %s"
 msgstr "--> Sukob pri obradi: %s se sukobi sa %s"
 
-#: ../output.py:682
+#: ../output.py:1050
 msgid "--> Populating transaction set with selected packages. Please wait."
 msgstr ""
 "--> Popunjavam skup transakcije sa izabranim paketima. Molim vas, sačekajte."
 
-#: ../output.py:686
+#: ../output.py:1054
 #, python-format
 msgid "---> Downloading header for %s to pack into transaction set."
 msgstr "---> Preuzimam zaglavlje za %s radi pakovanja u skup transakcije."
 
-#: ../yumcommands.py:36
+#: ../yumcommands.py:40
 msgid "You need to be root to perform this command."
 msgstr "Morate biti root korisnik da biste izvršili ovu komandu."
 
-#: ../yumcommands.py:43
+#: ../yumcommands.py:47
 msgid ""
 "\n"
 "You have enabled checking of packages via GPG keys. This is a good thing. \n"
@@ -799,252 +894,313 @@ msgstr ""
 "\n"
 "Za više informacija kontaktirajte dobavljača vaše distribucije ili paketa.\n"
 
-#: ../yumcommands.py:63
+#: ../yumcommands.py:67
 #, python-format
 msgid "Error: Need to pass a list of pkgs to %s"
 msgstr "Greška: potrebno je da dodate spisak paketa %s-u"
 
-#: ../yumcommands.py:69
+#: ../yumcommands.py:73
 msgid "Error: Need an item to match"
 msgstr "Greška: potrebno je pridružiti stavku"
 
-#: ../yumcommands.py:75
+#: ../yumcommands.py:79
 msgid "Error: Need a group or list of groups"
 msgstr "Greška: potrebna je grupa ili spisak grupa"
 
-#: ../yumcommands.py:84
+#: ../yumcommands.py:88
 #, python-format
 msgid "Error: clean requires an option: %s"
 msgstr "Greška: clean zahteva opciju: %s"
 
-#: ../yumcommands.py:89
+#: ../yumcommands.py:93
 #, python-format
 msgid "Error: invalid clean argument: %r"
 msgstr "Greška: pogrešan clean argument:%r"
 
-#: ../yumcommands.py:102
+#: ../yumcommands.py:106
 msgid "No argument to shell"
 msgstr "Ne postoji argument za komandno okruženje"
 
-#: ../yumcommands.py:105
+#: ../yumcommands.py:109
 #, python-format
 msgid "Filename passed to shell: %s"
 msgstr "Ime datoteke je prosleđeno komandnom okruženju: %s"
 
-#: ../yumcommands.py:109
+#: ../yumcommands.py:113
 #, python-format
 msgid "File %s given as argument to shell does not exist."
 msgstr ""
-"Ne postoji datoteka %s, koja je prosleđena kao argument komadnom okruženju."
+"Ne postoji datoteka %s, koja je prosleđena kao argument komandnom okruženju."
 
-#: ../yumcommands.py:115
+#: ../yumcommands.py:119
 msgid "Error: more than one file given as argument to shell."
 msgstr ""
 "Greška: više od jedne datoteke je prosleđeno kao argument komandnom "
 "okruženju."
 
-#: ../yumcommands.py:156
+#: ../yumcommands.py:160
 msgid "PACKAGE..."
 msgstr "PAKET..."
 
-#: ../yumcommands.py:159
+#: ../yumcommands.py:163
 msgid "Install a package or packages on your system"
 msgstr "Instalirajte paket ili pakete na vaš sistem"
 
-#: ../yumcommands.py:168
+#: ../yumcommands.py:172
 msgid "Setting up Install Process"
 msgstr "Postavljam proces instalacije"
 
-#: ../yumcommands.py:179
+#: ../yumcommands.py:183
 msgid "[PACKAGE...]"
 msgstr "[PAKET...]"
 
-#: ../yumcommands.py:182
+#: ../yumcommands.py:186
 msgid "Update a package or packages on your system"
 msgstr "Ažuriraj paket ili pakete na vašem sistemu"
 
-#: ../yumcommands.py:190
+#: ../yumcommands.py:194
 msgid "Setting up Update Process"
 msgstr "Postavljam proces ažuriranja"
 
-#: ../yumcommands.py:204
+#: ../yumcommands.py:236
 msgid "Display details about a package or group of packages"
 msgstr "Prikaži detalje o svakom paketu ili grupi paketa"
 
-#: ../yumcommands.py:212
+#. Output the packages:
+#: ../yumcommands.py:261
 msgid "Installed Packages"
 msgstr "Instalirani paketi"
 
-#: ../yumcommands.py:213
+#: ../yumcommands.py:263
 msgid "Available Packages"
 msgstr "Dostupni paketi"
 
-#: ../yumcommands.py:214
+#: ../yumcommands.py:265
 msgid "Extra Packages"
 msgstr "Dodatni paketi"
 
-#: ../yumcommands.py:215
+#: ../yumcommands.py:267
 msgid "Updated Packages"
 msgstr "Ažurirani paketi"
 
-#: ../yumcommands.py:221 ../yumcommands.py:225
+#: ../yumcommands.py:274 ../yumcommands.py:281
 msgid "Obsoleting Packages"
 msgstr "Prevaziđeni paketi"
 
-#: ../yumcommands.py:226
+#: ../yumcommands.py:283
 msgid "Recently Added Packages"
 msgstr "Nedavno dodati paketi"
 
-#: ../yumcommands.py:232
+#: ../yumcommands.py:290
 msgid "No matching Packages to list"
 msgstr "Ne postoje odgovarajući paketi za izlistavanje"
 
-#: ../yumcommands.py:246
+#: ../yumcommands.py:304
 msgid "List a package or groups of packages"
 msgstr "Izlistaj pakete ili grupe paketa"
 
-#: ../yumcommands.py:258
+#: ../yumcommands.py:316
 msgid "Remove a package or packages from your system"
 msgstr "Uklonite paket ili pakete sa vašeg sistema"
 
-#: ../yumcommands.py:266
+#: ../yumcommands.py:324
 msgid "Setting up Remove Process"
 msgstr "Postavljam proces uklanjanja"
 
-#: ../yumcommands.py:278
+#: ../yumcommands.py:339
 msgid "Setting up Group Process"
 msgstr "Postavljam proces za grupe"
 
-#: ../yumcommands.py:284
+#: ../yumcommands.py:345
 msgid "No Groups on which to run command"
 msgstr "Ne postoji grupa nad kojom se može izvršiti komanda"
 
-#: ../yumcommands.py:297
+#: ../yumcommands.py:358
 msgid "List available package groups"
 msgstr "Izlistaj dostupne grupe paketa"
 
-#: ../yumcommands.py:314
+#: ../yumcommands.py:375
 msgid "Install the packages in a group on your system"
 msgstr "Instalirajte pakete u grupi na vašem sistemu"
 
-#: ../yumcommands.py:336
+#: ../yumcommands.py:397
 msgid "Remove the packages in a group from your system"
 msgstr "Uklonite pakete u grupi sa vašeg sistema"
 
-#: ../yumcommands.py:360
+#: ../yumcommands.py:424
 msgid "Display details about a package group"
 msgstr "Prikaži detalje o grupi paketa"
 
-#: ../yumcommands.py:384
+#: ../yumcommands.py:448
 msgid "Generate the metadata cache"
 msgstr "Napravi keš sa metapodacima"
 
-#: ../yumcommands.py:390
+#: ../yumcommands.py:454
 msgid "Making cache files for all metadata files."
 msgstr "Pravim keš datoteke za sve datoteke sa metapodacima."
 
-#: ../yumcommands.py:391
+#: ../yumcommands.py:455
 msgid "This may take a while depending on the speed of this computer"
 msgstr "Ovo može da potraje u zavisnosti od brzine vašeg računara"
 
-#: ../yumcommands.py:412
+#: ../yumcommands.py:476
 msgid "Metadata Cache Created"
 msgstr "Napravljen je keš sa metapodacima"
 
-#: ../yumcommands.py:426
+#: ../yumcommands.py:490
 msgid "Remove cached data"
 msgstr "Ukloni keširane podatke"
 
-#: ../yumcommands.py:447
+#: ../yumcommands.py:511
 msgid "Find what package provides the given value"
 msgstr "Pronađi koji paket pruža datu vrednost"
 
-#: ../yumcommands.py:467
+#: ../yumcommands.py:531
 msgid "Check for available package updates"
 msgstr "Proverite da li su dostupna ažuriranja paketa"
 
-#: ../yumcommands.py:490
+#: ../yumcommands.py:556
 msgid "Search package details for the given string"
 msgstr "Pretražite detalje o paketu za zadatu nisku"
 
-#: ../yumcommands.py:496
+#: ../yumcommands.py:562
 msgid "Searching Packages: "
 msgstr "Pretražujem pakete: "
 
-#: ../yumcommands.py:513
+#: ../yumcommands.py:579
 msgid "Update packages taking obsoletes into account"
 msgstr "Ažurirajte pakete uzimajući prevaziđene u obzir"
 
-#: ../yumcommands.py:522
+#: ../yumcommands.py:588
 msgid "Setting up Upgrade Process"
 msgstr "Postavljam proces nadgradnje"
 
-#: ../yumcommands.py:536
+#: ../yumcommands.py:602
 msgid "Install a local RPM"
 msgstr "Instaliraj lokalni RPM"
 
-#: ../yumcommands.py:545
+#: ../yumcommands.py:611
 msgid "Setting up Local Package Process"
 msgstr "Postavljam proces lokalnih paketa"
 
-#: ../yumcommands.py:564
+#: ../yumcommands.py:630
 msgid "Determine which package provides the given dependency"
 msgstr "Odredi koji paketi pružaju datu zavisnost"
 
-#: ../yumcommands.py:567
+#: ../yumcommands.py:633
 msgid "Searching Packages for Dependency:"
 msgstr "Pretražujem pakete u potrazi za zavisnostima:"
 
-#: ../yumcommands.py:581
+#: ../yumcommands.py:647
 msgid "Run an interactive yum shell"
 msgstr "Izvršavaj interaktivno komandno okruženje yum-a"
 
-#: ../yumcommands.py:587
+#: ../yumcommands.py:653
 msgid "Setting up Yum Shell"
 msgstr "Postavljam Yum komandno okruženje"
 
-#: ../yumcommands.py:605
+#: ../yumcommands.py:671
 msgid "List a package's dependencies"
 msgstr "Izlistaj zavisnosti paketa"
 
-#: ../yumcommands.py:611
+#: ../yumcommands.py:677
 msgid "Finding dependencies: "
 msgstr "Tražim zavisnosti: "
 
-#: ../yumcommands.py:627
+#: ../yumcommands.py:693
 msgid "Display the configured software repositories"
 msgstr "Prikaži podešene softverske riznice"
 
-#: ../yumcommands.py:645
+#: ../yumcommands.py:742
+msgid "enabled"
+msgstr "uključena"
+
+#: ../yumcommands.py:751
+msgid "disabled"
+msgstr "isključena"
+
+#: ../yumcommands.py:760
 msgid "repo id"
 msgstr "repo id"
 
-#: ../yumcommands.py:645
+#: ../yumcommands.py:761
 msgid "repo name"
 msgstr "repo ime"
 
-#: ../yumcommands.py:645
+#: ../yumcommands.py:761
 msgid "status"
 msgstr "status"
 
-#: ../yumcommands.py:651
-msgid "enabled"
-msgstr "uključena"
+#: ../yumcommands.py:765
+msgid "Repo-id     : "
+msgstr "IB riznice         : "
 
-#: ../yumcommands.py:654
-msgid "disabled"
-msgstr "isključena"
+#: ../yumcommands.py:766
+msgid "Repo-name   : "
+msgstr "Ime riznice        : "
 
-#: ../yumcommands.py:671
+#: ../yumcommands.py:767
+msgid "Repo-status : "
+msgstr "Status riznice     : "
+
+#: ../yumcommands.py:769
+#, fuzzy
+msgid "Repo-revision: "
+msgstr "Veličina riznice   : "
+
+#: ../yumcommands.py:773
+#, fuzzy
+msgid "Repo-tags   : "
+msgstr "Paketi riznice     : "
+
+#: ../yumcommands.py:779
+#, fuzzy
+msgid "Repo-distro-tags: "
+msgstr "Status riznice     : "
+
+#: ../yumcommands.py:784
+msgid "Repo-updated: "
+msgstr "Riznica ažurirana  : "
+
+#: ../yumcommands.py:786
+msgid "Repo-pkgs   : "
+msgstr "Paketi riznice     : "
+
+#: ../yumcommands.py:787
+msgid "Repo-size   : "
+msgstr "Veličina riznice   : "
+
+#: ../yumcommands.py:794
+msgid "Repo-baseurl: "
+msgstr "Osnovni URL riznice: "
+
+#: ../yumcommands.py:798
+#, fuzzy
+msgid "Repo-metalink: "
+msgstr "Ime riznice        : "
+
+#: ../yumcommands.py:801
+msgid "Repo-mirrors: "
+msgstr "Odrazi riznice     : "
+
+#: ../yumcommands.py:805
+msgid "Repo-exclude: "
+msgstr "Riznica isključena : "
+
+#: ../yumcommands.py:809
+msgid "Repo-include: "
+msgstr "Riznica uključena  : "
+
+#: ../yumcommands.py:835
 msgid "Display a helpful usage message"
 msgstr "Prikaži korisnu poruku o upotrebi"
 
-#: ../yumcommands.py:705
+#: ../yumcommands.py:869
 #, python-format
 msgid "No help available for %s"
 msgstr "Nije dostupna pomoć za %s"
 
-#: ../yumcommands.py:710
+#: ../yumcommands.py:874
 msgid ""
 "\n"
 "\n"
@@ -1052,9 +1208,9 @@ msgid ""
 msgstr ""
 "\n"
 "\n"
-"alijasi: "
+"pseudonimi: "
 
-#: ../yumcommands.py:712
+#: ../yumcommands.py:876
 msgid ""
 "\n"
 "\n"
@@ -1062,13 +1218,13 @@ msgid ""
 msgstr ""
 "\n"
 "\n"
-"alijas: "
+"pseudonim: "
 
-#: ../yumcommands.py:741
+#: ../yumcommands.py:905
 msgid "Setting up Reinstall Process"
 msgstr "Postavljam proces ponovne instalacije"
 
-#: ../yumcommands.py:755
+#: ../yumcommands.py:919
 msgid "reinstall a package"
 msgstr "ponovno instaliram paket"
 
@@ -1092,29 +1248,29 @@ msgstr ""
 "\n"
 "Izlazim kada se slomi cev"
 
-#: ../yummain.py:105
+#: ../yummain.py:98
 msgid ""
 "Another app is currently holding the yum lock; waiting for it to exit..."
 msgstr ""
-"Neki drugi program trenutno drži yum zaključavanje, čekam da se taj program "
-"isključi..."
+"Neki drugi program trenutno drži yum zaključanim; čekam da taj program "
+"izađe..."
 
-#: ../yummain.py:132 ../yummain.py:171
+#: ../yummain.py:125 ../yummain.py:164
 #, python-format
 msgid "Error: %s"
 msgstr "Greška: %s"
 
-#: ../yummain.py:142 ../yummain.py:178
+#: ../yummain.py:135 ../yummain.py:171
 #, python-format
 msgid "Unknown Error(s): Exit Code: %d:"
 msgstr "Nepoznata greška(e): izlazni kod: %d:"
 
 #. Depsolve stage
-#: ../yummain.py:149
+#: ../yummain.py:142
 msgid "Resolving Dependencies"
 msgstr "Razrešavam zavisnosti"
 
-#: ../yummain.py:184
+#: ../yummain.py:177
 msgid ""
 "\n"
 "Dependencies Resolved"
@@ -1122,11 +1278,11 @@ msgstr ""
 "\n"
 "Zavisnosti su razrešene"
 
-#: ../yummain.py:198
+#: ../yummain.py:191
 msgid "Complete!"
 msgstr "Završeno!"
 
-#: ../yummain.py:245
+#: ../yummain.py:238
 msgid ""
 "\n"
 "\n"
@@ -1136,318 +1292,315 @@ msgstr ""
 "\n"
 "Izlazim kada korisnik otkaže."
 
-#: ../yum/depsolve.py:82
+#: ../yum/depsolve.py:84
 msgid "doTsSetup() will go away in a future version of Yum.\n"
 msgstr "doTsSetup() neće biti prisutna u budućim verzijama Yum-a.\n"
 
-#: ../yum/depsolve.py:95
+#: ../yum/depsolve.py:97
 msgid "Setting up TransactionSets before config class is up"
 msgstr "Postavljam TransactionSets pre nego što se podigne klasa podešavanja"
 
-#: ../yum/depsolve.py:136
+#: ../yum/depsolve.py:148
 #, python-format
 msgid "Invalid tsflag in config file: %s"
 msgstr "Pogrešan tsflag u datoteci podešavanja: %s"
 
-#: ../yum/depsolve.py:147
+#: ../yum/depsolve.py:159
 #, fuzzy, python-format
 msgid "Searching pkgSack for dep: %s"
 msgstr "tražim paket %s"
 
-#: ../yum/depsolve.py:170
+#: ../yum/depsolve.py:182
 #, fuzzy, python-format
 msgid "Potential match for %s from %s"
 msgstr "Postoji više od jednog identičnog slaganja u grupi za %s"
 
-#: ../yum/depsolve.py:178
+#: ../yum/depsolve.py:190
 #, fuzzy, python-format
 msgid "Matched %s to require for %s"
 msgstr "%s zahteva: %s"
 
-#: ../yum/depsolve.py:219
+#: ../yum/depsolve.py:231
 #, python-format
 msgid "Member: %s"
 msgstr "Član: %s"
 
-#: ../yum/depsolve.py:233 ../yum/depsolve.py:696
+#: ../yum/depsolve.py:245 ../yum/depsolve.py:732
 #, python-format
 msgid "%s converted to install"
 msgstr "%s prebačen za instalaciju"
 
-#: ../yum/depsolve.py:240
+#: ../yum/depsolve.py:252
 #, python-format
 msgid "Adding Package %s in mode %s"
 msgstr "Dodajem paket %s u načinu rada %s"
 
-#: ../yum/depsolve.py:250
+#: ../yum/depsolve.py:262
 #, python-format
 msgid "Removing Package %s"
 msgstr "Uklanjam paket %s"
 
-#: ../yum/depsolve.py:261
+#: ../yum/depsolve.py:273
 #, python-format
 msgid "%s requires: %s"
 msgstr "%s zahteva: %s"
 
-#: ../yum/depsolve.py:312
+#: ../yum/depsolve.py:331
 msgid "Needed Require has already been looked up, cheating"
-msgstr ""
+msgstr "Potreban zahtev je već potražen, obmanjujem"
 
-#: ../yum/depsolve.py:322
+#: ../yum/depsolve.py:341
 #, python-format
 msgid "Needed Require is not a package name. Looking up: %s"
-msgstr ""
+msgstr "Potreban zahtev nije ime paketa. Tražim: %s"
 
-#: ../yum/depsolve.py:329
-#, fuzzy, python-format
+#: ../yum/depsolve.py:348
+#, python-format
 msgid "Potential Provider: %s"
-msgstr "Ukupna veličina: %s"
+msgstr "Mogući snabdevač: %s"
 
-#: ../yum/depsolve.py:352
+#: ../yum/depsolve.py:371
 #, python-format
 msgid "Mode is %s for provider of %s: %s"
-msgstr ""
+msgstr "Režim je %s za snabdevača %s: %s"
 
-#: ../yum/depsolve.py:356
+#: ../yum/depsolve.py:375
 #, python-format
 msgid "Mode for pkg providing %s: %s"
-msgstr ""
+msgstr "Režim za paket koji snabdeva %s: %s"
 
-#: ../yum/depsolve.py:360
+#: ../yum/depsolve.py:379
 #, python-format
 msgid "TSINFO: %s package requiring %s marked as erase"
 msgstr "TSINFO: %s paket zahteva da %s bude označen za brisanje"
 
-#: ../yum/depsolve.py:372
+#: ../yum/depsolve.py:391
 #, python-format
 msgid "TSINFO: Obsoleting %s with %s to resolve dep."
-msgstr "TSINFO: menjam %s sa %s da bih razrešio zavisnost."
+msgstr "TSINFO: menjam %s sa %s radi razrešavanja zavisnosti."
 
-#: ../yum/depsolve.py:375
+#: ../yum/depsolve.py:394
 #, python-format
 msgid "TSINFO: Updating %s to resolve dep."
-msgstr "TSINFO: ažuriram %s da bih razrešio zavisnost."
+msgstr "TSINFO: ažuriram %s radi razrešavanja zavisnosti."
 
-#: ../yum/depsolve.py:378
+#: ../yum/depsolve.py:402
 #, python-format
 msgid "Cannot find an update path for dep for: %s"
 msgstr "Ne mogu da pronađem putanju ažuriranja za zavisnost za: %s"
 
-#: ../yum/depsolve.py:388
+#: ../yum/depsolve.py:412
 #, python-format
 msgid "Unresolvable requirement %s for %s"
-msgstr ""
+msgstr "Nerazrešiv zahtev paketa %s za %s"
+
+#: ../yum/depsolve.py:435
+#, python-format
+msgid "Quick matched %s to require for %s"
+msgstr "Brzo povezivanje paketa %s kao zahteva za %s"
 
 #. is it already installed?
-#: ../yum/depsolve.py:434
+#: ../yum/depsolve.py:477
 #, python-format
 msgid "%s is in providing packages but it is already installed, removing."
-msgstr "%s je u pruženim paketa ali je već instaliran, uklanjam ga."
+msgstr "%s je u pruženim paketima ali je već instaliran, uklanjam ga."
 
-#: ../yum/depsolve.py:449
+#: ../yum/depsolve.py:492
 #, python-format
 msgid "Potential resolving package %s has newer instance in ts."
 msgstr "Potencijalno razrešavanje paketa %s ima noviji primerak u ts-u."
 
-#: ../yum/depsolve.py:460
+#: ../yum/depsolve.py:503
 #, python-format
 msgid "Potential resolving package %s has newer instance installed."
-msgstr "Potencijalno razrešavanje paketa %s ima instaliran novi primerak."
+msgstr "Potencijalno razrešavanje paketa %s ima instaliran noviji primerak."
 
-#: ../yum/depsolve.py:468 ../yum/depsolve.py:527
+#: ../yum/depsolve.py:511 ../yum/depsolve.py:560
 #, python-format
 msgid "Missing Dependency: %s is needed by package %s"
 msgstr "Nedostaje zavisnost: %s je potreban od strane paketa %s"
 
-#: ../yum/depsolve.py:481
+#: ../yum/depsolve.py:524
 #, python-format
 msgid "%s already in ts, skipping this one"
 msgstr "%s je već u ts-u, preskačem ga"
 
-#: ../yum/depsolve.py:510
-#, python-format
-msgid ""
-"Failure finding best provider of %s for %s, exceeded maximum loop length"
-msgstr ""
-
-#: ../yum/depsolve.py:537
+#: ../yum/depsolve.py:570
 #, python-format
 msgid "TSINFO: Marking %s as update for %s"
 msgstr "TSINFO: označavam %s kao ažuriranje za %s"
 
-#: ../yum/depsolve.py:544
+#: ../yum/depsolve.py:578
 #, python-format
 msgid "TSINFO: Marking %s as install for %s"
 msgstr "TSINFO: označavam %s kao instalaciju za %s"
 
-#: ../yum/depsolve.py:635 ../yum/depsolve.py:714
+#: ../yum/depsolve.py:670 ../yum/depsolve.py:750
 msgid "Success - empty transaction"
 msgstr "Uspeh - prazna transakcija"
 
-#: ../yum/depsolve.py:673 ../yum/depsolve.py:686
+#: ../yum/depsolve.py:709 ../yum/depsolve.py:722
 msgid "Restarting Loop"
 msgstr "Ponovo pokrećem petlju"
 
-#: ../yum/depsolve.py:702
+#: ../yum/depsolve.py:738
 msgid "Dependency Process ending"
 msgstr "Završetak procesa zavisnosti"
 
-#: ../yum/depsolve.py:708
+#: ../yum/depsolve.py:744
 #, python-format
 msgid "%s from %s has depsolving problems"
 msgstr "%s iz %s ima problema sa razrešavanjem zavisnosti"
 
-#: ../yum/depsolve.py:715
+#: ../yum/depsolve.py:751
 msgid "Success - deps resolved"
 msgstr "Uspeh - zavisnosti su razrešene"
 
-#: ../yum/depsolve.py:729
+#: ../yum/depsolve.py:765
 #, python-format
 msgid "Checking deps for %s"
 msgstr "Proveravam zavisnosti za %s"
 
-#: ../yum/depsolve.py:782
+#: ../yum/depsolve.py:848
 #, python-format
 msgid "looking for %s as a requirement of %s"
 msgstr "tražim %s kao zahtev za %s"
 
-#: ../yum/depsolve.py:933
-#, python-format
-msgid "Comparing best: %s to po: %s"
-msgstr ""
-
-#: ../yum/depsolve.py:937
+#: ../yum/depsolve.py:988
 #, python-format
-msgid "Same: best %s == po: %s"
-msgstr ""
+msgid "Running compare_providers() for %s"
+msgstr "Pokrećem compare_providers() za %s"
 
-#: ../yum/depsolve.py:952 ../yum/depsolve.py:963
+#: ../yum/depsolve.py:1016 ../yum/depsolve.py:1022
 #, fuzzy, python-format
-msgid "best %s obsoletes po: %s"
-msgstr "%s prevazilazi %s"
-
-#: ../yum/depsolve.py:955
-#, fuzzy, python-format
-msgid "po %s obsoletes best: %s"
-msgstr "%s prevazilazi %s"
-
-#: ../yum/depsolve.py:972 ../yum/depsolve.py:979 ../yum/depsolve.py:1036
-#, python-format
 msgid "better arch in po %s"
 msgstr "bolja arhitektura u po %s"
 
-#: ../yum/depsolve.py:988 ../yum/depsolve.py:1010
+#: ../yum/depsolve.py:1061
 #, python-format
-msgid "po %s shares a sourcerpm with %s"
-msgstr ""
+msgid "%s obsoletes %s"
+msgstr "%s prevazilazi %s"
 
-#: ../yum/depsolve.py:992 ../yum/depsolve.py:1015
+#: ../yum/depsolve.py:1077
 #, python-format
-msgid "best %s shares a sourcerpm with %s"
+msgid ""
+"archdist compared %s to %s on %s\n"
+"  Winner: %s"
 msgstr ""
+"archdist uporedio %s sa %s na %s\n"
+"  Pobednik: %s"
 
-#: ../yum/depsolve.py:999 ../yum/depsolve.py:1020
+#: ../yum/depsolve.py:1084
 #, python-format
-msgid "po %s shares more of the name prefix with %s"
-msgstr ""
+msgid "common sourcerpm %s and %s"
+msgstr "zajednički izvorni rpm %s i %s"
 
-#: ../yum/depsolve.py:1003 ../yum/depsolve.py:1029
+#: ../yum/depsolve.py:1090
 #, python-format
-msgid "po %s has a shorter name than best %s"
-msgstr ""
+msgid "common prefix of %s between %s and %s"
+msgstr "zajednički prefiks %s između %s i %s"
 
-#: ../yum/depsolve.py:1025
+#: ../yum/depsolve.py:1098
 #, python-format
-msgid "bestpkg %s shares more of the name prefix with %s"
-msgstr ""
+msgid "Best Order: %s"
+msgstr "Najbolji redosled: %s"
 
-#: ../yum/__init__.py:119
+#: ../yum/__init__.py:135
 msgid "doConfigSetup() will go away in a future version of Yum.\n"
 msgstr "doConfigSetup() neće biti prisutna u budućim verzijama Yum-a.\n"
 
-#: ../yum/__init__.py:296
+#: ../yum/__init__.py:315
 #, python-format
 msgid "Repository %r is missing name in configuration, using id"
 msgstr "Riznici %r nedostaje ime u podešavanjima, koristim id"
 
-#: ../yum/__init__.py:332
+#: ../yum/__init__.py:353
 msgid "plugins already initialised"
 msgstr "već inicijalizovani dodaci"
 
-#: ../yum/__init__.py:339
+#: ../yum/__init__.py:360
 msgid "doRpmDBSetup() will go away in a future version of Yum.\n"
 msgstr "doRpmDBSetup() neće biti prisutna u budućim verzijama Yum-a.\n"
 
-#: ../yum/__init__.py:349
+#: ../yum/__init__.py:370
 msgid "Reading Local RPMDB"
 msgstr "Čitam lokalni RPMDB"
 
-#: ../yum/__init__.py:367
+#: ../yum/__init__.py:388
 msgid "doRepoSetup() will go away in a future version of Yum.\n"
 msgstr "doRepoSetup() neće biti prisutna u budućim verzijama Yum-a.\n"
 
-#: ../yum/__init__.py:387
+#: ../yum/__init__.py:408
 msgid "doSackSetup() will go away in a future version of Yum.\n"
 msgstr "doSackSetup() neće biti prisutna u budućim verzijama Yum-a.\n"
 
-#: ../yum/__init__.py:404
+#: ../yum/__init__.py:425
 msgid "Setting up Package Sacks"
 msgstr "Postavljam grupe paketa"
 
-#: ../yum/__init__.py:447
+#: ../yum/__init__.py:468
 #, python-format
 msgid "repo object for repo %s lacks a _resetSack method\n"
 msgstr "repo objektu za repo %s nedostaje a _resetSack metoda\n"
 
-#: ../yum/__init__.py:448
+#: ../yum/__init__.py:469
 msgid "therefore this repo cannot be reset.\n"
 msgstr "zbog toga se ovaj repo ne može vratiti na početnu postavku.\n"
 
-#: ../yum/__init__.py:453
+#: ../yum/__init__.py:474
 msgid "doUpdateSetup() will go away in a future version of Yum.\n"
 msgstr "doUpdateSetup() neće biti prisutna u budućim verzijama Yum-a.\n"
 
-#: ../yum/__init__.py:465
+#: ../yum/__init__.py:486
 msgid "Building updates object"
-msgstr "Izgrađujem objekat ažurirnja"
+msgstr "Izgrađujem objekat ažuriranja"
 
-#: ../yum/__init__.py:496
+#: ../yum/__init__.py:517
 msgid "doGroupSetup() will go away in a future version of Yum.\n"
 msgstr "doGroupSetup() neće biti prisutna u budućim verzijama Yum-a.\n"
 
-#: ../yum/__init__.py:520
+#: ../yum/__init__.py:541
 msgid "Getting group metadata"
 msgstr "Dobavljam metapodatke grupe"
 
-#: ../yum/__init__.py:546
+#: ../yum/__init__.py:567
 #, python-format
 msgid "Adding group file from repository: %s"
 msgstr "Dodajem datoteku grupe iz riznice: %s"
 
-#: ../yum/__init__.py:555
+#: ../yum/__init__.py:576
 #, python-format
 msgid "Failed to add groups file for repository: %s - %s"
-msgstr "Nisam uspeo da dodam datoteku grupe za riznicu: %s - %s"
+msgstr "Nije uspelo dodavanje datoteke grupe za riznicu: %s - %s"
 
-#: ../yum/__init__.py:561
+#: ../yum/__init__.py:582
 msgid "No Groups Available in any repository"
 msgstr "Ne postoji grupa koja je dostupna u bilo kojoj riznici"
 
-#: ../yum/__init__.py:611
+#: ../yum/__init__.py:632
 msgid "Importing additional filelist information"
 msgstr "Uvozim dodatne informacije o spiskovima datoteka"
 
-#: ../yum/__init__.py:657
+#: ../yum/__init__.py:641
+#, fuzzy
+msgid ""
+"There are unfinished transactions remaining. You might consider running yum-"
+"complete-transaction first to finish them."
+msgstr ""
+"Ostale su nedovršene transakcije. Možda bi trebalo da izvršite yum-complete-"
+"transaction da biste ih završili."
+
+#: ../yum/__init__.py:698
 #, python-format
 msgid "Skip-broken round %i"
 msgstr "Skip-broken etapa %i"
 
-#: ../yum/__init__.py:680
+#: ../yum/__init__.py:724
 #, python-format
 msgid "Skip-broken took %i rounds "
 msgstr "Skip-broken je završen u %i etapa "
 
-#: ../yum/__init__.py:681
+#: ../yum/__init__.py:725
 msgid ""
 "\n"
 "Packages skipped because of dependency problems:"
@@ -1455,96 +1608,108 @@ msgstr ""
 "\n"
 "Paketi su preskočeni zbog problema sa zavisnostima:"
 
-#: ../yum/__init__.py:685
+#: ../yum/__init__.py:729
 #, python-format
 msgid "    %s from %s"
 msgstr "    %s iz %s"
 
-#: ../yum/__init__.py:774
+#: ../yum/__init__.py:816
+msgid ""
+"Warning: scriptlet or other non-fatal errors occurred during transaction."
+msgstr ""
+"Upozorenje: došlo je do greške u skriptici ili neke druge nekritične greške "
+"tokom transakcije."
+
+#: ../yum/__init__.py:832
 #, python-format
 msgid "Failed to remove transaction file %s"
-msgstr "Nisam uspeo da uklonim datoteku transakcije %s"
+msgstr "Nije uspelo uklanjanje datoteke transakcije %s"
 
-#: ../yum/__init__.py:814
+#: ../yum/__init__.py:873
 #, python-format
 msgid "excluding for cost: %s from %s"
 msgstr "izuzimam iz troška: %s iz %s"
 
-#: ../yum/__init__.py:845
+#: ../yum/__init__.py:904
 msgid "Excluding Packages in global exclude list"
 msgstr "Izuzimam pakete u globalnom spisku za izuzimanje"
 
-#: ../yum/__init__.py:847
+#: ../yum/__init__.py:906
 #, python-format
 msgid "Excluding Packages from %s"
 msgstr "Izuzimam pakete iz %s"
 
-#: ../yum/__init__.py:875
+#: ../yum/__init__.py:933
 #, python-format
 msgid "Reducing %s to included packages only"
 msgstr "Sažimam %s samo u sadržane pakete"
 
-#: ../yum/__init__.py:880
+#: ../yum/__init__.py:939
 #, python-format
 msgid "Keeping included package %s"
 msgstr "Zadržavam sadržani paket %s"
 
-#: ../yum/__init__.py:886
+#: ../yum/__init__.py:945
 #, python-format
 msgid "Removing unmatched package %s"
 msgstr "Uklanjam nepovezani paket %s"
 
-#: ../yum/__init__.py:889
+#: ../yum/__init__.py:948
 msgid "Finished"
 msgstr "Završio"
 
 #. Whoa. What the heck happened?
-#: ../yum/__init__.py:919
+#: ../yum/__init__.py:978
 #, python-format
 msgid "Unable to check if PID %s is active"
-msgstr "Nisam u mogućnisti da proverim da li je PID %s aktivan"
+msgstr "Nisam u mogućnosti da proverim da li je PID %s aktivan"
 
 #. Another copy seems to be running.
-#: ../yum/__init__.py:923
+#: ../yum/__init__.py:982
 #, python-format
 msgid "Existing lock %s: another copy is running as pid %s."
 msgstr "Postoji zaključavanje %s: druga kopija se izvršava kao pid %s."
 
-#: ../yum/__init__.py:970 ../yum/__init__.py:977
+#: ../yum/__init__.py:1053
 msgid "Package does not match intended download"
 msgstr "Paket nije odgovarajući za nameravano preuzimanje"
 
-#: ../yum/__init__.py:991
+#: ../yum/__init__.py:1068
 msgid "Could not perform checksum"
 msgstr "Ne mogu da izvršim kontrolu sume"
 
-#: ../yum/__init__.py:994
+#: ../yum/__init__.py:1071
 msgid "Package does not match checksum"
 msgstr "Paket nema odgovarajući kontrolnu sumu"
 
-#: ../yum/__init__.py:1036
+#: ../yum/__init__.py:1114
 #, python-format
 msgid "package fails checksum but caching is enabled for %s"
 msgstr ""
 "paket nema odgovarajuću vrednost kontrolne sume ili je za %s uključeno "
 "keširanje"
 
-#: ../yum/__init__.py:1042
+#: ../yum/__init__.py:1117 ../yum/__init__.py:1145
 #, python-format
 msgid "using local copy of %s"
 msgstr "koristim lokalni umnožak %s-a"
 
-#: ../yum/__init__.py:1061
+#: ../yum/__init__.py:1159
 #, python-format
-msgid "Insufficient space in download directory %s to download"
+msgid ""
+"Insufficient space in download directory %s\n"
+"    * free   %s\n"
+"    * needed %s"
 msgstr ""
-"Nedovoljna količina prostora u direktorijumu %s namenjenog za preuzimanje"
+"Nedovoljna količina prostora u direktorijumu %s za preuzimanje\n"
+"    * slobodno je %s\n"
+"    * potrebno je %s"
 
-#: ../yum/__init__.py:1094
+#: ../yum/__init__.py:1206
 msgid "Header is not complete."
 msgstr "Zaglavlje nije potpuno."
 
-#: ../yum/__init__.py:1134
+#: ../yum/__init__.py:1246
 #, python-format
 msgid ""
 "Header not in local cache and caching-only mode enabled. Cannot download %s"
@@ -1552,204 +1717,240 @@ msgstr ""
 "Zaglavlje nije u lokalnom kešu i samo način rada sa keširanjem je uključen. "
 "Ne mogu da preuzmem %s"
 
-#: ../yum/__init__.py:1189
+#: ../yum/__init__.py:1301
 #, python-format
 msgid "Public key for %s is not installed"
 msgstr "Javni ključ za %s nije instaliran"
 
-#: ../yum/__init__.py:1193
+#: ../yum/__init__.py:1305
 #, python-format
 msgid "Problem opening package %s"
 msgstr "Problem sa otvaranjem paketa %s"
 
-#: ../yum/__init__.py:1201
+#: ../yum/__init__.py:1313
 #, python-format
 msgid "Public key for %s is not trusted"
 msgstr "Javni ključ za %s nije poverljiv"
 
-#: ../yum/__init__.py:1205
+#: ../yum/__init__.py:1317
 #, python-format
 msgid "Package %s is not signed"
 msgstr "Paket %s nije potpisan"
 
-#: ../yum/__init__.py:1243
+#: ../yum/__init__.py:1355
 #, python-format
 msgid "Cannot remove %s"
 msgstr "Ne mogu da uklonim %s"
 
-#: ../yum/__init__.py:1247
+#: ../yum/__init__.py:1359
 #, python-format
 msgid "%s removed"
 msgstr "%s je uklonjen"
 
-#: ../yum/__init__.py:1283
+#: ../yum/__init__.py:1396
 #, python-format
 msgid "Cannot remove %s file %s"
 msgstr "Ne mogu da uklonim %s datoteku %s"
 
-#: ../yum/__init__.py:1287
+#: ../yum/__init__.py:1400
 #, python-format
 msgid "%s file %s removed"
 msgstr "%s datoteka %s je uklonjena"
 
-#: ../yum/__init__.py:1289
+#: ../yum/__init__.py:1402
 #, python-format
 msgid "%d %s files removed"
 msgstr "%d %s datoteke su uklonjene"
 
-#: ../yum/__init__.py:1329
+#: ../yum/__init__.py:1464
 #, python-format
 msgid "More than one identical match in sack for %s"
 msgstr "Postoji više od jednog identičnog slaganja u grupi za %s"
 
-#: ../yum/__init__.py:1335
+#: ../yum/__init__.py:1470
 #, python-format
 msgid "Nothing matches %s.%s %s:%s-%s from update"
 msgstr "Ništa se ne slaže sa %s.%s %s:%s-%s iz ažuriranja"
 
-#: ../yum/__init__.py:1543
+#: ../yum/__init__.py:1678
 msgid ""
 "searchPackages() will go away in a future version of "
 "Yum.                      Use searchGenerator() instead. \n"
 msgstr ""
-"searchPackages() neće biti prisutna u budućim verzijama Yum-"
-"a.                      Umesto nje koristite searchGenerator(). \n"
+"searchPackages() neće biti prisutna u budućim Yum "
+"verzijama.                      Umesto nje koristite searchGenerator(). \n"
 
-#: ../yum/__init__.py:1580
+#: ../yum/__init__.py:1716
 #, python-format
 msgid "Searching %d packages"
 msgstr "Pretražujem %d pakete"
 
-#: ../yum/__init__.py:1584
+#: ../yum/__init__.py:1720
 #, python-format
 msgid "searching package %s"
 msgstr "tražim paket %s"
 
-#: ../yum/__init__.py:1596
+#: ../yum/__init__.py:1732
 msgid "searching in file entries"
 msgstr "tražim u unosima datoteka"
 
-#: ../yum/__init__.py:1603
+#: ../yum/__init__.py:1739
 msgid "searching in provides entries"
 msgstr "tražim u unosima dostavljača"
 
-#: ../yum/__init__.py:1633
+#: ../yum/__init__.py:1772
 #, python-format
 msgid "Provides-match: %s"
 msgstr "Dostavlja-slaganje: %s"
 
-#: ../yum/__init__.py:1702 ../yum/__init__.py:1720 ../yum/__init__.py:1748
-#: ../yum/__init__.py:1753 ../yum/__init__.py:1808 ../yum/__init__.py:1812
+#: ../yum/__init__.py:1821
+msgid "No group data available for configured repositories"
+msgstr "Nema dostupnih podataka o grupama za podešene riznice"
+
+#: ../yum/__init__.py:1847 ../yum/__init__.py:1866 ../yum/__init__.py:1897
+#: ../yum/__init__.py:1903 ../yum/__init__.py:1976 ../yum/__init__.py:1980
 #, python-format
 msgid "No Group named %s exists"
 msgstr "Ne postoji grupa pod imenom %s"
 
-#: ../yum/__init__.py:1731 ../yum/__init__.py:1824
+#: ../yum/__init__.py:1878 ../yum/__init__.py:1993
 #, python-format
 msgid "package %s was not marked in group %s"
 msgstr "paket %s nije označen u grupi %s"
 
-#: ../yum/__init__.py:1770
+#: ../yum/__init__.py:1925
 #, python-format
 msgid "Adding package %s from group %s"
 msgstr "Dodajem paket %s iz grupe %s"
 
-#: ../yum/__init__.py:1774
+#: ../yum/__init__.py:1929
 #, python-format
 msgid "No package named %s available to be installed"
 msgstr "Nijedan paket pod imenom %s nije dostupan za instalaciju"
 
-#: ../yum/__init__.py:1849
-#, python-format
+#: ../yum/__init__.py:2018
+#, fuzzy, python-format
 msgid "Package tuple %s could not be found in packagesack"
 msgstr "Grupa paketa %s nije nađena u packagesack-u"
 
-#: ../yum/__init__.py:1917 ../yum/__init__.py:1960
+#: ../yum/__init__.py:2033
+msgid ""
+"getInstalledPackageObject() will go away, use self.rpmdb.searchPkgTuple().\n"
+msgstr ""
+"getInstalledPackageObject() će nestati, koristite self.rpmdb.searchPkgTuple"
+"().\n"
+
+#: ../yum/__init__.py:2085 ../yum/__init__.py:2128
 msgid "Invalid versioned dependency string, try quoting it."
 msgstr ""
 "Neispravna niska zavisnosti sa verzijom, pokušajte da je obeležite "
 "navodnicima."
 
-#: ../yum/__init__.py:1919 ../yum/__init__.py:1962
+#: ../yum/__init__.py:2087 ../yum/__init__.py:2130
 msgid "Invalid version flag"
 msgstr "Pogrešna oznaka verzije"
 
-#: ../yum/__init__.py:1934 ../yum/__init__.py:1938
+#: ../yum/__init__.py:2102 ../yum/__init__.py:2106
 #, python-format
 msgid "No Package found for %s"
 msgstr "Nema pronađenih paketa za %s"
 
-#: ../yum/__init__.py:2066
+#: ../yum/__init__.py:2305
 msgid "Package Object was not a package object instance"
 msgstr "Objekat paketa nije bio primerak objekta paketa"
 
-#: ../yum/__init__.py:2070
+#: ../yum/__init__.py:2309
 msgid "Nothing specified to install"
 msgstr "Nije određeno ništa za instalaciju"
 
 #. only one in there
-#: ../yum/__init__.py:2085
+#: ../yum/__init__.py:2327
 #, python-format
 msgid "Checking for virtual provide or file-provide for %s"
 msgstr "Proveravam virtuelnu dostavu ili dostavu datoteke za %s"
 
-#: ../yum/__init__.py:2091 ../yum/__init__.py:2380
+#: ../yum/__init__.py:2333 ../yum/__init__.py:2715
 #, python-format
 msgid "No Match for argument: %s"
 msgstr "Ne postoji slaganje za argument: %s"
 
-#. FIXME - this is where we could check to see if it already installed
-#. for returning better errors
-#: ../yum/__init__.py:2146
+#: ../yum/__init__.py:2399
+#, python-format
+msgid "Package %s installed and not available"
+msgstr "Paket %s je instaliran i nije dostupan"
+
+#: ../yum/__init__.py:2402
 msgid "No package(s) available to install"
 msgstr "Nema paketa dostupnih za instalaciju"
 
-#: ../yum/__init__.py:2158
+#: ../yum/__init__.py:2414
 #, python-format
 msgid "Package: %s  - already in transaction set"
 msgstr "Paket: %s  - već je u skupu transakcije"
 
-#: ../yum/__init__.py:2171
+#: ../yum/__init__.py:2427
 #, python-format
 msgid "Package %s already installed and latest version"
 msgstr "Već je instalirana najnovija verzija paketa %s"
 
-#: ../yum/__init__.py:2178
+#: ../yum/__init__.py:2434
 #, python-format
 msgid "Package matching %s already installed. Checking for update."
 msgstr ""
 "Paket koji se poklapa sa %s je već instaliran. Proveravam za noviju verziju."
 
+#: ../yum/__init__.py:2444
+#, python-format
+msgid "Package %s is obsoleted by %s, trying to install %s instead"
+msgstr "Paket %s je zamenjen paketom %s, pokušavam da namesto instaliram %s"
+
 #. update everything (the easy case)
-#: ../yum/__init__.py:2220
+#: ../yum/__init__.py:2514
 msgid "Updating Everything"
 msgstr "Ažuriram sve"
 
-#: ../yum/__init__.py:2304
+#: ../yum/__init__.py:2526 ../yum/__init__.py:2631 ../yum/__init__.py:2642
+#: ../yum/__init__.py:2664
+#, python-format
+msgid "Not Updating Package that is already obsoleted: %s.%s %s:%s-%s"
+msgstr "Ne ažuriram pakete koji su već prevaziđeni: %s.%s %s:%s-%s"
+
+#: ../yum/__init__.py:2622
 #, python-format
 msgid "Package is already obsoleted: %s.%s %s:%s-%s"
 msgstr "Paket je već prevaziđen: %s.%s %s:%s-%s"
 
-#: ../yum/__init__.py:2377
+#: ../yum/__init__.py:2645 ../yum/__init__.py:2667
+#, python-format
+msgid "Not Updating Package that is already updated: %s.%s %s:%s-%s"
+msgstr "Ne ažuriram pakete koji su već ažurirani: %s.%s %s:%s-%s"
+
+#: ../yum/__init__.py:2712
 #, python-format
 msgid "%s"
 msgstr "%s"
 
-#: ../yum/__init__.py:2392
+#: ../yum/__init__.py:2728
 msgid "No package matched to remove"
 msgstr "Nijedan paket nije određen za uklanjanje"
 
-#: ../yum/__init__.py:2426
+#: ../yum/__init__.py:2762
 #, python-format
 msgid "Cannot open file: %s. Skipping."
 msgstr "Ne mogu da otvorim datoteku: %s. Preskačem je."
 
-#: ../yum/__init__.py:2429
+#: ../yum/__init__.py:2765
 #, python-format
 msgid "Examining %s: %s"
 msgstr "Ispitujem %s: %s"
 
-#: ../yum/__init__.py:2436
+#: ../yum/__init__.py:2773
+#, python-format
+msgid "Cannot add package %s to transaction. Not a compatible architecture: %s"
+msgstr ""
+"Ne mogu da dodam paket %s u transakciju. Arhitektura nije usaglašena: %s"
+
+#: ../yum/__init__.py:2781
 #, python-format
 msgid ""
 "Package %s not installed, cannot update it. Run yum install to install it "
@@ -1758,136 +1959,157 @@ msgstr ""
 "Paket %s nije instaliran, ne mogu da ga ažuriram. Izvršite yum instalaciju "
 "da biste ga instalirali."
 
-#: ../yum/__init__.py:2468
+#: ../yum/__init__.py:2814
 #, python-format
 msgid "Excluding %s"
 msgstr "Izuzimam %s"
 
-#: ../yum/__init__.py:2473
+#: ../yum/__init__.py:2819
 #, python-format
 msgid "Marking %s to be installed"
 msgstr "Označavam %s za instalaciju"
 
-#: ../yum/__init__.py:2479
+#: ../yum/__init__.py:2825
 #, python-format
 msgid "Marking %s as an update to %s"
 msgstr "Označavam %s kao ažuriranje za %s"
 
-#: ../yum/__init__.py:2486
+#: ../yum/__init__.py:2832
 #, python-format
 msgid "%s: does not update installed package."
 msgstr "%s: ne ažurira instalirani paket."
 
-#: ../yum/__init__.py:2504
+#: ../yum/__init__.py:2850
 msgid "Problem in reinstall: no package matched to remove"
 msgstr ""
 "Problem pri ponovnoj instalaciji: nijedan paket nije određen za uklanjanje"
 
-#: ../yum/__init__.py:2515
+#: ../yum/__init__.py:2861
 #, python-format
 msgid "Package %s is allowed multiple installs, skipping"
 msgstr "Paketu %s su dozvoljene mnogostruke instalacije, preskačem ga"
 
-#: ../yum/__init__.py:2522
+#: ../yum/__init__.py:2868
 msgid "Problem in reinstall: no package matched to install"
 msgstr ""
 "Problem pri ponovnoj instalaciji: nijedan paket nije određen za instalaciju"
 
-#: ../yum/__init__.py:2570
+#: ../yum/__init__.py:2903
 #, python-format
 msgid "Retrieving GPG key from %s"
 msgstr "Dobavljam GPG ključ sa %s"
 
-#: ../yum/__init__.py:2576
+#: ../yum/__init__.py:2923
 msgid "GPG key retrieval failed: "
 msgstr "Dobavljanje GPG ključa nije uspelo: "
 
-#: ../yum/__init__.py:2589
-msgid "GPG key parsing failed: "
-msgstr "Raščlanjivanje GPG ključa nije uspelo: "
+#: ../yum/__init__.py:2934
+#, python-format
+msgid "GPG key parsing failed: key does not have value %s"
+msgstr "Raščlanjivanje GPG ključa nije uspelo: ključ nema vrednost %s"
 
-#: ../yum/__init__.py:2593
+#: ../yum/__init__.py:2966
 #, python-format
 msgid "GPG key at %s (0x%s) is already installed"
 msgstr "GPG ključ na %s (0x%s) je već instaliran"
 
 #. Try installing/updating GPG key
-#: ../yum/__init__.py:2598
+#: ../yum/__init__.py:2971 ../yum/__init__.py:3033
 #, python-format
 msgid "Importing GPG key 0x%s \"%s\" from %s"
 msgstr "Uvozim GPG ključ 0x%s „%s“ iz %s"
 
-#: ../yum/__init__.py:2610
+#: ../yum/__init__.py:2988
 msgid "Not installing key"
 msgstr "Ne instaliram ključ"
 
-#: ../yum/__init__.py:2616
+#: ../yum/__init__.py:2994
 #, python-format
 msgid "Key import failed (code %d)"
 msgstr "Nije uspeo uvoz ključa (kod %d)"
 
-#: ../yum/__init__.py:2619
+#: ../yum/__init__.py:2995 ../yum/__init__.py:3054
 msgid "Key imported successfully"
 msgstr "Ključ je uspešno uvezen"
 
-#: ../yum/__init__.py:2624
+#: ../yum/__init__.py:3000 ../yum/__init__.py:3059
 #, python-format
 msgid ""
 "The GPG keys listed for the \"%s\" repository are already installed but they "
 "are not correct for this package.\n"
 "Check that the correct key URLs are configured for this repository."
 msgstr ""
-"GPG ključevi izlistani za „%s“ riznicu su već istalirani ali nisu "
+"GPG ključevi izlistani za „%s“ riznicu su već instalirani ali nisu "
 "odgovarajući za ovaj paket.\n"
 "Proverite da li su podešeni odgovarajući URL-ovi ključeva za ovu riznicu."
 
-#: ../yum/__init__.py:2633
+#: ../yum/__init__.py:3009
 msgid "Import of key(s) didn't help, wrong key(s)?"
 msgstr "Uvoz ključa(ključeva) nije pomogao, pogrešan ključ(ključevi)?"
 
-#: ../yum/__init__.py:2707
+#: ../yum/__init__.py:3028
+#, python-format
+msgid "GPG key at %s (0x%s) is already imported"
+msgstr "GPG ključ na %s (0x%s) je već uvezen"
+
+#: ../yum/__init__.py:3048
+#, python-format
+msgid "Not installing key for repo %s"
+msgstr "Ne instaliram ključ za riznicu %s"
+
+#: ../yum/__init__.py:3053
+msgid "Key import failed"
+msgstr "Nije uspeo uvoz ključa"
+
+#: ../yum/__init__.py:3144
 msgid "Unable to find a suitable mirror."
 msgstr "Ne mogu da pronađem odgovarajući odraz."
 
-#: ../yum/__init__.py:2709
+#: ../yum/__init__.py:3146
 msgid "Errors were encountered while downloading packages."
 msgstr "Pojavile su se greške za vreme preuzimanja paketa."
 
-#: ../yum/__init__.py:2774
+#: ../yum/__init__.py:3210
 msgid "Test Transaction Errors: "
 msgstr "Greške pri proveri transakcije: "
 
 #. Mostly copied from YumOutput._outKeyValFill()
-#: ../yum/plugins.py:195
+#: ../yum/plugins.py:199
 msgid "Loaded plugins: "
 msgstr "Učitani dodaci: "
 
-#: ../yum/plugins.py:206
+#: ../yum/plugins.py:213 ../yum/plugins.py:219
 #, python-format
 msgid "No plugin match for: %s"
 msgstr "Ne postoji slaganje za dodatak: %s"
 
-#: ../yum/plugins.py:219
+#: ../yum/plugins.py:249
 #, python-format
 msgid "\"%s\" plugin is disabled"
 msgstr "„%s“ dodatak je isključen"
 
-#: ../yum/plugins.py:231
+#. Give full backtrace:
+#: ../yum/plugins.py:261
+#, python-format
+msgid "Plugin \"%s\" can't be imported"
+msgstr "Dodatak „%s“ ne može da bude uvezen"
+
+#: ../yum/plugins.py:268
 #, python-format
 msgid "Plugin \"%s\" doesn't specify required API version"
 msgstr "Dodatak „%s“ ne određuje verziju zahtevanog API-a"
 
-#: ../yum/plugins.py:235
+#: ../yum/plugins.py:273
 #, python-format
 msgid "Plugin \"%s\" requires API %s. Supported API is %s."
 msgstr "Dodatak „%s“ zahteva API %s. Podržani API je %s."
 
-#: ../yum/plugins.py:264
+#: ../yum/plugins.py:306
 #, python-format
 msgid "Loading \"%s\" plugin"
 msgstr "Učitavam „%s“ dodatak"
 
-#: ../yum/plugins.py:271
+#: ../yum/plugins.py:313
 #, python-format
 msgid ""
 "Two or more plugins with the name \"%s\" exist in the plugin search path"
@@ -1895,22 +2117,26 @@ msgstr ""
 "U putanji za pretraživanje dodataka postoje dva ili više dodataka pod imenom "
 "„%s“"
 
-#: ../yum/plugins.py:291
+#: ../yum/plugins.py:333
 #, python-format
 msgid "Configuration file %s not found"
 msgstr "Datoteka podešavanja %s nije pronađena"
 
 #. for
 #. Configuration files for the plugin not found
-#: ../yum/plugins.py:294
+#: ../yum/plugins.py:336
 #, python-format
 msgid "Unable to find configuration file for plugin %s"
 msgstr "Ne mogu da pronađem datoteku podešavanja za dodatak %s"
 
-#: ../yum/plugins.py:448
+#: ../yum/plugins.py:490
 msgid "registration of commands not supported"
 msgstr "registracija komandi nije podržana"
 
+#: ../yum/rpmtrans.py:78
+msgid "Repackaging"
+msgstr "Ponovno pakovanje"
+
 #: ../rpmUtils/oldUtils.py:26
 #, python-format
 msgid "Header cannot be opened or does not match %s, %s."
@@ -1929,7 +2155,7 @@ msgstr ""
 
 #: ../rpmUtils/oldUtils.py:174
 msgid "Got an empty Header, something has gone wrong"
-msgstr "Dobio sam prazno zaglavlje, nešto je pošlo naopako"
+msgstr "Primljeno je prazno zaglavlje, nešto je pošlo naopako"
 
 #: ../rpmUtils/oldUtils.py:244 ../rpmUtils/oldUtils.py:251
 #: ../rpmUtils/oldUtils.py:254 ../rpmUtils/oldUtils.py:257
@@ -1941,64 +2167,3 @@ msgstr "Oštećeno zaglavlje %s"
 #, python-format
 msgid "Error opening rpm %s - error %s"
 msgstr "Greška pri otvaranju rpm-a %s - greška %s"
-
-#~ msgid ""
-#~ "\n"
-#~ "\n"
-#~ "%s: %s option requires an argument"
-#~ msgstr ""
-#~ "\n"
-#~ "\n"
-#~ "%s: %s opcija zahteva argument"
-
-#~ msgid "show this help message and exit"
-#~ msgstr "prikaži ovu pomoćnu poruku i izađi"
-
-#~ msgid "verbose operation"
-#~ msgstr "opširna radnja"
-
-#~ msgid "Repo-id     : "
-#~ msgstr "IB riznice      : "
-
-#~ msgid "Repo-name   : "
-#~ msgstr "Ime riznice     : "
-
-#~ msgid "Repo-enabled: "
-#~ msgstr "Riznica uključena: "
-
-#~ msgid "Repo-size   : "
-#~ msgstr "Veličina riznice: "
-
-#~ msgid "Running compare_providers() for %s"
-#~ msgstr "Pokrećem compare_providers() za %s"
-
-#~ msgid ""
-#~ "archdist compared %s to %s on %s\n"
-#~ "  Winner: %s"
-#~ msgstr ""
-#~ "archdist uporedio %s sa %s na %s\n"
-#~ "  Pobednik: %s"
-
-#~ msgid "common sourcerpm %s and %s"
-#~ msgstr "zajednički izvorni rpm %s i %s"
-
-#~ msgid "common prefix of %s between %s and %s"
-#~ msgstr "zajednički prefiks %s između %s i %s"
-
-#~ msgid "Best Order: %s"
-#~ msgstr "Najbolji redosled: %s"
-
-#~ msgid ""
-#~ "Warning: scriptlet or other non-fatal errors occurred during transaction."
-#~ msgstr ""
-#~ "Upozorenje: došlo je do greške u skriptici ili neke druge nekritične "
-#~ "greške tokom transkacije."
-
-#~ msgid "Package %s is obsoleted by %s, trying to install %s instead"
-#~ msgstr "Paket %s je zamenjen paketom %s, pokušavam da namesto instaliram %s"
-
-#~ msgid "Not Updating Package that is already updated: %s.%s %s:%s-%s"
-#~ msgstr "Ne ažuriram pakete koji su već ažurirani: %s.%s %s:%s-%s"
-
-#~ msgid "Repackaging"
-#~ msgstr "Ponovno pakovanje"
diff --git a/po/zh_CN.po b/po/zh_CN.po
index 20dc426..bb32159 100644
--- a/po/zh_CN.po
+++ b/po/zh_CN.po
@@ -3,7 +3,7 @@ msgstr ""
 "Project-Id-Version: yum\n"
 "Report-Msgid-Bugs-To: \n"
 "POT-Creation-Date: 2008-03-25 11:29+0100\n"
-"PO-Revision-Date: 2008-07-24 19:43+0800\n"
+"PO-Revision-Date: 2008-11-01 23:43+0400\n"
 "Last-Translator: lijiansheng <lijiangsheng1@gmail.com>\n"
 "Language-Team: zh_CN <lijiangsheng1@gmail.com>\n"
 "MIME-Version: 1.0\n"
@@ -460,61 +460,61 @@ msgstr "尝试其他镜像."
 
 #: ../output.py:293
 #, python-format
-msgid "Name       : %s"
-msgstr "名称       : %s"
+msgid "Name       : %s%s%s"
+msgstr "名称          : %s%s%s"
 
 #: ../output.py:294
 #, python-format
 msgid "Arch       : %s"
-msgstr "架构 : %s"
+msgstr "架构          : %s"
 
 #: ../output.py:296
 #, python-format
 msgid "Epoch      : %s"
-msgstr "Epoch      : %s"
+msgstr "Epoch          : %s"
 
 #: ../output.py:297
 #, python-format
 msgid "Version    : %s"
-msgstr "版本    : %s"
+msgstr "版本          : %s"
 
 #: ../output.py:298
 #, python-format
 msgid "Release    : %s"
-msgstr "发行    : %s"
+msgstr "发行          : %s"
 
 #: ../output.py:299
 #, python-format
 msgid "Size       : %s"
-msgstr "大小    : %s"
+msgstr "大小          : %s"
 
 #: ../output.py:300
 #, python-format
 msgid "Repo       : %s"
-msgstr "Repo       : %s"
+msgstr "Repo          : %s"
 
 #: ../output.py:302
 #, python-format
 msgid "Committer  : %s"
-msgstr "Übermittler  : %s"
+msgstr "Übermittler   : %s"
 
 #: ../output.py:303
 msgid "Summary    : "
-msgstr "语法    : "
+msgstr "语法          : "
 
 #: ../output.py:305
 #, python-format
 msgid "URL        : %s"
-msgstr "统一资源定位符       : %s"
+msgstr "统一资源定位符: %s"
 
 #: ../output.py:306
 #, python-format
 msgid "License    : %s"
-msgstr "许可证    : %s"
+msgstr "许可证        : %s"
 
 #: ../output.py:307
 msgid "Description: "
-msgstr "升级:"
+msgstr "升级          : "
 
 #: ../output.py:351
 msgid "Is this ok [y/N]: "
diff --git a/rpmUtils/updates.py b/rpmUtils/updates.py
index f348ae9..16f733b 100644
--- a/rpmUtils/updates.py
+++ b/rpmUtils/updates.py
@@ -54,6 +54,7 @@ class Updates:
         self.updating_dict = {}
         #debug, ignore me
         self.debug = 0
+        self.obsoletes = {}
 
     def _delFromDict(self, dict_, keys, value):
         for key in keys:
diff --git a/shell.py b/shell.py
index 4c490e8..97bd963 100644
--- a/shell.py
+++ b/shell.py
@@ -114,7 +114,7 @@ class YumShell(cmd.Cmd):
         msg = """
     Shell specific arguments:
       config - set config options
-      repository (or repo) - enable/disable repositories
+      repository (or repo) - enable/disable/list repositories
       transaction (or ts) - list, reset or run the transaction set
       run - run the transaction set
       exit or quit - exit the shell
@@ -131,7 +131,7 @@ class YumShell(cmd.Cmd):
         elif arg in ['repo', 'repository']:
             msg = """
     %s arg [option]
-      list: lists repositories and their status
+      list: lists repositories and their status. option = [all] name/id glob
       enable: enable repositories. option = repository id
       disable: disable repositories. option = repository id
     """ % arg
@@ -337,11 +337,13 @@ class YumShell(cmd.Cmd):
                 if e.errno == 32:
                     self.logger.critical('\n\nExiting on Broken Pipe')
             else:
-                if returnval != 0:
-                    self.verbose_logger.info('Transaction did not run.')
+                if returnval not in [0,1]:
+                    self.verbose_logger.info('Transaction encountered a serious error.')
                 else:
+                    if returnval == 1:
+                        self.verbose_logger.info('There were non-fatal errors in the transaction')
                     self.verbose_logger.log(logginglevels.INFO_2,
                         'Finished Transaction')
-                    self.base.closeRpmDB()
+                self.base.closeRpmDB()
 
 
diff --git a/test/simpleobsoletestests.py b/test/simpleobsoletestests.py
index 05ebf05..035970c 100644
--- a/test/simpleobsoletestests.py
+++ b/test/simpleobsoletestests.py
@@ -217,6 +217,119 @@ class SimpleObsoletesTests(OperationsTests):
         self.assertResult((p.obsoletes_i386, p.obsoletes_x86_64, p.requires_obsoletes))
 
 
+    def testInstallObsoletenoarchTonoarch(self):
+        p = self.pkgs
+        res, msg = self.runOperation(['install', 'zsh-ng'], [p.installed_noarch], [p.obsoletes_noarch])
+        self.assert_(res=='ok', msg)
+        self.assertResult((p.obsoletes_noarch,))
+
+    def _MultiObsHelper(self):
+        ret = {'zsh'  : FakePackage('zsh', '1', '1', '0', 'noarch'),
+               'ksh'  : FakePackage('ksh', '1', '1', '0', 'noarch'),
+               'nash' : FakePackage('nash', '1', '1', '0', 'noarch')}
+        ret['pi'] = [ret['zsh'], ret['ksh'], ret['nash']]
+              
+        ret['fish'] = FakePackage('fish', '0.1', '1', '0', 'noarch')
+        ret['fish'].addObsoletes('zsh', None, (None, None, None))
+        ret['bigfish'] = FakePackage('bigfish', '0.2', '1', '0', 'noarch')
+        ret['bigfish'].addObsoletes('zsh', None, (None, None, None))
+        ret['bigfish'].addObsoletes('ksh', None, (None, None, None))
+        ret['shark'] = FakePackage('shark', '0.3', '1', '0', 'noarch')
+        ret['shark'].addObsoletes('zsh', None, (None, None, None))
+        ret['shark'].addObsoletes('ksh', None, (None, None, None))
+        ret['shark'].addObsoletes('nash', None, (None, None, None))
+
+        ret['po'] = [ret['fish'], ret['bigfish'], ret['shark']]
+        return ret
+
+    def testMultiObs1(self):
+        pkgs = self._MultiObsHelper()
+        res, msg = self.runOperation(['install', 'fish'],
+                                     pkgs['pi'], pkgs['po'])
+        self.assert_(res=='ok', msg)
+        self.assertResult((pkgs['ksh'],pkgs['nash'],pkgs['fish'],))
+
+    def testMultiObs2(self):
+        pkgs = self._MultiObsHelper()
+        res, msg = self.runOperation(['install', 'bigfish'],
+                                     pkgs['pi'], pkgs['po'])
+        self.assert_(res=='ok', msg)
+        self.assertResult((pkgs['nash'],pkgs['bigfish'],))
+
+    def testMultiObs3(self):
+        pkgs = self._MultiObsHelper()
+        res, msg = self.runOperation(['install', 'shark'],
+                                     pkgs['pi'], pkgs['po'])
+        self.assert_(res=='ok', msg)
+        self.assertResult((pkgs['shark'],))
+
+    def testMultiObs4(self):
+        # This tests update...
+        pkgs = self._MultiObsHelper()
+        oldshark = FakePackage('shark', '0.1', '1', '0', 'noarch')
+
+        res, msg = self.runOperation(['update', 'shark'],
+                                     pkgs['pi'] + [oldshark], pkgs['po'])
+        self.assert_(res=='ok', msg)
+        self.assertResult((pkgs['shark'],))
+
+    def testMultiObs5(self):
+        # This tests update of the to be obsoleted pkg...
+        pkgs = self._MultiObsHelper()
+        oldshark = FakePackage('shark', '0.1', '1', '0', 'noarch')
+
+        res, msg = self.runOperation(['update', 'nash'],
+                                     pkgs['pi'] + [oldshark], pkgs['po'])
+        self.assert_(res=='ok', msg)
+        self.assertResult((pkgs['shark'],))
+
+    # NOTE: Do we really want to remove the old kernel-xen? ... not 100% sure
+    def testMultiObsKern1(self):
+        # kernel + kernel-xen installed, and update kernel obsoletes kernel-xen
+        okern1    = FakePackage('kernel',     '0.1', '1', '0', 'noarch')
+        okern2    = FakePackage('kernel',     '0.2', '1', '0', 'noarch')
+        okernxen1 = FakePackage('kernel-xen', '0.1', '1', '0', 'noarch')
+        okernxen2 = FakePackage('kernel-xen', '0.2', '1', '0', 'noarch')
+        nkern     = FakePackage('kernel',     '0.8', '1', '0', 'noarch')
+        nkern.addObsoletes('kernel-xen', None, (None, None, None))
+
+        res, msg = self.runOperation(['update', 'kernel'],
+                                     [okern1, okernxen1,
+                                      okern2, okernxen2], [nkern])
+        self.assert_(res=='ok', msg)
+        self.assertResult((okern1,okern2,nkern,))
+
+    def testMultiObsKern2(self):
+        # kernel + kernel-xen installed, and update kernel obsoletes kernel-xen
+        okern1    = FakePackage('kernel',     '0.1', '1', '0', 'noarch')
+        okern2    = FakePackage('kernel',     '0.2', '1', '0', 'noarch')
+        okernxen1 = FakePackage('kernel-xen', '0.1', '1', '0', 'noarch')
+        okernxen2 = FakePackage('kernel-xen', '0.2', '1', '0', 'noarch')
+        nkern     = FakePackage('kernel',     '0.8', '1', '0', 'noarch')
+        nkern.addObsoletes('kernel-xen', None, (None, None, None))
+
+        res, msg = self.runOperation(['update', 'kernel-xen'],
+                                     [okern1, okernxen1,
+                                      okern2, okernxen2], [nkern])
+        self.assert_(res=='ok', msg)
+        self.assertResult((okern1,okern2,nkern,))
+
+    def testMultiObsKern3(self):
+        # kernel + kernel-xen installed, and update kernel obsoletes kernel-xen
+        okern1    = FakePackage('kernel',     '0.1', '1', '0', 'noarch')
+        okern2    = FakePackage('kernel',     '0.2', '1', '0', 'noarch')
+        okernxen1 = FakePackage('kernel-xen', '0.1', '1', '0', 'noarch')
+        okernxen2 = FakePackage('kernel-xen', '0.2', '1', '0', 'noarch')
+        nkern     = FakePackage('kernel',     '0.8', '1', '0', 'noarch')
+        nkern.addObsoletes('kernel-xen', None, (None, None, None))
+
+        res, msg = self.runOperation(['update'],
+                                     [okern1, okernxen1,
+                                      okern2, okernxen2], [nkern])
+        self.assert_(res=='ok', msg)
+        self.assertResult((okern1,okern2,nkern,))
+
+
 class GitMetapackageObsoletesTests(OperationsTests):
 
     @staticmethod
diff --git a/test/simpleupdatetests.py b/test/simpleupdatetests.py
index 4efe382..10ddd4f 100644
--- a/test/simpleupdatetests.py
+++ b/test/simpleupdatetests.py
@@ -92,9 +92,9 @@ class SimpleUpdateTests(OperationsTests):
         p = self.pkgs
         res, msg = self.runOperation(['update'], [p.installed_noarch], [p.update_i386, p.update_x86_64])
         self.assert_(res=='ok', msg)
-        if new_behavior:
+        if True or new_behavior: # We update from .noarch to just the .x86_64
             self.assertResult((p.update_x86_64,), (p.update_i386,)) # ?
-        else:
+        else: # Updates to both...
             self.assertResult((p.update_i386, p.update_x86_64))
     def testUpdatenoarchToMultilibForDependencyRev(self):
         p = self.pkgs
@@ -360,3 +360,122 @@ class SimpleUpdateTests(OperationsTests):
         res, msg = self.runOperation(['install', 'foo'], [foo11, bar11], [foo12, bar12, bar21])
         self.assert_(res=='ok', msg)
         self.assertResult((foo12, bar12))
+
+    def testUpdateBadMultiInstall1(self):
+        # This is a bug, but we shouldn't die too badly on it...
+        foo11 = FakePackage('foo', '1', '1', '0', 'i386')
+        foo12 = FakePackage('foo', '1', '2', '0', 'i386')
+        foo13 = FakePackage('foo', '1', '3', '0', 'i386')
+        foo20 = FakePackage('foo', '2', '0', '0', 'i386')
+
+        res, msg = self.runOperation(['install', 'foo'],
+                                     [foo11, foo12, foo13],
+                                     [foo20])
+        self.assert_(res=='ok', msg)
+        self.assertResult((foo20,))
+
+    def testUpdateBadMultiInstall2(self):
+        # This is a bug, but we shouldn't die too badly on it...
+        foo11 = FakePackage('foo', '1', '1', '0', 'i386')
+        foo12 = FakePackage('foo', '1', '2', '0', 'i386')
+        foo13 = FakePackage('foo', '1', '3', '0', 'i386')
+        foo20 = FakePackage('foo', '2', '0', '0', 'i386')
+
+        res, msg = self.runOperation(['update', 'foo'],
+                                     [foo11, foo12, foo13],
+                                     [foo20])
+        self.assert_(res=='ok', msg)
+        self.assertResult((foo20,))
+
+    def testUpdateBadMultiInstall3(self):
+        # This is a bug, but we shouldn't die too badly on it...
+        foo11 = FakePackage('foo', '1', '1', '0', 'i386')
+        foo12 = FakePackage('foo', '1', '2', '0', 'i386')
+        foo13 = FakePackage('foo', '1', '3', '0', 'i386')
+        foo20 = FakePackage('foo', '2', '0', '0', 'i386')
+
+        res, msg = self.runOperation(['update'],
+                                     [foo11, foo12, foo13],
+                                     [foo20])
+        self.assert_(res=='ok', msg)
+        self.assertResult((foo20,))
+
+    def testUpdateBadMultiInstall4(self):
+        # This is a bug, but we shouldn't die too badly on it...
+        foo11 = FakePackage('foo', '1', '1', '0', 'i386')
+        foo12 = FakePackage('foo', '1', '2', '0', 'i386')
+        foo13 = FakePackage('foo', '1', '3', '0', 'i386')
+        foo20 = FakePackage('foo', '2', '0', '0', 'i386')
+        bar11 = FakePackage('bar', '1', '1', '0', 'i386')
+        bar12 = FakePackage('bar', '1', '2', '0', 'i386')
+        bar12.addRequires('foo', 'EQ', ('0', '2', '0'))
+
+        res, msg = self.runOperation(['update', 'bar'],
+                                     [foo11, foo12, foo13, bar11],
+                                     [foo20, bar12])
+        self.assert_(res=='ok', msg)
+        self.assertResult((foo20,bar12))
+
+    def testUpdateBadMultiInstall5(self):
+        # This is a bug, but we shouldn't die too badly on it...
+        foo11 = FakePackage('foo', '1', '1', '0', 'i386')
+        foo12 = FakePackage('foo', '1', '2', '0', 'i386')
+        foo13 = FakePackage('foo', '1', '3', '0', 'i386')
+        foo20 = FakePackage('foo', '2', '0', '0', 'i386')
+        bar11 = FakePackage('bar', '1', '1', '0', 'i386')
+        bar12 = FakePackage('bar', '1', '2', '0', 'i386')
+        bar12.addRequires('foo', 'EQ', ('0', '2', '0'))
+
+        res, msg = self.runOperation(['update'],
+                                     [foo11, foo12, foo13, bar11],
+                                     [foo20, bar12])
+        self.assert_(res=='ok', msg)
+        self.assertResult((foo20,bar12))
+
+    def testUpdateBadMultiInstall6(self):
+        # This is a bug, but we shouldn't die too badly on it...
+        foo11 = FakePackage('foo', '1', '1', '0', 'i386')
+        foo12 = FakePackage('foo', '1', '2', '0', 'i386')
+        foo13 = FakePackage('foo', '1', '3', '0', 'i386')
+        foo20 = FakePackage('foo', '2', '0', '0', 'i386')
+        bar11 = FakePackage('bar', '1', '1', '0', 'i386')
+        bar12 = FakePackage('bar', '1', '2', '0', 'i386')
+        bar12.addObsoletes('foo', None, (None, None, None))
+
+        res, msg = self.runOperation(['update'],
+                                     [foo11, foo12, foo13, bar11],
+                                     [foo20, bar12])
+        self.assert_(res=='ok', msg)
+        self.assertResult((bar12,))
+
+    def testUpdateBadMultiInstall7(self):
+        # This is a bug, but we shouldn't die too badly on it...
+        foo11 = FakePackage('foo', '1', '1', '0', 'i386')
+        foo12 = FakePackage('foo', '1', '2', '0', 'i386')
+        foo13 = FakePackage('foo', '1', '3', '0', 'i386')
+        foo20 = FakePackage('foo', '2', '0', '0', 'i386')
+        bar11 = FakePackage('bar', '1', '1', '0', 'i386')
+        bar12 = FakePackage('bar', '1', '2', '0', 'i386')
+        bar12.addRequires('foo', 'EQ', ('0', '2', '0'))
+
+        res, msg = self.runOperation(['update', '*'],
+                                     [foo11, foo12, foo13, bar11],
+                                     [foo20, bar12])
+        self.assert_(res=='ok', msg)
+        self.assertResult((foo20,bar12))
+
+    def testUpdateBadMultiInstall8(self):
+        # This is a bug, but we shouldn't die too badly on it...
+        foo11 = FakePackage('foo', '1', '1', '0', 'i386')
+        foo12 = FakePackage('foo', '1', '2', '0', 'i386')
+        foo13 = FakePackage('foo', '1', '3', '0', 'i386')
+        foo20 = FakePackage('foo', '2', '0', '0', 'i386')
+        bar11 = FakePackage('bar', '1', '1', '0', 'i386')
+        bar12 = FakePackage('bar', '1', '2', '0', 'i386')
+        bar12.addObsoletes('foo', None, (None, None, None))
+
+        res, msg = self.runOperation(['update', '*'],
+                                     [foo11, foo12, foo13, bar11],
+                                     [foo20, bar12])
+        self.assert_(res=='ok', msg)
+        self.assertResult((bar12,))
diff --git a/test/skipbroken-tests.py b/test/skipbroken-tests.py
index 7af855e..d6f763c 100644
--- a/test/skipbroken-tests.py
+++ b/test/skipbroken-tests.py
@@ -378,35 +378,210 @@ class SkipBrokenTests(DepsolveTests):
         po2.addProvides('barlib', 'EQ', ('0', '2', '0'))
         po3 = self.repoPackage('zap', '2')
         po3.addRequires('barlib', 'EQ', ('0', '2', '0'))
+        #FIXME: Find out why this line is needed, it should be auto updated by the solver.
         self.tsInfo.addUpdate(po1, oldpo=ipo1) # why is this needed, it should work without ?
         self.tsInfo.addUpdate(po3, oldpo=ipo3)
         self.assertEquals('ok', *self.resolveCode(skip=True))
         self.assertResult([po1,po2,po3])               
 
-    def testInstReqOldVer2(self):
-    	""" 
-    	zap-2.0 updates zap-1.0, but zap-2.0 needs barlib-2.0 provided by
-    	bar-2.0, but the installed foo, needs barlib-1.0,  so it need to be updated to
-    	foo-2.0, that requires barlib-2.0
-    	But it only work if foo-1.0 -> foo-2.0 is added as an update, it is not 
-    	pulled in by it self.
-    	FIXME: This test case will fail for now 
-    	"""
-        ipo1 = self.instPackage('foo', '1')
-        ipo1.addRequires('barlib', 'EQ', ('0', '1', '0'))
-        ipo2 = self.instPackage('bar', '1')
-        ipo2.addProvides('barlib', 'EQ', ('0', '1', '0'))
-        ipo3 = self.instPackage('zap', '1')
-        po1 = self.repoPackage('foo', '2')
-        po1.addRequires('barlib', 'EQ', ('0', '2', '0'))
-        po2 = self.repoPackage('bar', '2')
-        po2.addProvides('barlib', 'EQ', ('0', '2', '0'))
-        po3 = self.repoPackage('zap', '2')
-        po3.addRequires('barlib', 'EQ', ('0', '2', '0'))
-        #self.tsInfo.addUpdate(po1, oldpo=ipo1) # why is this needed, it should work without ?
-        self.tsInfo.addUpdate(po3, oldpo=ipo3)
+
+    def testBumpedSoName1(self):
+        """ 
+        d2 need a lib from b1, so the update fails.
+        d2 and b2 get skipped, but the installed b1 needs a
+        lib from a1, but it has been updated to a2, so it is
+        no longer there. so a2 needs to be skipped to
+        """
+        a1 = self.instPackage('a', '1', arch='x86_64')
+        a1.addProvides("liba.so.1()(64bit)")
+        a2 = self.repoPackage('a', '2', arch='x86_64')
+        a2.addProvides("liba.so.2()(64bit)")
+        
+        b1 = self.instPackage('b', '1', arch='x86_64')
+        b1.addProvides("libb.so.1()(64bit)")
+        b1.addRequires("liba.so.1()(64bit)")
+        b2 = self.repoPackage('b', '2', arch='x86_64')
+        b2.addProvides("libb.so.2()(64bit)")
+        b2.addRequires("liba.so.2()(64bit)")
+        
+        c1 = self.instPackage('c', '1', arch='x86_64')
+        c1.addRequires("liba.so.1()(64bit)")
+        c2 = self.repoPackage('c', '2', arch='x86_64')
+        c2.addRequires("liba.so.2()(64bit)")
+
+        d1 = self.instPackage('d', '1', arch='x86_64')
+        d1.addRequires("libb.so.1()(64bit)")
+        d2 = self.repoPackage('d', '2', arch='x86_64')
+        d2.addRequires("libb.so.1()(64bit)")
+
+        e1 = self.instPackage('e', '1', arch='x86_64')
+        e2 = self.repoPackage('e', '2', arch='x86_64')
+
+        f1 = self.instPackage('f', '1', arch='x86_64')
+        f2 = self.repoPackage('f', '2', arch='x86_64')
+
+        self.tsInfo.addUpdate(a2, oldpo=a1)
+        self.tsInfo.addUpdate(b2, oldpo=b1)
+        self.tsInfo.addUpdate(c2, oldpo=c1)
+        self.tsInfo.addUpdate(d2, oldpo=d1)
+        self.tsInfo.addUpdate(e2, oldpo=e1)
+        self.tsInfo.addUpdate(f2, oldpo=f1)
         self.assertEquals('ok', *self.resolveCode(skip=True))
-        self.assertResult([po1,po2,po3])               
+        self.assertResult([a1,b1,c1,d1,e2,f2])
+
+    def testBumpedSoName2(self):
+        """ 
+        https://bugzilla.redhat.com/show_bug.cgi?id=468785
+        """
+        c1 = self.instPackage('cyrus-sasl-lib', '2.1.22',"18")
+        c1.addRequires("libdb-4.3.so")
+        
+        d1 = self.instPackage('compat-db', '4.6.21',"4")
+        d1.addProvides("libdb-4.3.so")
+        od1 = self.repoPackage('compat-db46', '4.6.21',"5")
+        od1.addProvides("libdb-4.6.so")
+        od1.addObsoletes("compat-db")
+        od2 = self.repoPackage('compat-db45', '4.6.21',"5")
+        od2.addProvides("libdb-4.5.so")
+        od2.addObsoletes("compat-db")
+        
+        r1 = self.instPackage('rpm', '4.6.0-0','0.rc1.3')
+        r1.addRequires("libdb-4.5.so")
+        r2 = self.instPackage('rpm-libs', '4.6.0-0','0.rc1.3')
+        r2.addRequires("libdb-4.5.so")
+        r3 = self.instPackage('rpm-build', '4.6.0-0','0.rc1.3')
+        r3.addRequires("libdb-4.5.so")
+        r4 = self.instPackage('rpm-python', '4.6.0-0','0.rc1.3')
+        r4.addRequires("libdb-4.5.so")
+
+        ur1 = self.repoPackage('rpm', '4.6.0-0','0.rc1.5')
+        ur1.addRequires("libdb-4.5.so")
+        ur1.addRequires("compat-db45")
+        ur2 = self.repoPackage('rpm-libs', '4.6.0-0','0.rc1.5')
+        ur2.addRequires("libdb-4.5.so")
+        ur2.addRequires("compat-db45")
+        ur3 = self.repoPackage('rpm-build', '4.6.0-0','0.rc1.5')
+        ur3.addRequires("libdb-4.5.so")
+        ur3.addRequires("compat-db45")
+        ur4 = self.repoPackage('rpm-python', '4.6.0-0','0.rc1.5')
+        ur4.addRequires("libdb-4.5.so")
+        ur4.addRequires("compat-db45")
+
+        self.tsInfo.addObsoleting(od2, oldpo=d1)
+        self.tsInfo.addObsoleted(d1, od2)
+        self.tsInfo.addObsoleting(od1, oldpo=d1)
+        self.tsInfo.addObsoleted(d1, od1)
+        self.tsInfo.addUpdate(ur1, oldpo=r1)
+        self.tsInfo.addUpdate(ur2, oldpo=r2)
+        self.tsInfo.addUpdate(ur3, oldpo=r3)
+        self.tsInfo.addUpdate(ur4, oldpo=r4)
+        
+        self.assertEquals('empty', *self.resolveCode(skip=True))
+        self.assertResult([c1,d1,r1,r2,r3,r4])
+
+    def testBumpedSoName3(self):
+        """ 
+        https://bugzilla.redhat.com/show_bug.cgi?id=468785
+        yum update compat-db46
+        """
+        c1 = self.instPackage('cyrus-sasl-lib', '2.1.22',"18")
+        c1.addRequires("libdb-4.3.so")
+        
+        d1 = self.instPackage('compat-db', '4.6.21',"4")
+        d1.addProvides("libdb-4.3.so")
+        od1 = self.repoPackage('compat-db46', '4.6.21',"5")
+        od1.addProvides("libdb-4.6.so")
+        od1.addObsoletes("compat-db")
+        od2 = self.repoPackage('compat-db45', '4.6.21',"5")
+        od2.addProvides("libdb-4.5.so")
+        od2.addObsoletes("compat-db")
+        
+        r1 = self.instPackage('rpm', '4.6.0-0','0.rc1.3')
+        r1.addRequires("libdb-4.5.so")
+        r2 = self.instPackage('rpm-libs', '4.6.0-0','0.rc1.3')
+        r2.addRequires("libdb-4.5.so")
+        r3 = self.instPackage('rpm-build', '4.6.0-0','0.rc1.3')
+        r3.addRequires("libdb-4.5.so")
+        r4 = self.instPackage('rpm-python', '4.6.0-0','0.rc1.3')
+        r4.addRequires("libdb-4.5.so")
+
+        ur1 = self.repoPackage('rpm', '4.6.0-0','0.rc1.5')
+        ur1.addRequires("libdb-4.5.so")
+        ur1.addRequires("compat-db45")
+        ur2 = self.repoPackage('rpm-libs', '4.6.0-0','0.rc1.5')
+        ur2.addRequires("libdb-4.5.so")
+        ur2.addRequires("compat-db45")
+        ur3 = self.repoPackage('rpm-build', '4.6.0-0','0.rc1.5')
+        ur3.addRequires("libdb-4.5.so")
+        ur3.addRequires("compat-db45")
+        ur4 = self.repoPackage('rpm-python', '4.6.0-0','0.rc1.5')
+        ur4.addRequires("libdb-4.5.so")
+        ur4.addRequires("compat-db45")
+
+        self.tsInfo.addObsoleting(od1, oldpo=d1)
+        self.tsInfo.addObsoleted(d1, od1)
+        self.tsInfo.addUpdate(ur1, oldpo=r1)
+        self.tsInfo.addUpdate(ur2, oldpo=r2)
+        self.tsInfo.addUpdate(ur3, oldpo=r3)
+        self.tsInfo.addUpdate(ur4, oldpo=r4)
+        
+        self.assertEquals('err', *self.resolveCode(skip=False))
+        
+    def testBumpedSoNameMultiArch(self):
+        """ 
+        if compat-db45.x86_64 get skipped, then compat-db45.i386 should not 
+        get pulled in instead
+        """
+        c1 = self.instPackage('cyrus-sasl-lib', '2.1.22',"18", arch='x86_64')
+        c1.addRequires("libdb-4.3.so")
+        
+        d1 = self.instPackage('compat-db', '4.6.21',"4", arch='x86_64')
+        d1.addProvides("libdb-4.3.so")
+        od1 = self.repoPackage('compat-db46', '4.6.21',"5", arch='x86_64')
+        od1.addProvides("libdb-4.6.so")
+        od1.addObsoletes("compat-db")
+        od2 = self.repoPackage('compat-db45', '4.6.21',"5", arch='x86_64')
+        od2.addProvides("libdb-4.5.so")
+        od2.addObsoletes("compat-db")
+        od3 = self.repoPackage('compat-db45', '4.6.21',"5", arch='i386')
+        od3.addProvides("libdb-4.5.so")
+        od3.addObsoletes("compat-db")
+        
+        r1 = self.instPackage('rpm', '4.6.0-0','0.rc1.3', arch='x86_64')
+        r1.addRequires("libdb-4.5.so")
+        r2 = self.instPackage('rpm-libs', '4.6.0-0','0.rc1.3', arch='x86_64')
+        r2.addRequires("libdb-4.5.so")
+        r3 = self.instPackage('rpm-build', '4.6.0-0','0.rc1.3', arch='x86_64')
+        r3.addRequires("libdb-4.5.so")
+        r4 = self.instPackage('rpm-python', '4.6.0-0','0.rc1.3', arch='x86_64')
+        r4.addRequires("libdb-4.5.so")
+
+        ur1 = self.repoPackage('rpm', '4.6.0-0','0.rc1.5', arch='x86_64')
+        ur1.addRequires("libdb-4.5.so")
+        ur1.addRequires("compat-db45")
+        ur2 = self.repoPackage('rpm-libs', '4.6.0-0','0.rc1.5', arch='x86_64')
+        ur2.addRequires("libdb-4.5.so")
+        ur2.addRequires("compat-db45")
+        ur3 = self.repoPackage('rpm-build', '4.6.0-0','0.rc1.5', arch='x86_64')
+        ur3.addRequires("libdb-4.5.so")
+        ur3.addRequires("compat-db45")
+        ur4 = self.repoPackage('rpm-python', '4.6.0-0','0.rc1.5', arch='x86_64')
+        ur4.addRequires("libdb-4.5.so")
+        ur4.addRequires("compat-db45")
+
+
+        self.tsInfo.addObsoleting(od2, oldpo=d1)
+        self.tsInfo.addObsoleted(d1, od2)
+        self.tsInfo.addObsoleting(od1, oldpo=d1)
+        self.tsInfo.addObsoleted(d1, od1)
+        self.tsInfo.addUpdate(ur1, oldpo=r1)
+        self.tsInfo.addUpdate(ur2, oldpo=r2)
+        self.tsInfo.addUpdate(ur3, oldpo=r3)
+        self.tsInfo.addUpdate(ur4, oldpo=r4)
+
+        self.assertEquals('empty', *self.resolveCode(skip=True))
+        self.assertResult([c1,d1,r1,r2,r3,r4])
+        
     
     def resolveCode(self,skip = False):
         solver = YumBase()
@@ -415,6 +590,7 @@ class SkipBrokenTests(DepsolveTests):
         solver.tsInfo = solver._tsInfo = self.tsInfo
         solver.rpmdb = self.rpmdb
         solver.pkgSack = self.xsack
+        solver.dsCallback = DepSolveProgressCallBack()
         
         for po in self.rpmdb:
             po.repoid = po.repo.id = "installed"
@@ -438,4 +614,3 @@ def setup_logging():
     verbose.propagate = False
     verbose.addHandler(console_stdout)
     verbose.setLevel(2)
-
diff --git a/test/testbase.py b/test/testbase.py
index ccab847..d0ff1c3 100644
--- a/test/testbase.py
+++ b/test/testbase.py
@@ -3,6 +3,8 @@ import sys
 import unittest
 
 import settestpath
+import logging
+import yum.logginglevels as logginglevels
 
 new_behavior = "NEW_BEHAVIOR" in os.environ.keys()
 
@@ -19,6 +21,10 @@ from rpmUtils import arch
 ### Helper classes ##########################################
 #############################################################
 
+# Dummy translation wrapper
+def _(msg):
+    return msg
+
 class FakeConf(object):
 
     def __init__(self):
@@ -35,6 +41,7 @@ class FakeConf(object):
         self.disable_excludes = []
         self.multilib_policy = 'best'
         self.persistdir = '/should-not-exist-bad-test!'
+        self.showdupesfromrepos = False
 
 class FakeRepo(object):
 
@@ -81,6 +88,65 @@ class _Container(object):
     pass
 
 
+class DepSolveProgressCallBack:
+    """provides text output callback functions for Dependency Solver callback"""
+    
+    def __init__(self):
+        """requires yum-cli log and errorlog functions as arguments"""
+        self.verbose_logger = logging.getLogger("yum.verbose.cli")
+        self.loops = 0
+    
+    def pkgAdded(self, pkgtup, mode):
+        modedict = { 'i': _('installed'),
+                     'u': _('updated'),
+                     'o': _('obsoleted'),
+                     'e': _('erased')}
+        (n, a, e, v, r) = pkgtup
+        modeterm = modedict[mode]
+        self.verbose_logger.log(logginglevels.INFO_2,
+            _('---> Package %s.%s %s:%s-%s set to be %s'), n, a, e, v, r,
+            modeterm)
+        
+    def start(self):
+        self.loops += 1
+        
+    def tscheck(self):
+        self.verbose_logger.log(logginglevels.INFO_2, _('--> Running transaction check'))
+        
+    def restartLoop(self):
+        self.loops += 1
+        self.verbose_logger.log(logginglevels.INFO_2,
+            _('--> Restarting Dependency Resolution with new changes.'))
+        self.verbose_logger.debug('---> Loop Number: %d', self.loops)
+    
+    def end(self):
+        self.verbose_logger.log(logginglevels.INFO_2,
+            _('--> Finished Dependency Resolution'))
+
+    
+    def procReq(self, name, formatted_req):
+        self.verbose_logger.log(logginglevels.INFO_2,
+            _('--> Processing Dependency: %s for package: %s'), formatted_req,
+            name)
+        
+    
+    def unresolved(self, msg):
+        self.verbose_logger.log(logginglevels.INFO_2, _('--> Unresolved Dependency: %s'),
+            msg)
+
+    
+    def procConflict(self, name, confname):
+        self.verbose_logger.log(logginglevels.INFO_2,
+            _('--> Processing Conflict: %s conflicts %s'), name, confname)
+
+    def transactionPopulation(self):
+        self.verbose_logger.log(logginglevels.INFO_2, _('--> Populating transaction set '
+            'with selected packages. Please wait.'))
+    
+    def downloadHeader(self, name):
+        self.verbose_logger.log(logginglevels.INFO_2, _('---> Downloading header for %s '
+            'to pack into transaction set.'), name)
+      
 #######################################################################
 ### Abstract super class for test cases ###############################
 #######################################################################
@@ -145,6 +211,35 @@ class _DepsolveTestsBase(unittest.TestCase):
             errors.append("\n")
             self.fail("".join(errors))
 
+class FakeRpmDb(packageSack.PackageSack):
+    '''
+    We use a PackagePack for a Fake rpmdb insted of the normal
+    RPMDBPackageSack, getProvides works a little different on
+    unversioned requirements so we have to overload an add some
+    extra checkcode.
+    '''
+    def __init__(self):
+        packageSack.PackageSack.__init__(self)
+
+    def getProvides(self, name, flags=None, version=(None, None, None)):
+        """return dict { packages -> list of matching provides }"""
+        self._checkIndexes(failure='build')
+        result = { }
+        # convert flags & version for unversioned reqirements
+        if not version:
+            version=(None, None, None)
+        if flags == '0':
+            flags=None
+        for po in self.provides.get(name, []):
+            hits = po.matchingPrcos('provides', (name, flags, version))
+            if hits:
+                result[po] = hits
+        if name[0] == '/':
+            hit = (name, None, (None, None, None))
+            for po in self.searchFiles(name):
+                result.setdefault(po, []).append(hit)
+        return result
+            
 
 #######################################################################
 ### Derive Tests from these classes or unittest.TestCase ##############
@@ -173,12 +268,17 @@ class DepsolveTests(_DepsolveTestsBase):
         """ Called at the start of each test. """
         _DepsolveTestsBase.setUp(self)
         self.tsInfo = transactioninfo.TransactionData()
-        self.rpmdb  = packageSack.PackageSack()
+        self.tsInfo.debug = 1
+        self.rpmdb  = FakeRpmDb()
         self.xsack  = packageSack.PackageSack()
         self.repo   = FakeRepo("installed")
         # XXX this side-affect is hacky:
         self.tsInfo.setDatabases(self.rpmdb, self.xsack)
 
+    def resetTsInfo(self):
+        self.tsInfo = transactioninfo.TransactionData()
+        
+
     def resolveCode(self):
         solver = YumBase()
         solver.conf = FakeConf()
diff --git a/utils.py b/utils.py
index d92f533..cea9110 100644
--- a/utils.py
+++ b/utils.py
@@ -61,12 +61,20 @@ class YumUtilBase(YumBaseCli):
         root = self._parser.getRoot(opts)
         # Read up configuration options and initialise plugins
         try:
+            disabled_plugins = None
+            if hasattr(opts, "disableplugins"):
+                disabled_plugins = self._parser._splitArg(opts.disableplugins)
+            enabled_plugins  = None
+            if hasattr(opts, "enableplugins"):
+                enabled_plugins = self._parser._splitArg(opts.enableplugins)
             self._getConfig(opts.conffile, root, 
                     init_plugins=not opts.noplugins,
                     plugin_types= pluginsTypes,
                     optparser=self._parser,
                     debuglevel=opts.debuglevel,
-                    errorlevel=opts.errorlevel)
+                    errorlevel=opts.errorlevel,
+                    disabled_plugins=disabled_plugins,
+                    enabled_plugins=enabled_plugins)
         except yum.Errors.ConfigError, e:
             self.logger.critical(_('Config Error: %s'), e)
             sys.exit(1)
diff --git a/yum/Errors.py b/yum/Errors.py
index 4bccd86..be6bda2 100644
--- a/yum/Errors.py
+++ b/yum/Errors.py
@@ -18,6 +18,8 @@
 Exceptions and Errors thrown by yum.
 """
 
+from i18n import to_unicode
+
 class YumBaseError(Exception):
     """
     Base Yum Error. All other Errors thrown by yum should inherit from
@@ -29,6 +31,9 @@ class YumBaseError(Exception):
     def __str__(self):
         return "%s" %(self.value,)
 
+    def __unicode__(self):
+        return '%s' % to_unicode(self.value)
+
 class YumGPGCheckError(YumBaseError):
     pass
 
diff --git a/yum/__init__.py b/yum/__init__.py
index 04f2aac..27eb5c2 100644
--- a/yum/__init__.py
+++ b/yum/__init__.py
@@ -665,7 +665,10 @@ class YumBase(depsolve.Depsolve):
         # Try another depsolve
         if self.conf.skip_broken and rescode==1:
             self.skipped_packages = []    # reset the public list of skipped packages.
+            sb_st = time.time()
             rescode, restring = self._skipPackagesWithProblems(rescode, restring)
+            self._printTransaction()        
+            self.verbose_logger.debug('Skip-Broken time: %0.3f' % (time.time() - sb_st))
 
         self.verbose_logger.debug('Depsolve time: %0.3f' % (time.time() - ds_st))
         return rescode, restring
@@ -681,21 +684,28 @@ class YumBase(depsolve.Depsolve):
             _remove_from_sack(po)
 
         def _remove_from_sack(po):
-            if not po.repoid == 'installed' and po not in removed_from_sack:
-                self.verbose_logger.debug('SKIPBROKEN: removing %s from pkgSack & updates' % str(po))
-                self.pkgSack.delPackage(po)
-                self.up.delPackage(po.pkgtup)
-                removed_from_sack.add(po)
+            # get all compatible arch packages from pkgSack
+            # we need to remove them to so a i386 paqckages is not 
+            # dragged in when a x86_64 is skipped.
+            pkgs = self._getPackagesToRemoveAllArch(po)
+            for pkg in pkgs:
+                if not po.repoid == 'installed' and pkg not in removed_from_sack:             
+                    self.verbose_logger.debug('SKIPBROKEN: removing %s from pkgSack & updates' % str(po))
+                    self.pkgSack.delPackage(pkg)
+                    self.up.delPackage(pkg.pkgtup)
+                    removed_from_sack.add(pkg)
 
         # Keep removing packages & Depsolve until all errors is gone
         # or the transaction is empty
         count = 0
         skipped_po = set()
         removed_from_sack = set()
-        orig_restring = restring    # Keep the old error messages
-        while len(self.po_with_problems) > 0 and rescode == 1:
+        orig_restring = restring    # Keep the old error messages 
+        looping = 0 
+        while (len(self.po_with_problems) > 0 and rescode == 1):
             count += 1
             self.verbose_logger.debug(_("Skip-broken round %i"), count)
+            self._printTransaction()        
             depTree = self._buildDepTree()
             startTs = set(self.tsInfo)
             toRemove = set()
@@ -712,14 +722,39 @@ class YumBase(depsolve.Depsolve):
                     # make sure we get the compat arch packages skip from pkgSack and up too.
                     if skip not in removed_from_sack and skip.repoid == 'installed':
                         _remove_from_sack(skip)
-            if not toRemove: # Nothing was removed, so we still got a problem
-                break # Bail out
+            # Nothing was removed, so we still got a problem
+             # the first time we get here we reset the resolved members of
+             # tsInfo and takes a new run all members in the current transaction
+            if not toRemove: 
+                looping += 1
+                if looping > 2:
+                    break # Bail out
+                else:
+                    self.verbose_logger.debug('SKIPBROKEN: resetting already resovled packages (no packages to skip)' )
+                    self.tsInfo.resetResolved(hard=True)
             rescode, restring = self.resolveDeps()
             endTs = set(self.tsInfo)
              # Check if tsInfo has changes since we started to skip packages
              # if there is no changes then we got a loop.
+             # the first time we get here we reset the resolved members of
+             # tsInfo and takes a new run all members in the current transaction
             if startTs-endTs == set():
-                break    # bail out
+                looping += 1
+                if looping > 2:
+                    break # Bail out
+                else:
+                    self.verbose_logger.debug('SKIPBROKEN: resetting already resovled packages (transaction not changed)' )
+                    self.tsInfo.resetResolved(hard=True)
+                    
+            # if we are alel clear, then we have to check that the whole current transaction 
+            # can complete the depsolve without error, because the packages skipped
+            # can have broken something that passed the tests earliere.
+            # FIXME: We need do this in a better way.
+            if rescode != 1:
+                self.verbose_logger.debug('SKIPBROKEN: sanity check the current transaction' )
+                self.tsInfo.resetResolved(hard=True)
+                self._checkMissingObsoleted() # This is totally insane, but needed :(
+                rescode, restring = self.resolveDeps()
         if rescode != 1:
             self.verbose_logger.debug(_("Skip-broken took %i rounds "), count)
             self.verbose_logger.info(_('\nPackages skipped because of dependency problems:'))
@@ -733,9 +768,46 @@ class YumBase(depsolve.Depsolve):
             # If we cant solve the problems the show the original error messages.
             self.verbose_logger.info("Skip-broken could not solve problems")
             return 1, orig_restring
-        
         return rescode, restring
 
+    def _checkMissingObsoleted(self):
+        """ 
+        If multiple packages is obsoleting the same package
+        then the TS_OBSOLETED can get removed from the transaction
+        so we must make sure that they, exist and else create them
+        """
+        for txmbr in self.tsInfo:
+            for pkg in txmbr.obsoletes:
+                if not self.tsInfo.exists(pkg.pkgtup):
+                    obs = self.tsInfo.addObsoleted(pkg,txmbr.po)
+                    self.verbose_logger.debug('SKIPBROKEN: Added missing obsoleted %s (%s)' % (pkg,txmbr.po) )
+            for pkg in txmbr.obsoleted_by:
+                # check if the obsoleting txmbr is in the transaction
+                # else remove the obsoleted txmbr
+                # it clean out some really wierd cases
+                if not self.tsInfo.exists(pkg.pkgtup):
+                    self.verbose_logger.debug('SKIPBROKEN: Remove extra obsoleted %s (%s)' % (txmbr.po,pkg) )
+                    self.tsInfo.remove(txmbr.po.pkgtup)
+
+    def _getPackagesToRemoveAllArch(self,po):
+        ''' get all compatible arch packages in pkgSack'''
+        pkgs = []
+        if rpmUtils.arch.isMultiLibArch():
+            archs = rpmUtils.arch.getArchList() 
+            n,a,e,v,r = po.pkgtup
+            # skip for all compat archs
+            for a in archs:
+                pkgtup = (n,a,e,v,r)
+                matched = self.pkgSack.searchNevra(n,e,v,r,a) 
+                pkgs.extend(matched)
+        else:
+            pkgs.append(po)
+        return pkgs   
+        
+                
+                
+        
+
     def _skipFromTransaction(self,po):
         skipped =  []
         if rpmUtils.arch.isMultiLibArch():
@@ -778,6 +850,26 @@ class YumBase(depsolve.Depsolve):
             for p in l:
                 print "\t", p
 
+    def _printTransaction(self):
+        #transaction set states
+        state = { TS_UPDATE     : "update",
+                  TS_INSTALL    : "install",
+                  TS_TRUEINSTALL: "trueinstall",
+                  TS_ERASE      : "erase",
+                  TS_OBSOLETED  : "obsoleted",
+                  TS_OBSOLETING : "obsoleting",
+                  TS_AVAILABLE  : "available",
+                  TS_UPDATED    : "updated"}
+
+        self.verbose_logger.log(logginglevels.DEBUG_2,"TSINFO: Current Transaction : %i member(s) " % len(self.tsInfo))
+        for txmbr in self.tsInfo:
+            msg = "  %-11s : %s " % (state[txmbr.output_state],txmbr.po)
+            self.verbose_logger.log(logginglevels.DEBUG_2, msg)
+            for po,rel in txmbr.relatedto:
+                msg = "                   %s : %s" % (rel,po)
+                self.verbose_logger.log(logginglevels.DEBUG_2, msg)
+                
+                                    
     def _getPackagesToRemove(self,po,deptree,toRemove):
         '''
         get the (related) pos to remove.
@@ -1371,7 +1463,7 @@ class YumBase(depsolve.Depsolve):
         return self._cleanFiles(exts, 'cachedir', 'sqlite')
 
     def cleanMetadata(self):
-        exts = ['xml.gz', 'xml', 'cachecookie', 'mirrorlist.txt']
+        exts = ['xml.gz', 'xml', 'cachecookie', 'mirrorlist.txt', 'asc']
         # Metalink is also here, but is a *.xml file
         return self._cleanFiles(exts, 'cachedir', 'metadata') 
 
@@ -1412,6 +1504,8 @@ class YumBase(depsolve.Depsolve):
         
         installed = []
         available = []
+        reinstall_available = []
+        old_available = []
         updates = []
         obsoletes = []
         obsoletesTuples = []
@@ -1437,7 +1531,6 @@ class YumBase(depsolve.Depsolve):
                 avail = self.pkgSack.returnPackages(patterns=patterns,
                                                     ignore_case=ic)
             else:
-                del dinst # Using ndinst instead
                 try:
                   avail = self.pkgSack.returnNewestByNameArch(patterns=patterns,
                                                               ignore_case=ic)
@@ -1446,12 +1539,18 @@ class YumBase(depsolve.Depsolve):
             
             for pkg in avail:
                 if showdups:
-                    if pkg.pkgtup not in dinst:
+                    if pkg.pkgtup in dinst:
+                        reinstall_available.append(pkg)
+                    else:
                         available.append(pkg)
                 else:
                     key = (pkg.name, pkg.arch)
-                    if key not in ndinst or pkg.verGT(ndinst[key]):
+                    if pkg.pkgtup in dinst:
+                        reinstall_available.append(pkg)
+                    elif key not in ndinst or pkg.verGT(ndinst[key]):
                         available.append(pkg)
+                    else:
+                        old_available.append(pkg)
 
         # produce the updates list of tuples
         elif pkgnarrow == 'updates':
@@ -1489,12 +1588,20 @@ class YumBase(depsolve.Depsolve):
             
             for pkg in avail:
                 if showdups:
-                    if not self.rpmdb.contains(po=pkg):
+                    if self.rpmdb.contains(po=pkg):
+                        reinstall_available.append(pkg)
+                    else:
                         available.append(pkg)
                 else:
                     ipkgs = self.rpmdb.searchNevra(pkg.name, arch=pkg.arch)
-                    if not ipkgs or pkg.verGT(sorted(ipkgs, reverse=True)[0]):
+                    if ipkgs:
+                        latest = sorted(ipkgs, reverse=True)[0]
+                    if not ipkgs or pkg.verGT(latest):
                         available.append(pkg)
+                    elif pkg.verEQ(latest):
+                        reinstall_available.append(pkg)
+                    else:
+                        old_available.append(pkg)
 
         # not in a repo but installed
         elif pkgnarrow == 'extras':
@@ -1550,6 +1657,8 @@ class YumBase(depsolve.Depsolve):
         
         ygh.installed = installed
         ygh.available = available
+        ygh.reinstall_available = reinstall_available
+        ygh.old_available = old_available
         ygh.updates = updates
         ygh.obsoletes = obsoletes
         ygh.obsoletesTuples = obsoletesTuples
@@ -1808,7 +1917,7 @@ class YumBase(depsolve.Depsolve):
             
         return matches
 
-    def doGroupLists(self, uservisible=0):
+    def doGroupLists(self, uservisible=0, patterns=None, ignore_case=True):
         """returns two lists of groups, installed groups and available groups
            optional 'uservisible' bool to tell it whether or not to return
            only groups marked as uservisible"""
@@ -1820,7 +1929,12 @@ class YumBase(depsolve.Depsolve):
         if self.comps.compscount == 0:
             raise Errors.GroupsError, _('No group data available for configured repositories')
         
-        for grp in self.comps.groups:
+        if patterns is None:
+            grps = self.comps.groups
+        else:
+            grps = self.comps.return_groups(",".join(patterns),
+                                            case_sensitive=not ignore_case)
+        for grp in grps:
             if grp.installed:
                 if uservisible:
                     if grp.user_visible:
@@ -2288,6 +2402,15 @@ class YumBase(depsolve.Depsolve):
             tx_return.extend(txmbrs)
         return tx_return
 
+    def _find_obsoletees(self, po):
+        """ Return the pkgs. that are obsoleted by the po we pass in. """
+        for (obstup, inst_tup) in self.up.getObsoletesTuples(name=po.name, 
+                                                             arch=po.arch):
+            if po.pkgtup == obstup:
+                installed_pkg =  self.rpmdb.searchPkgTuple(inst_tup)[0]
+                yield installed_pkg
+
+
     def install(self, po=None, **kwargs):
         """try to mark for install the item specified. Uses provided package 
            object, if available. If not it uses the kwargs and gets the best
@@ -2421,6 +2544,16 @@ class YumBase(depsolve.Depsolve):
                 tx_return.extend(txmbrs)
                 continue
             
+            #  Make sure we're not installing a package which is obsoleted by
+            # something else in the repo. Unless there is a obsoletion loop,
+            # at which point ignore everything.
+            obsoleting_pkg = self._test_loop(po, self._pkg2obspkg)
+            if obsoleting_pkg is not None:
+                self.verbose_logger.warning(_('Package %s is obsoleted by %s, trying to install %s instead'),
+                    po.name, obsoleting_pkg.name, obsoleting_pkg)               
+                self.install(po=obsoleting_pkg)
+                continue
+            
             # make sure it's not already installed
             if self.rpmdb.contains(po=po):
                 if not self.tsInfo.getMembersWithState(po.pkgtup, TS_REMOVE_STATES):
@@ -2436,18 +2569,25 @@ class YumBase(depsolve.Depsolve):
                     tx_return.extend(txmbrs)
                     continue
 
-            #  Make sure we're not installing a package which is obsoleted by
-            # something else in the repo. Unless there is a obsoletion loop,
-            # at which point ignore everything.
-            obsoleting_pkg = self._test_loop(po, self._pkg2obspkg)
-            if obsoleting_pkg is not None:
-                self.verbose_logger.warning(_('Package %s is obsoleted by %s, trying to install %s instead'),
-                    po.name, obsoleting_pkg.name, obsoleting_pkg)               
-                self.install(po=obsoleting_pkg)
-                continue
                 
-            txmbr = self.tsInfo.addInstall(po)
-            tx_return.append(txmbr)
+            # at this point we are going to mark the pkg to be installed, make sure
+            # it's not an older package that is allowed in due to multiple installs
+            # or some other oddity. If it is - then modify the problem filter to cope
+            
+            for ipkg in self.rpmdb.searchNevra(name=po.name, arch=po.arch):
+                if ipkg.EVR > po.EVR:
+                    self.tsInfo.probFilterFlags.append(rpm.RPMPROB_FILTER_OLDPACKAGE)
+                    break
+            
+            # it doesn't obsolete anything. If it does, mark that in the tsInfo, too
+            if po.pkgtup in self.up.getObsoletesList(name=po.name, arch=po.arch):
+                for obsoletee in self._find_obsoletees(po):
+                    txmbr = self.tsInfo.addObsoleting(po, obsoletee)
+                    self.tsInfo.addObsoleted(obsoletee, po)
+                    tx_return.append(txmbr)
+            else:
+                txmbr = self.tsInfo.addInstall(po)
+                tx_return.append(txmbr)
         
         return tx_return
 
@@ -2503,15 +2643,15 @@ class YumBase(depsolve.Depsolve):
         # if no po do kwargs
         # uninstalled pkgs called for update get returned with errors in a list, maybe?
 
-        updates = self.up.getUpdatesTuples()
-        if self.conf.obsoletes:
-            obsoletes = self.up.getObsoletesTuples(newest=1)
-        else:
-            obsoletes = []
-
         tx_return = []
         if not po and not kwargs: # update everything (the easy case)
             self.verbose_logger.log(logginglevels.DEBUG_2, _('Updating Everything'))
+            updates = self.up.getUpdatesTuples()
+            if self.conf.obsoletes:
+                obsoletes = self.up.getObsoletesTuples(newest=1)
+            else:
+                obsoletes = []
+
             for (obsoleting, installed) in obsoletes:
                 obsoleting_pkg = self.getPackageObject(obsoleting)
                 installed_pkg =  self.rpmdb.searchPkgTuple(installed)[0]
@@ -2526,12 +2666,7 @@ class YumBase(depsolve.Depsolve):
                     self.verbose_logger.log(logginglevels.DEBUG_2, _('Not Updating Package that is already obsoleted: %s.%s %s:%s-%s'), 
                         old)
                 else:
-                    updating_pkg = self.getPackageObject(new)
-                    updated_pkg = self.rpmdb.searchPkgTuple(old)[0]
-                    txmbr = self.tsInfo.addUpdate(updating_pkg, updated_pkg)
-                    if requiringPo:
-                        txmbr.setAsDep(requiringPo)
-                    tx_return.append(txmbr)
+                    tx_return.extend(self.update(po=self.getPackageObject(new)))
             
             return tx_return
 
@@ -2557,8 +2692,23 @@ class YumBase(depsolve.Depsolve):
             instpkgs.extend(e)
             instpkgs.extend(m)
 
-            # if we can't find an installed package then look at available pkgs
-            if not instpkgs:
+            if u:
+                depmatches = []
+                arg = u[0]
+                try:
+                    depmatches = self.returnInstalledPackagesByDep(arg)
+                except yum.Errors.YumBaseError, e:
+                    self.logger.critical(_('%s') % e)
+                
+                if not depmatches:
+                    self.logger.critical(_('No Match for argument: %s') % arg)
+                else:
+                    instpkgs.extend(depmatches)
+
+            #  Always look for available packages, it doesn't seem to do any
+            # harm (apart from some time). And it fixes weird edge cases where
+            # "update a" (which requires a new b) is different from "update b"
+            if True or not instpkgs:
                 (e, m, u) = self.pkgSack.matchPackageNames([kwargs['pattern']])
                 availpkgs.extend(e)
                 availpkgs.extend(m)
@@ -2605,12 +2755,7 @@ class YumBase(depsolve.Depsolve):
             for installed_pkg in instpkgs:
                 for obsoleting in self.up.obsoleted_dict.get(installed_pkg.pkgtup, []):
                     obsoleting_pkg = self.getPackageObject(obsoleting)
-                    # FIXME check for what might be in there here
-                    txmbr = self.tsInfo.addObsoleting(obsoleting_pkg, installed_pkg)
-                    self.tsInfo.addObsoleted(installed_pkg, obsoleting_pkg)
-                    if requiringPo:
-                        txmbr.setAsDep(requiringPo)
-                    tx_return.append(txmbr)
+                    tx_return.extend(self.install(po=obsoleting_pkg))
             for available_pkg in availpkgs:
                 for obsoleted in self.up.obsoleting_dict.get(available_pkg.pkgtup, []):
                     obsoleted_pkg = self.getInstalledPackageObject(obsoleted)
@@ -2626,12 +2771,23 @@ class YumBase(depsolve.Depsolve):
 
         for installed_pkg in instpkgs:
             for updating in self.up.updatesdict.get(installed_pkg.pkgtup, []):
-                updating_pkg = self.getPackageObject(updating)
+                po = self.getPackageObject(updating)
                 if self.tsInfo.isObsoleted(installed_pkg.pkgtup):
                     self.verbose_logger.log(logginglevels.DEBUG_2, _('Not Updating Package that is already obsoleted: %s.%s %s:%s-%s'), 
                                             installed_pkg.pkgtup)                                               
+                # at this point we are going to mark the pkg to be installed, make sure
+                # it doesn't obsolete anything. If it does, mark that in the tsInfo, too
+                elif po.pkgtup in self.up.getObsoletesList(name=po.name,
+                                                           arch=po.arch):
+                    for obsoletee in self._find_obsoletees(po):
+                        txmbr = self.tsInfo.addUpdate(po, installed_pkg)
+                        if requiringPo:
+                            txmbr.setAsDep(requiringPo)
+                        self.tsInfo.addObsoleting(po, obsoletee)
+                        self.tsInfo.addObsoleted(obsoletee, po)
+                        tx_return.append(txmbr)
                 else:
-                    txmbr = self.tsInfo.addUpdate(updating_pkg, installed_pkg)
+                    txmbr = self.tsInfo.addUpdate(po, installed_pkg)
                     if requiringPo:
                         txmbr.setAsDep(requiringPo)
                     tx_return.append(txmbr)
@@ -3184,7 +3340,8 @@ class YumBase(depsolve.Depsolve):
             if msgs:
                 retmsgs = [_('ERROR with rpm_check_debug vs depsolve:')]
                 retmsgs.extend(msgs) 
-                retmsgs.append(_('Please report this error in bugzilla'))
+                retmsgs.append(_('Please report this error at %s') 
+                                             % self.conf.bugtracker_url)
                 raise Errors.YumRPMCheckError,retmsgs
         
         tsConf = {}
diff --git a/yum/comps.py b/yum/comps.py
index ee9f187..6820c64 100755
--- a/yum/comps.py
+++ b/yum/comps.py
@@ -247,8 +247,8 @@ class Group(CompsObj):
    <id>%s</id>
    <default>%s</default>
    <uservisible>%s</uservisible>
-   <display_order>%s</display_order>\n""" % (self.groupid, str(self.default), 
-                                  str(self.user_visible), self.display_order)
+   <display_order>%s</display_order>\n""" % (self.groupid, str(self.default).lower(), 
+                                  str(self.user_visible).lower(), self.display_order)
    
         if self.langonly:
             msg += """   <langonly>%s</langonly>""" % self.langonly
@@ -354,7 +354,7 @@ class Category(CompsObj):
                 self.translated_description[lang] = obj.translated_description[lang]
 
     def xml(self):
-        """write out an xml stanza for the group object"""
+        """write out an xml stanza for the category object"""
         msg ="""        
   <category>
    <id>%s</id>
diff --git a/yum/config.py b/yum/config.py
index 03123a9..2219605 100644
--- a/yum/config.py
+++ b/yum/config.py
@@ -637,7 +637,7 @@ class YumConf(StartupConf):
     # FIXME: rename gpgcheck to pkgs_gpgcheck
     gpgcheck = BoolOption(__pkgs_gpgcheck_default__)
     repo_gpgcheck = BoolOption(__repo_gpgcheck_default__)
-    obsoletes = BoolOption(False)
+    obsoletes = BoolOption(True)
     showdupesfromrepos = BoolOption(False)
     enabled = BoolOption(True)
     enablegroups = BoolOption(True)
@@ -667,7 +667,23 @@ class YumConf(StartupConf):
                  # all == install any/all arches you can
                  # best == use the 'best  arch' for the system
                  
-
+    bugtracker_url = Option('http://yum.baseurl.org/report')
+
+    color = SelectionOption('auto', ('auto', 'never', 'always'),
+                            mapper={'on' : 'always', 'yes' : 'always',
+                                    '1' : 'always', 'true' : 'always',
+                                    'off' : 'never', 'no' : 'never',
+                                    '0' : 'never', 'false' : 'never',
+                                    'tty' : 'auto', 'if-tty' : 'auto'})
+    color_list_installed_older = Option('bold')
+    color_list_installed_newer = Option('bold,yellow')
+    color_list_installed_extra = Option('bold,red')
+
+    color_list_available_upgrade = Option('bold,blue')
+    color_list_available_downgrade = Option('dim,cyan')
+    color_list_available_install = Option('normal')
+
+    color_search_match = Option('bold')
     
     _reposlist = []
 
diff --git a/yum/i18n.py b/yum/i18n.py
old mode 100644
new mode 100755
index 86f3ce2..af70881
--- a/yum/i18n.py
+++ b/yum/i18n.py
@@ -13,11 +13,398 @@
 # along with this program; if not, write to the Free Software
 # Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
 
+
 def dummy_wrapper(str):
     '''
     Dummy Translation wrapper, just returning the same string.
     '''
-    return str
+    return to_unicode(str)
+
+# This is ported from ustr_utf8_* which I got from:
+#     http://www.cl.cam.ac.uk/~mgk25/ucs/wcwidth.c
+#  I've tried to leave it close to the original C (same names etc.) so that
+# it is easy to read/compare both versions...
+
+# ----------------------------- BEG utf8 -----------------------------
+# This is an implementation of wcwidth() and wcswidth() (defined in
+# IEEE Std 1002.1-2001) for Unicode.
+#
+# http://www.opengroup.org/onlinepubs/007904975/functions/wcwidth.html
+# http://www.opengroup.org/onlinepubs/007904975/functions/wcswidth.html
+#
+# In fixed-width output devices, Latin characters all occupy a single
+# "cell" position of equal width, whereas ideographic CJK characters
+# occupy two such cells. Interoperability between terminal-line
+# applications and (teletype-style) character terminals using the
+# UTF-8 encoding requires agreement on which character should advance
+# the cursor by how many cell positions. No established formal
+# standards exist at present on which Unicode character shall occupy
+# how many cell positions on character terminals. These routines are
+# a first attempt of defining such behavior based on simple rules
+# applied to data provided by the Unicode Consortium.
+#
+# [...]
+#
+# Markus Kuhn -- 2007-05-26 (Unicode 5.0)
+#
+# Permission to use, copy, modify, and distribute this software
+# for any purpose and without fee is hereby granted. The author
+# disclaims all warranties with regard to this software.
+#
+# Latest version: http://www.cl.cam.ac.uk/~mgk25/ucs/wcwidth.c
+
+def __utf8_bisearch(ucs, table):
+    """ auxiliary function for binary search in interval table. """
+
+    min = 0
+    max = len(table) - 1
+    if ucs < table[min][0] or ucs > table[max][1]:
+        return False
+
+    while max >= min:
+        mid = (min + max) / 2;
+        if ucs > table[mid][1]:
+            min = mid + 1;
+        elif ucs < table[mid][0]:
+            max = mid - 1;
+        else:
+          return True
+
+    return False
+
+def __utf8_ucp_width(ucs):
+    """ Get the textual width of a ucs character. """
+    # sorted list of non-overlapping intervals of non-spacing characters
+    # generated by "uniset +cat=Me +cat=Mn +cat=Cf -00AD +1160-11FF +200B c"
+    combining = [
+    ( 0x0300, 0x036F ), ( 0x0483, 0x0486 ), ( 0x0488, 0x0489 ),
+    ( 0x0591, 0x05BD ), ( 0x05BF, 0x05BF ), ( 0x05C1, 0x05C2 ),
+    ( 0x05C4, 0x05C5 ), ( 0x05C7, 0x05C7 ), ( 0x0600, 0x0603 ),
+    ( 0x0610, 0x0615 ), ( 0x064B, 0x065E ), ( 0x0670, 0x0670 ),
+    ( 0x06D6, 0x06E4 ), ( 0x06E7, 0x06E8 ), ( 0x06EA, 0x06ED ),
+    ( 0x070F, 0x070F ), ( 0x0711, 0x0711 ), ( 0x0730, 0x074A ),
+    ( 0x07A6, 0x07B0 ), ( 0x07EB, 0x07F3 ), ( 0x0901, 0x0902 ),
+    ( 0x093C, 0x093C ), ( 0x0941, 0x0948 ), ( 0x094D, 0x094D ),
+    ( 0x0951, 0x0954 ), ( 0x0962, 0x0963 ), ( 0x0981, 0x0981 ),
+    ( 0x09BC, 0x09BC ), ( 0x09C1, 0x09C4 ), ( 0x09CD, 0x09CD ),
+    ( 0x09E2, 0x09E3 ), ( 0x0A01, 0x0A02 ), ( 0x0A3C, 0x0A3C ),
+    ( 0x0A41, 0x0A42 ), ( 0x0A47, 0x0A48 ), ( 0x0A4B, 0x0A4D ),
+    ( 0x0A70, 0x0A71 ), ( 0x0A81, 0x0A82 ), ( 0x0ABC, 0x0ABC ),
+    ( 0x0AC1, 0x0AC5 ), ( 0x0AC7, 0x0AC8 ), ( 0x0ACD, 0x0ACD ),
+    ( 0x0AE2, 0x0AE3 ), ( 0x0B01, 0x0B01 ), ( 0x0B3C, 0x0B3C ),
+    ( 0x0B3F, 0x0B3F ), ( 0x0B41, 0x0B43 ), ( 0x0B4D, 0x0B4D ),
+    ( 0x0B56, 0x0B56 ), ( 0x0B82, 0x0B82 ), ( 0x0BC0, 0x0BC0 ),
+    ( 0x0BCD, 0x0BCD ), ( 0x0C3E, 0x0C40 ), ( 0x0C46, 0x0C48 ),
+    ( 0x0C4A, 0x0C4D ), ( 0x0C55, 0x0C56 ), ( 0x0CBC, 0x0CBC ),
+    ( 0x0CBF, 0x0CBF ), ( 0x0CC6, 0x0CC6 ), ( 0x0CCC, 0x0CCD ),
+    ( 0x0CE2, 0x0CE3 ), ( 0x0D41, 0x0D43 ), ( 0x0D4D, 0x0D4D ),
+    ( 0x0DCA, 0x0DCA ), ( 0x0DD2, 0x0DD4 ), ( 0x0DD6, 0x0DD6 ),
+    ( 0x0E31, 0x0E31 ), ( 0x0E34, 0x0E3A ), ( 0x0E47, 0x0E4E ),
+    ( 0x0EB1, 0x0EB1 ), ( 0x0EB4, 0x0EB9 ), ( 0x0EBB, 0x0EBC ),
+    ( 0x0EC8, 0x0ECD ), ( 0x0F18, 0x0F19 ), ( 0x0F35, 0x0F35 ),
+    ( 0x0F37, 0x0F37 ), ( 0x0F39, 0x0F39 ), ( 0x0F71, 0x0F7E ),
+    ( 0x0F80, 0x0F84 ), ( 0x0F86, 0x0F87 ), ( 0x0F90, 0x0F97 ),
+    ( 0x0F99, 0x0FBC ), ( 0x0FC6, 0x0FC6 ), ( 0x102D, 0x1030 ),
+    ( 0x1032, 0x1032 ), ( 0x1036, 0x1037 ), ( 0x1039, 0x1039 ),
+    ( 0x1058, 0x1059 ), ( 0x1160, 0x11FF ), ( 0x135F, 0x135F ),
+    ( 0x1712, 0x1714 ), ( 0x1732, 0x1734 ), ( 0x1752, 0x1753 ),
+    ( 0x1772, 0x1773 ), ( 0x17B4, 0x17B5 ), ( 0x17B7, 0x17BD ),
+    ( 0x17C6, 0x17C6 ), ( 0x17C9, 0x17D3 ), ( 0x17DD, 0x17DD ),
+    ( 0x180B, 0x180D ), ( 0x18A9, 0x18A9 ), ( 0x1920, 0x1922 ),
+    ( 0x1927, 0x1928 ), ( 0x1932, 0x1932 ), ( 0x1939, 0x193B ),
+    ( 0x1A17, 0x1A18 ), ( 0x1B00, 0x1B03 ), ( 0x1B34, 0x1B34 ),
+    ( 0x1B36, 0x1B3A ), ( 0x1B3C, 0x1B3C ), ( 0x1B42, 0x1B42 ),
+    ( 0x1B6B, 0x1B73 ), ( 0x1DC0, 0x1DCA ), ( 0x1DFE, 0x1DFF ),
+    ( 0x200B, 0x200F ), ( 0x202A, 0x202E ), ( 0x2060, 0x2063 ),
+    ( 0x206A, 0x206F ), ( 0x20D0, 0x20EF ), ( 0x302A, 0x302F ),
+    ( 0x3099, 0x309A ), ( 0xA806, 0xA806 ), ( 0xA80B, 0xA80B ),
+    ( 0xA825, 0xA826 ), ( 0xFB1E, 0xFB1E ), ( 0xFE00, 0xFE0F ),
+    ( 0xFE20, 0xFE23 ), ( 0xFEFF, 0xFEFF ), ( 0xFFF9, 0xFFFB ),
+    ( 0x10A01, 0x10A03 ), ( 0x10A05, 0x10A06 ), ( 0x10A0C, 0x10A0F ),
+    ( 0x10A38, 0x10A3A ), ( 0x10A3F, 0x10A3F ), ( 0x1D167, 0x1D169 ),
+    ( 0x1D173, 0x1D182 ), ( 0x1D185, 0x1D18B ), ( 0x1D1AA, 0x1D1AD ),
+    ( 0x1D242, 0x1D244 ), ( 0xE0001, 0xE0001 ), ( 0xE0020, 0xE007F ),
+    ( 0xE0100, 0xE01EF )]
+
+    # test for 8-bit control characters
+    if ucs == 0:
+        return 0
+
+    if ucs < 32 or (ucs >= 0x7f and ucs < 0xa0):
+        return (-1)
+
+    if __utf8_bisearch(ucs, combining):
+        return 0
+
+    # if we arrive here, ucs is not a combining or C0/C1 control character
+
+    return (1 + 
+      (ucs >= 0x1100 and
+       (ucs <= 0x115f or                     # Hangul Jamo init. consonants
+        ucs == 0x2329 or ucs == 0x232a or
+        (ucs >= 0x2e80 and ucs <= 0xa4cf and
+         ucs != 0x303f) or                   # CJK ... Yi
+        (ucs >= 0xac00 and ucs <= 0xd7a3) or # Hangul Syllables
+        (ucs >= 0xf900 and ucs <= 0xfaff) or # CJK Compatibility Ideographs
+        (ucs >= 0xfe10 and ucs <= 0xfe19) or # Vertical forms
+        (ucs >= 0xfe30 and ucs <= 0xfe6f) or # CJK Compatibility Forms
+        (ucs >= 0xff00 and ucs <= 0xff60) or # Fullwidth Forms
+        (ucs >= 0xffe0 and ucs <= 0xffe6) or
+        (ucs >= 0x20000 and ucs <= 0x2fffd) or
+        (ucs >= 0x30000 and ucs <= 0x3fffd))))
+
+
+def __utf8_iter_ints(msg):
+    for byte in to_utf8(msg):
+        yield ord(byte)
+def __utf8_iter_ucs(msg):
+    uiter = __utf8_iter_ints(msg)
+    for byte0 in uiter:
+        if byte0 < 0x80:             # 0xxxxxxx
+            yield (byte0, 1)
+        elif (byte0 & 0xe0) == 0xc0: # 110XXXXx 10xxxxxx
+            byte1 = uiter.next()
+            if (((byte1 & 0xc0) != 0x80) or
+                ((byte0 & 0xfe) == 0xc0)):                          # overlong?
+                yield (None, 2)
+                return
+            yield ((((byte0 & 0x1f) << 6) | (byte1 & 0x3f)), 2)
+        elif (byte0 & 0xf0) == 0xe0: # 1110XXXX 10Xxxxxx 10xxxxxx
+            byte1 = uiter.next()
+            byte2 = uiter.next()
+            if (((byte1 & 0xc0) != 0x80) or ((byte2 & 0xc0) != 0x80) or
+                ((byte0 == 0xe0) and ((byte1 & 0xe0) == 0x80)) or   # overlong?
+                ((byte0 == 0xed) and ((byte1 & 0xe0) == 0xa0)) or   # surrogate?
+                ((byte0 == 0xef) and  (byte1 == 0xbf) and
+                 ((byte2 & 0xfe) == 0xbe))): # U+FFFE or U+FFFF?
+                yield (None, 3)
+                return
+            yield ((((byte0 & 0x0f) << 12) | ((byte1 & 0x3f) << 6) |
+                   (byte2 & 0x3f)), 3)
+        elif (byte0 & 0xf8) == 0xf0: # 11110XXX 10XXxxxx 10xxxxxx 10xxxxxx
+            byte1 = uiter.next()
+            byte2 = uiter.next()
+            byte3 = uiter.next()
+            if (((byte1 & 0xc0) != 0x80) or
+                ((byte2 & 0xc0) != 0x80) or
+                ((byte3 & 0xc0) != 0x80) or
+                ((byte0 == 0xf0) and ((byte1 & 0xf0) == 0x80)) or # overlong?
+                ((byte0 == 0xf4) and (byte1 > 0x8f)) or           # > U+10FFFF?
+                (byte0 > 0xf4)):                                  # > U+10FFFF?
+                yield (None, 4)
+                return
+
+            yield ((((byte0 & 0x07) << 18) | ((byte1 & 0x3f) << 12) |
+                    ((byte2 & 0x3f) <<  6) |  (byte3 & 0x3f)), 4)
+        else:
+            yield (None, 1)
+            return
+
+def utf8_width(msg):
+    """ Get the textual width of a utf8 string. """
+    ret = 0
+    for (ucs, bytes) in __utf8_iter_ucs(msg):
+        if ucs is None:
+            ret += bytes # Ugly ... should not feed bad utf8
+        else:
+            ret += __utf8_ucp_width(ucs)
+    return ret
+
+def utf8_width_chop(msg, chop=None):
+    """ Return the textual width of a utf8 string, chopping it to a specified
+        value. This is what you want to use instead of %.*s, as it does the
+        "right" thing with regard to utf-8 sequences. Eg.
+        "%.*s" % (10, msg)   <= becomes => "%s" % (utf8_width_chop(msg, 10)) """
+
+    if chop is None or utf8_width(msg) <= chop:
+        return utf8_width(msg), msg
+
+    ret = 0
+    passed_unicode = isinstance(msg, unicode)
+    msg_bytes = 0
+    msg = to_utf8(msg)
+    for (ucs, bytes) in __utf8_iter_ucs(msg):
+        if ucs is None:
+            width = bytes # Ugly ... should not feed bad utf8
+        else:
+            width = __utf8_ucp_width(ucs)
+
+        if chop is not None and (ret + width) > chop:
+            msg = msg[:msg_bytes]
+            break
+        ret += width
+        msg_bytes += bytes
+
+    if passed_unicode:
+        msg = to_unicode(msg)
+
+    return ret, msg
+
+def utf8_width_fill(msg, fill, chop=None, left=True, prefix='', suffix=''):
+    """ Expand a utf8 msg to a specified "width" or chop to same.
+        Expansion can be left or right. This is what you want to use instead of
+        %*.*s, as it does the "right" thing with regard to utf-8 sequences.
+        Eg.
+        "%-*.*s" % (10, 20, msg)
+           <= becomes =>
+        "%s" % (utf8_width_fill(msg, 10, 20)).
+
+        "%20.10s" % (msg)
+           <= becomes =>
+        "%s" % (utf8_width_fill(msg, 20, 10, left=False)).
+        """
+    passed_msg = msg
+    width, msg = utf8_width_chop(msg, chop)
+
+    if width < fill:
+        extra = " " * (fill - width)
+        if left:
+            msg = ''.join([prefix, msg, suffix, extra])
+        else:
+            msg = ''.join([extra, prefix, msg, suffix])
+
+    if isinstance(passed_msg, unicode):
+        return to_unicode(msg)
+
+    return msg
+
+def utf8_valid(msg):
+    """ Return True/False is the text is valid utf8. """
+    for (ucs, bytes) in __utf8_iter_ucs(msg):
+        if ucs is None:
+            return False
+    return True
+
+def utf8_text_wrap(text, width=70, initial_indent='', subsequent_indent=''):
+    """ Works like we want textwrap.wrap() to work, uses utf-8 data and
+        doesn't screw up lists/blocks/etc. """
+    # Tested with:
+    # yum info robodoc gpicview php-pear-Net-Socket wmctrl ustr moreutils
+    #          mediawiki-HNP ocspd insight yum mousepad
+    # ...at 120, 80 and 40 chars.
+    # Also, notable among lots of others, searching for "\n  ":
+    #   exim-clamav, jpackage-utils, tcldom, synaptics, "quake3",
+    #   perl-Class-Container, ez-ipupdate, perl-Net-XMPP, "kipi-plugins",
+    #   perl-Apache-DBI, netcdf, python-configobj, "translate-toolkit", alpine,
+    #   "udunits", "conntrack-tools"
+    #
+    # Note that, we "fail" on:
+    #   alsa-plugins-jack, setools*, dblatex, uisp, "perl-Getopt-GUI-Long",
+    #   suitesparse, "synce-serial", writer2latex, xenwatch, ltsp-utils
+
+    passed_unicode = isinstance(text, unicode)
+
+    def _indent_at_beg(line):
+        count = 0
+        byte = 'X'
+        for byte in line:
+            if byte != ' ':
+                break
+            count += 1
+        list_chr = utf8_width_chop(line[count:], 1)[1]
+        if list_chr in ("-", "*", ".", "o",
+                        "\xe2\x80\xa2", "\xe2\x80\xa3", "\xe2\x88\x98"):
+            nxt = _indent_at_beg(line[count+len(list_chr):])
+            nxt = nxt[1] or nxt[0]
+            if nxt:
+                return count, count + 1 + nxt
+        return count, 0
+
+    initial_indent = to_utf8(initial_indent)
+    subsequent_indent = to_utf8(subsequent_indent)
+
+    text = to_utf8(text).rstrip('\n')
+    lines = to_utf8(text).replace('\t', ' ' * 8).split('\n')
+
+    ret = []
+    indent = initial_indent
+    wrap_last = False
+    csab = 0
+    cspc_indent = 0
+    for line in lines:
+        line = line.rstrip(' ')
+        (lsab, lspc_indent) = (csab, cspc_indent)
+        (csab, cspc_indent) = _indent_at_beg(line)
+        force_nl = False # We want to stop wrapping under "certain" conditions:
+        if wrap_last and cspc_indent:      # if line starts a list or
+            force_nl = True
+        if wrap_last and csab == len(line):# is empty line
+            force_nl = True
+        if wrap_last and not lspc_indent:  # if line doesn't continue a list and
+            if csab >= 4 and csab != lsab: # is "block indented"
+                force_nl = True
+        if force_nl:
+            ret.append(indent.rstrip(' '))
+            indent = subsequent_indent
+            wrap_last = False
+        if csab == len(line): # empty line, remove spaces to make it easier.
+            line = ''
+        if wrap_last:
+            line = line.lstrip(' ')
+            cspc_indent = lspc_indent
+
+        if (utf8_width(indent) + utf8_width(line)) <= width:
+            wrap_last = False
+            ret.append(indent + line)
+            indent = subsequent_indent
+            continue
+
+        wrap_last = True
+        words = line.split(' ')
+        line = indent
+        spcs = cspc_indent
+        if not spcs and csab >= 4:
+            spcs = csab
+        while words:
+            word = words.pop(0)
+            if (utf8_width(line) + utf8_width(word)) > width:
+                ret.append(line.rstrip(' '))
+                line = subsequent_indent + ' ' * spcs
+            line += word
+            line += ' '
+        indent = line.rstrip(' ') + ' '
+    if wrap_last:
+        ret.append(indent.rstrip(' '))
+
+    if passed_unicode:
+        return map(to_unicode, ret)
+    return ret
+
+def utf8_text_fill(text, *args, **kwargs):
+    """ Works like we want textwrap.fill() to work, uses utf-8 data and
+        doesn't screw up lists/blocks/etc. """
+    return '\n'.join(utf8_text_wrap(text, *args, **kwargs))
+# ----------------------------- END utf8 -----------------------------
+
+def to_unicode(obj, encoding='utf-8', errors='replace'):
+    ''' convert a 'str' to 'unicode' '''
+    if isinstance(obj, basestring):
+        if not isinstance(obj, unicode):
+            obj = unicode(obj, encoding, errors)
+    return obj
+
+def to_utf8(obj, errors='replace'):
+    '''convert 'unicode' to an encoded utf-8 byte string '''
+    if isinstance(obj, unicode):
+        obj = obj.encode('utf-8', errors)
+    return obj
+
+# Don't use this, to_unicode should just work now
+def to_unicode_maybe(obj, encoding='utf-8', errors='replace'):
+    ''' Don't ask don't tell, only use when you must '''
+    try:
+        return to_unicode(obj, encoding, errors)
+    except UnicodeEncodeError:
+        return obj
+
+def to_str(obj):
+    """ Convert something to a string, if it isn't one. """
+    # NOTE: unicode counts as a string just fine. We just want objects to call
+    # their __str__ methods.
+    if not isinstance(obj, basestring):
+        obj = str(obj)
+    return obj
+
 
 try: 
     '''
@@ -34,3 +421,49 @@ except:
     returning the same text
     '''
     _ = dummy_wrapper
+
+if __name__ == "__main__":
+    import sys
+
+    def out(arg):
+        arg = to_utf8(arg)
+        print "UTF8 :", arg
+        print "len  :", len(arg)
+        arg = to_unicode(arg)
+        print "USC  :", arg
+        print "len  :", len(arg)
+        print "valid:", utf8_valid(arg)
+        print "width:", utf8_width(arg)
+        print "4.8  :", "%s%s%s" % ('<', utf8_width_fill(arg,  4,  8), '>')
+        print "4.3  :", "%s%s%s" % ('<', utf8_width_fill(arg,  4,  3), '>')
+        print "4.2  :", "%s%s%s" % ('<', utf8_width_fill(arg,  4,  2), '>')
+        print "4.1  :", "%s%s%s" % ('<', utf8_width_fill(arg,  4,  1), '>')
+        print "3.3  :", "%s%s%s" % ('<', utf8_width_fill(arg,  3,  3), '>')
+        print "3.2  :", "%s%s%s" % ('<', utf8_width_fill(arg,  3,  2), '>')
+        print "3.1  :", "%s%s%s" % ('<', utf8_width_fill(arg,  3,  1), '>')
+        print "40.79:", "%s%s%s" % ('<', utf8_width_fill(arg, 40, 79), '>')
+        print "40.20:", "%s%s%s" % ('<', utf8_width_fill(arg, 40, 20), '>')
+        print ''
+
+    print " ---- Arguments/str ---- "
+    for arg in sys.argv[1:]:
+        out(arg)
+
+    print " ---- Arguments/gettext ---- "
+    for arg in sys.argv[1:]:
+        try:
+            arg = _(arg)
+        except UnicodeDecodeError:
+            continue
+        out(arg)
+
+    if len(sys.argv) > 2:
+        print " ---- Arguments/str/all ---- "
+        out(sys.argv[1] % sys.argv[2:])
+
+        print " ---- Arguments/gettext/all ---- "
+        try:
+            arg = _(sys.argv[1]) % map(_, sys.argv[2:])
+        except UnicodeDecodeError:
+            sys.exit(0)
+        out(arg)
diff --git a/yum/metalink.py b/yum/metalink.py
index 5a57511..ff36393 100755
--- a/yum/metalink.py
+++ b/yum/metalink.py
@@ -135,9 +135,12 @@ class MetaLinkURL:
 
         self.url        = elem.text
         self.preference = int(elem.get("preference", -1))
-        self.protocol   = elem.get("protocol")
+        self.protocol   = elem.get("type") # This is the "std" attribute name
         self.location   = elem.get("location")
 
+        if self.protocol is None: # Try for the old MM protocol attribute
+            self.protocol   = elem.get("protocol")
+
     def __str__(self):
         return """\
 URL:             %s
@@ -179,7 +182,10 @@ class MetaLinkRepoMD:
         self.mirrors = []
         if not os.path.exists(filename):
             raise MetaLinkRepoErrorParseFail, "File %s does not exist" %filename
-        root = xmlparse(filename)
+        try:
+            root = xmlparse(filename)
+        except SyntaxError:
+            raise MetaLinkRepoErrorParseFail, "File %s is not XML" % filename
 
         for elem in root.findall(__ML_FILE_ELEMENT__):
             name = elem.get('name')
diff --git a/yum/misc.py b/yum/misc.py
index 801fc0f..e0e8256 100644
--- a/yum/misc.py
+++ b/yum/misc.py
@@ -40,6 +40,7 @@ except ImportError:
             raise ValueError, "Bad checksum type"
 
 from Errors import MiscError
+from i18n import to_unicode, to_unicode_maybe, to_utf8, to_str
 
 _share_data_store   = {}
 _share_data_store_u = {}
@@ -177,15 +178,14 @@ class Checksums:
         Length and the result(s) when complete. """
 
     def __init__(self, checksums=None, ignore_missing=False):
-        self._checksums = checksums
-        if self._checksums is None:
-            self._checksums = ['sha256']
+        if checksums is None:
+            checksums = ['sha256']
         self._sumalgos = []
         self._sumtypes = []
         self._len = 0
 
         done = set()
-        for sumtype in self._checksums:
+        for sumtype in checksums:
             if sumtype in done:
                 continue
 
@@ -198,6 +198,8 @@ class Checksums:
             done.add(sumtype)
             self._sumtypes.append(sumtype)
             self._sumalgos.append(sumalgo)
+        if not done:
+            raise MiscError, 'Error Checksumming, no valid checksum type'
 
     def __len__(self):
         return self._len
@@ -218,9 +220,22 @@ class Checksums:
             ret[sumtype] = sumdata.hexdigest()
         return ret
 
-    def hexdigest(self, checksum):
+    def hexdigest(self, checksum=None):
+        if checksum is None:
+            checksum = self._sumtypes[0]
         return self.hexdigests()[checksum]
 
+    def digests(self):
+        ret = {}
+        for sumtype, sumdata in zip(self._sumtypes, self._sumalgos):
+            ret[sumtype] = sumdata.digest()
+        return ret
+
+    def digest(self, checksum=None):
+        if checksum is None:
+            checksum = self._sumtypes[0]
+        return self.digests()[checksum]
+
 
 class AutoFileChecksums:
     """ Generate checksum(s), on given file/fileobject. Pretending to be a file
@@ -763,34 +778,6 @@ def setup_locale(override_codecs=True, override_time=False):
         sys.stdout = codecs.getwriter(locale.getpreferredencoding())(sys.stdout)
         sys.stdout.errors = 'replace'
 
-def to_unicode(obj, encoding='utf-8', errors='replace'):
-    ''' convert a 'str' to 'unicode' '''
-    if isinstance(obj, basestring):
-        if not isinstance(obj, unicode):
-            obj = unicode(obj, encoding, errors)
-    return obj
-
-def to_utf8(obj, errors='replace'):
-    '''convert 'unicode' to an encoded utf-8 byte string '''
-    if isinstance(obj, unicode):
-        obj = obj.encode('utf-8', errors)
-    return obj
-
-# Don't use this, to_unicode should just work now
-def to_unicode_maybe(obj, encoding='utf-8', errors='replace'):
-    ''' Don't ask don't tell, only use when you must '''
-    try:
-        return to_unicode(obj, encoding, errors)
-    except UnicodeEncodeError:
-        return obj
-
-def to_str(obj):
-    """ Convert something to a string, if it isn't one. """
-    # NOTE: unicode counts as a string just fine. We just want objects to call
-    # their __str__ methods.
-    if not isinstance(obj, basestring):
-        obj = str(obj)
-    return obj
 
 def get_my_lang_code():
     mylang = locale.getlocale()
diff --git a/yum/packages.py b/yum/packages.py
index 48dfc8d..acfb9f0 100644
--- a/yum/packages.py
+++ b/yum/packages.py
@@ -978,7 +978,9 @@ class YumHeaderPackage(YumAvailablePackage):
         self.ver = self.version
         self.rel = self.release
         self.pkgtup = (self.name, self.arch, self.epoch, self.version, self.release)
-        self.summary = misc.share_data(self.hdr['summary'].replace('\n', ''))
+        # Summaries "can be" empty, which rpm return [], see BZ 473239, *sigh*
+        self.summary = self.hdr['summary'] or ''
+        self.summary = misc.share_data(self.summary.replace('\n', ''))
         self.description = misc.share_data(self.hdr['description'])
         self.pkgid = self.hdr[rpm.RPMTAG_SHA1HEADER]
         if not self.pkgid:
diff --git a/yum/parser.py b/yum/parser.py
index ca5a068..4f297c3 100644
--- a/yum/parser.py
+++ b/yum/parser.py
@@ -58,6 +58,9 @@ class ConfigPreProcessor:
     def __init__(self, configfile, vars=None):
         # put the vars away in a helpful place
         self._vars = vars
+
+        # used to track the current ini-section
+        self._section = None
         
         # set some file-like object attributes for ConfigParser
         # these just make confpp look more like a real file object.
@@ -129,6 +132,10 @@ class ConfigPreProcessor:
                         # whooohoo a valid include line.. push it on the stack
                         fo = self._pushfile( url )
                 else:
+                    # check if the current line starts a new section
+                    secmatch = re.match( r'\s*\[(?P<section>.*)\]', line )
+                    if secmatch:
+			self._section = secmatch.group('section')
                     # line didn't match include=, just return it as is
                     # for the ConfigParser
                     break
@@ -156,8 +163,7 @@ class ConfigPreProcessor:
             return url
         else:
             return urlparse.urljoin( self.geturl(), url )
-    
-    
+
     def _pushfile( self, url ):
         """
         Opens the url specified, pushes it on the stack, and 
@@ -169,8 +175,12 @@ class ConfigPreProcessor:
         # absolutize this url using the including files url
         # as a base url.
         absurl = self._absurl(url)
+
+        # get the current section to add it to the included
+        # url's name.
+        includetuple = (absurl, self._section)
         # check if this has previously been included.
-        if self._urlalreadyincluded(absurl):
+        if self._isalreadyincluded(includetuple):
             return None
         try:
             fo = urlgrabber.grabber.urlopen(absurl)
@@ -179,7 +189,7 @@ class ConfigPreProcessor:
         if fo is not None:
             self.name = absurl
             self._incstack.append( fo )
-            self._alreadyincluded.append(absurl)
+            self._alreadyincluded.append(includetuple)
         else:
             raise Errors.ConfigError, \
                   'Error accessing file for config %s' % (absurl)
@@ -199,13 +209,13 @@ class ConfigPreProcessor:
             self.name = None
     
     
-    def _urlalreadyincluded( self, url ):
+    def _isalreadyincluded( self, tuple ):
         """
-        Checks if the url has already been included at all.. this 
-        does not necessarily have to be recursive
+        Checks if the tuple describes an include that was already done.
+        This does not necessarily have to be recursive
         """
-        for eurl in self._alreadyincluded:
-            if eurl == url: return 1
+        for etuple in self._alreadyincluded:
+            if etuple == tuple: return 1
         return 0
     
     
diff --git a/yum/pgpmsg.py b/yum/pgpmsg.py
index 35a7801..04ab346 100644
--- a/yum/pgpmsg.py
+++ b/yum/pgpmsg.py
@@ -13,7 +13,26 @@
 ##You should have received a copy of the GNU General Public License
 ##along with this program; if not, write to the Free Software
 ##Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA  02111-1307, USA.
-import struct, time, cStringIO, base64, types, md5, sha
+import struct, time, cStringIO, base64, types
+
+#  We use this so that we can work on python-2.4 and python-2.6, and thus.
+# use import md5/import sha on the older one and import hashlib on the newer.
+#  Stupid deprecation warnings.
+try:
+    import hashlib
+except ImportError:
+    # Python-2.4.z ... gah!
+    import sha
+    import md5
+    class hashlib:
+
+        @staticmethod
+        def new(algo):
+            if algo == 'md5':
+                return md5.new()
+            if algo == 'sha1':
+                return sha.new()
+            raise ValueError, "Bad checksum type"
 
 debug = None
 
@@ -378,14 +397,14 @@ class public_key(pgp_packet) :
         # otherwise calculate it now and cache it
         # v3 and v4 are calculated differently
         if self.version == 3 :
-            h = md5.new()
+            h = hashlib.new('md5')
             h.update(pack_long(self.pk_rsa_mod))
             h.update(pack_long(self.pk_rsa_exp))
             self.fingerprint_ = h.digest()
         elif self.version == 4 :
             # we hash what would be the whole PGP message containing
             # the pgp certificate
-            h = sha.new()
+            h = hashlib.new('sha1')
             h.update('\x99')
             # we need to has the length of the packet as well
             buf = self.serialize()
diff --git a/yum/plugins.py b/yum/plugins.py
index 82efdee..287fba7 100644
--- a/yum/plugins.py
+++ b/yum/plugins.py
@@ -37,6 +37,8 @@ from weakref import proxy as weakref
 
 from yum import _
 
+from yum.i18n import utf8_width, utf8_width_fill
+
 # TODO: expose rpm package sack objects to plugins (once finished)
 # TODO: allow plugins to use the existing config stuff to define options for
 # their own configuration files (would replace confString() etc).
@@ -198,7 +200,7 @@ class YumPlugins:
             # Mostly copied from YumOutput._outKeyValFill()
             key = _("Loaded plugins: ")
             val = ", ".join(sorted(self._plugins))
-            nxt = ' ' * (len(key) - 2) + ': '
+            nxt = ' ' * (utf8_width(key) - 2) + ': '
             width = 80
             if hasattr(self.base, 'term'):
                 width = self.base.term.columns
diff --git a/yum/sqlitesack.py b/yum/sqlitesack.py
index 7ff7d9a..21fec5a 100644
--- a/yum/sqlitesack.py
+++ b/yum/sqlitesack.py
@@ -34,7 +34,8 @@ import sqlutils
 import constants
 import operator
 import time
-from yum.misc import seq_max_split
+from yum.misc import seq_max_split, to_utf8
+import sys
 
 def catchSqliteException(func):
     """This decorator converts sqlite exceptions into RepoError"""
@@ -42,7 +43,9 @@ def catchSqliteException(func):
         try:
             return func(*args, **kwargs)
         except sqlutils.sqlite.Error, e:
-            if hasattr(e, "message"):
+            # 2.4.x requires this, but 2.6.x complains about even hasattr()
+            # of e.message ... *sigh*
+            if sys.hexversion < 0x02050000:
                 raise Errors.RepoError, str(e.message)
             raise Errors.RepoError, str(e)
 
@@ -205,8 +208,8 @@ class YumAvailablePackageSqlite(YumAvailablePackage, PackageObject, RpmBase):
             # Failure mode is much less of a problem.
             for ob in cur:
                 c_date = ob['date']
-                c_author = ob['author'].encode('utf-8', 'replace')
-                c_log = ob['changelog'].encode('utf-8', 'replace')
+                c_author = to_utf8(ob['author'])
+                c_log = to_utf8(ob['changelog'])
                 result.append((c_date, _share_data(c_author), c_log))
             self._changelog = result
             return
diff --git a/yum/update_md.py b/yum/update_md.py
index b1d7388..a2b2008 100644
--- a/yum/update_md.py
+++ b/yum/update_md.py
@@ -24,7 +24,7 @@ Update metadata (updateinfo.xml) parsing.
 import sys
 import gzip
 
-from textwrap import wrap
+from yum.i18n import utf8_text_wrap
 from yum.yumRepo import YumRepository
 from yum.misc import to_xml
 
@@ -95,7 +95,7 @@ class UpdateNotice(object):
             for bz in bzs:
                 buglist += " %s%s\n\t    :" % (bz['id'], bz.has_key('title')
                                                and ' - %s' % bz['title'] or '')
-            head += buglist[:-1].rstrip() + '\n'
+            head += buglist[: - 1].rstrip() + '\n'
 
         # Add our CVE references
         cves = filter(lambda r: r['type'] == 'cve', self._md['references'])
@@ -103,11 +103,11 @@ class UpdateNotice(object):
             cvelist = "       CVEs :"
             for cve in cves:
                 cvelist += " %s\n\t    :" % cve['id']
-            head += cvelist[:-1].rstrip() + '\n'
+            head += cvelist[: - 1].rstrip() + '\n'
 
         if self._md['description'] is not None:
-            desc = wrap(self._md['description'], width=64,
-                        subsequent_indent=' ' * 12 + ': ')
+            desc = utf8_text_wrap(self._md['description'], width=64,
+                                  subsequent_indent=' ' * 12 + ': ')
             head += "Description : %s\n" % '\n'.join(desc)
 
         #  Get a list of arches we care about:
@@ -119,7 +119,7 @@ class UpdateNotice(object):
                 if file['arch'] not in arches:
                     continue
                 filelist += " %s\n\t    :" % file['filename']
-        head += filelist[:-1].rstrip()
+        head += filelist[: - 1].rstrip()
 
         return head
 
@@ -236,17 +236,17 @@ class UpdateNotice(object):
 
     def xml(self):
         """Generate the xml for this update notice object"""
-        msg="""
+        msg = """
 <update from="%s" status="%s" type="%s" version="%s">
   <id>%s</id>
   <title>%s</title>
   <release>%s</release>
   <issued date="%s"/>
   <description>%s</description>\n""" % (to_xml(self._md['from']),
-                to_xml(self._md['status']), to_xml(self._md['type']), 
-                to_xml(self._md['version']),to_xml(self._md['update_id']),
+                to_xml(self._md['status']), to_xml(self._md['type']),
+                to_xml(self._md['version']), to_xml(self._md['update_id']),
                 to_xml(self._md['title']), to_xml(self._md['release']),
-                to_xml(self._md['issued'], attrib=True), 
+                to_xml(self._md['issued'], attrib=True),
                 to_xml(self._md['description']))
         
         if self._md['references']:
@@ -398,7 +398,7 @@ class UpdateMetadata(object):
         if fileobj:
             fileobj.write(end)
         else:
-            msg+= end
+            msg += end
 
         if fileobj:
             return
diff --git a/yum/yumRepo.py b/yum/yumRepo.py
index b762deb..7a83756 100644
--- a/yum/yumRepo.py
+++ b/yum/yumRepo.py
@@ -44,6 +44,8 @@ import warnings
 import glob
 import shutil
 import stat
+import errno
+import tempfile
 
 #  If you want yum to _always_ check the MD .sqlite files then set this to
 # False (this doesn't affect .xml files or .sqilte files derived from them).
@@ -207,7 +209,11 @@ class YumPackageSack(packageSack.PackageSack):
                 repo.checkMD(db_un_fn, mdtype, openchecksum=True)
             except URLGrabError:
                 if not repo.cache:
-                    os.unlink(db_un_fn)
+                    try:
+                        os.unlink(db_un_fn)
+                    except OSError, e:
+                        if e.errno != errno.ENOENT:
+                            raise # Could have an error before anything happens
             else:
                 result = db_un_fn
 
@@ -774,6 +780,9 @@ class YumRepository(Repository, config.RepoConf):
         start = package.hdrstart
         end = package.hdrend
         basepath = package.basepath
+        # yes, I know, don't ask
+        if not os.path.exists(self.hdrdir):
+            os.makedirs(self.hdrdir)
 
         return self._getFile(url=basepath, relative=remote, local=local, start=start,
                         reget=None, end=end, checkfunc=checkfunc, copy_local=1,
@@ -874,12 +883,20 @@ class YumRepository(Repository, config.RepoConf):
 
     def _getFileRepoXML(self, local, text=None, grab_can_fail=None):
         """ Call _getFile() for the repomd.xml file. """
+        def _cleanup_tmp():
+            try:
+                os.unlink(tfname)
+            except:
+                pass
         checkfunc = (self._checkRepoXML, (), {})
         if grab_can_fail is None:
             grab_can_fail = 'old_repo_XML' in self._oldRepoMDData
         try:
+            # This is named so that "yum clean metadata" picks it up
+            tfname = tempfile.mktemp(prefix='repomd', suffix="tmp.xml",
+                                     dir=os.path.dirname(local))
             result = self._getFile(relative=self.repoMDFile,
-                                   local=local,
+                                   local=tfname,
                                    copy_local=1,
                                    text=text,
                                    reget=None,
@@ -887,16 +904,27 @@ class YumRepository(Repository, config.RepoConf):
                                    cache=self.http_caching == 'all')
 
         except URLGrabError, e:
+            _cleanup_tmp()
             if grab_can_fail:
                 return None
             raise Errors.RepoError, 'Error downloading file %s: %s' % (local, e)
         except (Errors.NoMoreMirrorsRepoError, Errors.RepoError):
+            _cleanup_tmp()
             if grab_can_fail:
                 return None
             raise
 
-
-        return result
+        # This should always work...
+        try:
+            os.rename(result, local)
+        except:
+            # But in case it doesn't...
+            _cleanup_tmp()
+            if grab_can_fail:
+                return None
+            raise Errors.RepoError, 'Error renaming file %s to %s' % (result,
+                                                                      local)
+        return local
 
     def _parseRepoXML(self, local, parse_can_fail=None):
         """ Parse the repomd.xml file. """
@@ -1294,27 +1322,22 @@ class YumRepository(Repository, config.RepoConf):
                 result = self._getFile(relative='repodata/repomd.xml.asc',
                                        copy_local=1,
                                        local = sigfile,
-                                       text='%s repo signature' % self.id,
+                                       text='%s/signature' % self.id,
                                        reget=None,
                                        checkfunc=None,
                                        cache=self.http_caching == 'all')
             except URLGrabError, e:
                 raise URLGrabError(-1, 'Error finding signature for repomd.xml for %s: %s' % (self, e))
 
-            if not os.path.exists(self.gpgdir):
-                if self.gpg_import_func:
-                    #FIXME probably should have an else off of this to
-                    # complain if there is no import function
-                    try:
-                        self.gpg_import_func(self, self.confirm_func)
-                    except Errors.YumBaseError, e:
-                        raise URLGrabError(-1, 'Gpg Keys not imported, cannot verify repomd.xml for repo %s' % (self))
-
-                    # FIXME if we get the okay here to import the key then
-                    # we should set an option so that future key imports for this
-                    # repo will be allowed w/o question
+            valid = misc.valid_detached_sig(result, filepath, self.gpgdir)
+            if not valid and self.gpg_import_func:
+                try:
+                    self.gpg_import_func(self, self.confirm_func)
+                except Errors.YumBaseError, e:
+                    raise URLGrabError(-1, 'Gpg Keys not imported, cannot verify repomd.xml for repo %s' % (self))
+                valid = misc.valid_detached_sig(result, filepath, self.gpgdir)
 
-            if not misc.valid_detached_sig(result, filepath, self.gpgdir):
+            if not valid:
                 raise URLGrabError(-1, 'repomd.xml signature could not be verified for %s' % (self))
 
         try:
diff --git a/yumcommands.py b/yumcommands.py
index d3ce5ee..3783292 100644
--- a/yumcommands.py
+++ b/yumcommands.py
@@ -29,6 +29,7 @@ import locale
 import fnmatch
 import time
 from yum.misc import to_unicode
+from yum.i18n import utf8_width, utf8_width_fill
 
 def checkRootUID(base):
     """
@@ -237,31 +238,54 @@ class InfoCommand(YumCommand):
 
     def doCommand(self, base, basecmd, extcmds):
         try:
-            ypl = base.returnPkgLists(extcmds)
+            highlight = base.term.MODE['bold']
+            ypl = base.returnPkgLists(extcmds, installed_available=highlight)
         except yum.Errors.YumBaseError, e:
             return 1, [str(e)]
         else:
             update_pkgs = {}
+            inst_pkgs   = {}
 
             columns = None
             if basecmd == 'list':
                 # Dynamically size the columns
                 columns = _list_cmd_calc_columns(base, ypl)
 
-            if ypl.installed:
+            if highlight and ypl.installed:
                 #  If we have installed and available lists, then do the
                 # highlighting for the installed packages so you can see what's
-                # available to install vs. available to update.
-                for pkg in ypl.available:
+                # available to update, an extra, or newer than what we have.
+                for pkg in (ypl.hidden_available +
+                            ypl.reinstall_available +
+                            ypl.old_available):
                     key = (pkg.name, pkg.arch)
                     if key not in update_pkgs or pkg.verGT(update_pkgs[key]):
                         update_pkgs[key] = pkg
 
+            if highlight and ypl.available:
+                #  If we have installed and available lists, then do the
+                # highlighting for the available packages so you can see what's
+                # available to install vs. update vs. old.
+                for pkg in ypl.hidden_installed:
+                    key = (pkg.name, pkg.arch)
+                    if key not in inst_pkgs or pkg.verGT(inst_pkgs[key]):
+                        inst_pkgs[key] = pkg
+
             # Output the packages:
+            clio = base.conf.color_list_installed_older
+            clin = base.conf.color_list_installed_newer
+            clie = base.conf.color_list_installed_extra
             rip = base.listPkgs(ypl.installed, _('Installed Packages'), basecmd,
-                                highlight_na=update_pkgs, columns=columns)
+                                highlight_na=update_pkgs, columns=columns,
+                                highlight_modes={'>' : clio, '<' : clin,
+                                                 'not in' : clie})
+            clau = base.conf.color_list_available_upgrade
+            clad = base.conf.color_list_available_downgrade
+            clai = base.conf.color_list_available_install
             rap = base.listPkgs(ypl.available, _('Available Packages'), basecmd,
-                                columns=columns)
+                                highlight_na=inst_pkgs, columns=columns,
+                                highlight_modes={'<' : clau, '>' : clad,
+                                                 'not in' : clai})
             rep = base.listPkgs(ypl.extras, _('Extra Packages'), basecmd,
                                 columns=columns)
             rup = base.listPkgs(ypl.updates, _('Updated Packages'), basecmd,
@@ -535,11 +559,25 @@ class CheckUpdateCommand(YumCommand):
         result = 0
         try:
             ypl = base.returnPkgLists(extcmds)
+            if base.verbose_logger.isEnabledFor(logginglevels.DEBUG_3):
+                typl = base.returnPkgLists(['obsoletes'])
+                ypl.obsoletes = typl.obsoletes
+                ypl.obsoletesTuples = typl.obsoletesTuples
+
             columns = _list_cmd_calc_columns(base, ypl)
             if len(ypl.updates) > 0:
                 base.listPkgs(ypl.updates, '', outputType='list',
                               columns=columns)
                 result = 100
+            if len(ypl.obsoletes) > 0: # This only happens in verbose mode
+                rop = [0, '']
+                print _('Obsoleting Packages')
+                # The tuple is (newPkg, oldPkg) ... so sort by new
+                for obtup in sorted(ypl.obsoletesTuples,
+                                    key=operator.itemgetter(0)):
+                    base.updatesObsoletesList(obtup, 'obsoletes',
+                                              columns=columns)
+                result = 100
         except yum.Errors.YumBaseError, e:
             return 1, [str(e)]
         else:
@@ -719,11 +757,9 @@ class RepoListCommand(YumCommand):
         # Setup so len(repo.sack) is correct
         base.repos.populateSack()
 
-        format_string = "%-20.20s %-40.40s %-8s%s"
         repos = base.repos.repos.values()
         repos.sort()
         enabled_repos = base.repos.listEnabled()
-        done = False
         verbose = base.verbose_logger.isEnabledFor(logginglevels.DEBUG_3)
         if arg == 'all':
             ehibeg = base.term.FG_COLOR['green'] + base.term.MODE['bold']
@@ -734,33 +770,32 @@ class RepoListCommand(YumCommand):
             dhibeg = ''
             hiend  = ''
         tot_num = 0
+        cols = []
         for repo in repos:
             if len(extcmds) and not _repo_match(repo, extcmds):
                 continue
             if repo in enabled_repos:
                 enabled = True
-                ui_enabled = ehibeg + _('enabled') + hiend
+                ui_enabled = ehibeg + _('enabled') + hiend + ": "
+                ui_endis_wid = utf8_width(_('enabled')) + 2
                 num        = len(repo.sack)
                 tot_num   += num
                 ui_num     = to_unicode(locale.format("%d", num, True))
-                ui_fmt_num = ": %7s"
                 if verbose:
                     ui_size = _repo_size(repo)
             else:
                 enabled = False
                 ui_enabled = dhibeg + _('disabled') + hiend
+                ui_endis_wid = utf8_width(_('disabled'))
                 ui_num     = ""
-                ui_fmt_num = "%s"
                 
             if (arg == 'all' or
                 (arg == 'enabled' and enabled) or
                 (arg == 'disabled' and not enabled)):
-                if not done and not verbose:
-                    base.verbose_logger.log(logginglevels.INFO_2,
-                                            format_string, _('repo id'),
-                                            _('repo name'), _('status'), "")
-                done = True
-                if verbose:
+                if not verbose:
+                    cols.append((str(repo), repo.name,
+                                 (ui_enabled, ui_endis_wid), ui_num))
+                else:
                     md = repo.repoXML
                     out = [base.fmtKeyValFill(_("Repo-id     : "), repo),
                            base.fmtKeyValFill(_("Repo-name   : "), repo.name),
@@ -812,10 +847,47 @@ class RepoListCommand(YumCommand):
                     base.verbose_logger.log(logginglevels.DEBUG_3,
                                             "%s\n",
                                             "\n".join(out))
-                else:
-                    base.verbose_logger.log(logginglevels.INFO_2, format_string,
-                                            repo, repo.name, ui_enabled,
-                                            ui_fmt_num % ui_num)
+
+        if not verbose and cols:
+            #  Work out the first (id) and last (enabled/disalbed/count),
+            # then chop the middle (name)...
+            id_len = utf8_width(_('repo id'))
+            nm_len = 0
+            ct_len = 0
+            ui_len = 0
+
+            for (rid, rname, (ui_enabled, ui_endis_wid), ui_num) in cols:
+                if id_len < utf8_width(rid):
+                    id_len = utf8_width(rid)
+                if nm_len < utf8_width(rname):
+                    nm_len = utf8_width(rname)
+                if ct_len < ui_endis_wid:
+                    ct_len = ui_endis_wid
+                if ui_len < len(ui_num):
+                    ui_len = len(ui_num)
+            if utf8_width(_('status')) > ct_len + ui_len:
+                left = base.term.columns - (id_len + utf8_width(_('status')) +2)
+            else:
+                left = base.term.columns - (id_len + ct_len + ui_len + 2)
+
+            if left < nm_len: # Name gets chopped
+                nm_len = left
+            else: # Share the extra...
+                left -= nm_len
+                id_len += left / 2
+                nm_len += left - (left / 2)
+
+            txt_rid  = utf8_width_fill(_('repo id'), id_len)
+            txt_rnam = utf8_width_fill(_('repo name'), nm_len, nm_len)
+            base.verbose_logger.log(logginglevels.INFO_2,"%s %s %s",
+                                    txt_rid, txt_rnam, _('status'))
+            for (rid, rname, (ui_enabled, ui_endis_wid), ui_num) in cols:
+                if ui_num:
+                    ui_num = utf8_width_fill(ui_num, ui_len, left=False)
+                base.verbose_logger.log(logginglevels.INFO_2, "%s %s %s%s",
+                                        utf8_width_fill(rid, id_len),
+                                        utf8_width_fill(rname, nm_len, nm_len),
+                                        ui_enabled, ui_num)
 
         return 0, ['repolist: ' +to_unicode(locale.format("%d", tot_num, True))]