File discourse-puma.service of Package discourse

[Unit]
Description=Discourse Puma
After=postgresql.service redis.target discourse-update.service
Requires=discourse-update.service
PartOf=discourse.target

[Service]
Type=simple
User=discourse
Group=discourse
Environment="RUBY_GC_MALLOC_LIMIT=90000000" "LANG=en_US.UTF-8" "LC_ALL=en_US.UTF-8" "RAILS_ENV=production"
WorkingDirectory=/srv/www/vhosts/discourse/
ExecStart=BUNDLER_REPLACE exec /usr/bin/puma.@RUBY_SUFFIX@ --env production --config /srv/www/vhosts/discourse/config/puma.rb
KillSignal=SIGINT
Restart=on-failure

[Install]
WantedBy=multi-user.target
openSUSE Build Service is sponsored by