File gem2rpm.yml of Package rubygem-rugged

# ---
# ## used by gem2rpm
# :summary: this is a custom summary
# ## used by gem2rpm
# :description: |-
#   this is a custom description
#
#   it can be multiline
# ## used by gem2rpm
# :license: MIT or Ruby
# ## used by gem2rpm and gem_packages
# :version_suffix: -x_y
# ## used by gem2rpm and gem_packages
# :disable_docs: true
# ## used by gem2rpm
# :disable_automatic_rdoc_dep: true
# ## used by gem2rpm
# :preamble: |-
#   BuildRequires: foobar
#   Requires: foobar
# ## used by gem2rpm
# :patches:
#   foo.patch: -p1
#   bar.patch: 
# ## used by gem2rpm
# :sources:
# - foo.desktop
# - bar.desktop
# :gem_install_args: '....'
# ## used by gem2rpm
# :pre_install: |-
#   %if 0%{?use_system_libev}
#   export USE_VENDORED_LIBEV="no"
#   %endif
# ## used by gem2rpm
# :post_install: |-
#   # delete custom files here or do other fancy stuff
#   install -D -m 0644 %{S:1} %{buildroot}%{_bindir}/gem2rpm-opensuse
# ## used by gem2rpm
# :testsuite_command: |-
#   (pushd %{buildroot}%{gem_base}/gems/%{mod_full_name} && rake test)
# ## used by gem2rpm
# :filelist: |-
#   /usr/bin/gem2rpm-opensuse
# ## used by gem2rpm
# :scripts:
#   :post: |-
#     /bin/echo foo
# ## used by gem_packages
# :main:
#   :preamble: |-
#     Requires: util-linux
#     Recommends: pwgen
#   :filelist: |-
#     /usr/bin/gem2rpm-opensuse
# ## used by gem_packages
# :custom:
#   apache:
#     :preamble: |-
#       Requires: .....
#     :filelist: |-
#       /etc/apache2/conf.d/passenger.conf
#     :summary: Custom summary is optional
#     :description: |-
#       Custom description is optional
#
#       bar
#     :post: |-
#       /bin/echo foo
# TODO: check if we can build against system libgit2
#
---
:sources:
  - rubygem-rugged-rpmlintrc
  - series
:patches:
  allow_newer_libgit.patch: -p1
:gem_install_args: 
:pre_install: |-
  %if %{with system_libgit2}
  export RUGGED_USE_SYSTEM_LIBRARIES=1
  %endif
:preamble: |-
  %bcond_without   system_libgit2
  BuildRequires:   cmake
  BuildRequires:   pkgconfig
  %if %{with system_libgit2}
  BuildRequires:   libgit2-devel >= 0.27.0
  %else
  BuildRequires:   pkgconfig(libcurl)
  BuildRequires:   pkgconfig(libssh2)
  BuildRequires:   pkgconfig(openssl)
  BuildRequires:   http-parser-devel
  %endif
:post_install: |-
  find %{buildroot} -type d -name build -print0 | xargs -r0 rm -rv
  find %{buildroot}         -name \*.a  -print0 | xargs -r0 rm -v