File baselibs.conf of Package openssl

libopenssl1_0_0
  obsoletes "openssl-<targettype> <= <version>"
libopenssl-devel
  requires -libopenssl-<targettype>
  requires "libopenssl1_0_0-<targettype> = <version>"