File gnome-python-desktop.changes of Package gnome-python-desktop

-------------------------------------------------------------------
Mon Sep 17 13:24:15 UTC 2012 - vuntz@opensuse.org

- Disable building python-bugbuddy as we don't ship it anymore,
  with a %define in the same way we disable other bindings. If not
  building python-bugbuddy:
  + Use python-bugbuddy Obsoletes in main subpackage, for smooth
    upgrades.
  + Pass --disable-bugbuddy to configure.

-------------------------------------------------------------------
Fri Aug 24 17:30:05 UTC 2012 - dimstar@opensuse.org

- Disable building of the evo plugins: they are currently not
  compatible with w-d-s 3.5.x.

-------------------------------------------------------------------
Thu Feb 23 10:02:14 UTC 2012 - vuntz@opensuse.org

- Stop building python-metacity:
  + The bindings are not compatible with current metacity.
  + Add build_metacity macro to change this behavior, set to 0.
  + Do not use pkgconfig(libmetacity-private) BuildRequires if we
    don't build python-metacity.
  + Add Obsoletes for python-metacity to main subpackage, instead
    of a Requires, for smooth upgrades.
  + Only pass --enable-metacity to configure if we build
    python-metacity.
- Stop passing --libexecdir=%{_libexecdir}/%{name} to configure: we
  never use libexecdir.
- Remove applet, brasero, mediaprofiles code examples if we don't
  build those bindings.

-------------------------------------------------------------------
Thu Apr 14 10:07:12 UTC 2011 - dimstar@opensuse.org

- Add Obsoletes for the disabled modules (brasero, media-profiles,
  evince and applets) to ease upgrade processes.

-------------------------------------------------------------------
Thu Apr  7 08:30:58 UTC 2011 - fcrozat@novell.com

- Disable modules not available for gnome3 (brasero,
  media-profiles, applets, evince). We use macros to make it easy
  to re-eanble them, should we wish to do so later on.

-------------------------------------------------------------------
Fri Jan  7 14:58:35 CET 2011 - vuntz@opensuse.org

- Split all python modules in subpackages, so we can have more
  fine-grained dependencies:
  + Create python-brasero, python-bugbuddy, python-evince,
    python-evolution, python-gnomeapplet, python-gnomedesktop,
    python-gnomekeyring, python-gnomeprint, python-gtop,
    python-mediaprofiles, python-metacity, python-rsvg,
    python-totem, python-wnck.
  + Ship a README.openSUSE file explaining the setup of the
    package.
- Package code examples in the devel subpackage.


-------------------------------------------------------------------
Tue Sep 28 20:32:19 CEST 2010 - vuntz@opensuse.org

- Update to version 2.32.0:
  + Update evince bindings to 2.32 API (bgo#626283)
- Re-enable the build of evince bindings: uncomment
  pkgconfig(evince-document-2.30) BuildRequires and update it to
  evince-document-2.32.

-------------------------------------------------------------------
Wed Sep  8 00:51:22 CEST 2010 - vuntz@opensuse.org

- Change old-style BuildRequires to pkgconfig() style
  BuildRequires:
  + old-style: brasero-devel, evince-devel,
    evolution-data-server-devel, gnome-desktop-devel,
    gnome-media-devel, gnome-panel-devel, gtk2-devel,
    libgnomeprintui-devel, libgtop-devel, librsvg-devel,
    libwnck-devel, metacity-devel, python-gnome-devel,
    python-gtk-devel, totem-pl-parser-devel
  + new-style: evince-document-2.30, gconf-2.0, gdk-pixbuf-2.0,
    gnome-desktop-2.0, gnome-keyring-1, gnome-media-profiles,
    gnome-python-2.0, gobject-2.0, libbrasero-burn,
    libbrasero-media, libebook-1.2, libecal-1.2, libgnome-2.0,
    libgnomeprint-2.2, libgnomeprintui-2.2, libgnomeui-2.0,
    libgtop-2.0, libmetacity-private, libpanelapplet-2.0,
    librsvg-2.0, libwnck-1.0, pango, pycairo, pygobject-2.0,
    pygtk-2.0, totem-plparser.
- This will make it easier to switch to GNOME 3 libraries.

-------------------------------------------------------------------
Mon Aug  9 00:12:36 CEST 2010 - vuntz@opensuse.org

- Add a devel subpackage, and merge doc subpackage there.

-------------------------------------------------------------------
Mon Jul 19 08:31:56 UTC 2010 - dimstar@opensuse.org

- Disable evince bindings for now since they don't build with
  latest evince (see bgo#626283).

-------------------------------------------------------------------
Thu Jul  8 10:55:44 CEST 2010 - dimstar@opensuse.org

- Update to version 2.31.1:
  + evince/evince.defs: Update evince bindings to latest api
  + wscript: Use the 3rd party waf tool 'cflags'

-------------------------------------------------------------------
Tue Mar 30 21:53:52 CEST 2010 - vuntz@opensuse.org

- Update to version 2.30.0:
  + Fix configure check for evince.
  + Fix configure check for bug-buddy.
- Drop gnome-python-desktop-fix-bugbuddy.patch,
  gnome-python-desktop-fix-evince.patch: fixed upstream.

-------------------------------------------------------------------
Tue Mar 30 03:23:24 CEST 2010 - vuntz@opensuse.org

- Add gnome-python-desktop-fix-bugbuddy.patch to fix detection of
  bug-buddy in configure.
- Add gnome-python-desktop-fix-evince.patch to fix detection of
  evince in configure.

-------------------------------------------------------------------
Thu Mar 11 19:34:35 CET 2010 - dimstar@opensuse.org

- Update to version 2.29.92:
  + bgo#608331: totem-pl-parser doesn't build with latest
    totem-pl-parser
- Drop gnome-python-desktop-fix-totem-build.patch.

-------------------------------------------------------------------
Thu Jan 28 17:21:05 CET 2010 - vuntz@opensuse.org

- Add gnome-python-desktop-fix-totem-build.patch to fix build of
  totem-pl-parser bindings with latest totem-pl-parser.

-------------------------------------------------------------------
Wed Jan  6 11:32:24 CET 2010 - vuntz@opensuse.org

- Update to version 2.29.1:
  + Fix crash in gnomekeyringk.item_get_attributes_sync
    (bgo#598835)
  + Fix build with latest brasero (bgo#603231)
  + Fix build with latest evince (bgo#603659, bgo#604751)
  + Make braseromedia work (bgo#595342)
  + Fix wnck bindings to not bind enums as flags
  + Fix wnck example to not do suboptimal loop (bgo#600952)
  + Build fix.
- Drop gnome-python-desktop-brasero-api.patch: fixed upstream.
- Drop gnome-python-desktop-evince-api.patch: fixed upstream.
- Remove autoreconf call.
- Pass --disable-static to configure.
- Remove all .la files.

-------------------------------------------------------------------
Mon Dec 14 12:59:57 UTC 2009 - aj@suse.de

- Fix build with libtool version conflict: pass -i to autoreconf.

-------------------------------------------------------------------
Sat Dec  5 10:09:14 CET 2009 - vuntz@opensuse.org

- Add gnome-python-desktop-brasero-api.patch to fix build with
  latest brasero.

-------------------------------------------------------------------
Thu Dec  3 00:49:29 CET 2009 - vuntz@opensuse.org

- Add gnome-python-desktop-evince-api.patch to compile with latest
  evince.
- Fix self-obsoletion of evolution-python.

-------------------------------------------------------------------
Thu Sep 24 14:02:14 CEST 2009 - dimstar@opensuse.org

- Update to version 2.28.0:
  + bgo#594334 - evince: wrap DocumentLinks bit
  + bgo#595380 - braseroburn examples not shipped in tarballs
  + bgo#595373 - The braseroburn module is missing important
                 constants.

-------------------------------------------------------------------
Tue Sep  1 23:00:11 CEST 2009 - dimstar@opensuse.org

- Update to version 2.27.3:
  + Extended brasero modules API.
  + Wrap gnome_keyring_find_items.

-------------------------------------------------------------------
Mon Jul 20 10:49:42 CEST 2009 - vuntz@novell.com

- Update to version 2.27.2:
  + Add licensing information for the evince module.
  + Fix evince module compilation bug.
  + Add bindings for libbrasero-burn.

-------------------------------------------------------------------
Thu Jun  4 15:40:20 CEST 2009 - lmedinas@gmail.com

- Remove nautilus-cd-burner-devel BuildRequires: these bindings are
  obsoleted by the brasero ones.

-------------------------------------------------------------------
Tue May  5 17:00:48 CEST 2009 - vuntz@novell.com

- Update to version 2.27.1:
  + New braseromedia module (bgo#569055).
- Add brasero-devel BuildRequires.

-------------------------------------------------------------------
Sun Apr 26 14:35:37 CEST 2009 - vuntz@novell.com

- Remove unneeded BuildRequires: notification-daemon.

-------------------------------------------------------------------
Sat Mar 14 23:01:05 CET 2009 - mboman@suse.de

- Update to version 2.26.0:
  + evince
    * bgo#572575: evince.JobFind() crashes caller
  + evolution
    * Fix evolution modules installation issue
    * Make sure bonobo is imported before evolution.* modules are
      used (bgo#561354)
    * Add __version__ to evolution modules
  + gnomedesktop 
    * Add missing caller-owns-return annotations (bgo#570540)
- Remove custom CFLAGS

-------------------------------------------------------------------
Mon Feb 16 06:13:55 CET 2009 - mboman@suse.de

- Update to version 2.25.91:
  + Call ev_shutdown() on a python atexit handler (bgo#570622)
- Remove glib2-devel, gnome-common, gtk-doc, python,
  python-devel, gtksourceview18-devel from BuildRequires
- Use CFLAGS="$RPM_OPT_FLAGS -fno-strict-aliasing"

-------------------------------------------------------------------
Thu Feb  5 16:18:56 CET 2009 - vuntz@novell.com

- Really package evince-related files.

-------------------------------------------------------------------
Mon Feb  2 15:30:42 EST 2009 - mboman@suse.de

- Update to version 2.25.90:
  + New Evince bindings (bgo#568287)
  + Fix bgo#568284 (Error building wnck bindings)
  + Upgrade to WAF 1.5.3
  + gnomeapplet: bgo#569823 (get_popup_component does not return
    correct object)

-------------------------------------------------------------------
Sun Jan 25 10:58:11 CET 2009 - vuntz@novell.com

- Update to version 2.25.1:
  + gtop: missing include
  + evolution: bgo#561727: evolution still installed even if
    disabled
  + upgrade to newer WAF

-------------------------------------------------------------------
Mon Dec 29 09:55:44 EST 2008 - mboman@suse.de

- Update to version 2.24.1:
  + Cosmetic version bumb 

-------------------------------------------------------------------
Wed Oct  1 20:00:27 WST 2008 - mboman@suse.de

- Update to version 2.24.0:
  + pygtk-codegen-2.0 -> pygobject-codegen-2.0
  + Convert TOTEM_TYPE_PL_PARSER_METADATA values to/from Python

-------------------------------------------------------------------
Wed Sep 17 10:53:57 CDT 2008 - maw@suse.de

- Obsolete and provide evolution-python (bnc#418004).  

-------------------------------------------------------------------
Thu Sep 04 17:14:56 CEST 2008 - mboman@novell.com

- Update to version 2.23.1:
  + evolution
    * Wrap e_source_peek_uid() as ebook.get_uid() and ecalsource.get_uid()
      (bgo#519258)
    * Wrap a bunch of additional APIs
  + gnomekeyring
   * get_default_keyring_sync() always returning None (bgo#531254)
  + Ability to compile only selected modules (bgo#534307)

-------------------------------------------------------------------
Fri Jun 20 17:14:56 CEST 2008 - maw@suse.de

- Update to version 2.23.0:
  + evolution:
    + Wrap e_source_peek_uid() as ebook.get_uid() and
      ecalsource.get_uid() (bgo#519258)
    + Wrap a bunch of additional APIs
  + gnomekeyring:
    + get_default_keyring_sync() always returning None (bgo#531254)
    + Ability to compile only selected modules (bgo#534307).

-------------------------------------------------------------------
Wed Apr  2 03:58:20 CEST 2008 - maw@suse.de

- Update to version 2.22.0:
  + Cosmetic version bump.

-------------------------------------------------------------------
Wed Mar  5 00:40:39 CET 2008 - maw@suse.de

- Update to version 2.21.3:
  + Evo calendar bug fixes
  + Fix gnomekeyring.find_network_password_sync erroneously
    returning None (bgo#516788).

-------------------------------------------------------------------
Mon Feb 25 17:31:47 CET 2008 - maw@suse.de

- Depend on totem-pl-parser-devel to build.

-------------------------------------------------------------------
Fri Feb  1 18:53:58 CET 2008 - maw@suse.de

- Update to version 2.21.2:
  + Add WAB build support
  + Better wnck API coverate
  + New evolution libeook and libecal bindings
  + gnome keyring erro code gandling fixes
  + Wrap evo_cal_component_[gs]et_status (bgo#505305)
  + Avoid multiply defined symbols in evolution modules
    (bgo#506401)
  + Fix builds against newer versions of metacity (bgo#505307)
  + Ensure that the evolution modules get a __version__
    attribute.

-------------------------------------------------------------------
Fri Nov  2 12:38:17 CET 2007 - sbrabec@suse.cz

- Build feature complete with gtksourceview18 and bug-buddy.

-------------------------------------------------------------------
Tue Oct  2 20:46:45 CEST 2007 - maw@suse.de

- Reinclude the metacity module (#237144).

-------------------------------------------------------------------
Wed Sep 19 13:50:55 CEST 2007 - sbrabec@suse.cz

- Updated to version 2.20.0:
  * stable version number

-------------------------------------------------------------------
Thu Aug  2 22:39:18 CEST 2007 - maw@suse.de

- Update to version 2.19.2:
  + With recent versions of pygtk, add a __version__ attribute to
    modules
  + All some paramaters to be None
  + Keep current with metacity API changes
  + Wrap WnckSelector
  + Use python-config to get python includes
- Use %fdupes.

-------------------------------------------------------------------
Fri Mar 30 12:25:24 CST 2007 - maw@suse.de

- Update to version 2.18.0
- Remove upstreamed totem-includes.patch
- b.g.o 416240 and 409252
- Updated metacity requirements.

-------------------------------------------------------------------
Tue Mar 27 15:02:35 CEST 2007 - sbrabec@suse.cz

- Do not require gtk-doc in runtime.
- Spec file cleanup.
- Split doc subpackage.

-------------------------------------------------------------------
Mon Mar 12 14:32:25 CST 2007 - maw@suse.de

- build-require gtk-doc
- add patch totem-includes.patch to fix up -I arguments when
  building.

-------------------------------------------------------------------
Thu Mar  8 18:24:40 CST 2007 - maw@suse.de

- Update to version 2.17.3.
  * general
   - Fix bad .pc file (#394172 alike)
  * totem.plparser
   - Fix to update to new/old totem.plparser.write API change (Gustavo)
  * bugbuddy
   - New bug-buddy integration module (#346106, Fernando Herrara, Gustavo)
  * gtksourceview
   - Improve repr() of gtksourceview.SourceLanguage (#351567)
   - make get_mime_types() returns the proper list (#351367, Paolo Borelli)
  * gnomekeyring
   - Fix build with Sun Forte compiler (#368364, Damien Carbery)
   - implementation of gnomekeyring.find_items_sync (#386366, Lukás Lalinský)
  * general
   - Py_ssize_t fixes, for python 2.5 + 64 bits (#338492)
  * gnomekeyring
   - Wrap item_create and item_get_info (Gustavo)
   - Fix sync example, add async example (Gustavo)
  * metacity
   - Update defs to follow upstream metacity API changes (Marc-Andre Lureau)
  * wnck
   - Add a new example (Kyle Brooks, Gustavo)
  * mediaprofiles
   - Use the gnome-python defs dir for gconf.defs (Marco Pesenti Gritti)
  * general
   - make check fixes (Gustavo)

-------------------------------------------------------------------
Thu Jan 18 23:55:42 CET 2007 - jhargadon@suse.de

- removed useless *.la files. (#223698)

-------------------------------------------------------------------
Wed Nov  8 00:32:28 CET 2006 - jhargadon@suse.de

- added totem-devel, nautilus-cd-burner-devel, gnome-media-devel,
  metacity to the BuildRequires so that the following parts get
  built:
    totem.plparser
    nautilusburn
    mediaprofiles
    metacity

-------------------------------------------------------------------
Mon Nov  6 22:08:45 CET 2006 - jhargadon@suse.de

- changed prefix to /usr to resolve bug #217660 

-------------------------------------------------------------------
Mon Oct 30 23:46:24 CET 2006 - jhargadon@suse.de

- changed python-gnome to python-gnome-devel in BuildRequires 

-------------------------------------------------------------------
Tue Oct  3 15:27:41 CEST 2006 - aj@suse.de

- Fix for lib64 systems.
- Use common macros.

-------------------------------------------------------------------
Mon Sep 11 23:00:58 CEST 2006 - jhargadon@suse.de

- added missing directory ownership to the specfile 

-------------------------------------------------------------------
Thu Sep  7 18:27:15 CEST 2006 - rodrigo@suse.de

- Initial submission from GNOME 2.16