File google-cloud-sdk.changes of Package google-cloud-sdk

-------------------------------------------------------------------
Fri Jun 27 14:16:56 UTC 2014 - rschweikert@suse.com

- Disable the Google built in "component" management and version upgrade
  mechanism
  + add hideImplicitVersionMgmt.patch

-------------------------------------------------------------------
Sat Jun 21 10:41:36 UTC 2014 - rschweikert@suse.com

- Fix setup file to properly include package data embedded in
  googlecloudsdk package, previously *.json files were missing

-------------------------------------------------------------------
Tue Jun 17 13:43:52 UTC 2014 - rschweikert@suse.com

- Remove debug print from setup.py
- Include templated html files as data files, these are used by the
  auth setup workflow

-------------------------------------------------------------------
Fri Jun  6 14:34:11 UTC 2014 - rschweikert@suse.com

- Remove unnecessary dependency on python-oauth2

-------------------------------------------------------------------
Thu Jun  5 14:11:50 UTC 2014 - rschweikert@suse.com

- Update to version 0.9.25
  + 'gcloud preview app deploy' and '... run' argument updates.
  + 'gcloud config *' argument updates.
  + Updated all AppEngine tools to 1.9.5
    - https://code.google.com/p/googleappengine/wiki/SdkReleaseNotes
    - https://code.google.com/p/googleappengine/wiki/SdkForJavaReleaseNotes
  + gcloud now has App Engine and Cloud Datastore integration.
    - Commands can be found under `gcloud preview app` and
      `gcloud preview datastore`
  + New `gcloud compute` tool for working with compute engine (RC)
    - Run `gcloud components update compute` to install
    - Run `gcloud help compute` for more information
  + Updated all AppEngine tools to 1.9.4
    - https://code.google.com/p/googleappengine/wiki/SdkReleaseNotes
    - https://code.google.com/p/googleappengine/wiki/SdkForJavaReleaseNotes
  + Added color to error and warning messages (on Linux and Mac)
    - To disable, run `gcloud config set disable_color true`
  + New 'gcloud help command'
    - Displays man style extended help for commands (where available).
  + New 'gcloud auth activate-service-account' command
    - Used to authenticate with gcloud using a service account key file.
    - See: https://developers.google.com/storage/docs/authentication#service_accounts
- Enable "big query" install and use
  + add patch bqHideDeps.patch
- Fix use of gcloud command
  + add patch gcloudFixPath.patch

-------------------------------------------------------------------
Thu Mar  6 14:56:17 UTC 2014 - rschweikert@suse.com

- Update to version 0.9.18
  + Updated all AppEngine tools to 1.9.0
      - https://code.google.com/p/googleappengine/wiki/SdkReleaseNotes
      - https://code.google.com/p/googleappengine/wiki/SdkForJavaReleaseNotes
  + New 'gcloud init' command
      - Creates a local workspace for your project with a git clone of
        your Google hosted repository.
  + Updated gcutil to 1.14.0
      - Switched to new, single API call for creating a virtual machine instance
        with a root persistent disk.
      - Added new command, 'setinstancediskautodelete', that sets the
        auto-delete option for persistent disks attached to virtual
        machine instances.
      - Added support for specifying a disk size when creating a disk using
        a snapshot.
      - Decreased the time spent waiting for SSH keys to propagate
        during initial instance creation from 120 seconds to 10 seconds.

-------------------------------------------------------------------
Thu Mar  6 12:46:52 UTC 2014 - rschweikert@suse.com

- Disable gcutil internal version check
- add patch: gcutilNoInternalVersionCheck.patch

-------------------------------------------------------------------
Thu Mar  6 01:19:04 UTC 2014 - rschweikert@suse.com

- Support the new boto config option and recognize the "system"
  keyword. Set the certificates file to None to use the system
  implementation
- add patch: gsutilSupportBotoCfgKeyword.patch

-------------------------------------------------------------------
Thu Feb 27 15:05:56 UTC 2014 - rschweikert@suse.com

- Add missing dependency to python-setuptools

-------------------------------------------------------------------
Thu Feb 27 14:47:49 UTC 2014 - rschweikert@suse.com

- Include in SLE 12 (FATE #316168)

-------------------------------------------------------------------
Wed Feb 26 20:54:38 UTC 2014 - rschweikert@suse.com

- Add missing package dependencies

-------------------------------------------------------------------
Wed Feb 26 18:18:01 UTC 2014 - rschweikert@suse.com

- Remove the dependency on python-oauth2, this is only needed when using
  the oauth2client delivered with the sdk tarball. However, we use the
  already packaged version of the client google-api-python-client which
  does not have that dependency. Thus the dependency is superfluos.

-------------------------------------------------------------------
Mon Feb 24 23:02:29 UTC 2014 - rschweikert@suse.com

- Fix the gcutilHideDeps.patch to hide requirements on python versions < 2.7
  this fixes build on SLE 11

-------------------------------------------------------------------
Mon Feb 24 22:33:46 UTC 2014 - rschweikert@suse.com

- Use the setup.py code of the "integrated" gsutil and gcutil code
  the toplevel gsutil and gcutil commands are useless wrappers that play
  extremely stupid tricks with the path and other stuff.
- Add patch gsutilHideDeps.patch and gcutilHideDeps.patch to hide the
  hard dependencies for gsutil and gcutil, respectively

-------------------------------------------------------------------
Thu Feb 20 22:45:26 UTC 2014 - rschweikert@suse.com

- Adjust version settings for obsoletes and provides

-------------------------------------------------------------------
Wed Feb 19 19:55:39 UTC 2014 - rschweikert@suse.com

- Initial build