File python-gnome.changes of Package python-gnome

-------------------------------------------------------------------
Fri Mar  1 12:46:22 UTC 2013 - dimstar@opensuse.org

- Spec-cleanup using format_spec_file service.

-------------------------------------------------------------------
Fri Jan  7 14:29:54 CET 2011 - vuntz@opensuse.org

- Split all python modules in subpackages, so we can have more
  fine-grained dependencies:
  + Create python-bonobo, python-gconf, python-gnomecanvas,
    python-gnomevfs subpackages.
  + Move some Requires to the relevant subpackages.
  + Ship a README.openSUSE file explaining the setup of the
    package.
- Move code examples to the devel subpackage.
- Add fdupes BuildRequires and use %fdupes.

-------------------------------------------------------------------
Wed Dec 15 11:34:17 CET 2010 - vuntz@opensuse.org

- Own /usr/share/pygtk/2.0/argtypes to fix build.

-------------------------------------------------------------------
Sun Aug  8 23:28:27 CEST 2010 - vuntz@opensuse.org

- Move .defs and gtk-doc files to devel subpackage.
- Do not call autoreconf without a reason.
- Pass --disable-static to configure.

-------------------------------------------------------------------
Wed Mar 31 01:56:48 CEST 2010 - vuntz@opensuse.org

- Update to version 2.28.1:
  + A couple of gconf module bugs fixed

-------------------------------------------------------------------
Sat Jan 23 20:01:50 CET 2010 - jengelh@medozas.de

- Package baselibs.conf.

-------------------------------------------------------------------
Tue Sep 29 10:25:24 CEST 2009 - vuntz@opensuse.org

- Update to version 2.28.0:
  + Bump version.
- Changes from version 2.27.1:
  + gnome: GOption support in gnome_program_init (bgo#507174)

-------------------------------------------------------------------
Tue Apr 21 19:14:15 CEST 2009 - matejcik@suse.cz

- update to 2.26.1
  * compatibility with newer modules
  * minor bugfixes
- removed dependency on python-numeric

-------------------------------------------------------------------
Tue Nov 25 17:39:07 CET 2008 - sbrabec@suse.cz

- Supplement gnome-vfs2-32bit/gnome-vfs2-64bit in baselibs.conf
  (bnc#354164).

-------------------------------------------------------------------
Thu Apr 24 17:21:23 CEST 2008 - maw@suse.de

- Remove some cruft from the spec file
- Use fewer globs in the file list (bnc#237144)
- Reduce build requirements.

-------------------------------------------------------------------
Mon Apr  7 17:23:40 CEST 2008 - matejcik@suse.cz

- updated to 2.22.0
  * mainly bugfixes and a few new calls available
  * html documentation for pygnomevfs
- included %sharedir/gtk-doc/html in directory list (not that
  the directories belong to this package, but it wouldn't work
  otherwise)

-------------------------------------------------------------------
Wed Sep 19 13:43:01 CEST 2007 - sbrabec@suse.cz

- Updated to version 2.20.0:
  * Fix typo in a gnomevfs error message
  * Change gnome-vfs-python-method.c header to LGPL
  * Add a __version__ attribute on some modules with new pygtk
  * Fix memory errors in gconf.Value.get_car/cdr()
  * wrap gnome_vfs_drive_needs_eject
  * Fix warning when reloading the gnome.ui module
  * use python-config to get python includes
  * Wrap gnome_vfs_mime_type_get_equivalence

-------------------------------------------------------------------
Thu Jul 26 19:47:25 CEST 2007 - jmatejek@suse.cz

- update to 2.18.2
  * upstream fixed Py2.5 ssize issues
  * various bugfixes

-------------------------------------------------------------------
Thu Feb 22 10:59:10 CET 2007 - sbrabec@suse.cz

- Removed reference to /opt/gnome (#242979).

-------------------------------------------------------------------
Tue Dec 19 16:29:05 CET 2006 - sbrabec@suse.cz

- Spec file cleanup.

-------------------------------------------------------------------
Thu Nov 30 16:25:56 CET 2006 - sbrabec@suse.cz

- Do not apply Py_ssize_t patch for older products.

-------------------------------------------------------------------
Tue Nov 14 17:59:56 CET 2006 - jhargadon@suse.de

- applied a patch to resolve inconsistent use of tabs and spaces
  mentioned in bug #220318 

-------------------------------------------------------------------
Mon Oct 23 16:42:39 CEST 2006 - jmatejek@suse.cz

- update to 2.16.0 (no changes, only promoted 2.15.90 to stable status)
- fixed some 64bit problems from PEP353 conversion

-------------------------------------------------------------------
Sat Sep 30 08:05:20 CEST 2006 - aj@suse.de

- Cleanup BuildRequires.

-------------------------------------------------------------------
Tue Sep  5 13:18:32 CEST 2006 - sbrabec@suse.cz

- Build all modules (fixed BuildRequires).

-------------------------------------------------------------------
Wed Aug 16 12:26:51 CEST 2006 - cthiel@suse.de

- split of -devel package
- buildrequire python-gtk-devel instead of python-gtk

-------------------------------------------------------------------
Thu Aug 10 20:12:49 CEST 2006 - jmatejek@suse.cz

- update to 2.15.90
- fixes issue that prevented build with new gnome-vfs and bonobo

-------------------------------------------------------------------
Sun Feb 19 17:31:26 CET 2006 - aj@suse.de

- Reduce BuildRequires.

-------------------------------------------------------------------
Wed Jan 25 21:32:37 CET 2006 - mls@suse.de

- converted neededforbuild to BuildRequires

-------------------------------------------------------------------
Thu Jan  5 15:44:44 CET 2006 - matejcik@suse.cz

- update to 2.12.3

-------------------------------------------------------------------
Wed Dec 14 20:05:53 CET 2005 - jmatejek@suse.cz

- update to 2.12.2

-------------------------------------------------------------------
Tue Dec 13 21:42:43 CET 2005 - gekker@suse.de

- removed nautilus and nautilus-devel from nfb, not needed and
causes a loop in the build system

-------------------------------------------------------------------
Mon Oct 17 02:40:11 CEST 2005 - ro@suse.de

- removed libzvt from neededforbuild (unused) 

-------------------------------------------------------------------
Mon Sep  5 18:12:41 CEST 2005 - gekker@suse.de

- Update to 2.12.0 (GNOME 2.12) 

-------------------------------------------------------------------
Wed Aug  3 00:14:56 CEST 2005 - gekker@suse.de

- update to 2.11.3 

-------------------------------------------------------------------
Tue Jul 12 12:43:24 CEST 2005 - ltinkl@suse.cz

- update to 2.11.2
- fix gnome-canvas build problems
- integrate the gnome-vfs module

-------------------------------------------------------------------
Thu Apr 14 16:52:02 CEST 2005 - mcihar@suse.cz

- update to 2.10.0

-------------------------------------------------------------------
Tue Feb  8 17:08:42 CET 2005 - mcihar@suse.cz

- update to 2.9.4

-------------------------------------------------------------------
Thu Jan 20 17:38:12 CET 2005 - mcihar@suse.cz

- update to 2.6.2

-------------------------------------------------------------------
Wed Nov 24 15:54:11 CET 2004 - mcihar@suse.cz

- update to 2.6.1

-------------------------------------------------------------------
Mon Nov 22 15:44:09 CET 2004 - ro@suse.de

- only use py_ver macro, py_libdir is broken on 9.0 and older

-------------------------------------------------------------------
Mon Aug 09 13:06:16 CEST 2004 - mcihar@suse.cz

- update to 2.0.3

-------------------------------------------------------------------
Mon Apr 19 15:49:44 CEST 2004 - mcihar@suse.cz

- compile python code with correct paths inside

-------------------------------------------------------------------
Thu Apr 15 20:26:25 CEST 2004 - mcihar@suse.cz

- update to 2.0.2
- drop gnome 1.4 support

-------------------------------------------------------------------
Tue Mar 16 17:59:59 CET 2004 - mcihar@suse.cz

- compile GNOME 1 version with -fno-strict-aliasing
- move gconf installation using distutils to same place as Makefiles
  install it (bug #36164)

-------------------------------------------------------------------
Fri Feb 20 15:49:55 CET 2004 - sbrabec@suse.cz

- Fixed names of GNOME2 packages.

-------------------------------------------------------------------
Wed Oct 15 15:32:45 CEST 2003 - mcihar@suse.cz

- record-rpm is really not needed
- don't build as root

-------------------------------------------------------------------
Sat Sep 13 12:39:45 CEST 2003 - ro@suse.de

- fix build (find gdk-pixbuf includes) 

-------------------------------------------------------------------
Tue Sep 02 19:08:34 CEST 2003 - mcihar@suse.cz

- updated to 2.0.0 (final GNOME 2 version, just minor bugfixes)

-------------------------------------------------------------------
Tue Aug 26 19:36:59 CEST 2003 - mcihar@suse.cz

- included sources missing from upstream
- moved gnome-vfs files into /opt/gnome

-------------------------------------------------------------------
Tue Aug 26 13:07:52 CEST 2003 - mcihar@suse.cz

- updated to 1.99.18:
    Many improvements were made to the gnome-print, bonobo, and
    gnome-vfs bindings. Some bugs with SIGCHLD handling were fixed.

-------------------------------------------------------------------
Tue Aug 19 15:26:02 CEST 2003 - sbrabec@suse.cz

- Updated neededforbuild (rename of librsvg2, eel2).

-------------------------------------------------------------------
Wed Aug 13 13:34:49 CEST 2003 - mcihar@suse.cz

- build more modules

-------------------------------------------------------------------
Wed Aug 06 15:06:11 CEST 2003 - mcihar@suse.cz

- added workaround for lib64 dirs and pkgconfig

-------------------------------------------------------------------
Tue Aug 05 15:36:42 CEST 2003 - mcihar@suse.cz

- use distutils when possible
- compile python files with correct paths inside
- fix pkgconfig file to not contain buildroot

-------------------------------------------------------------------
Mon Jul 14 16:52:11 CEST 2003 - sbrabec@suse.cz

- GNOME prefix change to /opt/gnome.

-------------------------------------------------------------------
Thu May 29 13:59:03 CEST 2003 - mcihar@suse.cz

- make executable only files that should be

-------------------------------------------------------------------
Tue May 27 12:34:48 CEST 2003 - mcihar@suse.cz

- fixed filelist

-------------------------------------------------------------------
Mon May 12 14:15:48 CEST 2003 - mcihar@suse.cz

- use versioned dependency on python

-------------------------------------------------------------------
Mon May 05 16:26:11 CEST 2003 - mcihar@suse.cz

- included also version for gnome 1.4, it is still needed for some apps (fixes
  bug #25150)
- included some examples and more documentation
- gnome 2 version updated to 1.99.16

-------------------------------------------------------------------
Thu Jan 23 11:33:23 CET 2003 - mcihar@suse.cz

- updated to 1.99.14

-------------------------------------------------------------------
Thu Jan 16 12:31:48 CET 2003 - ro@suse.de

- update neededforbuild 

-------------------------------------------------------------------
Mon Dec 02 11:23:08 CET 2002 - mcihar@suse.cz

- fixed filelist for lib64

-------------------------------------------------------------------
Thu Nov 28 00:32:37 CET 2002 - ro@suse.de

- added gnome-panel,libgtkhtml to neededforbuild 

-------------------------------------------------------------------
Wed Nov 27 18:11:29 CET 2002 - mcihar@suse.cz

- cleaned up specfile
- fixed building for lib64 (this is temporary, should be fixed in autoconf)

-------------------------------------------------------------------
Wed Nov 27 15:11:49 CET 2002 - mcihar@suse.cz

- version for GNOME 2