File rrdtool-lua-ruby_lib64.patch of Package rrdtool

Index: configure
===================================================================
--- configure.orig
+++ configure
@@ -27550,7 +27550,7 @@ fi
 if test "${enable_ruby_site_install+set}" = set; then
   enableval=$enable_ruby_site_install; RUBY_MAKE_OPTIONS=
 else
-  RUBY_MAKE_OPTIONS="sitedir=$langpref/lib/ruby"
+  RUBY_MAKE_OPTIONS="sitedir=$langpref/lib64/ruby"
 fi
 
 
@@ -29316,7 +29316,7 @@ fi
           done
         fi
 
-        LUA_RRD_LIBDIR="$langpref/lib/lua/$lua_vdot"
+        LUA_RRD_LIBDIR="$langpref/lib64/lua/$lua_vdot"
         # if lua 5.0 can't find compat-5.1, force installation of
         # compat-5.1.lua together with RRDtool.
         if test "$lua_vdot" = "5.0" -a "$LUA_HAVE_COMPAT51" != "HAVE_COMPAT51"; then
Index: configure.ac
===================================================================
--- configure.ac.orig
+++ configure.ac
@@ -675,7 +675,7 @@ fi
 dnl pass additional ruby options when generating Makefile from Makefile.PL
 AC_ARG_ENABLE(ruby-site-install,
 AS_HELP_STRING([--enable-ruby-site-install],[by default the rrdtool ruby modules are installed together with rrdtool in $prefix/lib/ruby. You have to add $prefix/lib/ruby/$ruby_version/$sitearch to your $: variable for ruby to find the RRD.so file.]),
-[RUBY_MAKE_OPTIONS=],[RUBY_MAKE_OPTIONS="sitedir=$langpref/lib/ruby"])
+[RUBY_MAKE_OPTIONS=],[RUBY_MAKE_OPTIONS="sitedir=$langpref/lib64/ruby"])
 
     
 AC_ARG_WITH(ruby-options,
@@ -782,7 +782,7 @@ LUA_EOF
           done
         fi
 
-        LUA_RRD_LIBDIR="$langpref/lib/lua/$lua_vdot"
+        LUA_RRD_LIBDIR="$langpref/lib64/lua/$lua_vdot"
         # if lua 5.0 can't find compat-5.1, force installation of
         # compat-5.1.lua together with RRDtool.
         if test "$lua_vdot" = "5.0" -a "$LUA_HAVE_COMPAT51" != "HAVE_COMPAT51"; then