File python-configobj.changes of Package python-configobj

-------------------------------------------------------------------
Wed Jul 23 13:04:31 UTC 2014 - fcastelli@suse.com

- Update to version 5.0.5:
  * BUGFIX: error in writing out config files to disk with non-ascii
    characters
  * BUGFIX: correcting that the code path fixed in 5.0.3 didn’t cover
    reading in config files
  * BUGFIX: not handling unicode encoding well, especially with respect to
    writing out files
  * Specific error message for installing version this version on Python
    versions older than 2.5
  * Documentation corrections
  * BUGFIX: Fixed regression on python 2.x where passing an encoding parameter
    did not convert a bytestring config file (which is the most common) to
    unicode. Added unit tests for this and related cases
  * BUGFIX: A particular error message would fail to display with a type error
    on python 2.6 only
  * Python 3 single-source compatibility at the cost of a more restrictive set
    of versions: 2.6, 2.7, 3.2, 3.3 (otherwise unchanged)

-------------------------------------------------------------------
Tue May 29 08:26:59 UTC 2012 - cfarrell@suse.com

- license update: BSD-3-Clause
  Refers only to the license available at
  http://www.voidspace.org.uk/python/license.shtml (which is BSD-3-Clause)

-------------------------------------------------------------------
Fri May 25 08:21:00 UTC 2012 - toddrme2178@gmail.com

- Spec file cleanups

-------------------------------------------------------------------
Sun Feb  5 19:40:33 UTC 2012 - dimstar@opensuse.org

- Really make the obsoletes sane: The package was called
  python-configobj-docs before, so that's what we need to obsolete
  (not -doc).
- The Obsoletes tag is for <= %{version}, as the package existed in
  version 4.7.2, which is also when it was merged back. Obsoleting
  only < 4.7.2 would cause conflicts when installing the newly
  merged package.

-------------------------------------------------------------------
Tue Jan 24 13:50:32 UTC 2012 - bwiedemann@suse.com

- fix Obsoletes

-------------------------------------------------------------------
Fri Dec  9 12:39:05 UTC 2011 - saschpe@suse.de

- Spec file cleanup:
  * Use upstream tarball
  * Obsoleted empty doc package
  * Fix SLE-11 build
  * Use upstream description

-------------------------------------------------------------------
Thu Dec  8 13:54:30 UTC 2011 - coolo@suse.com

- fix license to be in spdx.org format

-------------------------------------------------------------------
Mon Sep 13 22:07:25 CEST 2010 - dimstar@opensuse.org

- Update to version 4.7.2:
  + BUGFIX: Restore Python 2.3 compatibility
  + BUGFIX: Members that were lists were being returned as copies
    due to interpolation introduced in 4.7. Lists are now only
    copies if interpolation changes a list member.
  + BUGFIX: pop now does interpolation in list values as well.
  + BUGFIX: where interpolation matches a section name rather
    than a value it is ignored instead of raising an exception on
    fetching the item.
  + BUGFIX: values that use interpolation to reference members
    that don't exist can now be repr'd.
  + BUGFIX: Fix to avoid writing '\r\r\n' on Windows when given a
    file opened in text write mode ('w').

-------------------------------------------------------------------
Tue Jul 20 20:24:28 UTC 2010 - pascal.bleser@opensuse.org

- update to 4.7.1
- split out -docs subpackage

-------------------------------------------------------------------
Sun May 27 18:22:00 CEST 2007 - peter+rpmspam@suntel.com.tr

- add "unzip" as a builddep so it builds on Factory - 4.4.0

-------------------------------------------------------------------

Fri May 11 16:59:40 CEST 2007 - poeml@suse.de

- package created (copy from packman package) - 4.4.0