File vlc-projectM-qt5.patch of Package vlc

Index: vlc-3.0.0/configure.ac
===================================================================
--- vlc-3.0.0.orig/configure.ac
+++ vlc-3.0.0/configure.ac
@@ -3950,12 +3950,12 @@ AC_ARG_ENABLE(projectm,
   [  --enable-projectm       projectM visualization plugin (default enabled)])
 AS_IF([test "${enable_projectm}" != "no"],
   [
-    PKG_CHECK_MODULES(PROJECTM, libprojectM,
+    PKG_CHECK_MODULES(PROJECTM, libprojectM-qt5,
     [
       VLC_ADD_PLUGIN([projectm])
-      PKG_CHECK_EXISTS([libprojectM >= 2.0.0],
-        [ AC_DEFINE([HAVE_PROJECTM2], 1, [Define to 1 if using libprojectM 2.x]) ],
-        [ AC_MSG_WARN( [Using libprojectM version 1] )
+      PKG_CHECK_EXISTS([libprojectM-qt5 >= 2.0.0],
+        [ AC_DEFINE([HAVE_PROJECTM2], 1, [Define to 1 if using libprojectM-qt5 2.x]) ],
+        [ AC_MSG_WARN( [Using libprojectM-qt5 version 1] )
       ])
     ],[
       AC_MSG_WARN([${PROJECTM_PKG_ERRORS}.])
Index: vlc-3.0.0/modules/visualization/projectm.cpp
===================================================================
--- vlc-3.0.0.orig/modules/visualization/projectm.cpp
+++ vlc-3.0.0/modules/visualization/projectm.cpp
@@ -34,7 +34,7 @@
 #include <vlc_filter.h>
 #include <vlc_rand.h>
 
-#include <libprojectM/projectM.hpp>
+#include <libprojectM-qt5/projectM.hpp>
 
 #ifndef _WIN32
 # include <locale.h>