File vlc.changes of Package vlc

-------------------------------------------------------------------
Wed May  9 11:17:48 UTC 2018 - tchvatal@suse.com

- Add patch 0001-Update-czech-translation.patch to make czech
  usable without too many english strings (from upstream)

-------------------------------------------------------------------
Mon Apr 30 11:01:03 UTC 2018 - dimstar@opensuse.org

- Update to version 3.0.2:
  + Core:
    * Fix snapshotting with subtitles when using hardware acceleration
    * Fix green/missing line/column when the picture dimensions are odd
  + Decoders:
    * Important improvements in hardware decoding for macOS, notably faster,
      supporting more samples and removing crashes/deadlocks
    * Improve compatibility for DxVA2 and D3D11 decoding, fix crashes when seeking
      and fix blacklisting of broken drivers
    * Fix SSA subtitles forced alignment
    * Fix E-AC-3 stuttering
    * Fix MIDI playback on macOS
    * Add playback support for ProRes 4444 XQ
  + Demux:
    * Fix wrong colors in some AVI files
    * Fix IFO files playback to start DVDs
    * Fix a crash with missing/invalid MPEG SDT
    * Update VP8/9/10 ISOBMFF bindings and improve HDR for those cases
    * Fix TTML inside MP4
    * Improve MP4 read of color information
    * Fix flac seeking and improve flac parsing
    * Improve mkv opening & seeking speed
    * Fix display of chapters with no name defined
    * Miscellaneous MKV crash fixes
    * Fix crash with multi-region DVDs
    * Fix audio being muted on DVD chapter change
    * Fix audio being muted when seeking in a BluRay disc
  + Access: Avoid a crash/assert in FTP after seeking
  + Audio output:
    * Fix mmdevice default audio device handling
    * Fix "reset audio volume" being forcefully deactivated
    * Allow a default device to be used by VLC
    * Only warn once about misconfiguration for AUhal devices on macOS
    * Improve resampling and latency computation for CoreAudio
    * Passthrough is now disabled by default
  + Audio filters:
    * Fix audio stutter after unpausing with headphones
    * Fix silence when dolby-surround was mis-selected in preferences
  + Video output:
    * Fix OpenGL crashes or bad display with semi-planar chromas
    * Fix OpenGL interop (zero-copy) disabled for tvOS
    * Major rewrite of the iOS video output to fix numerous crashes
    * Important improvements of the D3D11 video output to use less memory
      and less GPU for HDR tone-mapping
    * Fix crop on vertical videos with Direct3D11
    * Fix Direct3D9 filters settings not being applied properly
    * Fix transform filters with hardware decoding
    * Fix snapshot and filters with HEVC hardware decoding
    * Fix a buffer overrun during GPU/CPU image copy
    * Fix glitches on DVD menus with Direct3D11
    * Fix non-HDR content playback on HDR screens with Direct3D11
    * Fix YUV full range displayed incorrectly in Direct3D11
    * Fix miscellaneous crashes in Direct3D11
    * Fix potential black screen with 10bits videos on Direct3D11
  + Qt:
    * Fix last folder used in open dialogs
    * Allow to customize the seek jump when using the mousewheel
    * Fix fullscreen controller positionment on multiscreen setups
    * Fix pasted URLs not being trimmed
    * Fix jump size not being configurable
    * Fix missing time labels updates
    * Fix playback speed slider not accepting 1.0x value
    * Fix raw input dump
    * Fix window size after a fullscreen playback
  + Misc:
    * Fix lua rc & oldrc interfaces host specification
    * Fix crashes when searching for renderers
    * Relocate localedir for Linux (improves snap i18n support)
    * Fix VDPAU GLX usage on Linux
    * Improve support for NetBSD
    * Fix MSI script for Windows
    * Fix libvlc_media_list not going to next media
    * Fix character encoding on win32 consoles
    * Miscellaneous chromecast improvements
    * Fix missing OSD navigation feedback
    * Various VLSub improvements
    * lua: Fix scripts not being loaded on some filesystems
    * lua: Add vlc.io APIs to handle UTF-8 paths
- Drop arm-neon-asm.patch: fixed upstream.
- Add vlc-lua-5.3.patch: fix build with LUA 5.3.

-------------------------------------------------------------------
Tue Mar 27 09:27:58 UTC 2018 - dimstar@opensuse.org

- Pass explicit --enable-chromecast to configure: ensure the module
  does not accidentally get disabled.

-------------------------------------------------------------------
Thu Mar 22 09:05:53 UTC 2018 - schwab@suse.de

- arm-neon-asm.patch: add forgotten file

-------------------------------------------------------------------
Tue Mar 20 08:33:37 UTC 2018 - dimstar@opensuse.org

- Add explicit mpg123-devel BuildRequires: on Leap/TW it was
  already pulled in by openmpt-devel, but being explicit is better.

-------------------------------------------------------------------
Mon Mar 19 15:31:44 UTC 2018 - dimstar@opensuse.org

- Explicitly call autoreconf: vlc-projectM-qt5.patch touches the
  build system.
- Apply said patch only for suse_version > 1320: Leap 42.x used the
  Qt4 based projectM.

-------------------------------------------------------------------
Mon Mar 19 11:14:46 UTC 2018 - dimstar@opensuse.org

- Fix build for Leap 42.x: BuildRequire gcc7-c++ and export
  CXX=/usr/bin/g++-7: we need a c++11 compiler.

-------------------------------------------------------------------
Mon Mar 19 09:01:10 UTC 2018 - dimstar@opensuse.org

- Conditionalize wayland dependencies to only match suse_version >=
  1500.

-------------------------------------------------------------------
Mon Mar  5 14:19:35 UTC 2018 - dimstar@opensuse.org

- Update to version 3.0.1:
  + Demux:
    * Fix wrong colors in some AVI files.
    * Fix IFO files playback.
    * Fix a crash with missing/invalid MPEG SDT.
  + Audio output:
    * Fix mmdevice default audio device handling.
    * Fix "reset audio volume" being forcefully deactivated.
    * Allow a default device to be used by VLC.
  + Audio filters: Fix audio stutter after unpausing.
  + Misc: Fix lua rc & oldrc interfaces host specification.

-------------------------------------------------------------------
Wed Feb 28 22:20:56 UTC 2018 - bjorn.lie@gmail.com

- Split out new vlc-jack sub-package, add post(un) handling and
  devel subpackage Requires.
- Split out new conditional vlc-vdpau sub-package, add post(un)
  handling and devel subpackage Requires.
- The rational for the above splits is allowing users to select
  what features they need and want, avoiding in many cases unwanted
  dependencies, vdpau support is only available for third party
  builds, and jack (real time audio) is really just for a select
  few of our end-users.
- Run spec-cleaner, modernize spec, sort file lists.

-------------------------------------------------------------------
Sat Feb 24 13:02:40 UTC 2018 - bjorn.lie@gmail.com

- Add conditional pkgconfig(x265) BuildRequires and pass
  conditional --enable-x265 or --disable-x265, package resulting
  plugin in vlc-codecs subpackage (boo#1081608).
- Add conditional pkgconfig(fdk-aac) BuildRequires and pass
  conditional --enable-fdkaac or --disable-fdkaac, package
  resulting plugin in vlc-codecs subpackage.

-------------------------------------------------------------------
Thu Feb 22 17:14:17 UTC 2018 - dimstar@opensuse.org

- Move libmpeg2 dependency/plugin out of the BUILD_ORIG condition,
  as openSUSE now contains/ships the library.

-------------------------------------------------------------------
Sun Feb 18 10:01:28 UTC 2018 - dimstar@opensuse.org

- Add vlc-allow-deprecated-fribidi.patch: Allow the usage of
  deprecated fribidi functions. Disallowing deprecated stuff is
  good during the dev phase, but once released, it is just becoming
  a pain.

-------------------------------------------------------------------
Wed Feb 14 20:12:18 UTC 2018 - bjorn.lie@gmail.com

- Move liba52-devel, libmad-devel and pkgconfig(twolame)
  BuildRequires from conditional BUILD_ORIG to standard build, now
  available in openSUSE. Following this, remove --disable-a52 and
  --disable-mad and move --enable-a52 and --enable-mad to normal
  part of configure calls. Add a --enable-twolame configure call to
  ensure we build twolame support.

-------------------------------------------------------------------
Mon Feb 12 10:52:18 UTC 2018 - dimstar@opensuse.org

- Add cache regeneration post/postun scriptlets to gstreamer-codec
  subpackage.

-------------------------------------------------------------------
Thu Feb  8 12:39:26 UTC 2018 - dimstar@opensuse.org

- Update to Version 3.0.0:
  + Core:
    - Support network browsing for distant filesystems (SMB, FTP,
      SFTP, NFS...) and rewrite the parsing of the media files and
      inputs.
    - Support keystores: fetch and store passwords securely (sic!)
      for common protocols (HTTP, SMB, SFTP, FTP, RTSP ...).
    - Autodetect external audio tracks (ac3, m4a, aac, dts...)
      similar to subtitles.
    - Support HDMI passthrough for Audio HD codecs, like E-AC3,
      TrueHD or DTS-HD.
    - Support for 12bits codec and extended colorspaces (HDR).
    - Support output renderers, like ChromeCast.
    - VLC now assumes vlcrc config file is in UTF-8.
    - Support portable version of Windows build (create a
      "portable/" folder).
    - Support wayland surface type.
    - Allow to start the video paused on the first frame.
    - Refactor preparsing input.
    - EPG rework: table and single event updates, now using network
      time.
    - Refactor and fix subtitles es selection. Demuxers can now
      override es category single only or multiple es behavior.
    - Support for 360 video and audio, including viewpoint
      modification.
    - Support for ambisonic audio and more than 8 audio channels.
    - Support subtitles size live adjustments.
  + For a full list of changes to the various modules, see the
    packaged NEWS file.
- Rebase vlc-projectM-qt5.patch and vlc.a52.patch.
- Drop obsoleted patches: 0001-no-return-in-non-void.patch,
  vlc-support-qt5.5.patch, vlc-gcc6-buildfixes.patch,
  vlc-2.2.0-fix_deinterlace_mmx.patch.

-------------------------------------------------------------------
Sun Dec  3 16:20:45 UTC 2017 - dimstar@opensuse.org

- Disable projectM on non-x86(_64) archs (boo#1070913).

-------------------------------------------------------------------
Sun Nov 26 23:21:35 UTC 2017 - joerg.lorenzen@ki.tng.de

- Update to version 2.2.8:
  + Demuxers: Fix AVI invalid pointer dereferences.
  + Updated translations.
- Changes from version 2.2.7:
  + Decoders:
    - Fix flac heap write overflow on format change.
    - Fix crash in libavcodec module (heap write out-of band)
      CVE-2017-10699.
    - Fix infinite loop in sami subtitle.
    - Fix AAC 7.1 channels detection.
    - Fix potential crash in ASX parser.
  + Mac OS X:
    - Fix compatibility with macOS High Sierra.
    - Fix regression in ASS subtitle decoding.
    - Fix crash during automatic update. Some users might need to
      manually update to the newest version.
  + Video Output: Fix Direct3D9 output with odd offsets.
  + Misc:
    - Fix crash in MTP.
    - Support libupnp 1.8.
  + Updated translations.
- Removed vlc-flac-heap-overflow.patch, fixed upstream.

-------------------------------------------------------------------
Tue Nov 14 16:14:57 UTC 2017 - dimstar@opensuse.org

- Prepare for Tumbleweed potentially changing suse_version: request
  ffmpeg2 for all suse_version >= 1330 (not == 1330 only).

-------------------------------------------------------------------
Thu Sep 21 11:20:24 UTC 2017 - dimstar@opensuse.org

- Add vlc-flac-heap-overflow.patch: flac: fix heap write overflow
  on frame format change (CVE-2017-9300, boo#1041907).

-------------------------------------------------------------------
Tue Sep 19 15:08:45 UTC 2017 - dimstar@opensuse.org

- Stop depending on libkde4-devel: It's only used to find the
  install path for kde4, but configure falls back to the correct
  default for openSUSE anyway (boo#1057736).

-------------------------------------------------------------------
Fri Aug 11 14:20:29 UTC 2017 - aloisio@gmx.com

- Added vlc-projectM-qt5.patch and applied it for Factory

-------------------------------------------------------------------
Mon Jul 24 06:37:10 UTC 2017 - olaf@aepfle.de

- Adjust to API change in a52dec with vlc.a52.patch

-------------------------------------------------------------------
Thu Jun 22 15:34:58 UTC 2017 - dimstar@opensuse.org

- Disable vnc access module: it does not work in my current tests.

-------------------------------------------------------------------
Fri May 26 14:28:36 UTC 2017 - dimstar@opensuse.org

- Update to version 2.2.6:
  + Video output:
    - Fix systematic green line on nvidia.
    - Fix direct3d SPU texture offsets handling.
  + Demuxer: Fix heap buffer overflows.
- Changes from version 2.2.5.1:
  + Security hardening for DLL hijacking environments.
- Changes from version 2.2.5:
  + Decoder:
    - Fix mp3 playback quality regression in libmad.
    - Fix video scaling in VDPAU.
    - Fix playback of palettized codecs.
    - Fix ADPCM heap corruption (FG-VD-16-067).
    - Fix AES3 16bps decoding.
    - Fix DVD/LPCM heap corruption (FG-VD-16-090).
    - Fix SCTE-27 colors.
  + Demuxer:
    - Fix possible ASF integer overflow.
    - Fix MP4, VOC, XA, SMF divide-by-zero errors.
    - Fix MP4 heap buffer overflows.
    - Fix Flac metadata integer overflow.
    - Fix NSVf and AIFF infinite loops.
    - Fix flac null-pointer dereference.
    - Fix vorbis and opus comments integer overflows and leaks.
  + Video output:
    - Fix green line on Windows with AMD drivers.
    - Fix screenshots size.
  + Access:
    - Fix crash in screen recording on Windows.
    - Fix FTP scan string injection.
    - Fix HTTP size handling.
  + Mux: Fix mp4 drift.
  + Lua: Fix vimeo, youtube, dailymotion, cli, appletrailers, http,
    soundcloud scripts.
  + Audio filter: Fix heap write in stereo_widen audio filter.
- Rebase 0001-no-return-in-non-void.patch.
- Drop vlc-2.1.5-fix-skins2-default-skin-creation.patch: this
  should really not be required anymore.

-------------------------------------------------------------------
Wed May  3 06:57:57 UTC 2017 - dimstar@opensuse.org

- Replace libmodplug-devel BuildRequires with
  pkgconfig(libmodplug): this helps with the migration from
  libmodplug to openmpt.

-------------------------------------------------------------------
Tue Nov 29 14:21:37 UTC 2016 - dimstar@opensuse.org

- Expand the lang_package macro in order to change the dependency
  to be on vlc-noX instead of vlc. USers of headless installed
  vlc might still be interested in translations too (boo#1012556).

-------------------------------------------------------------------
Wed Sep 28 18:54:45 UTC 2016 - dimstar@opensuse.org

- Require libavcodec<ABI>(unrestricted) (<ABI> is automatically
  discovered during build based on what libavcodec.so links to)
  from vlc-codecs. This ensures that users installing vlc-codecs
  will get a prompt to replace the distro-provided libavcodec
  package - which is restricted in its formats. This requires the
  user to accept a vendor change.

-------------------------------------------------------------------
Tue Sep 20 17:32:50 UTC 2016 - jengelh@inai.de

- Drop VLC from summaries (rpmlint: name-repeated-in-summary).
  Improve summaries and descriptions.

-------------------------------------------------------------------
Tue Sep 20 17:08:50 UTC 2016 - dimstar@opensuse.org

- Update summaries: 'VLC' is sufficiently known by now - and nobody
  really remembers the name 'Video Lan Client'.

-------------------------------------------------------------------
Fri Sep 16 14:24:01 UTC 2016 - dimstar@opensuse.org

- Rename vlc-noX-lang to vlc-lang: this helps the AppStream builder
  in confirming that 'vlc' (the application) does have a full
  translation set. Obsolete vlc-noX-lang by vlc-noX directly.

-------------------------------------------------------------------
Mon Sep  5 07:56:44 UTC 2016 - dimstar@opensuse.org

- Drop vlc-2.2.4-unambig-shortcuts.patch: it does not solve the
  problem it attempted to solve to start with. A better solution
  is to be found with upstream.

-------------------------------------------------------------------
Sun Sep  4 09:23:25 UTC 2016 - dimstar@opensuse.org

- Update vlc-2.2.4-unambig-shortcuts.patch: Also make ALT-P
  unambiguous.

-------------------------------------------------------------------
Wed Aug 31 10:54:00 UTC 2016 - dimstar@opensuse.org

- Also use ffmpeg2-devel BuildRequires on Leap 42.2 (sle_version
  120200).

-------------------------------------------------------------------
Mon Aug 22 09:12:46 UTC 2016 - dimstar@opensuse.org

- Add ffmpeg2-devel BuildRequires for Tumbleweed: older openSUSE
  versions had ffmpeg 2.x in the distribution.

-------------------------------------------------------------------
Wed Aug 10 16:30:31 UTC 2016 - dimstar@opensuse.org

- BuildConflict pkgconfig(libavutil) >=55: vlc 2.2.x is not yet
  compatible with these updates.

-------------------------------------------------------------------
Tue Aug  9 11:14:19 UTC 2016 - dimstar@opensuse.org

- Enable avcodec on openSUSE since ffmpeg had been in the distro
  since Leap 42.1.

-------------------------------------------------------------------
Thu Aug  4 18:59:44 UTC 2016 - dimstar@opensuse.org

- Build GStreamer plugin support:
  + Add pkgconfig(gstreamer-app-1.0) BuildRequires.
  + Split out new package vlc-codec-gstreamer, which is triggered
    for automatic installation if vlc-noX and libgstapp are present
    on the system. By using the GStreamer extension one can make
    use of all available addons there (incl. OnePlay codec packs).

-------------------------------------------------------------------
Thu Aug  4 14:41:44 UTC 2016 - dimstar@opensuse.org

- Add vlc-2.2.4-unambig-shortcuts.patch: Make keyboard shortcuts
  in open dialog unambiguous.

-------------------------------------------------------------------
Wed Aug  3 03:19:18 UTC 2016 - badshah400@gmail.com

- Add and install appdata file.

-------------------------------------------------------------------
Sun Jul 10 16:15:58 UTC 2016 - suse@tleine.de

- disable freerdp module support on openSUSE Leap 42.2. It
  has freerdp 2.

-------------------------------------------------------------------
Thu Jun 23 11:16:23 UTC 2016 - meissner@suse.com

- build binaries as PIE (position independend executable).

-------------------------------------------------------------------
Mon Jun 13 08:52:18 UTC 2016 - dimstar@opensuse.org

- Update to version 2.2.4:
  + Decoder:
    - Fix crash in G.711 wav files.
    - Fix mp3 crash in libmad.
    - Fix out-of-bound write in adpcm QT IMA codec (CVE-2016-5108,
      boo#984382).
  + Qt: Fix resizing issues.
  + Win32: Fix overlay creation on Windows XP for DirectDraw video
    output.
  + Misc: Build fixes for Hurd.
  + Updated translations.

-------------------------------------------------------------------
Tue May 24 13:39:13 UTC 2016 - dimstar@opensuse.org

- Add vlc-gcc6-buildfixes.patch: fix build with GCC 6. This patch
  file is a collection of the backported commits from master:
  + 5d26efcad8d1aa5023028e3caa5a608b5e1d81fe
  + 406f697d5592752efc8a0479e48512ed20ab274b
  + 569df08d1be561022b86ce9c58dece388532e818
  + 45495aa458ef6856ee9eb18860706149148bb660
  + a7a70e8163e04244d733f4745dc8cbbc7502b830
  + ada4b4748eefcfd22f1417ed223f1381c694aa60
  + 0bcb7fd2567ba494b730234609b146cd8e23483c
  + 59678ec0b489d86f6f62cc987e21a82346f8da42
  + e8b683357b2ccc2bbd1ffbcb4783441a3620a6ea
  + ab550d60dd8d823b8ddacd2d4759f0840a9ea352
  + f5d5cb75768b692359068e837f72c9fd7cf6bd45
  + c5f80f5bc4cb498c8eb7469650437e92ae6d085a
  + 66842e08e177e3c458fa0e4db970deae84feb625
  + 98b4e987252f798213effa5ed6d19d958d6d9d42
  + d2571e643edb0f1cb217805ef8d5ac172d59a864
- Disable atmoLight sensor: pass --disable-atmo to configure. This
  module fails to build with GCC 6 and has been removed upstream
  for the next version of VLC already (671304).

-------------------------------------------------------------------
Mon May 23 10:09:24 UTC 2016 - dimstar@opensuse.org

- Disable freerdp module support on openSUSE Tumbleweed: VLC has
  not been ported to FreeRDP 2.0.

-------------------------------------------------------------------
Tue May  3 07:33:21 UTC 2016 - dimstar@opensuse.org

- Update to version 2.2.3:
  + Demux:
    - Fix HLS quality selection and a potential stack overflow.
    - Fix potential MKV infinite loop and improve MKV tags support.
    - Fix WMV regression.
  + Decoder:
    - Fix hardware decoding with libvdpau-va-gl.
    - Fix crashes with libvpx.
    - Use libass without caching dialog.
  + Video Ouptut: Fix green lines on Direct3D output.
  + Skins2: Fix maximizing Window in multi-screen context.
  + Qt:
    - Fix resume where you left off.
    - Fix infinite recursion in the customize dialog.
    - Fix size when switching to/from the minimal interface.
    - Fix size after resume toolbar is displayed.
  + MacOS X:
    - Fix crashes in media information panel.
    - Correctly respect the disable-screensaver option.
  + Win32: Allow opening more than 15 elements in Explorer.
  + Updated translations.

-------------------------------------------------------------------
Wed Mar 16 10:32:14 UTC 2016 - dimstar@opensuse.org

- Disable deprecated gnome-vfs2 support (that was GNOME 2 tech):
  + Replace --enable-gnomevfs configure parameter with
    --disable-gnomevfs.
  + Remove gnome-vfs2-devel BuildRequires.
  + Drop -gnome subpackage and obsolete it by the main package.

-------------------------------------------------------------------
Fri Feb  5 21:28:01 UTC 2016 - dimstar@opensuse.org

- Update to version 2.2.2:
  + libVLC:
    - Expose audio mute, cork and volume change events:
      libvlc_MediaPlayerCorked, libvlc_MediaPlayerUncorked,
      libvlc_MediaPlayerMuted, libvlc_MediaPlayerUnmuted and
      libvlc_MediaPlayerAudioVolume.
    - Fix propagation of libvlc_MediaPlayerTitleChanged event.
  + Access:
    - Fix SetupFormat for continuous framesize in v4l2.
    - Fix off-by-one buffer overflow in RealRtsp module.
    - Fix screen recording aspect-ratio, framerate and potential
      crash.
    - Fix Windows directshow input freeze.
    - Fix MMS segmentation fault/abort when server forces a large
      allocation.
  + Demux:
    - Fix support for ms-dvr files.
    - Fix time detection in AVI files over HTTP.
    - HLS: fix hang on stop, crashes and small improvements.
    - Fix mp4 NULL dereference reported by by Fortinet's FortiGuard
      Labs.
    - Fix regression for VC-1 in WMV.
    - Fix MXF crashes on stop.
    - Fix EAC3 detection in some TS files.
  + Decoders:
    - Fix importing surface from main memory in VDPAU.
    - Fix possible double-free in ADPCM decoder.
    - Support 9-bit and 10-bit GBR planar formats.
    - Support GoToMeeting 2 and GoToMeeting 3 codecs.
    - Fix crash in teletext (zvbi) decoder.
    - Fix Bluray subtitles (PGS) timestamps.
  + Audio output:
    - Fix audio drop after a flush with pulseaudio.
    - Fix audio initialization on iOS.
    - Fix audio stuttering with AirPlay devices on OS X (2 sec
      delay needs to be set manually by the user).
    - Fix pulseaudio latency computation.
    - Fix alsa default device selection.
  + Skins2:
    - Fix video control that fails to show up.
    - Fix UTF-8 conversion issues.
    - Fix Unicode folders location failing to open the skins.
    - Fix crash over malformed skins bitmaps.
    - Fix fullscreen for Gnome3/Unity Window Managers.
  + OS X fixes.
  + Qt:
    - Fix crash when opening multiple items on Windows.
    - Fix recent items appending when using a playlist.
    - Improve addons manager dialog, playlist.
    - Fix changing the audio-device in the menu.
    - Fix key and mouse event support for Qt >= 5.5 under X11.
    - Fix memory leaks.
  + Video Output:
    - Fix build if one disables XCB but activate VDPAU on Unix.
    - Fix Direct3D plane allocation size to avoid colour bleeding.
    - Fix some crashes in swscale resizing.
  + Misc:
    - Fix build with recent FreeRDP versions.
    - Fix interface crashes when input-title-format option is
      empty.
    - Fix MP4 mux divide-by-zero crash.
    - Improve PNG encoding time.
    - Fix some UPnP initialization lag.
    - Rewrite of the Jamendo Service Discovery.
    - Fix snapshot aspect ratio for anamorphic contents.
    - Fix custom snapshot sizes.
    - Dynamic generation of GnuTLS Diffie-Hellman parameters.
    - Fix "vb" transcoding parameter.
    - Fix superfluous audio channel extraction in the core.
    - Fix miscellaneous crashes, double-frees, integer overflows,
      infinite loops, read overflow, invalid frees and division by
      zero issues.
    - Fix support for lua 5.2 and fix XSS in the http interface.
    - Update and improve Soundcloud, Vimeo and Youtube scripts.
    - Update of codecs and libraries to fix 3rd party security
      issues (like TALOS-CAN-0036, TALOS-CAN-0037, CVE-2015-7981,
      CVE-2015-8126).
  + Updated translations.
- Drop vlc-CVE-2015-5949.patch and vlc-qt5.5-mousepointer.patch:
  fixed upstream.
- Add vlc-support-qt5.5.patch (reverse applied): The Qt 5.5 package
  in Leap and Tumbleweed have been patched to have the fix upstream
  wanted to make us aware of with this commit.

-------------------------------------------------------------------
Fri Feb  5 09:07:03 UTC 2016 - dimstar@opensuse.org

- Add vlc-CVE-2015-5949.patch: demux: mp4: correctly match release
  function (boo#965227, CVE-2015-5949).

-------------------------------------------------------------------
Mon Jan  4 08:50:53 UTC 2016 - ctrippe@opensuse.org

- Install the solid action desktop files also in /usr/share/solid/actions
  to make them available in Plasma5 (boo#960621)

-------------------------------------------------------------------
Mon Dec 28 06:49:35 UTC 2015 - wbauer@tmo.at

- Build against libQt5X11Extras5 on Leap as well to make video
  integration into the GUI work (boo#953693)
- Also add BuildRequires: pkgconfig(xi), without it the build fails
  on Leap now

-------------------------------------------------------------------
Tue Dec 15 09:30:13 UTC 2015 - dimstar@opensuse.org

- Enable libupnp support on Leap 42.1: the library is available
  (boo#959100).

-------------------------------------------------------------------
Mon Dec  7 03:07:12 UTC 2015 - dimstar@opensuse.org

- Add vlc-qt5.5-mousepointer.patch: Fix mouse cursor in video
  interface (boo#956769).

-------------------------------------------------------------------
Tue Dec  1 10:37:35 UTC 2015 - lnussel@suse.de

- libvlc_vdpau needs to be in codecs package to avoid dependency issue

-------------------------------------------------------------------
Sun Nov 22 21:14:44 UTC 2015 - jdelvare@suse.com

- Don't pass --enable-dca unconditionally, it is handled later with
  a condition.

-------------------------------------------------------------------
Wed Sep  2 20:10:21 UTC 2015 - wbauer@tmo.at

- Modify vlc-2.1.5-fix-skins2-default-skin-creation.patch to patch
  Makefile.am instead of Makefile.in: autoreconf overwrote the
  change, making the patch totally ineffective and thus the default
  skin was broken

-------------------------------------------------------------------
Fri Jul 24 12:28:32 UTC 2015 - dimstar@opensuse.org

- Fix build with LUA 5.3 / 5.3.1.

-------------------------------------------------------------------
Fri May 15 10:11:17 UTC 2015 - joerg.lorenzen@ki.tng.de

- Enabled VPX support.

-------------------------------------------------------------------
Wed May 13 15:46:45 UTC 2015 - aloisio@gmx.com

- Enabled Qt5 for targets that support it.

-------------------------------------------------------------------
Fri May  1 18:22:44 UTC 2015 - jengelh@inai.de

- Enable ffmpeg for newer openSUSE

-------------------------------------------------------------------
Tue Apr 28 19:30:49 UTC 2015 - tittiatcoke@gmail.com

- Regenerate the cache for all packages that install plugins.
  This otherwise would cause issues during the switch from Qt4-Qt5

-------------------------------------------------------------------
Fri Apr 24 10:07:55 UTC 2015 - joerg.lorenzen@ki.tng.de

- Build against qt5 for openSUSE > 13.2.

-------------------------------------------------------------------
Tue Apr 21 12:33:01 UTC 2015 - seife+obs@b1-systems.com

- remove build host name (again) from binaries

-------------------------------------------------------------------
Tue Apr 14 10:38:47 UTC 2015 - aloisio@gmx.com

- Removed DTV/DVB patch that was fixed upstream.

-------------------------------------------------------------------
Mon Apr 13 14:59:16 UTC 2015 - joerg.lorenzen@ki.tng.de

- Update to version 2.2.1:
  + Codec:
    - Fix compilation with older libavcodec versions.
    - Fix some VP9 decoding.
    - Fix flac crashes.
    - Fix lpcm channel ordering.
    - Fix potential NULL dereference in dmo.
    - Fix teletext framing code in DVB PES packets.
    - Fix potential buffer overflow in schroendinger decoder.
    - Fix AAC samplerate.
  + Demuxers:
    - Fix MP4 chapters.
    - Fix MKV overseeking, introducing slowness over network shares.
    - Fix crash when playing SPC files.
    - Fix ATRAC3 playback in MKV.
    - Revert to older ASX code.
    - Workaround TS issue with mpeg-audio.
  + Access:
    - Fix sftp read and close sockets.
    - Fix DTV build with Linux DVB versions < 5.8.
    - Fix UDP/RTP input on Windows.
  + Audio output:
    - Fix Alsa HDMI plugs.
    - Improve Alsa output, with larger buffers.
    - Fix DirectSound output with multi-channel files.
  + OS X:
    - Fix numerous crashes in the UI.
    - Fix video-wallpaper mode.
    - Fix race when starting VLC from command line.
  + Qt:
    - Fix recent items behaviour.
    - Fix rotation filter activation.
    - Fix mux modules names for the streaming wizard.
  + Win32:
    - Timestamp the signature of the dlls.
    - Fix extensions registration during install.
    - Fix extensions dialog crash.
    - Default to no DxVA decoding.
  + libVLC:
    - fix libvlc_media_get_stats.
  + Updated translations.
- Fixed patch 0001-no-return-in-non-void.patch.

-------------------------------------------------------------------
Sun Apr 12 08:47:32 UTC 2015 - dimstar@opensuse.org

- Require at least the version of libbluray1 that was used during
  build. libbluray.so.1 has a strange ABI diff between 0.3 and 0.7.
  Libbluray had an API/ABI break at 0.5, which was not represented
  in a soname bump (boo#926842).

-------------------------------------------------------------------
Tue Mar 31 10:18:25 UTC 2015 - dvlaeev@suse.com

- Fix package lists for PowerPC architectures.

-------------------------------------------------------------------
Tue Mar 17 15:21:39 UTC 2015 - dimstar@opensuse.org

- Move vlc.desktop vlc package: AppStream bases the addition of
  packages to the store based on the .desktop file (which
  identifies the application). In case of VLC, we want to present
  'the full set' as part of the App Stores.

-------------------------------------------------------------------
Wed Mar  4 11:09:14 UTC 2015 - dimstar@opensuse.org

- Reintroduce calling {_libdir}/vlc/vlc-cache-gen during post.

-------------------------------------------------------------------
Tue Mar  3 15:00:18 UTC 2015 - aloisio@gmx.com

- made fludsynth optional again out of caution
- added vlc-2.2.0-fix_deinterlace_mmx.patch to make
  SLE11/i586 build without a recent enough gcc
- fixed SLE11 to build without automake >= 1.11
- fixed a SLE12 build problem on packman
- removed hevc plugins in a cleaner way

-------------------------------------------------------------------
Sun Mar  1 18:05:03 UTC 2015 - aloisio@gmx.com

- enabled ncurses for Factory
- enabled fluidsynth unconditionally
- enabled libcdio
- enabled x265 for packman
- fixed SLE11/SLE12 build
- added vlc-rpmlintrc to suppress bogus warnings
- added manpages for the various versions of vlc
  as link to the main one

-------------------------------------------------------------------
Fri Feb 27 18:28:17 UTC 2015 - dimstar@opensuse.org

- Update to version 2.2.0:
  + Long awaited update with a huge changelog. Please see the
    content of /usr/share/doc/packages/vlc/NEWS.
- Drop vlc-CVE-2014-9625.patch: fixed upstream.

-------------------------------------------------------------------
Wed Feb  4 10:11:09 UTC 2015 - dimstar@opensuse.org

- Add vlc.changes as source so that we can reliably access it
  during build, even when using the .src.rpm.

-------------------------------------------------------------------
Thu Jan 22 15:03:10 UTC 2015 - dimstar@opensuse.org

- Add vlc-CVE-2014-9625.patch: Fix various buffer overflows and
  null ptr dereferencing (boo#914268, CVE-2014-9625).

-------------------------------------------------------------------
Sun Nov  9 16:06:10 UTC 2014 - seife+obs@b1-systems.com

- fix skins2 defaut.vlt generation with newer tar defaults (and
  remove the embedded build date from it on the way)
  vlc-2.1.5-fix-skins2-default-skin-creation.patch
- remove buildhost hostname from the binary to avoid republishing

-------------------------------------------------------------------
Thu Oct 30 06:08:06 UTC 2014 - olaf@aepfle.de

- Convert BuildRequires from foo-devel to pkgconfig(foo)

-------------------------------------------------------------------
Fri Oct 24 07:47:58 UTC 2014 - dimstar@opensuse.org

- First attempts on enabling build for SLE-12.

-------------------------------------------------------------------
Thu Oct  9 18:37:20 UTC 2014 - vindex17@outlook.it

- Enable SSE2 instruction set for x86_64

-------------------------------------------------------------------
Tue Oct  7 00:44:05 UTC 2014 - dimstar@opensuse.org

- Disable fluidsynth again: the crashes we had earlier are still
  not all fixed. They are less, but less common makes it more
  difficult to debug.

-------------------------------------------------------------------
Sun Oct  5 12:54:44 UTC 2014 - olaf@aepfle.de

- Enable build for SLE_11

-------------------------------------------------------------------
Tue Sep 23 19:12:35 UTC 2014 - vindex17@outlook.it

- Fix rpmlint warning about duplicates with fdupes
- Add missing BuildRequires:
  + fluidsynth-devel: SMF files playback
  + freerdp-devel: RDP support
  + libkde4-devel: KDE integration
  + libchromaprint-devel: Chromaprint stream output
  + libmlt6-modules: television broadcasting
  + LibVNCServer-devel: VNC support
  + opencv-devel: real-time computer vision support
  + xcb-util-keysyms-devel: better X integration
- Remome gcc-c++ and libqt4-devel because automatically installed
- Add 'suse_version' conditionals to the new BuildRequires
- Remove 'suse_version' conditionals from live555-devel & lua-devel

-------------------------------------------------------------------
Sat Jul 12 13:26:39 UTC 2014 - dimstar@opensuse.org

- Update to version 2.1.5:
  + Core: Fix compilation on OS/2.
  + Access: Stability improvements for the QTSound capture module.
  + Mac OS X audio output:
    - Fix channel ordering.
    - Increase the buffersize.
  + Decoders:
    - Fix DxVA2 decoding of samples needing more surfaces.
    - Improve MAD resistance to broken mp3 streams.
    - Fix PGS alignment in MKV.
  + Qt Interface: Don't rename mp3 converted files to .raw.
  + Mac OS X Interface:
    - Correctly support video-on-top.
    - Fix video output event propagation on Macs with retina
      displays.
    - Stability improvements when using future VLC releases side by
      side.
  + Streaming: Fix transcode when audio format changes.
  + Updated translations.

-------------------------------------------------------------------
Thu May 15 11:47:43 CEST 2014 - olaf@aepfle.de

- Include also libglobalhotkeys_plugin.so which is build with old x11

-------------------------------------------------------------------
Thu May 15 11:30:28 CEST 2014 - olaf@aepfle.de

- BuildRequire at least gnutls 3.0.20

-------------------------------------------------------------------
Fri May  2 08:29:17 CEST 2014 - olaf@aepfle.de

- BuildRequire at least jack 1.9.7

-------------------------------------------------------------------
Thu Apr 24 20:00:17 CEST 2014 - olaf@aepfle.de

- BuildRequire libtag-devel instead of taglib-devel to work around
  a resolver bug. A package name from external project is prefered
  over a provide from the same project.

-------------------------------------------------------------------
Tue Apr 15 20:14:20 CEST 2014 - olaf@aepfle.de

- Require plain lua-devel instead of lua51-devel for 12.1 or older

-------------------------------------------------------------------
Sat Mar  8 21:55:46 UTC 2014 - dap.darkness@gmail.com

- Fixed PowerPC builds.

-------------------------------------------------------------------
Sun Feb 23 17:02:26 UTC 2014 - dimstar@opensuse.org

- Update to version 2.1.4:
  + Demuxers: Fix issue in WMV with multiple compressed payload and
    empty payloads.
  + Video Output: Fix subtitles size rendering on Windows.
  + Mac OS X:
    - Fix DVD playback regression.
    - Fix misleading error message during video playback on
      OS X 10.9.
    - Fix hardware acceleration memleaks.

-------------------------------------------------------------------
Thu Feb 20 19:48:32 UTC 2014 - dimstar@opensuse.org

- Update to version 2.1.3 (bnc#864422):
  + Core:
    - Fix broken behaviour with SOCKSv5 proxies
    - Fix integer overflow on error when using vlc_readdir
  + Access:
    - Fix DVB-T2 tuning on Linux.
    - Fix encrypted DVD playback.
    - Fix v4l2 frequency conversion.
  + Decoders:
    - Fix numerous issues (M2TS, VC1 interlaced, Lagarith, FFv1.3,
      Xvid) by updating codec libraries.
    - Bring fluidsynth back on Mac OS X
    - Fix some Opus crashes with some filters
    - Fix teletext crash on Windows
  + Demuxers:
    - Avoid an infinite recursion in MKV tags parsing
    - Fix an issue with some Vobsub tracks
    - Fix missing samples at the end of some wav files
    - Fix divide by 0 on ASF/WMV parsing
  + Audio output:
    - Fix audio device selection via command line on Mac OS X
    - Fix audio crashes on Mac OS X
 + Video Output:
    - Fix selection of DirectDraw as the default output for XP
    - Fix transform off-by-one issue
    - Fix screensaver disabling on Windows outputs
    - Fix DirectDraw device enumeration and multi-display output
    - Fix a potential crash when playing a fullscreen game at the same time as VLC
  + Stream output:
    - Fix 24bits audio MTU alignment in RTP
    - Fix record file names
  + Qt interface:
    - Fix minimal size possible on start
    - Fix a crash with the simple volume widget
    - Fix a crash in the audio menu building
    - Fix multimedia keys issues on Windows
    - Fix opening of DVD and BD folders on Windows
  + HTTP interface: Fix album art display on Windows.
  + Updated translations.

-------------------------------------------------------------------
Mon Dec 27 18:30:00 UTC 2013 - claudiozumbo@gmail.com

- Add update-desktop-files BuildRequires and
  %desktop_database_post/postun calls to respective scriptlets: Fix
  https://bugs.links2linux.org/browse/PM-108.

-------------------------------------------------------------------
Wed Dec 11 10:52:46 UTC 2013 - dimstar@opensuse.org

- Update to version 2.1.2:
  + Audio output:
    - Fix digital playback on OS X when more than one audio device
      is installed.
    - Fix digital playback (SPDIF/HDMI) on Windows.
    - Fix stuttering or silent playback when using sound enhancers
      or external audio devices on OS X.
    - Improve responsiveness on OS X when playback starts or is
      being paused.
    - Improve responsiveness, silent playback intervals and
      reliability on iOS.
  + Demuxers:
    - Fix Vimeo and DailyMotion parsing.
    - Various WMV playback improvements and fixes.
  + Decoders:
    - Fix LPCM 20/24-bit decoding and 16 bits with channel padding.
    - Fix playback of some HEVC samples.
  + Video filters: Fix crash on deinterlace selection.
  + Qt interface:
    - Fix some streaming profiles when copy existed.
    - Improve A-B loop control.
    - Fix album art update when changing media.
  + Mac OS X interface adjustments.
  + Win32 installer: Kill running VLC process on uninstall/update.
  + Updated translations.

-------------------------------------------------------------------
Sat Nov 23 02:17:25 UTC 2013 - dimstar@opensuse.org

- More features (by adding BuildRequires):
  + IDN Support (International Domain Names): libidn-devel
  + SFTP Access: libssh2-devel
  + HotKey Support: xcb-util-keysyms-devel
  + Complete SDL Stack: SDL_image-devel
  + ProjectM suppor (for openSUSE >= 12.3)

-------------------------------------------------------------------
Mon Nov 18 09:54:30 UTC 2013 - dimstar@opensuse.org

- Update to version 2.1.1:
  + Core:
    - Fix random and reshuffling behaviour.
    - Fix recording.
    - Fix some subtitles track selection.
  + Decoders:
    - VP9 support in WebM.
    - HEVC/H.265 support in MKV, MP4 and raw files.
    - Fix GPU decoding under Windows (DxVA2) crashes.
  + Demuxers:
    - Fix crashes on wav, mlp and mkv and modplug files.
    - Support Speex in ogg files.
    - Fix some .mov playlists support.
    - Support Alac in mkv.
    - Fix WMV3 and palette in AVI.
    - Fix FLAC packetizer issues in some files.
  + Access:
    - Fix DVB options parsing.
    - Fix DeckLink HDMI input.
    - Fix HTTPS connectivity on OS X by loading root certificates
      from Keychain.
  + Audio output:
    - Fixes for DirectSound pass-through.
    - Fixes for OSS output, notably on BSD.
  + Interfaces:
    - Fix HTTP interface infinite loop.
    - Fix D-Bus volume setting.
  + Qt:
    - Reinstore right click subtitle menu to open a subtitle.
    - Fix saving the hotkeys in preferences.
    - Fix saving the audio volume on Win32, using DirectSound.
    - Fix play after drag'n drop.
    - Fix streaming options edition and scale parameter.
  + Stream out:
    - Fix transcoding audio drift issues.
    - Fix numerous audio encoding issues.
  + Win32 installer:
    - Important rewrite to fix numerous bugs, notably about
      updates.
    - Simplification of the upgrade mechanism.
  + Mac OS X interface:
    - Reintroduce the language selector known from pre-2.1
      releases.
    - Fix fullscreen behaviour and various crashes.
    - Fix about dialog crash in Japanese.
    - Fix crashes on proxy lookups.
    - Fixes on the playlist and information behaviours.
    - Fixes on the streaming dialogs.
    - Improves interface resizings.
  + Updated translations.
- Pass --with-default-font=[path] and
  --with-default-monospace-font=[path] to configure.
- Drop fix_font_path.patch: replaced with configure parameters
  above.

-------------------------------------------------------------------
Wed Nov 13 09:58:01 UTC 2013 - dimstar@opensuse.org

- Recommend 'vlc' by vlc-qt: some users might go installing the UI
  package directly. Having Qt most likely also means the user has X,
  so we at least recommend the vlc package relying on X.

-------------------------------------------------------------------
Thu Nov  7 16:56:22 UTC 2013 - hrvoje.senjan@gmail.com

- Force creation of plugins cache in vlc-nox %post, instead of just 
  touching the file, for details see 
  https://trac.videolan.org/vlc/ticket/9807#comment:2

-------------------------------------------------------------------
Thu Oct 24 13:49:52 UTC 2013 - dimstar@opensuse.org

- Update License: A lot has been relicensed to LGPL-2.1.

-------------------------------------------------------------------
Mon Oct 21 18:04:36 UTC 2013 - hrvoje.senjan@gmail.com

- Make vlc build on OBS for openSUSE 12.3 - BuildRequire 
  pkgconfig(libswscale) and live555-devel on >= 13.1, and on 
  BUILD_ORIG case

-------------------------------------------------------------------
Sat Oct 12 09:42:57 UTC 2013 - scarabeus@opensuse.org

- Drop support for < 12.2 as it does not build anyway
  * Removal of pulseaudio subpackage and incorporating it to the
    noX package.
  * Cleanup of the dependencies and configure switches we don't
    need to use anymore.
- Add lang subpackage as it was most of what was noX package
  containing. This way we can reduce the size and use noarch there.
- Touch the ghosted file in %post to make rpmlint happy
- Fix __DATE__ and __TIME__ usage so we do not rebuild so often.
- Drop obsolete configure options which are no longer around
- Disable xcb switch as we no longer build for such old distros.

-------------------------------------------------------------------
Wed Oct  2 9:11:58 UTC 2013 - wbauer@tmo.at

- Re-add and adapt 0001-no-return-in-non-void.patch: fixes build on
  openSUSE versions other than Factory

-------------------------------------------------------------------
Wed Oct  2 08:20:45 UTC 2013 - guillaume@opensuse.org

- Add support to openGL ES 2 (enabled by default for %arm):
  + Introduce bcon_with(out) opengles.
  + If enabled, pass --enable-gles2 --enable-egl to configure.
  + Adjust the files section for that.

-------------------------------------------------------------------
Wed Oct  2 08:16:18 UTC 2013 - guillaume@opensuse.org

- Add vdpau support to -codecs package (BUILD_ORIG):
  + BuildRequire libvdpua-devel
  + Adapt files section.

-------------------------------------------------------------------
Tue Oct  1 20:09:40 UTC 2013 - dimstar@opensuse.org

- Only enable GME support on openSUSE >= 12.00 (disable on SLE11).

-------------------------------------------------------------------
Wed Sep 25 19:38:09 UTC 2013 - dimstar@opensuse.org

- Update to version 2.1.0:
  + Important changes:
    - The licenses of numerous modules have changed from GPLv2+ to
      LGPLv2.1+.
    - Discontinued support for PowerPC-based Macs; VLC now requires
      Mac OS X 10.6+.
    - The --with-tuning and --without-tuning options are removed;
      to tune compilation for a specific processor type, set CFLAGS
      manually.
  + LOTS of updates all over. See NEWS for a full overview.
- Rebase fix_font_path.patch.
- Drop 0001-no-return-in-non-void.patch: no longer needed.
- Drop vlc-avcodec-encoder-single-threaded.patch: fixed upstream.
- Drop ppc64_altivec.patch: fixed upstream.

-------------------------------------------------------------------
Sat Sep 21 13:08:45 UTC 2013 - dimstar@opensuse.org

- Drop fluidsynt-devel BuildRequires: the fluid plugin is known to
  introduce a lot crashes at no gain from functionality PoV.

-------------------------------------------------------------------
Sat Sep  7 18:52:22 UTC 2013 - dimstar@opensuse.org

- If we have a smblcient.pc available (meaning, we build against
  samba 4), we export the output of pkg-config --cflags smbclient
  into CFLAGS. Fixes build with Samba 4.0.

-------------------------------------------------------------------
Fri Aug  9 14:20:19 UTC 2013 - dvaleev@suse.com

- Add ppc64_altivec.patch: Enable altivec for powerpc64
  (backport cce2cdb0dd246fa9669378f5a3b967464c88bf20)
- Add autoreconf call in build section, as above patch touches the
  build system.

-------------------------------------------------------------------
Fri Aug  9 11:30:54 UTC 2013 - dvaleev@suse.com

- Package altivec plugins on powerpc

-------------------------------------------------------------------
Sat Aug  3 13:09:04 UTC 2013 - dimstar@opensuse.org

- Update to version 2.0.8a:
  + always hide menu bar for fullscreen on osx redacted (vlc#9040).
  + macosx: fix double release
  + avcodec audio decoder: update block pointer.

-------------------------------------------------------------------
Tue Jul 30 18:03:49 UTC 2013 - dimstar@opensuse.org

- Update to version 2.0.8:
  + Access:
    - Fix ISDB-S tuning.
    - Fix crash in QTsound.
    - Fix screen mouse file location.
    - Fix invalid memcpy in MMS access.
  + Demux:
    - Fix use after free in sgimb.
    - Improve resistance and checking against malformed MKV files.
  + Decoders:
    - Fix crash in the libavcodec module.
  + Mac OS X:
    - Fix interface crashes.
    - Fix autostart playback option.
    - Respect "playlist-autostart" option.
  + Updated translations.
- Drop vlc-vaapi.patch: fixed upstream.
- Add vlc-avcodec-encoder-single-threaded.patch: disable
  multithreading for avcodec encoder for now. Taken from git.

-------------------------------------------------------------------
Sun Jul 28 21:38:22 UTC 2013 - reddwarf@opensuse.org

- Add pkgconfig(dirac) BuildRequires to enable Dirac support.

-------------------------------------------------------------------
Sat Jul 13 16:17:36 UTC 2013 - dimstar@opensuse.org

- Add vlc-vaapi.patch: Make vaapi decoder compatible with latest
  libva changes.

-------------------------------------------------------------------
Thu Jul  4 10:41:24 UTC 2013 - hrvoje.senjan@gmail.com

- Update to version 2.0.7:
  + Input:
    - Fix playback termination when switching ES tracks
      (PowerPC only)
    - Fix memory exhaustion vulnerability when playing specifically 
      crafted playlist files
  + Decoders:
    - Fix WMA Pro, MPEG 4 ALS, APE, MLP and ADPCM-IMA4 playback
  + Encoders:
    - Fix audio encoding for numerous codecs, notably mp3 and aac
  + Muxers:
    - Fix noticeable memory leak when creating AVI files
  + Video output:
    - Fix crash when using libvlc in 3rd party applications 
      (Mac only)
  + Mac OS X Interface
    - Minor improvements
    - Fix issue which could lead to loss of media files created 
      through transcoding

-------------------------------------------------------------------
Tue Jun 11 22:01:52 UTC 2013 - dvaleev@suse.com

- Enable SSE for x86 only 

-------------------------------------------------------------------
Tue Jun  4 19:40:47 UTC 2013 - reddwarf@opensuse.org

- Enable gme:
  + Pass --enable-gme to configure
  + Add pkgconfig(gme) BuildRequires

-------------------------------------------------------------------
Thu May  9 18:41:57 UTC 2013 - dimstar@opensuse.org

- Enable opus codec:
  + Pass --enable-opus to configure
  + Add libopus-devel BuildRequires

-------------------------------------------------------------------
Tue May  7 13:22:21 UTC 2013 - dimstar@opensuse.org

- Move live555-devel BuildRequires to the unconditional area:
  live555 has been added to Factory and is safe for distribution.
- Move the live555 demuxer from vlc-codecs to vlc-noX.
- Add unconditional --enable-live555 parameter to configure, and
  remove the conditional enable/remove-live555, based on BUILD_ORIG.

-------------------------------------------------------------------
Thu May  2 18:19:13 UTC 2013 - dimstar@opensuse.org

- Add pkgconfig(libswscale) BuildRequires: improve the quality of
  the video filters.
- Unconditionally pass --enable-swscale to configure.
- Move the swscale videofilter out of the -codecs package to the
  -noX package.

-------------------------------------------------------------------
Thu Apr 25 09:45:55 UTC 2013 - dimstar@opensuse.org

- Change libdvbpsi-devel BuildRequires to require version < 1.0.
  VLC 2.0.6 is not able to cope with the new API yet.

-------------------------------------------------------------------
Wed Apr 10 08:05:59 UTC 2013 - dimstar@opensuse.org

- Change live555 BuildRequires to live555-devel: in fact we do
  require the devel package, which for historical reasons just
  happens to provide live555 as well.

-------------------------------------------------------------------
Tue Apr  9 11:56:15 UTC 2013 - dimstar@opensuse.org

- Update to version 2.0.6:
  + Access:
    - Fix HTTPS playback with some certificates previously
      rejected.
  + Audio Output:
    - Fix lookup for device names in auhal plugin
  + Demuxers:
    - Fix crash with broken asf files (SA-1302)
    - Fix MKV behaviour with unknown or new ebml elements
    - Fix use-after-free crash in Ogg demuxer
    - Fix regression on some paletted codecs in AVI
    - Fix ALAC in mp4 regression
    - Improvements to the vimeo playlist parser
  + Decoders:
    - Fix GPU decoding on Intel HD 2000/3000 cards on Windows
    - Fix FLAC 6.1 and 7.1 channel layout
    - Fix crashes in HTML srt subtitles
    - 3rd party codecs updates
  + Mac OS X fixes
  + Qt: Fix clearing of Media Info panel on dialog exit
  + GNU/Linux:
    - Numerous D-Bus and MPRIS2 improvements
    - Reject broken versions of PulseAudio
  + Windows:
    - Fix uninstallation in different location than C:\
  + Updated translations.

-------------------------------------------------------------------
Thu Apr  4 19:01:21 UTC 2013 - dimstar@opensuse.org

- Fix files section for openSUSE 11.4 and 12.1.

-------------------------------------------------------------------
Thu Apr  4 08:28:57 UTC 2013 - dimstar@opensuse.org

- Introduce BUILD_ORIG build flag, in order to build without
  'legally difficult' extensions in OBS.

-------------------------------------------------------------------
Tue Jan 22 13:20:29 UTC 2013 - dimstar@opensuse.org

- Add --enable-png configure parameter to enable png support
  (pointed out by Alin).

-------------------------------------------------------------------
Mon Dec 17 17:50:12 UTC 2012 - dimstar@opensuse.org

- Add -msse to CFLAGS: this helps us over GCC 4.3 being used in
  SLE 11SP2.

-------------------------------------------------------------------
Sun Dec 16 18:02:57 UTC 2012 - dimstar@opensuse.org

- Update to version 2.0.5:
  * See http://www.videolan.org/vlc/releases/2.0.5.html

-------------------------------------------------------------------
Sun Oct 21 13:24:51 UTC 2012 - dimstar@opensuse.org

- Disable ncurses build: will need to work on finding the right
  ncursesw integration steps.

-------------------------------------------------------------------
Thu Oct 18 11:36:52 UTC 2012 - dimstar@opensuse.org

- Update to version 2.0.4:
  + See NEWS for details.

-------------------------------------------------------------------
Thu Jul 19 21:28:10 UTC 2012 - dimstar@opensuse.org

- Update to version 2.0.3 

-------------------------------------------------------------------
Mon Jul  2 11:25:55 UTC 2012 - dimstar@opensuse.org

- Upadate to version 2.0.2:
    Rework of the Mac OS X interface
    Fix video output for old graphic cards on Windows XP, which are using DirectX
    Fix video output on old Macs, notably PowerPC and GMA950 intel Macs.
    Support for HiDPI, aka Retina Display
    Support for H264 v4l2 devices on Linux
    Translations updates and new Scottish Gaelic translation
    Fixes for splitted RAR, MKV segmented, mp4 and Real media files playback.
    Rewrite of the Digital TV module on Windows
    Enhancements in HLS, Blu-Ray and various codecs support
    Fixes for subtitles auto-detection
    Fixes on Qt, skins2 and web interfaces

-------------------------------------------------------------------
Fri Mar 30 18:15:07 UTC 2012 - dimstar@opensuse.org

- Inject -L%{_libdir}/live into CFLAGS and CXXFLAGS for live555 to
  be built. The static lib is in a non-standard place and not
  detected by configure scripts.

-------------------------------------------------------------------
Mon Mar 19 17:42:12 UTC 2012 - dimstar@opensuse.org

- Update to version 2.0.1:
  + Lots of bug fixes
  + For a full list, see NEWS file in the package.

-------------------------------------------------------------------
Fri Feb 17 21:32:10 UTC 2012 - dimstar@opensuse.org

- Update to version 2.0.0 final.

-------------------------------------------------------------------
Wed Feb  1 20:23:37 UTC 2012 - dimstar@opensuse.org

- Update to version 2.0.0 rc1

-------------------------------------------------------------------
Wed Jan 18 21:43:16 UTC 2012 - dimstar@opensuse.org

- Add xorg-x11-devel BuildRequires: fixes build on Factory.

-------------------------------------------------------------------
Wed Jan 11 08:41:30 UTC 2012 - dimstar@opensuse.org

- Use lua 5.1 on Factory.

-------------------------------------------------------------------
Thu Dec 22 14:54:01 UTC 2011 - dimstar@opensuse.org

- Update to version 1.1.13:
  + This release was necessary due to a security issue in the TiVo
    demuxer.

-------------------------------------------------------------------
Fri Dec  2 18:44:13 UTC 2011 - dimstar@opensuse.org

- Add libtool BuildRequires, as the chroot no longer implicitly
  provides it.

-------------------------------------------------------------------
Wed Nov 23 21:10:39 UTC 2011 - dimstar@opensuse.org

- Build libva dependencies only for 11.4+.

-------------------------------------------------------------------
Fri Oct  7 10:36:55 UTC 2011 - dominique-vlc.suse@leuenberger.net

- Update to version 1.1.12:
  + Audio outputs:
    - Mac OS X / auhal: multiple fixes for the Digital Audio output
      (S/PDIF) including support for OS X Lion
    - Multiple fixes and improved synchronization for PulseAudio
      support
    - Support for AC-3 and DTS passthrough with PulseAudio 1.0
  + Unix port:
    - Fix build compatibility with taglib < 1.6 and Xulrunner 1.9.1
  + Misc:
    - Fix crashes with Japanese locale on OS X
    - Minor fixes for Webplugin under Win32, AVI demuxer, smem and
      AudioScrobbler
    - Fix crash in HTTP and RTSP server (stream output or Web
      interface)
- Drop vlc-1.1.11-taglib.patch: Fixed upstream

-------------------------------------------------------------------
Wed Aug 24 17:18:10 UTC 2011 - dominique-vlc.suse@leuenberger.net

- Add libgcrypt-devel BuildRequires.

-------------------------------------------------------------------
Mon Jul 18 10:45:10 UTC 2011 - dominique-vlc.suse@leuenberger.net

- Update to version 1.1.11:
  + Security:
    - Fix buffer overflows in the RealMedia demuxer (CVE-2011-2587)
      and the AVI one (CVE-2011-2588).
  + Mozilla/ActiveX webplugin:
    - Fullscreen mode is fixed on Win32
    - Very simple fullscreen controller is visible on Win32
  + Demuxers/Meta Readers:
    - Better support for cover art embedded in mp4, wma
  + Muxers/Output:
    - Fix AVI muxer so the generated files are readable on other
      players
  + Extensions:
    - Multiple fixes for crashes and malfunctionning issues
  + Qt Interface:
    - Fix quitting on Linux
    - Fix opening of VIDEO_TS folders through the open disc dialog
      on Windows
    - Miscellaneous
  + Updated translations.
- Add vlc-1.1.11-taglib.patch: Fix build on openSUSE <= 11.2 with
  taglib 1.5.

-------------------------------------------------------------------
Mon Jul 11 20:57:33 UTC 2011 - dominique-vlc.suse@leuenberger.net

- Remove PortAudio-devel BuildRequires. This is long obsolete.

-------------------------------------------------------------------
Tue Jun 14 18:53:14 UTC 2011 - dominique-vlc.suse@leuenberger.net

- Update to 1.1.0

-------------------------------------------------------------------
Sun Apr  3 20:44:45 UTC 2011 - dominique-vlc.suse@leuenberger.net

- Add vlc-youtube.patch: fix youtube playback. Hack patch from
  upstream git repository, commit id d938db.

-------------------------------------------------------------------
Tue Mar 15 19:10:25 UTC 2011 - dominique-vlc.suse@leuenberger.net

- Update to 1.1.8:
  + Interfaces:
    - Oldrc interface is again the default RC interface, on Windows
    - Luarc, luahttp and luatelnet fixes
    - Qt and Mac OS X fixes
    - numerous Skins2 fixes, notably winamp2 skins
  + Encoder:
    - new libschroedinger-based Dirac codec encoder, faster than the
      current one
  + Access/Demuxers/Codecs:
    - Subtitles auto-detection is back for .txt files
    - vod/rtsp server and rtsp input fixes
    - mp4 demuxer improvements
    - ogg, rstp input, video filters minor fixes
    - taglib's replaygain is fixed for mp3
    - vobsub support has an improved auto-detection
    - fix a crash in malformed ape files
  + Miscellaneous fixes in:
    - Pulseaudio audio output, notably for usb cards
    - Stacktraces are now limited in size on Windows
    - Video resolution is now limited to 8192x8192, for security
      reasons (CORE-2011-0208)
    - Configure and build system improvements
    - DirectShow and BDA build headers have been updated
- Drop patches that came from upstream git:
  + vlc-matroska.patch
  + vlc-upnp-assert.patch

-------------------------------------------------------------------
Sat Mar 12 17:25:43 UTC 2011 - dominique-vlc.suse@leuenberger.net

- Add 0001-KDE-Add-smb-to-the-supported-protocols-we-can-get-fi.patch

-------------------------------------------------------------------
Wed Feb 23 22:17:10 UTC 2011 - dominique-vlc.suse@leuenberger.net

- Own _datadir/kde4/apps, so we do not have to rely on meta-
  package kde4-filesystem, which does not exist in Fedora.
- Remove kde4-filesystem BuildRequires.

-------------------------------------------------------------------
Sat Feb 19 13:02:11 UTC 2011 - dominique-vlc.suse@leuenberger.net

- Add vlc-matroska.patch: Fix build with new matroska version.
  Multi Tag no longer exists.

-------------------------------------------------------------------
Mon Jan 31 21:07:19 UTC 2011 - dominique-vlc.suse@leuenberger.net

- Update to version 1.1.7: 
  + Linux port:
    - Integration with the KDE GUI platform is disabled due to KDE
    - bugs #234484 and #260719.
  + Mac OS X port:
    + Updated live555 library to fix playback of RTSP and Freebox
      streams
  + Running VLC in 64bit mode requires Mac OS X 10.6.0 or later for
    speed and stability reasons
  + Demuxers:
    - Fix for Matroska / WebM remote code execution vulnerability.
      VideoLAN-SA-1102
  + Updated translations.
- Changes from version 1.1.6.1:
  + Fix libnotify, lirc, pulse compilation and packaging for
    Unix/Linux
- Drop patches: vlc-lirc.patch and  
  0001-Libnotify-depends-on-a-GTK-version-can-be-gtk-2.0-or.patch

-------------------------------------------------------------------
Mon Jan 24 14:06:14 UTC 2011 - dominique-vlc.suse@leuenberger.net

- Update to version 1.1.6:
  + Audio output:
    - Multiple fixes and improvements on PulseAudio output
  + Access:
    - Fix the Audio CD crash when looking for CDDB metadata on
      Windows
  + Decoders:
    - Support for MPC SV7 and SV8 on Windows and Mac OS X (Unix was
      already working)
    - Enabled FluidSynth MIDI playback plugin on Mac OS X
    - Faster VP8/Webm decoding with recent codecs libraries
  + Demuxers:
    - Fix Buffer overflow in Real demuxer CVE-2010-3907 /
      VideoLAN-SA-1007
    - Fix some asf/wmv seeking issues, notably when seek didn't go
      to a keyframe
    - Support for 24-bits PCM over RTP (audio/L24)
  + Subtitles and renderer:
    - Do not auto-detect .txt files for subtitles
    - Mark more freetype options as safe
    - Mac OS X: fixed fontconfig cache creation
    - Fix heap corruption in subtitle decoders, potentially
      exploitable
  + Visualization:
    - Fix projectM visualization for Linux in all locales
    - Fix projectM visualization support for Windows
    - Various projectM improvements: the module should be working
      now
    - Fix goom crash on Windows XP and Mac OS X
  + Interfaces:
    - Qt4: fixes for media keys processing and MCE remotes
    - Qt4: various fixes and portability improvements
    - KDE: work-around open dialog first slow opening because of
      KMimeTypeRepository
  + Miscellaneous fixes:
    - KDE device solid actions
    - XDG screensaver
    - Transcode integer overflow
    - HTTP Icy metadata reading
    - Windows: revert to 1.1.4 performance timers
  + Updated translations.
- Add vlc-lirc.patch: fix build of the lirc module. Taken from git.

-------------------------------------------------------------------
Sun Jan 16 17:56:11 UTC 2011 - dominique-vlc.suse@leuenberger.net

- No loner package locale co.

-------------------------------------------------------------------
Fri Nov 19 19:24:53 UTC 2010 - dominique-vlc.suse@leuenberger.net

- Add vlc-upnp-assert.patch: fix build of upnp plugin.

-------------------------------------------------------------------
Sat Nov 13 21:13:14 UTC 2010 - dominique-vlc.suse@leuenberger.net

- Update to version 1.1.5:
  + Security:
    - Fix a Windows crash on accessing Network Shared files/drives,
      VideoLAN-SA-1006
  + Services Discovery:
    - Integration in the playlist, of a list of web shows,
      provided by channels.com
  + Demuxers:
    - Game Music Emu (GME) plugin rewritten, using the proper C API
    - DVDnav and DVDread fixes for encoding and misc issues
    - Playback of live http .Webm streams
    - Taglib thread-safety fix
  + Decoders:
    - Fix decoding of H264 using DxVA2 using Intel IGP, thanks to
      the donation from "Puget Systems"
  + Skins:
    - Add an icon to VLC on Linux
  + Video Output:
    - fix a bug that could lead to 100% CPU usage on XCB
  + Interfaces:
    - fix for Qt bug where VLC didn't exit properly on some Windows
      XP configuration
    - fixes on luatelnet and luarc
  + Miscellaneous crashes and fixes in various plugins (telnet,
    live555, theora and TS-mux, Qt)
  + libLVC:
    - add libvlc_media_new_fd() to play directly file descriptors
      (not Win32/Win64)
    - Miscellaneous fixes
  + Updated translations.

-------------------------------------------------------------------
Wed Oct 20 22:41:32 UTC 2010 - dominique-vlc.suse@leuenberger.net

- Update to version 1.1.4.1:
  + Demuxers:
    - DVDnav and DVDread fixes for encoding and misc issues
    - Playback of live http .Webm streams
  + Decoders:
    - Fix decoding of H264 using DxVA2 using Intel IGP, thanks to
      the donation from "Puget Systems"
  + Skins:
    - add an icon to VLC
  + Uodated translations.

-------------------------------------------------------------------
Mon Sep  6 17:40:04 UTC 2010 - dominique-vlc.suse@leuenberger.net

- Add libtwolame-devel BuildRequires

-------------------------------------------------------------------
Fri Aug 27 19:00:34 UTC 2010 - dominique-vlc.suse@leuenberger.net

- Update to version 1.1.4:
  + Win32:
    - Fix a security issue when loading DLLs, especially in Qt4
      and dmo modules, See VideoLAN-SA-1005
    - Fix folders opening from the interface
  + Updated translations.
- Add gdk-pixbuf-devel BuildRequires for openSUSE 11.4+
- Add gtk2-devel BuildRequires and add new patch:
  0001-Libnotify-depends-on-a-GTK-version-can-be-gtk-2.0-or.patch

-------------------------------------------------------------------
Thu Aug 19 08:57:04 UTC 2010 - dominique-vlc.suse@leuenberger.net

- Update to version 1.1.3:
  + Access and demuxers:
    - fixes for FTP relatives path and FTP directory support
    - fix for podcasts parsing
    - DVD: fix an assert error and various memory leaks
  + Taglib:
    - fix NULL dereferences, as reported by FortiGuard Lab,
      CVE-2010-2937 / VideoLAN-SA-1004
  + Playlist:
    - fix a regression where the wrong entry was played
    - fix m3u playlists exports
  + Skins2:
    - fix video autoresize behaviour
  + updated translations

-------------------------------------------------------------------
Tue Aug  3 20:14:12 UTC 2010 - dominique-vlc.suse@leuenberger.net

- BuildRequire libmatroska-devel instead of libmatroska.

-------------------------------------------------------------------
Fri Jul 30 19:22:12 UTC 2010 - dominique-vlc.suse@leuenberger.net

- Update to version 1.1.2:
  + Demuxers:
    - Avformat fps displaying fix
    - TS, fix an issue where some programs would get dropped
      (fixes DVB issues too)
  + Audio filters:
    * fix timestamps handling on some filters that provoqued issues
      when playback of mono streams, especially on Windows
  + Windows:
    - fix a bug in direct3d video output with old nVidia drivers
      that broke video playback with overlay (YUV->RGB)
    - fix console output encoding
  + Interface and extensions:
    - Youtube and other scripts updates
    - Misc fixes in Qt4 (especially VLM and EPG dialogs) and MacOS
      interface.

-------------------------------------------------------------------
Tue Jul 20 10:20:15 UTC 2010 - dominique-vlc.suse@leuenberger.net

- Update to version 1.1.1:
  + libVLC:
    * Support for the new capabilities: libvlc_adjust_Enable,
      libvlc_adjust_Contrast, libvlc_adjust_Brightness,
      libvlc_adjust_Hue, libvlc_adjust_Saturation,
      libvlc_adjust_Gamma
    * Various fixes and crash preventions, especially when video
      functions were called early
    * libvlc_media_player_set_pause() can force the pause state,
      whereas libvlc_media_player_pause() would only toggle it.
    * libvlc_set_user_agent() configures the "user agent" strings
      used for some protocols (HTTP, PulseAudio...).
      This replaces the --http-user-agent and the former
      --user-agent libvlc_new() parameters.
    * libvlc_video_set_callbacks() and libvlc_video_set_format()
      allow grabbing video frames from a chosen memory location in
      real-time.
      This replace the ugly --vmem-* libvlc_new() parameters in
      previous versions.
      See http://wiki.videolan.org/LibVLC_SampleCode_SDL as an
      example.
    * libvlc_audio_get_delay() and libvlc_audio_set_delay()
      configure the delay between audio and video/subpictures for
      the current input.
  + Stream output:
    * Fix h264 streaming in ts
  + Decoders/Demuxers:
    * Fix performance issues with GPU decoding using DxVA2 using
      ATI graphic cards You NEED ATI Catalyst 10.7
    * Fix :program selection in TS and DVB-T
    * Fixes and improvements for MKV, Avformat and Avcodec modules
    * Fix mod (.xm, .s3m, .it) files support on Windows and Mac
      builds
  + Linux port:
    * Fix pulse closing
    * VAAPI small improvements, notable for FourCC selection for
      extraction
  + Interfaces:
    * Qt: fix preferences, hotkeys, messages and some fulscreen
      behaviour
    * Skins: support for mousewheel in fullscreen, fix
      radialsliders
    * Http: fix fullscreen toggle
  + Updated translations.

-------------------------------------------------------------------
Sat Jul  3 21:44:20 UTC 2010 - dominique-vlc.suse@leuenberger.net

- Add lirc-devel to BuildRequires to actually build the lirc
  interface. Thanks to Rob Verduijn for reporting this error.

-------------------------------------------------------------------
Mon Jun 21 08:01:27 UTC 2010 - dominique-vlc.suse@leuenberger.net

- Update to 1.1.0:
  + This is a major release, adding major features, notably:
    - GPU and DSP decoding on selected platforms
    - New support for codecs, demuxers and muxers
    - Lua extensions and Lua content extensions (luaSD)
    - Improved interfaces
    - Video Output rework
    - Removal of lots of modules, rewrite of many
    - Improved performances, in CPU, RAM and I/O
    - New libVLC and bindings
    - New or improved ports on misc platforms
  + And so many bugs and other features...

-------------------------------------------------------------------
Wed Jun 16 18:39:33 UTC 2010 - dominique-vlc.suse@leuenberger.net

- Update to rc4

-------------------------------------------------------------------
Fri Jun 11 06:29:39 UTC 2010 - dominique-vlc.suse@leuenberger.net

- Update to rc2
- BuildRequires SDL_image-devel
- Remove obsoleted switches from configure call.

-------------------------------------------------------------------
Thu Jun 10 21:21:27 UTC 2010 - dominique-vlc.suse@leuenberger.net

- Add git-rollup.patch.bz2 to rollup to current git. Supposed
  to fix various crashers we see lately in 1.1rc2.

-------------------------------------------------------------------
Tue Jun  8 19:21:12 UTC 2010 - dominique-vlc.suse@leuenberger.net

- BuildRequire libva-devel on openSUSE 11.2+

-------------------------------------------------------------------
Sun Jun  6 21:56:49 UTC 2010 - dominique-vlc.suse@leuenberger.net

- Update to 1.1.0 RC 2: Final to be expected soon.

-------------------------------------------------------------------
Wed May 26 21:20:36 UTC 2010 - dominique-vlc.suse@leuenberger.net

- Update to version 1.1.0 RC

-------------------------------------------------------------------
Mon Apr 26 21:30:16 UTC 2010 - root@localhost

- BuildRequire appropriate xulrunner version.

-------------------------------------------------------------------
Sat Apr 24 19:46:14 CEST 2010 - dominique-vlc.suse@leuenberger.net

- Patched tarball uploaded, as older versions of openSUSE
  seem not able to properly bootstrap it. The patch applied to the
  source tarball is vlc-globalhotkey-with-old-xcb-keysyms.patch.

-------------------------------------------------------------------
Fri Apr 23 14:52:16 CEST 2010 - dominique-vlc.suse@leuenberger.net

- Add vlc-libpng14.patch, taken from git master, commit ffa6a2f.

-------------------------------------------------------------------
Thu Apr 22 20:31:34 CEST 2010 - dominique-vlc.suse@leuenberger.net

- Update to version 1.0.6:
  + Access:
    * Fix crash on FTP URI with no file path
  + Decoders/Packetizers:
    * Fix overflows in A/52, DTS, MPEG Audio and subtitles support
  + Demuxers:
    * Update LUA script for Youtube pages
    * Fix crashes in AVI, ASF and Matroska files
    * Fix crashes on malformatted ZIP archives
    * Fix crashes and leaks in the FFmpeg/avformat plugin
    * Fix crash on invalid XSPF playlist
  + X11 port:
    * Partial Xlib threading fixes
  + Interfaces:
    * Fix crash (use after free) in Qt4 bookmarks
    * Fix a few crashes in Qt4 playlist
  + Removed modules:
    RTMP input and output are removed due to security problems.
    Please update to VLC 1.1.0 which provides an FFmpeg-based RTMP
    input if needed.
  + Updated translations.
- Changes from version 1.0.5:
  + Decoders:
   * SubRip extra styles improvements
   * Fix potential crashes in SSA and svg decoders
  + Mac OS X Interface:
    * Improved support for the 2009 Apple Remote
  + Windows port:
    * Use of gcc 4.4.2 to compile instead of gcc 4.2. This might
      slightly increase performance and fix x264 issues

-------------------------------------------------------------------
Thu Dec 10 19:52:16 CET 2009 - dominique-vlc.suse@leuenberger.net

- Update to version 1.0.4:
  + Audio outputs:
    * Fix deadlocks in the audio output core
    * Make PulseAudio the default output if available
  + Video outputs:
    * Fix fullscreen mode with KDE 4.3.3 and other window managers
    * Fix incompatibility with cairo-dock and compositing
  + Input:
    * Fix DVB scanning regression from VLC 1.0.3
    * Support for XZ-compressed byte stream (LZMA algorithm)
  + Playlist:
    * Support for .m3u8 playlist files (UTF-8 M3U)
  + Unix:
    * Support for xcb-keysyms version 0.3.4 or higher
    * Fix globalhotkeys on FreeBSD
  + Qt4 interface:
    * Fix opening V4L version 1 devices
    * Fix default destination ports in the streaming wizard

-------------------------------------------------------------------
Fri Oct 30 13:19:42 CET 2009 - dominique-vlc.suse@leuenberger.net

- Update to version 1.0.3
  + Video outputs:
    - Fix video quality when resizing the video on Windows Vista
      and 7, due to regressions in most popular drivers
    - New deinterlacers modules based on yadif and yadif(x2)
      algorithms
  + Decoders:
    - Windows version supports now natively the WMA Professional
      codec, as it didn't work in the packaged version of 1.0.2
    - Fix downmixing of particual 4.0 AC-3 audio tracks
  + Encoders:
    - x264 has profile-limitter, like:
    #transcode{vcodec=h264,venc=x264{profile=baseline,level=12}..}
  + Input:
    - Update for appletrailers lua script
    - Fixes on the RAR stream filter
    - Fix for E-AC3 in ATSC/TS streams
    - Various fixes for v4l and v4l2
    - Fix a crash in mjpeg demuxer
  + Service discovery:
    - New udev module for Linux
  + Qt4 interface:
    - Fixes on the playlist and the stream output panels
  + Updated translations.

-------------------------------------------------------------------
Tue Sep 29 16:21:13 CEST 2009 - dominique-vlc.suse@leuenberger.net

- Add 540_all_x264.patch to build with x264 >= 0.76. Patch copied
  from gentoo portage.

-------------------------------------------------------------------
Mon Sep 21 14:06:27 CEST 2009 - dominique-vlc.suse@leuenberger.net

- Update to version 1.0.2
  + Decoders:
    - Native support for WMA Professional, without the use of the
      Win32 dlls
    - Fix issues in subtitles, especially SSA ones
    - Various fixes on theora and ogg
  + Demuxers:
    - Various fixes for EPG support in MPEG-TS demuxer
    - Fixes for potential stack overflow in .avi, .mp4 and .asf
      demuxers
  + Access:
    - Fixes for v4l2 devices
    - Fixes for dvb-c channels-scanning
  + Qt Interface:
    - Fix some playlist sorting issues
  + Encoders:
    - MPEG2 transrate stream output removed
    - x264 default-values closer to x264.exe defaults.
    - x264 rc-behaviour fixes:
      . if user defines qp-value, CQP-mode is used
      . otherwise if user defines vb=0, CRF-mode is used
      . otherwise ABR-mode is used
    - x264 set vbv-bufsize/vbv-maxsize better if user hasn't
      defined these:
      . ABR mode set vbv-max-bitrate=bitrate
      . vbv-bufsize is bitrate * seconds between keyframes
        (keyint/fps)
  + Playlist:
    - Lua scripts for Mpora and Vimeo playback
  + Updated translations.

-------------------------------------------------------------------
Mon Aug 17 10:31:36 CEST 2009 - dominique-vlc.suse@leuenberger.net

- Add vlc-1.0.1-libass4.patch to support newer libass. Patch
  taken from upstream commit 019359b5a5.

-------------------------------------------------------------------
Mon Jul 27 18:34:24 CEST 2009 - dominique-vlc.suse@leuenberger.net

- Update to version 1.0.1
  + Demuxers:
    * Fix wmv/asf issues that caused audio to drop
    * Various fixes for ac3, mp3, dts and stability for wav format
    * Fix seek in RTSP in conformity to RFC 2326
    * Fix Dailymotion access script
    * Fix crashes in xspf files handler
    * Fix seeking and timing issues in some flv files on Windows
      version
  + Access:
    * Add extra caching for files on network shares
    * Prevent integer underflow in Real pseudo-RTSP module,
      discovered by tixxDZ, DZCORE Labs, Algeria
  + Decoders:
    * Fix seeking in mpeg2 video files
    * Improve SSA subtitles rendering
    * Update most codecs for the Windows and Mac version
  + Muxers:
    * Fix sound recording of .flv files with mp3 audio
  + Qt Interface:
    * Possibility to change the opacity level of the Fullscreen
      controller
    * Fix various crashes and VIDEO_TS folders opening
  + Mac OS X Interface:
    * Added options to disable support for Apple Remote and Media
      Keys
    * Fixed options for Volume, Last.fm password and Subtitle
      Encoding
    * Fixed redraw issues when autosizing the video window
    * Preferences panel now includes help through tool-tips
    * More reliable Information and Messages panels
    * Fix various crashes
  + Windows port:
    * The ZVBI module is now available for Windows, for complete
      teletext support
  + Update translations.

-------------------------------------------------------------------
Tue Jul  7 09:55:39 CEST 2009 - dominique-vlc.suse@leuenberger.net

- Update to 1.0.0
  * See http://git.videolan.org/?p=vlc.git;a=blob;f=NEWS;h=777764

-------------------------------------------------------------------
Thu Jun 18 09:09:23 CEST 2009 - dominique-vlc.suse@leuenberger.net

- Update to 1.0.0-rc4
  Notable fixes:
  - Mac OS crashes
  - Qt Fullscreen controllers
  - libass, playlist and skins crashes
  - dv update to new API
  - TrueHD in M2TS
- dropped vlc-xulrunner191 patch; it was merged upstream

-------------------------------------------------------------------
Sat May 30 16:00:10 CEST 2009 - dominique-vlc.suse@leuenberger.net

- Add vlc-xulrunner191 patch (conditional. Works only with xul 191)