File python-oslo.serialization.changes of Package python-oslo.serialization

-------------------------------------------------------------------
Fri Oct 14 14:04:34 UTC 2016 - tbechtold@suse.com

- switch to stable/newton tarball in _service

-------------------------------------------------------------------
Fri Sep  2 19:10:06 UTC 2016 - tbechtold@suse.com

- update to version 2.13.0
  * Fix serialization of binary strings in Python3
  * Drop H803 in flake8 ignore list

-------------------------------------------------------------------
Wed Aug 10 12:17:07 UTC 2016 - tbechtold@suse.com

- update to 2.12.0:
  * Updated from global requirements
  * Fix parameters of assertEqual are misplaced
  * Add Python 3.5 classifier and venv
  * Use {} instead of dict()
  * Replace TypeError by ValueError in msgpackutils
  * Support serializing ipaddress objs with jsonutils

-------------------------------------------------------------------
Sun Jun 19 20:21:39 UTC 2016 - dmueller@suse.com

- update to 2.7.0:
  * Trivial: ignore openstack/common in flake8 exclude list
  * [Trivial] Remove executable privilege of doc/source/conf.py 
  * Drop babel as requirement since its not used
  * Updated from global requirements
  * Unified and simplified API for all serializers
  * Make msgpack registries copyable (and add __contains__)
  * msgpack: fix datetime serialization

-------------------------------------------------------------------
Thu Jun  2 09:21:42 UTC 2016 - tbechtold@suse.com

- use renderspec source service
- update spec from upstream

-------------------------------------------------------------------
Thu Mar  3 07:41:17 UTC 2016 - tbechtold@suse.com

- update to 2.4.0:
  * Updated from global requirements
  * Updated from global requirements
  * Updated from global requirements
  * Updated from global requirements
  * Remove fallback to simplejson in jsonutils
  * Remove iso8601 dependency
  * Updated from global requirements
  * Updated from global requirements
  * Trival: Remove 'MANIFEST.in'
  * msgpackutils: drop Python 2.6 support
  * Updated from global requirements
  * Updated from global requirements
  * Remove python 2.6 classifier
  * Fix bug track URL
  * Remove python 2.6 and cleanup tox.ini
  * Updated from global requirements
- Switch to .spec from rpm-packaging upstream project

-------------------------------------------------------------------
Fri Nov 20 07:50:48 UTC 2015 - bwiedemann@suse.com

- update to 1.11.0
  * Fix coverage configuration and execution
- update to 1.10.0:
  * Add utilities for base64
  * Also check for the existence of `items` in to_primitive()
  * Move 'history' -> release notes section
  * Add jsonutils.dump_as_bytes() function for py3
  * Change ignore-errors to ignore_errors

-------------------------------------------------------------------
Wed Sep  9 06:54:35 UTC 2015 - tbechtold@suse.com

- update to 1.9.0:
  * Updated from global requirements
  * Drop stale test - test_jsonutils
  * Stop using deprecated oslo_utils.timeutils.strtime
  * Add tox target to find missing requirements
  * Remove oslo namespace package
  * Do not use oslo namespace for oslo.i18n lib
  * Switch badges from 'pypip.in' to 'shields.io'
- Adjust Requires according to requirements.txt

-------------------------------------------------------------------
Mon Aug 10 11:45:21 UTC 2015 - seife+obs@b1-systems.com

- fix spelling of python-Sphinx BuildRequires

-------------------------------------------------------------------
Fri Jul 31 06:37:34 UTC 2015 - tbechtold@suse.com

- Unify spec file #2
- Add -doc package

-------------------------------------------------------------------
Wed Jul 29 10:43:33 UTC 2015 - tbechtold@suse.com

- Unify spec file. Use fedora compatible files macros

-------------------------------------------------------------------
Mon Jun  8 14:08:17 UTC 2015 - tbechtold@suse.com

- update to 1.6.0:
  * Revert "jsonutils: replace strtime(
  * jsonutils: encode dict keys
  * jsonutils: simplify simple value handling
  * jsonutils: replace strtime() usage with isoformat()
  * Advertise support for Python3.4 / Remove support for Python 3.3
  * Do not sync run_cross_tests.sh
  * Updated from global requirements
  * Remove run_cross_tests.sh
  * Fixes wrong folder for listing tests
  * Expose base msgpack exceptions so users don't need to import
  * Uncap library requirements for liberty
  * More docstring cleanups/tweaks
  * Add docstring(s) to handler registry(s)
  * Add pypi download + version badges
  * Cleanup README.rst and setup.cfg
  * Make the msgpackutils handlers more extendable
  * Updated from global requirements
- Adjust Requires according to requirements.txt

-------------------------------------------------------------------
Wed Jun  3 09:15:44 UTC 2015 - dmueller@suse.com

- remove hacking dep 

-------------------------------------------------------------------
Tue Mar 10 15:14:18 UTC 2015 - tbechtold@suse.com

- update to 1.4.0:
  * Updated from global requirements
- update Requires

-------------------------------------------------------------------
Tue Feb 24 12:37:00 UTC 2015 - tbechtold@suse.com

- update to version 1.3.0:
  * add dependency warning to requirements.txt
  * Correctly load and dump items with datetime.date(s)
  * Avoid using strtime for serializing datetimes
  * jsonutils: add set() tests and simplify recursive code
  * jsonutils: support UUID encoding
  * Use default in dumps()
  * Updated from global requirements
  * Update Oslo imports to remove namespace package
  * Add a messagepack utils helper module
  * Bump to hacking 0.10
  * Updated from global requirements
  * fix bug tracker link in README.rst
- Add python-pytz and python-msgpack-python as Requires
- Remove SLES11 compat

-------------------------------------------------------------------
Thu Jan 15 08:15:53 UTC 2015 - tbechtold@suse.com

- update to 1.2.0:
  * Move files out of the namespace package
  * Activate pep8 check that _ is imported
  * Updated from global requirements
  * Workflow documentation is now in infra-manual
- Add python_requires to _service

-------------------------------------------------------------------
Thu Jan  8 10:18:38 UTC 2015 - dmueller@suse.com

- update to 1.1.0:
  * Add pbr to installation requirements
  * Updated from global requirements
  * Fix pep8, docs, requirements issues in jsonutils and tests
  * Remove extraneous vim editor configuration comments
  * Support building wheels (PEP-427)
  * Fix coverage testing
  * Updated from global requirements
  * Support 'built-in' datetime module

-------------------------------------------------------------------
Fri Oct 17 13:05:27 UTC 2014 - dmueller@suse.com

- add LICENSE 

-------------------------------------------------------------------
Sun Sep 21 10:22:13 UTC 2014 - tbechtold@suse.com

- Update to version 1.0.0:
  * Updated from global requirements
- Adjust Requires version of python-oslo.utils according to
  requirements.txt

-------------------------------------------------------------------
Tue Sep  9 05:59:01 UTC 2014 - tbechtold@suse.com

- Initial version