File python-azure-batch.changes of Package python-azure-batch

-------------------------------------------------------------------
Wed Apr 10 14:55:13 UTC 2019 - John Paul Adrian Glaubitz <adrian.glaubitz@suse.com>

- New upstream release
  + Version 6.0.0
  + For detailed information about changes see the
    HISTORY.txt file provided with this package
- Bump minimum version for namespace packages
  to 3.0.0 in BuildRequires and Requires
- Refresh patches for new version
  + ab_drop-compatible-releases-operator.patch
- Remove python-devel package from BuildRequires
- Run fdupes to hardlink duplicate files
  + Add fdupes to BuildRequires
  + Add %fdupes invocation to %install
- Update BuildRequires and Requires from setup.py
- Use namespace packages for python2 builds only as the python3
  packages are using Implicit Namespace Packages (PEP 420)

-------------------------------------------------------------------
Mon Sep  3 08:59:20 UTC 2018 - John Paul Adrian Glaubitz <adrian.glaubitz@suse.com>

- New upstream release
  + Version 5.0.0
  + For detailed information about changes see the
    HISTORY.txt file provided with this package
- Refresh patches for new version
  + ab_drop-compatible-releases-operator.patch
- Update Requires from setup.py

-------------------------------------------------------------------
Tue Apr 10 12:57:27 UTC 2018 - adrian.glaubitz@suse.com

- New upstream release
  + Version 4.1.1
- Move LICENSE.txt from %doc to %license section
- Refresh patches for new version
  + ab_drop-compatible-releases-operator.patch
- Update Requires from setup.py
- Update %description from setup.py

-------------------------------------------------------------------
Mon Jan 29 12:31:42 UTC 2018 - adrian.glaubitz@suse.com

- Install HISTORY.rst into doc directory

-------------------------------------------------------------------
Wed Oct  4 13:37:20 UTC 2017 - adrian.glaubitz@suse.com

- New upstream release
  + Version 4.0.0
- Refresh patches for new version
  + amn_drop-compatible-releases-operator.patch
- Remove versioning for namespace packages in Requires
- Update Requires from setup.py
- Update %description from README.rst
- Add namespace packages to BuildRequires
- Remove namespace files in %install target
- Explicitly specify Python files of the package in %files

-------------------------------------------------------------------
Thu Sep 14 12:00:55 UTC 2017 - adrian.glaubitz@suse.com

- New upstream release
  + Version 3.1.0
- Update patch to drop compatible releases operator from setup.py
  + ab_drop-compatible-releases-operator.patch

-------------------------------------------------------------------
Thu Jul 13 11:34:52 UTC 2017 - adrian.glaubitz@suse.com

- Add python-azure-nspkg to Requires

-------------------------------------------------------------------
Tue Jun 27 14:16:40 UTC 2017 - adrian.glaubitz@suse.com

- Initial build
  + Version 3.0.0
- Add patch to drop compatible releases operator from setup.py,
  required for SLES12 as the setuptools version is too old
  + ab_drop-compatible-releases-operator.patch