File python-dfVFS.changes of Package python-dfVFS

-------------------------------------------------------------------
Thu Jan 11 21:53:23 UTC 2018 - Greg.Freemyer@gmail.com

- update to v0~20171230
  * add more python3 support (even though openSUSE package doesn't use it)
  * bug fixes
  * compatible with plaso 20171231
- revert effort to use Python singlespec.  It's just not working smoothly.

-------------------------------------------------------------------
Mon Oct  2 21:09:51 UTC 2017 - Greg.Freemyer@gmail.com

- update to v0~20170723
  * worked on internal test structure
- add python3 support
- implement python singlespec syntax
- In Requires: lines for libyal python bindings, use the python-lib* variant of the package
	Python singlespec automatically converts that to python2 / python3 as appropriate
- remove Requres: python-protobuf.  It has been replaced by a JSON solution
- adopt upstream name of python{23}-tsk3

-------------------------------------------------------------------
Sun Feb 26 22:14:42 UTC 2017 - Greg.Freemyer@gmail.com

- correct Requires to have 0~ prefix

-------------------------------------------------------------------
Thu Jul 14 02:09:04 UTC 2016 - Greg.Freemyer@gmail.com

- update to v0~20160918
  * still pre-release and no ChangeLog available
  * add requires pyfwnt, pyvslvm, python-dfdatetime

-------------------------------------------------------------------
Wed Dec  2 21:00:42 UTC 2015 - Greg.Freemyer@gmail.com

- update to v0~20160108
  * still pre-release and no ChangeLog available
  * required by plaso v1.4.0 which is in feature freeze at this point
- update pyvshadow requires to version v0~20160110
- add Requires: pyfsntfs

-------------------------------------------------------------------
Wed Jul  1 22:20:33 UTC 2015 - Greg.Freemyer@gmail.com

- update to v0~20150708
  * warning, breaks plaso prior to v1.3.0rc2
  * still pre-release and no ChangeLog available

-------------------------------------------------------------------
Fri May  8 20:30:48 UTC 2015 - Greg.Freemyer@gmail.com

- update to v0~20150408
  * Plaso is the primary consumer of dfVFS, but it can be used standalone and may have other consumers in the future
  * Warning breaks JSON serialization in plaso and require a plaso version of 20150507 or later.

-------------------------------------------------------------------
Wed Mar 25 14:59:26 UTC 2015 - Greg.Freemyer@gmail.com

- update to v0~20150303
  * dfVFS is in a rapid state of development and Changelog entries have not been implemented by upstream
- add Requires: pysigscan, it is a new dependency
- add a new %exclude in %files due to doubly included %doc files
- remove spec file entry deleting installed examples.  Resolved upstream.
  * see https://github.com/log2timeline/dfvfs/issues/4
- chmod run_tests.py to remove the executable bits.  Was causing a rmplint warning.

-------------------------------------------------------------------
Wed Jan 21 15:22:54 UTC 2015 - Greg.Freemyer@gmail.com

- update to v0~20150108
  * bugfix for auto-dependency build
- add explicit "%py_compile ." to resolve rpmlint complaint about datestamps not matching
- add the examples folder to the %doc section of %files
- add run_tests.py to the %doc section of %files

-------------------------------------------------------------------
Mon Dec 22 22:59:29 UTC 2014 - Greg.Freemyer@gmail.com

- upgrade to v0~20141220
  * dfVFS is in a rapid state of development and Changelog entries have not been implemented by upstream
- v0~20141220 required by latest plaso release
- update Url field to point to the new github site
- update source to be complete URL
- delete DL_URL field
- add an exclude for the "examples" that are provided.  They need a better namespace.
- add check_dependencies.py to %doc so that users can verify they have usable dependencies

-------------------------------------------------------------------
Thu Aug 21 17:47:47 UTC 2014 - Greg.Freemyer@gmail.com

- add a %doc line to %files section
- change the license tag to Apache-2.0
- add Requires libvmdk since it is now in OBS
- add Requires libvhdi since it is now in OBS

-------------------------------------------------------------------
Wed Aug 20 15:35:12 UTC 2014 - Greg.Freemyer@gmail.com

- add missing "Requires: pyqcow" line to specfile
- remove %attr(755...) line and instead use sed to remove #!/usr/bin/python from *py files
- cleanup Requires: in general

-------------------------------------------------------------------
Mon Aug 18 19:39:53 UTC 2014 - Greg.Freemyer@gmail.com

- initial version in OBS (version 0~20140727)