File nsca-ng.changes of Package nsca-ng

-------------------------------------------------------------------
Tue Apr  2 15:16:50 UTC 2019 - Marcus Rueckert <mrueckert@suse.de>

- update to 1.6
  - Work around TLSv1.3 PSK bug in (at least) OpenSSL 1.1.1b.
  - Apply a few minor improvements.

-------------------------------------------------------------------
Mon Feb 26 12:51:25 UTC 2018 - mcaj@suse.cz

- Resolving the conflict with the old package nsca via
  provides / obsolates the new package will provide the same
  function but in the secure way.

-------------------------------------------------------------------
Fri Feb 16 14:26:43 UTC 2018 - mrueckert@suse.de

- one scriptlet block was guarded in an %if systemd which basically
  made it a noop.
- drop unneeded requires for nagios-common

-------------------------------------------------------------------
Thu Jan 11 16:46:36 UTC 2018 - jengelh@inai.de

- Use a single %_service_* call per scriptlet to reduce output
  code.

-------------------------------------------------------------------
Thu Jan 11 13:36:29 UTC 2018 - mcaj@suse.com

- Added conflict for nsca-client.

-------------------------------------------------------------------
Tue Jan  2 12:07:09 UTC 2018 - tchvatal@suse.com

- Reduce the support only for openSUSE
- Make sure we build on Tumbleweed
- Run also the generic tests not just perl ones
- Disable perl module as it fails to build with them on new openssl
  releases due to refactoring done in bio.h (the same problem is
  in the python modules)
- Due to ssl requirements that are too high simply always require
  systemd package as all systems with new enough openssl contain
  systemd too

-------------------------------------------------------------------
Tue Aug 29 10:33:50 UTC 2017 - mrueckert@suse.de

- bump fedora conditionals

-------------------------------------------------------------------
Fri Nov 25 11:46:21 UTC 2016 - mrueckert@suse.de

- enable perl bindings

-------------------------------------------------------------------
Fri Nov 25 11:23:03 UTC 2016 - mrueckert@suse.de

- update to 1.5
  - enable openssl 1.1
  - Include an experimental NSCA-ng client module for Perl.
  - Link against libsystemd instead of libsystemd-daemon when using
    systemd version 210 or newer, where the latter library has been
    merged into the former.
  - Include the systemd.service(5) and systemd.socket(5) files with
    the release tarball.
  - Update our copy of libev from version 4.15 to version 4.22.
    The new release provides a number of bug fixes and small
    enhancements.
- drop nsca-ng.HEAD.patch and BR needed for it
- no longer ship our own copies of  nsca-ng.service nsca-ng.socket
  included upstream now.

-------------------------------------------------------------------
Mon Apr 13 16:22:06 UTC 2015 - mrueckert@suse.de

- make the rc symlink suse only

-------------------------------------------------------------------
Mon Apr 13 15:29:38 UTC 2015 - mrueckert@suse.de

- make it build on non suse distros

-------------------------------------------------------------------
Mon Apr 13 14:08:50 UTC 2015 - mrueckert@suse.de

- initial package