File project.diff of Package ruby-common

--- gem_build_cleanup.orig
+++ gem_build_cleanup
@@ -1,4 +1,5 @@
 #!/bin/sh
+export QA_SKIP_BUILD_ROOT=1
 if [ ${#*} = 1 ] ; then
     if [ -d "$1" ] ; then
         find $1 \
--- gem_install.sh.orig
+++ gem_install.sh
@@ -42,7 +42,7 @@ options.gemversion=nil
 options.gemsuffix=nil
 options.otheropts=[]
 options.ua_dir='/etc/alternatives'
-options.docdir='/usr/share/doc/packages'
+options.docdir='/usr/share/doc'
 # once we start fixing packages set this to true
 options.symlinkbinaries=false
 options.verbose = false
--- opensuse.spec.erb.orig
+++ opensuse.spec.erb
@@ -66,7 +66,7 @@
   gem_platform       = Gem::Platform.new(RbConfig::CONFIG["arch"]).to_s
   rb_bindir          = RbConfig::CONFIG['bindir']
   rb_sysconfdir      = RbConfig::CONFIG['sysconfdir']
-  docdir             = '/usr/share/doc/packages'
+  docdir             = '/usr/share/doc'
   gem_spec           = Gem::Specification.new
   gem_base_dir       = patch_libdir(gem_spec.base_dir)
   gem_cache_dir      = patch_libdir(gem_spec.cache_dir)
@@ -91,7 +91,7 @@
 Summary:        <%= config[:summary] or spec.summary %>
 Group:          Development/Languages/Ruby
 <% unless spec.executables.empty? -%>
-PreReq:         update-alternatives
+PreReq:         chkconfig 
 <% end -%>
 
 %description -n <%= pkg_basename %><%= config[:version_suffix] %>
@@ -156,20 +156,20 @@ Test::Unit or RSpec files, useful for de
 <% unless spec.executables.empty? -%>
 %post -n <%= pkg_basename %><%= config[:version_suffix] %>
 <% spec.executables.each do |executable| -%>
-/usr/sbin/update-alternatives --install \
+/usr/sbin/alternatives --install \
     <%= rb_bindir %>/<%= executable %>                      <%= executable                      %> <%= rb_bindir %>/<%= "#{executable}#{rb_suffix}-#{spec.version}" %> <%= mod_weight %>
-/usr/sbin/update-alternatives --install \
+/usr/sbin/alternatives --install \
     <%= rb_bindir %>/<%= "#{executable}-#{spec.version}" %> <%= "#{executable}-#{spec.version}" %> <%= rb_bindir %>/<%= "#{executable}#{rb_suffix}-#{spec.version}" %> <%= mod_weight %>
-/usr/sbin/update-alternatives --install \
+/usr/sbin/alternatives --install \
     <%= rb_bindir %>/<%= "#{executable}#{rb_suffix}" %>     <%= "#{executable}#{rb_suffix}"     %> <%= rb_bindir %>/<%= "#{executable}#{rb_suffix}-#{spec.version}" %> <%= mod_weight %>
 <% end -%>
 
 %preun -n <%= pkg_basename %><%= config[:version_suffix] %>
 if [ "$1" = 0 ] ; then
 <% spec.executables.each do |executable| -%>
-    /usr/sbin/update-alternatives --remove <%= executable                      %> <%= rb_bindir %>/<%= "#{executable}#{rb_suffix}-#{spec.version}" %>
-    /usr/sbin/update-alternatives --remove <%= "#{executable}-#{spec.version}" %> <%= rb_bindir %>/<%= "#{executable}#{rb_suffix}-#{spec.version}" %>
-    /usr/sbin/update-alternatives --remove <%= "#{executable}#{rb_suffix}"     %> <%= rb_bindir %>/<%= "#{executable}#{rb_suffix}-#{spec.version}" %>
+    /usr/sbin/alternatives --remove <%= executable                      %> <%= rb_bindir %>/<%= "#{executable}#{rb_suffix}-#{spec.version}" %>
+    /usr/sbin/alternatives --remove <%= "#{executable}-#{spec.version}" %> <%= rb_bindir %>/<%= "#{executable}#{rb_suffix}-#{spec.version}" %>
+    /usr/sbin/alternatives --remove <%= "#{executable}#{rb_suffix}"     %> <%= rb_bindir %>/<%= "#{executable}#{rb_suffix}-#{spec.version}" %>
 <% end -%>
 fi
 <% end -%>
--- ruby-common.spec.orig
+++ ruby-common.spec
@@ -45,9 +45,8 @@ Url:            https://github.com/openS
 Requires:       /usr/bin/getopt
 #Requires:       ruby-devel
 Requires:       rubygem(gem2rpm)
-Recommends:     rubygem(%{rb_default_ruby_abi}:gem2rpm)
+#Recommends:     rubygem(%{rb_default_ruby_abi}:gem2rpm)
 #Requires:       rubygems > 1.8
-Requires:       fdupes
 BuildArch:      noarch
 Provides:       ruby-macros = %{rpm_macros_version}
 %if 0%{?suse_version} < 1140 && 0%{?suse_version} > 1110