File noprereqdeprec.diff of Package python3-rpm

Not deprecated for SUSE builds.

--- ./build/parsePreamble.c.orig	2011-05-11 15:59:08.000000000 +0000
+++ ./build/parsePreamble.c	2011-05-11 16:35:47.000000000 +0000
@@ -891,7 +891,7 @@ static struct PreambleRec_s const preamb
     {RPMTAG_ICON,		0, 0, LEN_AND_STR("icon")},
     {RPMTAG_PROVIDEFLAGS,	0, 0, LEN_AND_STR("provides")},
     {RPMTAG_REQUIREFLAGS,	2, 0, LEN_AND_STR("requires")},
-    {RPMTAG_PREREQ,		2, 1, LEN_AND_STR("prereq")},
+    {RPMTAG_PREREQ,		2, 0, LEN_AND_STR("prereq")},
     {RPMTAG_CONFLICTFLAGS,	0, 0, LEN_AND_STR("conflicts")},
     {RPMTAG_OBSOLETEFLAGS,	0, 0, LEN_AND_STR("obsoletes")},
     {RPMTAG_PREFIXES,		0, 0, LEN_AND_STR("prefixes")},
@@ -900,7 +900,7 @@ static struct PreambleRec_s const preamb
     {RPMTAG_BUILDARCHS,		0, 0, LEN_AND_STR("buildarchitectures")},
     {RPMTAG_BUILDARCHS,		0, 0, LEN_AND_STR("buildarch")},
     {RPMTAG_BUILDCONFLICTS,	0, 0, LEN_AND_STR("buildconflicts")},
-    {RPMTAG_BUILDPREREQ,	0, 1, LEN_AND_STR("buildprereq")},
+    {RPMTAG_BUILDPREREQ,	0, 0, LEN_AND_STR("buildprereq")},
     {RPMTAG_BUILDREQUIRES,	0, 0, LEN_AND_STR("buildrequires")},
     {RPMTAG_AUTOREQPROV,	0, 0, LEN_AND_STR("autoreqprov")},
     {RPMTAG_AUTOREQ,		0, 0, LEN_AND_STR("autoreq")},