File gradle.changes of Package gradle

-------------------------------------------------------------------
Tue Dec 17 11:49:50 UTC 2019 - Fridrich Strba <fstrba@suse.com>

- Avoid all-released-versions.json as source, since we are not
  building integration tests.

-------------------------------------------------------------------
Mon Dec  9 12:38:32 UTC 2019 - Fridrich Strba <fstrba@suse.com>

- Modified patch:
  * gradle-4.4.1-asm7.patch
    + Rediff and use ASM7 api instead of ASM6, since we are using
      objectweb-asm 7.2
- Added patches:
  * cast-estimated-runtime-to-long.patch
    + estimatedRuntime must be cast to long otherwise gradle build
      fails with "Cannot assign value of type java.math.BigDecimal
      to variable of type long".
  * java11-compatibility.patch
    + Fixes the compatibility with Java 11. This is backport of
      upstream changes in 4.8
  * java8-compatibility.patch
    + Keep compatibility with Java 8 by avoiding to use Java 9+
      APIs
  * remove-timestamps.patch
    + Avoid timestamps and thus irreproducible builds

-------------------------------------------------------------------
Mon Nov 25 11:14:34 UTC 2019 - Fridrich Strba <fstrba@suse.com>

- Added patch:
  * gradle-4.4.1-asm7.patch
    + fix build with objectweb-asm 7.2

-------------------------------------------------------------------
Wed Nov 20 21:31:11 UTC 2019 - Fridrich Strba <fstrba@suse.com>

- Gradle looks for slf4j-api.jar, so we provide a link there

-------------------------------------------------------------------
Sun Nov 17 20:04:50 UTC 2019 - Fridrich Strba <fstrba@suse.com>

- Package a full gradle instead of the open apis only
- Upgrade to version 4.4.1
- Added patches:
  * 0001-Gradle-local-mode.patch
    + Use gradle local mode by default
  * 0002-Remove-Class-Path-from-manifest.patch
    + Remove classpath from manifest
  * 0003-Implement-XMvn-repository-factory-method.patch
    + Implement factory methods for xmvn repository
  * 0004-Use-unversioned-dependency-JAR-names.patch
    + Use unversioned jar files for dependencies
  * 0005-Port-to-Maven-3.3.9-and-Eclipse-Aether.patch
    + Port to maven 3.3.9 and maven-resolver
  * 0006-Disable-code-quality-checks.patch
    + Disable code quality checks useless for rpm build
  * 0007-Port-to-Kryo-3.0.patch
    + Fix build with kryo 3.0
  * 0008-Port-to-Ivy-2.4.0.patch
    + Fix build with apache-ivy 2.4.0
  * 0009-Port-to-Polyglot-0.1.8.patch
    + Allow building with tesla-polyglot >= 0.1.8
  * 0010-Port-from-Simple-4-to-Jetty-9.patch
    + build using org.eclipse.jetty:jetty-server instead of
      org.simpleframework:simple
  * 0011-Disable-benchmarks.patch
    + Do not run benchmarks useless during rpm build
  * 0012-Disable-patching-of-external-modules.patch
    + Disable patching of external modules during the build
  * 0013-Add-missing-transitive-dependencies.patch
    + Add transitive dependencies for aqute-bndlib, jansi and zinc
  * 0014-Disable-ideNative-module.patch
    + Do not build ideNative module
  * 0015-Disable-docs-build.patch
    + Do not build docs needing asciidoctorj that we don't have
  * 0016-Port-to-guava-20.0.patch
    + Fix build with guava 20.0
  * 0017-Set-core-api-source-level-to-8.patch
    + Build core-api submodule with source/target 8

-------------------------------------------------------------------
Tue Sep 17 11:37:40 UTC 2019 - Pedro Monreal Gonzalez <pmonrealgonzalez@suse.com>

- Add LICENSE file to the correct tag

-------------------------------------------------------------------
Tue Sep 17 11:31:39 UTC 2019 - Pedro Monreal Gonzalez <pmonrealgonzalez@suse.com>

- Security fix: [bsc#1150998, CVE-2019-16370]
  * The PGP signing plugin in Gradle before 6.0 relies on the SHA-1
    algorithm. PGP signing plugin might allow an attacker to replace
    an artifact with a different one.
- Add gradle-CVE-2019-16370.patch

-------------------------------------------------------------------
Thu Sep 14 05:34:54 UTC 2017 - fstrba@suse.com

- Specify java source and target level 1.6 in order to allow
  building with jdk9

-------------------------------------------------------------------
Thu Dec 15 05:10:11 UTC 2016 - margherio.adam@gmail.com

- Updated to 3.2.1

-------------------------------------------------------------------
Mon Dec 28 13:56:20 UTC 2015 - mailaender@opensuse.org

- Update to 2.10

-------------------------------------------------------------------
Tue Apr 14 19:21:36 UTC 2015 - afaerber@suse.de

- Update to 2.3

-------------------------------------------------------------------
Tue Jul  8 08:48:15 UTC 2014 - tchvatal@suse.com

- Cleanup the sle11 build bit more.

-------------------------------------------------------------------
Fri Jun 27 14:22:37 UTC 2014 - tchvatal@suse.com

- Build on sle11

-------------------------------------------------------------------
Fri Jun 27 12:24:36 UTC 2014 - tchvatal@suse.com

- Cleanup the package to be up par at least a bit

-------------------------------------------------------------------
Fri Nov 27 00:00:00 UTC 2009 - lkundrak@v3.sk

- Initial packaging