A new user interface for you! Read more...

File QtBitcoinTrader.spec of Package QtBitcoinTrader

Summary: Cryptocurrency exchange client with rich trading tools made with Qt
Name: QtBitcoinTrader
Conflicts: QtBitcoinTrader-mobility
Version: 1.30.03
Release: 1
License: GPL-3.0
Group: Productivity/Office/Finance
Source: https://github.com/JulyIGHOR/QtBitcoinTrader/archive/%{name}-%{version}.tar.gz
URL: http://qtopentrader.com
BuildRequires: unzip
BuildRequires: libQt5Core-devel >= 5.5
BuildRequires: libQt5Network-devel >= 5.5
BuildRequires: libQt5Gui-devel >= 5.5
BuildRequires: libQt5Widgets-devel >= 5.5
BuildRequires: libqt5-qtscript-devel >= 5.5
BuildRequires: libqt5-qtmultimedia-devel >= 5.5
BuildRequires: gcc-c++ >= 4.7
BuildRequires: openssl-devel
%if 0%{?suse_version}
BuildRequires:  update-desktop-files
%endif
BuildRoot:      %{_tmppath}/%{name}-%{version}-build

%description
Qt Bitcoin Trader is open source application that helps you open and cancel Mt.Gox, BTC-e, Bitstamp, BTCChina orders very fast. Real time data monitoring.
Developed on pure Qt, uses OpenSSL.

Api key and secret is protected by password using AES 256 encryption.
Your password must be at least 8 characters and contain letters, digits, and special characters.
Interface Languages: English, Russian, Ukrainian, Spanish, Dutch, Norwegian, German, Chinese, Polish, Czech, Italiano, Turkish.

%prep
%setup -n QtBitcoinTrader-%{version}

%build
qmake-qt5 src/QtBitcoinTrader_Desktop.pro
make RPM_OPT_FLAGS="$RPM_OPT_FLAGS"

%install
make INSTALL_ROOT=$RPM_BUILD_ROOT install
%if 0%{?suse_version}
%suse_update_desktop_file -i -r %{name} Office Finance
%endif

%files
%defattr (0644, root, root)
%attr(0755, root, root) /usr/bin/%{name}
/usr/share/applications/%{name}.desktop
/usr/share/pixmaps/%{name}.png

%clean
rm -rf $RPM_BUILD_ROOT

%changelog
* Thu Feb 14 2017 linux4humans <zenitur@yandex.ru> 1.3.03
- Upgrade to 1.30.03

* Sat Oct 15 2016 linux4humans <zenitur@yandex.ru> 1.3.01
- Upgrade to 1.3.01

* Fri Sep 30 2016 linux4humans <zenitur@yandex.ru> 1.20.01
- Upgrade to 1.20.01

* Thu Apr 10 2014 m0Ray <dmitry.a.kirilin@gmail.com> 1.07.98
- Upgrade to 1.07.98

* Wed Mar 05 2014 m0Ray <dmitry.a.kirilin@gmail.com> 1.07.97
- Downloaded stable v.1.07.97, written spec file