A new user interface for you! Read more...

File rubygem-yajl-ruby.changes of Package rubygem-yajl-ruby

-------------------------------------------------------------------
Wed Oct 22 13:39:22 UTC 2014 - tboerger@suse.com

- Fixed the license as there is still BSD-3-Clause source included

-------------------------------------------------------------------
Wed Oct 22 08:29:41 UTC 2014 - tboerger@suse.com

- For SLES 11 it exceeds the badness limit

-------------------------------------------------------------------
Wed Oct 22 08:20:23 UTC 2014 - tboerger@suse.com

- Made it really aware of new macros
- Removed manual entry, maximum badness not exceeded

-------------------------------------------------------------------
Tue Oct 14 12:16:47 UTC 2014 - adrian@suse.de

- adapt to new rubygem packaging style

-------------------------------------------------------------------
Mon Jul 28 10:10:38 UTC 2014 - coolo@suse.com

- updated to version 1.2.1, no changelog

-------------------------------------------------------------------
Thu Feb  6 09:31:43 UTC 2014 - coolo@suse.com

- use new macros

-------------------------------------------------------------------
Fri Dec 20 12:02:53 UTC 2013 - coolo@suse.com

- updated to version 1.2.0, no changelog

-------------------------------------------------------------------
Tue Jul 24 07:52:30 UTC 2012 - cfarrell@suse.com

- license update: MIT and BSD-3-Clause
  See data/LICENSE.txt (MIT) - also numerous files are BSD-3-Clause
  licensed

-------------------------------------------------------------------
Tue Jul 10 19:08:56 UTC 2012 - jatan@suse.de

- Add provides for rubygem-yajl-ruby-1 and rubygem-yajl-ruby-1_1 

-------------------------------------------------------------------
Wed Apr  4 13:20:49 UTC 2012 - coolo@suse.com

- remove .c and .h files to avoid rpmlint exodus

-------------------------------------------------------------------
Tue Apr  3 08:36:33 UTC 2012 - coolo@suse.com

- update to 1.1
  * fix compilation due to a "bug" in gcc-llvm on 10.7.2
  * fix gemspec so ruby 1.8.6 or later is required

  * add deprecation notice for Yajl's Bzip2 support
  * add deprecation notice for Yajl's Deflate support
  * add deprecation notice for Yajl's Gzip support
  * add deprecation notice for Yajl's JSON gem compatibility API
  * add deprecation notice for Yajl::HttpStream
  * change the path the extension is copied into to be 'lib/yajl'
  * remove 'ext' from the loadpath
  
  * fix bug where Yajl::HttpStream wouldn't pass through a user-specified socket
  * fix incorrect Ruby initialization hook method name
  * Bump bundled YAJL version to 1.0.12
  * fix to correctly symbolize multibyte characters on 1.9
  * add `:headers` option to Yajl::HttpStream for user-specified arbitrary headers
  
  * define RSTRING_NOT_MODIFIED for rbx to prevent string caching, making things A LOT faster (100x)
  
  * fixed a retart bug where Yajl::VERSION wasn't defined when explicitly requiring yajl/http_stream
  
  * added a new html_safe option to Yajl::Encoder to escape '/' characters for use in the DOM
  * moved away from Jeweler to a Bundler/manual gemfile management setup
  
  * moved to rspec2
  * fixed some compilation warnings on 1.9.3
  * brought over latest from Yajl upstream
  * finally removed the deprecated Yajl::Stream methods
  * moved to rake-compiler
  * moved to Bundler for development
  * fix memory corruption bug when using :pretty => true and a custom indent string
  * fixed memory leak when exceptions were being raised during a parse
  
  * fix a bug in chunked http response regex (thanks to http://github.com/kevn for catching this)
  * Make sure json compability doesn't break ActiveSupport#to_json
  * fix improper usage of rb_define_method
  
  * full string encoding support for 1.9, respecting Encoding.default_internal
  * refactor the #to_json function bodies into a C macro
  * some misc code cleanup in the benchmark scripts

-------------------------------------------------------------------
Thu Jul  1 10:22:33 UTC 2010 - mrueckert@suse.de

- initial package