File xfce4-whiskermenu-plugin.spec of Package xfce4-whiskermenu-plugin

Name:           xfce4-whiskermenu-plugin
Version:        0
Release:        0
Summary:        Upstream %{name}
License:        GPL-2.0
Group:          System/GUI/XFCE
Url:            https://git.xfce.org/panel-plugins/xfce4-whiskermenu-plugin
Source0: %{name}-%{version}.tar
#KEEP NOSOURCE DEBUGINFO
NoSource: 0
BuildRoot:      %{_tmppath}/%{name}-%{version}-build
BuildRequires:  xfce4-dev-tools
BuildRequires:  cmake
BuildRequires:  pkg-config
BuildRequires:  gcc-c++
BuildRequires: pkgconfig(gtk+-3.0) >= 3.22
BuildRequires: pkgconfig(exo-2) >= 0.11
BuildRequires: pkgconfig(garcon-1)
BuildRequires: pkgconfig(libxfce4panel-2.0) >= 4.11
BuildRequires: pkgconfig(libxfce4ui-2) >= 4.11
BuildRequires: pkgconfig(libxfce4util-1.0) >= 4.11
%description
%lang_package
%package -n xfce4-panel-plugin-whiskermenu
Summary: Whisker Plugin for the Xfce Panel
Group: System/GUI/XFCE
Requires: xfce4-panel
Requires:       %{name}-lang = %{version}-%{release}
%description -n xfce4-panel-plugin-whiskermenu
%prep
%setup -q
%build
%cmake
%make_build
%install
%cmake_install
find %{buildroot} -name "*.la" -print -delete
%find_lang %{name}
%files
%dir %{_datadir}/xfce4
%files -n xfce4-panel-plugin-whiskermenu
%{_bindir}/*
%{_datadir}/icons/*
%{_datadir}/xfce4
%{_libdir}/xfce4
%{_mandir}/man?/*
%files lang -f %{name}.lang