LogoopenSUSE Build Service > Projects
Sign Up | Log In

View File configure-drop-udev-check.patch of Package midisport-firmware (Project home:seife:testing)

From: Adrian Knoth <adi@drcomp.erfurt.thur.de>
Forwarded: not-needed
Description: Strip udev version check from configure
 We are Debian, we know the udev version. (via build dependency).
 Without this patch, we'd need to augment $PATH (/sbin/udevadm) in the
 pbuilder, just to find out that we have the right one.
--- a/configure.ac
+++ b/configure.ac
@@ -22,18 +22,6 @@
   AC_MSG_ERROR([$FXLOAD not found; please install the fxload package first])
 fi
 
-AC_MSG_CHECKING([for udev version])
-udev_ver=`udevinfo -V | awk '{ print $3 }'`
-if test -n "$udev_ver"; then
-  AC_MSG_RESULT([$udev_ver])
-else
-  AC_MSG_RESULT([none])
-  udev_ver="0"
-fi
-if test "$udev_ver" -lt 057; then
-  AC_MSG_ERROR([udev version 057 or later is required])
-fi
-
 AC_ARG_WITH([udev],
 	    AS_HELP_STRING([--with-udev=dir],
 			   [specify udev directory [[/etc/udev]]]),