File PKGBUILD of Package kup-kf5

# Maintainer; Simper < simonpersson1 AT gmail DOT com >

pkgname=kup
pkgver=0.7.3
pkgrel=1
pkgdesc="Kup Backup System"
arch=('i686' 'x86_64')
url="http://http://kde-apps.org/content/show.php/Kup+Backup+System?content=147465"
license=('GPL')
depends=('qt5-base' 'kcoreaddons' 'kdbusaddons' 'ki18n' 'kio' 'solid' 'kidletime' 'knotifications' 'kiconthemes' 'kconfig' 'kinit' 'plasma-framework')
makedepends=('cmake' 'extra-cmake-modules' 'phonon-qt5-gstreamer' 'python')
optdepends=(
    'bup: support for incremental backups'
    'rsync: support for synced backups'
    )
source=("${pkgname}-${pkgver}.tar.gz")
md5sums=("SKIP")

prepare() {
	[ -d "build" ] && rm -rf build
	mkdir -p build
}

build() {
	cd build
	cmake ../${pkgname}-${pkgver} \
		-DCMAKE_BUILD_TYPE=Release \
		-DCMAKE_INSTALL_PREFIX=/usr \
		-DKDE_INSTALL_USE_QT_SYS_PATHS=ON
	make
}

package() {
	cd build
	make DESTDIR="${pkgdir}" install
}