LogoopenSUSE Build Service > Projects
Sign Up | Log In

View File perl-CPAN-Meta-Requirements.changes of Package perl-CPAN-Meta-Requirements (Project home:smithfarm)

-------------------------------------------------------------------
Thu Apr 16 21:26:17 UTC 2015 - coolo@suse.com

- updated to 2.133
   see /usr/share/doc/packages/perl-CPAN-Meta-Requirements/Changes

  2.133     2015-02-22 06:35:34-05:00 America/New_York
  
      [FIXED]
  
      - In fixing preservation of "0.00", some Module => 0 optimizations were
        lost; this restores those optimizations
  
  2.132     2015-01-22 17:09:19-05:00 America/New_York
  
      [FIXED]
  
      - Precision of version requirement "0.00" is preserved when merging
        requirements.
  
  2.131     2014-12-23 15:04:19-05:00 America/New_York
  
      [ENHANCEMENTS]
  
      - Merging Module => 0 into requirements is now optimized
  
      [PREREQS]
  
      - Scalar::Utils removed as a prerequisite
  
  2.130     2014-11-19 23:25:46-05:00 America/New_York
  
      [ADDED]
  
      - from_string_hash can take optional constructor arguments
  
      [CHANGED]
  
      - bad_version_hook callback gets module name as well as version string
  
      - undefined/empty versions given to from_string_hash or
        add_string_requirement now carp and are coerced to "0" instead of
        being fatal.  This is more consistent with how the other requirement
        functions work.
  
  2.129     2014-11-13 16:28:45-05:00 America/New_York
  
      [FIXED]
  
      - from_string_hash can now accept v-strings as hash values
  
  2.128     2014-09-06 00:04:22-04:00 America/New_York
  
      [FIXED]
  
      - Throws an error at compile time if neither version nor
        the ExtUtils::MakeMaker bootstrap are available
  
  2.127     2014-09-04 22:17:44-04:00 America/New_York
  
      [FIXED]
  
      - Works around limitations in version::vpp detecting v-string magic
  
      [PREREQS]
  
      - Requires version.pm 0.88 in metadata, but code should work with any
        version of version.pm
  
      - Adds support for forthcoming ExtUtils::MakeMaker bootstrap version.pm
        for Perls older than 5.10.0
  
  2.126     2014-07-30 16:26:29-04:00 America/New_York
  
      [FIXED]
  
      - Fixed compatibility with version.pm 0.77
  
      [DOCUMENTED]
  
      - Minor documentation fixes
  
      [CHANGED]
  
      - Modernized distribution meta files

-------------------------------------------------------------------
Fri Dec  6 15:53:15 UTC 2013 - coolo@suse.com

- readd the fake provides - removing them was wrong

-------------------------------------------------------------------
Tue Nov 26 17:45:11 UTC 2013 - coolo@suse.com

- more fake provides

-------------------------------------------------------------------
Fri Oct  4 09:15:20 UTC 2013 - coolo@suse.com

- updated to 2.125
  [FIXED]
    - updated Makefile.PL logic to support PERL_NO_HIGHLANDER
    - Better fix than 2.123.  On old perls, rather than install into
      'core', we continue to install into the proper 'site' library,
      but force UNINST=1 when necessary to remove stale copies
      from ExtUtils::MakeMaker
    - On Perls prior to v5.12, CPAN::Meta::Requirements will be installed
      into the 'core' library path to avoid an older version bundled with
      ExtUtils::MakeMaker and installed there taking precedence.

-------------------------------------------------------------------
Tue Jun 11 19:01:54 UTC 2013 - coolo@suse.com

- rebuild for fixed perl macros

-------------------------------------------------------------------
Mon Jun  3 11:56:55 UTC 2013 - coolo@suse.com

- add workaround for mismatch between rpm and perl version logic

-------------------------------------------------------------------
Thu May 31 13:00:13 UTC 2012 - coolo@suse.com

- initial package 2.122
    * created by cpanspec 1.78.06