File sphinx.patch of Package polybar

--- doc/conf.py	2020-12-22 09:04:52.879125160 +0100
+++ doc/conf2.py	2020-12-22 09:09:02.607319684 +0100
@@ -17,7 +17,6 @@
 import subprocess
 from docutils.nodes import Node
 from typing import List
-from sphinx.domains.changeset import VersionChange
 
 
 # -- Project information -----------------------------------------------------
@@ -197,24 +196,3 @@
 
 # The 'versionadded' and 'versionchanged' directives are overridden.
 suppress_warnings = ['app.add_directive']
-
-def setup(app):
-  app.add_directive('deprecated', VersionDirective)
-  app.add_directive('versionadded', VersionDirective)
-  app.add_directive('versionchanged', VersionDirective)
-
-class VersionDirective(VersionChange):
-  """
-  Overwrites the Sphinx directive for versionchanged, versionadded, and
-  deprecated and adds an unreleased tag to versions that are not yet released
-  """
-  def run(self) -> List[Node]:
-    # If the tag exists 'git rev-parse' will succeed and otherwise fail
-    completed = subprocess.run(["git", "rev-parse", self.arguments[0]],
-        stdout=subprocess.DEVNULL, stderr=subprocess.DEVNULL, cwd=doc_path,
-        check=False)
-
-    if completed.returncode != 0:
-      self.arguments[0] += " (unreleased)"
-
-    return super().run()
openSUSE Build Service is sponsored by