File brltty-5.0-speechd.diff of Package brltty

From: Jan Engelhardt <jengelh@inai.de>
Date: 2013-06-18 11:27:55.105668872 +0200

speech-dispatcher-0.8 moved speechd.h from /usr/include
to /usr/include/speech-dispatcher.

This patch is not really for upstream; the proper way to
use speech-dispatcher is by way of pkg-config. This here is
just a quick way to get it building in openSUSE again.

---
 Drivers/Speech/SpeechDispatcher/speech.c |    2 +-
 configure                                |    2 +-
 2 files changed, 2 insertions(+), 2 deletions(-)

Index: brltty-4.3/Drivers/Speech/SpeechDispatcher/speech.c
===================================================================
--- brltty-4.3.orig/Drivers/Speech/SpeechDispatcher/speech.c
+++ brltty-4.3/Drivers/Speech/SpeechDispatcher/speech.c
@@ -34,7 +34,7 @@ typedef enum {
 
 #include "spk_driver.h"
 
-#include <libspeechd.h>
+#include <speech-dispatcher/libspeechd.h>
 
 static SPDConnection *connectionHandle = NULL;
 static const char *moduleName;
Index: brltty-4.3/configure
===================================================================
--- brltty-4.3.orig/configure
+++ brltty-4.3/configure
@@ -13484,7 +13484,7 @@
    roots="/usr /usr/local /usr/local/speech-dispatcher /usr/local/speechd /opt/speech-dispatcher /opt/speechd /mingw /mingw/speech-dispatcher /mingw/speechd"
    for root in ${roots}
    do
-      if test -f "${root}/include/libspeechd.h"
+      if test -f "${root}/include/speech-dispatcher/libspeechd.h"
       then
          speechd_root="${root}"
          break