LogoopenSUSE Build Service > Projects
Sign Up | Log In

View File disable_hp-upgrade.patch of Package hplip (Project home:uninstall:Printing)

--- upgrade.py.orig	2013-10-31 12:46:54.000000000 +0100
+++ upgrade.py	2013-12-04 14:58:03.000000000 +0100
@@ -134,6 +134,11 @@ except getopt.GetoptError, e:
 if os.getenv("HPLIP_DEBUG"):
     log.set_level('debug')
 
+
+log.error("HPLIP upgrade is disabled by openSUSE for security reasons, see https://bugzilla.novell.com/show_bug.cgi?id=853405 - if you like to upgrade HPLIP, use an openSUSE software package manager like YaST or zypper.")
+clean_exit(1)
+
+
 for o, a in opts:
     if o in ('-h', '--help'):
         usage()