A new user interface for you! Read more...

File foomatic-filters.changes of Package foomatic-filters

-------------------------------------------------------------------
Tue Mar 26 14:13:04 UTC 2013 - mmeister@suse.com

- Added url as source.
  Please see http://en.opensuse.org/SourceUrls

-------------------------------------------------------------------
Thu May 31 13:07:10 CEST 2012 - jsmeix@suse.de

- Version upgrade to foomatic-filters-4.0.12.
  The version number jumps from 4.0.9 to 4.0.12 because
  the versions 4.0.10 and 4.0.11 got broken due to a bug
  in the release script.
  If incoming PDF needs to be converted to PostScript, use
  preferrably Ghostscript (with the "ps2write" device) for this
  conversion as Ghostscript is better optimized for printing and
  has a more sophisticated color management compared to Poppler.
  See the ChangeLog file for details.

-------------------------------------------------------------------
Thu Mar 29 10:22:06 CEST 2012 - jsmeix@suse.de

- BuildRequire only ghostscript-mini-devel (instead of
  ghostscript-devel and ghostscript-library) because
  in the "Printing" repository Ghostscript is cleaned up
  and upgraded to a stable release >= 9.05 (bnc #735824)
  where ghostscript-library is replaced
  by ghostscript plus ghostscript-devel
  and ghostscript-mini plus ghostscript-mini-devel.

-------------------------------------------------------------------
Wed Feb  8 15:27:39 CET 2012 - jsmeix@suse.de

- Bugfix upgrade to foomatic-filters-4.0-20120208 which is
  the bugfix version 4.0.9.242 (see the VERSION.full file)
  which fixes CVE-2011-2924 (see bnc#713717).
  See the ChangeLog file for details.

-------------------------------------------------------------------
Sun Sep 18 17:17:12 UTC 2011 - jengelh@medozas.de

- Apply packaging guidelines (remove redundant/obsolete
  tags/sections from specfile, etc.)

-------------------------------------------------------------------
Thu Aug 11 10:56:54 CEST 2011 - jsmeix@suse.de

- Version upgrade to foomatic-filters-4.0.9.
  SECURITY FIX for CVE-2011-2697 (see bnc#698451).
  Use "ps2write" instead of "pswrite" as PostScript output device.
  Added support for ICC-based color managment. Both colord
  and CUPS' ICC-related PPD extensions are supported. For
  colord D-Bus is required.
  Several bugs fixed.
  See the ChangeLog file for details.

-------------------------------------------------------------------
Wed Feb  9 17:15:23 CET 2011 - jsmeix@suse.de

- Replaced the not needed strict RPM "Requires: a2ps"
  by "Recommends: a2ps".

-------------------------------------------------------------------
Thu Dec 16 16:06:59 CET 2010 - jsmeix@suse.de

- Version upgrade to foomatic-filters-4.0.6.
  foomatic-rip has several potential crashes fixed.
  See the ChangeLog file for details.
- fix_no-return-in-nonvoid-function.patch is obsolete
  because it is fixed in the sources, see
  http://bugs.linux-foundation.org/show_bug.cgi?id=348

-------------------------------------------------------------------
Thu Apr  8 16:23:13 CEST 2010 - jsmeix@suse.de

- Work with upstream compliant CUPS 1.4 on all platforms
  which means to have a fixed "/usr/lib/cups/" directory
  on all platforms (see Novell/Suse Bugzilla bnc#575544).

-------------------------------------------------------------------
Fri May 29 15:01:17 CEST 2009 - jsmeix@suse.de

- Makeshift fix build on x86_64. The upstream bug report
  is http://bugs.linux-foundation.org/show_bug.cgi?id=349

-------------------------------------------------------------------
Wed May 27 16:00:08 CEST 2009 - jsmeix@suse.de

- Updated to the latest bzr version of the current stable
  version 4.0.1 which was released on 13-May-2009 00:20
  from http://www.openprinting.org/download/foomatic/
  See the ChangeLog file for details.

-------------------------------------------------------------------
Wed Sep 10 11:44:50 CEST 2008 - kssingvo@suse.de

- update to latest bzr version:
  * fix: Make foomatic-rip also working with PPD file names which
    contain brackets or other special characters

-------------------------------------------------------------------
Tue Mar 18 16:26:57 CET 2008 - kssingvo@suse.de

- update to latest bzr version:
  * feature: kill all subprocesses on job termination via TERM signal

-------------------------------------------------------------------
Wed Jan 16 15:24:20 CET 2008 - kssingvo@suse.de

- update to latest bzr version:
  * Allow the parameters of the \"*Foomatic...\" lines which formerly
    had to be given without quotes also to be given with double quotes.
  * Assorted fixes of bugs found during LSB test suite development
  * Fixed wrong handling of CUPS duplex option \"sides\", and bug when
    having more than one option with page overrides.
  * Let Ghostscript always use buffered input.

-------------------------------------------------------------------
Thu Aug  2 13:59:32 CEST 2007 - kssingvo@suse.de

- update to latest bzr version:
  * Added support for suppressing page accounting on a per-driver basis.
  * Performance improvement
  * Fixed bug of custom page sizes not read from the PostScript code
    when the size values are in more than one line
  * Let data structure get written to debug log also if foomatic-rip
    exits with an error (only in debug mode)
  * Replaced sysread() and syswrite() by read() and print()
  * Fixed problem of too high memory consumption when binary output
    data of GhostScript is read line-wise
  * Replaced "linuxprinting.org" by "openprinting.org" or
    "OpenPrinting".

-------------------------------------------------------------------
Wed Oct 18 16:07:34 CEST 2006 - kssingvo@suse.de

- update to new upstream version: contains "fix of bashism"

-------------------------------------------------------------------
Mon Oct  9 12:58:05 CEST 2006 - jsmeix@suse.de

- fixed cyclic 'foomatic-rip -> foomatic-rip' link to the
  correct link: 'foomatic-rip -> ../../../bin/foomatic-rip'
  (bugzilla#210924).

-------------------------------------------------------------------
Wed Sep 20 14:01:19 CEST 2006 - kssingvo@suse.de

- updated to latest bzr (kind of cvs) version:
- foomatic-gswrapper.in: Support for built-in redirection of standard
  output of PostScript programs ("-sstdout=%stderr") in newer
  GhostScript versions. More reliable then using /dev/fd/3 (not always
  available difficult to check presence) or '|cat >3' (not seekable
  and some GhostScript output devices require seekability of the
  output file),
- Removed executable permissions from source files which are not
  executables
- foomatid-rip.in: failing to open IPP attributes file shouldn't be
  fatal
- filter.conf: example of a preferred shell setting
- foomatid-rip.in: detect and use a "modern" shell for shell commands
- foomatic-rip.in: Add support for Solaris LP, made default echo,
  fileconverter, and execpath setable through configure options.
- foomatic-gswrapper.in: made default execpath setable through
  configure options
- foomatic-rip-1.in: fixed to use @sysconfdir@ for configure
- foomatic-gswrapper-1.in: fixed to use @sysconfdir@ for configure
- configure.ac: made default execpath, fileconverter and echo setable
  through configure options.  Generate man pages through configure
- makeMan.in: removed, configure now generates the man pages
- Makefile.in: cleaned up some to work with makes other than gmake
- README, USAGE: added Solaris LP 
- foomatic-rip.in: Better support for non-PJL JCLs. If there are
  Foomatic options of execution style JCL, they are only prefixed with
  "@PJL " if the PPD does not contain a "*JCLBegin:" expression not
  containing "PJL" and if the prefix is not changed by a
  "*FoomaticJCLPrefix:" in the PPD file. If there is a "*JCLBegin:"
  without "PJL" and no "*FoomaticJCLPrefix:" the JCL commands do not
  get any prefix. Fixed also bug of $jobuser and $jobhost not being
  chomped.
- foomatic-rip.in: Added substitution of special XML entities by job
  data, as date, time, job ID, user name, ... (in function
  "unhtmlify()"). This was suggested by George Liu from Ricoh (george
  dot liu at ussj dot ricoh dot com), to support jobs with submission
  of login/password to the printer.
- foomatic-rip.in, foomatic-gswrapper.in: Fix for the fix on the
  regexp for reading the config file (Thanks to Hans-Dieter Kosch,
  hdkosch at t-online dot de, for this fix).
- foomatic-rip.in: In quiet mode (non-logging mode) $logh is closed in
  the beginning but was never opened (Thanks to Hans-Dieter Kosch,
  hdkosch at t-online dot de, for this fix).
- foomatic-gswrapper.in: Fixed quoting of single quotes (Thanks to
  Hans-Dieter Kosch, hdkosch at t-online dot de, for this fix).
- foomatic-rip.in, foomatic-gswrapper.in: Fixed regexp for reading the
  config file (Thanks to Hans-Dieter Kosch, hdkosch at t-online dot
  de, for this fix).
- foomatic-rip.in: Make EPSF files not be an exception when checking
  whether the input file is DSC-conforming. They can also be
  DSC-conforming (thanks to Kevin ODonovan, kevin dot odonovan at nist
  dot gov, for his report); Let the "FontPath" defined in
  /etc/cups/cupsd.conf being used when CUPS is the spooler (thanks to
  Peter Kekesi, kekpeti at freemail dot hu, for his report).
- foomatic-rip.in: Added comment before the line to automatically
  quote unquoted slashes in the allowed characters list or allowed
  regexp.
- foomatic-rip.in: Fixed bug of foomatic-rip replacing a JCL command
  (ex: "@PJL HOLDKEY=1234") if another which is contained in the first
  one is supplied (ex: "@PJL HOLD=STORE"). Thanks to Jociel Cavalcante
  Andrade (jcainfo at inf dot ufes dot br) for reporting the bug and
  testing the fix.


-------------------------------------------------------------------
Tue May 23 21:02:40 CEST 2006 - kssingvo@suse.de

- fixed remote command execution vulnerability SWAMP#4432 (bugzilla#59233)

-------------------------------------------------------------------
Wed Jan 25 21:35:59 CET 2006 - mls@suse.de

- converted neededforbuild to BuildRequires

-------------------------------------------------------------------
Fri Jan 13 11:18:29 CET 2006 - meissner@suse.de

- use -fstack-protector.

-------------------------------------------------------------------
Wed Dec 21 13:41:19 CET 2005 - aj@suse.de

- Remove unpackaged symlinks on lib64 as well.

-------------------------------------------------------------------
Wed Dec 21 01:26:59 CET 2005 - ro@suse.de

- remove unpackaged symlinks 

-------------------------------------------------------------------
Tue Feb 22 15:17:28 CET 2005 - kssingvo@suse.de

- upgrade to 3.0.2, which contains the below security fix only

-------------------------------------------------------------------
Thu Sep 23 16:20:08 CEST 2004 - kssingvo@suse.de

- forget to add cupsomatic as foomatic-rip link (backward compatible)

-------------------------------------------------------------------
Tue Sep 14 14:44:17 CEST 2004 - kssingvo@suse.de

- upgrade to CVS version to keep in sync with cups-drivers package
- author told me that foomatic-rip is 100% compatible with cupsomatic
  made soft-link

-------------------------------------------------------------------
Mon Aug 30 19:31:35 CEST 2004 - kssingvo@suse.de

- fixes for security problem in foomatic-rip, CAN-2004-0801
  (bugzilla#44233)

-------------------------------------------------------------------
Mon Mar  1 10:56:09 CET 2004 - kssingvo@suse.de

- upgrade to version 3.0.1

-------------------------------------------------------------------
Sun Jan 11 10:20:48 CET 2004 - adrian@suse.de

- build as user

-------------------------------------------------------------------
Mon Aug 25 11:27:52 CEST 2003 - kssingvo@suse.de

- updated to 2003-08-21 version (fix for PS code insertion)

-------------------------------------------------------------------
Mon Jul 28 11:29:14 CEST 2003 - kssingvo@suse.de

- fixed problem in version name (removed %cvsdate) - thx meissner

-------------------------------------------------------------------
Tue Jul 15 17:19:04 CEST 2003 - meissner@suse.de

- lib64 fixes.

-------------------------------------------------------------------
Fri Jul  4 13:47:23 CEST 2003 - kssingvo@suse.de

- It's coolo's fault: cannot add cups related link to cups package. :(
  it's now in this package (ugly and hopefully temporary solution)

-------------------------------------------------------------------
Fri Jul  4 12:35:23 CEST 2003 - ro@suse.de

- added directory to filelist /etc/foomatic 

-------------------------------------------------------------------
Fri Jul  4 10:58:42 CEST 2003 - kssingvo@suse.de

- initial version