A new user interface for you! Read more...

File meego-panel-people-libnm.patch of Package meego-panel-people

Index: meego-panel-people-0.2.2/configure
===================================================================
--- meego-panel-people-0.2.2.orig/configure
+++ meego-panel-people-0.2.2/configure
@@ -13496,12 +13496,12 @@ if test -n "$ONLINE_CFLAGS"; then
     pkg_cv_ONLINE_CFLAGS="$ONLINE_CFLAGS"
  elif test -n "$PKG_CONFIG"; then
     if test -n "$PKG_CONFIG" && \
-    { { $as_echo "$as_me:${as_lineno-$LINENO}: \$PKG_CONFIG --exists --print-errors \"libnm_glib >= 0.7\""; } >&5
-  ($PKG_CONFIG --exists --print-errors "libnm_glib >= 0.7") 2>&5
+    { { $as_echo "$as_me:${as_lineno-$LINENO}: \$PKG_CONFIG --exists --print-errors \"libnm-glib >= 0.7\""; } >&5
+  ($PKG_CONFIG --exists --print-errors "libnm-glib >= 0.7") 2>&5
   ac_status=$?
   $as_echo "$as_me:${as_lineno-$LINENO}: \$? = $ac_status" >&5
   test $ac_status = 0; }; then
-  pkg_cv_ONLINE_CFLAGS=`$PKG_CONFIG --cflags "libnm_glib >= 0.7" 2>/dev/null`
+  pkg_cv_ONLINE_CFLAGS=`$PKG_CONFIG --cflags "libnm-glib >= 0.7" 2>/dev/null`
 else
   pkg_failed=yes
 fi
@@ -13512,12 +13512,12 @@ if test -n "$ONLINE_LIBS"; then
     pkg_cv_ONLINE_LIBS="$ONLINE_LIBS"
  elif test -n "$PKG_CONFIG"; then
     if test -n "$PKG_CONFIG" && \
-    { { $as_echo "$as_me:${as_lineno-$LINENO}: \$PKG_CONFIG --exists --print-errors \"libnm_glib >= 0.7\""; } >&5
-  ($PKG_CONFIG --exists --print-errors "libnm_glib >= 0.7") 2>&5
+    { { $as_echo "$as_me:${as_lineno-$LINENO}: \$PKG_CONFIG --exists --print-errors \"libnm-glib >= 0.7\""; } >&5
+  ($PKG_CONFIG --exists --print-errors "libnm-glib >= 0.7") 2>&5
   ac_status=$?
   $as_echo "$as_me:${as_lineno-$LINENO}: \$? = $ac_status" >&5
   test $ac_status = 0; }; then
-  pkg_cv_ONLINE_LIBS=`$PKG_CONFIG --libs "libnm_glib >= 0.7" 2>/dev/null`
+  pkg_cv_ONLINE_LIBS=`$PKG_CONFIG --libs "libnm-glib >= 0.7" 2>/dev/null`
 else
   pkg_failed=yes
 fi
@@ -13537,14 +13537,14 @@ else
         _pkg_short_errors_supported=no
 fi
         if test $_pkg_short_errors_supported = yes; then
-	        ONLINE_PKG_ERRORS=`$PKG_CONFIG --short-errors --print-errors "libnm_glib >= 0.7" 2>&1`
+	        ONLINE_PKG_ERRORS=`$PKG_CONFIG --short-errors --print-errors "libnm-glib >= 0.7" 2>&1`
         else
-	        ONLINE_PKG_ERRORS=`$PKG_CONFIG --print-errors "libnm_glib >= 0.7" 2>&1`
+	        ONLINE_PKG_ERRORS=`$PKG_CONFIG --print-errors "libnm-glib >= 0.7" 2>&1`
         fi
 	# Put the nasty error message in config.log where it belongs
 	echo "$ONLINE_PKG_ERRORS" >&5
 
-	as_fn_error "Package requirements (libnm_glib >= 0.7) were not met:
+	as_fn_error "Package requirements (libnm-glib >= 0.7) were not met:
 
 $ONLINE_PKG_ERRORS
 
Index: meego-panel-people-0.2.2/configure.ac
===================================================================
--- meego-panel-people-0.2.2.orig/configure.ac
+++ meego-panel-people-0.2.2/configure.ac
@@ -81,7 +81,7 @@ AS_IF(
         [test "$with_online" = networkmanager],
         [
         AC_MSG_RESULT([Network Manager])
-        PKG_CHECK_MODULES(ONLINE, libnm_glib >= 0.7)
+        PKG_CHECK_MODULES(ONLINE, libnm-glib >= 0.7)
         AC_DEFINE([WITH_ONLINE_NM], 1, [NM online detection])
         ],