A new user interface for you! Read more...

File nepomuk-core.spec of Package nepomuk-core

#
# spec file for package nepomuk-core
#
# Copyright (c) 2013 SUSE LINUX Products GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via http://bugs.opensuse.org/
#


# Please submit bugfixes or comments via http://bugs.opensuse.org/

Name:           nepomuk-core
Version:        4.11.5
Release:        0
Summary:        The KDE Nepomuk Core Library
License:        GPL-2.0+
Group:          System/GUI/KDE
Url:            http://nepomuk.kde.org/
Source0:        %{name}-%{version}.tar.xz
Source99:       nepomuk.png
# PATCH-FIX-OPENSUSE kauth.patch disable installing of kauth actions until bnc#825262 is resolved
Patch0:         kauth.patch
BuildRequires:  fdupes
BuildRequires:  libepub-devel
BuildRequires:  libexiv2-devel
BuildRequires:  libkde4-devel
BuildRequires:  libpoppler-qt4-devel
BuildRequires:  libsoprano-devel >= 2.9.3
BuildRequires:  libtag-devel
BuildRequires:  shared-desktop-ontologies-devel >= 0.11.0
BuildRequires:  soprano-backend-redland >= 2.9.3
BuildRequires:  soprano-backend-virtuoso >= 2.9.3
BuildRequires:  xz
BuildRequires:  xz-devel
BuildRequires:  libffmpeg-devel
Requires:       kdelibs4 >= %{version}
Requires:       soprano-backend-redland
Requires:       libqt4-x11 >= %( echo `rpm -q --queryformat '%{VERSION}' libqt4-x11`)
Suggests:       cagibi
BuildRoot:      %{_tmppath}/%{name}-%{version}-build
%define debug_package_requires %{name} = %{version}-%{release} kdelibs4-debuginfo

%description
This package contains all the core libraries for nepomuk

%package devel
Summary:        The Nepomuk Core Library
Group:          System/GUI/KDE
Requires:       %{name} = %{version}
Requires:       libkde4-devel
Requires:       libsoprano-devel >= 2.9.3
Requires:       shared-desktop-ontologies-devel >= 0.11.0

%description devel
The devel package of the core library for nepomuk

%package ffmpegindexer
Summary:        The Nepomuk Core Library
Group:          System/GUI/KDE
Requires:       %{name} = %{version}

%description ffmpegindexer
This package contains the ffmpeg indexer for nepomuk

%prep
%setup -q -n %{name}-%{version}
%if 0%{?suse_version} < 1310
%patch0 -p1
%endif

%build
  %cmake_kde4 -d build -- -DKDE4_ENABLE_FPIE=1
  %make_jobs

%install
  cd build
  %kde4_makeinstall
  mkdir -p %{buildroot}%{_datadir}/pixmaps
  install $RPM_SOURCE_DIR/nepomuk.png %{buildroot}%{_datadir}/pixmaps/
  %suse_update_desktop_file -r nepomukcleaner             Utility Archiving
  %fdupes -s %{buildroot}
  %kde_post_install

%post -p /sbin/ldconfig

%postun -p /sbin/ldconfig

%files devel
%defattr(-,root,root)
%{_kde4_includedir}/Nepomuk2/
%{_kde4_includedir}/nepomuk2/
%{_kde4_libdir}/cmake/NepomukCore/
%{_kde4_libdir}/libnepomukcore.so
%{_kde4_libdir}/libnepomukcleaner.so

%files
%defattr(-,root,root)
%{_kde4_bindir}/nepomuk*
%{_kde4_modulesdir}/nepomuk*.so
%{_kde4_libdir}/libnepomukcommon.so
%{_kde4_libdir}/libnepomukextractor.so
%{_kde4_libdir}/libnepomukcore.so.*
%{_kde4_libdir}/libnepomukcleaner.so.*
%{_kde4_libdir}/libkdeinit4_nepomukserver.so
%{_kde4_applicationsdir}/nepomuk*.desktop
%{_kde4_datadir}/autostart/nepomukserver.desktop
%{_kde4_datadir}/dbus-1/interfaces/org.kde.nepomuk.*.xml
%{_kde4_datadir}/dbus-1/interfaces/org.kde.NepomukServer.xml
%{_kde4_appsdir}/fileindexerservice/
%{_kde4_appsdir}/nepomukfilewatch/
%{_kde4_appsdir}/nepomukstorage/
%{_kde4_servicesdir}/nepomuk*.desktop
%{_kde4_servicetypesdir}/nepomuk*.desktop
%{_kde4_datadir}/ontology/
%{_kde4_datadir}/pixmaps/nepomuk.png
%if 0%{?suse_version} >= 1310
%{_kde4_sysconfdir}/dbus-1/system.d/org.kde.nepomuk.filewatch.conf
%{_kde4_libexecdir}/kde_nepomuk_filewatch_raiselimit
%{_kde4_datadir}/dbus-1/system-services/org.kde.nepomuk.filewatch.service
%{_kde4_datadir}/polkit-1/actions/org.kde.nepomuk.filewatch.policy
%endif
%exclude %{_kde4_modulesdir}/nepomukffmpegextractor.so
%exclude %{_kde4_servicesdir}/nepomukffmpegextractor.desktop

%files ffmpegindexer
%defattr(-,root,root)
%{_kde4_modulesdir}/nepomukffmpegextractor.so
%{_kde4_servicesdir}/nepomukffmpegextractor.desktop

%changelog