File baselibs.conf of Package uim

uim
  recommends "uim-gtk2-<targettype> = <version>"
  recommends "uim-gtk3-<targettype> = <version>"
  recommends "uim-qt4-<targettype> = <version>"
uim-gtk2
  post "%if "%_lib" == "lib64""
  post "<prefix>%{_bindir}/gtk-query-immodules-2.0-64 --update-cache"
  post "%else"
  post "<prefix>%{_bindir}/gtk-query-immodules-2.0 --update-cache"
  post "%endif"
  postun "%if "%_lib" == "lib64""
  postun "<prefix>%{_bindir}/gtk-query-immodules-2.0-64 --update-cache"
  postun "%else"
  postun "<prefix>%{_bindir}/gtk-query-immodules-2.0 --update-cache"
  postun "%endif"
  requires "uim-<targettype> = <version>"
  supplements "packageand(uim:gtk2-<targettype>)"
uim-gtk3
  post "%if "%_lib" == "lib64""
  post "<prefix>%{_bindir}/gtk-query-immodules-3.0-64 --update-cache"
  post "%else"
  post "<prefix>%{_bindir}/gtk-query-immodules-3.0 --update-cache"
  post "%endif"
  postun "%if "%_lib" == "lib64""
  postun "<prefix>%{_bindir}/gtk-query-immodules-3.0-64 --update-cache"
  postun "%else"
  postun "<prefix>%{_bindir}/gtk-query-immodules-3.0 --update-cache"
  postun "%endif"
  requires "uim-<targettype> = <version>"
  supplements "packageand(uim:gtk3-<targettype>)"
uim-qt4
  requires "uim-<targettype> = <version>"
  supplements "packageand(uim:libqt4-<targettype>)"