File patterns-openSUSE.spec of Package patterns-openSUSE

#
# spec file for package patterns-openSUSE
#
# Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via http://bugs.opensuse.org/
#



Name:           patterns-openSUSE
BuildRequires:  patterns
License:        GPLv2+
Group:          Metapackages
AutoReqProv:    on
Summary:        Patterns for Installation (full ftp tree)
Version:        11.4
Release:        6.<RELEASE2>
Url:            http://en.opensuse.org/Patterns
BuildRoot:      %{_tmppath}/%{name}-%{version}-build
Source:         patterns-openSUSE-data.tar.bz2
Source1:        preprocess
Source3:        %name-rpmlintrc
Source4:        create-suggests
Source5:        sort_patterns
Source6:        patterns-openSUSE.spec.in
Conflicts:      patterns-openSUSE-dvd5 patterns-openSUSE-dvd9 patterns-openSUSE-cd patterns-openSUSE-addon-non-oss patterns-openSUSE-GNOME-cd patterns-openSUSE-KDE-cd

%description
This is an internal package that is used to create the patterns as part
of the installation source setup.  Installation of this package does
not make sense.



%package Promo
License:        GPLv2+
Summary:        Patterns for Installation (Promo DVD)
Group:          Metapackages
Conflicts:      patterns-openSUSE-dvd5 patterns-openSUSE-dvd9 patterns-openSUSE-cd patterns-openSUSE-addon-non-oss patterns-openSUSE patterns-openSUSE-KDE-cd patterns-openSUSE-GNOME-cd

%description Promo
This is an internal package that is used to create the patterns as part
of the installation source setup.  Installation of this package does
not make sense.

%package dvd
License:        GPLv2+
Summary:        Patterns for Installation (DVD media)
Group:          Metapackages
Conflicts:      patterns-openSUSE-dvd5 patterns-openSUSE-dvd9 patterns-openSUSE-cd patterns-openSUSE-addon-non-oss patterns-openSUSE patterns-openSUSE-KDE-cd patterns-openSUSE-GNOME-cd

%description dvd
This is an internal package that is used to create the patterns as part
of the installation source setup.  Installation of this package does
not make sense.

#BEGIN1
%package 32bit
License:        GPLv2+
Group:          Metapackages
Summary:        Meta package for pattern 32bit

%description 32bit
This package is installed if a pattern is selected to have a working update path

%package 64bit
License:        GPLv2+
Group:          Metapackages
Summary:        Meta package for pattern 64bit

%description 64bit
This package is installed if a pattern is selected to have a working update path

%package apparmor
License:        GPLv2+
Group:          Metapackages
Summary:        Meta package for pattern apparmor
Recommends:     apparmor-utils
Recommends:     pam_apparmor
Recommends:     patterns-openSUSE-apparmor_opt
Recommends:     yast2-apparmor
Requires:       apparmor-parser
Requires:       apparmor-profiles
Requires:       audit
Requires:       patterns-openSUSE-apparmor
Requires:       patterns-openSUSE-basesystem

%description apparmor
This package is installed if a pattern is selected to have a working update path

%package apparmor_opt
License:        GPLv2+
Group:          Metapackages
Summary:        Meta package for pattern apparmor_opt
Requires:       apparmor-docs
Requires:       patterns-openSUSE-basesystem

%description apparmor_opt
This package is installed if a pattern is selected to have a working update path

%package base
License:        GPLv2+
Group:          Metapackages
Summary:        Meta package for pattern base
Provides:       patterns-openSUSE-basesystem
Recommends:     branding-openSUSE
Recommends:     pm-utils
Recommends:     rsyslog
Recommends:     sysvinit
Requires:       aaa_base
Requires:       dhcpcd
Requires:       grub
Requires:       hwinfo
Requires:       insserv
Requires:       kbd
Requires:       licenses
Requires:       mkinitrd
Requires:       module-init-tools
Requires:       netcfg
Requires:       openSUSE-build-key
Requires:       openSUSE-release
Requires:       openssh
Requires:       patterns-openSUSE-base
Requires:       patterns-openSUSE-yast2_install_wf
Requires:       polkit
Requires:       polkit-default-privs
Requires:       procps
Requires:       pwdutils
Requires:       rpcbind
Requires:       rpm
Requires:       sysconfig
Requires:       syslog

%description base
This package is installed if a pattern is selected to have a working update path

%package console
License:        GPLv2+
Group:          Metapackages
Summary:        Meta package for pattern console
Recommends:     emacs-nox
Recommends:     mtools
Recommends:     sox
Recommends:     vorbis-tools
Requires:       ivman
Requires:       mc
Requires:       patterns-openSUSE-console
Requires:       w3m
Requires:       wodim

%description console
This package is installed if a pattern is selected to have a working update path

%package default
License:        GPLv2+
Group:          Metapackages
Summary:        Meta package for pattern default
Obsoletes:      patterns-openSUSE-voip_server < 10.3
Requires:       patterns-openSUSE-basesystem
Suggests:       patterns-openSUSE-32bit
Suggests:       patterns-openSUSE-64bit
Suggests:       patterns-openSUSE-apparmor
Suggests:       patterns-openSUSE-base
Suggests:       patterns-openSUSE-x11
Suggests:       patterns-openSUSE-x86

%description default
This package is installed if a pattern is selected to have a working update path

%package devel_basis
License:        GPLv2+
Group:          Metapackages
Summary:        Meta package for pattern devel_basis
Recommends:     bin86
Recommends:     binutils-devel
Recommends:     e2fsprogs-devel
Recommends:     fdupes
Recommends:     gcc-c++
Recommends:     gcc-info
Recommends:     glibc-info
Recommends:     gmp-devel
Recommends:     gperf
Recommends:     libaio-devel
Recommends:     libapparmor-devel
Recommends:     libdb-4_5-devel
Recommends:     libgcj-devel
Recommends:     libosip2-devel
Recommends:     libstdc++-devel
Recommends:     openldap2-devel
Recommends:     pam-devel
Recommends:     patch
Recommends:     pkg-config
Recommends:     subversion
Requires:       autoconf
Requires:       automake
Requires:       binutils
Requires:       bison
Requires:       cpp
Requires:       cvs
Requires:       flex
Requires:       gcc
Requires:       gdbm-devel
Requires:       gettext-tools
Requires:       glibc-devel
Requires:       libtool
Requires:       m4
Requires:       make
Requires:       ncurses-devel
Requires:       patch
Requires:       patterns-openSUSE-basesystem
Requires:       patterns-openSUSE-devel_basis
Requires:       rcs
Requires:       texinfo
Requires:       zlib-devel

%description devel_basis
This package is installed if a pattern is selected to have a working update path

%package devel_C_C++
License:        GPLv2+
Group:          Metapackages
Summary:        Meta package for pattern devel_C_C++
Recommends:     boost-devel
Recommends:     boost-jam
Recommends:     ddd
Recommends:     glibc-info
Recommends:     ltrace
Recommends:     posix_cc
Recommends:     swig
Recommends:     texinfo
Recommends:     valgrind
Requires:       patterns-openSUSE-devel_C_C++
Requires:       patterns-openSUSE-devel_basis

%description devel_C_C++
This package is installed if a pattern is selected to have a working update path

%package devel_gnome
License:        GPLv2+
Group:          Metapackages
Summary:        Meta package for pattern devel_gnome
Recommends:     ConsoleKit-devel
Recommends:     aalib-devel
Recommends:     accerciser
Recommends:     alsa-devel
Recommends:     at-spi-devel
Recommends:     atk-devel
Recommends:     audiofile-devel
Recommends:     cairo-devel
Recommends:     dbus-1-devel
Recommends:     devhelp
Recommends:     devhelp-devel
Recommends:     emacs-x11
Recommends:     epiphany-devel
Recommends:     epiphany-doc
Recommends:     evolution-data-server-devel
Recommends:     evolution-devel
Recommends:     fam-devel
Recommends:     gconf2-devel
Recommends:     ghex
Recommends:     glade
Recommends:     glib2-devel
Recommends:     gnome-bluetooth-devel
Recommends:     gnome-common
Recommends:     gnome-control-center-devel
Recommends:     gnome-desktop-devel
Recommends:     gnome-doc-utils
Recommends:     gnome-doc-utils-devel
Recommends:     gnome-media-devel
Recommends:     gnome-menus-devel
Recommends:     gnome-pilot-devel
Recommends:     gnome-speech-devel
Recommends:     gnome-vfs2-devel
Recommends:     gnome-vfs2-doc
Recommends:     gob2
Recommends:     gstreamer-0_10-devel
Recommends:     gstreamer-0_10-doc
Recommends:     gstreamer-0_10-plugins-base-devel
Recommends:     gtk-doc
Recommends:     gtk2-devel
Recommends:     gtkhtml2-devel
Recommends:     gtksourceview-devel
Recommends:     gucharmap-devel
Recommends:     guile-devel
Recommends:     gvfs-devel
Recommends:     imlib2-devel
Recommends:     intltool
Recommends:     libart_lgpl-devel
Recommends:     libavc1394-devel
Recommends:     libbonobo-devel
Recommends:     libbonobo-doc
Recommends:     libbonoboui-devel
Recommends:     libbonoboui-doc
Recommends:     libbtctl-devel
Recommends:     libcroco-devel
Recommends:     libgail-gnome-devel
Recommends:     libgcrypt-devel
Recommends:     libgda-3_0-devel
Recommends:     libglade2-devel
Recommends:     libglade2-doc
Recommends:     libgnome-devel
Recommends:     libgnome-keyring-devel
Recommends:     libgnomecanvas-devel
Recommends:     libgnomecups-devel
Recommends:     libgnomekbd-devel
Recommends:     libgnomeprint-devel
Recommends:     libgnomeprint-doc
Recommends:     libgnomeprintui-devel
Recommends:     libgnomeprintui-doc
Recommends:     libgnomesu-devel
Recommends:     libgnomeui-devel
Recommends:     libgnomeui-doc
Recommends:     libgsf-devel
Recommends:     libgtop-devel
Recommends:     libgweather-devel
Recommends:     libidl-devel
Recommends:     libksba-devel
Recommends:     libmusicbrainz-devel
Recommends:     libneon-devel
Recommends:     libnl-devel
Recommends:     libopencdk-devel
Recommends:     libpurple-devel
Recommends:     libslab-devel
Recommends:     libsoup-devel
Recommends:     libvisual-devel
Recommends:     libwnck-devel
Recommends:     libxklavier-devel
Recommends:     libxml2-devel
Recommends:     libxslt-devel
Recommends:     metacity-devel
Recommends:     nautilus-devel
Recommends:     orbit2-devel
Recommends:     pango-devel
Recommends:     planner-devel
Recommends:     startup-notification-devel
Recommends:     tracker-devel
Recommends:     vte-devel
Recommends:     wvstreams-devel
Requires:       patterns-openSUSE-devel_C_C++
Requires:       patterns-openSUSE-devel_gnome
Requires:       patterns-openSUSE-gnome_basis

%description devel_gnome
This package is installed if a pattern is selected to have a working update path

%package devel_ide
License:        GPLv2+
Group:          Metapackages
Summary:        Meta package for pattern devel_ide
Recommends:     monodevelop
Requires:       patterns-openSUSE-devel_basis
Requires:       patterns-openSUSE-devel_ide

%description devel_ide
This package is installed if a pattern is selected to have a working update path

%package devel_java
License:        GPLv2+
Group:          Metapackages
Summary:        Meta package for pattern devel_java
Recommends:     ant
Recommends:     ant-antlr
Recommends:     ant-apache-bcel
Recommends:     ant-apache-bsf
Recommends:     ant-apache-log4j
Recommends:     ant-apache-oro
Recommends:     ant-apache-regexp
Recommends:     ant-apache-resolver
Recommends:     ant-commons-logging
Recommends:     ant-javadoc
Recommends:     ant-javamail
Recommends:     ant-jdepend
Recommends:     ant-jmf
Recommends:     ant-junit
Recommends:     ant-manual
Recommends:     ant-nodeps
Recommends:     ant-scripts
Recommends:     ant-swing
Recommends:     ant-trax
Recommends:     java-1_5_0-gcj-compat-devel
Recommends:     java-1_6_0-openjdk
%ifarch ix86
Recommends:     java-1_6_0-openjdk-plugin
%endif
Recommends:     log4j
Recommends:     xalan-j2
Recommends:     xerces-j2
Recommends:     xml-commons-apis
Recommends:     xml-commons-resolver
Recommends:     xml-commons-which
Requires:       patterns-openSUSE-devel_java

%description devel_java
This package is installed if a pattern is selected to have a working update path

%package devel_kde
License:        GPLv2+
Group:          Metapackages
Summary:        Meta package for pattern devel_kde
Recommends:     ConsoleKit-devel
Recommends:     ImageMagick-devel
Recommends:     NetworkManager-devel
Recommends:     OpenEXR-devel
Recommends:     alsa-devel
Recommends:     aspell-devel
Recommends:     avahi-compat-mDNSResponder-devel
Recommends:     bluez-devel
Recommends:     clucene-core-devel
Recommends:     cmake
Recommends:     cups-devel
%ifarch ix86
Recommends:     cups-devel
%endif
Recommends:     cyrus-sasl-devel
Recommends:     doxygen
Recommends:     enchant-devel
Recommends:     fam-devel
Recommends:     gettext-tools
Recommends:     ggz-client-libs-devel
Recommends:     giflib-devel
%ifarch ix86
Recommends:     giflib-devel
%endif
Recommends:     google-gadgets-devel
Recommends:     gstreamer-0_10-devel
Recommends:     icecream
Recommends:     kdebase4-workspace-devel
Recommends:     krb5-devel
Recommends:     libSDL-devel
Recommends:     libao-devel
Recommends:     libattr-devel
Recommends:     libavahi-devel
Recommends:     libavahi-qt4-devel
Recommends:     libbz2-devel
Recommends:     libcurl-devel
Recommends:     libdvdread-devel
Recommends:     libgpgme-devel
Recommends:     libgphoto2-devel
Recommends:     libgpod-devel
Recommends:     libical-devel
Recommends:     libidn-devel
Recommends:     libjasper-devel
Recommends:     libjpeg-devel
Recommends:     libkexiv2-devel
Recommends:     libmal-devel
Recommends:     libmtp-devel
Recommends:     libmysqlclient-devel
Recommends:     libopenssl-devel
Recommends:     libpisock-devel
Recommends:     libpng14-compat-devel
Recommends:     libpng14-devel
Recommends:     libpoppler-devel
Recommends:     libpoppler-qt4-devel
Recommends:     libpulse-devel
Recommends:     libqca2-devel
Recommends:     libqimageblitz-devel
Recommends:     libqt4-devel
Recommends:     libqt4-devel-doc
Recommends:     libraptor-devel
Recommends:     libraw1394-devel
Recommends:     libsmbclient-devel
Recommends:     libsoprano-devel
Recommends:     libtiff-devel
Recommends:     libusb-compat-devel
Recommends:     libxine-devel
Recommends:     libxklavier-devel
Recommends:     libxml2-devel
Recommends:     libxslt-devel
Recommends:     loudmouth-devel
Recommends:     openldap2-devel
Recommends:     patterns-openSUSE-devel_qt4
Recommends:     pcre-devel
Recommends:     python-devel
Recommends:     sqlite3-devel
Recommends:     strigi-devel
Recommends:     wv2-devel
Requires:       patterns-openSUSE-devel_C_C++
Requires:       patterns-openSUSE-devel_kde

%description devel_kde
This package is installed if a pattern is selected to have a working update path

%package devel_kernel
License:        GPLv2+
Group:          Metapackages
Summary:        Meta package for pattern devel_kernel
Recommends:     ctags
Recommends:     diffstat
Recommends:     git-core
Recommends:     git-email
Recommends:     gitk
Recommends:     indent
Recommends:     kernel-source
Recommends:     kernel-syms
Recommends:     patchutils
Recommends:     quilt
Requires:       patterns-openSUSE-devel_basis
Requires:       patterns-openSUSE-devel_kernel

%description devel_kernel
This package is installed if a pattern is selected to have a working update path

%package devel_mono
License:        GPLv2+
Group:          Metapackages
Summary:        Meta package for pattern devel_mono
Recommends:     apache2-mod_mono
Recommends:     boo
Recommends:     bytefx-data-mysql
Recommends:     dbus-1-mono
Recommends:     gsf-sharp
Recommends:     gtk-sharp2-complete
Recommends:     gtk-sharp2-doc
Recommends:     gtk-sharp2-gapi
Recommends:     gtksourceview-sharp2
Recommends:     ikvm
Recommends:     mono-basic
Recommends:     mono-core
Recommends:     mono-data
Recommends:     mono-data-firebird
Recommends:     mono-data-oracle
Recommends:     mono-data-postgresql
Recommends:     mono-data-sqlite
Recommends:     mono-data-sybase
Recommends:     mono-devel
Recommends:     mono-extras
Recommends:     mono-locale-extras
Recommends:     mono-nunit
Recommends:     mono-tools
Recommends:     mono-web
Recommends:     mono-winforms
Recommends:     monodevelop
Recommends:     monodoc-core
Requires:       patterns-openSUSE-devel_mono

%description devel_mono
This package is installed if a pattern is selected to have a working update path

%package devel_perl
License:        GPLv2+
Group:          Metapackages
Summary:        Meta package for pattern devel_perl
Recommends:     perlref
Requires:       patterns-openSUSE-devel_perl

%description devel_perl
This package is installed if a pattern is selected to have a working update path

%package devel_python
License:        GPLv2+
Group:          Metapackages
Summary:        Meta package for pattern devel_python
Recommends:     pychecker
Recommends:     python
Recommends:     python-devel
Requires:       patterns-openSUSE-devel_python

%description devel_python
This package is installed if a pattern is selected to have a working update path

%package devel_qt4
License:        GPLv2+
Group:          Metapackages
Summary:        Meta package for pattern devel_qt4
Recommends:     libqt4-devel
Recommends:     libqt4-devel-doc
Recommends:     libqt4-sql-sqlite
Requires:       patterns-openSUSE-devel_qt4

%description devel_qt4
This package is installed if a pattern is selected to have a working update path

%package devel_rpm_build
License:        GPLv2+
Group:          Metapackages
Summary:        Meta package for pattern devel_rpm_build
Requires:       acl
Requires:       attr
Requires:       autoconf
Requires:       automake
Requires:       binutils
Requires:       cpp
Requires:       cracklib
Requires:       cvs
Requires:       gawk
Requires:       gcc
Requires:       gettext-tools
Requires:       glibc-devel
Requires:       glibc-locale
Requires:       less
Requires:       libtool
Requires:       make
Requires:       man
Requires:       netcfg
Requires:       patch
Requires:       patterns-openSUSE-basesystem
Requires:       patterns-openSUSE-devel_rpm_build
Requires:       rpm
Requires:       sysvinit-tools
Requires:       tar
Requires:       texinfo
Requires:       timezone
Requires:       util-linux

%description devel_rpm_build
This package is installed if a pattern is selected to have a working update path

%package devel_ruby
License:        GPLv2+
Group:          Metapackages
Summary:        Meta package for pattern devel_ruby
Requires:       patterns-openSUSE-devel_ruby
Requires:       ruby
Requires:       rubygems

%description devel_ruby
This package is installed if a pattern is selected to have a working update path

%package devel_tcl
License:        GPLv2+
Group:          Metapackages
Summary:        Meta package for pattern devel_tcl
Recommends:     bwidget
Recommends:     expect
Recommends:     expect-devel
Recommends:     frink
Recommends:     itcl
Recommends:     itcl-devel
Recommends:     itk
Recommends:     iwidgets
Recommends:     snack
Recommends:     tcl
Recommends:     tcl-devel
Recommends:     tcllib
Recommends:     tclplug
Recommends:     tcludp
Recommends:     tclx
Recommends:     tdom
Recommends:     tix
Recommends:     tk
Recommends:     tk-devel
Recommends:     tkcon
Recommends:     tkimg
Recommends:     tktable
Recommends:     tls
Requires:       patterns-openSUSE-devel_tcl

%description devel_tcl
This package is installed if a pattern is selected to have a working update path

%package devel_web
License:        GPLv2+
Group:          Metapackages
Summary:        Meta package for pattern devel_web
Recommends:     apache2-devel
Requires:       patterns-openSUSE-devel_web
Requires:       patterns-openSUSE-lamp_server

%description devel_web
This package is installed if a pattern is selected to have a working update path

%package devel_yast
License:        GPLv2+
Group:          Metapackages
Summary:        Meta package for pattern devel_yast
Recommends:     libzypp-devel
Recommends:     subversion
Recommends:     yast2-core-devel
Recommends:     yast2-devel-doc
Recommends:     yast2-devtools
Recommends:     yast2-installation-devel-doc
Recommends:     yast2-libyui-devel
Recommends:     yast2-ncurses-devel
Recommends:     yast2-network-devel-doc
Recommends:     yast2-nis-server-devel-doc
Recommends:     yast2-perl-bindings
Recommends:     yast2-pkg-bindings-devel-doc
Recommends:     yast2-printer-devel-doc
Recommends:     yast2-python-bindings
Recommends:     yast2-qt-devel
Recommends:     yast2-ruby-bindings
Recommends:     yast2-storage-devel
Recommends:     yast2-testsuite
Recommends:     yast2-ycp-ui-bindings-devel
Requires:       patterns-openSUSE-devel_yast

%description devel_yast
This package is installed if a pattern is selected to have a working update path

%package dhcp_dns_server
License:        GPLv2+
Group:          Metapackages
Summary:        Meta package for pattern dhcp_dns_server
Recommends:     bind
Recommends:     bind-doc
Recommends:     dhcp-relay
Recommends:     dhcp-server
Recommends:     dhcp-tools
Recommends:     dhcpv6
Recommends:     yast2-dhcp-server
Recommends:     yast2-dns-server
Requires:       patterns-openSUSE-basesystem
Requires:       patterns-openSUSE-dhcp_dns_server

%description dhcp_dns_server
This package is installed if a pattern is selected to have a working update path

%package directory_server
License:        GPLv2+
Group:          Metapackages
Summary:        Meta package for pattern directory_server
Recommends:     nss_ldap
Recommends:     openldap2
Recommends:     pam_ldap
Recommends:     yast2-ldap-server
Requires:       patterns-openSUSE-basesystem
Requires:       patterns-openSUSE-directory_server
%ifarch x86_64
Recommends:     pam_ldap-32bit
Recommends:     nss_ldap-32bit
%endif

%description directory_server
This package is installed if a pattern is selected to have a working update path

%package enhanced_base
License:        GPLv2+
Group:          Metapackages
Summary:        Meta package for pattern enhanced_base
Recommends:     SuSEfirewall2
Recommends:     acl
Recommends:     acpica
Recommends:     acpid
Recommends:     alsa-plugins
Recommends:     attr
Recommends:     autofs
Recommends:     bind-utils
Recommends:     bootsplash
Recommends:     bootsplash-branding-openSUSE
Recommends:     bzip2
Recommends:     cifs-mount
Recommends:     command-not-found
Recommends:     cronie
Recommends:     cryptsetup
Recommends:     cups
Recommends:     cups-client
Recommends:     curl
Recommends:     cyrus-sasl
Recommends:     cyrus-sasl-crammd5
Recommends:     cyrus-sasl-digestmd5
Recommends:     cyrus-sasl-gssapi
Recommends:     cyrus-sasl-plain
Recommends:     db-utils
Recommends:     deltarpm
Recommends:     diffutils
Recommends:     dmidecode
Recommends:     dmraid
Recommends:     dosfstools
Recommends:     e2fsprogs
Recommends:     eject
Recommends:     ethtool
Recommends:     file
Recommends:     fillup
Recommends:     findutils
Recommends:     gawk
Recommends:     genisoimage
Recommends:     gettext-runtime
Recommends:     gfxboot
Recommends:     glibc-locale
Recommends:     gpart
Recommends:     gpg2
Recommends:     gpm
Recommends:     hdparm
Recommends:     ifplugd
Recommends:     info
Recommends:     insserv
Recommends:     iproute2
Recommends:     iputils
Recommends:     kpartx
Recommends:     less
Recommends:     linux-atm-lib
Recommends:     lsb-release
Recommends:     lsof
Recommends:     lsscsi
Recommends:     lukemftp
Recommends:     mailx
Recommends:     man
Recommends:     master-boot-code
Recommends:     mdadm
Recommends:     microcode_ctl
Recommends:     ncurses-utils
Recommends:     netcat
Recommends:     nfs-client
Recommends:     nfsidmap
Recommends:     ntfs-3g
Recommends:     ntfsprogs
Recommends:     ntp
Recommends:     openldap2-client
Recommends:     openslp
Recommends:     openssh
Recommends:     parted
Recommends:     patterns-openSUSE-apparmor
Recommends:     patterns-openSUSE-enhanced_base_opt
Recommends:     patterns-openSUSE-sw_management
Recommends:     patterns-openSUSE-yast2_basis
Recommends:     pciutils
Recommends:     perl-base
Recommends:     pm-profiler
Recommends:     pm-utils
Recommends:     postfix
Recommends:     ppp
Recommends:     pptp
Recommends:     psmisc
Recommends:     recode
Recommends:     release-notes-openSUSE
Recommends:     scout
Recommends:     sg3_utils
Recommends:     smp_utils
Recommends:     strace
Recommends:     sudo
Recommends:     tar
Recommends:     timezone
Recommends:     udev
Recommends:     ulimit
Recommends:     unscd
Recommends:     usbutils
Recommends:     utempter
Recommends:     vim
Recommends:     wget
Recommends:     wireless-tools
Recommends:     xinetd
Recommends:     yp-tools
Recommends:     ypbind
Requires:       patterns-openSUSE-basesystem
Requires:       patterns-openSUSE-enhanced_base
%ifarch x86_64
Recommends:     glibc-32bit
Recommends:     irqbalance
Recommends:     numactl
Recommends:     linux32
Recommends:     glibc-locale-32bit
%endif

%description enhanced_base
This package is installed if a pattern is selected to have a working update path

%package enhanced_base_opt
License:        GPLv2+
Group:          Metapackages
Summary:        Meta package for pattern enhanced_base_opt
Recommends:     OpenPrinting-PPDs
Recommends:     at
Recommends:     bc
Recommends:     bootcycle
Recommends:     cracklib-dict-full
Recommends:     dos2unix
Recommends:     ed
Recommends:     finger
Recommends:     groff
Recommends:     haveged
Recommends:     initviocons
Recommends:     joe
Recommends:     ksh
Recommends:     ksymoops
Recommends:     man-pages
Recommends:     man-pages-posix
Recommends:     manufacturer-PPDs
Recommends:     mpt-status
Recommends:     pax
Recommends:     perl-TermReadLine-Gnu
Recommends:     prctl
Recommends:     procinfo
Recommends:     procmail
Recommends:     providers
Recommends:     rsync
Recommends:     sash
Recommends:     screen
Recommends:     setserial
Recommends:     sharutils
Recommends:     smartmontools
Recommends:     strace
Recommends:     tcpdump
Recommends:     tcsh
Recommends:     telnet
Recommends:     terminfo
Recommends:     udev-configure-printer
Recommends:     vlan
Recommends:     w3m
Recommends:     wol
Recommends:     zisofs-tools
Recommends:     zsh
%ifarch x86_64
Recommends:     mcelog
%endif

%description enhanced_base_opt
This package is installed if a pattern is selected to have a working update path

%package file_server
License:        GPLv2+
Group:          Metapackages
Summary:        Meta package for pattern file_server
Recommends:     nfs-kernel-server
Recommends:     nfsidmap
Recommends:     samba
Recommends:     samba-client
Recommends:     samba-winbind
Recommends:     tftp
Recommends:     vsftpd
Recommends:     yast2-ftp-server
Recommends:     yast2-nfs-server
Recommends:     yast2-samba-server
Recommends:     yast2-tftp-server
Requires:       patterns-openSUSE-basesystem
Requires:       patterns-openSUSE-file_server

%description file_server
This package is installed if a pattern is selected to have a working update path

%package fonts
License:        GPLv2+
Group:          Metapackages
Summary:        Meta package for pattern fonts
Recommends:     dejavu
Recommends:     ghostscript-fonts-std
Recommends:     ifnteuro
Recommends:     liberation-fonts
Recommends:     patterns-openSUSE-fonts_opt
Recommends:     xorg-x11-fonts-core
Requires:       patterns-openSUSE-fonts

%description fonts
This package is installed if a pattern is selected to have a working update path

%package fonts_opt
License:        GPLv2+
Group:          Metapackages
Summary:        Meta package for pattern fonts_opt
Recommends:     droid-fonts
Recommends:     efont-unicode
Recommends:     ghostscript-fonts-other
Recommends:     intlfnts
Recommends:     xorg-x11-fonts

%description fonts_opt
This package is installed if a pattern is selected to have a working update path

%package games
License:        GPLv2+
Group:          Metapackages
Summary:        Meta package for pattern games
Requires:       patterns-openSUSE-games
Requires:       patterns-openSUSE-x11

%description games
This package is installed if a pattern is selected to have a working update path

%package gateway_server
License:        GPLv2+
Group:          Metapackages
Summary:        Meta package for pattern gateway_server
Recommends:     ddclient
Recommends:     fetchmail
Recommends:     ipsec-tools
Recommends:     quagga
Recommends:     radvd
Recommends:     rarpd
Recommends:     squid3
Recommends:     squidGuard
Recommends:     wireshark
Requires:       patterns-openSUSE-basesystem
Requires:       patterns-openSUSE-gateway_server

%description gateway_server
This package is installed if a pattern is selected to have a working update path

%package gnome
License:        GPLv2+
Group:          Metapackages
Summary:        Meta package for pattern gnome
Recommends:     alacarte
Recommends:     brasero
Recommends:     cheese
Recommends:     dasher
Recommends:     empathy
Recommends:     eog
Recommends:     evince
Recommends:     evolution
Recommends:     evolution-tracker
Recommends:     evolution-webcal
Recommends:     file-roller
Recommends:     gcalctool
Recommends:     gconf-editor
Recommends:     gedit
Recommends:     gnome-bluetooth
Recommends:     gnome-disk-utility
Recommends:     gnome-media
Recommends:     gnome-nettool
Recommends:     gnome-system-monitor
Recommends:     gnome-themes
Recommends:     gnome-user-share
Recommends:     gnome-utils
Recommends:     gucharmap
Recommends:     hamster-applet
Recommends:     mousetweaks
Recommends:     nautilus-sendto
Recommends:     orca
Recommends:     patterns-openSUSE-games
Recommends:     patterns-openSUSE-gnome_admin
Recommends:     patterns-openSUSE-gnome_internet
Recommends:     patterns-openSUSE-gnome_utilities
Recommends:     patterns-openSUSE-imaging
Recommends:     patterns-openSUSE-multimedia
Recommends:     patterns-openSUSE-non_oss
Recommends:     patterns-openSUSE-office
Recommends:     patterns-openSUSE-xgl
Recommends:     seahorse
Recommends:     system-config-printer
Recommends:     telepathy-gabble
Recommends:     telepathy-haze
Recommends:     telepathy-idle
Recommends:     telepathy-salut
Recommends:     telepathy-sofiasip
Recommends:     tomboy
Recommends:     totem
Recommends:     totem-browser-plugin
Recommends:     tracker
Recommends:     tracker-gui
Recommends:     vino
Recommends:     zenity
Requires:       patterns-openSUSE-gnome
Requires:       patterns-openSUSE-gnome_basis

%description gnome
This package is installed if a pattern is selected to have a working update path

%package gnome_admin
License:        GPLv2+
Group:          Metapackages
Summary:        Meta package for pattern gnome_admin
Recommends:     alacarte
Recommends:     vinagre
Requires:       patterns-openSUSE-basesystem
Requires:       patterns-openSUSE-gnome_admin
Requires:       patterns-openSUSE-x11

%description gnome_admin
This package is installed if a pattern is selected to have a working update path

%package gnome_basis
License:        GPLv2+
Group:          Metapackages
Summary:        Meta package for pattern gnome_basis
Recommends:     MozillaFirefox
Recommends:     NetworkManager
Recommends:     NetworkManager-gnome
Recommends:     aria2
Recommends:     at-spi
Recommends:     avahi
Recommends:     bug-buddy
Recommends:     canberra-gtk-play
Recommends:     cups-backends
Recommends:     dbus-1-x11
Recommends:     desktop-data-openSUSE
Recommends:     desktop-file-utils
Recommends:     droid-fonts
Recommends:     fifth-leg-font
Recommends:     gconf2-branding-openSUSE
Recommends:     gdb
Recommends:     glib2-branding-openSUSE
Recommends:     gnome-control-center
Recommends:     gnome-desktop
Recommends:     gnome-icon-theme
Recommends:     gnome-icon-theme-extras
Recommends:     gnome-icon-theme-symbolic
Recommends:     gnome-keyring
Recommends:     gnome-keyring-pam
Recommends:     gnome-mag
Recommends:     gnome-menus
Recommends:     gnome-menus-branding-openSUSE
Recommends:     gnome-power-manager
Recommends:     gnome-screensaver
Recommends:     gnome-terminal
Recommends:     gnome-user-docs
Recommends:     gpg2
Recommends:     gpgme
Recommends:     gtk2
Recommends:     gtk2-branding-openSUSE
Recommends:     gtk2-engine-murrine
Recommends:     gtk2-engines
Recommends:     gtk2-metatheme-sonar
Recommends:     hicolor-icon-theme-branding-openSUSE
Recommends:     input-utils
Recommends:     libgail-gnome
Recommends:     metacity
Recommends:     nautilus
Recommends:     notification-daemon
Recommends:     patterns-openSUSE-gnome_basis_opt
Recommends:     pinentry-gtk2
Recommends:     polkit-default-privs
Recommends:     preload
Recommends:     pulseaudio-esound-compat
Recommends:     pulseaudio-module-bluetooth
Recommends:     pulseaudio-module-gconf
Recommends:     pulseaudio-module-lirc
Recommends:     pulseaudio-module-x11
Recommends:     pulseaudio-module-zeroconf
Recommends:     pulseaudio-utils
Recommends:     samba
Recommends:     shared-mime-info
Recommends:     susehelp
Recommends:     tango-icon-theme
Recommends:     xdg-user-dirs
Recommends:     xdg-user-dirs-gtk
Recommends:     xkeyboard-config
Recommends:     yelp
Requires:       gdm
Requires:       gnome-applets
Requires:       gnome-main-menu
Requires:       gnome-panel
Requires:       gnome-session
Requires:       patterns-openSUSE-basesystem
Requires:       patterns-openSUSE-gnome_basis
Requires:       patterns-openSUSE-x11

%description gnome_basis
This package is installed if a pattern is selected to have a working update path

%package gnome_basis_opt
License:        GPLv2+
Group:          Metapackages
Summary:        Meta package for pattern gnome_basis_opt
Recommends:     gutenprint
Recommends:     hplip
Recommends:     java-1_6_0-openjdk-plugin
Recommends:     openSUSE-dynamic-wallpaper
Recommends:     samba
Requires:       patterns-openSUSE-basesystem
Requires:       patterns-openSUSE-x11
%ifarch x86_64
Recommends:     nspluginwrapper
%endif

%description gnome_basis_opt
This package is installed if a pattern is selected to have a working update path

%package gnome_games
License:        GPLv2+
Group:          Metapackages
Summary:        Meta package for pattern gnome_games
Recommends:     gbrainy
Recommends:     gnome-games-recommended
Recommends:     phalanx
Requires:       patterns-openSUSE-gnome_games
Supplements:    packageand(patterns-openSUSE-gnome:patterns-openSUSE-games)

%description gnome_games
This package is installed if a pattern is selected to have a working update path

%package gnome_ide
License:        GPLv2+
Group:          Metapackages
Summary:        Meta package for pattern gnome_ide
Recommends:     anjuta
Recommends:     devhelp
Recommends:     glade3
Requires:       patterns-openSUSE-gnome_ide
Supplements:    packageand(patterns-openSUSE-gnome:patterns-openSUSE-devel_ide)

%description gnome_ide
This package is installed if a pattern is selected to have a working update path

%package gnome_imaging
License:        GPLv2+
Group:          Metapackages
Summary:        Meta package for pattern gnome_imaging
Recommends:     eog
Recommends:     f-spot
Recommends:     patterns-openSUSE-gnome_imaging_opt
Requires:       patterns-openSUSE-gnome_basis
Requires:       patterns-openSUSE-gnome_imaging
Supplements:    packageand(patterns-openSUSE-gnome:patterns-openSUSE-imaging)

%description gnome_imaging
This package is installed if a pattern is selected to have a working update path

%package gnome_imaging_opt
License:        GPLv2+
Group:          Metapackages
Summary:        Meta package for pattern gnome_imaging_opt
Recommends:     inkscape
Recommends:     simple-scan
Requires:       patterns-openSUSE-gnome_basis
Supplements:    packageand(patterns-openSUSE-gnome:patterns-openSUSE-imaging)

%description gnome_imaging_opt
This package is installed if a pattern is selected to have a working update path

%package gnome_internet
License:        GPLv2+
Group:          Metapackages
Summary:        Meta package for pattern gnome_internet
Recommends:     NetworkManager-openvpn-gnome
Recommends:     NetworkManager-pptp-gnome
Recommends:     NetworkManager-vpnc-gnome
Recommends:     empathy
Recommends:     evolution
Recommends:     gnome-nettool
Recommends:     liferea
Recommends:     transmission-gtk
Recommends:     xchat
Requires:       patterns-openSUSE-gnome_internet

%description gnome_internet
This package is installed if a pattern is selected to have a working update path

%package gnome_laptop
License:        GPLv2+
Group:          Metapackages
Summary:        Meta package for pattern gnome_laptop
Recommends:     gnome-bluetooth
Recommends:     gnome-docker
Recommends:     gnome-phone-manager
Requires:       patterns-openSUSE-gnome_basis
Requires:       patterns-openSUSE-gnome_laptop
Supplements:    packageand(patterns-openSUSE-gnome:patterns-openSUSE-laptop)

%description gnome_laptop
This package is installed if a pattern is selected to have a working update path

%package gnome_multimedia
License:        GPLv2+
Group:          Metapackages
Summary:        Meta package for pattern gnome_multimedia
Recommends:     banshee-1
Recommends:     banshee-1-backend-engine-gstreamer
Recommends:     banshee-1-backend-platform-gnome
Recommends:     banshee-1-backend-platform-unix
Recommends:     banshee-1-extensions-default
Recommends:     gnome-media
Recommends:     gstreamer-0_10-plugins-base
Recommends:     gstreamer-0_10-plugins-good
Recommends:     gstreamer-0_10-schroedinger
Recommends:     gstreamer-utils
Recommends:     paprefs
Recommends:     patterns-openSUSE-gnome_multimedia_opt
Recommends:     pavucontrol
Recommends:     totem
Recommends:     totem-browser-plugin
Requires:       patterns-openSUSE-gnome_multimedia
Supplements:    packageand(patterns-openSUSE-gnome:patterns-openSUSE-multimedia)

%description gnome_multimedia
This package is installed if a pattern is selected to have a working update path

%package gnome_multimedia_opt
License:        GPLv2+
Group:          Metapackages
Summary:        Meta package for pattern gnome_multimedia_opt
Supplements:    packageand(patterns-openSUSE-gnome:patterns-openSUSE-multimedia)

%description gnome_multimedia_opt
This package is installed if a pattern is selected to have a working update path

%package gnome_office
License:        GPLv2+
Group:          Metapackages
Summary:        Meta package for pattern gnome_office
Recommends:     evolution
Recommends:     libreoffice-gnome
Recommends:     libreoffice-icon-theme-tango
Recommends:     patterns-openSUSE-gnome_office_opt
Requires:       patterns-openSUSE-gnome_basis
Requires:       patterns-openSUSE-gnome_office
Supplements:    packageand(patterns-openSUSE-gnome:patterns-openSUSE-office)

%description gnome_office
This package is installed if a pattern is selected to have a working update path

%package gnome_office_opt
License:        GPLv2+
Group:          Metapackages
Summary:        Meta package for pattern gnome_office_opt
Recommends:     gnucash
Requires:       patterns-openSUSE-gnome_basis
Supplements:    packageand(patterns-openSUSE-gnome:patterns-openSUSE-office)

%description gnome_office_opt
This package is installed if a pattern is selected to have a working update path

%package gnome_utilities
License:        GPLv2+
Group:          Metapackages
Summary:        Meta package for pattern gnome_utilities
Recommends:     cheese
Recommends:     dasher
Recommends:     file-roller
Recommends:     gcalctool
Recommends:     gedit
Recommends:     gnome-do
Recommends:     gnome-utils
Recommends:     gnome-web-photo
Recommends:     gucharmap
Recommends:     hamster-applet
Recommends:     nautilus-open-terminal
Recommends:     nautilus-sendto
Recommends:     seahorse
Recommends:     tasque
Recommends:     tomboy
Requires:       patterns-openSUSE-gnome_basis
Requires:       patterns-openSUSE-gnome_utilities

%description gnome_utilities
This package is installed if a pattern is selected to have a working update path

%package gnome_xgl
License:        GPLv2+
Group:          Metapackages
Summary:        Meta package for pattern gnome_xgl
Requires:       compiz-gnome
Requires:       patterns-openSUSE-gnome_basis
Requires:       patterns-openSUSE-gnome_xgl
Requires:       simple-ccsm
Supplements:    packageand(patterns-openSUSE-gnome:patterns-openSUSE-xgl)

%description gnome_xgl
This package is installed if a pattern is selected to have a working update path

%package gnome_yast
License:        GPLv2+
Group:          Metapackages
Summary:        Meta package for pattern gnome_yast
Requires:       patterns-openSUSE-gnome_yast
Requires:       yast2-control-center-gnome
Requires:       yast2-gtk
Supplements:    packageand(patterns-openSUSE-gnome:patterns-openSUSE-yast2_basis)

%description gnome_yast
This package is installed if a pattern is selected to have a working update path

%package imaging
License:        GPLv2+
Group:          Metapackages
Summary:        Meta package for pattern imaging
Recommends:     gimp
Recommends:     patterns-openSUSE-imaging_opt
Requires:       patterns-openSUSE-imaging
Requires:       patterns-openSUSE-x11

%description imaging
This package is installed if a pattern is selected to have a working update path

%package imaging_opt
License:        GPLv2+
Group:          Metapackages
Summary:        Meta package for pattern imaging_opt
Recommends:     AdobeICCProfiles
Recommends:     gimp-help
Requires:       patterns-openSUSE-x11

%description imaging_opt
This package is installed if a pattern is selected to have a working update path

%package kde
License:        GPLv2+
Group:          Metapackages
Summary:        Meta package for pattern kde
Requires:       patterns-openSUSE-kde4

%description kde
This package is installed if a pattern is selected to have a working update path

%package kde4
License:        GPLv2+
Group:          Metapackages
Summary:        Meta package for pattern kde4
Provides:       patterns-openSUSE-kde4 = 11.1
Recommends:     ark
Recommends:     kcalc
Recommends:     kgpg
Recommends:     ksnapshot
Recommends:     kwalletmanager
Recommends:     mozilla-kde4-integration
Recommends:     patterns-openSUSE-games
Recommends:     patterns-openSUSE-imaging
Recommends:     patterns-openSUSE-kde4_internet
Recommends:     patterns-openSUSE-kde4_utilities
Recommends:     patterns-openSUSE-multimedia
Recommends:     patterns-openSUSE-non_oss
Recommends:     patterns-openSUSE-office
Requires:       patterns-openSUSE-kde4
Requires:       patterns-openSUSE-kde4_basis

%description kde4
This package is installed if a pattern is selected to have a working update path

%package kde4_admin
License:        GPLv2+
Group:          Metapackages
Summary:        Meta package for pattern kde4_admin
Recommends:     kiosktool
Requires:       patterns-openSUSE-kde4_admin
Requires:       patterns-openSUSE-kde4_basis

%description kde4_admin
This package is installed if a pattern is selected to have a working update path

%package kde4_basis
License:        GPLv2+
Group:          Metapackages
Summary:        Meta package for pattern kde4_basis
Recommends:     MozillaFirefox
Recommends:     akregator
Recommends:     alsa-plugins-pulse
Recommends:     aria2
Recommends:     avahi
Recommends:     desktop-data-openSUSE
Recommends:     droid-fonts
Recommends:     gdb
Recommends:     kaddressbook
Recommends:     kcm_gtk
Recommends:     kdebase4-nsplugin
Recommends:     kdenetwork4-filesharing
Recommends:     kdepasswd
Recommends:     kdepim4-wizards
Recommends:     kdm
Recommends:     keditbookmarks
Recommends:     kio_iso
Recommends:     kmail
Recommends:     knotes
Recommends:     konqueror
Recommends:     konsole
Recommends:     kontact
Recommends:     korganizer
Recommends:     kvkbd
Recommends:     kwebkitpart
Recommends:     oxygen-gtk
Recommends:     pinentry-qt4
Recommends:     plasma-addons
Recommends:     plasmoid-networkmanagement
Recommends:     plasmoid-quickaccess
Recommends:     polkit-default-privs
Recommends:     preload
Recommends:     pulseaudio
Recommends:     pulseaudio-module-bluetooth
Recommends:     pulseaudio-module-jack
Recommends:     pulseaudio-module-lirc
Recommends:     pulseaudio-module-x11
Recommends:     pulseaudio-module-zeroconf
Recommends:     pulseaudio-utils
Recommends:     skanlite
Recommends:     soprano-backend-redland
Recommends:     soprano-backend-virtuoso
Recommends:     susehelp
Recommends:     synaptiks
Recommends:     xdg-user-dirs
Recommends:     yast2-control-center-qt
Requires:       dolphin
Requires:       kdebase4
Requires:       kdebase4-session
Requires:       kdebase4-workspace
Requires:       kwin
Requires:       kwrite
Requires:       patterns-openSUSE-basesystem
Requires:       patterns-openSUSE-kde4_basis
Requires:       patterns-openSUSE-x11

%description kde4_basis
This package is installed if a pattern is selected to have a working update path

%package kde4_edutainment
License:        GPLv2+
Group:          Metapackages
Summary:        Meta package for pattern kde4_edutainment
Recommends:     blinken
Recommends:     kalgebra
Recommends:     kalzium
Recommends:     kanagram
Recommends:     kbruch
Recommends:     kgeography
Recommends:     khangman
Recommends:     kig
Recommends:     kiten
Recommends:     klettres
Recommends:     kmplot
Recommends:     kstars
Recommends:     ktouch
Recommends:     kwordquiz
Recommends:     marble
Recommends:     parley
Recommends:     step
Requires:       patterns-openSUSE-kde4_edutainment

%description kde4_edutainment
This package is installed if a pattern is selected to have a working update path

%package kde4_games
License:        GPLv2+
Group:          Metapackages
Summary:        Meta package for pattern kde4_games
Recommends:     kmahjongg
Recommends:     kmines
Recommends:     kpat
Recommends:     kreversi
Recommends:     ksudoku
Requires:       patterns-openSUSE-kde4_games
Supplements:    packageand(patterns-openSUSE-kde4:patterns-openSUSE-games)

%description kde4_games
This package is installed if a pattern is selected to have a working update path

%package kde4_ide
License:        GPLv2+
Group:          Metapackages
Summary:        Meta package for pattern kde4_ide
Recommends:     cervisia
Recommends:     kate
Recommends:     kcachegrind
Recommends:     kdbg
Recommends:     kde4-kapptemplate
Recommends:     kde4-l10n-devel
Recommends:     kdesdk4
Recommends:     kdevelop4
Recommends:     kio_svn
Recommends:     kompare
Recommends:     lokalize
Recommends:     umbrello
Requires:       patterns-openSUSE-kde4_ide
Supplements:    packageand(patterns-openSUSE-kde4:patterns-openSUSE-devel_ide)

%description kde4_ide
This package is installed if a pattern is selected to have a working update path

%package kde4_imaging
License:        GPLv2+
Group:          Metapackages
Summary:        Meta package for pattern kde4_imaging
Recommends:     digikam
Recommends:     gwenview
Recommends:     jpeg
Recommends:     kcolorchooser
Recommends:     kgamma
Recommends:     kio_kamera
Recommends:     kipi-plugins
Recommends:     kruler
Recommends:     okular
Recommends:     skanlite
Requires:       patterns-openSUSE-kde4_basis
Requires:       patterns-openSUSE-kde4_imaging
Supplements:    packageand(patterns-openSUSE-kde4:patterns-openSUSE-imaging)

%description kde4_imaging
This package is installed if a pattern is selected to have a working update path

%package kde4_internet
License:        GPLv2+
Group:          Metapackages
Summary:        Meta package for pattern kde4_internet
Recommends:     NetworkManager-openvpn-kde4
Recommends:     NetworkManager-pptp-kde4
Recommends:     NetworkManager-vpnc-kde4
Recommends:     choqok
Recommends:     kdnssd
Recommends:     kget
Recommends:     konversation
Recommends:     kopete
Recommends:     krdc
Recommends:     krfb
Recommends:     ktorrent
Requires:       patterns-openSUSE-kde4_internet

%description kde4_internet
This package is installed if a pattern is selected to have a working update path

%package kde4_laptop
License:        GPLv2+
Group:          Metapackages
Summary:        Meta package for pattern kde4_laptop
Recommends:     synaptiks
Requires:       patterns-openSUSE-basesystem
Requires:       patterns-openSUSE-kde4_laptop
Supplements:    packageand(patterns-openSUSE-kde4:patterns-openSUSE-laptop)

%description kde4_laptop
This package is installed if a pattern is selected to have a working update path

%package kde4_multimedia
License:        GPLv2+
Group:          Metapackages
Summary:        Meta package for pattern kde4_multimedia
Recommends:     amarok
Recommends:     gstreamer-0_10-plugins-good
Recommends:     k3b
Recommends:     kaffeine
Recommends:     kio_audiocd
Recommends:     kmix
Recommends:     kscd
Recommends:     opensuse-codecs-installer
Recommends:     phonon-backend-gstreamer-0_10
Requires:       patterns-openSUSE-kde4_multimedia
Supplements:    packageand(patterns-openSUSE-kde4:patterns-openSUSE-multimedia)

%description kde4_multimedia
This package is installed if a pattern is selected to have a working update path

%package kde4_office
License:        GPLv2+
Group:          Metapackages
Summary:        Meta package for pattern kde4_office
Recommends:     libreoffice-icon-theme-oxygen
Recommends:     libreoffice-kde4
Requires:       patterns-openSUSE-kde4_office
Supplements:    packageand(patterns-openSUSE-kde4:patterns-openSUSE-office)

%description kde4_office
This package is installed if a pattern is selected to have a working update path

%package kde4_pure
License:        GPLv2+
Group:          Metapackages
Summary:        Meta package for pattern kde4_pure
Conflicts:      patterns-openSUSE-gnome
Requires:       patterns-openSUSE-kde4_pure
Supplements:    packageand(patterns-openSUSE-kde4:patterns-openSUSE-kde4_basis)

%description kde4_pure
This package is installed if a pattern is selected to have a working update path

%package kde4_utilities
License:        GPLv2+
Group:          Metapackages
Summary:        Meta package for pattern kde4_utilities
Recommends:     bluedevil
Recommends:     kcharselect
Recommends:     kdeartwork4-screensaver
Recommends:     kmag
Recommends:     kmousetool
Recommends:     kompare
Recommends:     patterns-openSUSE-kde4_utilities_opt
Recommends:     sweeper
Requires:       patterns-openSUSE-kde4_utilities

%description kde4_utilities
This package is installed if a pattern is selected to have a working update path

%package kde4_utilities_opt
License:        GPLv2+
Group:          Metapackages
Summary:        Meta package for pattern kde4_utilities_opt
Recommends:     gutenprint
Recommends:     hplip
Recommends:     java-1_6_0-openjdk-plugin
Recommends:     konqueror-plugins
Recommends:     samba
%ifarch x86_64
Recommends:     nspluginwrapper
%endif

%description kde4_utilities_opt
This package is installed if a pattern is selected to have a working update path

%package kde4_xgl
License:        GPLv2+
Group:          Metapackages
Summary:        Meta package for pattern kde4_xgl
Recommends:     compiz-kde4
Recommends:     simple-ccsm-kde
Requires:       patterns-openSUSE-kde4_xgl
Supplements:    packageand(patterns-openSUSE-kde4:patterns-openSUSE-xgl)

%description kde4_xgl
This package is installed if a pattern is selected to have a working update path

%package kde4_yast
License:        GPLv2+
Group:          Metapackages
Summary:        Meta package for pattern kde4_yast
Requires:       patterns-openSUSE-kde4_yast
Requires:       yast2-control-center-qt
Requires:       yast2-qt
Requires:       yast2-qt-pkg
Requires:       yast2-theme-openSUSE-Oxygen
Supplements:    packageand(patterns-openSUSE-kde4:patterns-openSUSE-yast2_basis)

%description kde4_yast
This package is installed if a pattern is selected to have a working update path

%package lamp_server
License:        GPLv2+
Group:          Metapackages
Summary:        Meta package for pattern lamp_server
Recommends:     apache2
Recommends:     apache2-doc
Recommends:     apache2-example-pages
Recommends:     apache2-mod_perl
Recommends:     apache2-mod_php5
Recommends:     apache2-mod_python
Recommends:     apache2-prefork
Recommends:     mysql-community-server
Recommends:     php5-ctype
Recommends:     php5-dom
Recommends:     php5-iconv
Recommends:     php5-mysql
Recommends:     yast2-http-server
Requires:       patterns-openSUSE-basesystem
Requires:       patterns-openSUSE-lamp_server

%description lamp_server
This package is installed if a pattern is selected to have a working update path

%package laptop
License:        GPLv2+
Group:          Metapackages
Summary:        Meta package for pattern laptop
Recommends:     crda
Recommends:     irda
Recommends:     iw
Recommends:     jarnal
Recommends:     pcmciautils
Recommends:     wireless-regdb
Recommends:     wpa_supplicant
Recommends:     x11-input-wacom-tools
Recommends:     xstroke
Recommends:     xvkbd
Requires:       patterns-openSUSE-basesystem
Requires:       patterns-openSUSE-laptop

%description laptop
This package is installed if a pattern is selected to have a working update path

%package lxde
License:        GPLv2+
Group:          Metapackages
Summary:        Meta package for pattern lxde
Recommends:     MozillaFirefox
Recommends:     NetworkManager
Recommends:     NetworkManager-gnome
Recommends:     aria2
Recommends:     avahi
%ifarch ix86
Recommends:     avahi
%endif
Recommends:     beaver
Recommends:     brasero
Recommends:     bug-buddy
Recommends:     cheese
Recommends:     claws-mail
Recommends:     desktop-data-openSUSE
Recommends:     droid-fonts
Recommends:     empathy
Recommends:     galculator
Recommends:     gconf2-branding-openSUSE
Recommends:     gmixer
Recommends:     gnome-packagekit
Recommends:     gpicview
Recommends:     gtk2-engine-murrine
Recommends:     gutenprint
Recommends:     hplip
Recommends:     java-1_6_0-openjdk-plugin
Recommends:     libgnomesu
Recommends:     lxappearance
Recommends:     lxcc
Recommends:     lxde-common
Recommends:     lxde-common-branding-openSUSE
Recommends:     lxdm
Recommends:     lxdm-conf
Recommends:     lxinput
Recommends:     lxmenu-data
Recommends:     lxmusic
Recommends:     lxpanel
Recommends:     lxrandr
Recommends:     lxsession
Recommends:     lxsession-edit
Recommends:     lxshortcut
Recommends:     lxtask
Recommends:     lxterminal
Recommends:     menu-cache
Recommends:     mtpaint
Recommends:     nuoveXT2-icon-theme
Recommends:     obconf
Recommends:     openbox
Recommends:     opensuse-codecs-installer
Recommends:     parcellite
Recommends:     patterns-openSUSE-imaging
Recommends:     patterns-openSUSE-lxde_office
%ifarch ix86
Recommends:     patterns-openSUSE-lxde_office
%endif
Recommends:     patterns-openSUSE-multimedia
Recommends:     patterns-openSUSE-remote_desktop
Recommends:     pcmanfm
Recommends:     pinentry-gtk2
Recommends:     preload
Recommends:     samba
Recommends:     seahorse
Recommends:     smolt
Recommends:     system-config-printer
Recommends:     totem
Recommends:     totem-browser-plugin
Recommends:     transmission-gtk
Recommends:     xarchiver
Recommends:     xchat
Recommends:     xdg-user-dirs
Recommends:     xdg-user-dirs-gtk
Recommends:     xdg-utils
Recommends:     xfce4-power-manager
Recommends:     xorg-x11
Recommends:     xscreensaver
Recommends:     yast2-control-center-gnome
Recommends:     yast2-gtk
Requires:       patterns-openSUSE-lxde
Requires:       patterns-openSUSE-x11
%ifarch x86_64
Recommends:     nspluginwrapper
%endif

%description lxde
This package is installed if a pattern is selected to have a working update path

%package lxde_laptop
License:        GPLv2+
Group:          Metapackages
Summary:        Meta package for pattern lxde_laptop
Recommends:     gnome-bluetooth
Recommends:     gsynaptics
Requires:       patterns-openSUSE-lxde
Requires:       patterns-openSUSE-lxde_laptop
Supplements:    packageand(patterns-openSUSE-lxde:patterns-openSUSE-laptop)

%description lxde_laptop
This package is installed if a pattern is selected to have a working update path

%package lxde_office
License:        GPLv2+
Group:          Metapackages
Summary:        Meta package for pattern lxde_office
Recommends:     abiword
Recommends:     epdfview
Recommends:     gnumeric
Recommends:     goffice
Requires:       patterns-openSUSE-lxde
Requires:       patterns-openSUSE-lxde_office
Supplements:    packageand(patterns-openSUSE-lxde:patterns-openSUSE-office)

%description lxde_office
This package is installed if a pattern is selected to have a working update path

%package mail_server
License:        GPLv2+
Group:          Metapackages
Summary:        Meta package for pattern mail_server
Recommends:     amavisd-new
Recommends:     clamav
Recommends:     cyrus-imapd
Recommends:     fetchmail
Recommends:     inn
Recommends:     mailman
Recommends:     postfix
Recommends:     procmail
Recommends:     spamassassin
Recommends:     vacation
Requires:       patterns-openSUSE-basesystem
Requires:       patterns-openSUSE-mail_server

%description mail_server
This package is installed if a pattern is selected to have a working update path

%package minimal_base
License:        GPLv2+
Group:          Metapackages
Summary:        Meta package for pattern minimal_base
Conflicts:      cups-client
Conflicts:      desktop-translations
Conflicts:      glib-networking
Conflicts:      gsettings-backend-dconf
Conflicts:      netpbm
Conflicts:      perl-doc
Conflicts:      python-base
Conflicts:      readline-doc
Conflicts:      samba-client
Recommends:     SuSEfirewall2
Recommends:     autofs
Recommends:     bc
Recommends:     deltarpm
Recommends:     eject
Recommends:     haveged
Recommends:     hdparm
Recommends:     iputils
Recommends:     joe
Recommends:     less
Recommends:     linux32
Recommends:     lsof
Recommends:     lukemftp
Recommends:     netcat
Recommends:     nfs-client
Recommends:     ntfs-3g
Recommends:     ntp
Recommends:     prctl
Recommends:     release-notes-openSUSE
Recommends:     rsync
Recommends:     strace
Recommends:     sudo
Recommends:     sysfsutils
Recommends:     tcsh
Recommends:     telnet
Recommends:     unscd
Recommends:     vim-base
Recommends:     w3m
Recommends:     wget
Recommends:     wireless-tools
Recommends:     wol
Recommends:     xinetd
Recommends:     yp-tools
Recommends:     ypbind
Requires:       patterns-openSUSE-basesystem
Requires:       patterns-openSUSE-minimal_base
Requires:       patterns-openSUSE-sw_management
Requires:       patterns-openSUSE-yast2_basis

%description minimal_base
This package is installed if a pattern is selected to have a working update path

%package misc_server
License:        GPLv2+
Group:          Metapackages
Summary:        Meta package for pattern misc_server
Recommends:     openslp-server
Recommends:     yast2-instserver
Recommends:     yast2-iscsi-server
Recommends:     yast2-nis-server
%ifarch ix86
Recommends:     yast2-nis-server
%endif
Recommends:     yast2-slp-server
Requires:       patterns-openSUSE-basesystem
Requires:       patterns-openSUSE-misc_server

%description misc_server
This package is installed if a pattern is selected to have a working update path

%package multimedia
License:        GPLv2+
Group:          Metapackages
Summary:        Meta package for pattern multimedia
Recommends:     dvd+rw-tools
Recommends:     patterns-openSUSE-multimedia_opt
Recommends:     vorbis-tools
Recommends:     yast2-sound
Requires:       patterns-openSUSE-multimedia

%description multimedia
This package is installed if a pattern is selected to have a working update path

%package multimedia_opt
License:        GPLv2+
Group:          Metapackages
Summary:        Meta package for pattern multimedia_opt
Recommends:     ImageMagick
Recommends:     mjpegtools

%description multimedia_opt
This package is installed if a pattern is selected to have a working update path

%package network_admin
License:        GPLv2+
Group:          Metapackages
Summary:        Meta package for pattern network_admin
Recommends:     arpwatch
Recommends:     iftop
Recommends:     mtr
Recommends:     nagios
Recommends:     nmap
Recommends:     quagga
Recommends:     tcpdump
Recommends:     whois
Recommends:     wireshark
Requires:       patterns-openSUSE-basesystem
Requires:       patterns-openSUSE-network_admin

%description network_admin
This package is installed if a pattern is selected to have a working update path

%package non_oss
License:        GPLv2+
Group:          Metapackages
Summary:        Meta package for pattern non_oss
Recommends:     patterns-openSUSE-non_oss_opt
Recommends:     pullin-flash-player
Requires:       patterns-openSUSE-non_oss
Requires:       patterns-openSUSE-x11

%description non_oss
This package is installed if a pattern is selected to have a working update path

%package non_oss_opt
License:        GPLv2+
Group:          Metapackages
Summary:        Meta package for pattern non_oss_opt
Recommends:     flash-player
Recommends:     gst-fluendo-mp3
Requires:       patterns-openSUSE-non_oss

%description non_oss_opt
This package is installed if a pattern is selected to have a working update path

%package office
License:        GPLv2+
Group:          Metapackages
Summary:        Meta package for pattern office
Recommends:     libreoffice
Recommends:     libreoffice-calc
Recommends:     libreoffice-draw
Recommends:     libreoffice-impress
Recommends:     libreoffice-writer
Recommends:     patterns-openSUSE-office_opt
Requires:       patterns-openSUSE-office

%description office
This package is installed if a pattern is selected to have a working update path

%package office_opt
License:        GPLv2+
Group:          Metapackages
Summary:        Meta package for pattern office_opt
Recommends:     libreoffice-base-extensions
Recommends:     libreoffice-calc-extensions
Recommends:     libreoffice-converter
Recommends:     libreoffice-draw-extensions
Recommends:     libreoffice-filters
Recommends:     libreoffice-impress-extensions
Recommends:     libreoffice-math
Recommends:     libreoffice-writer-extensions

%description office_opt
This package is installed if a pattern is selected to have a working update path

%package print_server
License:        GPLv2+
Group:          Metapackages
Summary:        Meta package for pattern print_server
Recommends:     OpenPrinting-PPDs
Recommends:     cups
Recommends:     cups-backends
Recommends:     foomatic-filters
Recommends:     gutenprint
Recommends:     hplip
Recommends:     m2300w
Recommends:     manufacturer-PPDs
Recommends:     samba
Recommends:     splix
Requires:       patterns-openSUSE-basesystem
Requires:       patterns-openSUSE-print_server

%description print_server
This package is installed if a pattern is selected to have a working update path

%package remote_desktop
License:        GPLv2+
Group:          Metapackages
Summary:        Meta package for pattern remote_desktop
Recommends:     rdesktop
Recommends:     tightvnc
Recommends:     tsclient
Requires:       patterns-openSUSE-remote_desktop

%description remote_desktop
This package is installed if a pattern is selected to have a working update path

%package sw_management
License:        GPLv2+
Group:          Metapackages
Summary:        Meta package for pattern sw_management
Obsoletes:      patterns-openSUSE-zmd < 11.0
Provides:       patterns-openSUSE-zmd = 11.1
Recommends:     patterns-openSUSE-sw_management_x11
Requires:       patterns-openSUSE-sw_management
Requires:       zypper

%description sw_management
This package is installed if a pattern is selected to have a working update path

%package sw_management_gnome
License:        GPLv2+
Group:          Metapackages
Summary:        Meta package for pattern sw_management_gnome
Obsoletes:      patterns-openSUSE-sw_management_x11 <= 10.2
Obsoletes:      patterns-openSUSE-zmd_x11 <= 10.2
Provides:       patterns-openSUSE-zmd_x11 = 10.3
Recommends:     gnome-packagekit
Recommends:     smolt
Requires:       patterns-openSUSE-sw_management
Requires:       patterns-openSUSE-sw_management_gnome
Requires:       patterns-openSUSE-x11
Supplements:    packageand(patterns-openSUSE-gnome_basis:patterns-openSUSE-sw_management)

%description sw_management_gnome
This package is installed if a pattern is selected to have a working update path

%package sw_management_kde4
License:        GPLv2+
Group:          Metapackages
Summary:        Meta package for pattern sw_management_kde4
Obsoletes:      patterns-openSUSE-sw_management_x11 <= 10.2
Obsoletes:      patterns-openSUSE-zmd_x11 <= 10.2
Provides:       patterns-openSUSE-zmd_x11 = 10.3
Recommends:     kpackagekit
Recommends:     ksmolt
Recommends:     smolt
Requires:       patterns-openSUSE-sw_management
Requires:       patterns-openSUSE-sw_management_kde4
Requires:       patterns-openSUSE-x11
Supplements:    packageand(patterns-openSUSE-kde4_basis:patterns-openSUSE-sw_management)

%description sw_management_kde4
This package is installed if a pattern is selected to have a working update path

%package tabletpc
License:        GPLv2+
Group:          Metapackages
Summary:        Meta package for pattern tabletpc
Recommends:     cellwriter
Recommends:     jarnal
Recommends:     wacom-kmp
Recommends:     x11-input-evtouch
Recommends:     x11-input-fujitsu
Recommends:     x11-input-wacom
Recommends:     x11-input-wacom-tools
Recommends:     xournal
Recommends:     xstroke
Recommends:     xvkbd
Requires:       patterns-openSUSE-basesystem
Requires:       patterns-openSUSE-tabletpc

%description tabletpc
This package is installed if a pattern is selected to have a working update path

%package technical_writing
License:        GPLv2+
Group:          Metapackages
Summary:        Meta package for pattern technical_writing
Obsoletes:      patterns-openSUSE-xml <= 10.3
Recommends:     batik
Recommends:     dbsplit-tools
Recommends:     dia
Recommends:     docbook-dsssl-stylesheets
Recommends:     docbook-xml-website
Recommends:     docbook-xsl-stylesheets
Recommends:     docbook5-xsl-stylesheets
Recommends:     docbook_5
Recommends:     emacs
Recommends:     emacs-x11
Recommends:     fop
Recommends:     inkscape
Recommends:     mxml
Recommends:     nxml-mode
Recommends:     psutils
Recommends:     sablot
Recommends:     saxon
Recommends:     susedoc
Recommends:     svg-schema
Recommends:     tei-roma
Recommends:     tei-xsl-stylesheets
Recommends:     xmlformat
Recommends:     xmlstarlet
Recommends:     xmlto
Recommends:     xslide
Requires:       patterns-openSUSE-technical_writing

%description technical_writing
This package is installed if a pattern is selected to have a working update path

%package update_test
License:        GPLv2+
Group:          Metapackages
Summary:        Meta package for pattern update_test
Recommends:     update-test-affects-package-manager
Recommends:     update-test-interactive
Recommends:     update-test-optional
Recommends:     update-test-reboot-needed
Recommends:     update-test-security
Recommends:     update-test-trival
Requires:       patterns-openSUSE-update_test

%description update_test
This package is installed if a pattern is selected to have a working update path

%package voip
License:        GPLv2+
Group:          Metapackages
Summary:        Meta package for pattern voip
Recommends:     ekiga
Requires:       patterns-openSUSE-voip
Requires:       patterns-openSUSE-x11

%description voip
This package is installed if a pattern is selected to have a working update path

%package x11
License:        GPLv2+
Group:          Metapackages
Summary:        Meta package for pattern x11
Recommends:     ConsoleKit-x11
Recommends:     freeglut
Recommends:     ghostscript-x11
Recommends:     icewm-lite
Recommends:     numlockx
Recommends:     openssh-askpass
Recommends:     patterns-openSUSE-x11_opt
Recommends:     patterns-openSUSE-x11_yast
Recommends:     suspend
Recommends:     tightvnc
Recommends:     translation-update
Recommends:     x11-tools
%ifarch ix86
Recommends:     x11-tools
%endif
Recommends:     xkeyboard-config
Recommends:     xorg-x11
Recommends:     xorg-x11-Xvnc
Recommends:     xorg-x11-driver-input
Recommends:     xorg-x11-driver-video
Recommends:     xorg-x11-libX11-ccache
Recommends:     xorg-x11-server
Recommends:     xorg-x11-xauth
Recommends:     xterm
Recommends:     yast2-scanner
Recommends:     yast2-tv
Requires:       patterns-openSUSE-basesystem
Requires:       patterns-openSUSE-enhanced_base
Requires:       patterns-openSUSE-fonts
Requires:       patterns-openSUSE-x11
%ifarch x86_64
Recommends:     nss-mdns-32bit
%endif

%description x11
This package is installed if a pattern is selected to have a working update path

%package x11_opt
License:        GPLv2+
Group:          Metapackages
Summary:        Meta package for pattern x11_opt
Recommends:     freeglut
Recommends:     x11-input-wacom
Recommends:     xdmbgrd
Recommends:     xtermset
Requires:       patterns-openSUSE-basesystem
Requires:       patterns-openSUSE-enhanced_base
Requires:       patterns-openSUSE-fonts

%description x11_opt
This package is installed if a pattern is selected to have a working update path

%package x11_yast
License:        GPLv2+
Group:          Metapackages
Summary:        Meta package for pattern x11_yast
Conflicts:      patterns-openSUSE-gnome
Conflicts:      patterns-openSUSE-kde4
Recommends:     yast2-control-center-qt
Recommends:     yast2-qt
Recommends:     yast2-qt-pkg
Requires:       patterns-openSUSE-x11_yast
Supplements:    packageand(patterns-openSUSE-x11:patterns-openSUSE-yast2_basis)

%description x11_yast
This package is installed if a pattern is selected to have a working update path

%package x86
License:        GPLv2+
Group:          Metapackages
Summary:        Meta package for pattern x86

%description x86
This package is installed if a pattern is selected to have a working update path

%package xen_server
License:        GPLv2+
Group:          Metapackages
Summary:        Meta package for pattern xen_server
Recommends:     bridge-utils
Recommends:     kernel-xen
Recommends:     virt-manager
Recommends:     virt-viewer
Recommends:     vm-install
Recommends:     xen
Recommends:     xen-doc-html
Recommends:     xen-doc-pdf
Recommends:     xen-libs
Recommends:     xen-tools
Recommends:     xterm
Recommends:     yast2-vm
Requires:       patterns-openSUSE-basesystem
Requires:       patterns-openSUSE-xen_server

%description xen_server
This package is installed if a pattern is selected to have a working update path

%package xfce
License:        GPLv2+
Group:          Metapackages
Summary:        Meta package for pattern xfce
Recommends:     MozillaFirefox
Recommends:     MozillaThunderbird
Recommends:     NetworkManager
Recommends:     NetworkManager-gnome
Recommends:     Terminal
Recommends:     aria2
Recommends:     avahi
%ifarch ix86
Recommends:     avahi
%endif
Recommends:     cheese
Recommends:     desktop-data-openSUSE
Recommends:     droid-fonts
Recommends:     empathy
Recommends:     evince
Recommends:     gcalctool
Recommends:     gconf2-branding-openSUSE
Recommends:     gdm
Recommends:     gmixer
Recommends:     gnome-packagekit
Recommends:     gtk-xfce-engine
Recommends:     gtk2-engine-murrine
Recommends:     gutenprint
Recommends:     hplip
Recommends:     java-1_6_0-openjdk-plugin
Recommends:     libgnomesu
Recommends:     mousepad
Recommends:     opensuse-codecs-installer
Recommends:     orage
Recommends:     parole
Recommends:     patterns-openSUSE-imaging
Recommends:     patterns-openSUSE-multimedia
Recommends:     patterns-openSUSE-remote_desktop
Recommends:     patterns-openSUSE-xfce_office
Recommends:     pinentry-gtk2
Recommends:     preload
Recommends:     ristretto
Recommends:     samba
Recommends:     smolt
Recommends:     system-config-printer
Recommends:     thunar
Recommends:     thunar-archive-plugin
Recommends:     thunar-media-tags-plugin
Recommends:     thunar-thumbnailers
Recommends:     thunar-volman
Recommends:     transmission-gtk
Recommends:     xarchiver
Recommends:     xdg-user-dirs
Recommends:     xdg-user-dirs-gtk
Recommends:     xdg-utils
Recommends:     xfburn
Recommends:     xfce-utils
Recommends:     xfce4-appfinder
Recommends:     xfce4-branding-openSUSE
Recommends:     xfce4-mixer
Recommends:     xfce4-notifyd
Recommends:     xfce4-panel
Recommends:     xfce4-power-manager
Recommends:     xfce4-screenshooter
Recommends:     xfce4-session
Recommends:     xfce4-settings
Recommends:     xfce4-taskmanager
Recommends:     xfconf
Recommends:     xfdesktop
Recommends:     xfwm4
Recommends:     xorg-x11
Recommends:     xscreensaver
Recommends:     yast2-control-center-gnome
Requires:       patterns-openSUSE-x11
Requires:       patterns-openSUSE-xfce
%ifarch x86_64
Recommends:     nspluginwrapper
%endif

%description xfce
This package is installed if a pattern is selected to have a working update path

%package xfce_laptop
License:        GPLv2+
Group:          Metapackages
Summary:        Meta package for pattern xfce_laptop
Recommends:     gnome-bluetooth
Recommends:     gsynaptics
Recommends:     xfce-panel-plugin-brightness
Requires:       patterns-openSUSE-xfce
Requires:       patterns-openSUSE-xfce_laptop
Supplements:    packageand(patterns-openSUSE-xfce:patterns-openSUSE-laptop)

%description xfce_laptop
This package is installed if a pattern is selected to have a working update path

%package xfce_office
License:        GPLv2+
Group:          Metapackages
Summary:        Meta package for pattern xfce_office
Recommends:     libreoffice-gnome
Requires:       patterns-openSUSE-xfce
Requires:       patterns-openSUSE-xfce_office
Supplements:    packageand(patterns-openSUSE-xfce:patterns-openSUSE-office)

%description xfce_office
This package is installed if a pattern is selected to have a working update path

%package xgl
License:        GPLv2+
Group:          Metapackages
Summary:        Meta package for pattern xgl
Recommends:     compiz
Recommends:     compiz-manager
Recommends:     compiz-plugins-main
Requires:       patterns-openSUSE-xgl

%description xgl
This package is installed if a pattern is selected to have a working update path

%package yast2_basis
License:        GPLv2+
Group:          Metapackages
Summary:        Meta package for pattern yast2_basis
Recommends:     yast2-backup
Recommends:     yast2-inetd
Recommends:     yast2-iscsi-client
Recommends:     yast2-kerberos-client
Recommends:     yast2-ldap-client
Recommends:     yast2-metapackage-handler
Recommends:     yast2-nfs-client
Recommends:     yast2-nis-client
Recommends:     yast2-ntp-client
Recommends:     yast2-packager-webpin
Recommends:     yast2-printer
Recommends:     yast2-restore
Recommends:     yast2-samba-client
Recommends:     yast2-samba-server
Recommends:     yast2-slp
Recommends:     yast2-sudo
Recommends:     yast2-vm
Requires:       libstorage
Requires:       limal-perl
Requires:       patterns-openSUSE-yast2_basis
Requires:       yast2
Requires:       yast2-country
Requires:       yast2-firewall
Requires:       yast2-hardware-detection
Requires:       yast2-installation
Requires:       yast2-irda
Requires:       yast2-ldap
Requires:       yast2-mail
Requires:       yast2-mouse
Requires:       yast2-ncurses
Requires:       yast2-ncurses-pkg
Requires:       yast2-network
Requires:       yast2-online-update
Requires:       yast2-online-update-frontend
Requires:       yast2-packager
Requires:       yast2-pam
Requires:       yast2-perl-bindings
Requires:       yast2-pkg-bindings
Requires:       yast2-runlevel
Requires:       yast2-security
Requires:       yast2-storage
Requires:       yast2-sysconfig
Requires:       yast2-theme-openSUSE
Requires:       yast2-transfer
Requires:       yast2-tune
Requires:       yast2-update
Requires:       yast2-users
Requires:       yast2-xml

%description yast2_basis
This package is installed if a pattern is selected to have a working update path

%package yast2_install_wf
License:        GPLv2+
Group:          Metapackages
Summary:        Meta package for pattern yast2_install_wf
Requires:       patterns-openSUSE-yast2_install_wf
Requires:       yast2-bootloader
Requires:       yast2-installation
Requires:       yast2-ncurses
Requires:       yast2-network
Requires:       yast2-users

%description yast2_install_wf
This package is installed if a pattern is selected to have a working update path

#END1

%prep
%setup -q -n patterns-openSUSE-data

%build
for i in data/*; do sh %SOURCE1 $i; done | perl %SOURCE4 | \
   uniq > data/REST-DVD-SUGGESTS
for i in gnome kde4; do 
  sh %{SOURCE1} toinstall/rest_cd_$i/requires > t && \
    mv t toinstall/rest_cd_$i/requires
done
/usr/sbin/patterns_utf8

%install
# Create description files for YaST2:
#
# Patterns
#
# For generation of -32bit/-x86/-64bit patterns
export RPM_BUILD_ROOT 
export RPM_SOURCE_DIR
sh -e %{SOURCE5} %{version} %{release} %{_target_cpu} openSUSE
/usr/sbin/patterns_lint $RPM_BUILD_ROOT/CD1/suse/setup/descr/*.pat
rm $RPM_BUILD_ROOT/CD1/suse/setup/descr/kde4_cd-*.pat
rm $RPM_BUILD_ROOT/CD1/suse/setup/descr/gnome_cd-*.pat
rm $RPM_BUILD_ROOT/CD1/suse/setup/descr/x11_cd-*.pat
rm $RPM_BUILD_ROOT/CD1/suse/setup/descr/dvd9-*.pat

#BEGIN2
mkdir -p $RPM_BUILD_ROOT/usr/share/doc/packages/patterns-openSUSE/
echo 'This file marks the pattern 32bit to be installed.' > $RPM_BUILD_ROOT/usr/share/doc/packages/patterns-openSUSE/32bit.txt
echo 'This file marks the pattern 64bit to be installed.' > $RPM_BUILD_ROOT/usr/share/doc/packages/patterns-openSUSE/64bit.txt
echo 'This file marks the pattern apparmor to be installed.' > $RPM_BUILD_ROOT/usr/share/doc/packages/patterns-openSUSE/apparmor.txt
echo 'This file marks the pattern apparmor_opt to be installed.' > $RPM_BUILD_ROOT/usr/share/doc/packages/patterns-openSUSE/apparmor_opt.txt
echo 'This file marks the pattern base to be installed.' > $RPM_BUILD_ROOT/usr/share/doc/packages/patterns-openSUSE/base.txt
echo 'This file marks the pattern console to be installed.' > $RPM_BUILD_ROOT/usr/share/doc/packages/patterns-openSUSE/console.txt
echo 'This file marks the pattern default to be installed.' > $RPM_BUILD_ROOT/usr/share/doc/packages/patterns-openSUSE/default.txt
echo 'This file marks the pattern devel_basis to be installed.' > $RPM_BUILD_ROOT/usr/share/doc/packages/patterns-openSUSE/devel_basis.txt
echo 'This file marks the pattern devel_C_C++ to be installed.' > $RPM_BUILD_ROOT/usr/share/doc/packages/patterns-openSUSE/devel_C_C++.txt
echo 'This file marks the pattern devel_gnome to be installed.' > $RPM_BUILD_ROOT/usr/share/doc/packages/patterns-openSUSE/devel_gnome.txt
echo 'This file marks the pattern devel_ide to be installed.' > $RPM_BUILD_ROOT/usr/share/doc/packages/patterns-openSUSE/devel_ide.txt
echo 'This file marks the pattern devel_java to be installed.' > $RPM_BUILD_ROOT/usr/share/doc/packages/patterns-openSUSE/devel_java.txt
echo 'This file marks the pattern devel_kde to be installed.' > $RPM_BUILD_ROOT/usr/share/doc/packages/patterns-openSUSE/devel_kde.txt
echo 'This file marks the pattern devel_kernel to be installed.' > $RPM_BUILD_ROOT/usr/share/doc/packages/patterns-openSUSE/devel_kernel.txt
echo 'This file marks the pattern devel_mono to be installed.' > $RPM_BUILD_ROOT/usr/share/doc/packages/patterns-openSUSE/devel_mono.txt
echo 'This file marks the pattern devel_perl to be installed.' > $RPM_BUILD_ROOT/usr/share/doc/packages/patterns-openSUSE/devel_perl.txt
echo 'This file marks the pattern devel_python to be installed.' > $RPM_BUILD_ROOT/usr/share/doc/packages/patterns-openSUSE/devel_python.txt
echo 'This file marks the pattern devel_qt4 to be installed.' > $RPM_BUILD_ROOT/usr/share/doc/packages/patterns-openSUSE/devel_qt4.txt
echo 'This file marks the pattern devel_rpm_build to be installed.' > $RPM_BUILD_ROOT/usr/share/doc/packages/patterns-openSUSE/devel_rpm_build.txt
echo 'This file marks the pattern devel_ruby to be installed.' > $RPM_BUILD_ROOT/usr/share/doc/packages/patterns-openSUSE/devel_ruby.txt
echo 'This file marks the pattern devel_tcl to be installed.' > $RPM_BUILD_ROOT/usr/share/doc/packages/patterns-openSUSE/devel_tcl.txt
echo 'This file marks the pattern devel_web to be installed.' > $RPM_BUILD_ROOT/usr/share/doc/packages/patterns-openSUSE/devel_web.txt
echo 'This file marks the pattern devel_yast to be installed.' > $RPM_BUILD_ROOT/usr/share/doc/packages/patterns-openSUSE/devel_yast.txt
echo 'This file marks the pattern dhcp_dns_server to be installed.' > $RPM_BUILD_ROOT/usr/share/doc/packages/patterns-openSUSE/dhcp_dns_server.txt
echo 'This file marks the pattern directory_server to be installed.' > $RPM_BUILD_ROOT/usr/share/doc/packages/patterns-openSUSE/directory_server.txt
echo 'This file marks the pattern enhanced_base to be installed.' > $RPM_BUILD_ROOT/usr/share/doc/packages/patterns-openSUSE/enhanced_base.txt
echo 'This file marks the pattern enhanced_base_opt to be installed.' > $RPM_BUILD_ROOT/usr/share/doc/packages/patterns-openSUSE/enhanced_base_opt.txt
echo 'This file marks the pattern file_server to be installed.' > $RPM_BUILD_ROOT/usr/share/doc/packages/patterns-openSUSE/file_server.txt
echo 'This file marks the pattern fonts to be installed.' > $RPM_BUILD_ROOT/usr/share/doc/packages/patterns-openSUSE/fonts.txt
echo 'This file marks the pattern fonts_opt to be installed.' > $RPM_BUILD_ROOT/usr/share/doc/packages/patterns-openSUSE/fonts_opt.txt
echo 'This file marks the pattern games to be installed.' > $RPM_BUILD_ROOT/usr/share/doc/packages/patterns-openSUSE/games.txt
echo 'This file marks the pattern gateway_server to be installed.' > $RPM_BUILD_ROOT/usr/share/doc/packages/patterns-openSUSE/gateway_server.txt
echo 'This file marks the pattern gnome to be installed.' > $RPM_BUILD_ROOT/usr/share/doc/packages/patterns-openSUSE/gnome.txt
echo 'This file marks the pattern gnome_admin to be installed.' > $RPM_BUILD_ROOT/usr/share/doc/packages/patterns-openSUSE/gnome_admin.txt
echo 'This file marks the pattern gnome_basis to be installed.' > $RPM_BUILD_ROOT/usr/share/doc/packages/patterns-openSUSE/gnome_basis.txt
echo 'This file marks the pattern gnome_basis_opt to be installed.' > $RPM_BUILD_ROOT/usr/share/doc/packages/patterns-openSUSE/gnome_basis_opt.txt
echo 'This file marks the pattern gnome_games to be installed.' > $RPM_BUILD_ROOT/usr/share/doc/packages/patterns-openSUSE/gnome_games.txt
echo 'This file marks the pattern gnome_ide to be installed.' > $RPM_BUILD_ROOT/usr/share/doc/packages/patterns-openSUSE/gnome_ide.txt
echo 'This file marks the pattern gnome_imaging to be installed.' > $RPM_BUILD_ROOT/usr/share/doc/packages/patterns-openSUSE/gnome_imaging.txt
echo 'This file marks the pattern gnome_imaging_opt to be installed.' > $RPM_BUILD_ROOT/usr/share/doc/packages/patterns-openSUSE/gnome_imaging_opt.txt
echo 'This file marks the pattern gnome_internet to be installed.' > $RPM_BUILD_ROOT/usr/share/doc/packages/patterns-openSUSE/gnome_internet.txt
echo 'This file marks the pattern gnome_laptop to be installed.' > $RPM_BUILD_ROOT/usr/share/doc/packages/patterns-openSUSE/gnome_laptop.txt
echo 'This file marks the pattern gnome_multimedia to be installed.' > $RPM_BUILD_ROOT/usr/share/doc/packages/patterns-openSUSE/gnome_multimedia.txt
echo 'This file marks the pattern gnome_multimedia_opt to be installed.' > $RPM_BUILD_ROOT/usr/share/doc/packages/patterns-openSUSE/gnome_multimedia_opt.txt
echo 'This file marks the pattern gnome_office to be installed.' > $RPM_BUILD_ROOT/usr/share/doc/packages/patterns-openSUSE/gnome_office.txt
echo 'This file marks the pattern gnome_office_opt to be installed.' > $RPM_BUILD_ROOT/usr/share/doc/packages/patterns-openSUSE/gnome_office_opt.txt
echo 'This file marks the pattern gnome_utilities to be installed.' > $RPM_BUILD_ROOT/usr/share/doc/packages/patterns-openSUSE/gnome_utilities.txt
echo 'This file marks the pattern gnome_xgl to be installed.' > $RPM_BUILD_ROOT/usr/share/doc/packages/patterns-openSUSE/gnome_xgl.txt
echo 'This file marks the pattern gnome_yast to be installed.' > $RPM_BUILD_ROOT/usr/share/doc/packages/patterns-openSUSE/gnome_yast.txt
echo 'This file marks the pattern imaging to be installed.' > $RPM_BUILD_ROOT/usr/share/doc/packages/patterns-openSUSE/imaging.txt
echo 'This file marks the pattern imaging_opt to be installed.' > $RPM_BUILD_ROOT/usr/share/doc/packages/patterns-openSUSE/imaging_opt.txt
echo 'This file marks the pattern kde to be installed.' > $RPM_BUILD_ROOT/usr/share/doc/packages/patterns-openSUSE/kde.txt
echo 'This file marks the pattern kde4 to be installed.' > $RPM_BUILD_ROOT/usr/share/doc/packages/patterns-openSUSE/kde4.txt
echo 'This file marks the pattern kde4_admin to be installed.' > $RPM_BUILD_ROOT/usr/share/doc/packages/patterns-openSUSE/kde4_admin.txt
echo 'This file marks the pattern kde4_basis to be installed.' > $RPM_BUILD_ROOT/usr/share/doc/packages/patterns-openSUSE/kde4_basis.txt
echo 'This file marks the pattern kde4_edutainment to be installed.' > $RPM_BUILD_ROOT/usr/share/doc/packages/patterns-openSUSE/kde4_edutainment.txt
echo 'This file marks the pattern kde4_games to be installed.' > $RPM_BUILD_ROOT/usr/share/doc/packages/patterns-openSUSE/kde4_games.txt
echo 'This file marks the pattern kde4_ide to be installed.' > $RPM_BUILD_ROOT/usr/share/doc/packages/patterns-openSUSE/kde4_ide.txt
echo 'This file marks the pattern kde4_imaging to be installed.' > $RPM_BUILD_ROOT/usr/share/doc/packages/patterns-openSUSE/kde4_imaging.txt
echo 'This file marks the pattern kde4_internet to be installed.' > $RPM_BUILD_ROOT/usr/share/doc/packages/patterns-openSUSE/kde4_internet.txt
echo 'This file marks the pattern kde4_laptop to be installed.' > $RPM_BUILD_ROOT/usr/share/doc/packages/patterns-openSUSE/kde4_laptop.txt
echo 'This file marks the pattern kde4_multimedia to be installed.' > $RPM_BUILD_ROOT/usr/share/doc/packages/patterns-openSUSE/kde4_multimedia.txt
echo 'This file marks the pattern kde4_office to be installed.' > $RPM_BUILD_ROOT/usr/share/doc/packages/patterns-openSUSE/kde4_office.txt
echo 'This file marks the pattern kde4_pure to be installed.' > $RPM_BUILD_ROOT/usr/share/doc/packages/patterns-openSUSE/kde4_pure.txt
echo 'This file marks the pattern kde4_utilities to be installed.' > $RPM_BUILD_ROOT/usr/share/doc/packages/patterns-openSUSE/kde4_utilities.txt
echo 'This file marks the pattern kde4_utilities_opt to be installed.' > $RPM_BUILD_ROOT/usr/share/doc/packages/patterns-openSUSE/kde4_utilities_opt.txt
echo 'This file marks the pattern kde4_xgl to be installed.' > $RPM_BUILD_ROOT/usr/share/doc/packages/patterns-openSUSE/kde4_xgl.txt
echo 'This file marks the pattern kde4_yast to be installed.' > $RPM_BUILD_ROOT/usr/share/doc/packages/patterns-openSUSE/kde4_yast.txt
echo 'This file marks the pattern lamp_server to be installed.' > $RPM_BUILD_ROOT/usr/share/doc/packages/patterns-openSUSE/lamp_server.txt
echo 'This file marks the pattern laptop to be installed.' > $RPM_BUILD_ROOT/usr/share/doc/packages/patterns-openSUSE/laptop.txt
echo 'This file marks the pattern lxde to be installed.' > $RPM_BUILD_ROOT/usr/share/doc/packages/patterns-openSUSE/lxde.txt
echo 'This file marks the pattern lxde_laptop to be installed.' > $RPM_BUILD_ROOT/usr/share/doc/packages/patterns-openSUSE/lxde_laptop.txt
echo 'This file marks the pattern lxde_office to be installed.' > $RPM_BUILD_ROOT/usr/share/doc/packages/patterns-openSUSE/lxde_office.txt
echo 'This file marks the pattern mail_server to be installed.' > $RPM_BUILD_ROOT/usr/share/doc/packages/patterns-openSUSE/mail_server.txt
echo 'This file marks the pattern minimal_base to be installed.' > $RPM_BUILD_ROOT/usr/share/doc/packages/patterns-openSUSE/minimal_base.txt
echo 'This file marks the pattern misc_server to be installed.' > $RPM_BUILD_ROOT/usr/share/doc/packages/patterns-openSUSE/misc_server.txt
echo 'This file marks the pattern multimedia to be installed.' > $RPM_BUILD_ROOT/usr/share/doc/packages/patterns-openSUSE/multimedia.txt
echo 'This file marks the pattern multimedia_opt to be installed.' > $RPM_BUILD_ROOT/usr/share/doc/packages/patterns-openSUSE/multimedia_opt.txt
echo 'This file marks the pattern network_admin to be installed.' > $RPM_BUILD_ROOT/usr/share/doc/packages/patterns-openSUSE/network_admin.txt
echo 'This file marks the pattern non_oss to be installed.' > $RPM_BUILD_ROOT/usr/share/doc/packages/patterns-openSUSE/non_oss.txt
echo 'This file marks the pattern non_oss_opt to be installed.' > $RPM_BUILD_ROOT/usr/share/doc/packages/patterns-openSUSE/non_oss_opt.txt
echo 'This file marks the pattern office to be installed.' > $RPM_BUILD_ROOT/usr/share/doc/packages/patterns-openSUSE/office.txt
echo 'This file marks the pattern office_opt to be installed.' > $RPM_BUILD_ROOT/usr/share/doc/packages/patterns-openSUSE/office_opt.txt
echo 'This file marks the pattern print_server to be installed.' > $RPM_BUILD_ROOT/usr/share/doc/packages/patterns-openSUSE/print_server.txt
echo 'This file marks the pattern remote_desktop to be installed.' > $RPM_BUILD_ROOT/usr/share/doc/packages/patterns-openSUSE/remote_desktop.txt
echo 'This file marks the pattern sw_management to be installed.' > $RPM_BUILD_ROOT/usr/share/doc/packages/patterns-openSUSE/sw_management.txt
echo 'This file marks the pattern sw_management_gnome to be installed.' > $RPM_BUILD_ROOT/usr/share/doc/packages/patterns-openSUSE/sw_management_gnome.txt
echo 'This file marks the pattern sw_management_kde4 to be installed.' > $RPM_BUILD_ROOT/usr/share/doc/packages/patterns-openSUSE/sw_management_kde4.txt
echo 'This file marks the pattern tabletpc to be installed.' > $RPM_BUILD_ROOT/usr/share/doc/packages/patterns-openSUSE/tabletpc.txt
echo 'This file marks the pattern technical_writing to be installed.' > $RPM_BUILD_ROOT/usr/share/doc/packages/patterns-openSUSE/technical_writing.txt
echo 'This file marks the pattern update_test to be installed.' > $RPM_BUILD_ROOT/usr/share/doc/packages/patterns-openSUSE/update_test.txt
echo 'This file marks the pattern voip to be installed.' > $RPM_BUILD_ROOT/usr/share/doc/packages/patterns-openSUSE/voip.txt
echo 'This file marks the pattern x11 to be installed.' > $RPM_BUILD_ROOT/usr/share/doc/packages/patterns-openSUSE/x11.txt
echo 'This file marks the pattern x11_opt to be installed.' > $RPM_BUILD_ROOT/usr/share/doc/packages/patterns-openSUSE/x11_opt.txt
echo 'This file marks the pattern x11_yast to be installed.' > $RPM_BUILD_ROOT/usr/share/doc/packages/patterns-openSUSE/x11_yast.txt
echo 'This file marks the pattern x86 to be installed.' > $RPM_BUILD_ROOT/usr/share/doc/packages/patterns-openSUSE/x86.txt
echo 'This file marks the pattern xen_server to be installed.' > $RPM_BUILD_ROOT/usr/share/doc/packages/patterns-openSUSE/xen_server.txt
echo 'This file marks the pattern xfce to be installed.' > $RPM_BUILD_ROOT/usr/share/doc/packages/patterns-openSUSE/xfce.txt
echo 'This file marks the pattern xfce_laptop to be installed.' > $RPM_BUILD_ROOT/usr/share/doc/packages/patterns-openSUSE/xfce_laptop.txt
echo 'This file marks the pattern xfce_office to be installed.' > $RPM_BUILD_ROOT/usr/share/doc/packages/patterns-openSUSE/xfce_office.txt
echo 'This file marks the pattern xgl to be installed.' > $RPM_BUILD_ROOT/usr/share/doc/packages/patterns-openSUSE/xgl.txt
echo 'This file marks the pattern yast2_basis to be installed.' > $RPM_BUILD_ROOT/usr/share/doc/packages/patterns-openSUSE/yast2_basis.txt
echo 'This file marks the pattern yast2_install_wf to be installed.' > $RPM_BUILD_ROOT/usr/share/doc/packages/patterns-openSUSE/yast2_install_wf.txt
#END2

%files
%defattr(-,root,root)
%dir /CD1
%dir /CD1/suse
%dir /CD1/suse/setup
%dir /CD1/suse/setup/descr
/CD1/suse/setup/descr/dvd-*.pat
/CD1/suse/setup/descr/ftp-*.pat
/CD1/suse/setup/descr/non_oss-*.pat

%files dvd
%defattr(-,root,root)
%dir /CD1
%dir /CD1/suse
%dir /CD1/suse/setup
%dir /CD1/suse/setup/descr
/CD1/suse/setup/descr/dvd-*.pat

%files Promo
%defattr(-,root,root)
%dir /CD1
%dir /CD1/suse
%dir /CD1/suse/setup
%dir /CD1/suse/setup/descr
/CD1/suse/setup/descr/promo_dvd-*.pat
/CD1/suse/setup/descr/non_oss-*.pat

#BEGIN3

%files 32bit
%defattr(-,root,root)
%dir /usr/share/doc/packages/patterns-openSUSE
/usr/share/doc/packages/patterns-openSUSE/32bit.txt

%files 64bit
%defattr(-,root,root)
%dir /usr/share/doc/packages/patterns-openSUSE
/usr/share/doc/packages/patterns-openSUSE/64bit.txt

%files apparmor
%defattr(-,root,root)
%dir /usr/share/doc/packages/patterns-openSUSE
/usr/share/doc/packages/patterns-openSUSE/apparmor.txt

%files apparmor_opt
%defattr(-,root,root)
%dir /usr/share/doc/packages/patterns-openSUSE
/usr/share/doc/packages/patterns-openSUSE/apparmor_opt.txt

%files base
%defattr(-,root,root)
%dir /usr/share/doc/packages/patterns-openSUSE
/usr/share/doc/packages/patterns-openSUSE/base.txt

%files console
%defattr(-,root,root)
%dir /usr/share/doc/packages/patterns-openSUSE
/usr/share/doc/packages/patterns-openSUSE/console.txt

%files default
%defattr(-,root,root)
%dir /usr/share/doc/packages/patterns-openSUSE
/usr/share/doc/packages/patterns-openSUSE/default.txt

%files devel_basis
%defattr(-,root,root)
%dir /usr/share/doc/packages/patterns-openSUSE
/usr/share/doc/packages/patterns-openSUSE/devel_basis.txt

%files devel_C_C++
%defattr(-,root,root)
%dir /usr/share/doc/packages/patterns-openSUSE
/usr/share/doc/packages/patterns-openSUSE/devel_C_C++.txt

%files devel_gnome
%defattr(-,root,root)
%dir /usr/share/doc/packages/patterns-openSUSE
/usr/share/doc/packages/patterns-openSUSE/devel_gnome.txt

%files devel_ide
%defattr(-,root,root)
%dir /usr/share/doc/packages/patterns-openSUSE
/usr/share/doc/packages/patterns-openSUSE/devel_ide.txt

%files devel_java
%defattr(-,root,root)
%dir /usr/share/doc/packages/patterns-openSUSE
/usr/share/doc/packages/patterns-openSUSE/devel_java.txt

%files devel_kde
%defattr(-,root,root)
%dir /usr/share/doc/packages/patterns-openSUSE
/usr/share/doc/packages/patterns-openSUSE/devel_kde.txt

%files devel_kernel
%defattr(-,root,root)
%dir /usr/share/doc/packages/patterns-openSUSE
/usr/share/doc/packages/patterns-openSUSE/devel_kernel.txt

%files devel_mono
%defattr(-,root,root)
%dir /usr/share/doc/packages/patterns-openSUSE
/usr/share/doc/packages/patterns-openSUSE/devel_mono.txt

%files devel_perl
%defattr(-,root,root)
%dir /usr/share/doc/packages/patterns-openSUSE
/usr/share/doc/packages/patterns-openSUSE/devel_perl.txt

%files devel_python
%defattr(-,root,root)
%dir /usr/share/doc/packages/patterns-openSUSE
/usr/share/doc/packages/patterns-openSUSE/devel_python.txt

%files devel_qt4
%defattr(-,root,root)
%dir /usr/share/doc/packages/patterns-openSUSE
/usr/share/doc/packages/patterns-openSUSE/devel_qt4.txt

%files devel_rpm_build
%defattr(-,root,root)
%dir /usr/share/doc/packages/patterns-openSUSE
/usr/share/doc/packages/patterns-openSUSE/devel_rpm_build.txt

%files devel_ruby
%defattr(-,root,root)
%dir /usr/share/doc/packages/patterns-openSUSE
/usr/share/doc/packages/patterns-openSUSE/devel_ruby.txt

%files devel_tcl
%defattr(-,root,root)
%dir /usr/share/doc/packages/patterns-openSUSE
/usr/share/doc/packages/patterns-openSUSE/devel_tcl.txt

%files devel_web
%defattr(-,root,root)
%dir /usr/share/doc/packages/patterns-openSUSE
/usr/share/doc/packages/patterns-openSUSE/devel_web.txt

%files devel_yast
%defattr(-,root,root)
%dir /usr/share/doc/packages/patterns-openSUSE
/usr/share/doc/packages/patterns-openSUSE/devel_yast.txt

%files dhcp_dns_server
%defattr(-,root,root)
%dir /usr/share/doc/packages/patterns-openSUSE
/usr/share/doc/packages/patterns-openSUSE/dhcp_dns_server.txt

%files directory_server
%defattr(-,root,root)
%dir /usr/share/doc/packages/patterns-openSUSE
/usr/share/doc/packages/patterns-openSUSE/directory_server.txt

%files enhanced_base
%defattr(-,root,root)
%dir /usr/share/doc/packages/patterns-openSUSE
/usr/share/doc/packages/patterns-openSUSE/enhanced_base.txt

%files enhanced_base_opt
%defattr(-,root,root)
%dir /usr/share/doc/packages/patterns-openSUSE
/usr/share/doc/packages/patterns-openSUSE/enhanced_base_opt.txt

%files file_server
%defattr(-,root,root)
%dir /usr/share/doc/packages/patterns-openSUSE
/usr/share/doc/packages/patterns-openSUSE/file_server.txt

%files fonts
%defattr(-,root,root)
%dir /usr/share/doc/packages/patterns-openSUSE
/usr/share/doc/packages/patterns-openSUSE/fonts.txt

%files fonts_opt
%defattr(-,root,root)
%dir /usr/share/doc/packages/patterns-openSUSE
/usr/share/doc/packages/patterns-openSUSE/fonts_opt.txt

%files games
%defattr(-,root,root)
%dir /usr/share/doc/packages/patterns-openSUSE
/usr/share/doc/packages/patterns-openSUSE/games.txt

%files gateway_server
%defattr(-,root,root)
%dir /usr/share/doc/packages/patterns-openSUSE
/usr/share/doc/packages/patterns-openSUSE/gateway_server.txt

%files gnome
%defattr(-,root,root)
%dir /usr/share/doc/packages/patterns-openSUSE
/usr/share/doc/packages/patterns-openSUSE/gnome.txt

%files gnome_admin
%defattr(-,root,root)
%dir /usr/share/doc/packages/patterns-openSUSE
/usr/share/doc/packages/patterns-openSUSE/gnome_admin.txt

%files gnome_basis
%defattr(-,root,root)
%dir /usr/share/doc/packages/patterns-openSUSE
/usr/share/doc/packages/patterns-openSUSE/gnome_basis.txt

%files gnome_basis_opt
%defattr(-,root,root)
%dir /usr/share/doc/packages/patterns-openSUSE
/usr/share/doc/packages/patterns-openSUSE/gnome_basis_opt.txt

%files gnome_games
%defattr(-,root,root)
%dir /usr/share/doc/packages/patterns-openSUSE
/usr/share/doc/packages/patterns-openSUSE/gnome_games.txt

%files gnome_ide
%defattr(-,root,root)
%dir /usr/share/doc/packages/patterns-openSUSE
/usr/share/doc/packages/patterns-openSUSE/gnome_ide.txt

%files gnome_imaging
%defattr(-,root,root)
%dir /usr/share/doc/packages/patterns-openSUSE
/usr/share/doc/packages/patterns-openSUSE/gnome_imaging.txt

%files gnome_imaging_opt
%defattr(-,root,root)
%dir /usr/share/doc/packages/patterns-openSUSE
/usr/share/doc/packages/patterns-openSUSE/gnome_imaging_opt.txt

%files gnome_internet
%defattr(-,root,root)
%dir /usr/share/doc/packages/patterns-openSUSE
/usr/share/doc/packages/patterns-openSUSE/gnome_internet.txt

%files gnome_laptop
%defattr(-,root,root)
%dir /usr/share/doc/packages/patterns-openSUSE
/usr/share/doc/packages/patterns-openSUSE/gnome_laptop.txt

%files gnome_multimedia
%defattr(-,root,root)
%dir /usr/share/doc/packages/patterns-openSUSE
/usr/share/doc/packages/patterns-openSUSE/gnome_multimedia.txt

%files gnome_multimedia_opt
%defattr(-,root,root)
%dir /usr/share/doc/packages/patterns-openSUSE
/usr/share/doc/packages/patterns-openSUSE/gnome_multimedia_opt.txt

%files gnome_office
%defattr(-,root,root)
%dir /usr/share/doc/packages/patterns-openSUSE
/usr/share/doc/packages/patterns-openSUSE/gnome_office.txt

%files gnome_office_opt
%defattr(-,root,root)
%dir /usr/share/doc/packages/patterns-openSUSE
/usr/share/doc/packages/patterns-openSUSE/gnome_office_opt.txt

%files gnome_utilities
%defattr(-,root,root)
%dir /usr/share/doc/packages/patterns-openSUSE
/usr/share/doc/packages/patterns-openSUSE/gnome_utilities.txt

%files gnome_xgl
%defattr(-,root,root)
%dir /usr/share/doc/packages/patterns-openSUSE
/usr/share/doc/packages/patterns-openSUSE/gnome_xgl.txt

%files gnome_yast
%defattr(-,root,root)
%dir /usr/share/doc/packages/patterns-openSUSE
/usr/share/doc/packages/patterns-openSUSE/gnome_yast.txt

%files imaging
%defattr(-,root,root)
%dir /usr/share/doc/packages/patterns-openSUSE
/usr/share/doc/packages/patterns-openSUSE/imaging.txt

%files imaging_opt
%defattr(-,root,root)
%dir /usr/share/doc/packages/patterns-openSUSE
/usr/share/doc/packages/patterns-openSUSE/imaging_opt.txt

%files kde
%defattr(-,root,root)
%dir /usr/share/doc/packages/patterns-openSUSE
/usr/share/doc/packages/patterns-openSUSE/kde.txt

%files kde4
%defattr(-,root,root)
%dir /usr/share/doc/packages/patterns-openSUSE
/usr/share/doc/packages/patterns-openSUSE/kde4.txt

%files kde4_admin
%defattr(-,root,root)
%dir /usr/share/doc/packages/patterns-openSUSE
/usr/share/doc/packages/patterns-openSUSE/kde4_admin.txt

%files kde4_basis
%defattr(-,root,root)
%dir /usr/share/doc/packages/patterns-openSUSE
/usr/share/doc/packages/patterns-openSUSE/kde4_basis.txt

%files kde4_edutainment
%defattr(-,root,root)
%dir /usr/share/doc/packages/patterns-openSUSE
/usr/share/doc/packages/patterns-openSUSE/kde4_edutainment.txt

%files kde4_games
%defattr(-,root,root)
%dir /usr/share/doc/packages/patterns-openSUSE
/usr/share/doc/packages/patterns-openSUSE/kde4_games.txt

%files kde4_ide
%defattr(-,root,root)
%dir /usr/share/doc/packages/patterns-openSUSE
/usr/share/doc/packages/patterns-openSUSE/kde4_ide.txt

%files kde4_imaging
%defattr(-,root,root)
%dir /usr/share/doc/packages/patterns-openSUSE
/usr/share/doc/packages/patterns-openSUSE/kde4_imaging.txt

%files kde4_internet
%defattr(-,root,root)
%dir /usr/share/doc/packages/patterns-openSUSE
/usr/share/doc/packages/patterns-openSUSE/kde4_internet.txt

%files kde4_laptop
%defattr(-,root,root)
%dir /usr/share/doc/packages/patterns-openSUSE
/usr/share/doc/packages/patterns-openSUSE/kde4_laptop.txt

%files kde4_multimedia
%defattr(-,root,root)
%dir /usr/share/doc/packages/patterns-openSUSE
/usr/share/doc/packages/patterns-openSUSE/kde4_multimedia.txt

%files kde4_office
%defattr(-,root,root)
%dir /usr/share/doc/packages/patterns-openSUSE
/usr/share/doc/packages/patterns-openSUSE/kde4_office.txt

%files kde4_pure
%defattr(-,root,root)
%dir /usr/share/doc/packages/patterns-openSUSE
/usr/share/doc/packages/patterns-openSUSE/kde4_pure.txt

%files kde4_utilities
%defattr(-,root,root)
%dir /usr/share/doc/packages/patterns-openSUSE
/usr/share/doc/packages/patterns-openSUSE/kde4_utilities.txt

%files kde4_utilities_opt
%defattr(-,root,root)
%dir /usr/share/doc/packages/patterns-openSUSE
/usr/share/doc/packages/patterns-openSUSE/kde4_utilities_opt.txt

%files kde4_xgl
%defattr(-,root,root)
%dir /usr/share/doc/packages/patterns-openSUSE
/usr/share/doc/packages/patterns-openSUSE/kde4_xgl.txt

%files kde4_yast
%defattr(-,root,root)
%dir /usr/share/doc/packages/patterns-openSUSE
/usr/share/doc/packages/patterns-openSUSE/kde4_yast.txt

%files lamp_server
%defattr(-,root,root)
%dir /usr/share/doc/packages/patterns-openSUSE
/usr/share/doc/packages/patterns-openSUSE/lamp_server.txt

%files laptop
%defattr(-,root,root)
%dir /usr/share/doc/packages/patterns-openSUSE
/usr/share/doc/packages/patterns-openSUSE/laptop.txt

%files lxde
%defattr(-,root,root)
%dir /usr/share/doc/packages/patterns-openSUSE
/usr/share/doc/packages/patterns-openSUSE/lxde.txt

%files lxde_laptop
%defattr(-,root,root)
%dir /usr/share/doc/packages/patterns-openSUSE
/usr/share/doc/packages/patterns-openSUSE/lxde_laptop.txt

%files lxde_office
%defattr(-,root,root)
%dir /usr/share/doc/packages/patterns-openSUSE
/usr/share/doc/packages/patterns-openSUSE/lxde_office.txt

%files mail_server
%defattr(-,root,root)
%dir /usr/share/doc/packages/patterns-openSUSE
/usr/share/doc/packages/patterns-openSUSE/mail_server.txt

%files minimal_base
%defattr(-,root,root)
%dir /usr/share/doc/packages/patterns-openSUSE
/usr/share/doc/packages/patterns-openSUSE/minimal_base.txt

%files misc_server
%defattr(-,root,root)
%dir /usr/share/doc/packages/patterns-openSUSE
/usr/share/doc/packages/patterns-openSUSE/misc_server.txt

%files multimedia
%defattr(-,root,root)
%dir /usr/share/doc/packages/patterns-openSUSE
/usr/share/doc/packages/patterns-openSUSE/multimedia.txt

%files multimedia_opt
%defattr(-,root,root)
%dir /usr/share/doc/packages/patterns-openSUSE
/usr/share/doc/packages/patterns-openSUSE/multimedia_opt.txt

%files network_admin
%defattr(-,root,root)
%dir /usr/share/doc/packages/patterns-openSUSE
/usr/share/doc/packages/patterns-openSUSE/network_admin.txt

%files non_oss
%defattr(-,root,root)
%dir /usr/share/doc/packages/patterns-openSUSE
/usr/share/doc/packages/patterns-openSUSE/non_oss.txt

%files non_oss_opt
%defattr(-,root,root)
%dir /usr/share/doc/packages/patterns-openSUSE
/usr/share/doc/packages/patterns-openSUSE/non_oss_opt.txt

%files office
%defattr(-,root,root)
%dir /usr/share/doc/packages/patterns-openSUSE
/usr/share/doc/packages/patterns-openSUSE/office.txt

%files office_opt
%defattr(-,root,root)
%dir /usr/share/doc/packages/patterns-openSUSE
/usr/share/doc/packages/patterns-openSUSE/office_opt.txt

%files print_server
%defattr(-,root,root)
%dir /usr/share/doc/packages/patterns-openSUSE
/usr/share/doc/packages/patterns-openSUSE/print_server.txt

%files remote_desktop
%defattr(-,root,root)
%dir /usr/share/doc/packages/patterns-openSUSE
/usr/share/doc/packages/patterns-openSUSE/remote_desktop.txt

%files sw_management
%defattr(-,root,root)
%dir /usr/share/doc/packages/patterns-openSUSE
/usr/share/doc/packages/patterns-openSUSE/sw_management.txt

%files sw_management_gnome
%defattr(-,root,root)
%dir /usr/share/doc/packages/patterns-openSUSE
/usr/share/doc/packages/patterns-openSUSE/sw_management_gnome.txt

%files sw_management_kde4
%defattr(-,root,root)
%dir /usr/share/doc/packages/patterns-openSUSE
/usr/share/doc/packages/patterns-openSUSE/sw_management_kde4.txt

%files tabletpc
%defattr(-,root,root)
%dir /usr/share/doc/packages/patterns-openSUSE
/usr/share/doc/packages/patterns-openSUSE/tabletpc.txt

%files technical_writing
%defattr(-,root,root)
%dir /usr/share/doc/packages/patterns-openSUSE
/usr/share/doc/packages/patterns-openSUSE/technical_writing.txt

%files update_test
%defattr(-,root,root)
%dir /usr/share/doc/packages/patterns-openSUSE
/usr/share/doc/packages/patterns-openSUSE/update_test.txt

%files voip
%defattr(-,root,root)
%dir /usr/share/doc/packages/patterns-openSUSE
/usr/share/doc/packages/patterns-openSUSE/voip.txt

%files x11
%defattr(-,root,root)
%dir /usr/share/doc/packages/patterns-openSUSE
/usr/share/doc/packages/patterns-openSUSE/x11.txt

%files x11_opt
%defattr(-,root,root)
%dir /usr/share/doc/packages/patterns-openSUSE
/usr/share/doc/packages/patterns-openSUSE/x11_opt.txt

%files x11_yast
%defattr(-,root,root)
%dir /usr/share/doc/packages/patterns-openSUSE
/usr/share/doc/packages/patterns-openSUSE/x11_yast.txt

%files x86
%defattr(-,root,root)
%dir /usr/share/doc/packages/patterns-openSUSE
/usr/share/doc/packages/patterns-openSUSE/x86.txt

%files xen_server
%defattr(-,root,root)
%dir /usr/share/doc/packages/patterns-openSUSE
/usr/share/doc/packages/patterns-openSUSE/xen_server.txt

%files xfce
%defattr(-,root,root)
%dir /usr/share/doc/packages/patterns-openSUSE
/usr/share/doc/packages/patterns-openSUSE/xfce.txt

%files xfce_laptop
%defattr(-,root,root)
%dir /usr/share/doc/packages/patterns-openSUSE
/usr/share/doc/packages/patterns-openSUSE/xfce_laptop.txt

%files xfce_office
%defattr(-,root,root)
%dir /usr/share/doc/packages/patterns-openSUSE
/usr/share/doc/packages/patterns-openSUSE/xfce_office.txt

%files xgl
%defattr(-,root,root)
%dir /usr/share/doc/packages/patterns-openSUSE
/usr/share/doc/packages/patterns-openSUSE/xgl.txt

%files yast2_basis
%defattr(-,root,root)
%dir /usr/share/doc/packages/patterns-openSUSE
/usr/share/doc/packages/patterns-openSUSE/yast2_basis.txt

%files yast2_install_wf
%defattr(-,root,root)
%dir /usr/share/doc/packages/patterns-openSUSE
/usr/share/doc/packages/patterns-openSUSE/yast2_install_wf.txt

#END3

%changelog
openSUSE Build Service is sponsored by