File at-spi-gtk-version.patch of Package at-spi

Index: at-spi-1.32.0/configure.in
===================================================================
--- at-spi-1.32.0.orig/configure.in
+++ at-spi-1.32.0/configure.in
@@ -27,7 +27,7 @@ AC_SUBST(LT_AGE)
 
 dnl required versions of other tools.
 m4_define([req_ver_atk],	[1.29.2])
-m4_define([req_ver_gtk],	[2.19.7])
+m4_define([req_ver_gtk],	[2.18.0])
 m4_define([req_ver_dbus],	[0.76])
 m4_define([req_ver_gconf],	[2.0.0])
 m4_define([req_ver_gail],	[1.9.0])
Index: at-spi-1.32.0/configure
===================================================================
--- at-spi-1.32.0.orig/configure
+++ at-spi-1.32.0/configure
@@ -14264,14 +14264,14 @@ if test -n "$REGISTRYD_CFLAGS"; then
     { { $as_echo "$as_me:${as_lineno-$LINENO}: \$PKG_CONFIG --exists --print-errors \"
 	libbonobo-2.0	>= 1.107.0
 	atk		>= 1.29.2
-	gtk+-2.0	>= 2.19.7
+	gtk+-2.0	>= 2.18.0
 	dbus-glib-1     >= 0.76
 	gconf-2.0	>= 2.0.0
 \""; } >&5
   ($PKG_CONFIG --exists --print-errors "
 	libbonobo-2.0	>= 1.107.0
 	atk		>= 1.29.2
-	gtk+-2.0	>= 2.19.7
+	gtk+-2.0	>= 2.18.0
 	dbus-glib-1     >= 0.76
 	gconf-2.0	>= 2.0.0
 ") 2>&5
@@ -14281,7 +14281,7 @@ if test -n "$REGISTRYD_CFLAGS"; then
   pkg_cv_REGISTRYD_CFLAGS=`$PKG_CONFIG --cflags "
 	libbonobo-2.0	>= 1.107.0
 	atk		>= 1.29.2
-	gtk+-2.0	>= 2.19.7
+	gtk+-2.0	>= 2.18.0
 	dbus-glib-1     >= 0.76
 	gconf-2.0	>= 2.0.0
 " 2>/dev/null`
@@ -14298,14 +14298,14 @@ if test -n "$REGISTRYD_LIBS"; then
     { { $as_echo "$as_me:${as_lineno-$LINENO}: \$PKG_CONFIG --exists --print-errors \"
 	libbonobo-2.0	>= 1.107.0
 	atk		>= 1.29.2
-	gtk+-2.0	>= 2.19.7
+	gtk+-2.0	>= 2.18.0
 	dbus-glib-1     >= 0.76
 	gconf-2.0	>= 2.0.0
 \""; } >&5
   ($PKG_CONFIG --exists --print-errors "
 	libbonobo-2.0	>= 1.107.0
 	atk		>= 1.29.2
-	gtk+-2.0	>= 2.19.7
+	gtk+-2.0	>= 2.18.0
 	dbus-glib-1     >= 0.76
 	gconf-2.0	>= 2.0.0
 ") 2>&5
@@ -14315,7 +14315,7 @@ if test -n "$REGISTRYD_LIBS"; then
   pkg_cv_REGISTRYD_LIBS=`$PKG_CONFIG --libs "
 	libbonobo-2.0	>= 1.107.0
 	atk		>= 1.29.2
-	gtk+-2.0	>= 2.19.7
+	gtk+-2.0	>= 2.18.0
 	dbus-glib-1     >= 0.76
 	gconf-2.0	>= 2.0.0
 " 2>/dev/null`
@@ -14341,7 +14341,7 @@ fi
 	        REGISTRYD_PKG_ERRORS=`$PKG_CONFIG --short-errors --print-errors "
 	libbonobo-2.0	>= 1.107.0
 	atk		>= 1.29.2
-	gtk+-2.0	>= 2.19.7
+	gtk+-2.0	>= 2.18.0
 	dbus-glib-1     >= 0.76
 	gconf-2.0	>= 2.0.0
 " 2>&1`
@@ -14349,7 +14349,7 @@ fi
 	        REGISTRYD_PKG_ERRORS=`$PKG_CONFIG --print-errors "
 	libbonobo-2.0	>= 1.107.0
 	atk		>= 1.29.2
-	gtk+-2.0	>= 2.19.7
+	gtk+-2.0	>= 2.18.0
 	dbus-glib-1     >= 0.76
 	gconf-2.0	>= 2.0.0
 " 2>&1`
@@ -14360,7 +14360,7 @@ fi
 	as_fn_error $? "Package requirements (
 	libbonobo-2.0	>= 1.107.0
 	atk		>= 1.29.2
-	gtk+-2.0	>= 2.19.7
+	gtk+-2.0	>= 2.18.0
 	dbus-glib-1     >= 0.76
 	gconf-2.0	>= 2.0.0
 ) were not met:
@@ -14410,13 +14410,13 @@ if test -n "$TESTS_CFLAGS"; then
     { { $as_echo "$as_me:${as_lineno-$LINENO}: \$PKG_CONFIG --exists --print-errors \"
 	libbonobo-2.0	>= 1.107.0
 	atk		>= 1.29.2
-	gtk+-2.0	>= 2.19.7
+	gtk+-2.0	>= 2.18.0
 	gail		>= 1.9.0
 \""; } >&5
   ($PKG_CONFIG --exists --print-errors "
 	libbonobo-2.0	>= 1.107.0
 	atk		>= 1.29.2
-	gtk+-2.0	>= 2.19.7
+	gtk+-2.0	>= 2.18.0
 	gail		>= 1.9.0
 ") 2>&5
   ac_status=$?
@@ -14425,7 +14425,7 @@ if test -n "$TESTS_CFLAGS"; then
   pkg_cv_TESTS_CFLAGS=`$PKG_CONFIG --cflags "
 	libbonobo-2.0	>= 1.107.0
 	atk		>= 1.29.2
-	gtk+-2.0	>= 2.19.7
+	gtk+-2.0	>= 2.18.0
 	gail		>= 1.9.0
 " 2>/dev/null`
 else
@@ -14441,13 +14441,13 @@ if test -n "$TESTS_LIBS"; then
     { { $as_echo "$as_me:${as_lineno-$LINENO}: \$PKG_CONFIG --exists --print-errors \"
 	libbonobo-2.0	>= 1.107.0
 	atk		>= 1.29.2
-	gtk+-2.0	>= 2.19.7
+	gtk+-2.0	>= 2.18.0
 	gail		>= 1.9.0
 \""; } >&5
   ($PKG_CONFIG --exists --print-errors "
 	libbonobo-2.0	>= 1.107.0
 	atk		>= 1.29.2
-	gtk+-2.0	>= 2.19.7
+	gtk+-2.0	>= 2.18.0
 	gail		>= 1.9.0
 ") 2>&5
   ac_status=$?
@@ -14456,7 +14456,7 @@ if test -n "$TESTS_LIBS"; then
   pkg_cv_TESTS_LIBS=`$PKG_CONFIG --libs "
 	libbonobo-2.0	>= 1.107.0
 	atk		>= 1.29.2
-	gtk+-2.0	>= 2.19.7
+	gtk+-2.0	>= 2.18.0
 	gail		>= 1.9.0
 " 2>/dev/null`
 else
@@ -14481,14 +14481,14 @@ fi
 	        TESTS_PKG_ERRORS=`$PKG_CONFIG --short-errors --print-errors "
 	libbonobo-2.0	>= 1.107.0
 	atk		>= 1.29.2
-	gtk+-2.0	>= 2.19.7
+	gtk+-2.0	>= 2.18.0
 	gail		>= 1.9.0
 " 2>&1`
         else
 	        TESTS_PKG_ERRORS=`$PKG_CONFIG --print-errors "
 	libbonobo-2.0	>= 1.107.0
 	atk		>= 1.29.2
-	gtk+-2.0	>= 2.19.7
+	gtk+-2.0	>= 2.18.0
 	gail		>= 1.9.0
 " 2>&1`
         fi
@@ -14498,7 +14498,7 @@ fi
 	as_fn_error $? "Package requirements (
 	libbonobo-2.0	>= 1.107.0
 	atk		>= 1.29.2
-	gtk+-2.0	>= 2.19.7
+	gtk+-2.0	>= 2.18.0
 	gail		>= 1.9.0
 ) were not met: