File libopensync-plugin-evolution2.spec of Package libopensync-plugin-evolution2

#
# spec file for package libopensync-plugin-evolution2 (Version 0.22)
#
# Copyright (c) 2009 SUSE LINUX Products GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via http://bugs.opensuse.org/
#

# norootforbuild


Name:           libopensync-plugin-evolution2
BuildRequires:  evolution-data-server-devel libbonobo-devel libopensync-devel update-desktop-files
Url:            http://www.opensync.org
Version:        0.22
Release:        205
Summary:        Evolution 2 Synchronization Plug-In for OpenSync
License:        LGPL v2.1 or later
Group:          Productivity/Other
AutoReqProv:    on
Source:         %{name}-%{version}.tar.bz2
Patch:          libopensync-plugin-evolution2-fix_build.diff
BuildRoot:      %{_tmppath}/%{name}-%{version}-build
Requires:       evolution-data-server
%define prefix   /usr

%description
This plug-in allows applications using OpenSync to synchronize to and
from Evolution 2.

Additionally install the libopensync package.



Authors:
--------
    Armin Bauer <armin.bauer@desscon.com>

%package devel
License:        LGPL v2.1 or later
Summary:        Header files and libraries for libopensync-plugin-evolution2
Group:          Development/Libraries/C and C++
Requires:       %{name} = %{version}  libopensync-devel evolution-data-server 

%description devel
This package contains the header files, static libraries and
development documentation for libopensync-plugin-evolution2. If you
like to develop programs using libopensync-plugin-evolution2, you will
need to install libopensync-plugin-evolution2-devel.



Authors:
--------
    Armin Bauer <armin.bauer@desscon.com>

%prep
%setup -q
%patch

%build
autoreconf -sfi
CFLAGS="$RPM_OPT_FLAGS" ./configure --prefix=%_prefix --libdir=%_libdir --localstatedir=%_localstatedir
make

%install
make DESTDIR=$RPM_BUILD_ROOT install

%clean
rm -rf $RPM_BUILD_ROOT

%post -p /sbin/ldconfig

%postun -p /sbin/ldconfig

%files
%defattr(-, root, root)
%{_libdir}/opensync/plugins/evo2_sync.so
%{_datadir}/opensync/defaults/evo2-sync
%doc AUTHORS COPYING INSTALL ChangeLog NEWS README

%files devel
%defattr(-, root, root)
%{_includedir}/opensync-1.0/opensync/evo2_sync.h
%{_libdir}/opensync/plugins/evo2_sync.la
%doc AUTHORS COPYING INSTALL ChangeLog NEWS README

%changelog
* Thu Mar 13 2008 cstender@suse.de
- fixed build (ignore warning in libical/ical.h)
* Thu Mar 29 2007 cstender@suse.de
- updated to version 0.22
  o added osync_change_set_member(change, env->member)
* Mon Nov 06 2006 cstender@suse.de
- bumped version to 0.20
* Tue Oct 03 2006 aj@suse.de
- Cleanup BuildRequires.
* Fri Sep 29 2006 cstender@suse.de
- updated to version 0.19
* Mon Aug 28 2006 cstender@suse.de
- updated to version 0.18+svn1233
  o fixed the license (all code is LGPL)
* Thu Jul 06 2006 dgollub@suse.de
- updated to version 0.18_SVN1095:
  o added plugin description and detailed name
* Wed Jan 25 2006 mls@suse.de
- converted neededforbuild to BuildRequires
* Mon Dec 12 2005 dgollub@suse.de
- updated to v0.18_SVN770
* Mon Nov 14 2005 dgollub@suse.de
- re-enable patches
* Fri Nov 11 2005 dgollub@suse.de
- updated to version 0.18
* Fri Oct 21 2005 behlert@suse.de
- added patches from Stefan Scheler:
  * tries to add a record if modification fails (workaround for devices
  which only can report modifications, like various palms)
* Wed Oct 05 2005 behlert@suse.de
- updated svn-version (svn20051005)
* Thu Jun 30 2005 behlert@suse.de
- fixed requires
* Wed Jun 29 2005 behlert@suse.de
- added devel-package (needed for GUI)
* Mon Jun 27 2005 behlert@suse.de
- initial version (v0.17)