File perl-SOAP-Lite.spec of Package perl-SOAP-Lite

#
# spec file for package perl-SOAP-Lite (Version 0.712)
#
# Copyright (c) 2010 SUSE LINUX Products GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via http://bugs.opensuse.org/
#

# norootforbuild


Name:           perl-SOAP-Lite
%define cpan_name SOAP-Lite
Summary:        Perl's Web Services Toolkit
Version:        0.712
Release:        2
License:        GPL+ or Artistic
Group:          Development/Libraries/Perl
Url:            http://search.cpan.org/dist/SOAP-Lite/
#Source:         http://www.cpan.org/modules/by-module/SOAP/SOAP-Lite-%{version}.tar.gz
Source:         %{cpan_name}-%{version}.tar.bz2
Patch0:         %{cpan_name}-0.712-HTTPS_DAEMON.patch
BuildRoot:      %{_tmppath}/%{name}-%{version}-build
%{perl_requires}
BuildArch:      noarch
BuildRequires:  perl
BuildRequires:  perl-macros
BuildRequires:  perl(Class::Inspector)
BuildRequires:  perl(constant)
BuildRequires:  perl(HTTP::Daemon)
BuildRequires:  perl(IO::File)
BuildRequires:  perl(IO::Socket::SSL)
BuildRequires:  perl(LWP::UserAgent)
BuildRequires:  perl(MIME::Parser)
BuildRequires:  perl(Scalar::Util)
BuildRequires:  perl(Task::Weaken)
BuildRequires:  perl(URI)
BuildRequires:  perl(XML::Parser) >= 2.23
#
Requires:       perl(Class::Inspector)
Requires:       perl(constant)
Requires:       perl(HTTP::Daemon)
Requires:       perl(IO::File)
Requires:       perl(IO::Socket::SSL)
Requires:       perl(LWP::UserAgent)
Requires:       perl(MIME::Parser)
Requires:       perl(Scalar::Util)
Requires:       perl(Task::Weaken)
Requires:       perl(URI)
Requires:       perl(XML::Parser) >= 2.23

%description
SOAP::Lite is a collection of Perl modules which provides a simple and
lightweight interface to the Simple Object Access Protocol (SOAP) both on
client and server side.

Authors:
--------
    Paul Kulchenko <paulclinger@yahoo.com>
    Martin Kutter <martin.kutter@fen-net.de>
    Randy J. Ray <rjray@blackperl.com>
    Byrne Reese <byrne@majordojo.com>

%prep
%setup -q -n %{cpan_name}-%{version}
%patch0 -p1
for file in bin/SOAPsh.pl bin/XMLRPCsh.pl; do
%{__sed} -i -e 's@^\#\!/bin/env\(.*\)@\#\!/usr/bin/env\1@' $file
done

%build
%{__perl} Makefile.PL INSTALLDIRS=vendor
%{__make} %{?_smp_mflags}

%check
%{__make} test

%install
%perl_make_install
# do not perl_process_packlist (noarch)
# remove .packlist file
%{__rm} -rf $RPM_BUILD_ROOT%perl_vendorarch
# remove perllocal.pod file
%{__rm} -rf $RPM_BUILD_ROOT%perl_archlib
%perl_gen_filelist

%clean
%{__rm} -rf $RPM_BUILD_ROOT

%files -f %{name}.files
%defattr(-,root,root,-)
%doc Changes HACKING README ReleaseNotes.txt

%changelog