File nautilus-actions.changes of Package nautilus-actions

-------------------------------------------------------------------
Fri Mar  9 09:59:12 UTC 2012 - dimstar@opensuse.org

- Update to version 3.2.2:
  + UI enhancements: let the example label be expandable
  + Bump FDL to 1.3 among all documentation
  + Validate desktop file when making distcheck
  + Fix wrong display in tabs vs. the current selection in tree
    view
  + Bugs fixed: bgo#671043, bgo#671044, bgo#671083
  + Updated translations.

-------------------------------------------------------------------
Wed Feb 29 10:14:14 UTC 2012 - vuntz@opensuse.org

- Update to version 3.2.0:
  + Let import/export assistants pages be scrollable
  + Let the export format be selected in a treeview
  + Let the import mode be selected in a treeview
  + Make labels wrappable in import/export assistants
  + Fix vertical expand in Preferences dialog
  + Destroy the assistants toplevels when quitting
  + Set "Relying on runtime detection" as default in "Runtime
    execution" tab
  + Detect XFCE desktop
  + Force GConf I/O provider to be read-only after the migration
  + Check if action is writable when deleting a profile
  + Enable basenames, capabilities, folders, mimetypes and
    schemes tabs if a context is available
  + Migrate from dbus-glib to glib's GDBus (bgo#622909)
  + User documentation and gtk-doc documentation not installed by
    default (bgo#668181)
  + Should check for ice pkgconfig in configure (bgo#670434)
  + Mark strings as translatable (bgo#667429)
  + Many other code changes.
  + Several API additions (see NEWS for details).
  + Build fixes.
  + Updated translations.
- Remove xz BuildRequires now that it comes for free in the build
  system.
- Remove pkgconfig(dbus-glib-1) BuildRequires: code is ported to
  GDBus.
- Add pkgconfig(gio-2.0) and pkgconfig(ice) BuildRequires: now
  checked for by configure.
- Stop passing --enable-html-manuals to configure: it's not needed
  anymore, as the installation of documentation is now fixed.

-------------------------------------------------------------------
Sun Feb 19 16:29:24 UTC 2012 - dimstar@opensuse.org

- Add pkgconfig(sm) BuildRequires: this used to be pulled in by
  something else before, but the relayout of xorg-x11 packages
  changed that.

-------------------------------------------------------------------
Wed Jan 18 12:50:03 UTC 2012 - vuntz@opensuse.org

- Update to version 3.1.5:
  + Several bug fixes.
  + Removal of deprecated API usage.
  + Code cleanups.
  + Build system changes.
  + Updated translations.
- Add xz BuildRequires because we can't build a package for a
  xz-compressed tarball without explicitly specifying that... See
  bnc#697467 for more details.
- Add gnome-doc-utils-devel BuildRequires: needed for user
  documentation.
- Pass --enable-html-manuals to configure: even though we don't
  want the HTML docs, we need this to have the help files
  installed. See bgo#668181.

-------------------------------------------------------------------
Sat Jul  9 14:39:16 CEST 2011 - vuntz@opensuse.org

- Update to version 3.1.4:
  + Bug fixes:
    - bgo#649796: Migration tool doesn't automatically run
    - bgo#650523: Remote filenames are no more reachables
    - bgo#651911: 3.1.2 treats "isdir" differently than 2.30.2
    - bgo#652664: Documentation improvements
  + Other modifications:
    - Do not try to import a null or empty list of items
    - Keep GConf readable even after migration to Desktop
  + Updated translations.

-------------------------------------------------------------------
Tue Jun 28 10:20:01 UTC 2011 - dimstar@opensuse.org

- Initial version of nautilus-actions 3.1.3.