File perl-DBD-Pg.spec of Package perl-DBD-Pg

#
# spec file for package perl-DBD-Pg
#
# Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via http://bugs.opensuse.org/
#



Name:           perl-DBD-Pg
%define cpan_name DBD-Pg
Summary:        PostgreSQL database driver for the DBI module
Version:        2.18.1
Release:        1
License:        GPL-1.0+ or Artistic-1.0
Group:          Development/Libraries/Perl
Url:            http://search.cpan.org/dist/DBD-Pg/
Source:         http://www.cpan.org/authors/id/T/TU/TURNSTEP/DBD-Pg-%{version}.tar.gz
BuildRoot:      %{_tmppath}/%{name}-%{version}-build
BuildRequires:  openssl-devel
BuildRequires:  postgresql-devel >= 7.4
BuildRequires:  perl
BuildRequires:  perl-macros
BuildRequires:  perl(Test::More) >= 0.61
#BuildRequires:  perl(Cwd)
BuildRequires:  perl(DBI) >= 1.52
#BuildRequires:  perl(File::Comments)
#BuildRequires:  perl(File::Comments::Plugin::C)
#BuildRequires:  perl(File::Temp)
#BuildRequires:  perl(Module::Signature) >= 0.50
#BuildRequires:  perl(Perl::Critic)
#BuildRequires:  perl(Pod::Spell)
#BuildRequires:  perl(Test::Pod) >= 0.95
#BuildRequires:  perl(Test::Pod::Coverage)
#BuildRequires:  perl(Test::Warn) >= 0.08
#BuildRequires:  perl(Test::YAML::Meta) >= 0.03
#BuildRequires:  perl(Text::SpellChecker)
BuildRequires:  perl(version)
#
#Recommends:     perl(Cwd)
Requires:       perl(DBI) >= 1.52
#Recommends:     perl(File::Comments)
#Recommends:     perl(File::Comments::Plugin::C)
#Recommends:     perl(File::Temp)
#Suggests:       perl(Module::Signature) >= 0.50
#Suggests:       perl(Perl::Critic)
#Suggests:       perl(Pod::Spell)
#Suggests:       perl(Test::Pod) >= 0.95
#Suggests:       perl(Test::Pod::Coverage)
#Suggests:       perl(Test::Warn) >= 0.08
#Suggests:       perl(Test::YAML::Meta) >= 0.03
#Recommends:     perl(Text::SpellChecker)
Requires:       perl(version)
%{perl_requires}

%description
DBD::Pg is a Perl module that works with the DBI module to provide access
to PostgreSQL databases.

%prep
%setup -q -n %{cpan_name}-%{version}

%build
export POSTGRES_INCLUDE=/usr/include/pgsql
export POSTGRES_LIB="%{_libdir} -lssl"
%{__perl} Makefile.PL INSTALLDIRS=vendor OPTIMIZE="%{optflags}"
%{__make} %{?_smp_mflags}

%check
%{__make} test

%install
%perl_make_install
# remove testme.tmp.pl
%{__rm} -f $RPM_BUILD_ROOT%perl_vendorarch/DBD/testme.tmp.pl
%perl_process_packlist
%perl_gen_filelist

%clean
%{__rm} -rf %{buildroot}

%files -f %{name}.files
%defattr(644,root,root,755)
%doc Changes README SIGNATURE TODO testme.tmp.pl

%changelog