File python-gnome-extras.changes of Package python-gnome-extras

-------------------------------------------------------------------
Sun Nov 27 06:46:22 UTC 2011 - coolo@suse.com

- add libtool as buildrequire to avoid implicit dependency

-------------------------------------------------------------------
Tue Jun  7 13:50:53 UTC 2011 - dimstar@opensuse.org

- Drop -gda subpackage. No longer needed, as libgda supports
  gobject-introspection and this is the preferred way to interact
  with it from python now.
- Remove libgda-4_0-devel BuildRequires and the various gda related
  Requires in the -devel package.

-------------------------------------------------------------------
Tue Apr 26 23:52:57 CEST 2011 - vuntz@opensuse.org

- Add build_gdl/build_gtkmozembed defines to decide whether to
  build gdl and gtkmozembed bindings.
- Set build_gdl to 0 as gdl now has introspection support and the
  bindings don't support the latest gdl.
- Set build_gtkmozembed to 0 as mozilla announced they're dropping
  support for gtkmozembed.

-------------------------------------------------------------------
Mon Jan 17 23:43:03 CET 2011 - vuntz@opensuse.org

- Fix python-gda to have a python-gobject2 Requires instead of
  python-gobject, since the renaming to python-gobject hasn't
  happened yet.

-------------------------------------------------------------------
Fri Jan  7 14:08:03 CET 2011 - vuntz@opensuse.org

- Split all python modules in subpackages, so we can have more
  fine-grained dependencies:
  + Create python-egg, python-gdl, python-gtkmozembed,
    python-gtkspell, python-gda subpackages.
  + Move all Requires to the relevant subpackages.
  + Ship a README.openSUSE file explaining the setup of the
    package.
- Move code examples to the devel subpackage.
- Stop removing gksu bindings: they're not installed anymore.
- Add fdupes BuildRequires and use %fdupes.

-------------------------------------------------------------------
Thu Dec  9 10:26:38 CET 2010 - vuntz@opensuse.org

- Build against mozilla-xulrunner20-devel on 11.4 and later.

-------------------------------------------------------------------
Mon Aug  9 00:17:23 CEST 2010 - vuntz@opensuse.org

- Move some files to devel subpackage.

-------------------------------------------------------------------
Sun Aug  8 18:50:45 CEST 2010 - vuntz@opensuse.org

- Only have a python-gobject2-doc BuildRequires on openSUSE 11.3
  and earlier: starting with 11.4, this package is merged in
  python-gobject2-devel.

-------------------------------------------------------------------
Wed Feb 10 15:21:45 CET 2010 - vuntz@opensuse.org

- Drop libgtkhtml-devel BuildRequires: we stop building the
  gtkhtml2 bindings, so we can remove the library from openSUSE.
  Add --disable-gtkhtml2 to configure to make this explicit.
- Add python-gnome-extras-gdl.patch: taken from upstream, to fix
  build of gdl bindings. Also remove --disable-gdl from configure.

-------------------------------------------------------------------
Thu Jan  7 19:46:24 CET 2010 - vuntz@opensuse.org

- Build against mozilla-xulrunner192-devel on openSUSE > 11.2.
- Fix self-obsoletion of python-gnome-extras-doc.

-------------------------------------------------------------------
Thu May 28 16:18:24 CEST 2009 - vuntz@novell.com

- Do not build the gdl bindings: they fail to build with latest
  gdl.

-------------------------------------------------------------------
Wed May  6 15:15:11 CEST 2009 - vuntz@novell.com

- Build against mozilla-xulrunner190 on openSUSE <= 11.1.

-------------------------------------------------------------------
Wed May  6 05:03:10 CEST 2009 - vuntz@novell.com

- Review changes.

-------------------------------------------------------------------
Mon May  4 16:09:38 CEST 2009 - wr@opensuse.org

- Add xulrunner19.patch: make gtkembedmoz work with XULRunner 1.9's
  XPCOM_GLUE (bnc#480992, bgo#532856)
- Build against mozilla-xulrunner191

-------------------------------------------------------------------
Fri Apr  3 11:24:54 CEST 2009 - vuntz@novell.com

- Remove python-numeric Requires: there's no reference to it
  anywhere in the code, so it wasn't needed.

-------------------------------------------------------------------
Wed Feb 18 04:03:52 CET 2009 - mboman@suse.de

- Add back libgnomeui-devel. Was needed for gtk-2.0/egg/recent.so

-------------------------------------------------------------------
Tue Feb 17 11:10:31 CET 2009 - mboman@suse.de

- Update to version 2.25.3:
  + gda: Now requires and builds with the latest libgda (3.99.11)
- Merge -doc into -devel since it only contained gtk-doc
- Remove libbonoboui-devel and libgnomeui-devel from BuildRequires

-------------------------------------------------------------------
Sat Feb 14 04:15:44 CET 2009 - vuntz@novell.com

- Package the files for the gda bindings now that we have a recent
  enough version of libgda.

-------------------------------------------------------------------
Wed Feb  4 15:49:00 CET 2009 - vuntz@novell.com

- Remove BuildRequires on gnome-vfs2-devel and add one on
  gdl-devel.
- Add --enable-docs to configure and add BuildRequires on
  python-gobject2-doc to haveit work.
- We don't have the gda bindings in this release, but we should
  make sure they come back when we have a newer libgda.

-------------------------------------------------------------------
Wed Feb  4 15:13:48 CET 2009 - vuntz@novell.com

- Update to version 2.25.2:
  + gda: Now requires and builds with the latest libgda (3.99.9)
- Changes from version 2.25.1:
  + gda:
    - pygda-3.0 is now replaced by pygda-4.0, wrapping libgda-4.0 instead of 
      libgda-3.0, with various API changes.
    - On windows, install gda.pyd instead of gda.dll, as expected by Python on 
      Windows, along with some other Windows fixes.
  + Fixed the gdl build.
  + gtkmozembed:
    - Fix the build with XUL 1.9.
    - Wrap gtk_moz_embed_set_path(). bgo#400861, bgo#503067
  + Build:
    - Allow the build and install of some modules to be disabled to make 
      life easier for distro packagers. bgo#534307
    - Allow documentation building to be disabled.
    - Use python-config to get python includes. bgo#448182.

-------------------------------------------------------------------
Thu Jan 29 02:33:51 CET 2009 - vuntz@novell.com

- BuildRequires libgda-4_0-devel.

-------------------------------------------------------------------
Thu Nov  6 11:50:27 CST 2008 - maw@suse.de

- Split out a -devel subpackage to reduce the main package's
  requirements.

-------------------------------------------------------------------
Wed Nov  5 15:22:23 CST 2008 - maw@suse.de

- Require libgda-3_0-devel
- Don't run autoreconf.

-------------------------------------------------------------------
Wed Jul 23 14:34:22 CEST 2008 - coolo@suse.de

- build against xulrunner190

-------------------------------------------------------------------
Tue Oct 16 18:49:05 CEST 2007 - sbrabec@suse.cz

- Reduced BuildRequires.

-------------------------------------------------------------------
Fri Oct 12 16:30:29 CEST 2007 - sbrabec@suse.cz

- Updated to version 2.19.1:
  * egg.trayicon: By popular demand, undeprecate this, at least
    until Gtk+ adds all the functionality to GtkStatusIcon; apply
    upstream patch to enable transparent icons
  * gda: Now use libgda-3.0 instead of libgda-1.2. This breaks API;
    make it explicit that the license is LGPL
  * gksu2: New module, Various fixes; build gksu conditionally,
    like it was supposed to all along
  * gtkhtml2: Check for errors in html_document_open_stream; fix
    the example
  * gdl: Support the gdl 0.7.x API, in addtion to 0.6.x

-------------------------------------------------------------------
Wed Mar  7 01:26:31 CET 2007 - jhargadon@suse.de

- added more verbose statements in the %files section of the 
  specfile to resolve bug #224800 

-------------------------------------------------------------------
Tue Feb  6 23:12:02 CET 2007 - jhargadon@suse.de

- added back a line in the specfile to remove gksu module that was
  accidentally removed in the last update. 

-------------------------------------------------------------------
Thu Feb  1 16:59:21 CET 2007 - sbrabec@suse.cz

- Removed remaining references to /opt/gnome.
- Build python-gnome-extras-doc as a separate package.

-------------------------------------------------------------------
Mon Dec  4 18:49:20 CET 2006 - jhargadon@suse.de

- added mozilla-xulrunner to BuildRequires to enable gtkmozembed
  (#224800)
- removed unused BuildRequires 
- removed gksu module (#225388)
-------------------------------------------------------------------
Thu Aug 17 11:50:57 CEST 2006 - cthiel@suse.de

- fix build

-------------------------------------------------------------------
Wed Aug 16 12:38:00 CEST 2006 - cthiel@suse.de

- update to version 2.14.2
  * Correct gnome-python defsdir detection, fixes build breakage
- Overview of Changes from 2.14.0 to 2.14.1
  * Mac OS X build fixes
  * Allow building gtkmozembed against xulrunner
- Overview of Changes from 2.13.3 to 2.14.0
  * Fixed some crashes due to missing parameter type checking
- Overview of Changes from 2.13.2 to 2.13.3
  * The following modules moved to the package gnome-python-desktop:
    - gnomeapplet
    - gnomeprint, gnomeprint.ui
    - gtksourceview
    - wnck
    - totem.plparser
    - gtop
    - nautilusburn
    - mediaprofiles
  * Correct a typo in pygda-1.2.pc
- Overview of Changes from 2.13.1 to 2.13.2
  * Wrap panel_applet_set_background_widget
  * Revert back to wrapping pygda 1.2 due to API instability of 2.0
  * Add new metacity bindings
  * Update eggrecent code from CVS
- Overview of Changes from 2.13.0 to 2.13.1
  * Register missing wnck constants
- Overview of Changes from 2.12.1 to 2.13.0
  * Require libgda 2.0 instead of 1.2
  * Wrap panel_applet_get_background
  * Wrap egg_recent_model_get_list
  * Wrap wnck_tasklist_get_size_hint_list
  * Double-free fixes

-------------------------------------------------------------------
Mon Feb 20 16:14:14 CET 2006 - ro@suse.de

- added libstdc++-devel to BuildRequires 

-------------------------------------------------------------------
Wed Jan 25 21:40:48 CET 2006 - mls@suse.de

- converted neededforbuild to BuildRequires

-------------------------------------------------------------------
Thu Dec  1 21:14:49 CET 2005 - gekker@suse.de

- Update to version 2.12.1

-------------------------------------------------------------------
Mon Oct 24 01:48:05 CEST 2005 - ro@suse.de

- added hal/hal-devel to nfb 

-------------------------------------------------------------------
Fri Oct 14 19:01:28 CEST 2005 - ro@suse.de

- removed libzvt from neededforbuild (unused) 

-------------------------------------------------------------------
Wed Aug  3 01:32:52 CEST 2005 - gekker@suse.de

- Update to version 2.11.3 
- Enable more modules

-------------------------------------------------------------------
Mon Jun 13 23:02:58 CEST 2005 - gekker@suse.de

- Initial import, version 2.10.2