File ruby19.changes of Package ruby19

-------------------------------------------------------------------
Mon Jun  4 11:03:08 UTC 2012 - idonmez@suse.com

- Add patch to export ruby_init_prelude, ruby bug #5174

-------------------------------------------------------------------
Fri May 11 10:03:11 UTC 2012 - coolo@suse.com

- there is no obvious use for the vim buildrequires and it's causing
  a build cycle (because vim really requires ruby) - so remove it

-------------------------------------------------------------------
Fri May 11 05:02:13 UTC 2012 - coolo@suse.com

- rubygem-rake is still named like this

-------------------------------------------------------------------
Thu May 10 18:35:48 UTC 2012 - coolo@suse.com

- update to 1.9.3 p194
   - update rubygems to 1.8.23 to verify ssl certificates
   - other bug fixes

-------------------------------------------------------------------
Tue May  8 11:37:06 UTC 2012 - coolo@suse.com

- readd the requires on ruby-common to fix gems suffix

-------------------------------------------------------------------
Sun Mar 11 18:21:23 UTC 2012 - coolo@suse.com

- let gems of 1.9 install bins without suffix

-------------------------------------------------------------------
Fri Mar  9 07:20:21 UTC 2012 - coolo@suse.com

- remove provides for ruby and ruby-devel, only generates conflicts
  with wrapper package

-------------------------------------------------------------------
Wed Mar  7 15:45:53 UTC 2012 - mrueckert@suse.de

- update license:
  Ruby is licensed under BSD 2 Clause or Ruby License now.

-------------------------------------------------------------------
Wed Mar  7 15:09:46 UTC 2012 - coolo@suse.com

- update to 1.9.3 p125
 - Fix for Ruby OpenSSL module: Allow "0/n splitting" as a 
   prevention for the TLS BEAST attack
 - Fixed: LLVM/clang support [Bug #5076]
 - Fixed: GCC 4.7 support [Bug #5851]
 - other bug fixes

-------------------------------------------------------------------
Mon Oct 31 16:27:48 UTC 2011 - mrueckert@suse.de

- update to 1.9.3 preview 0

-------------------------------------------------------------------
Mon Jul 18 15:36:36 UTC 2011 - mrueckert@suse.de

- override rb_arch macro from the rpm in the spec file
  rb_arch in rpm is still using host_cpu instead of target_cpu. for
  older distros we will need the override anyway. this allows us to
  reduce the sed part in the marco  to just ppc/powerpc.
- related to the first change:
  pass --target={_target_platform} to configure (we used to do that
  on 1.8 already)
- provide unversioned package names
- rip out bleakhouse support for now to make merging easier
- install macros file
- reorder some file list lines to make merging easier
- use a ruby variable instead of calculating rb_ver in the macros
  file. (more important for 1.8)

-------------------------------------------------------------------
Mon Jul 18 13:11:48 UTC 2011 - mrueckert@suse.de

- update 1.9.2 p290
  some important fixes:
  - require 'date'; Date.new === nil throws an undefined method
    error for coerce on p180 - this has now been fixed
  - The Thread.kill segfaults when the object to be killed isn't a
    thread bug has been resolved.
  - Tweaks to reduce segmentation faults when using zlib on x86-64
    Darwin (OS X) - always good
  - Modification to prevent random number sequence repetition on
    forked child processes in SecureRandom
  - Fix to io system to resolve a Windows-only bug where characters
    are being read incorrectly due to ASCII not being treated as 7
    bit
  - A tweak to Psych (the YAML parser) to plug a memory leak
  - Load paths are now always expanded by rb_et_expanded_load_path
    (I think this might yield a performance gain?)
  - Fixes to Psych's treatment and testing of string taint
  - Prevention of temporary objects being garbage collected in some
    cases
  - Fixes to resolve compilation problems with Visual C++ 2010
  - A fix so that Tk's extconf.rb would run successfully
  - Lots of Tk related fixes generally
  - A fix to string parsing to resolve an obscure
    symbol-containing-newlines parsing bug

  for the complete changes see /usr/share/doc/packages/ruby19/ChangeLog
- refresh tcl rpath patch:
  old ruby-1.9.2p180_tcl_no_stupid_rpaths.patch
  new ruby-1.9.2p290_tcl_no_stupid_rpaths.patch

-------------------------------------------------------------------
Fri May  6 22:13:15 UTC 2011 - mrueckert@suse.de

- sync with d:l:r:1.9/ruby19

-------------------------------------------------------------------
Fri May  6 21:56:34 UTC 2011 - mrueckert@suse.de

- update 1.9.2 p180
- added ruby-1.9.2p180_tcl_no_stupid_rpaths.patch
  - remove the other path entries that are unneeded on our system
- dropped ruby-1.9.1-rc2_gc_64bit_warning.patch

-------------------------------------------------------------------
Thu Aug 26 21:51:51 UTC 2010 - mrueckert@suse.de

- build fiddle -> new dep libffi

-------------------------------------------------------------------
Thu Aug 26 19:48:29 UTC 2010 - mrueckert@suse.de

- update to 1.9.2 p0

-------------------------------------------------------------------
Wed Apr  7 14:28:48 UTC 2010 - mrueckert@suse.de

- split out tk bindings

-------------------------------------------------------------------
Wed Apr  7 14:08:47 UTC 2010 - mrueckert@suse.de

- fixed tk support, though it still has a warning about missing
  nativethread support in tcl/tk

-------------------------------------------------------------------
Wed Apr  7 10:26:00 UTC 2010 - mrueckert@suse.de

- update to snapshot of today

-------------------------------------------------------------------
Mon Feb  2 15:48:27 CET 2009 - mrueckert@suse.de

- update to p0
- drop ruby-1.9.1-rc2_rb_time_timeval_prototype.patch:
  fix included

-------------------------------------------------------------------
Wed Jan 21 19:00:13 CET 2009 - mrueckert@suse.de

- add ruby-1.9.1-rc2_gc_64bit_warning.patch
  do not cast a pointer to int
- add ruby-1.9.1-rc2_rb_time_timeval_prototype.patch
  copy the complete prototype for the function

-------------------------------------------------------------------
Wed Jan 21 14:06:04 CET 2009 - mrueckert@suse.de

- update to rc2
- remove ruby-1.9.1-preview2_mkconfig_continued_line.patch:
  included in update

-------------------------------------------------------------------
Mon Dec  8 13:52:11 CET 2008 - mrueckert@suse.de

- added ruby-1.9.1-preview2_mkconfig_continued_line.patch:
  handle continued lines with empty values

-------------------------------------------------------------------
Sat Dec  6 04:13:34 CET 2008 - mrueckert@suse.de

- initial package