File rubygem-rpam.spec of Package rubygem-rpam

#
# spec file for package rubygem-rpam (Version 1.0.1)
#
# Copyright (c) 2009 SUSE LINUX Products GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via http://bugs.opensuse.org/
#

# norootforbuild
Name:           rubygem-rpam
Version:        1.0.1
Release:        0
%define mod_name rpam
#
Group:          Development/Languages/Ruby
License:        GPL-2.0
#
BuildRoot:      %{_tmppath}/%{name}-%{version}-build
BuildRequires:  rubygems_with_buildroot_patch
%rubygems_requires

Requires:       ruby >= 1.8.2
BuildRequires:  ruby-devel >= 1.8.2
BuildRequires:  pam-devel
#
Url:            http://rubyforge.org/projects/rpam
Source0:        %{mod_name}-%{version}.gem
Source1:        rpam.pam
#
Summary:        PAM integration with ruby
%description
This extension provides PAM  - Pluggable Authentication Modules - integration

%prep
%build
%install
%gem_install %{S:0}
%gem_cleanup

%{__mkdir_p} %{buildroot}/etc/pam.d
%{__install} -c -m 0644 %{SOURCE1} %{buildroot}/etc/pam.d/rpam


%clean
%{__rm} -rf %{buildroot}

%files
%defattr(-,root,root,-)
%{_libdir}/ruby/gems/%{rb_ver}/cache/%{mod_name}-%{version}.gem
%{_libdir}/ruby/gems/%{rb_ver}/gems/%{mod_name}-%{version}/
%{_libdir}/ruby/gems/%{rb_ver}/specifications/%{mod_name}-%{version}.gemspec
%doc %{_libdir}/ruby/gems/%{rb_ver}/doc/%{mod_name}-%{version}/
/etc/pam.d/rpam

%changelog