File scummvm.spec of Package scummvm

#
# spec file for package scummvm
#
# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via http://bugs.opensuse.org/
#


%bcond_with aac
%bcond_with mp3
%bcond_without distributable

Name:           scummvm
Version:        1.4.1
Release:        0
Summary:        Interpreter for several adventure games
License:        GPLv2+, LGPLv2.1+, BSD
Group:          Amusements/Games/Other
Url:            http://www.scummvm.org/
# Waiting for sf#3527268 to be fixed
%if %{with distributable}
Source0:        scummvm-%{version}-crippled.tar.bz2
%else
Source0:        http://downloads.sourceforge.net/project/scummvm/scummvm/%{version}/scummvm-%{version}.tar.bz2
%endif
Source1:        precheckin_cripple_tarball.sh
Patch0:         scummvm-nostrip.patch
# It's an ugly workaround but makes the sword25 engine plugin link against
# png/theora, and since we use --as-needed there are no real problems. Once the
# engine passes to the main binary the problem will dissapear.
# It could also be good to make it use the system's Lua.
Patch1:         scummvm-underlinking.patch
BuildRequires:  desktop-file-utils
BuildRequires:  gcc-c++
BuildRequires:  hicolor-icon-theme
BuildRequires:  pkgconfig(alsa) >= 0.9
BuildRequires:  pkgconfig(flac) >= 1.0.1
BuildRequires:  pkgconfig(fluidsynth)
BuildRequires:  pkgconfig(libpng) >= 1.2.8
BuildRequires:  pkgconfig(sdl) >= 1.2.2
BuildRequires:  pkgconfig(theoradec) >= 1.0
BuildRequires:  pkgconfig(vorbisfile)
BuildRequires:  pkgconfig(zlib)
%if %{with aac}
BuildRequires:  libfaad-devel
%endif
%if %{with mp3}
BuildRequires:  pkgconfig(mad)
%endif
%ifarch %{ix86}
BuildRequires:  nasm
%endif
Suggests:       %{name}-extra
Suggests:       %{name}-tools

%description
ScummVM is an interpreter that will play graphic adventure games written for
LucasArts' SCUMM virtual machine (such as Day of the Tentacle and
Monkey Island), Sierra's AGI adventures (such as early King's Quest and
Space Quest games), Adventure Soft's Simon the Sorcerer 1, 2 and Feeble Files,
Revolution Software's Beneath a Steel Sky and Broken Sword 1 and 2,
Interactive Binary Illusions' Flight of the Amazon Queen,
Coktel Vision's Gobliiins, Wyrmkeep's Inherit the Earth, Westwood's
Legend of Kyrandia, and various others.

%package extra
Summary:        Extra engines for ScummVM
Group:          Amusements/Games/Other
Requires:       %{name} = %{version}

%description extra
M4, mohawk and hugo engines for ScummVM.
These engines are in a worse state, but allow to play extra games.

%prep
%setup -q
%patch0
%patch1
FAKE_BUILDDATE=$(LC_ALL=C date -u -r %{_sourcedir}/%{name}.changes '+%%b %%e %%Y')
sed -i "s/__DATE__/\"$FAKE_BUILDDATE\"/" base/version.cpp backends/plugins/elf/version.cpp
FAKE_BUILDTIME=$(LC_ALL=C date -u -r %{_sourcedir}/%{name}.changes '+%%H:%%M:%%S')
sed -i "s/__TIME__/\"$FAKE_BUILDTIME\"/" base/version.cpp backends/plugins/elf/version.cpp

%build
# No rpm configure because scummvm's configure isn't a real configure and thus
# doesn't understand some of the options %%configure passes.
CXXFLAGS="%{optflags}" ; export CXXFLAGS ; \
./configure --prefix=%{_prefix} \
            --bindir=%{_bindir} \
            --datarootdir=%{_datadir} \
            --mandir=%{_mandir} \
            --libdir=%{_libdir} \
            --enable-verbose-build \
            --enable-plugins \
            --enable-engine-dynamic=cge \
            --enable-engine-dynamic=composer \
            --enable-engine-dynamic=dreamweb \
            --enable-engine-dynamic=lastexpress \
            --enable-engine-dynamic=m4 \
            --enable-engine-dynamic=sword25
# --docdir=%%{_docdir}/%%{name}
# Subengines are not included even as dynamic since I don't want to touch the main engines
make %{?_smp_mflags}

%install
# docdir is here because since 1.2.0 configure is broken
%make_install docdir=%{_docdir}/%{name}
# Since desktop-file-utils 0.19 (openSUSE 12.2) it automatically searches for %{buildroot}
desktop-file-install --dir=%{buildroot}%{_datadir}/applications/ dists/scummvm.desktop

%post
%icon_theme_cache_post

%postun
%icon_theme_cache_postun

%files
%defattr(0644,root,root,0755)
%attr(0755,-,-) %{_bindir}/scummvm
%{_datadir}/scummvm
%{_mandir}/man6/scummvm.6*
%{_datadir}/applications/scummvm.desktop
%{_datadir}/icons/hicolor/*/*/*
%{_docdir}/%{name}

%files extra
%defattr(0644,root,root,0755)
%{_libdir}/scummvm

%changelog