File yast2-all-packages.spec of Package yast2-all-packages

#
# spec file for package yast2-all-packages
#
# Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via http://bugs.opensuse.org/
#



Name:           yast2-all-packages
Version:        1.0
Release:        158
License:        GPL-2.0+
Summary:        Internal Package
Group:          Metapackages
Source0:        COPYING
Requires:       autoyast2
Requires:       autoyast2-installation
Requires:       yast2
Requires:       yast2-add-on
Requires:       yast2-add-on-creator
Requires:       yast2-all-packages
Requires:       yast2-apparmor
Requires:       yast2-audit-laf
Requires:       yast2-autofs
Requires:       yast2-backup
Requires:       yast2-bootloader
Requires:       yast2-branding-openSUSE
Requires:       yast2-ca-management
Requires:       yast2-control-center
Requires:       yast2-control-center-gnome
Requires:       yast2-control-center-qt
Requires:       yast2-core
Requires:       yast2-core-devel
Requires:       yast2-country
Requires:       yast2-country-data
Requires:       yast2-devel-doc
Requires:       yast2-devtools
Requires:       yast2-dhcp-server
Requires:       yast2-dirinstall
Requires:       yast2-dns-server
Requires:       yast2-drbd
Requires:       yast2-fingerprint-reader
Requires:       yast2-firewall
Requires:       yast2-firstboot
Requires:       yast2-ftp-server
Requires:       yast2-gtk
Requires:       yast2-hardware-detection
Requires:       yast2-http-server
Requires:       yast2-inetd
Requires:       yast2-inetd-doc
Requires:       yast2-installation
Requires:       yast2-installation-devel-doc
Requires:       yast2-instserver
Requires:       yast2-irda
Requires:       yast2-iscsi-client
Requires:       yast2-iscsi-server
Requires:       yast2-isns
Requires:       yast2-kdump
Requires:       yast2-kerberos-client
Requires:       yast2-kerberos-server
Requires:       yast2-ldap
Requires:       yast2-ldap-client
Requires:       yast2-ldap-server
Requires:       yast2-libyui
Requires:       yast2-libyui-devel
Requires:       yast2-live-installer
Requires:       yast2-mail
Requires:       yast2-mail-plugins
Requires:       yast2-metapackage-handler
Requires:       yast2-mouse
Requires:       yast2-multipath
Requires:       yast2-ncurses
Requires:       yast2-ncurses-devel
Requires:       yast2-ncurses-pkg
Requires:       yast2-network
Requires:       yast2-network-devel-doc
Requires:       yast2-nfs-client
Requires:       yast2-nfs-common
Requires:       yast2-nfs-server
Requires:       yast2-nis-client
Requires:       yast2-nis-server
Requires:       yast2-nis-server-devel-doc
Requires:       yast2-ntp-client
Requires:       yast2-online-update
Requires:       yast2-online-update-frontend
Requires:       yast2-packager
Requires:       yast2-pam
Requires:       yast2-perl-bindings
Requires:       yast2-phone-services
Requires:       yast2-pkg-bindings
Requires:       yast2-pkg-bindings-devel-doc
Requires:       yast2-power-management
Requires:       yast2-printer
Requires:       yast2-printer-devel-doc
Requires:       yast2-product-creator
Requires:       yast2-python-bindings
Requires:       yast2-qt
Requires:       yast2-qt-devel
Requires:       yast2-qt-pkg
Requires:       yast2-reipl
Requires:       yast2-restore
Requires:       yast2-ruby-bindings
Requires:       yast2-runlevel
Requires:       yast2-samba-client
Requires:       yast2-samba-server
Requires:       yast2-scanner
Requires:       yast2-security
Requires:       yast2-slide-show-SLED
Requires:       yast2-slide-show-SLES
Requires:       yast2-slp
Requires:       yast2-slp-server
Requires:       yast2-squid
Requires:       yast2-sshd
Requires:       yast2-storage
Requires:       yast2-storage-devel
Requires:       yast2-storage-lib
Requires:       yast2-sudo
Requires:       yast2-support
Requires:       yast2-sysconfig
Requires:       yast2-testsuite
Requires:       yast2-tftp-server
Requires:       yast2-theme-SLE
Requires:       yast2-theme-openSUSE
Requires:       yast2-theme-openSUSE-Crystal
Requires:       yast2-theme-openSUSE-Oxygen
Requires:       yast2-trans-af
Requires:       yast2-trans-allpacks
Requires:       yast2-trans-am
Requires:       yast2-trans-ar
Requires:       yast2-trans-be
Requires:       yast2-trans-bg
Requires:       yast2-trans-bn
Requires:       yast2-trans-bs
Requires:       yast2-trans-ca
Requires:       yast2-trans-cs
Requires:       yast2-trans-cy
Requires:       yast2-trans-da
Requires:       yast2-trans-de
Requires:       yast2-trans-el
Requires:       yast2-trans-en_GB
Requires:       yast2-trans-en_US
Requires:       yast2-trans-es
Requires:       yast2-trans-et
Requires:       yast2-trans-fa
Requires:       yast2-trans-fi
Requires:       yast2-trans-fr
Requires:       yast2-trans-gl
Requires:       yast2-trans-gu
Requires:       yast2-trans-he
Requires:       yast2-trans-hi
Requires:       yast2-trans-hr
Requires:       yast2-trans-hu
Requires:       yast2-trans-id
Requires:       yast2-trans-it
Requires:       yast2-trans-ja
Requires:       yast2-trans-jv
Requires:       yast2-trans-ka
Requires:       yast2-trans-km
Requires:       yast2-trans-ko
Requires:       yast2-trans-lo
Requires:       yast2-trans-lt
Requires:       yast2-trans-mk
Requires:       yast2-trans-mr
Requires:       yast2-trans-ms
Requires:       yast2-trans-my
Requires:       yast2-trans-nb
Requires:       yast2-trans-nl
Requires:       yast2-trans-pa
Requires:       yast2-trans-pl
Requires:       yast2-trans-pot
Requires:       yast2-trans-pt
Requires:       yast2-trans-pt_BR
Requires:       yast2-trans-ro
Requires:       yast2-trans-ru
Requires:       yast2-trans-si
Requires:       yast2-trans-sk
Requires:       yast2-trans-sl
Requires:       yast2-trans-sr
Requires:       yast2-trans-stats
Requires:       yast2-trans-sv
Requires:       yast2-trans-ta
Requires:       yast2-trans-th
Requires:       yast2-trans-tk
Requires:       yast2-trans-tr
Requires:       yast2-trans-uk
Requires:       yast2-trans-vi
Requires:       yast2-trans-wa
Requires:       yast2-trans-xh
Requires:       yast2-trans-zh_CN
Requires:       yast2-trans-zh_TW
Requires:       yast2-trans-zu
Requires:       yast2-transfer
Requires:       yast2-tune
Requires:       yast2-update
Requires:       yast2-update-FACTORY
Requires:       yast2-users
Requires:       yast2-xml
Requires:       yast2-ycp-ui-bindings
Requires:       yast2-ycp-ui-bindings-devel
BuildRoot:      %{_tmppath}/%{name}-%{version}-build
Prefix:         /usr
%ifarch %ix86 x86_64
Requires:       yast2-vm
%endif
%ifnarch s390 s390x
Requires:       yast2-sound
Requires:       yast2-tv
%endif
%ifarch s390 s390x
Requires:       yast2-s390
%endif

%description
Internal package.

%prep
%setup -c -T

%install
mkdir -p %{buildroot}
echo 'Internal only' > README
mkdir -p %{buildroot}%{prefix}/share/doc/packages/yast2-all-packages
cp $RPM_SOURCE_DIR/COPYING %{buildroot}%{prefix}/share/doc/packages/yast2-all-packages

%files
%defattr(-,root,root)
%doc %{prefix}/share/doc/packages/yast2-all-packages/

%changelog